コンソールおよび API での Elastic Compute Service (ECS) インスタンス正常性診断の診断項目、メトリック、範囲、および推奨される操作を確認します。
ECS コンソールでの診断タイプ
インスタンス正常性診断は、次の診断タイプをサポートしています。
-
コンピューティングサービスの正常性診断:ECS の基盤となるリソースと仮想化レイヤーをチェックします。
-
ネットワークサービスの正常性診断:ネットワークコンポーネントの状態と外部ネットワーク環境の例外をチェックします。
-
ストレージサービスの正常性診断:ディスクの例外をチェックします。
-
インスタンス構成管理の正常性診断:操作によってインスタンスの起動または実行が妨げられていないかチェックします。
-
セキュリティコントロールの正常性診断:セキュリティグループで共通ポートへのインバウンドトラフィックが許可されているかチェックします。
-
課金の正常性診断:インスタンスおよび EIP などの関連コンポーネントの支払い遅延をチェックします。
-
リソースクォータの正常性診断:重要なリソースクォータの使用量が上限に近づいているかどうかをチェックします。
-
インスタンスの Linux オペレーティングシステムの構成診断:システムファイル、主要なプロセス、共通ポート、およびファイアウォールの状態をチェックします。
-
インスタンスの Windows オペレーティングシステムの構成診断:共通ポートとファイアウォールの状態をチェックします。
-
コンピューティング、ネットワーク、ストレージ、および構成管理の診断における例外はリアルタイムではありません。診断結果には過去 12 時間の例外が含まれており、即時の対応を必要としない場合があります。
-
セキュリティコントロール、課金、リソースクォータ、および OS 構成の診断における例外はリアルタイムです。これらの例外は速やかに修正してください。
コンピューティングサービスの正常性に関する診断項目
|
ECS コンソールでの診断項目 |
説明 |
診断範囲と推奨される操作 |
|
リソース不足 |
CPU またはメモリリソースの不足により、インスタンスを起動できません。 |
物理的な CPU またはメモリリソースが十分であるか確認します。 再割り当て中 (たとえば、節約モードで停止したインスタンスの起動) にリソースが不足している場合、インスタンスは起動できません。待ってから再試行するか、別のゾーンまたはリージョンでインスタンスを作成してください。 |
|
インスタンスオペレーティングシステムの例外 |
インスタンスの OS でカーネルパニック、OOM 例外、または内部ダウンタイムが発生します。 |
インスタンス OS でカーネルパニック、OOM、または内部ダウンタイムのエラーがないか確認します。 これらのエラーは、不適切なインスタンス構成またはユーザープログラムが原因である可能性があります。インスタンスを再起動して回復してください。 |
|
インスタンス仮想化の例外 |
インスタンスが応答しないか、実行中に予期せず停止します。 |
基盤となる仮想化レイヤーのコアサービスに例外がないか確認します。 例外により、インスタンスが応答しなくなったり、予期せず停止したりする可能性があります。インスタンスを再起動して回復してください。 |
|
インスタンスホストのアラート |
インスタンスをホストする物理デバイスでアラートがトリガーされます。 |
インスタンスをホストしている基盤となる物理サーバーにエラーがないか確認します。 物理サーバーのエラーは、インスタンスの状態やパフォーマンスに影響を与える可能性があります。インスタンスを再起動して回復してください。 |
|
インスタンスパフォーマンスの制限 |
バースト可能インスタンスが標準モードです。 |
バースト可能インスタンスに高性能を維持するための十分な CPU クレジットがあるか確認します。 CPU クレジットが不足していると、パフォーマンスのバースト機能が妨げられ、ピーク時間帯にはインスタンスがベースラインパフォーマンスに制限されます。 |
|
インスタンス CPU の例外 |
インスタンスが CPU を競合しているか、CPU を専用型インスタンスにバインドできないために例外が発生しました。 |
共有インスタンスが基盤レイヤーで CPU を競合しているか確認します。 基盤レイヤーでの CPU 競合により、専用型インスタンスが CPU を取得できなくなる可能性があります。インスタンスを再起動して回復してください。 |
|
インスタンス管理システムの例外 |
インスタンスのバックエンド管理システムで例外が発生しました。 |
バックエンド管理システムが期待どおりに動作しているか確認します。 管理システムの問題により、インスタンスの例外が発生する可能性があります。インスタンスを再起動して回復してください。 |
|
インスタンスパフォーマンスの一時的な低下 |
基盤となるソフトウェアまたはハードウェアの問題により、インスタンスのパフォーマンスが一時的に低下しているかどうかを確認します。 |
基盤となるソフトウェアまたはハードウェアの問題により、インスタンスのパフォーマンスが一時的に低下しているかどうかを確認します。 低下している場合、低下時間が表示されます。過去のイベントまたはシステムログを表示して原因を特定します。詳細については、「過去のシステムイベントの表示」および「インスタンスのシステムログとスクリーンショットの表示」をご参照ください。 |
ネットワークサービスの正常性に関する診断項目
|
ECS コンソールでの診断項目 |
説明 |
診断範囲と推奨される操作 |
|
インスタンスネットワークリンクでのパケット損失 |
物理デバイスまたはインスタンスのネットワークサービスでパケットが失われます。 |
インスタンスのネットワークリンクでパケット損失がないか確認します。 パケット損失はネットワーク接続またはスループットに影響を与え、接続の失敗やアクセスの遅延を引き起こします。インスタンスを再起動して回復してください。 |
|
ネットワーク構成の不整合 |
インスタンスのネットワーク構成が基盤となるサービスの構成と一致していません。 |
インスタンスのネットワーク構成が基盤となるサービスの構成と一致しているか確認します。 不整合はネットワークパフォーマンスに影響します。インスタンスを再起動して回復してください。 |
|
インスタンスリンクレイヤーの例外 |
NIC のリンクレイヤーで例外が発生しました。 |
NIC に ARP リクエストを送信して、基本的なネットワーク構成が正常かどうかを確認します。 リクエストが失敗した場合、インスタンスが正常に起動していないか、ネットワーク構成が異常であることを示します。インスタンスを再起動して回復してください。 |
|
NIC のロード例外 |
NIC のロード中に例外が発生しました。 |
NIC がロードできるか確認します。 ロードできない NIC はネットワーク接続に影響します。インスタンスを再起動して回復してください。 |
|
NIC でのパケット損失 |
NIC でインバウンドまたはアウトバウンドのパケット損失が発生しました。 |
NIC でインバウンドまたはアウトバウンドのパケット損失がないか確認します。パケット損失は接続性またはスループットに影響を与え、接続の失敗や速度の低下を引き起こします。インスタンスを再起動して回復してください。 |
|
ネットワーク接続の例外 |
NIC 接続を確立できないか、最大接続数に達しました。 |
NIC で接続を確立できるか確認します。 接続を確立できない場合や最大数に達した場合、ネットワーク接続またはスループットが影響を受けます。インスタンスを再起動して回復してください。 |
|
異常な DDoS 対策状態 |
DDoS 対策の状態と、パブリック IP アドレスが DDoS 攻撃を受けているかどうかを確認します。 |
パブリック IP アドレスが DDoS 攻撃を受けているか確認します。 Alibaba Cloud は無料の Anti-DDoS Origin を提供して、悪意のあるトラフィックをスクラビングします。攻撃トラフィックが保護能力を超えると、インスタンスは利用できなくなります。詳細については、「DDoS 攻撃とは?」をご参照ください。 より強力な保護のために、追加の Anti-DDoS サービスを購入してください。詳細については、「Anti-DDoS プロダクトの選択方法」をご参照ください。 DDoS 緩和のベストプラクティスについては、「DDoS 攻撃緩和ソリューション」をご参照ください。 |
|
バースト帯域幅の制限 |
バースト帯域幅が制限されているか確認します。 |
インスタンスのバースト帯域幅を確認します。 バースト帯域幅がインスタンスタイプの制限を超えると、ネットワークパフォーマンスがボトルネックになります。より高い帯域幅を持つインスタンスタイプにスペックアップしてください。詳細については、「インスタンスタイプの変更」をご参照ください。 説明
さまざまなインスタンスタイプのバースト帯域幅能力については、「インスタンスファミリーの概要」をご参照ください。 |
|
ネットワークトラフィックのスロットリング |
内部およびパブリック帯域幅の合計がインスタンスタイプの最大値に達しているか確認します。 |
内部およびパブリック帯域幅の合計を確認します。 合計帯域幅がインスタンスタイプの最大ベースラインを超えると、ネットワークパフォーマンスがボトルネックになります。より高い帯域幅を持つインスタンスタイプにスペックアップしてください。詳細については、「インスタンスタイプの変更」をご参照ください。 説明
さまざまなインスタンスタイプのベースラインネットワーク帯域幅については、「インスタンスファミリーの概要」をご参照ください。 |
ストレージサービスの正常性に関する診断項目
|
ECS コンソールでの診断項目 |
説明 |
診断範囲と推奨される操作 |
|
効果のないディスクのサイズ変更操作 |
ECS コンソールでディスクのサイズを変更した後、さらなる操作が必要かどうかを確認します。 |
ECS コンソールでディスクのサイズを変更した後、ディスクが実際にサイズ変更されたか確認します。そうでない場合は、コマンドを実行してパーティションとファイルシステムを拡張します。詳細については、「ステップ 1:ディスク容量を拡張するためのディスクのサイズ変更」をご参照ください。 |
|
ディスク I/O ハング |
ディスクで I/O ハングが発生しています。ディスクからのデータの読み取りまたは書き込みができません。 |
システムディスクで I/O ハングがないか確認します。高い読み取り/書き込み I/O レイテンシは、インスタンスの不安定さや機能停止を引き起こす可能性があります。 ディスクで I/O ハングが発生した場合、そのパフォーマンスメトリクスを確認します。詳細については、「ディスクのモニタリング情報の表示」をご参照ください。Alibaba Cloud Linux 2 での I/O ハング検出については、「ファイルシステムとブロックレイヤーの I/O ハングの検出」をご参照ください。 |
|
ディスクのロード例外 |
ディスクの作成またはアタッチ中に例外が発生しました。 |
インスタンスの起動中にディスクをアタッチできるか確認します。 ディスクをアタッチできない場合、インスタンスの起動に失敗する可能性があります。インスタンスを停止して再起動するか、ディスクを再アタッチしてください。詳細については、「データディスクのアタッチ」をご参照ください。 |
|
ディスクの読み取り/書き込み制限 |
ディスクの I/O レイテンシが高いか、ディスクの IOPS が上限に達しています。 |
システムディスクの I/O レイテンシが高いか、最大 IOPS に達しているか確認します。 ディスクが最大 IOPS に達すると、読み取り/書き込み操作が制限されます。詳細については、「ディスクのモニタリング情報の表示」をご参照ください。ディスクの I/O 頻度を減らすか、より高いパフォーマンスを得るためにディスクカテゴリをスペックアップしてください。詳細については、「ブロックストレージのパフォーマンス」をご参照ください。 |
|
ディスクサイズ変更の例外 |
ディスクのサイズを変更した後、OS がファイルシステムのサイズを調整できません。 |
システムディスクのサイズを変更した後、ファイルシステムのサイズも変更されたか確認します。 サイズ変更されていない場合、ディスクは使用できません。再度サイズ変更してください。オペレーティングシステムごとの制限と手順については、「概要」をご参照ください。 |
インスタンス構成管理の正常性に関する診断項目
|
ECS コンソールでの診断項目 |
説明 |
診断範囲と推奨される操作 |
|
インスタンス起動の例外 |
管理システムによってインスタンスを起動できません。 |
インスタンスで起動操作を実行できるか確認します。 できない場合は、別のインスタンスを作成してください。 |
|
コア操作エラー |
インスタンスで実行した操作が失敗しました。 |
起動、停止、構成のスペックアップなど、インスタンスでの最近の操作が成功したか確認します。 操作が失敗した場合は、再度実行してください。 |
|
イメージのロード例外 |
インスタンスが使用するイメージをロードできません。 |
起動時にイメージをロードできるか確認します。 システムまたはイメージの問題により、イメージのロードに失敗する可能性があります。インスタンスを再起動して回復してください。 |
セキュリティコントロールの正常性に関する診断項目
|
ECS コンソールでの診断項目 |
説明 |
診断範囲と推奨される操作 |
|
共通ポートの状態 |
Windows および Linux インスタンスについて、それぞれインスタンスのセキュリティグループでポート 3389 および 22 でのトラフィックが許可されているか確認します。 |
セキュリティグループで共通ポートのトラフィックが許可されているか確認します。 共通ポートのトラフィックがブロックされている場合、サービスが実行されないか、インスタンスにアクセスできなくなる可能性があります。次のポートでのインバウンドトラフィックを許可してください:
|
課金の正常性に関する診断項目
|
ECS コンソールでの診断項目 |
説明 |
診断範囲と推奨される操作 |
|
サブスクリプションインスタンスの有効期限切れ |
サブスクリプションインスタンスの有効期限が切れているか確認します。 |
サブスクリプションインスタンスの有効期限が切れているか確認します。 インスタンスの有効期限が切れると、停止されアクセスできなくなります。有効期限切れ後のリソースの状態変更については、「サブスクリプション」をご参照ください。サービスを回復するには、インスタンスを更新してください。 |
|
支払い遅延による従量課金インスタンスの停止確認 |
支払い遅延により従量課金インスタンスが停止し、使用できなくなっているか確認します。 |
従量課金インスタンスに支払い遅延があるか確認します。 ある場合、インスタンスは停止され使用できなくなります。支払い遅延後のリソースの状態変更については、「従量課金」をご参照ください。アカウントに資金を追加し、インスタンスを再アクティブ化してください。 |
|
インスタンスコンポーネントの支払い遅延 |
アカウント内の支払い遅延により、インスタンスのディスクまたはネットワーク帯域幅が利用できなくなっているか確認します。 |
サブスクリプションインスタンスにアタッチされた従量課金ディスクまたは帯域幅が、アカウント内の支払い遅延により利用できなくなっているか確認します。 インスタンスコンポーネントに支払い遅延がある場合、インスタンスへのアクセスも影響を受けます。アカウントに資金を追加する必要があります。 |
リソースクォータの正常性に関する診断項目
|
ECS コンソールでの診断項目 |
説明 |
診断範囲と推奨される操作 |
|
ディスク容量クォータの不足 |
ディスク容量がクォータに近づいています。 |
ECS コンソールにログインして、クォータの引き上げをリクエストします。 |
|
イメージクォータの不足 |
アカウント内のイメージ数がクォータに近づいています。 |
イメージクォータを増やすには、Elastic Compute Service の一般クォータページに移動し、カスタムイメージ数 の [アクション] 列で 申請 をクリックします。 |
|
ENI クォータの不足 |
アカウント内のセカンダリ Elastic Network Interface (ENI) の数がクォータに近づいています。 |
ECS コンソールでクォータの引き上げを申請します。詳細については、「ECS クォータ管理」をご参照ください。 |
|
NIC キュークォータの不足 |
インスタンスが NIC キューの最大数に達しました。 |
|
|
セキュリティグループクォータの不足 |
アカウント内のセキュリティグループの数がクォータに近づいています。 |
セキュリティグループのクォータを増やすには、Elastic Compute Service の特典クォータ ページに移動し、[セキュリティグループの最大数] の [アクション] 列で申請 をクリックします。 |
|
リソースのセキュリティグループクォータの不足 |
ENI が追加できるセキュリティグループの最大数に近づいています。 |
ECS コンソールでクォータの引き上げを申請します。詳細については、「ECS クォータの管理」をご参照ください。 ECS インスタンスまたは ENI が参加できるセキュリティグループの制限を調整すると、セキュリティグループごとのルールの最大数も変更されます。詳細については、「制限事項」をご参照ください。 |
|
セキュリティグループのルールクォータの不足 |
セキュリティグループ内のルールの数がクォータに近づいています。 |
ECS コンソールでクォータの引き上げを申請します。詳細については、「ECS クォータの管理」をご参照ください。 セキュリティグループごとの最大ルール数を調整すると、ECS インスタンスまたは ENI が参加できるセキュリティグループの数も変更されます。詳細については、「制限事項」をご参照ください。 |
Linux 関連構成の診断項目
|
ECS コンソールでの診断項目 |
説明 |
診断範囲と推奨される操作 |
|
合計 CPU 使用率 |
|
インスタンスの合計 CPU 使用率を確認します。 CPU 使用率が高い場合は、リソースを大量に消費しているプロセスを特定し、それらが正常であるか確認します。詳細については、「Linux インスタンスの高い CPU 使用率または負荷のトラブルシューティング」をご参照ください。 |
|
ディスク内の Inode |
ディスクの inode が十分であるか確認します。 |
インスタンス上のディスクの inode 使用量を確認します。 inode 使用量が高いと、ファイルの作成が妨げられる可能性があります。必要に応じてディスクのサイズを変更してください。 |
|
DHCP サービス |
DHCP (動的ホスト構成プロトコル) が構成されているときに、ネットワーク関連のプロセスが存在するかどうかを確認します。存在しない場合、リース期限が切れた後に IP アドレスが失われる可能性があります。 |
インスタンスの eth0 NIC の DHCP プロセスを確認します。 DHCP プロセスが存在しない場合、リース期限切れ後に IP アドレスの更新に失敗し、ネットワークの中断を引き起こす可能性があります。詳細については、「Linux インスタンスでの DHCP の構成」をご参照ください。 |
|
fstab 内のデバイス |
fstab ファイルに存在しないデバイスの構成が含まれているかどうかを確認します。 |
インスタンスの /etc/fstab ファイルを確認します。 /etc/fstab ファイルに存在しないデバイスの構成が含まれている場合、インスタンスの起動に失敗する可能性があります。これらの構成を削除するには、「Linux インスタンスでの /etc/fstab エラーによる起動失敗のトラブルシューティング」をご参照ください。 |
|
fstab 内のデバイスのマウント状態 |
fstab ファイル内のデバイスが正しくマウントされているか確認します。 |
インスタンスの /etc/fstab ファイルを確認します。 /etc/fstab ファイルでデバイスが自動マウント用に構成されていない場合、再起動後に利用できなくなります。mount コマンドを実行して手動でマウントするか、/etc/fstab で UUID を使用して自動マウントを構成してください。 |
|
fstab ファイル形式 |
fstab ファイルの内容が正しい形式であるか確認します。 |
インスタンスの /etc/fstab ファイルを確認します。 /etc/fstab の形式が無効な場合、インスタンスの起動が妨げられる可能性があります。詳細については、「Linux インスタンスでの /etc/fstab エラーによる起動失敗のトラブルシューティング」をご参照ください。 |
|
システムファイアウォールの状態 |
システムファイアウォールが有効になっているか確認します。 |
ファイアウォールの構成を確認します。 ファイアウォールが外部アクセスをブロックしている場合、接続が失敗する可能性があります。詳細については、「Linux でのシステムファイアウォールの管理」をご参照ください。 |
|
システムファイルの状態 |
重要なシステムファイルの状態を確認します。 |
ファイルシステムを確認および修復するには、「Linux インスタンスのファイルシステムの確認と修復」をご参照ください。 |
|
制限構成 |
制限構成が正しいか確認します。 |
インスタンスの /etc/security/limits.conf ファイルを確認します。 /etc/security/limits.conf ファイルの |
|
メモリ構成 |
構成されたヒュージページサイズが大きいかどうかを確認します。 |
インスタンスの etc/sysctl.conf ファイルを確認します。 合計ヒュージページサイズ (ヒュージページの数 × ページあたりのサイズ) がインスタンスのメモリを超えると、パフォーマンスの問題が発生する可能性があります。調整するには、「Linux インスタンスでヒュージページを調整する方法」をご参照ください。 |
|
共通ポートのリッスン状態 |
ポート 22 やポート 3389 などの共通ポートがリッスン状態にあるか確認します。 |
インスタンスの共通ポートを確認します。 共通ポートがリッスンしていない場合、アプリケーションにアクセスできない可能性があります。詳細については、「TCP および UDP ポートのテスト」をご参照ください。 |
|
CPU 使用率が 50% を超えるプロセス |
|
インスタンス上のプロセスの CPU 使用率を確認します。 一部のプロセスの CPU 使用率が高い場合は、それらが正常であるか確認します。詳細については、「Linux インスタンスの高い CPU 使用率または負荷のトラブルシューティング」をご参照ください。 |
|
単一 CPU の高い使用率 |
|
一定期間にわたるインスタンスの単一 CPU 使用率を確認します。 単一 CPU の使用率が高い場合は、リソースを大量に消費しているプロセスを特定します。詳細については、「Linux インスタンスの高い CPU 使用率または負荷のトラブルシューティング」をご参照ください。 |
|
主要なシステムプロセスの起動状態 |
重要なシステムプロセスが起動しているか確認します。 |
インスタンスの重要なシステムプロセスを確認します。 重要なシステムプロセスが実行中でない場合、インスタンスにアクセスできない可能性があります。 |
|
NAT 環境のカーネルパラメーター |
NAT 環境のカーネルパラメーターが有効であるか確認します。 |
インスタンスの NAT 環境に関連するカーネルパラメーターを確認します。 NAT 関連のカーネルパラメーターが誤って構成されている場合、SSH 接続や HTTP アクセスが失敗する可能性があります。/etc/sysctl.conf の net.ipv4.tcp_tw_recycle と net.ipv4.tcp_timestamps の値を確認します。詳細については、「クライアントに NAT を構成した後、ECS インスタンスまたは ApsaraDB RDS インスタンスにアクセスできないのはなぜですか?」をご参照ください。 |
|
TCP SACK 構成 |
TCP SACK が有効になっているか確認します。 |
インスタンスで TCP SACK が有効になっているか確認します。 TCP SACK が無効になっていると、ネットワークパフォーマンスに影響を与える可能性があります。詳細については、「Linux インスタンスで TCP SACK を有効にする」をご参照ください。 |
|
オペレーティングシステムが OOM かどうかを確認 |
インスタンスのオペレーティングシステムで OOM の問題が発生したかどうかを確認します。 |
インスタンスのオペレーティングシステムで OOM の問題が発生したかどうかを確認します。 発生した場合、インスタンスにワークロードに対して十分なメモリがあるか確認します。メモリが不足している場合は、インスタンスをスペックアップしてください。OOM の問題を分析および解決するには、「Linux インスタンスの Out of Memory 問題のトラブルシューティング」をご参照ください。 |
|
重要なシステムファイルの形式 |
重要なシステムファイルの形式を確認します。 |
インスタンス上の重要なシステムファイルが UNIX 形式であるか確認します。 そうでない場合、接続が失敗する可能性があります。詳細については、「Linux インスタンス上の非 Unix 形式のファイルの修復」をご参照ください。 |
|
SELinux の状態 |
SELinux が有効になっているか確認します。 |
インスタンスで SELinux が有効になっているか確認します。 有効になっている場合、SSH 接続が失敗する可能性があります。SELinux を一時的または永続的に無効にしてください。詳細については、「SELinux が有効な Linux インスタンスで SSH 接続が失敗する」をご参照ください。 |
|
重要なシステムユーザーの状態とパスワード設定 |
重要なシステムユーザーにパスワードがあるか確認します。重要なシステムユーザーには、Linux の root ユーザーと Windows の administrator ユーザーが含まれます。 |
インスタンスのオペレーティングシステムに重要なユーザーが存在するか確認します。 存在しない場合、接続が失敗する可能性があります。/etc/passwd で重要なユーザーの状態とパスワード設定を確認します。詳細については、「Linux インスタンスに重要なシステムユーザーが存在しない」をご参照ください。 |
|
SSH アクセス権限 |
SSH アクセス権限が正しく構成されているか確認します。 |
インスタンスの SSH アクセス権限を確認します。 SSH アクセス権限が正しくないと、接続が妨げられる可能性があります。詳細については、「Linux インスタンスに重要なシステムユーザーが存在しない」をご参照ください。 |
|
SSH のための重要なファイルシステム |
SSH アクセスのための重要なファイルまたはディレクトリが存在するか確認します。 |
SSH に必要な重要なファイルまたはディレクトリを確認します。 SSH の重要なファイルまたはディレクトリが欠落していると、SSH 接続が妨げられる可能性があります。詳細については、「Linux インスタンスで必要な SSH ファイルの検証」をご参照ください。 |
|
SSH が root ログインを許可しているかどうか |
SSH が root ユーザーとしてログインすることを許可しているか確認します。 |
SSH が root ユーザーとしてログインすることを許可しているか確認します。 SSH が root アクセスを拒否する場合、SSH 経由で root として接続すると Permission denied, please try again エラーが返されます。詳細については、「Linux インスタンスへの SSH 接続で「Permission denied, please try again」エラーを解決する」をご参照ください。 |
|
NIC マルチキューの状態 |
NIC マルチキューが有効になっているか確認します。 |
インスタンスの NIC で NIC マルチキューが有効になっているか確認します。 NIC マルチキューが有効になっていない場合、ネットワークパフォーマンスに影響を与える可能性があります。詳細については、「NIC マルチキュー」をご参照ください。 |
Windows 関連構成の診断項目
|
ECS コンソールでの診断項目 |
説明 |
診断範囲と推奨される操作 |
|
Windows オペレーティングシステムのバージョン |
Microsoft は Windows Server 2008 以前のバージョンのサポートを終了しました。 |
インスタンスの Windows オペレーティングシステムのバージョンを確認します。 Alibaba Cloud と Microsoft は Windows 2008 以前のサポートを終了しました。新しいバージョンの Windows Server をインストールしてください。詳細については、「システムディスク (OS) の置き換え」をご参照ください。 |
|
合計 CPU 使用率が高い |
Windows インスタンスの合計 CPU 使用率が 85% を超えているか確認します。 |
インスタンスの CPU 使用率を確認します。 合計 CPU 使用率が高い場合は、リソースを大量に消費しているプロセスを特定します。詳細については、「Windows インスタンスの高い CPU 使用率のトラブルシューティング」をご参照ください。 |
|
単一 CPU の高い使用率 |
単一 CPU の使用率が 80% を超えているか確認します。 |
インスタンスの CPU 使用率を確認します。 単一 CPU の使用率が高い場合は、リソースを大量に消費しているプロセスを特定します。詳細については、「Windows インスタンスの高い CPU 使用率のトラブルシューティング」をご参照ください。 |
|
高いメモリ使用量 |
Windows インスタンスのメモリ使用量が 80% を超えているか確認します。 |
メモリ使用量が 80% を超えているか確認します。 超えている場合、メモリを最も消費している上位 5 つのプロセスが表示されます。それらが期待どおりに実行されているか確認します。詳細については、「Windows のメモリ分析ツール」をご参照ください。 |
|
一般的な Windows サービスポートの状態 |
Windows インスタンスでポート 3389 が有効になっているか確認します。 |
インスタンスのポート 3389 を確認します。 ポート 3389 が無効になっている場合、RDP アクセスは失敗します。詳細については、「Windows ECS インスタンスでリモートデスクトップサービスを有効にする方法」をご参照ください。 |
|
Windows NIC の状態 |
Windows インスタンスの NIC が有効になっているか確認します。 |
インスタンスの NIC を確認します。 NIC が利用できない場合、インスタンスに接続できません。NIC を確認および修復するには、「ネットワーク接続の確認」をご参照ください。 |
|
NIC の IPv4 アドレス |
Windows インスタンスの NIC に IPv4 アドレスが割り当てられているか確認します。 |
NIC に IPv4 アドレスが割り当てられているか確認します。 割り当てられていない場合、インスタンス上のサービスにアクセスできない可能性があります。DHCP が有効になっているか、静的 IP アドレスが割り当てられているか確認します。DHCP を有効にするには、「DHCP サーバーのインストールと構成」をご参照ください。 |
|
ネットワークプロキシの状態 |
ネットワークプロキシ情報が構成されているか確認します。 |
ネットワークプロキシ情報が構成されているか確認します。 ネットワークプロキシが構成されている場合、インスタンス上のサービスにアクセスできない可能性があります。ビジネス要件に基づいてネットワークプロキシを有効または無効にします。Windows でネットワークプロキシを無効にするには、「Internet Explorer のプロキシ設定をリセットする方法」をご参照ください。 |
|
DHCP 構成の状態 |
Windows インスタンスの NIC で DHCP が有効になっているか確認します。 |
NIC の DHCP の状態を確認します。 NIC で DHCP が無効になっている場合、サービスにアクセスできない可能性があります。ビジネス要件に基づいて DHCP 構成を変更します。DHCP を有効にして構成するには、「ワークグループで DHCP サーバーをインストールおよび構成する方法」をご参照ください。 |
|
Windows 仮想ディスクドライバーの状態 |
virtio ドライバーのバージョンを確認します。 |
インスタンスの virtio ドライバーのバージョンを確認します。 virtio ドライバーのバージョンが古い場合、ディスクをオンラインでサイズ変更できません。スペックアップするには、「Windows インスタンスの virtio ドライバーの更新」をご参照ください。 |
|
ディスク容量 |
システムディスク C:\\ の利用可能な容量が 1 GB 未満であるか確認します。 |
インスタンスのシステムディスク C:\\ の利用可能な容量を確認します。 利用可能な容量が 1 GB 未満の場合、システムの動作が遅くなったり、起動に失敗したりする可能性があります。必要に応じてシステムディスクのサイズを変更してください。 |
|
Windows ファイアウォールの状態 |
Windows ファイアウォールが有効になっているか確認します。 |
インスタンスでファイアウォールが有効になっているか確認します。 有効になっている場合、インスタンス上のサービスにアクセスできない可能性があります。ファイアウォールポリシーを変更するには、「Windows のファイアウォールルールの構成」をご参照ください。 |
|
クラッシュダンプ構成の状態 |
インスタンスでクラッシュダンプ収集が有効になっているか確認します。 |
インスタンスでクラッシュダンプ収集が有効になっているか確認します。 有効になっていない場合、予期せぬ再起動やブルースクリーンイベント中にインスタンスが回復情報を保存できません。要件に応じてクラッシュダンプ収集を有効または無効にします。詳細については、「カーネルクラッシュダンプの有効化または無効化」をご参照ください。 |
|
管理者アカウント |
Administrator アカウントが存在するか確認します。 |
Administrator アカウントが存在するか確認します。 存在しない場合、サービスにアクセスできない可能性があります。必要に応じて Administrator アカウントを作成してください。詳細については、「管理コンソールを使用して管理者を追加または削除する方法」をご参照ください。 |
API 診断メトリックの分類
用語
-
診断メトリック (DiagnosticMetric):CPU 使用率など、インスタンスまたはアカウントの状態をチェックする単位。
-
診断項目 (Issue):診断メトリックがチェックされたときに発見される関連項目。項目は重要度レベルによって
Info、Warn、またはCriticalに分類されます。各診断メトリックは複数の診断項目に関連付けられる場合があります。関連する診断項目が存在しない場合、システムが診断メトリックをチェックしても問題は見つかりません。ただし、これは診断メトリックに実際の問題が存在しないことを意味するものではありません。 -
診断メトリックセット (DiagnosticMetricSet):一度にすべてのメトリックを診断できる診断メトリックのコレクション。
重要診断結果は参考としてのみ使用されます。正常な診断結果は、関連するシステムメトリックに問題がないことを意味するものではありません。
次の表は、特徴とモジュールによって分類されたインスタンス正常性診断項目を説明しています。
|
カテゴリコード |
カテゴリ名 |
説明 |
|
ECSService.ServiceHealth |
ECS の物理サーバーリソースと仮想化レイヤーをチェックします。 |
|
|
ECSService.InstanceNetwork |
インスタンス上のネットワークコンポーネントの状態と外部ネットワーク環境の例外をチェックします。 |
|
|
ECSService.InstanceStorage |
インスタンスのディスクに例外が存在するかどうかをチェックします。 |
|
|
ECSService.InstanceConfigure |
操作がインスタンスの起動または期待どおりの実行を妨げているかどうかをチェックします。 |
|
|
ECSService.SecurityGroup |
インスタンスに関連付けられたすべてのセキュリティグループで、共通ポートへのインバウンドトラフィックが許可されているかどうかをチェックします。 |
|
|
ECSService.AccountBalance |
インスタンスとその関連コンポーネント (パブリック IP アドレスや EIP トラフィックなど) に支払い遅延があるかどうかをチェックします。 |
|
|
ECSService.GuestOS |
インスタンスのオペレーティングシステム内のシステムファイル、主要なプロセス、および共通ポートとファイアウォールの使用状況をチェックします。 |
|
|
ECSService.GuestOS |
インスタンスのオペレーティングシステム内の共通ポートとファイアウォールの使用状況をチェックします。 |
|
|
ECSService.ActionTrace |
インスタンスの課金関連操作、セキュリティグループ関連操作、およびインスタンス状態関連操作を監査および追跡します。 |
-
コンピューティングサービスの正常性、ネットワークサービスの正常性、ストレージサービスの正常性、およびインスタンス構成管理の診断中に検出された例外は、非リアルタイムの例外です。診断結果には、過去の問題を表示するために過去 12 時間以内に発生した例外が含まれており、即時の解決を必要としない場合があります。
-
セキュリティコントロールの正常性、課金、リソースクォータ、およびインスタンスオペレーティングシステムの構成の診断中に検出された例外は、リアルタイムの例外です。これらの例外は診断時に存在するため、直ちに解決することを推奨します。
コンピューティングサービスの正常性に関する診断項目
|
診断メトリック ID |
診断メトリックの説明 |
診断結果項目 ID |
診断メトリック項目の説明 |
推奨される操作 |
|
Instance.ControllerError |
インスタンスのバックエンド管理システムが期待どおりに実行されているか確認します。 |
Instance.ECSService.MngServiceException |
バックエンド管理システムが期待どおりに実行されておらず、インスタンスが異常に実行される可能性があります。 |
インスタンスを再起動します。 |
|
Instance.CPUException |
共有インスタンスが基盤レイヤーで CPU を競合しているか確認します。 |
Instance.ECSService.CPUBindFailure |
CPU 競合が存在し、インスタンスが CPU リソースを取得できない、または他の例外が発生する可能性があります。 |
インスタンスを再起動します。 |
|
Instance.CPUSplitLock |
Intel CPU Split Lock の問題を確認します。 |
Instance.ECSService.CPUSplitLock |
インスタンスで Intel CPU Split Lock の問題が発生しました。 |
ECS インスタンス上のアプリケーションにこの問題を引き起こす異常なコードが含まれていないか確認し、コードを最適化してください。 |
|
Instance.GuestOSCrash |
インスタンスのオペレーティングシステムがクラッシュしたかどうかを確認します。 |
Instance.ECSService.GuestOSCrashed |
オペレーティングシステムがクラッシュしました。 |
ECS インスタンス上のアプリケーションにこの問題を引き起こす異常なコードが含まれていないか確認し、コードを最適化してください。 |
|
Instance.HostDownAlert |
インスタンスをホストする基盤となる物理サーバーにエラーが存在するかどうかを確認します。 |
Instance.ECSService.HostDown |
基盤となる物理サーバーにエラーが存在します。インスタンスの状態またはパフォーマンスが影響を受ける可能性があります。 |
インスタンスを再起動します。 |
|
Instance.PerformanceAffected |
基盤となるソフトウェアまたはハードウェアの問題により、インスタンスのパフォーマンスが一時的に低下しているかどうかを確認します。 |
Instance.ECSService.PerformanceAffected |
インスタンスのパフォーマンスが低下しています。過去のシステムイベントまたはシステムログとスクリーンショットを確認して原因を特定してください。 |
インスタンスを再起動します。 |
|
Instance.PerfRestrict |
バースト可能インスタンスの CPU クレジットが高性能を維持するのに十分であるか確認します。 |
Instance.ECSService.BurstPerformanceRestricted |
CPU クレジットが不足している場合、バースト可能インスタンスはピーク時間帯にベースラインパフォーマンスしか提供できず、パフォーマンスをバーストさせることができません。 |
インスタンスが要件を満たさない場合は、インスタンスタイプをスペックアップしてください。詳細については、「サブスクリプションインスタンスのインスタンスタイプのスペックアップ」または「従量課金インスタンスタイプの変更」をご参照ください。 |
|
Instance.ResourceNotEnough |
必要な物理 CPU またはメモリリソースが十分であるか確認します。 |
Instance.ECSService.ResourceOutOfStock |
システムがインスタンスにリソースを再割り当てしようとするとき (たとえば、節約モードで停止したインスタンスを起動するとき) に物理リソースが不足している場合、インスタンスは起動できません。 |
数分待ってから再試行するか、別のゾーンまたはリージョンで別のインスタンスを作成してください。 |
|
Instance.SystemException |
カーネルパニック、OOM 例外、または内部ダウンタイムなどのエラーがインスタンスのオペレーティングシステムに存在するかどうかを確認します。 |
Instance.ECSService.GuestOSException |
内部 OS の例外は、不適切なインスタンス構成またはユーザースペースでの不適切なプログラム構成が原因である可能性があります。 |
インスタンスを再起動します。 |
|
Instance.VirtException |
インスタンスの基盤となる仮想化レイヤーのコアサービスに例外が存在するかどうかを確認します。 |
Instance.ECSService.VirtualizationException |
この例外により、インスタンスが応答しなくなったり、予期せず停止したりする可能性があります。 |
インスタンスを再起動します。 |
|
Instance.RecentUtilHigh |
過去の負荷が 80% を超えているか確認します。 |
Instance.UtilizationHigh.IntranetBandwidth |
選択した診断期間中、インスタンスの内部帯域幅使用率が 80% を超えています。高い内部帯域幅使用率は、インスタンスが大量の内部ネットワークトラフィックを転送していることを示します。 |
Alibaba Cloud は特定のプロセス情報を判断できません。ビジネスに基づいてさらに分析してください。詳細なモニタリング情報については、CloudMonitor コンソールにログインしてください。 |
|
Instance.UtilizationHigh.DiskIOPS |
選択した診断期間中、インスタンスの IOPS 使用率が 80% に達しました。高い IOPS 使用率は、インスタンスが頻繁な I/O 読み取りおよび書き込み操作を実行していることを示します。 |
Alibaba Cloud は特定のプロセス情報を判断できません。ビジネスに基づいてさらに分析してください。詳細なモニタリング情報については、CloudMonitor コンソールにログインしてください。 |
||
|
Instance.UtilizationHigh.DiskBPS |
選択した診断期間中、インスタンスの BPS 使用率が 80% に達しました。高い BPS 使用率は、インスタンスが大量のデータを転送していることを示します。 |
Alibaba Cloud は特定のプロセス情報を判断できません。ビジネスに基づいてさらに分析してください。詳細なモニタリング情報については、CloudMonitor コンソールにログインしてください。 |
||
|
Instance.UtilizationHigh.CPU |
選択した診断期間中、インスタンスの CPU 使用率が 80% に達しました。高い CPU 使用率は、インスタンスが高頻度の計算タスクを実行していることを示します。 |
詳細なモニタリング情報については、CloudMonitor コンソールにログインしてください。 |
||
|
Instance.KMSInvalid |
KMS キーが正常に動作しているか確認します。 |
Instance.KMSInvalid.SecretInvalid |
現在のインスタンスは、Key Management Service (KMS) が提供するキーサービスを使用してシステムディスクまたはデータディスクを暗号化していますが、キーが無効なためインスタンスの起動に失敗します。 |
KMS コンソールにログインして、インスタンスのディスクに使用されているキーの状態を確認できます。インスタンスに支払い遅延がある場合は、サブスクリプションを更新してインスタンスを再起動してください。 インスタンスが期待どおりに実行されている場合は、このアラートを無視してください。 |
ネットワークサービスの正常性に関する診断項目
|
メトリック ID |
メトリックの説明 |
結果項目 ID |
結果の説明 |
推奨される操作 |
|
Instance.ArpPingError |
NIC に ARP リクエストを送信して、インスタンスの基本的なネットワーク構成が正常に機能しているか確認します。 |
Instance.ECSService.ARPPingIssue |
インスタンスの NIC のリンクレイヤーで例外が発生しました。 |
リクエストが失敗した場合、インスタンスは期待どおりに起動しないか、ネットワーク構成が異常です。インスタンスを再起動してください。 |
|
Instance.DDoSStatus |
インスタンスのパブリック IP アドレスが DDoS 攻撃を受けているか確認します。 |
Instance.Security.SufferDDoSAttacks |
次のサンプルデータが項目の追加情報として返されます:
返された結果の属性:
|
無料の Anti-DDoS Origin サービスは悪意のあるトラフィックをスクラビングします。トラフィックがインスタンスの保護能力を超えると、インスタンスは利用できなくなります。詳細については、「DDoS 攻撃とは?」をご参照ください。 インスタンスを保護するために、追加の Anti-DDoS サービスを購入してください。詳細については、「Alibaba Cloud Anti-DDoS ソリューションの比較」をご参照ください。 詳細については、「DDoS 攻撃緩和ソリューション」をご参照ください。 |
|
Instance.NetworkBoundLimit |
インスタンスの内部およびパブリック帯域幅の合計を確認します。 |
Instance.Network.IOLimit |
合計帯域幅がインスタンスタイプがサポートする最大ベースライン帯域幅を超えており、ネットワークパフォーマンスがビジネスのボトルネックになっています。 |
より高い帯域幅を持つインスタンスタイプにスペックアップします。 |
|
Instance.NetworkBurstLimit |
インスタンスのバースト帯域幅が上限に達しているか確認します。 |
Instance.Network.BurstBoundLimit |
バースト帯域幅がインスタンスタイプで許可されている上限を超えており、ネットワークパフォーマンスがビジネスのボトルネックになっています。 |
より高い帯域幅を持つインスタンスタイプにスペックアップします。 |
|
Instance.NetworkLoadFailure |
インスタンスの NIC がロードできるか確認します。 |
Instance.Network.ENILoadFailure |
NIC がロードできない場合、インスタンスのネットワーク接続が影響を受けます。たとえば、インスタンスに接続できません。 |
インスタンスを再起動します。 |
|
Instance.NetworkSessionError |
インスタンスの NIC で接続を確立できるか確認します。 |
Instance.Network.SessionException |
NIC で接続を確立できない場合、または最大接続数に達した場合、インスタンスのネットワーク接続またはスループットが影響を受けます。たとえば、インスタンスに接続できない、またはネットワーク速度が遅いなどです。 |
インスタンスを再起動します。 |
|
Instance.PacketDrop |
NIC でインバウンドまたはアウトバウンドのパケット損失が発生したかどうかを確認します。 |
Instance.Network.PacketDrop |
パケット損失が存在する場合、インスタンスのネットワーク接続またはスループットが影響を受けます。たとえば、インスタンスに接続できない、またはネットワーク速度が遅いなどです。 |
インスタンスを再起動します。 |
|
Instance.NetworkConfigConsistency |
インスタンスのネットワークメトリックが正常であるか確認します。 |
Instance.NetworkConfig.Inconsistent |
インスタンスの有効なネットワーク構成が基盤となるサービス構成と一致しておらず、インスタンスのネットワークパフォーマンスに影響を与える可能性があります。 |
|
|
Instance.NetworkLinkException |
インスタンスの内部リンクにパケット損失が存在するかどうかを確認します。 |
Instance.Network.LinkException |
検出期間中、インスタンスは基盤となるネットワークリンクでパケット損失を経験し、インスタンスのパフォーマンスに影響を与える可能性があります。 |
|
ストレージサービスの正常性に関する診断項目
|
メトリック ID |
メトリックの説明 |
結果項目 ID |
結果の説明 |
推奨される操作 |
|
Instance.DiskLimit |
インスタンスのシステムディスクに読み取りおよび書き込み I/O レイテンシがあるか、また読み取りおよび書き込み IOPS がディスクの上限を超えているか確認します。 |
Instance.Disk.IOLimit |
ディスクの IOPS が上限を超え、読み取り/書き込み操作が制限されています。詳細については、「ディスクのモニタリング情報の表示」をご参照ください。 |
これを防ぐには、ディスクの I/O 頻度を減らすか、より高性能なディスクカテゴリにスペックアップしてください。詳細については、「ブロックストレージのパフォーマンス」をご参照ください。 |
|
Instance.DiskLoadFailure |
インスタンスの起動中にディスクをインスタンスにアタッチできるか確認します。 |
Instance.Disk.EBSLoadFailure |
ディスクをインスタンスにアタッチできません。インスタンスを起動できません。 |
インスタンスを停止して再起動するか、ディスクを再アタッチして回復してください。 |
|
Instance.IOHang |
インスタンスのシステムディスクで I/O ハングが発生したかどうかを確認します。たとえば、ディスクのファイルシステムの読み取りおよび書き込み I/O レイテンシが高く、インスタンスの不安定さやクラッシュを引き起こす場合などです。 |
Instance.Disk.IOHang |
システムディスクで I/O ハングが発生し、ディスクからのデータの読み取りまたは書き込みができません。 |
ディスクのパフォーマンスメトリクスを確認します。詳細については、「ディスクのモニタリング情報の表示」をご参照ください。Alibaba Cloud Linux 2 インスタンスについては、「ファイルシステムとブロックレイヤーの I/O ハングの検出」をご参照ください。 |
|
Instance.ResizeFsFailure |
システムディスクのサイズを変更した後、システムディスク上のファイルシステムも拡張されているか確認します。 |
Instance.Disk.ResizeFailure |
ファイルシステムが拡張されておらず、新しくサイズ変更されたディスクを使用できません。 |
ディスクを再度サイズ変更してください。詳細については、「概要」をご参照ください。 |
|
Instance.DiskFull |
一定期間中にディスク使用率が 100% に達したかどうかを確認します。 |
Instance.Disk.Full |
特定の期間中、インスタンスのディスク使用率が 100% に達し、インスタンスの例外を引き起こす可能性があります。 |
システムが正常に実行されるように、必要に応じて次のいずれかのソリューションを選択してください:
|
インスタンス構成管理の診断項目
|
メトリック ID |
メトリックの説明 |
結果項目 ID |
結果の説明 |
推奨される操作 |
|
Instance.BootFailure |
インスタンスで起動操作を実行できるか確認します。 |
Instance.ECSService.BootIssue |
インスタンスを起動できません。 |
インスタンスを再起動します。 |
|
Instance.ImageLoadFailure |
インスタンスが使用するイメージを起動時にロードできるか確認します。 |
Instance.ECSService.ImageIssue |
システムまたはイメージの問題により、イメージのロードに失敗する可能性があります。 |
インスタンスを再起動します。 |
|
Instance.OperationFailure |
インスタンスで実行した操作が成功したか確認します。これらの操作には、インスタンスの起動と停止、およびインスタンスの構成のスペックアップが含まれます。 |
Instance.ECSService.OperationError |
操作が失敗します。 |
再試行してください。 |
|
Instance.BootScreenshot |
オペレーティングシステムの起動失敗がオペレーティングシステムの問題によって引き起こされたかどうかを確認します。 |
Instance.BootScreenshot.Exception |
オペレーティングシステムの異常な構成や異常なシャットダウンなどの問題により、インスタンスのオペレーティングシステムが起動できません。 |
VNC を使用してインスタンスにログインします。 |
セキュリティの正常性に関する診断項目
|
メトリック ID |
メトリックの説明 |
結果項目 ID |
結果の説明 |
推奨される操作 |
|
Instance.SGIngress |
インスタンス NIC のセキュリティグループルールで、共通ポートへのインバウンドトラフィックが許可されているか確認します。 |
Instance.Network.SSHPortRuleDeny |
インバウンド SSH ポート 22 が許可されていません。
|
SSH 経由でインスタンスにアクセスするには、セキュリティグループルールを追加して SSH インバウンドトラフィックを許可してください。 |
|
Instance.SgRule.PingPortDeny |
インスタンスに PING できません。
|
インスタンスに PING するには、セキュリティグループルールを追加して ICMP トラフィックを許可してください。 |
||
|
Instance.SgRule.WinRemotePortDeny |
RDP 経由でインスタンスに接続できません。
|
リモートデスクトップを使用してインスタンスにアクセスするには、セキュリティグループルールを追加して RDP インバウンドトラフィックを許可してください。 |
||
|
Instance.SecurityRisk |
インスタンスにセキュリティリスクが存在するかどうかを確認します。 |
Instance.Security.Risk |
インスタンスには例外を引き起こす可能性のあるセキュリティリスクがあります。 |
セキュリティリスクを表示するには、Security Center にログインしてください。 |
課金の診断項目と結果
|
メトリック ID |
メトリックの説明 |
結果項目 ID |
結果の説明 |
推奨される操作 |
|
Instance.ExpenseException |
ECS インスタンスの課金状態が異常であるか確認します。 |
Account.Balance.ExpenseException |
インスタンスの一部のリソースに課金状態の例外 (サブスクリプションの有効期限切れやアカウントの支払い遅延を含む) があり、インスタンスへの接続や正常な使用が妨げられています。 課金状態に例外があるリソースは以下のとおりです。インスタンスを更新するか、アカウントに資金を追加してから、インスタンスを再起動してログインしてください。
例:
例:
返された結果の属性:
|
詳細については、「課金概要」をご参照ください。 |
Linux オペレーティングシステム構成の診断項目と結果
|
メトリック ID |
メトリックの説明 |
結果項目 ID |
結果の説明 |
推奨される操作 |
|
GuestOS.CPUUtil |
CPU 使用率が高すぎないか確認します。 |
GuestOS.CPU.HighUtilization |
インスタンスの合計 CPU 使用率が 80% を超えています。 CPU 使用率で上位 5 つのプロセスを以下に示します。
返された結果の属性:
|
CPU 使用率をクエリするには、「Linux インスタンスの高い CPU 使用率または負荷のトラブルシューティング」をご参照ください。 |
|
GuestOS.CoreCPU.HighUtilization |
インスタンスの 1 つ以上の CPU の使用率が 85% を超えています。 CPU 使用率が 85% を超えるプロセスを以下に示します。
返された結果の属性:
|
CPU リソース使用量をクエリするには、「Linux インスタンスの高い CPU 使用率または負荷のトラブルシューティング」をご参照ください。 |
||
|
GuestOS.MemUtil |
インスタンスのメモリ使用量が高すぎないか確認します。 |
GuestOS.Memory.HighUtilization |
インスタンスの合計メモリ使用率が 80% を超えています。 メモリ使用量が最も高い上位 5 つのプロセスの例:
返された結果の属性:
|
必要に応じて不要なサービスやプロセスを無効にしてください。これが通常のビジネス運用によって引き起こされる場合は、ECS 構成をスペックアップすることを推奨します。 メモリ使用量をクエリするには、「Linux インスタンスの高いメモリ使用量のトラブルシューティング」をご参照ください。 |
|
GuestOS.DiskUtil |
システムディスクの使用率が高すぎないか確認します。 |
GuestOS.SystemDisk.InsufficientSpace |
インスタンスのディスク上の一部のファイルシステムのディスク領域または inode 使用率が 80% を超えています。これにより、これらのパーティションに新しいファイルを作成できなくなる可能性があります。 inode 使用率が高いディスクの例:
返された結果の属性:
|
必要に応じてディスクのサイズを変更してください。詳細については、「概要」をご参照ください。 inode 容量の問題を解決するには、「Linux での「no space left」問題の解決」をご参照ください。 |
|
GuestOS.SystemConfig |
重要なシステム構成が正しいか確認します。 |
GuestOS.AuditConfig.AutoShutdown |
インスタンスの Audit サービス構成ファイルに高リスクのパラメーター構成があります。Audit サービスログを保存するファイルシステムが領域不足になると、オペレーティングシステムは自動的にシャットダウンします。再起動後、Audit サービスログが継続的に生成されるため、オペレーティングシステムが繰り返しシャットダウンする可能性があります。
返された結果の属性:
|
必要に応じて Audit サービス構成の構成項目を変更してください。詳細については、「ディスク容量不足による自動シャットダウンを防ぐために auditd サービス構成を変更する方法」をご参照ください。 |
|
GuestOS.LimitsFile.UnreasonableConfig |
インスタンスの 異常なパラメーターの例:
返された結果の属性:
|
|
||
|
GuestOS.EnormousPageSize.UnreasonableConfig |
インスタンスのシステムファイル
返された結果の属性:
|
必要に応じてヒュージページの数を変更してください。詳細については、「Linux インスタンスでヒュージページを調整する方法」をご参照ください。 |
||
|
GuestOS.SELinuxService.Enabled |
インスタンスで SELinux サービスが有効になっており、インスタンスへの SSH 接続が妨げられる可能性があります。 |
SELinux を一時的または永続的に無効にしてください。詳細については、「SELinux が有効な Linux インスタンスで SSH 接続が失敗する」をご参照ください。 |
||
|
GuestOS.NvmeIOTimeout.UnreasonableConfig |
インスタンスのシステムファイルで Non-Volatile Memory Express (NVMe) ディスク用に構成された I/O 読み取り/書き込みタイムアウト期間が短い。これにより、I/O タイムアウト後に NVMe ディスクが読み取り専用になり、データ書き込みに失敗する可能性があります。
返された結果の属性:
|
必要に応じて値を 4294967295 に変更してください。詳細については、「Linux ECS インスタンスの NVMe ディスクが無効な I/O タイムアウトパラメーターのために利用できない場合はどうすればよいですか?」をご参照ください。 |
||
|
GuestOS.SysctlUnknownNmiPanic.Enabled |
インスタンスのカーネルのマスク不可能な割り込み構成が不適切です。これにより、インスタンスがマスク不可能な割り込みに遭遇したときに、予期しないカーネルパニックとインスタンスの再起動が発生する可能性があります。
返された結果の属性:
|
必要に応じて値を 0 に変更してください。詳細については、「kernel.unknown_nmi_panic が Linux インスタンスの異常な再起動を引き起こすのはなぜですか?」をご参照ください。 |
||
|
GuestOS.NetworkInterfaceMultiQueue.Disabled |
インスタンス上の 1 つ以上の NIC でマルチキュー機能が無効になっており、ネットワークパフォーマンスに影響を与える可能性があります。
返された結果の属性:
|
必要に応じてマルチキューを有効にしてください。詳細については、「NIC マルチキュー」をご参照ください。 |
||
|
GuestOS.SysctlIPv4TCPSACK.Disabled |
インスタンスで
返された結果の属性:
|
必要に応じて値を 1 に変更してください。 |
||
|
GuestOS.SysctlIPv4TCPTWRecycle.Enabled |
インスタンスの NAT 関連のカーネルパラメーターが誤って構成されています。これにより、インスタンスへの SSH 接続が妨げられ、インスタンス上の HTTP サービスへのアクセスが異常になります。
返された結果の属性:
|
必要に応じて値を 0 に変更してください。NAT 環境でカーネルパラメーターを修正する方法については、「Linux ECS インスタンスの一般的なカーネルネットワークパラメーターと FAQ」をご参照ください。 |
||
|
GuestOS.SysctlIPv4TCPTWReuse.Disabled |
インスタンスで TIME-WAIT ソケットの再利用機能が無効になっています。TIME-WAIT 状態のソケットは新しい TCP 接続に使用できません。これにより、インスタンスがリクエストを送信するときのネットワークパフォーマンスに影響を与える可能性があります。
返された結果の属性:
|
|
||
|
GuestOS.SysctlNetfilterNfMaxConnections.Unreasonable |
インスタンスの過去のシステムログには、一定期間内のエラーログが含まれています。この問題は、NAT アドレス変換をサポートするためにネットワーク接続エントリを追跡する
返された結果の属性:
|
必要に応じて、インスタンスのカーネル構成ファイルでこれらの 2 つのパラメーターの値を変更し、システムの状態を確認してください。詳細については、「ECS Linux インスタンスの一般的なカーネルネットワークパラメーターと FAQLinux ECS インスタンスの一般的なカーネルネットワークパラメーターと FAQ」をご参照ください。 |
||
|
GuestOS.PidMax.TooSmall |
インスタンスで実行中のプロセスの数が最大プロセス数 (
返された結果の属性:
|
|
||
|
GuestOS.SysctlTcpMaxTwBuckets.Unreasonable |
インスタンスの過去のシステムログには、一定期間内のエラーログが含まれています。この問題は、インスタンス上の TIME_WAIT 接続が多すぎると、予期しない切断や新しい接続への応答の失敗を引き起こし、インスタンスへのアクセスやサービスの応答に影響を与えるために発生します。
返された結果の属性:
|
この問題は通常、 |
||
|
GuestOS.SystemUserPwd |
システムアカウントとパスワードの設定を確認します。 |
GuestOS.SystemUser.MissingInfo |
インスタンスのシステムアカウントが存在しないため、インスタンスへのログインに失敗する可能性があります。
返された結果の属性:
|
必要に応じてアカウント情報を追加してください。欠落しているシステムユーザーを確認する方法については、「Linux インスタンスに重要なシステムユーザーが存在しない」をご参照ください。 |
|
GuestOS.SystemUserFile.NotUnixFormat |
インスタンス上のシステムアカウントファイルの形式が正しくないため、インスタンスへのログインに失敗する可能性があります。
返された結果の属性:
|
必要に応じてファイル形式を変更してください。詳細については、「Linux インスタンス上の非 Unix 形式のファイルの修復」をご参照ください。 |
||
|
GuestOS.SystemUserFile.InvalidExtensionAttribute |
インスタンス上のシステムアカウントファイルの拡張属性が正しくありません。これにより、一部のインスタンス機能が期待どおりに動作しなくなる可能性があります。たとえば、ECS コンソールでの root アカウントのパスワード変更が有効にならない場合があります。
返された結果の属性:
|
必要に応じてファイル形式を変更してください。詳細については、「Linux インスタンス上の非 Unix 形式のファイルの修復」をご参照ください。 |
||
|
GuestOS.FileSystems |
ファイルシステムの状態を確認します。 |
GuestOS.Filesystems.UUIDConflicts |
インスタンスには重複した UUID を持つファイルシステムが含まれており、これによりシステムが起動中に予期しないファイルシステムを自動的にマウントする可能性があります。これにより、起動の失敗や予期しない動作が発生する可能性があります。 同一 UUID を持つファイルシステムの例:
返された結果の属性:
|
インスタンスの virtio ドライバーのバージョンを確認します。 ファイルシステムの UUID を変更する方法については、「ディスクの UUID の変更」をご参照ください。 |
|
GuestOS.FstabFile.InvalidFormatExists |
インスタンスの 例:
返された結果の属性:
|
必要に応じて
|
||
|
Windows ファイアウォールの状態チェック |
インスタンスの
返された結果の属性:
|
必要に応じて、存在しないデバイスを
|
||
|
GuestOS.FstabFile.LossMountDevice |
インスタンスには
返された結果の属性:
|
ディスクのマウント属性を変更します。詳細については、「Linux インスタンスでの /etc/fstab エラーによる起動失敗のトラブルシューティング」をご参照ください。 |
||
|
GuestOS.FileSystems.PartitionUnaligned |
インスタンスのディスクには、推奨される 2,048 セクターにアライメントされていないパーティションがあります。ディスクのサイズが変更されると、アライメントされていないパーティションのために Linux での自動パーティション拡張操作が失敗し、ファイルシステムの利用可能な領域が増加しない結果となる可能性があります。
返された結果の属性:
|
アライメントされていないディスクパーティションを修正します。詳細については、「クラウドディスクのサイズ変更後に growpart を使用して GPT パーティションを拡張できない場合の対処方法」をご参照ください。 |
||
|
GuestOS.FstabFile.IncorrectType |
インスタンスの
返された結果の属性:
|
|
||
|
GuestOS.Mountpoint.Multiple |
インスタンスの
返された結果の属性:
|
|
||
|
GuestOS.NetworkStatus |
ネットワーク構成と状態を確認します。 |
GuestOS.Network.InvalidNetmask |
インスタンスの IPv4 アドレスまたは対応するサブネットマスクが誤って構成されているため、IP アドレス構成が無効になり、インスタンスへの接続に失敗します。
返された結果の属性:
|
必要に応じてサブネットマスクを変更してください。詳細については、「Linux ECS インスタンスの静的 IP アドレスの構成方法」をご参照ください。 |
|
GuestOS.Network.InvalidDefaultRoute |
インスタンスにデフォルトルートが構成されていないため、インスタンスへのアクセスに失敗する可能性があります。
返された結果の属性:
|
NIC またはシステムルーティング構成を変更して、必要なルーティングルールを追加します。詳細については、「Linux インスタンスからパブリック IP アドレスにアクセスすると「Network is unreachable」エラーメッセージが表示される場合の対処方法」をご参照ください。 |
||
|
GuestOS.DHCPService.Disabled |
インスタンスの NIC の DHCP サービスプロセスが無効になっています。これにより、リース期限切れ後にインスタンスの IP アドレスが更新されず、ネットワークの中断が発生する可能性があります。
返された結果の属性:
|
DHCP サービス構成を確認します。詳細については、「Linux ネットワークサービスの問題のトラブルシューティング」をご参照ください。 |
||
|
GuestOS.Udev.MacAddressNotExist |
インスタンスのカーネルにおける動的デバイス管理のための udev ルールに、MAC アドレスが NIC の実際の構成と一致しない残存エントリが含まれています。この不一致により、インスタンスのネットワークが誤動作したり、予期しないネットワークデバイスの命名が行われたりする可能性があります。
返された結果の属性:
|
MAC アドレスとネットワークインターフェース名の不一致など、一貫性のない udev ルールを削除します。詳細については、「複数のネットワークインターフェースを持つ Linux インスタンスでネットワークインターフェース名のドリフトを解決する方法」をご参照ください。 |
||
|
GuestOS.DHCPService.CustomPort |
特定のバージョンの CentOS または RHEL 7 を実行している ECS インスタンスには、4.2.5-60 より前のバージョンの DHClient が含まれています。これらの古いバージョンにはバグがあり、ポート 67、68、546、547 以外のポートでリッスンする可能性があります。ECS インスタンス上の他のサービスやプロセスもこれらのポートを使用している場合、競合が発生し、他のサービスやプロセスが起動に失敗したり、利用できなくなったりする可能性があります。
返された結果の属性:
|
DHClient サービスのバージョンを速やかにアップグレードしてください。詳細については、「CentOS または RHEL 7 インスタンスでサービスを起動する際のポート競合」をご参照ください。 |
||
|
GuestOS.NetworkConfig.InvalidInterface |
インスタンスのネットワーク構成ファイルに存在しないネットワークインターフェースが指定されているため、システムネットワークサービスが起動に失敗したり、異常に実行されたりする可能性があります。 この問題は、ネットワーク構成ファイルに存在しないネットワークインターフェースが指定されているために発生します。考えられる原因は次のとおりです:
返された結果の属性:
|
必要な ENI を追加するか、存在しない ENI の構成ファイルを削除します。 |
||
|
GuestOS.Firewall |
システムファイアウォールの状態を確認します。 |
GuestOS.NetworkFirewall.Enabled |
インスタンスのファイアウォール (iptables 設定) が有効になっています。インスタンスがファイアウォールを有効にし、外部アクセスをブロックするルールを設定している場合、インスタンスへの接続が失敗する可能性があります。 |
必要に応じてファイアウォール構成を変更してください。詳細については、「Linux でのシステムファイアウォールの管理」をご参照ください。 |
|
GuestOS.CloudInitService |
cloud-init の状態を確認します。 |
GuestOS.CloudinitService.BadDriverStatus |
インスタンスの cloud-init ドライバーが異常であり、システム初期化フェーズでシステム構成が正しく実行されず、インスタンスへのアクセスに失敗する可能性があります。
返された結果の属性:
|
必要に応じて cloud-init を確認して起動してください。詳細については、「cloud-init のインストール」をご参照ください。 |
|
GuestOS.CloudinitService.StartFailed |
インスタンスの cloud-init サービスが期待どおりに起動せず、システム構成の失敗やインスタンスへのアクセス不能を引き起こす可能性があります。 |
VNC を使用してインスタンスにログインし、cloud-init のシステムログを確認して、インスタンスを再起動してください。 |
||
|
GuestOS.SSHServiceStatus |
SSH サービスの状態を確認します。 |
GuestOS.SSH.ForbiddenRootLogin |
インスタンスの SSH サービスが root アカウントのログインを禁止しているため、root アカウントが SSH 経由でインスタンスにアクセスできません。
返された結果の属性:
|
root のリモートログインの問題を修正します。詳細については、「Linux インスタンスへの SSH 接続で「Permission denied, please try again」エラーを解決する」をご参照ください。 |
|
GuestOS.SSH.MissingCriticalFileOrDirectory |
インスタンスの SSH サービスに重要なファイルまたはディレクトリが欠落しているため、SSH 経由でインスタンスにアクセスできません。
返された結果の属性:
|
SSH のディレクトリとファイルを再構成します。詳細については、「Linux インスタンスで必要な SSH ファイルの検証」をご参照ください。 |
||
|
GuestOS.SSH.IncorrectSSHFilePermission |
SSH サービスが依存するファイルのアクセス権限が不適切に構成されているため、インスタンスへの SSH アクセスが妨げられています。
返された結果の属性:
|
必要に応じて SSH のディレクトリとファイルを再構成してください。詳細については、「Linux インスタンスで必要な SSH ファイルの検証」をご参照ください。 |
||
|
GuestOS.SSH.ListeningPortMismatchWithConfig |
sshd プロセスがリッスンしているアドレスとポートが、構成ファイルのものと一致しません。この不一致により、期待されるアドレスとポートへの SSH 接続が失敗する可能性があります。 sshd プロセスがリッスンしているアドレスとポートが、
返された結果の属性:
|
実際のニーズに基づいて sshd 構成ファイルのリッスンアドレスとポートを変更し、変更を適用するために sshd プロセスを再起動してください。 詳細については、「不正な SSH 権限が Linux インスタンスへのリモート接続をブロックする」をご参照ください。 |
||
|
GuestOS.TimeSyncService |
時刻同期サービスの状態を確認します。 |
GuestOS.TimeSyncService.Disabled |
インスタンスの時刻同期サービスが正常に動作していないか、誤って構成されています。これにより、システム時刻が実際の標準時刻からずれてしまい、インスタンス上の一部のアプリケーションの正常な動作に影響を与える可能性があります。
返された結果の属性:
|
必要に応じて時刻同期サービス構成を変更してください。 詳細については、「時刻同期」をご参照ください。 |
|
GuestOS.OSOOM |
OOM エラーが発生したかどうかを確認します。 |
GuestOS.Memory.OOM |
インスタンスのゲスト OS 内で OOM エラーが発生します。 最新の OOM インシデントのタイムスタンプと詳細ログの例:
|
インスタンスの現在のメモリサイズが、その上で実行されているビジネスをサポートするのに十分であるか確認してください。必要に応じて、構成をスペックアップしてインスタンスのメモリを増やしてください。 OOM の問題を分析および解決するには、「Linux インスタンスの Out of Memory 問題のトラブルシューティング」をご参照ください。 |
Windows オペレーティングシステム構成の診断項目と結果
|
メトリック ID |
メトリックの説明 |
結果項目 ID |
項目の説明 |
推奨される操作 |
|
GuestOS.WinCPUUtil |
CPU 使用率が高すぎないか確認します。 |
GuestOS.CPU.HighUtilization |
インスタンスの合計 CPU 使用率が 80% を超えています。 CPU 使用率が最も高い上位 5 つのプロセスを以下に示します。それらが期待どおりに実行されているか確認してください。
返された結果の属性:
|
CPU プロセスが異常であるか確認します。通常のビジネス運用によって引き起こされる場合は、ECS 構成をスペックアップしてください。 単一 CPU の高い使用率については、「Windows インスタンスの高い CPU 使用率のトラブルシューティング」をご参照ください。 |
|
GuestOS.WinCoreCPU.HighUtilization |
インスタンスには、使用率が 85% を超える CPU が 1 つ以上あります。 使用率が 85% を超える CPU に関する情報を以下に示します。プロセスが期待どおりに実行されているか確認してください。
返された結果の属性:
|
プロセスが期待どおりに実行されているか確認します。単一 CPU の高い使用率については、「Windows インスタンスの高い CPU 使用率のトラブルシューティング」をご参照ください。 |
||
|
GuestOS.WinMemoryUtil |
メモリ使用量が高すぎないか確認します。 |
GuestOS.WinMemory.HighUtilization |
合計メモリ使用量が 80% を超えています。 メモリ使用量が最も高い上位 5 つのプロセスの例:
返された結果の属性:
|
不要なサービスやプロセスを無効にします。高いメモリ使用量の分析については、「Windows のメモリ分析ツール」をご参照ください。 |
|
GuestOS.WinMemory.LicenseCorrupted |
Windows ライセンスデータベースの破損または誤構成により、タスクマネージャーでハードウェア予約メモリが異常に高くなり、高いメモリ使用量を引き起こします。
返された結果の属性:
|
Windows ライセンスデータベースを復元し、インスタンスを再起動します。 破損した Windows ライセンスデータベースの修正については、「ハードウェア用に予約されたメモリが過剰なために Windows インスタンスが遅延する場合の対処方法」をご参照ください。 |
||
|
GuestOS.WinSysDiskUtil |
システムディスクの使用率が高すぎないか確認します。 |
GuestOS.WinFileSystem.InsufficientSpace |
システムディスク (C:) の残りの領域が不足しているため、応答が遅くなったり、起動に失敗したりする可能性があります。
返された結果の属性:
|
必要に応じてシステムディスクのサイズを変更するか、インスタンスタイプをスペックアップしてください。 詳細については、「概要」をご参照ください。 |
|
GuestOS.WinSystemConfig |
重要なシステム構成が正しいか確認します。 |
GuestOS.WinOSVersion.Low |
ゲスト OS のバージョンは、Alibaba Cloud と Microsoft によってメンテナンスされなくなりました。
返された結果の属性:
|
システムを再インストールし、新しい Windows バージョンにスペックアップしてください。詳細については、「システムディスク (OS) の置き換え」または「OS 移行」をご参照ください。 |
|
GuestOS.VirtIOVersion.Low |
インスタンスのオペレーティングシステムは以前のバージョンの virtio ドライバーを使用しており、オンラインディスクサイズ変更が妨げられています。
返された結果の属性:
|
必要に応じて virtio のバージョンをスペックアップしてください。 詳細については、「Windows インスタンスの virtio ドライバーの更新」をご参照ください。 |
||
|
GuestOS.WinCrashDump.Disabled |
インスタンスでクラッシュダンプ機能が無効になっています。システムが異常な再起動やブルースクリーンを経験したときに、トラブルシューティングのためのエラー情報を保存できません。
返された結果の属性:
|
必要に応じてクラッシュダンプ機能を有効にしてください。 Windows でこの機能を有効にする方法については、「カーネルクラッシュダンプの有効化または無効化」をご参照ください。 |
||
|
GuestOS.KMSService.MismatchedKey |
インスタンスは KMS を使用して Windows オペレーティングシステムをアクティベートしますが、KMS クライアントが使用するアクティベーションキーが Windows のバージョンと一致しないため、アクティベーションに失敗します。
返された結果の属性:
|
Windows のアクティベーションチュートリアルに従って、Windows のバージョンに一致するキーを選択してください。 KMS を使用して Windows をアクティベートする方法については、 「KMS ドメイン名で Windows をアクティベートする」をご参照ください。 |
||
|
GuestOS.KMSService.Disconnected |
インスタンスが KMS アクティベーションサーバーに接続できないため、アクティベーションに失敗します。
返された結果の属性:
|
インスタンスのファイアウォール構成またはサードパーティソフトウェアが KMS アクティベーションサーバーへのアクセスをブロックしていないか確認し、必要に応じて関連する構成を変更してください。 KMS アクティベーションサーバーを確認する方法については、「ECS インスタンスでの Windows アクティベーション失敗の解決」をご参照ください。 |
||
|
GuestOS.SPPSVCService.Unhealthy |
インスタンスの Software Protection Platform Service (SPPSVC.exe) が起動または実行できないため、Windows のアクティベーションやアクティベーション設定へのアクセスが妨げられています。
返された結果の属性:
|
Windows ライセンス認証のチュートリアルに従って SPPSVC.exe サービスを再起動し、そのスタートアップの種類を [自動 (遅延開始)] に変更して、次回サービスが自動的に開始されるようにします。 |
||
|
GuestOS.SystemPatch.Incorrect |
インスタンスに誤ったシステムパッチがインストールされているため、異常な再起動やシステムクラッシュが発生する可能性があります。 誤ったパッチの例:
返された結果の属性:
|
必要に応じて、適切な期間内に誤ったパッチをアンインストールしてください。 詳細については、「Windows ECS インスタンスからシステムパッチをアンインストールする」をご参照ください。 |
||
|
GuestOS.WinFiles.Missing |
インスタンスのシステムディレクトリ (
|
必要に応じてシステムファイルを復元してください。詳細については、「Windows インスタンスにリモートログインするとブラックスクリーンが表示され、デスクトップにアクセスできない場合の対処方法」をご参照ください。 |
||
|
GuestOS.OperatingSystem.Unactivated |
インスタンスの Windows オペレーティングシステムがアクティベートされていないため、特定の Windows パーソナライゼーションサービスが利用できなくなる可能性があります。 |
正しい KMS キーを使用して Windows をアクティベートしてください。詳細については、「Windows システム ECS インスタンスのアクティベーションに失敗しました」をご参照ください。 |
||
|
GuestOS.WinSystemInit |
システム初期化の状態を確認します。 |
GuestOS.SysPrepService.Interrupted |
インスタンスの作成中に、インスタンスが早すぎる再起動のためにシステム準備サービス (SysPrep) の初期化プロセスが中断されました。オペレーティングシステムのいくつかの重要な構成が不完全であり、インスタンスの起動に失敗する可能性があります。
返された結果の属性:
|
システム初期化が不完全なため、システムディスクを置き換えてシステムを再インストールするか、このインスタンスを置き換えるために別のインスタンスを作成する必要があります。 詳細については、「システムディスク (OS) の置き換え」または「システムディスクの再初期化」をご参照ください。 |
|
GuestOS.SysPrepService.InitFailed |
インスタンスの作成中にシステム初期化プロセスが異常に完了したため、インスタンスが正常に動作しない可能性があります。 次のエラーメッセージが表示されます:
返された結果の属性:
|
システムディスクを置き換えてシステムを再インストールするか、このインスタンスを置き換えるために別のインスタンスを作成してください。 詳細については、「システムディスク (OS) の置き換え」または「システムディスクの再初期化」をご参照ください。 |
||
|
GuestOS.WinSystemUser |
管理者アカウントを確認します。 |
GuestOS.WinAdministrator.NotExist |
Administrator アカウントが存在しないため、サービスにアクセスできない可能性があります。
返された結果の属性:
|
必要に応じて Administrator アカウントを有効にしてください。 |
|
GuestOS.WinNetworkStatus |
ネットワーク構成と状態を確認します。 |
GuestOS.WinNetworkInterfaceDriver.Disabled |
インスタンスの NIC が利用できないため、インスタンスへの接続が妨げられる可能性があります。 NIC が無効になっています。
返された結果の属性:
|
必要に応じて NIC の状態を修復してください。 NIC の状態を確認および修復する方法については、「ステップ 7:ネットワークの確認」をご参照ください。 |
|
GuestOS.WinRDPPort.Closed |
インスタンスのシステムポートが開いていないか、ファイアウォールが有効になっているため、RDP 経由でインスタンスにアクセスできません。
返された結果の属性:
|
必要に応じてこのポートの開閉状態を変更してください。 RDP 接続を許可するためにポート 3389 を有効にする方法については、「Windows ECS インスタンスでリモートデスクトップサービスを有効にする方法」をご参照ください。 |
||
|
GuestOS.WinDHCPService.Disabled |
インスタンスの NIC で DHCP 構成が無効になっているため、サービスにアクセスできない可能性があります。
返された結果の属性:
|
必要に応じてこのポートの開閉状態を変更してください。 |
||
|
GuestOS.WinNetworkInterface.LackIPV4Address |
インスタンスの NIC に IPv4 アドレスがないため、サービスにアクセスできない可能性があります。
返された結果の属性:
|
インスタンスで DHCP が有効になっているか、静的 IP アドレスが構成されているか確認します。 |
||
|
GuestOS.NetworkProxy.Enabled |
インスタンス用に構成されたネットワークプロキシにより、サービスにアクセスできない可能性があります。
返された結果の属性:
|
必要に応じてネットワークプロキシを無効にしてください。 |
||
|
GuestOS.WinPort.Conflict |
インスタンスの RDP ポートが別のプロセスによって使用されているため、ポート競合が発生し、RDP 経由でインスタンスにアクセスできなくなる可能性があります。
返された結果の属性:
|
VNC 経由でログインし、RDP ポートを変更します。詳細については、「Windows インスタンスでの RDP ポート競合の解決」をご参照ください。 |
||
|
GuestOS.WinDiskStatus |
Windows ディスクの状態を確認します。 |
GuestOS.SystemDisk.Corrupted |
システムディスク (C:) が異常であり、再起動の失敗やドライバーのインストールの問題を引き起こす可能性があります。
返された結果の属性:
|
適切な期間内にシステムディスクを回復します:
|
|
GuestOS.VirtIODriver.DiskIDConflicts |
古い virtio ドライバーが原因でインスタンスに重複したディスク ID があり、ディスクリセット操作中にデータ損失を引き起こす可能性があります。 同じ ID を持つディスクの例:
返された結果の属性:
|
virtio ドライバーを速やかにスペックアップしてください。 詳細については、「Windows インスタンスの virtio ドライバーの更新」をご参照ください。 |
||
|
GuestOS.WinFirewall |
Windows ファイアウォールの状態を確認します。 |
GuestOS.WinFirewall.Enabled |
ファイアウォールが有効になっているため、サービスにアクセスできない可能性があります。
返された結果の属性:
|
必要に応じてファイアウォールポリシー構成を変更してください。詳細については、「Windows のファイアウォールルールの構成」をご参照ください。 |
|
GuestOS.WinDriverStatus |
重要な Windows ドライバーの状態を確認します。 |
GuestOS.DiskFilterDriver.Vestigital |
残存するディスクフィルタードライバーファイルにより、インスタンスが新しくアタッチされたディスクを認識できなくなる可能性があります。
返された結果の属性:
|
無効なディスクフィルタードライバーをクリアし、インスタンスを再起動します。詳細については、「Windows インスタンスのレジストリに残存するディスクドライバーエントリを確認する方法」をご参照ください。 |
|
GuestOS.VirtIODriver.Low |
virtio ドライバーのバージョンは {VirtioVersion} であり、古いためブルースクリーン、ネットワークパケット損失、ディスクデータ損失などの問題を引き起こす可能性があります。
|
virtio ドライバーのバージョンを速やかにアップグレードしてください。 詳細については、「Windows インスタンスの virtio ドライバーの更新」をご参照ください。 |
||
|
Instance.Type.Xen |
インスタンスタイプが古い (Xen ベース) ため、OS の起動失敗やデバイスマネージャーの問題を引き起こす可能性があります。
返された結果の属性:
|
必要に応じて新世代インスタンスタイプにスペックアップしてください。 詳細については、「サブスクリプションインスタンスのインスタンスタイプのスペックアップ」または「従量課金インスタンスタイプの変更」をご参照ください。 |
||
|
GuestOS.WinSystemProcess |
重要な Windows システムプロセスの状態を確認します。 |
GuestOS.RDPService.Unavailable |
RDP サービスが無効になっているか破損しているため、RDP アクセスが妨げられています。 |
必要に応じて RDP サービスを再起動または再インストールしてください。 詳細については、「Windows ECS インスタンスでリモートデスクトップサービスを有効にする方法」をご参照ください。 |
|
GuestOS.RDP.BlockedByFirewall |
ファイアウォールが RDP アクセスをブロックしているため、RDP 接続が妨げられる可能性があります。
返された結果の属性:
|
ファイアウォールを無効にするか、RDP (ポート 3389) アクセスを許可するルールを追加してください。 Windows で RDP アクセスを許可するには、「Windows のファイアウォールルールの構成」をご参照ください。 |
||
|
GuestOS.WSUS.Disconnected |
Windows Server Update Services (WSUS) が接続できないため、OS の更新が妨げられる可能性があります。 |
必要に応じて WSUS を再構成してください。 |
||
|
GuestOS.Metaserver.Disconnected |
メタデータサービス (metaserver) が接続できないかタイムアウトするため、インスタンスメタデータにアクセスできなくなる可能性があります。 |
ファイアウォールが 100.100.100.200 をブロックしているか確認します。ブロックしている場合は、メタデータサービスにアクセスする前に許可してください。 詳細については、「インスタンスメタデータ」をご参照ください。 |
||
|
GuestOS.WinLicence.Expired |
リモートデスクトップサービスライセンスの有効期限が切れているため、RDP が誤動作しています。 |
VNC 経由でログインし、リモートデスクトップサービスライセンスを購入するか、必要に応じてサービスをアンインストールしてください。 Windows リモートデスクトップライセンスの問題については、「リモートデスクトップサービスに有効なライセンスがないために RDP を使用して Windows ECS インスタンスに接続できない場合の対処方法」をご参照ください。 |
||
|
GuestOS.WinThirdPartSoftware |
サードパーティソフトウェアのインストール状態を確認します。 |
GuestOS.Operation.InfluencedByAntivirusProcess |
サードパーティ製ウイルス対策ソフトウェアがインストールされているため、管理操作 (パスワードリセットやリモート接続など) の失敗やインスタンスの例外が発生する可能性があります。 インストールされているウイルス対策ソフトウェアの例:
返された結果の属性:
|
必要に応じて対応するソフトウェアをアンインストールしてください。 |
ユーザーの動作追跡の診断項目と結果
|
メトリック ID |
メトリックの説明 |
結果項目 ID |
結果の説明 |
推奨される操作 |
|
Instance.UnexpectedSgCreationOrDeletion |
指定された期間内にセキュリティグループの作成と削除に関連する操作を RAM ロールに基づいてクエリします。AliyunServiceRoleForECSSelfService ロールが存在しない場合は、自動的に作成されます。 |
Instance.UnexpectedSgCreationOrDeletion.Log |
セキュリティグループの作成と削除に関連する操作を表示します。
|
ActionTrail で詳細を表示します。 |
|
Instance.UnexpectedSgMember |
指定された期間内にインスタンスのセキュリティグループへの関連付けまたは関連付け解除に関連する操作を RAM ロールに基づいてクエリします。AliyunServiceRoleForECSSelfService ロールが存在しない場合は、自動的に作成されます。 |
Instance.UnexpectedSgMember.Log |
インスタンスのセキュリティグループへの関連付けまたは関連付け解除に関連する操作を表示します。
|
ActionTrail で詳細を表示します。 |
|
Instance.UnexpectedFee |
指定された期間内にインスタンスの課金に関連する操作を RAM ロールに基づいてクエリします。AliyunServiceRoleForECSSelfService ロールが存在しない場合は、自動的に作成されます。 |
Instance.UnexpectedFee.Log |
インスタンスの課金に関連する操作を表示します。
|
ActionTrail で詳細を表示します。 |
|
Instance.UnexpectedCreationOrRelease |
指定された期間内にインスタンスの作成と削除に関連する操作を RAM ロールに基づいてクエリします。AliyunServiceRoleForECSSelfService ロールが存在しない場合は、自動的に作成されます。 |
Instance.UnexpectedCreationOrRelease.Log |
インスタンスの作成と削除に関連する操作を表示します。
|
ActionTrail で詳細を表示します。 |
|
Instance.UnexpectedRunningStatus |
指定された期間内にインスタンスの実行状態に影響を与える操作を RAM ロールに基づいてクエリします。AliyunServiceRoleForECSSelfService ロールが存在しない場合は、自動的に作成されます。 |
Instance.UnexpectedRunningStatus.Log |
インスタンスの実行状態に影響を与える操作を表示します。
|