すべてのプロダクト
Search
ドキュメントセンター

Elastic Compute Service:従量課金 ECS インスタンスのインスタンスタイプの変更

最終更新日:Aug 21, 2026

インスタンスタイプを変更することで、従量課金 Elastic Compute Service (ECS) インスタンスの vCPU とメモリを調整できます。

前提条件

インスタンスが以下の要件を満たしている必要があります。

  • インスタンスが従量課金インスタンスであり、スポットインスタンスではないこと。

  • インスタンスは [実行中] (Running) または [停止済み] (Stopped) 状態です。

    重要
    • 従量課金インスタンスを停止するときは、[停止モード] を [標準モード] に設定します。[節約モード] を選択した場合、コンピューティングリソース (vCPU とメモリ) が回収され、リソース不足が原因でインスタンスの再起動に失敗する可能性があります。

    • インスタンスの停止により、サービス中断が発生する可能性があります。オフピーク時間にインスタンスを停止してください。

  • インスタンスファミリーがインスタンスタイプの変更をサポートしていること。詳細については、「インスタンスタイプ変更の制限と事前チェック」をご参照ください。

制限事項

  • vCPU とメモリは、インスタンスタイプの変更によってのみ同時に変更できます。個別に変更することはできません。

  • インスタンスタイプの変更や帯域幅の変更など、別の設定変更が進行中の場合、インスタンスタイプを変更することはできません。

  • インスタンスタイプの変更は vCPU とメモリにのみ影響します。オペレーティングシステム、アプリケーションコード、データは変更されません。

課金

インスタンスタイプを変更した後、インスタンスは新しいインスタンスタイプに基づいて課金されます。詳細については、「従量課金」をご参照ください。

手順

警告

インスタンスタイプの変更には再起動が必要なため、サービスが中断されます。オフピーク時間にこの操作を実行してください。

  1. ECS コンソール - インスタンスに移動します。

  2. 上部メニューで、対象リソースのリージョンとリソースグループを選択します。 地域

  3. インスタンス ID をクリックして詳細ページに移動します。右上隅で、[すべてのアクション] > [アップグレード/ダウングレード] > [インスタンスタイプの変更] を選択します。

    説明

    インスタンスタイプを一括で変更するには、インスタンスページで複数のインスタンスを選択し、[その他] > [アップグレード/ダウングレード] > [インスタンスタイプの変更] を選択します。 詳細については、「一括操作」をご参照ください。

  4. 別のインスタンスタイプを選択します。

    説明

    利用可能なインスタンスタイプは、[新しいインスタンスタイプ] ドロップダウンリストに表示されます。

  5. インスタンスのステータスに応じて操作します。

    • インスタンスが [停止済み] の場合、[インスタンスタイプの変更] ダイアログボックスで、変更後のインスタンスタイプを選択し、概算費用を確認して、[変更を確定] をクリックします。

    • インスタンスが[実行中]の場合:

      1. 概算費用を確認し、[インスタンスを停止して続行] をクリックします。

      2. [インスタンスの停止] ダイアログボックスで、[停止者] と [停止モード] を設定し、[確認] をクリックします。

        重要
        • [停止モード] を [標準モード] に設定します。[エコノミーモード (旧称: 停止済みインスタンスは課金しない)] を選択した場合、コンピューティングリソース (vCPU とメモリ) が解放され、リソース不足が原因でインスタンスの再起動に失敗することがあります。

        • インスタンスの停止により、サービス中断が発生する可能性があります。オフピーク時間にインスタンスを停止してください。

  6. インスタンスタイプの変更が完了したら、[インスタンスを起動して戻る] をクリックします。[インスタンスの起動] ダイアログボックスで、[確定] をクリックします。