O que fazer se o erro "Failed to start OpenSSh server daemon" for exibido?

Fenômeno do problema


Na instância ECS do sistema Linux, o serviço SSH (sshd.service) não pode ser iniciado. Execute systemctl status sshd.service para verificar o serviço SSH, e o erro "Failed to start OpenSSh server daemon" é exibido.

Status do sshd

Causas do problema


Esse problema pode ser causado pela porta do serviço SSH (22) estar ocupada.

Solução


Você pode resolver esse problema modificando o número da porta do serviço que está ocupando a porta 22 ou modificando a porta do serviço SSH conforme as necessidades do negócio.

1. Conecte-se remotamente à instância ECS via VNC.

2. Execute o seguinte comando para rodar o serviço SSH em modo de teste.

/sbin/sshd -d

As informações exibidas são as seguintes, indicando que a porta 22 está ocupada e o serviço SSH não pode ser iniciado.

3. Execute o seguinte comando para verificar o uso da porta 22.

ss -tunlp | grep 22

As informações exibidas são as seguintes, indicando que a porta 22 está ocupada pelo serviço Nginx.

Importante O fato de a porta 22 estar ocupada pelo serviço Nginx neste artigo é apenas um exemplo, consulte a situação real.

Nginx ocupa a porta 22

4. Você pode escolher uma solução adequada para resolver esse problema conforme suas necessidades.

4.1 Modificar o número da porta do serviço Nginx.

Execute o seguinte comando para abrir o arquivo de configuração nginx.conf.

vim /etc/nginx/nginx.conf

Altere o número da porta ocupada pelo Nginx para 80.

Modificar a porta ocupada pelo Nginx

Após pressionar a tecla Esc, digite :wq e pressione Enter para salvar e fechar o arquivo de configuração.

Execute o seguinte comando para reiniciar o serviço Nginx.

systemctl restart nginx

Execute o seguinte comando para reiniciar o serviço SSH.

systemctl restart sshd.service

4.2 Modificar o número da porta do serviço SSH.

Execute o seguinte comando para abrir o arquivo de configuração sshd_config.

vim /etc/ssh/sshd_config

Altere o número da porta do serviço SSH, por exemplo, para 2222.

Modificar a porta ocupada pelo SSH

Após pressionar a tecla Esc, digite :wq e pressione Enter para salvar e fechar o arquivo de configuração.

Execute o seguinte comando para reiniciar o serviço SSH

Artigos relacionados

Explorar mais ofertas especiais

  1. Short Message Service (SMS) e Serviço de E-mail

    Pacote de 50.000 e-mails a partir de USD 1,99, 120 mensagens curtas a partir de apenas USD 1,00

phone Fale Conosco
Oi, eu sou o assistente de IA da Alibaba Cloud!
Posso ajudar com perguntas e soluções.