Que faire si l'erreur « Failed to start OpenSSh server daemon » s'affiche.

Symptôme du problème


Sur une instance ECS sous Linux, le service SSH (sshd.service) ne peut pas démarrer. Exécutez la commande systemctl status sshd.service pour afficher l'état du service SSH. L'erreur « Failed to start OpenSSh server daemon » s'affiche.

Statut de sshd

Causes du problème


Ce problème peut être causé par l'occupation du port du service SSH (22).

Solution


Vous pouvez résoudre ce problème en modifiant le numéro de port du service qui occupe le port 22 ou en modifiant le port du service SSH selon vos besoins.

1. Connectez-vous à distance à l'instance ECS via VNC.

2. Exécutez la commande suivante pour lancer le service SSH en mode test.

/sbin/sshd -d

Les informations affichées sont les suivantes, indiquant que le port 22 est occupé et que le service SSH ne peut pas démarrer.

3. Exécutez la commande suivante pour vérifier l'utilisation du port 22.

ss -tunlp | grep 22

Les informations affichées sont les suivantes, indiquant que le port 22 est occupé par le service Nginx.

Important L'exemple de cet article montre le port 22 occupé par le service Nginx. Veuillez vous référer à votre situation réelle.

Ngnix occupe le port 22

4. Choisissez la solution appropriée en fonction de vos besoins.

4.1 Modifier le numéro de port du service Nginx.

Exécutez la commande suivante pour ouvrir le fichier de configuration nginx.conf.

vim /etc/nginx/nginx.conf

Remplacez le numéro de port occupé par Nginx par 80.

Modifier le port occupé par Ngnix

Après avoir appuyé sur la touche Échap, saisissez :wq et appuyez sur Entrée pour enregistrer et fermer le fichier de configuration.

Exécutez la commande suivante pour redémarrer le service Nginx.

systemctl restart nginx

Exécutez la commande suivante pour redémarrer le service SSH.

systemctl restart sshd.service

4.2 Modifier le numéro de port du service SSH.

Exécutez la commande suivante pour ouvrir le fichier de configuration ssh_config.

vim /etc/ssh/sshd_config

Modifiez le numéro de port du service SSH, par exemple à 2222.

Modifier le port occupé par SSH

Après avoir appuyé sur la touche Échap, saisissez :wq et appuyez sur Entrée pour enregistrer et fermer le fichier de configuration.

Exécutez la commande suivante pour redémarrer le service SSH.

Articles associés

Découvrir plus d'offres spéciales

  1. Short Message Service (SMS) et Service de messagerie

    50,000 email package starts as low as USD 1.99, 120 short messages start at only USD 1.00

phone Contacter
Hi, I'm Alibaba Cloud AI Assistant!
I can help with questions and solutions.