すべてのプロダクト
Search
ドキュメントセンター

Elastic Compute Service:ディスクのサイズ変更 (Linux)

最終更新日:Sep 18, 2026

ディスクの容量を拡張した後、追加された領域を使用するには、パーティションとファイルシステムの拡張が必要です。ディスクは縮小できないため、ストレージ要件を慎重に計画してください。

サイズ変更の概要

ディスクのサイズ変更には、主に 2 つのステップがあります:

  1. ECS コンソールでディスクのストレージを追加購入します。これは、より大きなハードドライブを購入したものの、まだインストールしていない状態に似ています。支払いが完了しても、サイズ変更プロセスは完了しません。

  2. インスタンスのオペレーティングシステムで新しい領域を利用可能にします。これは、システムがそれを認識して使用できるように、ハードドライブ上の新しい領域をフォーマットするようなものです。

image

ステップ 1:ディスク容量の増加

前提条件

次のいずれかの条件を満たしていることを確認してください。

  • ディスクが ECS インスタンスにアタッチされており、インスタンスの有効期限が切れておらず、[実行中]または[停止済み]の状態である必要があります。

  • ディスクが[アタッチ待ち]の状態である必要があります。

操作手順

  1. ECS コンソール - ブロックストレージに移動します。上部メニューで、対象のリージョンとリソースグループを選択します。

  2. サイズ変更するディスクを見つけ、ディスクの拡張操作列でクリックします。

  3. 操作ミスによるデータ損失を防ぐため、サイズ変更の前にディスクのスナップショットを作成してデータをバックアップすることを強くお勧めします。ターゲットディスクと注意事項を確認する ページで、ディスク情報を確認し、[スナップショットの作成] をクリックし、スナップショットの名前と保持期間を設定してから、[確認] をクリックします。

    重要

    スナップショットの使用には料金が発生します。

    image

  4. 対応列にスケーリング対応が表示されたら、拡張の確認をクリックします。

    スナップショットの作成に必要な時間は、ディスク上のデータ量や利用可能な帯域幅などの要因によって異なります。ECS コンソールのスナップショットページに移動し、進行 列で作成ステータスを確認できます。
  5. 変更方法とサイズを設定する ウィザードで、パラメーターを設定し、料金を確認してから、[OK] をクリックします。

    重要

    ディスクのサイズ変更を行うと、追加された容量に対して課金されます。

    パラメータ

    説明

    [拡張後の容量]

    新しい容量は、現在の容量よりも小さくすることはできません。

    [サイズ変更方法]

    • [オンラインサイズ変更] (推奨):ディスクの容量を増やした後、インスタンスを再起動する必要はありません。新しい容量は即座に有効になります。

    • [オフラインサイズ変更]:ディスクが[アタッチ待ち]の状態、インスタンスが[停止済み]の状態、またはオフラインリサイズのみをサポートする特定のインスタンスタイプを使用している場合は、この方法を使用します。

  6. サブスクリプションディスクの場合、支払いポップアップウィンドウに表示される 5 秒のカウントダウンが終了したら、支払いへ をクリックして支払いを完了します。支払いが完了したら、サイズ変更ワークフローに戻り、支払い完了 をクリックします。

    支払いを完了する前に支払い完了をクリックすると、サイズ変更プロセスが停止します。注文の支払いをクリックし、支払いを完了させてから、サイズ変更ワークフローに戻る必要があります。

ステップ 2:パーティションとファイルシステムの拡張

前提条件

  • ディスクが [アタッチ待ち] 状態の場合は、ECS インスタンスにアタッチする必要があります。

  • 前のステップでオフラインでのサイズ変更を使用してディスク容量を拡張し、ディスクが ECS インスタンスにアタッチされている場合は、インスタンスを再起動するか、起動する必要があります。

  • データディスクにファイルシステムが作成されていない場合は、「データディスクの初期化」の指示に従ってください。

重要

オンラインでのサイズ変更中に、次のすべての条件に該当する場合、グループ記述子テーブル (GDT) が誤った物理ブロックに書き込まれ、ビジネスデータが上書きされることでデータの破損が発生する可能性があります。ディスクのサイズを変更する前に、システムタイプに基づいてオペレーティングシステムを移行するか、カーネルをアップグレードしてください。

操作手順

ディスク容量を拡張した後、追加された領域を使用するには、パーティションとファイルシステムを拡張する必要があります。Alibaba Cloud は 2 つの方法を提供しています:

  • コンソールを使用して拡張する (推奨):Cloud Assistant を使用して、コンソールからパーティションとファイルシステムを拡張します。この方法は便利で、手動でコマンドを実行する必要がなくなります。

  • コマンドラインを使用して拡張する:インスタンスにログインし、手動でコマンドを実行してパーティションとファイルシステムを拡張します。この方法は柔軟性が高く、さまざまな状況に適用できます。

コンソールでの拡張 (推奨)

誤ってこのページを閉じてしまった場合は、インスタンス詳細ページの [ブロックストレージ] タブから操作ページに戻ることができます。
  1. [未割り当て] セクションで、[最後のパーティションとファイルシステムのスケールアウト] をクリックします。

    Cloud Assistant に権限を付与していない場合は、プロンプトが表示されたときに権限を付与する必要があります。
    ページにメッセージ ["Cloud Assistant query or execution failed"] または ["Instance OS Version Not Supported"] が表示された場合は、コマンドラインを使用して拡張する必要があります。

    image

  2. クラウドアシスタントによるパーティションおよびファイルシステムの拡張 ダイアログボックスで、[今すぐ実行] をクリックします。メッセージ [クラウドアシスタントによるパーティションおよびファイルシステムの拡張に成功しました。] が表示されたら、拡張は完了です。閉じる をクリックします。

    重要

    続行する前に、拡張の失敗を防ぐためにコマンドが正しいことを確認してください。

CLI での拡張

パーティションの拡張

重要

インスタンス詳細ページで OS バージョンを確認してください。CentOS 6 以前、OpenSUSE 42.3、Debian 8 以前の場合は、パーティションとファイルシステムをオフラインで拡張する必要があります。

  1. ECS インスタンスにログインします。

    1. ECS コンソール - インスタンスに移動します。上部メニューで、対象のリージョンとリソースグループを選択します。

    2. 対象インスタンスの詳細ページに移動します。右上隅にある 接続 をクリックし、ワークベンチ を選択します。プロンプトに従ってインスタンスにログインし、ターミナルを開きます。

  2. パーティションを拡張します。

    1. sudo lsblk を実行して、拡張するディスクのデバイス名とパーティション番号を確認します。

      $ sudo lsblk
      NAME   MAJ:MIN RM  SIZE RO TYPE MOUNTPOINT
      vda    253:0    0   50G  0 disk 
      ├─vda1 253:1    0    2M  0 part 
      ├─vda2 253:2    0  200M  0 part /boot/efi
      └─vda3 253:3    0 39.8G  0 part /
      vdb    253:16   0   40G  0 disk /data
      • 拡張するディスクにパーティションがない場合は、直接ファイルシステムを拡張できます。この例では、データディスク vdb にはパーティションがないため、パーティションを拡張する必要はありません。

      • 拡張するディスクの容量がパーティションの合計容量より大きい場合は、パーティションを拡張する必要があります。この例では、システムディスク vda の容量は 50 GiB で、3 つのパーティションが含まれています。パーティションの合計容量は 40 GiB であり、最後のパーティション vda3 を拡張する必要があります。

        重要

        ディスク上の最後のパーティションのみを拡張できます。

        次の表に、一般的なデバイスの命名規則とパーティション形式を示します。

        sudo lsblk コマンドが vgx 形式で出力を表示する場合、これはディスクパーティションが論理ボリュームマネージャー (LVM) によって管理されていることを示します。コンソールでディスク容量を拡張した後、LVM を使用して論理ボリュームを拡張する必要があります。

        デバイスタイプ

        デバイス名

        パーティション番号

        NVMe プロトコルを使用しないディスク

        形式は vd[a-z] です (例: vda (システムディスク)、vdbvdc)。

        形式は vd[a-z]<partition number> です。たとえば、vda3 の場合、パーティション番号は 3 です。

        NVMe 準拠のディスク

        形式は nvmeXn1 です (例: nvme0n1nvme1n1nvme2n1)。

        形式は nvmeXn1p<partition_number> です。たとえば、nvme0n1p1 の場合、パーティション番号は 1 です。

    2. 拡張ツールをインストールします。

      Alibaba Cloud Linux および CentOS
      type growpart || sudo yum install -y cloud-utils-growpart
      sudo yum update cloud-utils-growpart
      type sgdisk || sudo yum install -y gdisk
      Debian および Ubuntu
      sudo apt-get update
      sudo apt-get install -y cloud-guest-utils
      type sgdisk || sudo apt-get install -y gdisk
    3. コマンドを実行してパーティションを拡張します。

      コマンド内の <DeviceName><PartitionNumber>ステップ a で取得したデバイス名とパーティション番号に置き換えて、コマンドを実行します。

      重要

      デバイス名とパーティション番号の間にスペースを入れてください。

      sudo LC_ALL=en_US.UTF-8 growpart /dev/<DeviceName> <PartitionNumber>

      レスポンス内のキーワード CHANGED は、コマンドが正常に実行されたことを示します。コマンドが失敗した場合は、「パーティション拡張の一般的な問題」を参照してトラブルシューティングしてください。

      コマンドの LC_ALL=en_US.UTF-8 は、中国語システムのエンコーディングに対応するために使用される環境変数です。
  3. パーティションの拡張を確認します。

    sudo lsblk コマンドを実行します。パーティションの合計サイズがデバイスの容量と等しい場合、パーティションは正常に拡張されています。この例では、デバイス vda の容量とパーティションの合計サイズはどちらも 50 GiB です。次に、追加された領域を利用可能にするためにファイルシステムを拡張する 必要があります。

    $ sudo lsblk
    NAME   MAJ:MIN RM  SIZE RO TYPE MOUNTPOINT
    vda    253:0    0   50G  0 disk 
    ├─vda1 253:1    0    2M  0 part 
    ├─vda2 253:2    0  200M  0 part /boot/efi
    └─vda3 253:3    0 49.8G  0 part /
    vdb    253:16   0   40G  0 disk /data

ファイルシステムの拡張

  1. コマンド sudo lsblk -f を実行し、ファイルシステムを拡張する際に使用するため、拡張するディスクの対象デバイス名、ファイルシステムタイプ、およびマウントポイントを記録します。

    $ sudo lsblk -f
    NAME   FSTYPE LABEL UUID                                 MOUNTPOINT
    vda                                                      
    ├─vda1                                                   
    ├─vda2 vfat         7938-FA03                            /boot/efi
    └─vda3 ext4   root  33b46ac5-7482-4aa5-8de0-60ab4c3a4c78 /
    vdb    ext4         3d7a3861-da22-484e-bbf4-b09375894b4f /data                                     
    • デバイスにパーティションがある場合、対象デバイス名は最後のパーティションの名前です。この例では、システムディスク vda の場合、対象デバイス名vda3ファイルシステムタイプext4マウントポイント/ です。

    • デバイスにパーティションがない場合、対象デバイス名はデバイス名と同じです。たとえば、データディスク vdb の場合、対象デバイス名vdbファイルシステムタイプext4マウントポイント/data です。

  2. ファイルシステムを拡張します。

    • ext2、ext3、または ext4

      コマンドの <TargetDeviceName> 変数を 前のステップ の対象デバイス名に置き換えて、コマンドを実行します。

      sudo resize2fs /dev/<TargetDeviceName>
    • xfs

      コマンドの <MountPoint>前のステップ で取得したマウントポイントに置き換えて、コマンドを実行します。

      sudo xfs_growfs <MountPoint>
  3. ファイルシステムが拡張されたことを確認します。

    sudo df -Th コマンドを実行して、ファイルシステムのサイズ (出力の Size 列の値) がディスク容量と一致することを確認します。

    ファイルシステムが作成されると、メタデータを格納するために一部の容量が予約されます。したがって、ファイルシステムのサイズは、コンソールに表示される容量よりわずかに小さい場合があります。

課金

ディスクをサイズ変更すると、追加容量分が課金されます。追加容量の課金方法は、元のディスクと同じです。

  • サブスクリプションディスク: サブスクリプションディスクをサイズ変更すると、新しい容量に基づいて直ちに課金されます。サブスクリプションの残り期間について、旧容量と新容量の差額を支払う必要があります。

    差額 = (1 GB あたりの月額料金 / 30日) × 残り期間 × 追加容量。

    残り期間は日単位で計測され、秒単位まで正確です。
  • 従量課金ディスク: 従量課金ディスクをサイズ変更すると、新しい容量に基づいて請求されます。料金は時間単位で計算されます。当時間分の請求書は、次の時間に作成されます。

ストレージ容量ユニット (SCU) を購入している場合、従量課金ディスクの請求書は自動的に相殺されます。詳細については、「ブロックストレージの課金」をご参照ください。

よくある質問

FAQ: ディスク容量の増加

  • 新しい容量が反映されないのはなぜですか?

    ディスクの容量を増やした後、OS は新しい容量を自動的に検出できません。追加された容量を利用できるようにするには、タイプに応じてパーティションとファイルシステムを手動で拡張する必要があります。

  • API を使用したディスクのサイズ変更

    1. 容量を増やす前に、操作ミスによるデータ損失を防ぐため、CreateSnapshot API を呼び出し、ディスクのスナップショットを作成することを強く推奨します。

      スナップショットの使用にはスナップショット料金が発生します。
    2. スナップショットが作成された後、ResizeDisk API を呼び出してディスク容量を増やします。

    3. ディスク容量を増やした後、パーティションとファイルシステムを拡張する必要があります。

      RunCommand API を呼び出して対象インスタンスにコマンドを送信し (コマンドについては、「CLI での拡張」を参照してください)、その後、DescribeInvocations API を呼び出してコマンドの出力をクエリし、パーティションとファイルシステムの拡張を確認します。

  • [リスクを理解し、データをバックアップしました。続行します] がグレー表示されて選択できません。どうすればよいですか?

    ディスクのスナップショットが作成中かどうかを確認してください。スナップショットの作成中はディスクのサイズを変更できません。スナップショットの作成が完了するのを待ってから、ディスクのサイズを変更してください。

  • 再起動せずにオフラインでのサイズ変更を行った後はどうすればよいですか?

    オフラインでのサイズ変更が反映されるには、インスタンスの再起動が必要です。ビジネス上、再起動が許容できない状況で、すでにオフラインでのサイズ変更を選択してしまった場合は、次のいずれかの方法で再起動を回避できます:

    • 2回目のサイズ変更:1 GiB のオンラインでのサイズ変更を実行します。これにより、新しい容量と以前のオフラインでのサイズ変更の両方がオンラインで適用されます。これは2回目のサイズ変更としてカウントされ、追加料金が発生します。ビジネスニーズに応じて慎重に実行してください。

    • 再アタッチ:この操作ではディスクのデタッチが伴い、現在のワークロードが中断されます。ニーズに応じて慎重に実行してください。

      • データディスクの場合、現在のインスタンスからデタッチし、再アタッチします。

      • システムディスクの場合、再起動は避けられません。あるいは、インスタンスを停止し、デタッチして再アタッチすることで、オフラインでのサイズ変更をオンラインで適用できます。

  • オフラインでのサイズ変更のみをサポートするインスタンスタイプはどれですか?

    以下の場合、オフラインでのサイズ変更のみがサポートされます。インスタンスを再起動するか、ディスクを再アタッチして新しい容量を認識させてください。

    • 以下のインスタンスタイプは、オフラインでのサイズ変更のみをサポートします。

      • ecs.ebmc4.8xlarge

      • ecs.ebmhfg5.2xlarge

      • ecs.ebmg5.24xlarge

      • ecs.t1

      • ecs.s1

      • ecs.s2

      • ecs.s3

      • ecs.c1

      • ecs.c2

      • ecs.m1

      • ecs.m2

    • カーネルバージョンが 3.6 より前のインスタンス、またはカーネルがトリミングされたカスタムイメージを使用しているインスタンスは、オフラインでのサイズ変更のみをサポートします。

  • Cloud Assistant の拡張ページへの戻り方

    1. インスタンス詳細ページの ブロックストレージ タブで、Cloud Assistant の検出機能を有効にします。

      image

    2. 対象ディスクの システム内ステータスチェック 列にある [2/3 のチェックに合格] をクリックし、パーティションとファイルシステムの拡張 をクリックしてページに戻ります。

  • 新しいパーティション容量が反映されないのはなぜですか?

    sudo lsblk を実行して、Size フィールドを確認してください。パーティションサイズがデバイスサイズと一致しない場合、サイズ変更は反映されていません。通常、パーティションのサイズ変更に再起動は不要です。パーティションのサイズ変更が反映されない場合、オペレーティングシステムのバージョンが古いことが原因である可能性があります。変更を反映させるには、インスタンスを再起動する必要があります。

FAQ: パーティションの拡張

  • growpart のエラー: "no tools available to resize disk with 'gpt'"

    オペレーティングシステムに gdisk ツールがインストールされていません。GPT パーティションのサイズを変更するには、お使いのオペレーティングシステムのタイプに応じて gdisk ツールをインストールする必要があります。

    • CentOS および類似のディストリビューション

      type sgdisk || sudo yum install -y gdisk
    • Debian、Ubuntu、および類似のディストリビューション

      sudo apt-get update
      type sgdisk || sudo apt-get install -y gdisk
  • growpart のエラー: "command not found"

    オペレーティングシステムに growpart ツールがインストールされていません。お使いのオペレーティングシステムのタイプに応じて次のコマンドを実行し、growpart ツールをインストールします (GPT パーティションを拡張するには gdisk ツールも必要です)。

    • CentOS および類似のディストリビューション

      type growpart || sudo yum install -y cloud-utils-growpart
      sudo yum update cloud-utils-growpart
      type sgdisk || sudo yum install -y gdisk
    • Debian、Ubuntu、および類似のディストリビューション

      sudo apt-get update
      sudo apt-get install -y cloud-guest-utils
      type sgdisk || sudo apt-get install -y gdisk
  • growpart コマンドを実行してパーティションを拡張すると、エラー "unexpected output in sfdisk --version [sfdisk, from util-linux 2.23.2]"が報告されます。

    原因: 中国語版のオペレーティングシステムが en_US.UTF-8 以外の文字エンコーディングタイプを使用しています。

    解決策

    • locale コマンドを実行して、ECS インスタンスの文字エンコーディングを確認してください。en_US.UTF-8 でない場合は、そのエンコーディングに変更してください。

      • 次のコマンドを実行して、文字エンコーディングタイプを切り替えます。

        export LANG=en_US.UTF-8
      • 問題が解決しない場合は、次のコマンドを実行して文字エンコーディングタイプを切り替えます。

        export LC_ALL=en_US.UTF-8
    • 問題が解決しない場合は、reboot コマンドを実行して ECS インスタンスを再起動してみてください。

    重要

    文字エンコーディングを切り替えてパーティションの拡張に成功した後、必要に応じて元の文字エンコーディングに戻すことができます。

  • growpart コマンドを実行してパーティションを拡張すると、エラー "mkdir: cannot create directory ... No space left on device"が表示されます。

    ディスクに一時ディレクトリを作成するための十分なスペースがありません。不要なファイルを削除してから、パーティションを拡張してください。

  • growpart コマンドを実行してパーティションを拡張すると、次のエラーが返されます: "unexpected output in sfdisk --version [sfdisk (util-linux-ng 2.17.2)]"

    fdisk のバージョンが growpart のバージョンと互換性がありません。growpart のバージョンを 0.27 にダウングレードしてください。

  • growpart コマンドがエラー "FAILED: unable to determine partition type"を返します。

    ディスクにパーティションがありません。パーティションを拡張する必要はありません。直接ファイルシステムを拡張できます。

  • growpart コマンドを実行してパーティションを拡張すると、次のメッセージが表示されます: "WARNING: MBR/dos partitioned disk is larger than 2TB. Additional space will go unused"

    MBR パーティション形式は 2 TiB を超えるディスクをサポートしていません。まず、データディスクの MBR パーティションを GPT パーティションに変換してから、GPT パーティションを拡張してください。

  • sudo lsblk を実行すると、パーティションが 2 TiB までしか拡張されていません

    MBR パーティションタイプは 2 TiB を超えるディスクをサポートしていません。まず、データディスクの MBR パーティションを GPT パーティションに変換してから、GPT パーティションを拡張してください。

  • CentOS 6 で growpart ツールをインストールすると、次のエラーが表示されます: "Error: Cannot retrieve repository metadata"

    CentOS 6 OS はサポート終了 (EOL) に達しています。ツールをインストールする前に、CentOS 6 EOL リポジトリを変更する必要があります。

  • growpart コマンドを実行してパーティションを拡張すると、メッセージ "NOCHANGE: partition 1 could only be grown by 2015 [fudge=2048]"が表示されます。

    パーティションのサイズ変更時に利用可能なスペースがない場合、通常はコンソールでオフラインでのディスクサイズ変更を行った後にインスタンスが再起動されていないことが原因です。その結果、ディスクの変更が反映されていません。オフラインでのサイズ変更後は、ECS コンソールまたは API を使用してインスタンスを再起動するか起動する必要があります (インスタンス内で reboot コマンドを実行して再起動しても無効です)。

FAQ: ファイルシステムの拡張