ディスクの容量を拡張した後、追加された領域を使用するには、パーティションとファイルシステムの拡張が必要です。ディスクは縮小できないため、ストレージ要件を慎重に計画してください。
サイズ変更の概要
ディスクのサイズ変更には、主に 2 つのステップがあります:
ECS コンソールでディスクのストレージを追加購入します。これは、より大きなハードドライブを購入したものの、まだインストールしていない状態に似ています。支払いが完了しても、サイズ変更プロセスは完了しません。
インスタンスのオペレーティングシステムで新しい領域を利用可能にします。これは、システムがそれを認識して使用できるように、ハードドライブ上の新しい領域をフォーマットするようなものです。
ステップ 1:ディスク容量の増加
前提条件
次のいずれかの条件を満たしていることを確認してください。
ディスクが ECS インスタンスにアタッチされており、インスタンスの有効期限が切れておらず、[実行中]または[停止済み]の状態である必要があります。
ディスクが[アタッチ待ち]の状態である必要があります。
操作手順
ECS コンソール - ブロックストレージに移動します。上部メニューで、対象のリージョンとリソースグループを選択します。
サイズ変更するディスクを見つけ、ディスクの拡張を操作列でクリックします。
操作ミスによるデータ損失を防ぐため、サイズ変更の前にディスクのスナップショットを作成してデータをバックアップすることを強くお勧めします。ターゲットディスクと注意事項を確認する ページで、ディスク情報を確認し、[スナップショットの作成] をクリックし、スナップショットの名前と保持期間を設定してから、[確認] をクリックします。
重要スナップショットの使用には料金が発生します。

対応列にスケーリング対応が表示されたら、拡張の確認をクリックします。
スナップショットの作成に必要な時間は、ディスク上のデータ量や利用可能な帯域幅などの要因によって異なります。ECS コンソールのスナップショットページに移動し、進行 列で作成ステータスを確認できます。
変更方法とサイズを設定する ウィザードで、パラメーターを設定し、料金を確認してから、[OK] をクリックします。
重要ディスクのサイズ変更を行うと、追加された容量に対して課金されます。
パラメータ
説明
[拡張後の容量]
新しい容量は、現在の容量よりも小さくすることはできません。
[サイズ変更方法]
[オンラインサイズ変更] (推奨):ディスクの容量を増やした後、インスタンスを再起動する必要はありません。新しい容量は即座に有効になります。
[オフラインサイズ変更]:ディスクが[アタッチ待ち]の状態、インスタンスが[停止済み]の状態、またはオフラインリサイズのみをサポートする特定のインスタンスタイプを使用している場合は、この方法を使用します。
サブスクリプションディスクの場合、支払いポップアップウィンドウに表示される 5 秒のカウントダウンが終了したら、支払いへ をクリックして支払いを完了します。支払いが完了したら、サイズ変更ワークフローに戻り、支払い完了 をクリックします。
支払いを完了する前に支払い完了をクリックすると、サイズ変更プロセスが停止します。注文の支払いをクリックし、支払いを完了させてから、サイズ変更ワークフローに戻る必要があります。
ステップ 2:パーティションとファイルシステムの拡張
前提条件
ディスクが [アタッチ待ち] 状態の場合は、ECS インスタンスにアタッチする必要があります。
前のステップでオフラインでのサイズ変更を使用してディスク容量を拡張し、ディスクが ECS インスタンスにアタッチされている場合は、インスタンスを再起動するか、起動する必要があります。
データディスクにファイルシステムが作成されていない場合は、「データディスクの初期化」の指示に従ってください。
オンラインでのサイズ変更中に、次のすべての条件に該当する場合、グループ記述子テーブル (GDT) が誤った物理ブロックに書き込まれ、ビジネスデータが上書きされることでデータの破損が発生する可能性があります。ディスクのサイズを変更する前に、システムタイプに基づいてオペレーティングシステムを移行するか、カーネルをアップグレードしてください。
サイズ変更前のディスク容量が 16 TiB (16,384 GiB) を超えている。
サイズ変更前のディスク容量が 8 GiB の整数倍ではない。
ファイルシステムタイプが ext4 である。
影響を受けるカーネルバージョンが使用されている。
操作手順
ディスク容量を拡張した後、追加された領域を使用するには、パーティションとファイルシステムを拡張する必要があります。Alibaba Cloud は 2 つの方法を提供しています:
コンソールを使用して拡張する (推奨):Cloud Assistant を使用して、コンソールからパーティションとファイルシステムを拡張します。この方法は便利で、手動でコマンドを実行する必要がなくなります。
コマンドラインを使用して拡張する:インスタンスにログインし、手動でコマンドを実行してパーティションとファイルシステムを拡張します。この方法は柔軟性が高く、さまざまな状況に適用できます。
コンソールでの拡張 (推奨)
誤ってこのページを閉じてしまった場合は、インスタンス詳細ページの [ブロックストレージ] タブから操作ページに戻ることができます。
[未割り当て] セクションで、[最後のパーティションとファイルシステムのスケールアウト] をクリックします。
Cloud Assistant に権限を付与していない場合は、プロンプトが表示されたときに権限を付与する必要があります。
ページにメッセージ ["Cloud Assistant query or execution failed"] または ["Instance OS Version Not Supported"] が表示された場合は、コマンドラインを使用して拡張する必要があります。

クラウドアシスタントによるパーティションおよびファイルシステムの拡張 ダイアログボックスで、[今すぐ実行] をクリックします。メッセージ [クラウドアシスタントによるパーティションおよびファイルシステムの拡張に成功しました。] が表示されたら、拡張は完了です。閉じる をクリックします。
重要続行する前に、拡張の失敗を防ぐためにコマンドが正しいことを確認してください。
CLI での拡張
パーティションの拡張
インスタンス詳細ページで OS バージョンを確認してください。CentOS 6 以前、OpenSUSE 42.3、Debian 8 以前の場合は、パーティションとファイルシステムをオフラインで拡張する必要があります。
ECS インスタンスにログインします。
ECS コンソール - インスタンスに移動します。上部メニューで、対象のリージョンとリソースグループを選択します。
対象インスタンスの詳細ページに移動します。右上隅にある 接続 をクリックし、ワークベンチ を選択します。プロンプトに従ってインスタンスにログインし、ターミナルを開きます。
パーティションを拡張します。
sudo lsblkを実行して、拡張するディスクのデバイス名とパーティション番号を確認します。$ sudo lsblk NAME MAJ:MIN RM SIZE RO TYPE MOUNTPOINT vda 253:0 0 50G 0 disk ├─vda1 253:1 0 2M 0 part ├─vda2 253:2 0 200M 0 part /boot/efi └─vda3 253:3 0 39.8G 0 part / vdb 253:16 0 40G 0 disk /data拡張するディスクにパーティションがない場合は、直接ファイルシステムを拡張できます。この例では、データディスク
vdbにはパーティションがないため、パーティションを拡張する必要はありません。拡張するディスクの容量がパーティションの合計容量より大きい場合は、パーティションを拡張する必要があります。この例では、システムディスク
vdaの容量は 50 GiB で、3 つのパーティションが含まれています。パーティションの合計容量は 40 GiB であり、最後のパーティションvda3を拡張する必要があります。重要ディスク上の最後のパーティションのみを拡張できます。
次の表に、一般的なデバイスの命名規則とパーティション形式を示します。
sudo lsblk コマンドが vgx 形式で出力を表示する場合、これはディスクパーティションが論理ボリュームマネージャー (LVM) によって管理されていることを示します。コンソールでディスク容量を拡張した後、LVM を使用して論理ボリュームを拡張する必要があります。
デバイスタイプ
デバイス名
パーティション番号
NVMe プロトコルを使用しないディスク
形式は
vd[a-z]です (例:vda(システムディスク)、vdb、vdc)。形式は
vd[a-z]<partition number>です。たとえば、vda3の場合、パーティション番号は 3 です。NVMe 準拠のディスク
形式は
nvmeXn1です (例:nvme0n1、nvme1n1、nvme2n1)。形式は
nvmeXn1p<partition_number>です。たとえば、nvme0n1p1の場合、パーティション番号は 1 です。
拡張ツールをインストールします。
Alibaba Cloud Linux および CentOS
type growpart || sudo yum install -y cloud-utils-growpart sudo yum update cloud-utils-growpart type sgdisk || sudo yum install -y gdiskDebian および Ubuntu
sudo apt-get update sudo apt-get install -y cloud-guest-utils type sgdisk || sudo apt-get install -y gdiskコマンドを実行してパーティションを拡張します。
コマンド内の
<DeviceName>と<PartitionNumber>を ステップ a で取得したデバイス名とパーティション番号に置き換えて、コマンドを実行します。重要デバイス名とパーティション番号の間にスペースを入れてください。
sudo LC_ALL=en_US.UTF-8 growpart /dev/<DeviceName> <PartitionNumber>レスポンス内のキーワード
CHANGEDは、コマンドが正常に実行されたことを示します。コマンドが失敗した場合は、「パーティション拡張の一般的な問題」を参照してトラブルシューティングしてください。コマンドの
LC_ALL=en_US.UTF-8は、中国語システムのエンコーディングに対応するために使用される環境変数です。
パーティションの拡張を確認します。
sudo lsblkコマンドを実行します。パーティションの合計サイズがデバイスの容量と等しい場合、パーティションは正常に拡張されています。この例では、デバイスvdaの容量とパーティションの合計サイズはどちらも 50 GiB です。次に、追加された領域を利用可能にするためにファイルシステムを拡張する 必要があります。$ sudo lsblk NAME MAJ:MIN RM SIZE RO TYPE MOUNTPOINT vda 253:0 0 50G 0 disk ├─vda1 253:1 0 2M 0 part ├─vda2 253:2 0 200M 0 part /boot/efi └─vda3 253:3 0 49.8G 0 part / vdb 253:16 0 40G 0 disk /data
ファイルシステムの拡張
コマンド
sudo lsblk -fを実行し、ファイルシステムを拡張する際に使用するため、拡張するディスクの対象デバイス名、ファイルシステムタイプ、およびマウントポイントを記録します。$ sudo lsblk -f NAME FSTYPE LABEL UUID MOUNTPOINT vda ├─vda1 ├─vda2 vfat 7938-FA03 /boot/efi └─vda3 ext4 root 33b46ac5-7482-4aa5-8de0-60ab4c3a4c78 / vdb ext4 3d7a3861-da22-484e-bbf4-b09375894b4f /dataデバイスにパーティションがある場合、対象デバイス名は最後のパーティションの名前です。この例では、システムディスク
vdaの場合、対象デバイス名はvda3、ファイルシステムタイプはext4、マウントポイントは/です。デバイスにパーティションがない場合、対象デバイス名はデバイス名と同じです。たとえば、データディスク
vdbの場合、対象デバイス名はvdb、ファイルシステムタイプはext4、マウントポイントは/dataです。
ファイルシステムを拡張します。
ファイルシステムが拡張されたことを確認します。
sudo df -Thコマンドを実行して、ファイルシステムのサイズ (出力のSize列の値) がディスク容量と一致することを確認します。ファイルシステムが作成されると、メタデータを格納するために一部の容量が予約されます。したがって、ファイルシステムのサイズは、コンソールに表示される容量よりわずかに小さい場合があります。
課金
ディスクをサイズ変更すると、追加容量分が課金されます。追加容量の課金方法は、元のディスクと同じです。
サブスクリプションディスク: サブスクリプションディスクをサイズ変更すると、新しい容量に基づいて直ちに課金されます。サブスクリプションの残り期間について、旧容量と新容量の差額を支払う必要があります。
差額 = (1 GB あたりの月額料金 / 30日) × 残り期間 × 追加容量。
残り期間は日単位で計測され、秒単位まで正確です。
従量課金ディスク: 従量課金ディスクをサイズ変更すると、新しい容量に基づいて請求されます。料金は時間単位で計算されます。当時間分の請求書は、次の時間に作成されます。
ストレージ容量ユニット (SCU) を購入している場合、従量課金ディスクの請求書は自動的に相殺されます。詳細については、「ブロックストレージの課金」をご参照ください。
よくある質問
FAQ: ディスク容量の増加
新しい容量が反映されないのはなぜですか?
ディスクの容量を増やした後、OS は新しい容量を自動的に検出できません。追加された容量を利用できるようにするには、タイプに応じてパーティションとファイルシステムを手動で拡張する必要があります。
API を使用したディスクのサイズ変更
容量を増やす前に、操作ミスによるデータ損失を防ぐため、CreateSnapshot API を呼び出し、ディスクのスナップショットを作成することを強く推奨します。
スナップショットの使用にはスナップショット料金が発生します。
スナップショットが作成された後、ResizeDisk API を呼び出してディスク容量を増やします。
ディスク容量を増やした後、パーティションとファイルシステムを拡張する必要があります。
RunCommand API を呼び出して対象インスタンスにコマンドを送信し (コマンドについては、「CLI での拡張」を参照してください)、その後、DescribeInvocations API を呼び出してコマンドの出力をクエリし、パーティションとファイルシステムの拡張を確認します。
[リスクを理解し、データをバックアップしました。続行します] がグレー表示されて選択できません。どうすればよいですか?
ディスクのスナップショットが作成中かどうかを確認してください。スナップショットの作成中はディスクのサイズを変更できません。スナップショットの作成が完了するのを待ってから、ディスクのサイズを変更してください。
再起動せずにオフラインでのサイズ変更を行った後はどうすればよいですか?
オフラインでのサイズ変更が反映されるには、インスタンスの再起動が必要です。ビジネス上、再起動が許容できない状況で、すでにオフラインでのサイズ変更を選択してしまった場合は、次のいずれかの方法で再起動を回避できます:
2回目のサイズ変更:1 GiB のオンラインでのサイズ変更を実行します。これにより、新しい容量と以前のオフラインでのサイズ変更の両方がオンラインで適用されます。これは2回目のサイズ変更としてカウントされ、追加料金が発生します。ビジネスニーズに応じて慎重に実行してください。
再アタッチ:この操作ではディスクのデタッチが伴い、現在のワークロードが中断されます。ニーズに応じて慎重に実行してください。
システムディスクの場合、再起動は避けられません。あるいは、インスタンスを停止し、デタッチして再アタッチすることで、オフラインでのサイズ変更をオンラインで適用できます。
オフラインでのサイズ変更のみをサポートするインスタンスタイプはどれですか?
以下の場合、オフラインでのサイズ変更のみがサポートされます。インスタンスを再起動するか、ディスクを再アタッチして新しい容量を認識させてください。
以下のインスタンスタイプは、オフラインでのサイズ変更のみをサポートします。
ecs.ebmc4.8xlarge
ecs.ebmhfg5.2xlarge
ecs.ebmg5.24xlarge
ecs.t1
ecs.s1
ecs.s2
ecs.s3
ecs.c1
ecs.c2
ecs.m1
ecs.m2
カーネルバージョンが 3.6 より前のインスタンス、またはカーネルがトリミングされたカスタムイメージを使用しているインスタンスは、オフラインでのサイズ変更のみをサポートします。
Cloud Assistant の拡張ページへの戻り方
インスタンス詳細ページの ブロックストレージ タブで、Cloud Assistant の検出機能を有効にします。

対象ディスクの システム内ステータスチェック 列にある [2/3 のチェックに合格] をクリックし、パーティションとファイルシステムの拡張 をクリックしてページに戻ります。
新しいパーティション容量が反映されないのはなぜですか?
sudo lsblkを実行して、Sizeフィールドを確認してください。パーティションサイズがデバイスサイズと一致しない場合、サイズ変更は反映されていません。通常、パーティションのサイズ変更に再起動は不要です。パーティションのサイズ変更が反映されない場合、オペレーティングシステムのバージョンが古いことが原因である可能性があります。変更を反映させるには、インスタンスを再起動する必要があります。
FAQ: パーティションの拡張
growpart のエラー:
"no tools available to resize disk with 'gpt'"オペレーティングシステムに
gdiskツールがインストールされていません。GPT パーティションのサイズを変更するには、お使いのオペレーティングシステムのタイプに応じて gdisk ツールをインストールする必要があります。CentOS および類似のディストリビューション
type sgdisk || sudo yum install -y gdiskDebian、Ubuntu、および類似のディストリビューション
sudo apt-get update type sgdisk || sudo apt-get install -y gdisk
growpart のエラー:
"command not found"オペレーティングシステムに
growpartツールがインストールされていません。お使いのオペレーティングシステムのタイプに応じて次のコマンドを実行し、growpartツールをインストールします (GPT パーティションを拡張するにはgdiskツールも必要です)。CentOS および類似のディストリビューション
type growpart || sudo yum install -y cloud-utils-growpart sudo yum update cloud-utils-growpart type sgdisk || sudo yum install -y gdiskDebian、Ubuntu、および類似のディストリビューション
sudo apt-get update sudo apt-get install -y cloud-guest-utils type sgdisk || sudo apt-get install -y gdisk
growpart コマンドを実行してパーティションを拡張すると、エラー
"unexpected output in sfdisk --version [sfdisk, from util-linux 2.23.2]"が報告されます。原因: 中国語版のオペレーティングシステムが en_US.UTF-8 以外の文字エンコーディングタイプを使用しています。
解決策:
localeコマンドを実行して、ECS インスタンスの文字エンコーディングを確認してください。en_US.UTF-8 でない場合は、そのエンコーディングに変更してください。次のコマンドを実行して、文字エンコーディングタイプを切り替えます。
export LANG=en_US.UTF-8問題が解決しない場合は、次のコマンドを実行して文字エンコーディングタイプを切り替えます。
export LC_ALL=en_US.UTF-8
問題が解決しない場合は、
rebootコマンドを実行して ECS インスタンスを再起動してみてください。
重要文字エンコーディングを切り替えてパーティションの拡張に成功した後、必要に応じて元の文字エンコーディングに戻すことができます。
growpartコマンドを実行してパーティションを拡張すると、エラー"mkdir: cannot create directory ... No space left on device"が表示されます。ディスクに一時ディレクトリを作成するための十分なスペースがありません。不要なファイルを削除してから、パーティションを拡張してください。
growpart コマンドを実行してパーティションを拡張すると、次のエラーが返されます:
"unexpected output in sfdisk --version [sfdisk (util-linux-ng 2.17.2)]"。fdisk のバージョンが growpart のバージョンと互換性がありません。growpart のバージョンを 0.27 にダウングレードしてください。
growpart コマンドがエラー
"FAILED: unable to determine partition type"を返します。ディスクにパーティションがありません。パーティションを拡張する必要はありません。直接ファイルシステムを拡張できます。
growpart コマンドを実行してパーティションを拡張すると、次のメッセージが表示されます:
"WARNING: MBR/dos partitioned disk is larger than 2TB. Additional space will go unused"。MBR パーティション形式は 2 TiB を超えるディスクをサポートしていません。まず、データディスクの MBR パーティションを GPT パーティションに変換してから、GPT パーティションを拡張してください。
sudo lsblkを実行すると、パーティションが 2 TiB までしか拡張されていませんMBR パーティションタイプは 2 TiB を超えるディスクをサポートしていません。まず、データディスクの MBR パーティションを GPT パーティションに変換してから、GPT パーティションを拡張してください。
CentOS 6 で growpart ツールをインストールすると、次のエラーが表示されます:
"Error: Cannot retrieve repository metadata"。CentOS 6 OS はサポート終了 (EOL) に達しています。ツールをインストールする前に、CentOS 6 EOL リポジトリを変更する必要があります。
growpart コマンドを実行してパーティションを拡張すると、メッセージ
"NOCHANGE: partition 1 could only be grown by 2015 [fudge=2048]"が表示されます。パーティションのサイズ変更時に利用可能なスペースがない場合、通常はコンソールでオフラインでのディスクサイズ変更を行った後にインスタンスが再起動されていないことが原因です。その結果、ディスクの変更が反映されていません。オフラインでのサイズ変更後は、ECS コンソールまたは API を使用してインスタンスを再起動するか起動する必要があります (インスタンス内で
rebootコマンドを実行して再起動しても無効です)。
FAQ: ファイルシステムの拡張
resize2fsコマンドを実行すると、エラー"Couldn't find valid filesystem superblock."または"open: Is a directory while opening /mnt"が報告されます。ファイルシステムを拡張する際には、デバイス名やマウントポイントではなく、正しいディスクパーティション名を指定する必要があります。
resize2fs コマンドが次のメッセージを返します:
"The filesystem is already ... blocks long. Nothing to do!"。原因: ファイルシステムに拡張可能な容量がありません。これは、パーティションが拡張されていないか、拡張が反映されていないことが原因として考えられます。
解決策:
まず、growpart コマンドを使用してパーティションが正常に拡張されたことを確認してください。このステップを実行していない場合は、growpart コマンドを実行してパーティションを拡張してください。
growpart コマンドを正常に実行してパーティションを拡張したにもかかわらず問題が解決しない場合、システムパーティションテーブルをオンラインで更新できない古い OS バージョンを使用していることが原因である可能性があります。インスタンスを再起動してから、resize2fs コマンドを実行してください。
resize2fs のエラー:
"Permission denied"原因: ファイルシステムの拡張が失敗するのは、通常、ファイルシステム自体の不整合やエラーが原因です。
解決策:
dmesg -T | grep fsコマンドを実行してください。出力に"There are errors in the filesystem"のようなメッセージが含まれている場合、ファイルシステムに不整合があることを示します。スナップショットを作成してディスクデータをバックアップしてください。
サービスが許容する場合は、
umountコマンドを実行して、環境に応じてマウントされたパーティションまたはディスク全体をアンマウントしてください。システムディスクの場合 (
umountできない場合)、修復するにはシステムディスクを別のインスタンスにデタッチしてアタッチする必要があります。e2fsckコマンドを使用して修復を試みてください。
resize2fs のエラー:
"inodes (4294967296) must be less than 4294967295"。原因: 初期化時に
bytes-per-inodeが正しく設定されていませんでした。容量を 64 TiB に拡張する必要がある場合は、ファイルシステムを作成する際にコマンドに
-i 65536を追加してください。解決策: 新しいディスクを作成してデータをコピーしてください。
重要bytes-per-inodeはディスクの初期化後に変更できません。現在のインスタンスに必要な容量の空のデータディスクを作成してください。
データディスクを初期化して ext4 ファイルシステムを作成する際に、コマンドに
-i 65536を追加してください。元のディスクから新しいディスクに手動でデータをコピーしてください。
ビジネスが期待通りに実行されていることを確認してください。これを確認するには、関連サービスを再起動する必要がある場合があります。
ビジネスが期待通りに実行されていることを確認した後、元のデータディスクをデタッチしてリリースできます。詳細については、「データディスクのデタッチ」および「ディスクのリリース」をご参照ください。
OS のディスク容量が購入した容量と異なるのはなぜですか?
ファイルシステムが作成されると、メタデータを格納するために一部の容量が予約されます。したがって、ファイルシステムのサイズは、コンソールに表示される容量よりわずかに小さい場合があります。
ファイルシステムタイプの表示方法
コンソールでの表示
インスタンス詳細ページの ブロックストレージ ページで、対象ディスクの [OS 内ステータスチェック] の下にあるコンテンツをクリックしてください。
[ディスクパーティションチェック] ダイアログボックスで、対象デバイスの [ファイルシステム] を確認します。
コマンドラインでの表示
sudo lsblk -fコマンドを実行して、対象デバイスのFSTYPEを確認します。$ sudo lsblk -f NAME FSTYPE LABEL UUID MOUNTPOINT vda ├─vda1 ├─vda2 vfat 7938-FA03 /boot/efi └─vda3 ext4 root 33b46ac5-7482-4aa5-8de0-60ab4c3a4c78 / vdb ext4 3d7a3861-da22-484e-bbf4-b09375894b4f /dataデバイスにパーティションがある場合、対象デバイスは最後のパーティションの名前です。この例では、システムディスク
vdaの対象デバイスはvda3であり、そのファイルシステムタイプはext4です。デバイスにパーティションがない場合、対象デバイスはデバイス名と同じです。この例では、データディスク
vdbの対象デバイスはvdbであり、そのファイルシステムタイプはext4です。
影響を受ける ECS インスタンスのオペレーティングシステムとカーネルバージョン
重要影響を受けるカーネルバージョンを使用して ext4 ファイルシステムのサイズを変更する際に、サイズ変更前のディスク容量が 16 TiB (16,384 GiB) を超え、かつ 8 GiB の整数倍でない場合、オンラインでのサイズ変更によってグループ記述子テーブル (GDT) が誤った物理ブロックに書き込まれ、ビジネスデータが上書きされてデータの破損を引き起こす可能性があります。したがって、ディスクをサイズ変更する前に、システムタイプに応じてオペレーティングシステムを移行するか、カーネルをアップグレードしてください。
uname -rコマンドを実行して、システムのカーネルバージョンを確認できます。オペレーティングシステム
影響を受ける OS バージョンとカーネルバージョン
修正方法
Alinux
Alibaba Cloud Linux 2: すべてのカーネルバージョン
Alibaba Cloud Linux 3: < 5.10.134-18
Alibaba Cloud Linux 2: Alibaba Cloud Linux 3 への移行
Alibaba Cloud Linux 3: Linux ECS インスタンスのカーネルを最新バージョンにアップグレード
Anolis
Anolis 7: すべてのカーネルバージョン
Anolis 8.2~8.9 ANCK および RHCK: すべてのカーネルバージョン
Anolis 7:
Alibaba Cloud Linux 3 または Alibaba Cloud Linux 4 へのオペレーティングシステムの交換を推奨します。
Anolis 8.2~8.9 ANCK および RHCK: Linux ECS インスタンスのカーネルを最新バージョンにアップグレード
Debian
Debian 8~9: すべてのカーネルバージョン
Debian 10: < 4.19.0-27-amd64
Debian 11.0~11.9: < 5.10.0-29-amd64
Debian 12.0~12.5: < 6.1.0-20-amd64
Debian 8~9:
Alibaba Cloud Linux 3 または Alibaba Cloud Linux 4 へのオペレーティングシステムの交換を推奨します。
Debian 10~12: Linux ECS インスタンスのカーネルを最新バージョンにアップグレード
Ubuntu
Ubuntu 16.04: すべてのカーネルバージョン
Ubuntu 18.04: すべてのカーネルバージョン
Ubuntu 20.04: < 5.4.0-189-generic
Ubuntu 22.04: < 5.15.0-116-generic
Ubuntu 24.04: < 6.8.0-35-generic
Ubuntu 16.04~18.04:
Alibaba Cloud Linux 3 または Alibaba Cloud Linux 4 へのオペレーティングシステムの交換を推奨します。
Ubuntu 20.04~24.04: Linux ECS インスタンスのカーネルを最新バージョンにアップグレード
RHEL
RedHat 7: すべてのカーネルバージョン
RedHat 8: < 4.18.0-553.16.1.el8_10
RedHat 9.0~9.4: < 5.14.0-503.11.1.el9_5
RedHat 7: Red Hat 9 または Alibaba Cloud Linux 3 への移行
RedHat 8 および RedHat 9: Linux ECS インスタンスのカーネルを最新バージョンにアップグレード
Rocky Linux
Rocky Linux 8: < 4.18.0-553.16.1.el8_10
Rocky Linux 9.0~9.4: < 5.14.0-503.14.1.el9_5
AlmaLinux
AlmaLinux 8: < 4.18.0-553.16.1.el8_10
AlmaLinux 9.0~9.4: < 5.14.0-503.11.1.el9_5
CentOS Stream
CentOS Stream 8: すべてのカーネルバージョン
CentOS Stream 9: < 5.14.0-472.el9
CentOS Stream 8:
Alibaba Cloud Linux 3 または Alibaba Cloud Linux 4 へのオペレーティングシステムの交換を推奨します。
CentOS Stream 9: Linux ECS インスタンスのカーネルを最新バージョンにアップグレード
CentOS
すべてのカーネルバージョン
Fedora
Fedora 33~37: すべてのカーネルバージョン
Fedora 38: < 6.8.4-100.fc38
Fedora 39: < 6.8.4-200.fc39
Fedora 33~37:
Alibaba Cloud Linux 3 または Alibaba Cloud Linux 4 へのオペレーティングシステムの交換を推奨します。
Fedora 38~39: Linux ECS インスタンスのカーネルを最新バージョンにアップグレード
SLES
SLES 12
SLES 12SP1~SP4: すべてのカーネルバージョン
SLES 12SP5: < 4.12.14-122.222.1
SLES 15
SLES 15SP1~SP4: すべてのカーネルバージョン
SLES 15SP5: < 5.14.21-150500.55.73.1
SLES 15SP6: < 6.4.0-150600.23.14.2
SLES 12SP1~SP4 または SLES 15SP1~SP4:
Alibaba Cloud Linux 3 または Alibaba Cloud Linux 4 へのオペレーティングシステムの交換を推奨します。
SLES 12SP5、SLES 15SP5、SLES 15SP6: Linux ECS インスタンスのカーネルを最新バージョンにアップグレード
openSUSE
openSUSE 15
openSUSE 15.0~15.4: すべてのカーネルバージョン
openSUSE 15.5: < 5.14.21-15000.55.73.1
openSUSE 15.6: < 6.4.0-150600.23.14.2
openSUSE 15.0~15.4:
Alibaba Cloud Linux 3 または Alibaba Cloud Linux 4 へのオペレーティングシステムの交換を推奨します。
openSUSE 15.5 および 15.6: Linux ECS インスタンスのカーネルを最新バージョンにアップグレード