ディスクのスナップショットを作成します。
操作説明
ローカルスナップショット機能は、スナップショットインスタントアクセス機能に置き換えられました。 詳細は以下のとおりです。
2020 年 12 月 14 日より前にローカルスナップショットを使用していた場合は、引き続き
Categoryパラメーターを「通常」として使用できます。2020 年 12 月 14 日より前にローカルスナップショットを使用していなかった場合、追加設定は不要です。 ESSD シリーズのディスク (ESSD、ESSD AutoPL、ESSD Entry、およびリージョン ESSD) 用に作成されたスナップショットは、デフォルトで即時にアクティブになり、手動スナップショットと自動スナップショットの両方をサポートします。 スナップショットインスタントアクセス機能に関連する InstantAccess、InstantAccessRetentionDays、および DisableInstantAccess パラメーターは無効になりました。 DescribeSnapshots および DescribeSnapshotGroups API には、スナップショットのアクティブな状態を示す新しいレスポンス要素 Available が含まれます。
開始する前に:
-
スナップショット機能を有効化してください。 詳細については、「スナップショット機能の有効化」をご参照ください。
-
ディスクが 使用中 または アタッチされていません の状態である必要があります。 各状態には、次の注意事項が適用されます。
ディスクが 使用中 の状態である場合、インスタンスは 実行中 または 停止済み の状態である必要があります。
ディスクが アタッチされていません の状態である場合、そのディスクは以前に ECS インスタンスにアタッチされたことがある必要があります。 一度も ECS インスタンスにアタッチされたことのないディスクのスナップショットは作成できません。
ディスクがダイナミックボリュームまたは RAID アレイの作成に使用される場合は、スナップショット整合性グループを使用し、アプリケーション整合性スナップショットを有効にしてデータをバックアップしてください。 スナップショット整合性グループは、ビジネスシステム内の複数のディスクにまたがる書き込み順序整合性を確保し、クラッシュ整合性を保証します。 詳細については、「スナップショット整合性グループの作成」および「アプリケーション整合性スナップショットの作成」をご参照ください。
スナップショットを作成する際は、次の点にご注意ください。
-
ビジネスのピーク時間中にスナップショットを作成することは避けてください。 スナップショットを作成すると、ディスクの I/O パフォーマンスが 10% 未満低下し、読み取りおよび書き込みパフォーマンスが一時的に低下する可能性があります。
-
スナップショットがまだ完了していない場合、そのスナップショットを使用してカスタムイメージを作成 (CreateImage) することはできません。
-
スナップショットの作成中にディスク操作によって生成された増分データは、そのスナップショットには含まれません。
-
ディスクが ECS インスタンスにアタッチされている場合、スナップショットの作成中にインスタンスのステータス (ECS インスタンスの停止や再起動など) を変更しないでください。 そうしないと、スナップショットの作成に失敗します。
-
スナップショットを作成中のディスクはスケールアウトできません。 スナップショットが完了するまで待ってから、スケールアウト操作を実行してください。
-
期限切れ (
Expired) 状態のディスクのスナップショットを作成できます。 スナップショットの作成中にディスクが有効期限に達した場合、ディスクはリリースされ、作成中 (Creating) 状態のスナップショットも同時に削除されます。 -
スナップショットが作成されると、スナップショットサイズに基づいてリージョンごとに料金が別途請求されます。 詳細については、「スナップショットの課金」をご参照ください。
-
次のシナリオでは、指定されたディスクのスナップショットを作成することはできません。
-
ディスクで保持されている手動スナップショットの数が上限に達しています。 詳細については、「スナップショットの制限」をご参照ください。
-
スナップショットの作成には、同時実行数の制限があります。 制限を超えると、作成に失敗します。 詳細については、「スナップショットの制限」をご参照ください。
-
ECS インスタンス情報を照会するときに、返されたデータに
{"OperationLocks": {"LockReason" : "security"}}が含まれている場合、すべての操作が禁止されます。
-
今すぐお試しください
テスト
RAM 認証
|
アクション |
アクセスレベル |
リソースタイプ |
条件キー |
依存アクション |
|
ecs:CreateSnapshot |
create |
*Disk。
*Snapshot。
|
なし | なし |
リクエストパラメーター
|
パラメーター |
型 |
必須 / 任意 |
説明 |
例 |
| DiskId |
string |
必須 |
ディスク ID。 |
d-bp1s5fnvk4gn2tws0**** |
| SnapshotName |
string |
任意 |
スナップショット名。 長さは 2~128 文字で、英字 (大文字または小文字) 、または中国語の文字で始まる必要があります。Unicode 文字 (英字や中国語文字など) 、ASCII 数字 (0~9) 、コロン (:) 、アンダースコア (_) 、ピリオド (.) 、ハイフン (-) を含めることができます。 説明
名前は http:// または https:// で始めることはできません。 自動スナップショット名との競合を避けるため、名前の先頭に |
testSnapshotName |
| Description |
string |
任意 |
スナップショットの説明。 説明の長さは 2~256 文字で、 デフォルト値は空です。 |
testDescription |
| RetentionDays |
integer |
任意 |
スナップショットの保持期間 (日数) 。 有効値: 1~65536。 保持期間が終了すると、スナップショットは自動的にリリースされます。 デフォルト値は空です。この場合、スナップショットは自動的にリリースされません。 |
30 |
| Category |
string |
任意 |
スナップショットのタイプ。 有効値:
説明
このパラメーターは非推奨です。 ESSD ディスクの標準スナップショットは、デフォルトでインスタントアクセスにアップグレードされています。 追加の設定は不要で、追加料金も発生しません。 |
Standard |
| ClientToken |
string |
任意 |
リクエストのべき等性を保証するために使用されるクライアントトークン。 クライアントを使用してトークンを生成できますが、トークンが異なるリクエスト間で一意であることを確認する必要があります。 トークンには ASCII 文字のみを含めることができ、長さは 64 文字を超えることはできません。 詳細については、「べき等性を確保する方法」をご参照ください。 |
123e4567-e89b-12d3-a456-426655440000 |
| ResourceGroupId |
string |
任意 |
スナップショットが属するリソースグループの ID。 |
rg-bp67acfmxazb4p**** |
| InstantAccess |
boolean |
任意 |
スナップショットのインスタントアクセス機能を有効にするかどうかを指定します。 有効値:
デフォルト値は false です。 説明
このパラメーターは非推奨です。 ESSD ディスクの標準スナップショットは、デフォルトでインスタントアクセスにアップグレードされています。 追加の設定は不要で、追加料金も発生しません。 |
false |
| InstantAccessRetentionDays |
integer |
任意 |
スナップショットのインスタントアクセス機能の保持期間 (日数) 。 保持期間が終了すると、スナップショットは自動的にリリースされます。 このパラメーターは、 デフォルト値は 説明
このパラメーターは非推奨です。 ESSD ディスクの標準スナップショットは、デフォルトでインスタントアクセスにアップグレードされています。 追加の設定は不要で、追加料金も発生しません。 |
1 |
| Tag |
array<object> |
任意 |
タグのリスト。 |
|
|
object |
任意 |
タグのリスト。 |
||
| Key |
string |
任意 |
スナップショットのタグキー。 N の有効値は 1~20 です。 タグキーを空の文字列にすることはできません。 タグキーは 128 文字以内で、 |
TestKey |
| Value |
string |
任意 |
スナップショットのタグ値。 N の有効値は 1~20 です。 タグ値は空の文字列に設定できます。 タグ値は 128 文字以内で、 |
TestValue |
| key |
string |
任意 |
スナップショットのタグキー。 N の有効値は 1~20 です。 タグキーを空の文字列にすることはできません。 タグキーは 128 文字以内で、 |
null |
| value |
string |
任意 |
スナップショットのタグ値。 N の有効値は 1~20 です。 タグ値は空の文字列に設定できます。 タグ値は 128 文字以内で、 |
null |
| StorageLocationArn |
string |
任意 |
説明
このパラメーターは使用できません。 |
null |
レスポンスフィールド
|
フィールド |
型 |
説明 |
例 |
|
object |
|||
| RequestId |
string |
リクエスト ID。 |
473469C7-AA6F-4DC5-B3DB-A3DC0DE3C83E |
| SnapshotId |
string |
スナップショット ID。 |
s-bp17441ohwka0yuh**** |
例
成功レスポンス
JSONJSON
{
"RequestId": "473469C7-AA6F-4DC5-B3DB-A3DC0DE3C83E",
"SnapshotId": "s-bp17441ohwka0yuh****"
}
エラーコード
|
HTTP ステータスコード |
エラーコード |
エラーメッセージ |
説明 |
|---|---|---|---|
| 400 | InvalidParameter.KMSKeyId.NotFound | The specified KMSKeyId does not exist. Please verify that the key ID is correct and that the key resides in the current region. | |
| 400 | InvalidSnapshotName.Malformed | The specified SnapshotName is malformed. | |
| 400 | IncorrectInstanceStatus | The current status of the resource does not support this operation. | 現在のインスタンスステータスでは、この操作はサポートされていません。 |
| 400 | DiskCategory.OperationNotSupported | The type of the specified disk does not support creating a snapshot. | 現在のディスクタイプはこの操作をサポートしていません。 |
| 400 | Duplicate.TagKey | The Tag.N.Key contain duplicate key. | タグ内に重複するキーが存在します。すべてのキーが一意であることを確認してください。 |
| 400 | InvalidTagKey.Malformed | The specified Tag.n.Key is not valid. | 指定されたタグキーパラメーターが無効です。 |
| 400 | InvalidTagValue.Malformed | The specified Tag.n.Value is not valid. | 指定されたタグ値パラメーターが無効です。 |
| 400 | InvalidRetentionDays.Malformed | The specified RetentionDays is not valid. | 指定された保持日数の値が無効です。RetentionDays パラメーター値が正しいかどうかを確認してください。 |
| 400 | CreateSnapshot.Failed | The process of creating snapshot is failed. | スナップショットの作成に失敗しました。 |
| 400 | InvalidOperation.StorageLocationMismatch | The specified storageLocation does not match the storage location of the last snapshot for the disk. Ensure the storageLocation is consistent with previous snapshots. | |
| 500 | InternalError | The request processing has failed due to an internal error and you may retry later or contact support with the request ID. | |
| 403 | Throttling | Request was denied due to user flow control. | リクエストがスロットルされました。 |
| 403 | IncorrectDiskStatus.CreatingSnapshot | A previous snapshot creation is in process. | |
| 403 | InstanceLockedForSecurity | The disk attached instance is locked due to security. | |
| 403 | IncorrectDiskStatus.NeverAttached | The specified disk has never been attached to any instance. | |
| 403 | QuotaExceed.Snapshot | The snapshot quota exceeds. | |
| 403 | IncorrectDiskStatus.NeverUsed | The specified disk has never been used after creating. | |
| 403 | CreateSnapshot.Failed | The process of creating snapshot is failed. | |
| 403 | DiskInArrears | The specified operation is denied as your disk has expired. | |
| 403 | DiskId.ValueNotSupported | The specified parameter diskid is not supported. | 指定されたブロックストレージタイプではこの操作はサポートされていません。 |
| 403 | IncorrectDiskStatus | The current disk status does not support this operation. | |
| 403 | InvalidAccountStatus.NotEnoughBalance | Your account does not have enough balance. | |
| 403 | InvalidAccountStatus.SnapshotServiceUnavailable | Snapshot service has not been opened yet. | スナップショットサービスが有効化されていません。操作を実行できません。 |
| 403 | IncorrectInstanceStatus | The current status of the resource does not support this operation. | |
| 403 | IncorrectVolumeStatus | The current volume status does not support this operation. | 現在のステータスではこの操作はサポートされていません。 |
| 403 | IdempotentParameterMismatch | The specified clientToken is used. | リクエストパラメーターが、同じ ClientToken を持つリクエストと一致しません。 |
| 403 | IncorrectDiskStatus.Invalid | The specified disk status is invalid. Restart the instance and try again. | |
| 403 | IncorrectDiskType.NotSupport | The specified device type is not supported. | 指定されたディスクのストレージタイプでは、この操作はサポートされていません。 |
| 403 | IncorrectDiskStatus.Transferring | The specified device is transferring. You can retry after the process is finished. | |
| 403 | InvalidParameter.KMSKeyId.CMKUnauthorized | ECS tags must be added to the CMK. | ECS タグをカスタマーマスターキー (CMK) に追加する必要があります。 |
| 403 | InvalidParameter.KMSKeyId.CMKNotEnabled | The CMK needs to be enabled. | |
| 403 | InvalidParameter.KMSKeyId.KMSUnauthorized | ECS service does not have permission to access your KMS key. Please verify that the specified KMS key has authorized the ECS service. | |
| 403 | IdempotentProcessing | The previous idempotent request(s) is still processing. | 前の冪等リクエストはまだ処理中です。後でもう一度お試しください。 |
| 403 | InvalidSnapshotCategory.Malformed | The specified Category is not valid. | 指定されたスナップショットタイプが無効です。Category パラメーター値が正しいかどうかを確認してください。 |
| 403 | InvalidAction.Unauthorized | The specified action is not valid. | 指定された操作が無効です。 |
| 403 | InvalidRegion.NotSupportSnapshotInstantAccessRegion | The snapshot InstantAccess is not supported for this region. | |
| 403 | InvalidCategoryAndInstantAccess.Malformed | The snapshot Category and InstantAccess can't be used together. | |
| 403 | DISK_HAS_CREATING_SNAPSHOT | The operation cannot be performed while a snapshot is being created for the disk. | |
| 403 | HibernationConfigured.InstanceOperationForbidden | The operation is not permitted due to limit of the hibernation configured instance. | インスタンスが休止状態オプションの有効化要件を満たしていないため、操作は許可されません。 |
| 403 | QuotaExceed.SnapshotQuota | The quota is insufficient. Please contact your channel partner to increase the quota. | |
| 403 | InvalidInstantAccessRetentionDays.Malformed | The specified InstantAccessRetentionDays is not valid. | 指定された InstantAccessRetentionDays パラメーターの形式が無効です。 |
| 403 | CloudBoxNotSupportSnapshotWithInstantAccess | The specified disk in CloudBox does not support to create a snapshot with InstantAccess. | CloudBox のディスクでは、即時アクセス特徴を使用したスナップショットの作成はサポートされていません。 |
| 403 | InvalidOperation.UnfinishedEncryptedSnapshotCopy | This disk has unfinished encrypted copy snapshots in the target region. | ディスクに未完了の暗号化スナップショットコピータスクがあります。 |
| 403 | QuotaExceed.ConcurrentSnapshotQuota | The number of snapshots being created for the disk %s has exceeded the concurrent quota (%s). Please wait for the previous snapshots to complete before trying again. | このディスクで作成中のスナップショット数が同時実行数クォータを超えています。前のスナップショットが完了するのを待ってから、もう一度お試しください。 |
| 403 | InvalidClientToken.Malformed | The specified clientToken is improperly formatted. It must contain only ASCII characters and must not exceed 64 characters in length. | 指定された冪等パラメーターが無効です。 |
| 403 | InvalidParameter.UnauthorizedStorageLocationArn | The operation has failed due to lack of permission for the specified "StorageLocationArn". Please use a resource with appropriate permission for the operation. | 指定された StorageLocationArn の権限が不足しているため、現在の操作に失敗しました。リソースの管理者に連絡して、必須の権限を取得してください。 |
| 403 | InvalidStorageLocationArn.Malformed | The specified parameter StorageLocationArn is malformed. | |
| 403 | InvalidStatus.ResourceGroup | You cannot perform an operation on a resource group that is being created or deleted. | リソースグループの作成中または削除中は、操作を実行できません。 |
| 403 | OperationDenied.QuotaExceed | The quota of tags on resource is beyond permitted range. | リソースタグの数が上限に達しました。 |
| 403 | Forbidden.InDebt | The operation is not allowed because your account has an outstanding balance. Please settle the overdue payment and try again. | |
| 404 | InvalidDiskId.NotFound | The specified DiskId does not exist. | 指定されたディスクが存在しません。ディスク ID が正しいかどうかを確認してください。 |
| 404 | InvalidDescription.Malformed | The specified description is malformed. | |
| 404 | InvalidInstanceId.NotFound | The specified InstanceId does not exist. | 指定されたインスタンスが存在しません。インスタンス ID が正しいかどうかを確認してください。 |
| 404 | InvalidVolumeId.NotFound | The specified volume does not exist. | |
| 404 | InvalidResourceGroup.NotFound | The ResourceGroup provided does not exist in our records. | Record にリソースグループが見つかりません。 |
完全なリストについては、「エラーコード」をご参照ください。
変更履歴
完全なリストについては、「変更履歴」をご参照ください。