Manually renews a subscription ApsaraDB RDS instance.
Operation description
Supported engines
ApsaraDB RDS for MySQL
ApsaraDB RDS for PostgreSQL
ApsaraDB RDS for SQL Server
ApsaraDB RDS for MariaDB
Related documentation
Try it now
Test
RAM authorization
|
Action |
Access level |
Resource type |
Condition key |
Dependent action |
|
rds:RenewInstance |
update |
*DBInstance
|
|
None |
Request parameters
|
Parameter |
Type |
Required |
Description |
Example |
| ClientToken |
string |
No |
The idempotency token generated by the client. It is an ASCII string with a maximum length of 64 characters. |
ETnLKlblzczshOTUbOCz**** |
| DBInstanceId |
string |
Yes |
The instance ID. You can call DescribeDBInstances to query the instance ID. |
rm-uf6wjk5**** |
| Period |
integer |
Yes |
The renewal duration. Unit: months. Valid values:
|
12 |
| AutoPay |
string |
No |
Specifies whether to enable automatic payment for the renewal. Valid values:
Note
To manually renew the instance in the console, refer to: |
True |
| AutoRenew |
string |
No |
Specifies whether to enable auto-renewal for the instance. Valid values:
|
true |
| AutoUseCoupon |
boolean |
No |
Specifies whether to use coupons. Valid values:
|
true |
| PromotionCode |
string |
No |
The coupon code. Note
This parameter is required when the AutoUseCoupon parameter is set to true (use coupons). |
726702810223 |
|
No |
Specifies whether to enable compression for the instance. |
off |
Response elements
|
Element |
Type |
Description |
Example |
|
object |
The response parameters. |
||
| OrderId |
integer |
The order ID. |
20181574543**** |
| RequestId |
string |
The request ID. |
1AD222E9-E606-4A42-BF6D-8A4442913CEF |
Examples
Success response
JSON format
{
"OrderId": 201815745430941,
"RequestId": "1AD222E9-E606-4A42-BF6D-8A4442913CEF\t"
}
Error codes
|
HTTP status code |
Error code |
Error message |
Description |
|---|---|---|---|
| 400 | InvalidConcurrentOperate | Concurrent operation is detected. | Concurrent operations exist. Wait until the previous operation is complete and try again. |
| 400 | ArrearageOrderExists | Your account has an outstanding balance. | Add funds to your Alibaba Cloud account, complete the overdue payments, and then try again. |
| 400 | OperationDenied.MultiRegions | Specified operation dose not support multiple regions. | The current operation does not support multiple regions. |
| 400 | RegionEndTimeDissolvedIndia | Cloud services in the India (Mumbai) region will be discontinued. Set the validity date to July 15, 2024 or earlier than July 15, 2024. | Hello customer, this area has been abolished. |
| 400 | RegionEndTimeDissolvedAustralia | Cloud services in the Australia (Sydney) region will be discontinued. Set the validity date to September 30, 2024 or earlier than September 30, 2024. | Hello customer, this area has been abolished. |
| 400 | CommodityServiceCalling.Exception | Failed to call commodity service. | Failed to call commodity service return. |
| 400 | Commodity.InvalidComponent | The module you purchased is not legal, please buy it again. | The module you purchased is not legal, please buy it again. |
| 400 | Pay.InsufficientBalance | Insufficient available balance. | Insufficient available balance. |
| 400 | Price.CommoditySys | Commodity system call exception. | Commodity system call exception. |
| 400 | InvalidParam.UsedTime | The renewal expiration date cannot exceed:%s. | The current instance is of the classic network type, and the renewal time cannot exceed the limit time. |
| 400 | Order.ComboInstanceNotAllowOperate | A package instance is not allowed to operate independently. | A package instance is not allowed to operate independently. |
| 400 | Price.PricingPlanResultNotFound | Pricing plan price result not found. | Pricing plan price result not found. |
| 400 | Order.NoRealNameAuthentication | You have not passed the real-name authentication and do not meet the purchase conditions. Please log in to the user center for real-name authentication. | You have not passed the real-name authentication and do not meet the purchase conditions. Please log in to the cost and cost for real-name authentication. |
| 400 | InsufficientAvailableQuota | Your account quota limit is less than 0, please recharge before trying to purchase. | Your account available limit is less than 0, please recharge before trying to purchase. |
| 400 | RegionDissolvedEOM | Dear customer, Alibaba Cloud plans to optimize and adjust the current region. Cloud services in this region will cease operations. You are currently unable to operate new purchase orders. Thank you for your understanding and support. | Hello, Alibaba Cloud plans to optimize and adjust the current region. Cloud services in this region will stop operating. In order to ensure your business continuity and smooth transition of data migration, you are currently unable to operate new purchase orders. Thank you for your understanding and support. |
| 400 | Order.PeriodInvalid | There is a problem with the period you selected, please choose again. | There is a problem with the period you selected, please choose again. |
| 400 | pay.noCreditCard | Account not bound to credit card. | The account is not associated with a credit card. |
| 400 | Order.InstHasUnpaidOrder | There is an unpaid order for the service you have purchased. Please pay or void it before placing the order. | There is an unpaid order for the service you have purchased. Please pay or void it before placing the order. |
| 400 | noAvailablePaymentMethod | No payment method is specified for your account. We recommend that you add a payment method. | No payment method has been specified for your account. We recommend that you add a payment method. |
| 400 | BasicInfoUncompleted | Your information is incomplete. Complete your information before the operation. | Your basic information is not complete, please complete your basic information before operation. |
| 400 | Risk.RiskControlRejection | Your account is abnormal, please contact customer service for details. | Your account is abnormal, please contact customer service for details. |
| 400 | Api.NotSupport | Specified api is not supported. | The current interface does not support. |
| 400 | ContainForbiddenLabelError | There is a label that prohibits placing orders. Please contact your distributor for assistance. | You cannot place the order because a tag indicates that order placement is prohibited. Contact your distributor. |
| 400 | InvalidDBInstanceId.NotFound | The DBInstanceId provided does not exist in records. | The DBInstanceId provided does not exist. |
| 400 | InvalidInstanceLevel.DiskType | Specified instance level not support request disk type | The current instance type does not support the specified storage type. |
| 400 | InvalidParam | Sepcified wal level Parameter is invalid. There are still logical slots in instance, so it can not be set as replica. | The specified wal_level parameter is invalid. There is still a copy slot in the instance, so it cannot be set to replica. |
| 400 | KmsApiError | User secret key invalid. | The user key is invalid. |
| 400 | System.SaleValidateFailed | Sales expression validation system error. | A system error occurs when the sales expression is verified. |
| 400 | Abs.InvalidAccount.NotFound | account is not found. | The account does not exist. |
| 400 | SqlExecuteFailedOrTimeout | sql command execution failed or timed out:%s. | SQL command execution failed or timed out |
| 400 | ColdData.EngineVersionNotSupport | The current instance engine version not support coldDataEnabled. | The current instance engine version not support coldDataEnabled. |
| 400 | ColdData.MinorVersionNotSupport | The current instance minor version not support coldDataEnabled. | The current instance minor version not support coldDataEnabled. |
| 400 | IncorrectTargetClasscode | The current instance type does not support this operation. | This operation is not supported by the instance type. |
| 400 | InvalidConnectionString.Duplicate | Specified connection string already exists in the RDS. | The link address name is duplicate. Please reset the connection string. |
| 400 | RequiredParam.NotFound | Required input param is not found. | Required parameters are missing. |
| 400 | Parameters.Invalid | Parameter error, please check the parameters. | Parameter error, please check the parameters. |
| 400 | BackupPolicyNotSupport | Cold Data won't open with CrossBackup or Flash Backup, please check Backup Policy. | Cold Data won't open with CrossBackup or Flash Backup, please check Backup Policy. |
| 400 | InvalideStatus.Format | The instance status does not support this operation. | The instance status does not support this operation. |
| 400 | InvalidReleasedKeepPolicy.Format | Specified Released Keep Policy is not valid. | Specified Released Keep Policy is not valid. |
| 400 | InvalidDBInstanceEngineType.Format | the DB instance engine type does not support this operation. | This operation is not supported for the database engine of the instance. |
| 400 | Pay.NoCreditCard | No credit cards. | No credit cards. |
| 400 | VpcNetworkTypeNotSupport | The vpc network type instance does not support this operation. | The vpc network type instance does not support this operation. |
| 400 | MirrorInsExists | Specified DB instance mirror ins already existed. | Specified DB instance mirror ins already existed. |
| 400 | UnsupportedClassCode | The specified DB instance class stops selling. | The specified DB instance class stops selling. |
| 400 | InvalidBackupSet | The specified database does not exist in the backup set. | The specified database does not exist in the backup set. |
| 400 | OrdTCommodityQueryError | Failed to query for product. | Failed to query product. |
| 400 | ProductInstanceReleased | The instance has been released. Please check before placing the order. | The instance has been released, please verify and place an order. |
| 400 | StopService.Renew | The service has been discontinued and renewal operations for instances on the classic network are no longer allowed. | The classic network is offline. The current instance is of the classic network type and has exceeded the service stop time. You cannot renew the instance. |
| 500 | ExternalFailure | The request processing has failed due to external service failure. | The request processing has failed due to external service failure. |
| 500 | RequestMetaDataFailed | The service request failed. Please try again later or contact service personnel. | The service request failed. Please try again later or contact service personnel. |
| 500 | InvokeProxyFailure | The request processing has failed due to service failure of rds api. | The request failed to be processed due to an RDS API failure. |
| 403 | OrderStatus.UnPaid | The specified db instance has unpaid order. | The instance has an unpaid order. Please pay first and try again. |
| 403 | InvalidReduceDiskSize | The storage capacity after the scale-down must be larger than the used amount. | The scale-in target capacity cannot be less than the current storage space usage |
| 403 | CloudSSDNotSupport | Cloud ssd does not support this operation, please upgrade to essd. | This operation is not supported for SSD cloud disks. Upgrade to ESSD. |
| 403 | InvalidUserOperatorPermission | The user permission does not support this operation. | The user is not authorized to perform this operation. |
| 403 | InvalidVswitchId | Specified conn vswitch id is not valid. | The specified VSwitchId is in an invalid format or is empty. |
| 403 | IncorrectMinorVersion | Current engine minor version does not support operations. | This operation is not supported for the current minor engine version. |
| 403 | OperationDenied.ZoneResource | There is no available zone for inventory. | There is no available zone for inventory. |
| 403 | NotInFlowController | Sorry,no permission. | Sorry,no permission. |
| 403 | InvalidKmsKey | Kms key is disabled. | The KMS key is disabled. |
| 403 | InvalidInstanceLevel.Malformed | Current DB instance level does not support this operation. | The specified database instance type does not support this operation. |
| 404 | InvalidOrderCharge.NotSupport | The specified order charge does not support in RDS. | The operation failed. ApsaraDB RDS supports two billing methods: subscription (Prepaid) and pay-as-you-go (Postpaid). Specify a valid billing method by using the PayType parameter. |
| 404 | InvalidClusterKms | The current instance does not authorized to access the Key Management Service. | The instance does not have permissions to access Key Management Service (KMS). |
| 404 | Request.NotFound | The requested resource is not available. | The requested resources are unavailable. |
| 404 | HostInfo.NotFound | The specified host info is not found. | The specified host information does not exist. |
See Error Codes for a complete list.
Release notes
See Release Notes for a complete list.