Use DTS to synchronize data from a PolarDB for MySQL cluster to an AnalyticDB for MySQL 3.0 cluster to quickly build internal business intelligence (BI), interactive query, and real-time reporting systems.
Prerequisites
The source PolarDB for MySQL cluster is created. For more information, see Custom Purchase and Purchase a subscription cluster.
2070624_v1_3_4.dita" data-node="2755247">.
You have created a destination AnalyticDB for MySQL 3.0. For details, see Create a cluster.
The destination AnalyticDB for MySQL instance requires more storage space than the source PolarDB for MySQL instance uses.
Limitations
During database and table schema synchronization, DTS does not synchronize foreign keys from the source database to the destination database.
Throughout both full and incremental synchronization, DTS temporarily disables constraint checks and foreign key cascading operations at the session level. If cascading updates or deletions occur in the source database while the task is running, data inconsistency may result.
DTS does not support synchronizing materialized views to the destination AnalyticDB MySQL instance during schema synchronization; if materialized views are required, you must create them manually on the destination instance after synchronization is complete.
Type | Description |
Source database limits |
|
Other limits |
|
Other notes | DTS periodically runs the CREATE DATABASE IF NOT EXISTS `test` command on the source database to advance the binary log offset. |
Billing
|
Synchronization type |
Pricing |
|
Schema synchronization and full data synchronization |
Free of charge. |
|
Incremental data synchronization |
Charged. For more information, see Billing overview. |
Supported synchronization topologies
-
One-way one-to-one synchronization
-
One-way one-to-many synchronization
-
One-way many-to-one synchronization
Supported SQL operations
|
Operation type |
SQL statement |
|
DML |
INSERT, UPDATE, and DELETE Note
When data is written to the AnalyticDB for MySQL cluster, the UPDATE statement is automatically converted to the REPLACE INTO statement. |
|
DDL |
CREATE TABLE, DROP TABLE, RENAME TABLE, TRUNCATE TABLE, ADD COLUMN, and DROP COLUMN |
If the data type of a field in the source table is changed during data synchronization, an error is returned and the synchronization task is interrupted. To troubleshoot this issue:
-
While DTS synchronizes data to the destination AnalyticDB for MySQL cluster, the data type of a field in the source table is changed, causing the synchronization task to fail. In this example, the source table is named customer.
-
In the destination AnalyticDB for MySQL V3.0 cluster, create a table named customer_new that has the same schema as the customer table.
-
Execute the INSERT INTO SELECT statement to copy data from the customer table to the customer_new table.
-
Rename or delete the customer table. Then, change the name of the customer_new table to customer.
-
Restart the data synchronization task in the DTS console.
Procedure
Go to the data synchronization task list page in the destination region. You can do this in one of two ways.
DTS console
Log on to the DTS console.
In the navigation pane on the left, click Data Synchronization.
In the upper-left corner of the page, select the region where the synchronization instance is located.
DMS console
NoteThe actual steps may vary depending on the mode and layout of the DMS console. For more information, see Simple mode console and Customize DMS console layout and style.
Log on to the DMS console.
In the top menu bar, choose .
To the right of Data Synchronization Tasks, select the region of the synchronization instance.
Click Create Task to open the task configuration page.
Configure the source and destination databases.
WarningAfter you select the source and destination instances, review the Limits at the top of the page. Otherwise, the task may fail or data inconsistency may occur.
Category
Parameter
Description
N/A
Task Name
DTS automatically generates a task name. We recommend that you specify a descriptive name for easy identification. The name does not need to be unique.
Source Database
Select Existing Connection
Select the registered database instance with DTS from the drop-down list. The database information below is automatically configured.
NoteIn the DMS console, this configuration item is Select a DMS database instance.
If you have not registered the database instance or do not need to use a registered instance, manually configure the database information below.
Database Type
Select PolarDB for MySQL.
Connection Type
Select Alibaba Cloud Instance.
Instance Region
Select the region of the source PolarDB for MySQL cluster.
PolarDB Cluster ID
Select the instance ID of the source PolarDB for MySQL cluster.
Database Account
Enter the database account of the source PolarDB for MySQL cluster. This account must have read permissions on the objects to be synchronized.
Database Password
Enter the password for the specified database account.
Encryption
Select an option based on your requirements. For more information, see Configure SSL encryption.
Destination Database
Select Existing Connection
Select the registered database instance with DTS from the drop-down list. The database information below is automatically configured.
NoteIn the DMS console, this configuration item is Select a DMS database instance.
If you have not registered the database instance or do not need to use a registered instance, manually configure the database information below.
Database Type
Select AnalyticDB for MySQL 3.0.
Connection Type
Select Alibaba Cloud Instance.
Instance Region
Select the region of the target AnalyticDB for MySQL 3.0 cluster.
Instance ID
Select the instance ID of the target AnalyticDB for MySQL 3.0 cluster.
Database Account
Enter the database account of the target AnalyticDB for MySQL 3.0 cluster. This account must have read and write permissions.
Database Password
Enter the password for the specified database account.
After you complete the configuration, click Test Connectivity and Proceed at the bottom of the page.
NoteEnsure that the IP address blocks of the DTS service are added to the security settings of the source and destination databases, either automatically or manually, to allow access from DTS servers. For more information, see Add the IP address whitelist of DTS servers.
Configure the task objects.
On the Configure Objects page, specify the objects to synchronize.
Parameter
Description
Synchronization Types
DTS always selects Incremental Data Synchronization. By default, you must also select Schema Synchronization and Full Data Synchronization. After the precheck, DTS initializes the destination cluster with the full data of the selected source objects, which serves as the baseline for subsequent incremental synchronization.
NoteIf Full Data Synchronization is selected, you can synchronize the schema and data of the table that is created by executing the CREATE TABLE statement to the destination database.
DDL and DML Operations to Be Synchronized
Select the DDL or DML operations to synchronize at the instance level. For information about supported operations, see Supported SQL operations.
NoteTo select SQL operations to synchronize at the database or table level, right-click an object in the Selected Objects list and select the desired SQL operations from the shortcut menu.
Merge Tables
Select Yes: In online transactional processing (TP) scenarios, sharding is often used to improve the response speed of business tables. In online analytical processing (OLAP) scenarios, a single table in the destination database can store large volumes of data, which simplifies single-table queries. In such scenarios, you can use the DTS table merging feature to synchronize multiple tables with the same schema (sharded tables) from the source database to a single table in the destination database. For details on this operation, see Enable table merging.
NoteAfter you select multiple tables from the source database, you must use the object name mapping feature to change their names to the same table name in the destination database. For more information about the object name mapping feature, see Object name mapping.
DTS adds a
__dts_data_sourcecolumn of the TEXT type to the destination table to store the data source. The column value is written in theDTS instance ID:database name:schema name:table nameformat to distinguish the source of the table, for example,dts********:dtstestdata:testschema:customer1.The table merging feature applies at the task level, not the table level. To merge only some tables, you must create a separate data synchronization task for them.
WarningDo not perform DDL operations that change the database or table schema in the source database. Otherwise, data inconsistency or task failure may occur.
No: This is the default option.
Processing Mode of Conflicting Tables
Precheck and Report Errors: Checks for tables with the same names in the destination database. If any tables with the same names are found, an error is reported during the precheck and the data synchronization task does not start. Otherwise, the precheck is successful.
NoteIf you cannot delete or rename the table with the same name in the destination database, you can map it to a different name in the destination. For more information, see Object name mapping.
Ignore Errors and Proceed: Skips the check for tables with the same name in the destination database.
WarningSelecting Ignore Errors and Proceed may cause data inconsistency and put your business at risk. For example:
If the table schemas are consistent and a record in the destination database has the same primary key or unique key value as a record in the source database:
During full data synchronization, DTS retains the destination record and skips the source record.
During incremental synchronization, DTS overwrites the destination record with the source record.
If the table schemas are inconsistent, data initialization may fail. This can result in only partial data synchronization or a complete synchronization failure. Use with caution.
Capitalization of Object Names in Destination Instance
Configure the case-sensitivity policy for database, table, and column names in the destination instance. By default, the DTS default policy is selected. You can also choose to use the default policy of the source or destination database. For more information, see Case policy for destination object names.
Source Objects
In the Source Objects box, click the objects, and then click
to move them to the Selected Objects box.Note-
You can select columns, tables, or databases as the objects to synchronize. If you select tables or columns, DTS does not synchronize other objects such as views, triggers, or stored procedures to the destination database.
-
If you select a database as the object to synchronize, DTS applies the following default rules:
-
If the source table has a primary key (single-column or composite), the primary key columns are used as the distribution keys.
-
If the source table does not have a primary key, an auto-increment primary key column is generated in the destination table. This may cause data inconsistency between the source and destination databases.
-
Selected Objects
To rename a single object in the destination instance, right-click the object in the Selected Objects box. For more information, see Map a single object name.
To rename multiple objects in bulk, click Batch Edit in the upper-right corner of the Selected Objects box. For more information, see Map multiple object names in bulk.
NoteTo select SQL operations to synchronize at the database or table level, right-click the object in the Selected Objects list and select the desired SQL operations in the dialog box that appears. For a list of supported operations, see Supported SQL operations.
To filter data by using a WHERE clause, right-click the table in the Selected Objects list and specify the filter condition in the dialog box that appears. For instructions, see Configure data filtering.
Click Next: Advanced Settings.
Parameter
Description
Dedicated Cluster for Task Scheduling
By default, DTS uses a shared cluster for tasks, so you do not need to make a selection. For greater task stability, you can purchase a dedicated cluster to run the DTS synchronization task. For more information, see What is a DTS dedicated cluster?.
Copy the temporary table of the Online DDL tool that is generated in the source table to the destination database.
DDL operations cannot be synchronized. Select No, Adapt To DMS Online DDL or No, Adapt To Gh-ost. If DDL synchronization is supported for this scenario in the future, you can choose whether to synchronize the temporary tables that are generated when you use Data Management (DMS) or gh-ost for online DDL changes.
Yes: Synchronizes data in temporary tables created by online DDL changes.
NoteIf the data of temporary tables generated by online DDL changes is too large, it may cause synchronization latency.
No, Adapt to DMS Online DDL: Does not synchronize data from temporary tables generated by online DDL changes. Only the original DDL statements executed in Data Management (DMS) are synchronized.
NoteThis option causes locked tables in the destination database.
Do not adapt to gh-ost: This option does not synchronize data from temporary tables generated by online DDL changes. Instead, it only synchronizes the original DDL statements executed by gh-ost. You can use default or custom regular expressions for gh-ost shadow and junk tables.
NoteThis option causes locked tables in the destination database.
Retry Time for Failed Connections
If the connection to the source or destination database fails after the synchronization task starts, DTS reports an error and immediately begins to retry the connection. The default retry duration is 720 minutes. You can customize the retry time to a value from 10 to 1,440 minutes. We recommend a duration of 30 minutes or more. If the connection is restored within this period, the task resumes automatically. Otherwise, the task fails.
NoteIf multiple DTS instances (e.g., Instance A and B) share a source or destination, DTS uses the shortest configured retry duration (e.g., 30 minutes for A, 60 for B, so 30 minutes is used) for all instances.
DTS charges for task runtime during connection retries. Set a custom duration based on your business needs, or release the DTS instance promptly after you release the source/destination instances.
Retry Time for Other Issues
If a non-connection issue (e.g., a DDL or DML execution error) occurs, DTS reports an error and immediately retries the operation. The default retry duration is 10 minutes. You can also customize the retry time to a value from 1 to 1,440 minutes. We recommend a duration of 10 minutes or more. If the related operations succeed within the set retry time, the synchronization task automatically resumes. Otherwise, the task fails.
ImportantThe value of Retry Time for Other Issues must be less than that of Retry Time for Failed Connections.
Enable Throttling for Full Data Synchronization
During full data synchronization, DTS consumes read and write resources from the source and destination databases, which can increase their load. To mitigate pressure on the destination database, you can limit the migration rate by setting Queries per second (QPS) to the source database, RPS of Full Data Migration, and Data migration speed for full migration (MB/s).
NoteThis parameter is available only if Synchronization Types is set to Full Data Synchronization.
You can also adjust the rate of full data synchronization when the synchronization instance is running.
Enable Throttling for Incremental Data Synchronization
You can also limit the incremental synchronization rate to reduce pressure on the destination database by setting RPS of Incremental Data Synchronization and Data synchronization speed for incremental synchronization (MB/s).
Environment Tag
You can select an environment tag to identify the instance based on your requirements. This parameter is optional.
Whether to delete SQL operations on heartbeat tables of forward and reverse tasks
Choose whether DTS writes heartbeat SQL information to the source database while the instance is running.
Yes: Does not write heartbeat SQL information to the source database. The DTS instance may display latency.
No: Writes heartbeat SQL information to the source database. This may interfere with source database operations like physical backups and cloning.
Configure ETL
Choose whether to enable the extract, transform, and load (ETL) feature. For more information, see What is ETL? Valid values:
-
Yes: Enables the ETL feature. Enter data processing statements in the code editor. For more information, see Configure ETL in a data migration or data synchronization task.
-
No: Disables the ETL feature.
Monitoring and Alerting
Choose whether to set up alerts. If the synchronization fails or the latency exceeds the specified threshold, DTS sends a notification to the alert contacts.
No: No alerts are configured.
Yes: Configures alerts. You must also set the alert threshold and alert notifications. For more information, see Configure monitoring and alerting during task configuration.
Click Data Verification to configure a data verification task.
To use the data verification feature, see Configure data verification.
Optional: After you complete the configuration, click Next: Configure Database and Table Fields to set the Type, Primary Key Column, Distribution Key, and partition key information (Partition Key, Partitioning Rules, and Partition Lifecycle) for the tables to sync in the destination database.
NoteThis step is available only if you select the Schema Synchronization checkbox for Synchronization Types during task object configuration. You can set Definition Status to All to make modifications.
You can use the Primary Key Column to specify a composite primary key that consists of multiple columns. You must then select one or more columns from the Primary Key Column to serve as the Distribution Key and Partition Key. For more information, see CREATE TABLE.
Save the task and perform a precheck.
To view the parameters for configuring this instance via an API operation, hover over the Next: Save Task Settings and Precheck button and click Preview OpenAPI parameters in the tooltip.
If you have finished viewing the API parameters, click Next: Save Task Settings and Precheck at the bottom of the page.
NoteBefore a synchronization task starts, DTS performs a precheck. You can start the task only if the precheck passes.
If the precheck fails, click View Details next to the failed item, fix the issue as prompted, and then rerun the precheck.
If the precheck generates warnings:
For non-ignorable warning, click View Details next to the item, fix the issue as prompted, and run the precheck again.
For ignorable warnings, you can bypass them by clicking Confirm Alert Details, then Ignore, and then OK. Finally, click Precheck Again to skip the warning and run the precheck again. Ignoring precheck warnings may lead to data inconsistencies and other business risks. Proceed with caution.
Purchase the instance.
When the Success Rate reaches 100%, click Next: Purchase Instance.
On the Purchase page, select the billing method and link specifications for the data synchronization instance. For more information, see the following table.
Category
Parameter
Description
New Instance Class
Billing Method
Subscription: You pay upfront for a specific duration. This is cost-effective for long-term, continuous tasks.
Pay-as-you-go: You are billed hourly for actual usage. This is ideal for short-term or test tasks, as you can release the instance at any time to save costs.
Resource Group Settings
The resource group to which the instance belongs. The default is default resource group. For more information, see What is resource management?.
Instance Class
DTS offers synchronization specifications at different performance levels that affect the synchronization rate. Select a specification based on your business requirements. For more information, see Data synchronization link specifications.
Subscription Duration
In subscription mode, select the duration and quantity of the instance. Monthly options range from 1 to 9 months. Yearly options include 1, 2, 3, or 5 years.
NoteThis option appears only when the billing method is Subscription.
Read and select the checkbox for Data Transmission Service (Pay-as-you-go) Service Terms.
Click Buy and Start, and then click OK in the OK dialog box.
You can monitor the task progress on the data synchronization page.