All Products
Search
Document Center

Data Transmission Service:Synchronize PolarDB-X 1.0 to Message Queue for Kafka

Last Updated:Aug 27, 2026

This topic explains how to synchronize data from a PolarDB-X 1.0 instance to an Alibaba Cloud Message Queue for Apache Kafka instance by using Data Transmission Service (DTS).

Prerequisites

  • You have created an ApsaraMQ for Kafka instance and a topic to receive the synchronized data. For more information, see Overview.

    Note

    For the versions supported by the source and destination, see Synchronization solutions overview.

  • The destination ApsaraMQ for Kafka instance's storage space must exceed that used by the source PolarDB-X 1.0 instance.

Limitations

Type

Description

Source database limitations

  • Tables to synchronize must have a primary key or a unique constraint to ensure each row is unique and prevent duplicate data in the destination database. If a table has only a unique constraint, schema synchronization is not supported for that table. We recommend that you use a primary key. Synchronization of tables with secondary indexes is not supported.

  • If you synchronize data at the table level and perform editing operations such as column name mapping, a single synchronization task supports a maximum of 5,000 tables. If you exceed this limit, split the tables into multiple tasks or synchronize the entire database. Otherwise, a request error may occur when you submit the task.

  • The binary logs of the ApsaraDB RDS for MySQL instances attached to the source PolarDB-X 1.0 instance must meet the following requirements:

    • The binary logging feature must be enabled, and the binlog_row_image parameter must be set to full. Otherwise, the precheck fails, and the data synchronization task cannot start.

    • For an incremental data synchronization task, you must retain the binary logs of the source database for at least 24 hours. For a task that includes both full and incremental data synchronization, the binary logs must be retained for at least 7 days. You can reduce the retention period to 24 hours after the full data synchronization is complete. If DTS cannot obtain the binary logs because the retention period is too short, the task may fail. In extreme cases, data inconsistency or loss can occur. Issues caused by a binary log retention period shorter than the DTS requirement are not covered by the DTS Service-Level Agreement (SLA).

  • Limitations on source database operations:

    • If you change the network type of the PolarDB-X 1.0 instance during data synchronization, you must update the connection information for the synchronization link.

    • During data synchronization, do not perform scaling on the source instance, such as scaling its attached ApsaraDB RDS for MySQL instances. Do not change the distribution of physical tables that correspond to logical tables in the ApsaraDB RDS for MySQL instances, modify shard keys, or perform DDL operations. Otherwise, the data synchronization task may fail or data inconsistency may occur.

    • If you perform only full synchronization, do not write new data to the source instance. Otherwise, data inconsistency between the source and destination databases will occur. To maintain real-time data consistency, we recommend selecting schema synchronization, full synchronization, and incremental synchronization.

    • Do not run DDL operations that change database or table schemas during schema synchronization or full synchronization. Otherwise, the synchronization task fails.

      Note

      During full synchronization, DTS queries the source database. This creates metadata locks that may block DDL operations on the source database.

  • The source PolarDB-X 1.0 instance must be version 5.2 or later.

Other limitations

  • Synchronization of INDEX, PARTITION, VIEW, PROCEDURE, FUNCTION, TRIGGER, and foreign key (FK) objects is not supported.

  • Data synchronization from a PolarDB-X 1.0 instance is a distributed process. A subtask is created for each attached ApsaraDB RDS for MySQL instance. You can view the status of each subtask in the task topology.

  • If the destination ApsaraMQ for Kafka instance is scaled during synchronization, you must restart the data synchronization task.

  • Incremental data synchronization relies on continuous XA transactions in the source PolarDB-X 1.0 instance to ensure data consistency. If this continuity is disrupted, for example when modifying synchronization objects or during disaster recovery of the incremental data capture module, uncommitted XA transactions may be lost.

  • Perform data synchronization during off-peak hours. Full data synchronization consumes read and write resources on both the source and destination databases, which increases their loads.

  • Full data synchronization performs concurrent INSERT operations, which can cause table fragmentation in the destination database. As a result, the destination tablespace is larger than the source after full data synchronization.

  • Do not use tools such as pt-online-schema-change to perform online DDL changes on synchronization objects in the source database. Otherwise, the synchronization task fails.

  • During data synchronization, do not write data to the destination database by using tools other than DTS. Otherwise, data inconsistencies may occur. For example, if you use DMS to perform an online DDL change while other data is being written to the destination database, data loss may occur.

  • During full and incremental synchronization, DTS temporarily disables constraint checks and foreign key cascading operations at the session level. If cascading update or delete operations occur on the source database while the task is running, data inconsistency may occur.

  • If a task fails, DTS support staff will attempt to restore it within eight hours. During restoration, they may restart the task or adjust its parameters.

    Note

    Only DTS task parameters are modified—not database parameters. Parameters that may be adjusted include those listed in Modify instance parameters.

Synchronization topologies

  • One-to-one one-way synchronization

  • One-to-many one-way synchronization

  • Cascade one-way synchronization

  • Many-to-one one-way synchronization

For an introduction to these synchronization topologies and their considerations, see Synchronization topologies.

Supported SQL operations

Operation type

SQL statement

DML

INSERT, UPDATE, and DELETE

Database account permissions

Database

Required permissions

Actions

Source PolarDB-X 1.0 instance

Read permission on the objects to sync.

Account management

Precautions

Procedure

  1. Go to the data synchronization task list page in the destination region. You can do this in one of two ways.

    DTS console

    1. Log on to the DTS console.

    2. In the navigation pane on the left, click Data Synchronization.

    3. In the upper-left corner of the page, select the region where the synchronization instance is located.

    DMS console

    Note

    The actual steps may vary depending on the mode and layout of the DMS console. For more information, see Simple mode console and Customize DMS console layout and style.

    1. Log on to the DMS console.

    2. In the top menu bar, choose Data + AI > DTS (DTS) > Data Synchronization.

    3. To the right of Data Synchronization Tasks, select the region of the synchronization instance.

  2. Click Create Task to open the task configuration page.

  3. Configure the source and destination databases.

    Category

    Parameter

    Description

    N/A

    Task Name

    DTS automatically generates a task name. We recommend that you specify a descriptive name for easy identification. The name does not need to be unique.

    Source Database

    Select Existing Connection

    • Select the registered database instance with DTS from the drop-down list. The database information below is automatically configured.

      Note

      In the DMS console, this configuration item is Select a DMS database instance.

    • If you have not registered the database instance or do not need to use a registered instance, manually configure the database information below.

    Database Type

    Select PolarDB-X 1.0.

    Connection Type

    Select Alibaba Cloud Instance.

    Instance Region

    Select the region where the source PolarDB-X 1.0 instance resides.

    Cross-account

    If you synchronize data within the same Alibaba Cloud account, select No.

    Instance ID

    Select the ID of the source PolarDB-X 1.0 instance.

    Database Account

    Enter the database account of the source PolarDB-X 1.0 instance. For information about the required permissions, see Permissions required for database accounts.

    Database Password

    Enter the password for the specified database account.

    Destination Database

    Select Existing Connection

    • Select the registered database instance with DTS from the drop-down list. The database information below is automatically configured.

      Note

      In the DMS console, this configuration item is Select a DMS database instance.

    • If you have not registered the database instance or do not need to use a registered instance, manually configure the database information below.

    Database Type

    Select Kafka.

    Connection Type

    Select Express Connect, VPN Gateway, or Smart Access Gateway.

    Note

    In this step, configure the synchronization instance by treating the ApsaraMQ for Kafka instance as if it were a self-managed Kafka database.

    Instance Region

    Select the region where the destination ApsaraMQ for Kafka instance resides.

    Connected VPC

    Select the ID of the Virtual Private Cloud (VPC) where the destination ApsaraMQ for Kafka instance is located. You can find the VPC ID on the Basic Information page of the ApsaraMQ for Kafka instance.

    Domain Name or IP

    Enter an IP address from the Default Endpoint of the ApsaraMQ for Kafka instance.

    Note

    You can find the IP address of the Default Endpoint on the Basic Information page of the ApsaraMQ for Kafka instance.

    Port

    The service port of the ApsaraMQ for Kafka instance. The default value is 9092.

    Database Account

    Enter the database account and password of the destination ApsaraMQ for Kafka instance.

    Note

    You only need to provide an account and password for ApsaraMQ for Kafka instances with Access Control Lists (ACLs) enabled. For more information, see Grant permissions to SASL users.

    Database Password

    Kafka Version

    Select the version of your ApsaraMQ for Kafka instance.

    Connection Method

    Select Non-encrypted or SCRAM-SHA-256 based on your business and security requirements.

    Topic

    From the drop-down list, select the topic to receive the data.

    Use Kafka Schema Registry

    Kafka Schema Registry is a serving layer for your metadata. It provides a RESTful API to store and retrieve your Avro schemas.

    • No: Does not use Kafka Schema Registry.

    • Yes: Uses Kafka Schema Registry. You must enter the URL or IP address of the Avro schema registered in Kafka Schema Registry.

  4. After completing the configuration, click Test Connectivity and Proceed at the bottom of the page.

    Note
    • Ensure that you add the CIDR blocks of the DTS servers (either automatically or manually) to the security settings of both the source and destination databases to allow access. For more information, see Add the IP address whitelist of DTS servers.

    • If the source or destination is a self-managed database (i.e., the Access Method is not Alibaba Cloud Instance), you must also click Test Connectivity in the CIDR Blocks of DTS Servers dialog box.

  5. Configure the task objects.

    1. On the Configure Objects page, specify the objects to synchronize.

      Parameter

      Description

      Synchronization Type

      DTS always selects Incremental Data Synchronization. By default, you must also select Schema Synchronization and Full Data Synchronization. After the precheck, DTS initializes the destination cluster with the full data of the selected source objects, which serves as the baseline for subsequent incremental synchronization.

      Note

      If you select Full Data Synchronization, the schema and data of tables for which a CREATE TABLE statement is executed can be synchronized to the destination database.

      Processing Mode for Existing Destination Tables

      • Precheck and Report Errors: Checks for tables with the same names in the destination database. If any tables with the same names are found, an error is reported during the precheck and the data synchronization task does not start. Otherwise, the precheck is successful.

        Note

        If you cannot delete or rename the table with the same name in the destination database, you can map it to a different name in the destination. For more information, see Object name mapping.

      • Ignore Errors and Proceed: Skips the check for tables with the same name in the destination database.

        Warning

        Selecting Ignore Errors and Proceed may cause data inconsistency and put your business at risk. For example:

        • If the table schemas are consistent and a record in the destination database has the same primary key or unique key value as a record in the source database:

          • During full data synchronization, DTS retains the destination record and skips the source record.

          • During incremental synchronization, DTS overwrites the destination record with the source record.

        • If the table schemas are inconsistent, data initialization may fail. This can result in only partial data synchronization or a complete synchronization failure. Use with caution.

      Data Format in Kafka

      Select the storage format for data synchronized to the ApsaraMQ for Kafka instance.

      Note

      PolarDB-X 1.0 does not support Canal JSON. You must select DTS Avro.

      Kafka Data Compression Format

      Select the compression format for Kafka message compression based on your business requirements.

      • LZ4 (default): The compression ratio is low, but the compression speed is high.

      • GZIP: The compression ratio is high, but the compression speed is low.

        Note

        CPU consumption is high.

      • Snappy: The compression ratio and compression speed are medium.

      Policy for Shipping Data to Kafka Partitions

      Message acknowledgement mechanism

      Select a message acknowledgment mechanism based on your business requirements.

      Topic That Stores DDL Information

      Select the topic that is used to store DDL information from the drop-down list.

      Note

      If not specified, the DDL information is stored in the topic that receives the data by default.

      Case Policy for Destination Object Names

      Configure the case-sensitivity policy for database, table, and column names in the destination instance. By default, the DTS default policy is selected. You can also choose to use the default policy of the source or destination database. For more information, see Case policy for destination object names.

      Source Objects

      In the Source Objects box, click the objects, and then click 向右 to move them to the Selected Objects box.

      Note

      We recommend that you select objects at the table level. If you select an entire database as a synchronization object, changes to add or delete tables in the source database are not synchronized to the destination database.

      Selected Objects

      You can use the mapping feature to set the topic name, number of partitions, and partition key for the source table in the destination ApsaraMQ for Kafka instance. For more information, see Map information.

      Note
      • If you use the object name mapping feature, the synchronization of other objects that depend on the mapped object may fail.

      • To select the SQL operations for incremental data synchronization, right-click the object in the Selected Objects box and select the desired SQL operations in the dialog box.

    2. Click Next: Advanced Settings.

      Parameter

      Description

      Dedicated Cluster for Task Scheduling

      By default, DTS uses a shared cluster for tasks, so you do not need to make a selection. For greater task stability, you can purchase a dedicated cluster to run the DTS synchronization task. For more information, see What is a DTS dedicated cluster?.

      Retry Time for Failed Connections

      If the connection to the source or destination database fails after the synchronization task starts, DTS reports an error and immediately begins to retry the connection. The default retry duration is 720 minutes. You can customize the retry time to a value from 10 to 1,440 minutes. We recommend a duration of 30 minutes or more. If the connection is restored within this period, the task resumes automatically. Otherwise, the task fails.

      Note
      • If multiple DTS instances (e.g., Instance A and B) share a source or destination, DTS uses the shortest configured retry duration (e.g., 30 minutes for A, 60 for B, so 30 minutes is used) for all instances.

      • DTS charges for task runtime during connection retries. Set a custom duration based on your business needs, or release the DTS instance promptly after you release the source/destination instances.

      Retry Time for Other Issues

      If a non-connection issue (e.g., a DDL or DML execution error) occurs, DTS reports an error and immediately retries the operation. The default retry duration is 10 minutes. You can also customize the retry time to a value from 1 to 1,440 minutes. We recommend a duration of 10 minutes or more. If the related operations succeed within the set retry time, the synchronization task automatically resumes. Otherwise, the task fails.

      Important

      The value of Retry Time for Other Issues must be less than that of Retry Time for Failed Connections.

      Enable Throttling for Full Data Synchronization

      During full data synchronization, DTS consumes read and write resources from the source and destination databases, which can increase their load. To mitigate pressure on the destination database, you can limit the migration rate by setting Queries per second (QPS) to the source database, RPS of Full Data Migration, and Data migration speed for full migration (MB/s).

      Note

      Enable Throttling for Incremental Data Synchronization

      You can also limit the incremental synchronization rate to reduce pressure on the destination database by setting RPS of Incremental Data Synchronization and Data synchronization speed for incremental synchronization (MB/s).

      Environment Tag

      You can select an environment tag to identify the instance. This is not required for this example.

      Configure ETL

      Choose whether to enable the extract, transform, and load (ETL) feature. For more information, see What is ETL? Valid values:

      Monitoring and Alerting

      Choose whether to set up alerts. If the synchronization fails or the latency exceeds the specified threshold, DTS sends a notification to the alert contacts.

  6. Save the task and perform a precheck.

    • To view the parameters for configuring this instance via an API operation, hover over the Next: Save Task Settings and Precheck button and click Preview OpenAPI parameters in the tooltip.

    • If you have finished viewing the API parameters, click Next: Save Task Settings and Precheck at the bottom of the page.

    Note
    • Before a synchronization task starts, DTS performs a precheck. You can start the task only if the precheck passes.

    • If the precheck fails, click View Details next to the failed item, fix the issue as prompted, and then rerun the precheck.

    • If the precheck generates warnings:

      • For non-ignorable warning, click View Details next to the item, fix the issue as prompted, and run the precheck again.

      • For ignorable warnings, you can bypass them by clicking Confirm Alert Details, then Ignore, and then OK. Finally, click Precheck Again to skip the warning and run the precheck again. Ignoring precheck warnings may lead to data inconsistencies and other business risks. Proceed with caution.

  7. Purchase the instance.

    1. When the Success Rate reaches 100%, click Next: Purchase Instance.

    2. On the Purchase page, select the billing method and link specifications for the data synchronization instance. For more information, see the following table.

      Category

      Parameter

      Description

      New Instance Class

      Billing Method

      • Subscription: You pay upfront for a specific duration. This is cost-effective for long-term, continuous tasks.

      • Pay-as-you-go: You are billed hourly for actual usage. This is ideal for short-term or test tasks, as you can release the instance at any time to save costs.

      Resource Group Settings

      The resource group to which the instance belongs. The default is default resource group. For more information, see What is resource management?.

      Instance Class

      DTS offers synchronization specifications at different performance levels that affect the synchronization rate. Select a specification based on your business requirements. For more information, see Data synchronization link specifications.

      Subscription Duration

      In subscription mode, select the duration and quantity of the instance. Monthly options range from 1 to 9 months. Yearly options include 1, 2, 3, or 5 years.

      Note

      This option appears only when the billing method is Subscription.

    3. Read and select the checkbox for Data Transmission Service (Pay-as-you-go) Service Terms.

    4. Click Buy and Start, and then click OK in the OK dialog box.

      You can monitor the task progress on the data synchronization page.

Mapping information

  1. In the Selected Objects area, hover over the destination topic name (at the table level).

  2. Click Edit that appears next to the destination topic name.

  3. In the Edit Table dialog box that appears, configure the mapping information.

    Note
    • At the database level, the Edit Schema dialog box supports fewer configurable parameters. At the table level, the Edit Table dialog box appears.

    • If the granularity of the synchronization objects is not the entire database, you cannot modify the Name of target Topic or Number of Partitions in the Edit Schema dialog box.

    Parameter

    Description

    Name of target Topic

    The name of the destination topic to which the source table is synchronized. The default value is the Topic that you specified for the Destination Database in the Configurations for Source and Destination Databases step.

    Important
    • When the destination database is a ApsaraMQ for Kafka instance, the topic name that you specify must exist in the destination Kafka instance. Otherwise, data synchronization fails. If the destination database is a self-managed Kafka database and the synchronization task includes schema synchronization, DTS attempts to create the topic that you specified in the destination database.

    • If you modify the Name of target Topic, data is written to the topic that you specified.

    Filter Conditions

    For more information, see Filter task data with an SQL condition.

    Number of Partitions

    The number of partitions when data is written to the destination topic.

    Partition Key

    When Policy for Shipping Data to Kafka Partitions is set to Ship Data to Separate Partitions Based on Hash Values of Primary Keys, you can configure this parameter. Specify one or more columns as the Partition Key that is used to calculate the hash value. DTS then delivers rows to different partitions of the destination topic based on the calculated hash values.

    Note

    You can select Partition Key only in the Edit Table dialog box.

  4. Click OK.

FAQ