This topic explains how to synchronize data from a PolarDB-X 1.0 instance to an Alibaba Cloud Message Queue for Apache Kafka instance by using Data Transmission Service (DTS).
Prerequisites
You have created an ApsaraMQ for Kafka instance and a topic to receive the synchronized data. For more information, see Overview.
NoteFor the versions supported by the source and destination, see Synchronization solutions overview.
The destination ApsaraMQ for Kafka instance's storage space must exceed that used by the source PolarDB-X 1.0 instance.
Limitations
Type | Description |
Source database limitations |
|
Other limitations |
|
Synchronization topologies
One-to-one one-way synchronization
One-to-many one-way synchronization
Cascade one-way synchronization
Many-to-one one-way synchronization
For an introduction to these synchronization topologies and their considerations, see Synchronization topologies.
Supported SQL operations
Operation type | SQL statement |
DML | INSERT, UPDATE, and DELETE |
Database account permissions
Database | Required permissions | Actions |
Source PolarDB-X 1.0 instance | Read permission on the objects to sync. |
Precautions
Procedure
Go to the data synchronization task list page in the destination region. You can do this in one of two ways.
DTS console
Log on to the DTS console.
In the navigation pane on the left, click Data Synchronization.
In the upper-left corner of the page, select the region where the synchronization instance is located.
DMS console
NoteThe actual steps may vary depending on the mode and layout of the DMS console. For more information, see Simple mode console and Customize DMS console layout and style.
Log on to the DMS console.
In the top menu bar, choose .
To the right of Data Synchronization Tasks, select the region of the synchronization instance.
Click Create Task to open the task configuration page.
Configure the source and destination databases.
Category
Parameter
Description
N/A
Task Name
DTS automatically generates a task name. We recommend that you specify a descriptive name for easy identification. The name does not need to be unique.
Source Database
Select Existing Connection
Select the registered database instance with DTS from the drop-down list. The database information below is automatically configured.
NoteIn the DMS console, this configuration item is Select a DMS database instance.
If you have not registered the database instance or do not need to use a registered instance, manually configure the database information below.
Database Type
Select PolarDB-X 1.0.
Connection Type
Select Alibaba Cloud Instance.
Instance Region
Select the region where the source PolarDB-X 1.0 instance resides.
Cross-account
If you synchronize data within the same Alibaba Cloud account, select No.
Instance ID
Select the ID of the source PolarDB-X 1.0 instance.
Database Account
Enter the database account of the source PolarDB-X 1.0 instance. For information about the required permissions, see Permissions required for database accounts.
Database Password
Enter the password for the specified database account.
Destination Database
Select Existing Connection
Select the registered database instance with DTS from the drop-down list. The database information below is automatically configured.
NoteIn the DMS console, this configuration item is Select a DMS database instance.
If you have not registered the database instance or do not need to use a registered instance, manually configure the database information below.
Database Type
Select Kafka.
Connection Type
Select Express Connect, VPN Gateway, or Smart Access Gateway.
NoteIn this step, configure the synchronization instance by treating the ApsaraMQ for Kafka instance as if it were a self-managed Kafka database.
Instance Region
Select the region where the destination ApsaraMQ for Kafka instance resides.
Connected VPC
Select the ID of the Virtual Private Cloud (VPC) where the destination ApsaraMQ for Kafka instance is located. You can find the VPC ID on the Basic Information page of the ApsaraMQ for Kafka instance.
Domain Name or IP
Enter an IP address from the Default Endpoint of the ApsaraMQ for Kafka instance.
NoteYou can find the IP address of the Default Endpoint on the Basic Information page of the ApsaraMQ for Kafka instance.
Port
The service port of the ApsaraMQ for Kafka instance. The default value is 9092.
Database Account
Enter the database account and password of the destination ApsaraMQ for Kafka instance.
NoteYou only need to provide an account and password for ApsaraMQ for Kafka instances with Access Control Lists (ACLs) enabled. For more information, see Grant permissions to SASL users.
Database Password
Kafka Version
Select the version of your ApsaraMQ for Kafka instance.
Connection Method
Select Non-encrypted or SCRAM-SHA-256 based on your business and security requirements.
Topic
From the drop-down list, select the topic to receive the data.
Use Kafka Schema Registry
Kafka Schema Registry is a serving layer for your metadata. It provides a RESTful API to store and retrieve your Avro schemas.
No: Does not use Kafka Schema Registry.
Yes: Uses Kafka Schema Registry. You must enter the URL or IP address of the Avro schema registered in Kafka Schema Registry.
After completing the configuration, click Test Connectivity and Proceed at the bottom of the page.
NoteEnsure that you add the CIDR blocks of the DTS servers (either automatically or manually) to the security settings of both the source and destination databases to allow access. For more information, see Add the IP address whitelist of DTS servers.
If the source or destination is a self-managed database (i.e., the Access Method is not Alibaba Cloud Instance), you must also click Test Connectivity in the CIDR Blocks of DTS Servers dialog box.
Configure the task objects.
On the Configure Objects page, specify the objects to synchronize.
Parameter
Description
Synchronization Type
DTS always selects Incremental Data Synchronization. By default, you must also select Schema Synchronization and Full Data Synchronization. After the precheck, DTS initializes the destination cluster with the full data of the selected source objects, which serves as the baseline for subsequent incremental synchronization.
NoteIf you select Full Data Synchronization, the schema and data of tables for which a CREATE TABLE statement is executed can be synchronized to the destination database.
Processing Mode for Existing Destination Tables
Precheck and Report Errors: Checks for tables with the same names in the destination database. If any tables with the same names are found, an error is reported during the precheck and the data synchronization task does not start. Otherwise, the precheck is successful.
NoteIf you cannot delete or rename the table with the same name in the destination database, you can map it to a different name in the destination. For more information, see Object name mapping.
Ignore Errors and Proceed: Skips the check for tables with the same name in the destination database.
WarningSelecting Ignore Errors and Proceed may cause data inconsistency and put your business at risk. For example:
If the table schemas are consistent and a record in the destination database has the same primary key or unique key value as a record in the source database:
During full data synchronization, DTS retains the destination record and skips the source record.
During incremental synchronization, DTS overwrites the destination record with the source record.
If the table schemas are inconsistent, data initialization may fail. This can result in only partial data synchronization or a complete synchronization failure. Use with caution.
Data Format in Kafka
Select the storage format for data synchronized to the ApsaraMQ for Kafka instance.
If you select DTS Avro, you must parse the data based on the DTS Avro schema definition. For more information, see DTS Avro schema definition and DTS Avro deserialization example.
If you select Canal JSON, see Canal JSON format for parameter descriptions and examples.
NotePolarDB-X 1.0 does not support Canal JSON. You must select DTS Avro.
Kafka Data Compression Format
Select the compression format for Kafka message compression based on your business requirements.
LZ4 (default): The compression ratio is low, but the compression speed is high.
GZIP: The compression ratio is high, but the compression speed is low.
NoteCPU consumption is high.
Snappy: The compression ratio and compression speed are medium.
Policy for Shipping Data to Kafka Partitions
Message acknowledgement mechanism
Select a message acknowledgment mechanism based on your business requirements.
Topic That Stores DDL Information
Select the topic that is used to store DDL information from the drop-down list.
NoteIf not specified, the DDL information is stored in the topic that receives the data by default.
Case Policy for Destination Object Names
Configure the case-sensitivity policy for database, table, and column names in the destination instance. By default, the DTS default policy is selected. You can also choose to use the default policy of the source or destination database. For more information, see Case policy for destination object names.
Source Objects
In the Source Objects box, click the objects, and then click
to move them to the Selected Objects box.NoteWe recommend that you select objects at the table level. If you select an entire database as a synchronization object, changes to add or delete tables in the source database are not synchronized to the destination database.
Selected Objects
You can use the mapping feature to set the topic name, number of partitions, and partition key for the source table in the destination ApsaraMQ for Kafka instance. For more information, see Map information.
NoteIf you use the object name mapping feature, the synchronization of other objects that depend on the mapped object may fail.
To select the SQL operations for incremental data synchronization, right-click the object in the Selected Objects box and select the desired SQL operations in the dialog box.
Click Next: Advanced Settings.
Parameter
Description
Dedicated Cluster for Task Scheduling
By default, DTS uses a shared cluster for tasks, so you do not need to make a selection. For greater task stability, you can purchase a dedicated cluster to run the DTS synchronization task. For more information, see What is a DTS dedicated cluster?.
Retry Time for Failed Connections
If the connection to the source or destination database fails after the synchronization task starts, DTS reports an error and immediately begins to retry the connection. The default retry duration is 720 minutes. You can customize the retry time to a value from 10 to 1,440 minutes. We recommend a duration of 30 minutes or more. If the connection is restored within this period, the task resumes automatically. Otherwise, the task fails.
NoteIf multiple DTS instances (e.g., Instance A and B) share a source or destination, DTS uses the shortest configured retry duration (e.g., 30 minutes for A, 60 for B, so 30 minutes is used) for all instances.
DTS charges for task runtime during connection retries. Set a custom duration based on your business needs, or release the DTS instance promptly after you release the source/destination instances.
Retry Time for Other Issues
If a non-connection issue (e.g., a DDL or DML execution error) occurs, DTS reports an error and immediately retries the operation. The default retry duration is 10 minutes. You can also customize the retry time to a value from 1 to 1,440 minutes. We recommend a duration of 10 minutes or more. If the related operations succeed within the set retry time, the synchronization task automatically resumes. Otherwise, the task fails.
ImportantThe value of Retry Time for Other Issues must be less than that of Retry Time for Failed Connections.
Enable Throttling for Full Data Synchronization
During full data synchronization, DTS consumes read and write resources from the source and destination databases, which can increase their load. To mitigate pressure on the destination database, you can limit the migration rate by setting Queries per second (QPS) to the source database, RPS of Full Data Migration, and Data migration speed for full migration (MB/s).
NoteThis parameter is available only if Synchronization Types is set to Full Data Synchronization.
You can also adjust the rate of full data synchronization when the synchronization instance is running.
Enable Throttling for Incremental Data Synchronization
You can also limit the incremental synchronization rate to reduce pressure on the destination database by setting RPS of Incremental Data Synchronization and Data synchronization speed for incremental synchronization (MB/s).
Environment Tag
You can select an environment tag to identify the instance. This is not required for this example.
Configure ETL
Choose whether to enable the extract, transform, and load (ETL) feature. For more information, see What is ETL? Valid values:
-
Yes: Enables the ETL feature. Enter data processing statements in the code editor. For more information, see Configure ETL in a data migration or data synchronization task.
-
No: Disables the ETL feature.
Monitoring and Alerting
Choose whether to set up alerts. If the synchronization fails or the latency exceeds the specified threshold, DTS sends a notification to the alert contacts.
No: No alerts are configured.
Yes: Configures alerts. You must also set the alert threshold and alert notifications. For more information, see Configure monitoring and alerting during task configuration.
Save the task and perform a precheck.
To view the parameters for configuring this instance via an API operation, hover over the Next: Save Task Settings and Precheck button and click Preview OpenAPI parameters in the tooltip.
If you have finished viewing the API parameters, click Next: Save Task Settings and Precheck at the bottom of the page.
NoteBefore a synchronization task starts, DTS performs a precheck. You can start the task only if the precheck passes.
If the precheck fails, click View Details next to the failed item, fix the issue as prompted, and then rerun the precheck.
If the precheck generates warnings:
For non-ignorable warning, click View Details next to the item, fix the issue as prompted, and run the precheck again.
For ignorable warnings, you can bypass them by clicking Confirm Alert Details, then Ignore, and then OK. Finally, click Precheck Again to skip the warning and run the precheck again. Ignoring precheck warnings may lead to data inconsistencies and other business risks. Proceed with caution.
Purchase the instance.
When the Success Rate reaches 100%, click Next: Purchase Instance.
On the Purchase page, select the billing method and link specifications for the data synchronization instance. For more information, see the following table.
Category
Parameter
Description
New Instance Class
Billing Method
Subscription: You pay upfront for a specific duration. This is cost-effective for long-term, continuous tasks.
Pay-as-you-go: You are billed hourly for actual usage. This is ideal for short-term or test tasks, as you can release the instance at any time to save costs.
Resource Group Settings
The resource group to which the instance belongs. The default is default resource group. For more information, see What is resource management?.
Instance Class
DTS offers synchronization specifications at different performance levels that affect the synchronization rate. Select a specification based on your business requirements. For more information, see Data synchronization link specifications.
Subscription Duration
In subscription mode, select the duration and quantity of the instance. Monthly options range from 1 to 9 months. Yearly options include 1, 2, 3, or 5 years.
NoteThis option appears only when the billing method is Subscription.
Read and select the checkbox for Data Transmission Service (Pay-as-you-go) Service Terms.
Click Buy and Start, and then click OK in the OK dialog box.
You can monitor the task progress on the data synchronization page.
Mapping information
In the Selected Objects area, hover over the destination topic name (at the table level).
Click Edit that appears next to the destination topic name.
In the Edit Table dialog box that appears, configure the mapping information.
NoteAt the database level, the Edit Schema dialog box supports fewer configurable parameters. At the table level, the Edit Table dialog box appears.
If the granularity of the synchronization objects is not the entire database, you cannot modify the Name of target Topic or Number of Partitions in the Edit Schema dialog box.
Parameter
Description
Name of target Topic
The name of the destination topic to which the source table is synchronized. The default value is the Topic that you specified for the Destination Database in the Configurations for Source and Destination Databases step.
ImportantWhen the destination database is a ApsaraMQ for Kafka instance, the topic name that you specify must exist in the destination Kafka instance. Otherwise, data synchronization fails. If the destination database is a self-managed Kafka database and the synchronization task includes schema synchronization, DTS attempts to create the topic that you specified in the destination database.
If you modify the Name of target Topic, data is written to the topic that you specified.
Filter Conditions
For more information, see Filter task data with an SQL condition.
Number of Partitions
The number of partitions when data is written to the destination topic.
Partition Key
When Policy for Shipping Data to Kafka Partitions is set to Ship Data to Separate Partitions Based on Hash Values of Primary Keys, you can configure this parameter. Specify one or more columns as the Partition Key that is used to calculate the hash value. DTS then delivers rows to different partitions of the destination topic based on the calculated hash values.
NoteYou can select Partition Key only in the Edit Table dialog box.
Click OK.
FAQ
Can I modify Kafka Data Compression Format?
Yes. You can use the Modify synchronization objects feature to modify it.
Can I modify Message acknowledgement mechanism?
Yes. You can use the Modify synchronization objects feature to modify it.