サブスクリプション Elastic Compute Service (ECS) インスタンスのインスタンスタイプを変更します。インスタンスタイプをスペックアップまたはスペックダウンでき、変更の効果は ECS インスタンスのライフサイクル全体にわたって持続します。
操作説明
この操作の呼び出し前に、ECS プロダクトの支払い方法、料金電卓、およびスペックダウンの返金ルール を完全に理解していることを確認してください。
この操作は非同期です。構成の変更は、約 5~10 秒後に効果が現れます。サブスクリプション ECS インスタンスのインスタンスタイプをスペックアップまたはスペックダウンする前に、 DescribeResourcesModification の呼び出しにより、現在のインスタンスを変更できる ECS インスタンスタイプをクエリできます。
注意事項
-
ソースとターゲットインスタンスのインスタンスタイプの NVMe プロパティが一致せず ( DescribeInstanceTypes によって返される
NvmeSupportフィールド)、オペレーティングシステムが Windows である ( DescribeInstances によって返されるOSTypeフィールド) 場合、スペックアップまたはスペックダウンを実行する前に、予防措置 に記載されている操作を完了してください。 -
期限切れのインスタンスのインスタンスタイプは変更できません。インスタンスを更新してから再試行してください。
-
インスタンスタイプのスペックダウン:
インスタンスは 停止 (
Stopped) 状態である必要があります。元のインスタンスタイプと新しいインスタンスタイプの価格差は、元の支払者に返金されます。使用済みのバウチャーは返金できません。
新しいインスタンスタイプは、インスタンスの起動 後にのみ効果があります。
-
インスタンスタイプのスペックアップ:
インスタンスは 停止 (
Stopped) または 実行中 (Running) 状態である必要があります。新しいインスタンスタイプは、インスタンスの起動 または インスタンスの再起動 後にのみ効果があります。
今すぐお試しください
テスト
RAM 認証
|
アクション |
アクセスレベル |
リソースタイプ |
条件キー |
依存アクション |
|
ecs:ModifyPrepayInstanceSpec |
update |
*Instance。
|
なし | なし |
リクエストパラメーター
|
パラメーター |
型 |
必須 / 任意 |
説明 |
例 |
| InstanceId |
string |
必須 |
インスタンス ID |
i-bp67acfmxazb4ph**** |
| RegionId |
string |
必須 |
インスタンスのリージョン ID。 DescribeRegions の呼び出しにより、最新のリージョンリストをクエリできます。 |
cn-hangzhou |
| InstanceType |
string |
必須 |
スペックアップまたはスペックダウンするターゲットインスタンスタイプ。詳細については、インスタンスファミリー を参照するか、 DescribeInstanceTypes を呼び出してください。 |
ecs.g5.xlarge |
| OperatorType |
string |
任意 |
操作のタイプ。有効な値: 説明
このパラメーターはオプションです。システムは、操作がスペックアップとスペックダウンのどちらであるかを自動的に判断できます。このパラメーターを指定する場合は、以下のルールをフォローしてください。
説明
インスタンスタイプのスペックアップまたはスペックダウンに関する注意事項については、上記の操作の説明セクションを参照してください。 |
スペックアップ |
| ClientToken |
string |
任意 |
リクエストのべき等性を確保するために使用されるクライアントトークン。クライアントを使用してトークンを生成できますが、異なるリクエスト間でトークンが一意であることを確認してください。ClientToken の値には ASCII 文字のみを使用でき、長さは 64 文字以下にする必要があります。詳細については、べき等性を確保する方法 を参照してください。 |
123e4567-e89b-12d3-a456-426655440000 |
| AutoPay |
boolean |
任意 |
インスタンスタイプをスペックアップするときに、自動的に支払いを完了するかどうかを指定します。有効な値:
デフォルト値: true。 説明
|
true |
| MigrateAcrossZone |
boolean |
任意 |
クラスターインスタンス間のインスタンスタイプの変更をサポートするかどうかを指定します。有効な値:
デフォルト値: false。
VPC タイプのインスタンス: 廃止されたインスタンスタイプ の場合、非 I/O 最適化インスタンスから I/O 最適化インスタンスに変更すると、サーバーのディスクデバイス名とソフトウェア権限付与コードが変更されます。Linux インスタンスのベーシックディスク (cloud) は xvda または xvdb として識別されます。Ultra ディスク (cloud_efficiency) と標準 SSD (cloud_ssd) は vda または vdb として識別されます。 |
false |
| SystemDisk.Category |
string |
任意 |
システムディスクの新しいカテゴリ。有効な値:
説明
このパラメーターは、廃止されたインスタンスタイプ から購入可能なインスタンスファミリー へのスペックアップを行い、非 I/O 最適化インスタンスから I/O 最適化インスタンスに変更する場合にのみ有効です。これは、インスタンスの仕様に対するクォータの引き上げ操作です。 |
cloud_efficiency |
| RebootTime |
string |
任意 |
インスタンスの再起動時間。時間を ISO 8601 標準の yyyy-MM-ddTHH:mmZ 形式で指定します。時間は協定世界時 (UTC) でなければなりません。 |
2018-01-01T12:05Z |
| EndTime |
string |
任意 |
一時インスタンスのインスタンスタイプ変更の終了時間。時間を ISO 8601 標準の yyyy-MM-ddTHH:mmZ 形式で指定します。時間は協定世界時 (UTC) でなければなりません。 |
2018-01-01T12:05Z |
| RebootWhenFinished |
boolean |
任意 |
インスタンスタイプの変更が完了した後、インスタンスをすぐに再起動するかどうかを指定します。有効な値:
デフォルト値: false。 説明
インスタンスが 停止 状態の場合、 |
false |
| ModifyMode |
string |
任意 |
説明
このパラメーターは公開されていません。 |
null |
| Disk |
array<object> |
任意 |
説明
このパラメーターは公開されていません。 |
|
|
object |
任意 |
説明
このパラメーターは公開されていません。 |
||
| Category |
string |
任意 |
説明
このパラメーターは公開されていません。 |
null |
| DiskId |
string |
任意 |
説明
このパラメーターは公開されていません。 |
null |
| PerformanceLevel |
string |
任意 |
説明
このパラメーターは公開されていません。 |
null |
レスポンスフィールド
|
フィールド |
型 |
説明 |
例 |
|
object |
|||
| OrderId |
string |
注文 ID。 |
1234567890 |
| RequestId |
string |
リクエスト ID |
473469C7-AA6F-4DC5-B3DB-A3DC0DE3C83E |
例
成功レスポンス
JSONJSON
{
"OrderId": "1234567890",
"RequestId": "473469C7-AA6F-4DC5-B3DB-A3DC0DE3C83E"
}
エラーコード
|
HTTP ステータスコード |
エラーコード |
エラーメッセージ |
説明 |
|---|---|---|---|
| 400 | InvalidInstanceType.ValueUnauthorized | The specified InstanceType is not authorized. | |
| 400 | InvalidInstanceType.ValueNotSupported | The specified InstanceType does not exist or beyond the permitted range. | 指定されたインスタンスタイプは利用可能な範囲外のため、無効です。 |
| 400 | InvalidBillingMethod.ValueNotSupported | The operation is not permitted due to an invalid billing method of the instance. | インスタンスの支払い方法が無効なため、この操作は許可されていません。 |
| 400 | InvalidInstance.PurchaseNotFound | The specified instance has no purchase history. | 指定されたインスタンスは購入できません。 |
| 400 | InvalidInstance.UnpaidOrder | The specified instance has unpaid order. | |
| 400 | InvalidInstanceType.NotSupported | The specified InstanceType is not Supported. | |
| 400 | OrderCreationFailed | Order creation failed, please check your params and try it again later. | 注文の作成に失敗しました。 |
| 400 | Throttling | You have made too many requests within a short time; your request is denied due to request throttling. | リクエストがスロットリングされました。 |
| 400 | Account.Arrearage | Your account has an outstanding payment. | アカウント残高が不足しています。続行する前にアカウントに入金してください。 |
| 400 | InvalidInstanceId.NotFound | The specified InstanceId does not exist. | |
| 400 | InvalidRebootTime.MalFormed | The specified rebootTime is not valid. | 指定された再起動時間が有効値の範囲外です。 |
| 400 | InvalidRebootTime.ValueNotSupported | The specified RebootTime is not valid. | 指定された再起動時刻は無効です。 |
| 400 | IdempotenceParamNotMatch | Request uses a client token in a previous request but is not identical to that request. | リクエストパラメーターが、同じ ClientToken を持つリクエストと一致しません。 |
| 400 | InvalidInstanceChargeType.ValueNotSupported | %s | 指定されたインスタンスの支払い方法が存在しません。 |
| 400 | InvalidStatus.NotStopped | Instance status must be stopped. | この操作は、インスタンスが停止状態の場合にのみ実行できます。 |
| 400 | InvalidAction | %s | 無効な操作です。 |
| 400 | InstanceDowngrade.QuotaExceed | Quota of instance downgrade is exceed. | インスタンスのスペックダウンクォータを超過しています。この操作は実行できません。 |
| 400 | InvalidParameter | %s | 現在のリクエストパラメーターは無効です。もう一度お試しください。 |
| 400 | OperationDenied | The current user does not support this operation. | 指定されたスナップショットでは、データボリュームの作成が許可されていません。 |
| 400 | LastOrderProcessing | The previous order is still processing, please try again later. | 注文は処理中です。後でもう一度お試しください。 |
| 400 | InvalidOperation.VpcHasEnabledAdvancedNetworkFeature | The specified vpc has enabled advanced network feature. | VPC で高度な機能が有効になっており、低仕様の ECS インスタンスの作成はサポートされていません。 |
| 400 | InvalidAction.WithActiveElasticUpgrade | The instance has active Elastic Upgrade. | |
| 400 | InstanceTypeNotSupported.TooManyDisksAttached | %s | |
| 400 | QuotaExceed.DiskCapacity | The used capacity of disk type has exceeded the quota in the zone, %s. | 指定されたディスクタイプの使用量がゾーンのクォータ制限を超えています。クォータセンターに移動して、ディスク容量のクォータをクエリし、引き上げをリクエストしてください。ディスクはアクティブな状態ではありません。 |
| 400 | MissingParameter.DiskCategory | The specified parameter Disk.Category can not be null when Disk.DiskId is specified. | |
| 400 | InvalidParameter.DiskCategory | The specified parameter Disk.Category is not valid. | |
| 400 | InvalidPerformanceLevel.Malformed | The specified parameter Disk.n.PerformanceLevel is not valid. | |
| 400 | InvalidSystemDiskCategory.NotMatchInstanceType | The system disk category does not match the instance type. | システムディスクのカテゴリがインスタンスタイプと一致しません。 |
| 400 | QuotaExceed.RufundVcpu | The maximum number of refunded vcpu is exceeded: %s . | 返金ルール内の vCPU クォータが最大値を超えています。具体的な上限については、エラーメッセージ内の %s プレースホルダーの実際の値を参照してください。 |
| 400 | NoPermission.Price | The operation requires price permission. Please either apply for permission from your main account, or set the parameter AutoPay as true. | この操作には課金に関する権限が必要です。Alibaba Cloud アカウントに対して権限をリクエストするか、AutoPay パラメーターを true に設定して自動支払いを有効にしてください。 |
| 400 | NoPermission.Refund | The operation requires refund permission. Please apply for permission from your main account. | アカウントに払い戻しを実行する権限がありません。プライマリアカウントから払い戻し関連の権限を付与される必要があります。 |
| 400 | InvalidInstanceStatus | The current status of the instance does not support this operation. | |
| 400 | InvalidOperation.InstanceRenewWithDowngradeInPlan | The operation is denied due to the specified instance has renew with downgrade record in plan. | 有効になっていない更新およびスペックダウンの注文が存在します。注文に効果が生じるまで、この操作は実行できません。 |
| 400 | InvalidOperation.OnlineModificationUnsupported | Online modification of instance type is not supported for the specified instance due to its CPU topology. | 現在の CPU トポロジータイプでは、実行中の仕様変更はサポートされていません。 |
| 400 | InvalidInstanceType.NotSupportCpuOptionsNestedVirtualization | The specified instance type does not support CpuOptions.NestedVirtualization: %s. | 指定された入れ子になった仮想化機能は、現在のインスタンスタイプではサポートされていません。 |
| 401 | InvalidInstanceType.ValueUnauthorized | The specified InstanceType is not authorized. | 指定された InstanceType は存在しません。 |
| 500 | InternalError | The request processing has failed due to some unknown error, exception or failure. | 内部エラーが発生しました。再度お試しください。 |
| 500 | ImageOrderFailed | Create marketplace image order failed. | Alibaba Cloud Marketplace の注文を作成できませんでした。サポートが必要な場合は、チケットを起票してください。 |
| 403 | OperationDenied.NoStock | The specified instance is out of usage. | 指定されたディスクカテゴリが指定されたゾーンまたはクラスターに存在しないか、あるいは指定されたゾーンがクラスターと一致しません。 |
| 403 | InvalidInstanceType.ValueNotSupported | The specified InstanceType does not exist or beyond the permitted range. | |
| 403 | InvalidUser.PassRoleForbidden | The RAM user does not have privilege to pass a role. | RAM ユーザーに RAM ロールを渡す権限がありません。 |
| 403 | ImageNotSupportInstanceType | The specified image does not support the specified InstanceType. | 指定されたイメージはこのインスタンスタイプをサポートしていません。 |
| 403 | InstanceType.Offline | %s | 指定されたインスタンスタイプは廃止されています。別のインスタンスタイプを選択してください。 |
| 403 | IncorrectInstanceStatus | The current status of the resource does not support this operation. | |
| 403 | Throttling | You have made too many requests within a short time; your request is denied due to request throttling. | |
| 403 | InvalidParameter.InstanceId | %s | 指定された InstanceId パラメーターが無効です。 |
| 403 | OperationDenied | %s | |
| 403 | InvalidInstanceStatus | The current status of the instance does not support this operation. | インスタンスの現在のステータスでは、この操作はサポートされていません。 |
| 403 | InvalidOperation.StarterPackage | StarterPackage not support modification. | |
| 403 | InvalidInstance.PreInstanceExpired | Instance business status is not Expired. | |
| 403 | InvalidInstance.EipNotSupport | The special instance with eip not support operate, please unassociate eip first. | この操作は、EIP に関連付けられているインスタンスではサポートされていません。先に EIP の関連付けを解除してください。 |
| 403 | OperationDenied.ImageNotValid | The specified marketplace image is not authorized. Please verify the marketplace image authorization and try again. | |
| 403 | OperationDenied.LocalDiskUnsupported | The configuration change is not allowed when the specified instance has local disks mounted. | ローカルディスクがアタッチされているインスタンスでは、仕様の変更はサポートされていません。 |
| 403 | InvalidOperation.EniCountExceeded | %s | |
| 403 | InvalidOperation.Ipv4CountExceeded | %s | IPv4 アドレスの数が上限に達しているため、この操作は実行できません。 |
| 403 | InvalidOperation.Ipv6CountExceeded | %s | IPv6 アドレスの数が上限に達しているため、この操作は実行できません。 |
| 403 | InvalidOperation.Ipv6NotSupport | %s | IPv6 ではこの操作はサポートされていません。 |
| 403 | InvalidOperation.Ipv4NotSupport | %s | |
| 403 | InvalidInstance.NotFoundSystemDisk | The specified instance has no system disk. | |
| 403 | InvalidInstanceType.NotSupportDiskCategory | The instanceType of the specified instance does not support this disk category. | 指定されたインスタンスタイプ (InstanceType) は、現在のインスタンスのディスクカテゴリをサポートしていません。別のインスタンスタイプをお試しください。各インスタンスタイプでサポートされているディスクタイプの詳細については、インスタンスファミリーのドキュメントを参照してください。 |
| 403 | QuotaExceed.ElasticQuota | No additional quota is available for the specified ECS instance type. | 現在のリージョンで選択したインスタンスタイプで作成されるインスタンスの数がクォータを超えているか、すべてのインスタンスタイプの合計 vCPU クォータを超えています。ECS コンソールまたはクォータセンターに移動して、クォータの増加をリクエストできます。 |
| 403 | InvalidResourceType.NotSupported | %s | リソースタイプはサポートされていません。 |
| 403 | InvalidOperation.MaxEniQueueNumberExceeded | %s | Elastic Network Interface (ENI) キューの数が上限を超えています。詳細については、エラーメッセージ内の %s プレースホルダーの実際の返却結果を参照してください。 |
| 403 | InvalidOperation.ExceedInstanceTypeQueueNumber | %s | Elastic Network Interface (ENI) キューの合計数が上限を超えています。詳細については、エラーメッセージ内の %s プレースホルダーの実際の返却結果を参照してください。 |
| 403 | InvalidParameter.InvalidEniQueueNumber | %s | Elastic Network Interface (ENI) キューの数が正しくありません。詳細については、エラーメッセージ内の %s プレースホルダーの実際の返却結果を参照してください。 |
| 403 | HibernationConfigured.InstanceOperationForbidden | The operation is not permitted due to limit of the hibernation configured instance. | インスタンスが休止状態オプションの有効化要件を満たしていないため、この操作は許可されていません。 |
| 403 | InvalidOperation.MaxModifyOnlineNumberExceeded | The specified instance has reached the maximum number of modify online attempts and needs to be rebooted. | |
| 403 | InvalidOperation.RebootingRequired | The specified instance needs to be rebooted. | |
| 403 | InvalidOperation.OSTypeNotSupported | The specified OS type is not supported. | |
| 403 | OperationDenied.UnpaidOrder | The specified instance has unpaid order. | 指定されたインスタンス ID に対して、未払いの注文がすでに存在します。ECS コンソールにログインして、支払いを完了できます。 |
| 403 | InvalidDisk.DetachedSystemDisk | The specified resource is/has a detached system disk %s , not support current operation. | 指定されたディスクはデタッチされたシステムディスクであるため、現在の操作はサポートされていません。 |
| 403 | InvalidDataDiskCategory.ValueNotSupported | The specified Category of Data Disk is not valid. | 指定された DataDisk.n.Category パラメーターは正しくありません。 |
| 403 | InvalidDiskCategory.NotSupported | The upgrade operation of instance does not support this category of disk. | 指定されたディスクカテゴリはインスタンスタイプでサポートされていません。 |
| 403 | InvalidOperation.InstanceTypeSecureBootUnsupported | The instance type does not support secure boot. | このインスタンスタイプはセキュアブートをサポートしていません。 |
| 403 | InvalidOperation.InstanceTypeNotSupportEniTrunking | The specified instance type does not support ENI trunking operation. | この操作はサポートされていません。詳細については、エラーメッセージ内の %s プレースホルダーに返される実際の値を参照してください。 |
| 403 | InvalidStatus.InstanceStatus | The specified instance status does not support this operation, expected status is Running or Stopped. | 現在のインスタンスステータスでは、この操作はサポートされていません。 |
| 403 | InvalidClientToken.Malformed | The specified clientToken is improperly formatted. It must contain only ASCII characters and must not exceed 64 characters in length. | 指定された冪等パラメーターは無効です。 |
| 403 | IncorrectDiskStatus | This operation is not supported for the current disk status. The disk must be In Use or Available to continue. | 現在のディスクでは、この操作はサポートされていません。ディスクが正常に使用されており、支払い遅延がないことを確認してください。 |
| 404 | InvalidRegionId.NotFound | The specified RegionId does not exist. | 指定された RegionId は存在しません。このリージョンでプロダクトが利用可能かどうかを確認してください。 |
| 404 | BillingMethodNotFound | The account has not chosen any billing method. | Alibaba Cloud アカウントに支払い方法が選択されていません。 |
| 404 | InvalidInstanceId.NotFound | The specified InstanceId does not exist. | 指定されたインスタンスが存在しません。インスタンス ID が正しいかどうかを確認してください。 |
| 503 | LimitedOperation.ServiceUnavailable | The service is currently unavailable. Please try again later. | サービスは現在利用できません。後でもう一度お試しください。 |
完全なリストについては、「エラーコード」をご参照ください。
変更履歴
完全なリストについては、「変更履歴」をご参照ください。