すべてのプロダクト
Search
ドキュメントセンター

Data Transmission Service:RDS for MySQL から PolarDB for MySQL への同期

最終更新日:Jul 18, 2026

DTS は、MySQL から PolarDB for MySQL クラスターへデータを同期します。

サポートされるソースデータベース

以下のソース MySQL データベースを PolarDB for MySQL クラスターに同期できます。本トピックでは RDS MySQL インスタンスを例として説明します。他のソースデータベースの場合も手順は同様です。

  • ApsaraDB RDS for MySQL インスタンス

  • Elastic Compute Service (ECS) 上でホストされている自己管理データベース

  • Express Connect、VPN Gateway、または Smart Access Gateway 経由で接続された自己管理データベース

  • Database Gateway 経由で接続された自己管理データベース

  • Cloud Enterprise Network (CEN) 経由で接続された自己管理データベース

前提条件

注意事項

説明
  • スキーマ同期中に、DTS は外部キーをソースデータベースから宛先データベースに同期します。

  • 完全データ同期および増分データ同期中、DTS はセッションレベルで制約チェックおよび外部キーのカスケード操作を一時的に無効化します。タスク実行中にソースデータベースでカスケード更新または削除操作が実行されると、データの不整合が発生する可能性があります。

種別

説明

ソースデータベースの制限

  • 同期対象のテーブルにはプライマリキーまたは一意制約が設定されており、フィールド値が一意である必要があります。そうでない場合、宛先データベースに重複データが現れる可能性があります。

  • テーブル単位で同期し、マッピング(カラム名マッピングなど)を編集する必要がある場合、1 つの同期タスクでサポートされるテーブル数は最大 1,000 件です。この上限を超えると、タスクはエラーで失敗します。これを修正するには、複数のタスクにテーブルを分割するか、データベース全体の同期タスクを構成してください。

  • バイナリログ:

    • ApsaraDB RDS for MySQL はデフォルトでバイナリロギングが有効になっています。binlog_row_image パラメーターが full に設定されていることを確認してください。設定されていない場合、事前チェックに失敗し、同期タスクを開始できません。設定方法については、「インスタンスパラメーターの設定」をご参照ください。

      重要
      • ソースインスタンスが自己管理 MySQL データベースの場合、バイナリロギングを有効にし、binlog_format を row、binlog_row_image を full に設定してください。

      • 自己管理 MySQL データベースがデュアルプライマリクラスター(両ノードがプライマリおよびセカンダリの役割を果たす)の場合、log_slave_updates パラメーターを有効にして、DTS がすべてのバイナリログイベントを取得できるようにしてください。設定方法については、「自己管理 MySQL データベースのアカウント作成とバイナリロギング設定」をご参照ください。

    • ApsaraDB RDS for MySQL インスタンスのローカルバイナリログは、最低でも 3 日間(推奨は 7 日間)保持する必要があります。自己管理 MySQL データベースの場合は、ローカルバイナリログを最低でも 7 日間保持してください。保持期間が短いと、DTS がバイナリログを取得できず、タスクが失敗する可能性があります。最悪の場合、データの不整合やデータ損失が発生する可能性があります。DTS が要求する保持期間よりも短いバイナリログ保持期間に起因する問題は、DTS SLA の対象外です。

      説明

      ApsaraDB RDS for MySQL インスタンスのローカルバイナリログの保持期間を設定する方法については、「ローカルログの自動削除」をご参照ください。

  • スキーマ同期または完全同期中に、データベースまたはテーブルスキーマを変更する DDL 操作を実行しないでください。実行すると、同期タスクが失敗します。

    説明

    完全同期中、DTS はソースデータベースに対してクエリを実行します。これによりメタデータロックが発生し、ソースデータベースでの DDL 操作がブロックされる可能性があります。

  • バイナリログに書き込まれない変更(物理バックアップからのデータ復元やカスケード操作によって生成されたデータなど)は、宛先データベースに同期されません。

    説明

    このような状況が発生した場合は、影響を受けたデータベースまたはテーブルを同期オブジェクトから除外し、その後再度追加してください。ただし、これはビジネス要件で許容される場合に限ります。詳細については、「同期オブジェクトの変更」をご参照ください。

  • ソースデータベースが MySQL 8.0.23 以降で非表示の隠しカラムを含む場合、DTS がこれらのカラムを読み取らない可能性があります。これによりデータ損失が発生する可能性があります。

    説明

    ALTER TABLE <table_name> ALTER COLUMN <column_name> SET VISIBLE; コマンドを実行して、隠しカラムを表示可能にしてください。詳細については、「Invisible Columns」をご参照ください。

  • MySQL 互換性:DTS が MySQL ファミリーのソースデータベースからデータを同期する際は、標準 MySQL プロトコルおよび Binlog フォーマットに依存しており、標準 MySQL と互換性のない動作はサポートされません。ソースデータベースが MySQL 互換を謳っていても MySQL とは異なる動作をする場合(たとえば、OceanBase を MySQL モードでソースとして接続した際に、Binlog の末尾 rotate イベントのタイムスタンプが 0 になるなど)、DTS 同期タスクが失敗する可能性があります。

その他の制限

  • ソースおよび宛先データベースで同じバージョンを使用するか、下位バージョンから上位バージョンへのアップグレードを行うことで互換性を確保してください。上位バージョンから下位バージョンへの同期は、互換性の問題を引き起こす可能性があります。

  • ソースデータベースで一時テーブルモードによるオンライン DDL 操作(マルチテーブルマージなどのシナリオを含むがこれに限定されない)を使用している場合、または一意キーのカラムに関数ベースインデックスを追加している場合、宛先データベースでデータ損失またはタスク失敗が発生する可能性があります。

  • コメント構文で定義されたリゾルバは、同期使用をサポートしていません。

  • タスク実行中にプライマリキーまたは一意キーの競合が発生した場合:

    • テーブルスキーマが同一で、宛先データベースのレコードがソースデータベースのレコードと同じプライマリキーまたは一意キー値を持つ場合:

      • 完全同期中は、DTS が宛先クラスターのレコードを保持します。ソースデータベースの対応するレコードは同期されません。

      • 増分同期中は、ソースデータベースのレコードが宛先データベースのレコードを上書きします。

    • テーブルスキーマが異なる場合、初期データ同期が失敗する可能性があります。これにより、一部のカラムデータのみが同期されるか、完全に同期が失敗する可能性があります。慎重に操作してください。

  • 同期を開始する前に、ソースおよび宛先データベースのパフォーマンスを評価してください。オフピーク時間帯に同期を実行することを推奨します。そうしないと、完全初期化時に両方のデータベースの読み取りおよび書き込みリソースが消費され、データベース負荷が増大する可能性があります。

  • 完全初期化は INSERT 操作を並行して実行します。これにより宛先テーブルがフラグメント化します。完全初期化後、宛先インスタンスの表領域はソースインスタンスよりも大きくなります。

  • データに 4 バイト文字(まれな漢字や絵文字など)が含まれる場合、宛先データベースおよびテーブルは utf8mb4 文字セットを使用する必要があります。

    説明

    DTS を使用してテーブルスキーマを同期する場合、宛先データベースのインスタンスレベルで character_set_server パラメーターを utf8mb4 に設定してください。

  • データベース全体ではなく 1 つ以上のテーブルを同期する場合、pt-online-schema-change などのツールを使用してソーステーブルでオンライン DDL 操作を実行しないでください。実行すると、同期が失敗します。

    Data Management (DMS) を使用してオンライン DDL 操作を実行できます。詳細については、「テーブルロックなしのオンライン DDL」をご参照ください。

  • 同期実行中は、DTS 以外で宛先データベースにデータを書き込まないでください。書き込むと、ソースおよび宛先データベース間にデータの不整合が発生する可能性があります。たとえば、DMS を使用してオンライン DDL 操作を実行中に他のデータが宛先データベースに書き込まれると、データ損失が発生する可能性があります。

  • 完全移行のレートを調整することはできません。

  • datetime データを varchar に変換することはできません。

  • DDL 操作が宛先データベースで失敗した場合、DTS タスクは継続して実行されます。失敗した DDL はタスクログで確認してください。確認方法については、「タスクログの表示」をご参照ください。

  • ApsaraDB RDS for MySQL インスタンスで Always-Encrypted が有効になっている場合、完全データ同期はサポートされません。

    説明

    Transparent Data Encryption (TDE) が有効になっている ApsaraDB RDS for MySQL インスタンスは、スキーマ同期、完全データ同期、および増分データ同期をサポートしています。

  • ソースデータベースからアカウントを同期する場合は、前提条件を満たし、関連する考慮事項を確認してください。詳細については、「データベースアカウントの移行」をご参照ください。

  • タスクが失敗した場合、DTS サポートスタッフは 8 時間以内に復旧を試みます。復旧中には、タスクを再起動したりパラメーターを調整したりする可能性があります。

    説明

    DTS タスクパラメーターのみが変更され、データベースパラメーターは変更されません。 調整対象となるパラメーターは、「インスタンスパラメーターの変更」に記載されています。

特殊なケース

  • 自己管理 MySQL ソースデータベースの場合:

    • 同期中にソースデータベースでプライマリ/セカンダリ スイッチオーバーが発生すると、タスクは失敗します。

    • DTS は、最後に同期されたレコードのタイムスタンプと現在時刻を比較して遅延を計算します。ソースデータベースで長時間 DML 操作が実行されない場合、遅延レポートが不正確になる可能性があります。遅延が過大に表示される場合は、ソースデータベースで DML 操作を実行して遅延を更新してください。

      説明

      データベース全体を同期対象に選択する場合は、ハートビートテーブルを作成してください。このテーブルを毎秒更新または書き込みしてください。

    • DTS は定期的にソースデータベースで CREATE DATABASE IF NOT EXISTS `test` コマンドを実行して、バイナリログオフセットを進めます。

    • ソースデータベースが Amazon Aurora MySQL または他のクラスタ型 MySQL インスタンスの場合、タスク構成で使用するドメイン名または IP アドレス(およびその DNS 解決)が常に読み取り/書き込み (RW) ノードを指すようにしてください。そうでない場合、同期が失敗する可能性があります。

  • ApsaraDB RDS for MySQL ソースデータベースの場合:

    • トランザクションログを記録しない読み取り専用インスタンス(ApsaraDB RDS for MySQL 5.6 読み取り専用インスタンスなど)は、ソースデータベースとして使用できません。

    • DTS は定期的にソースデータベースで CREATE DATABASE IF NOT EXISTS `test` コマンドを実行して、バイナリログオフセットを進めます。

課金

同期タイプ

料金

スキーマ同期および完全データ同期

無料です。

増分データ同期

課金対象です。詳細については、「課金概要」をご参照ください。

サポートされる同期トポロジ

  • 1 対 1 の一方向同期

  • 1 対多の一方向同期

  • カスケード型の一方向同期

  • 多対 1 の一方向同期

同期トポロジおよびその使用方法の詳細については、「データ同期トポロジ」をご参照ください。

サポートされる SQL ステートメント

操作タイプ

SQL ステートメント

DML

INSERT、UPDATE、DELETE

DDL

  • ALTER TABLE、ALTER VIEW

  • CREATE FUNCTION、CREATE INDEX、CREATE PROCEDURE、CREATE TABLE、CREATE VIEW

  • DROP INDEX、DROP TABLE

  • RENAME TABLE

    重要

    RENAME TABLE 操作によりデータの不整合が発生する可能性があります。たとえば、同期オブジェクトが単一テーブルで、同期中にソースインスタンスでこのテーブルの名前を変更すると、このテーブルのデータは宛先データベースに同期されません。この問題を回避するには、テーブルが属するデータベース全体を同期オブジェクトとして選択してください。RENAME TABLE 操作の前後でテーブルが属するデータベースが同期オブジェクトに含まれていることを確認してください。

  • TRUNCATE TABLE

操作手順

  1. 宛先リージョンの同期タスク一覧ページに移動します。以下の 2 つの方法のいずれかを使用できます。

    DTS コンソールから

    1. Data Transmission Service (DTS) コンソールにログインします。

    2. 左側のナビゲーションウィンドウで、データ同期 をクリックします。

    3. ページ左上隅で、同期インスタンスが配置されているリージョンを選択します。

    DMS コンソールから

    説明

    実際の操作は、DMS コンソールのモードおよびレイアウトによって異なる場合があります。詳細については、「シンプルモード」および「DMS インターフェイスのレイアウトとスタイルのカスタマイズ」をご参照ください。

    1. Data Management (DMS) にログインします。

    2. 上部メニューバーで、データ + AI > データ伝送 (DTS) > データ同期 を選択します。

    3. データ同期タスク の右側で、同期インスタンスが配置されているリージョンを選択します。

  2. タスクの作成 をクリックして、タスク設定ページを開きます。

  3. ソースおよび宛先データベースを設定します。

    警告

    ソースおよび宛先インスタンスを選択した後、ページ上部に表示される制限事項を慎重に確認してください。制限事項に従わないと、タスクが失敗したりデータの不整合が発生したりする可能性があります。

    カテゴリ

    パラメーター

    説明

    該当なし

    タスク名

    DTS は自動的にタスク名を生成します。識別しやすいように、わかりやすい名前を指定することを推奨します。名前に一意性は必要ありません。

    移行元データベース

    既存の接続情報の選択

    • システムに追加済み(新規作成または保存済み)のデータベースインスタンスを使用する場合は、ドロップダウンリストからデータベースインスタンスを選択します。データベース情報は自動的に設定されます。

      説明

      DMS コンソールでは、この設定項目の名前は DMS データベースインスタンスの選択 です。

    • データベースインスタンスをシステムに追加していない場合、またはすでに追加済みのインスタンスを使用しない場合は、以下のデータベース情報を手動で設定します。

    データベースタイプ

    MySQL を選択します。

    アクセス方法

    Alibaba Cloud インスタンス を選択します。

    インスタンスリージョン

    ソース ApsaraDB RDS for MySQL インスタンスが配置されているリージョンを選択します。

    Alibaba Cloudアカウント全体でのデータの複製

    同一 Alibaba Cloud アカウント内での同期の場合、× を選択します。

    RDS インスタンス ID

    ソース ApsaraDB RDS for MySQL インスタンスの ID を選択します。

    データベースアカウント

    ソース ApsaraDB RDS for MySQL インスタンスのデータベースアカウントを入力します。アカウントには REPLICATION CLIENT、REPLICATION SLAVE、SHOW VIEW、および SELECT 権限が必要です。

    データベースパスワード

    データベースアカウントに対応するパスワードを入力します。

    暗号化

    必要に応じて、非暗号化 または SSL 暗号化 を選択します。SSL 暗号化 を選択する場合、事前に RDS for MySQL インスタンスで SSL 暗号化を有効にしておく必要があります。詳細については、「クラウド証明書を使用した SSL 暗号化の迅速な有効化」をご参照ください。

    移行先データベース

    既存の接続情報の選択

    • システムに追加済み(新規作成または保存済み)のデータベースインスタンスを使用する場合は、ドロップダウンリストからデータベースインスタンスを選択します。データベース情報は自動的に設定されます。

      説明

      DMS コンソールでは、この設定項目の名前は DMS データベースインスタンスの選択 です。

    • データベースインスタンスをシステムに追加していない場合、またはすでに追加済みのインスタンスを使用しない場合は、以下のデータベース情報を手動で設定します。

    データベースタイプ

    PolarDB for MySQL を選択します。

    アクセス方法

    Alibaba Cloud インスタンス を選択します。

    インスタンスリージョン

    宛先 PolarDB for MySQL クラスターが配置されているリージョンを選択します。

    PolarDB クラスター ID

    宛先 PolarDB for MySQL クラスターの ID を選択します。

    データベースアカウント

    宛先 PolarDB for MySQL クラスターのデータベースアカウントを入力します。アカウントには読み取りおよび書き込み権限が必要です。

    データベースパスワード

    データベースアカウントに対応するパスワードを入力します。

    暗号化

    要件に基づいてオプションを選択します。詳細については、「SSL 暗号化の設定」をご参照ください。

  4. 設定が完了したら、ページ下部の 接続をテストして続行 をクリックします。

    説明
    • DTS サーバーからのアクセスを許可するために、ソースおよび宛先データベースのセキュリティ設定に DTS サーバーの IP アドレス CIDR ブロックを追加していることを確認してください。これは自動または手動で行えます。詳細については、「DTS サーバーの IP アドレス CIDR ブロックをホワイトリストに追加」をご参照ください。

    • ソースまたは宛先データベースが自己管理データベース(アクセス方法 が Alibaba Cloud インスタンス ではない)の場合、DTS サーバーの CIDR ブロック ダイアログボックスで 接続テスト をクリックする必要もあります。

  5. タスクオブジェクトを設定します。

    1. オブジェクト設定 ページで、同期するオブジェクトを設定します。

      パラメーター

      説明

      同期タイプ

      増分データ同期 が選択されています。デフォルトでは、スキーマ同期 および 完全データ同期 も選択する必要があります。事前チェックが完了すると、DTS は選択されたオブジェクトの完全データ同期をソースインスタンスから宛先クラスターに実行します。これは、その後の増分データ同期のベースラインデータとなります。

      移行元データベースのトリガーを移行する方法

      トリガー同期方法を選択します。トリガーが関与しない場合は、このパラメーターをスキップしてください。詳細については、「トリガーの同期または移行方法の設定」をご参照ください。

      説明

      このパラメーターは、同期タイプ が スキーマ同期 に設定されている場合にのみ設定できます。

      同期トポロジ

      一方向同期 を選択します。

      競合するテーブルの処理モード

      • エラーの事前チェックと報告:宛先データベースに同じ名前のテーブルが存在するかどうかをチェックします。同じ名前のテーブルが存在しない場合、事前チェックは合格します。同じ名前のテーブルが存在する場合、事前チェックは失敗し、データ同期タスクは開始されません。

        説明

        宛先データベースで同じ名前のテーブルを削除または名前変更できない場合は、別のテーブル名にマッピングできます。詳細については、「テーブル名およびカラム名のマッピング」をご参照ください。

      • エラーを無視して続行:宛先データベースでの重複テーブル名のチェックをスキップします。

        警告

        エラーを無視して続行 を選択すると、データの不整合が発生し、ビジネスにリスクをもたらす可能性があります。例:

        • テーブルスキーマが同一で、宛先データベースのレコードがソースデータベースのレコードと同じプライマリキーまたは一意キー値を持つ場合:

          • 完全同期中は、DTS が宛先クラスターのレコードを保持します。ソースデータベースの対応するレコードは同期されません。

          • 増分同期中は、ソースデータベースのレコードが宛先データベースのレコードを上書きします。

        • テーブルスキーマが異なる場合、初期データ同期が失敗する可能性があります。これにより、一部のカラムデータのみが同期されるか、完全に同期が失敗する可能性があります。慎重に操作してください。

      イベントを移行するかどうか

      必要に応じて、ソースデータベースからイベントを同期するかどうかを指定します。○ を選択する場合、関連要件を満たし、後続の操作を実行する必要があります。詳細については、「イベントの同期または移行」をご参照ください。

      移行先インスタンスでのオブジェクト名の大文字化

      宛先インスタンスに同期されるデータベース、テーブル、カラムオブジェクト名の大文字小文字の扱いポリシーを設定できます。デフォルトでは、DTS のデフォルトポリシー が選択されています。ソースおよび宛先データベースのデフォルトポリシーを使用することもできます。詳細については、「宛先オブジェクト名の大文字小文字の扱いポリシー」をご参照ください。

      ソースオブジェクト

      ソースオブジェクト ボックスで、同期するオブジェクトをクリックし、向右 をクリックして 選択中のオブジェクト ボックスに移動させます。

      説明

      データベースまたはテーブルレベルで同期するオブジェクトを選択できます。

      選択中のオブジェクト

      説明
      • データベースまたはテーブルレベルで SQL 操作を選択するには、選択中のオブジェクト セクションで同期オブジェクトを右クリックし、ダイアログボックスで目的の操作を選択します。詳細については、「サポートされる SQL 操作」をご参照ください。

      • データをフィルターするには、選択中のオブジェクト セクションで同期するテーブルを右クリックし、ダイアログボックスでフィルター条件を設定します。詳細については、「フィルター条件の設定」をご参照ください。

      • オブジェクト名マッピング機能を使用する場合、マッピングされたオブジェクトに依存する他のオブジェクトの同期が失敗する可能性があります。

    2. 詳細設定へ をクリックして、高度なパラメーターを設定します。

      パラメーター

      説明

      タスクのスケジュールに使用する専用クラスターの選択

      デフォルトでは、DTS は共有クラスター上でタスクをスケジューリングするため、クラスターを選択する必要はありません。より安定したパフォーマンスを求める場合は、DTS 同期タスクを実行するための専用クラスターを購入できます。詳細については、「DTS 専用クラスターとは」をご参照ください。

      移行先データベースのエンジンタイプを選択します。

      宛先データベースのエンジンタイプを選択します。

      • InnoDB:デフォルトのストレージエンジンです。

      • X-Engine:オンライントランザクション処理 (OLTP) 向けのデータベースストレージエンジンです。

      移行元テーブルで生成された Online DDL ツールの一時テーブルを移行先データベースにコピーします。

      ソースデータベースで Data Management (DMS) または gh-ost を使用してオンライン DDL 変更を実行する場合、オンライン DDL 変更によって生成された一時テーブルのデータを同期するかどうかを選択できます。

      重要
      • DTS タスクは、pt-online-schema-change などのツールを使用したオンライン DDL 変更をサポートしていません。これらのツールを使用すると、DTS タスクが失敗します。

      • 各ステージの処理方法は次のとおりです。スキーマ同期 および 完全データ同期 ステージでは、データベースまたはテーブルスキーマを変更する DDL 操作が許可されていないため、これらのステージはオンライン DDL ポリシーの制御を受けません。

        • スキーマ同期:このステージはオンライン DDL ポリシーの制御を受けません。関連する一時テーブルが作成されます。

        • 完全データ同期:このステージはオンライン DDL ポリシーの制御を受けません。一時テーブルは完全同期オブジェクトに含まれません。正規表現 (^_(.+)_(?:gho|new)$ または ^_(.+)_(?:ghc|del|old)$) に一致するすべてのテーブルがフィルターで除外されます。

        • 増分データ同期:このステージはオンライン DDL ポリシーの制御を受けます。

          • ○:オンライン DDL 操作によって生成された一時テーブル(例:_table-name_gho)のデータ変更を同期します。

          • いいえ、DMS オンライン DDL に適応 および いいえ、gh-ost に適応:gh-ost などのツールによって生成された一時テーブル(例:_table-name_gho)のデータ変更を正規表現ルールに基づいてフィルターで除外します。

      • ○:オンライン DDL 変更によって生成された一時テーブルのデータを同期します。

        説明

        オンライン DDL 変更によって生成された一時テーブルのデータが大きすぎる場合、同期遅延が発生する可能性があります。

      • いいえ、DMS オンライン DDL に適応:オンライン DDL 操作によって生成された一時テーブルのデータを同期しません。ソースデータベースで Data Management (DMS) を使用して実行された元の DDL ステートメントのみを同期します。

        説明

        このオプションにより、宛先データベースでテーブルがロックされます。

      • いいえ、gh-ost に適応:オンライン DDL 変更によって生成された一時テーブルのデータを同期しません。カスタムフィルタールールをサポートしています。DTS は、gh-ost などのツールによって生成された一時テーブル(例:_table-name_gho)のデータ変更を正規表現ルールに基づいてフィルターで除外します。必要に応じて、シャドウテーブルおよび不要なテーブルに一致させるデフォルトの正規表現を変更できます。

        • シャドウテーブル:^_(.+)_(?:gho|new)$

        • 不要なテーブル:^_(.+)_(?:ghc|del|old)$

        説明

        このオプションにより、宛先データベースでテーブルがロックされます。

      アカウントを移行

      ソースデータベースからアカウント情報を同期するかどうかを指定します。○ を選択する場合、同期するアカウントを選択し、アカウント権限を確認してください。権限付与方法については、「データベースアカウントの移行」をご参照ください。

      失敗した接続の再試行時間

      同期タスク開始後、ソースまたは宛先データベースへの接続が失敗した場合、DTS はエラーを報告し、直ちに接続の再試行を開始します。デフォルトの再試行時間は 720 分です。10 分から 1,440 分の範囲でカスタム再試行時間を指定することもできます。30 分以上に設定することを推奨します。指定された時間内に DTS がデータベースへの再接続に成功した場合、同期タスクは自動的に再開されます。それ以外の場合は、タスクが失敗します。

      説明
      • 同じソースまたは宛先を共有する複数の DTS インスタンス(例:インスタンス A とインスタンス B)があり、インスタンス A のネットワーク再試行時間を 30 分、インスタンス B を 60 分に設定した場合、両方に短い方の 30 分が適用されます。

      • DTS は接続再試行期間中もタスクランタイムに対して課金するため、ビジネス要件に基づいて再試行時間をカスタマイズするか、ソースおよび宛先データベースインスタンスをリリースした後は速やかに DTS インスタンスをリリースすることを推奨します。

      移行元データベースと移行先データベースで他の問題が発生した場合の、再試行までの待機時間です。

      同期タスク開始後、ソースまたは宛先データベースで接続以外の問題(DDL または DML 実行例外など)が発生した場合、DTS はエラーを報告し、直ちに継続的な再試行操作を開始します。デフォルトの再試行時間は 10 分です。1 分から 1,440 分の範囲でカスタム再試行時間を指定することもできます。10 分以上に設定することを推奨します。設定された再試行時間内に関連操作が成功した場合、同期タスクは自動的に再開されます。それ以外の場合は、タスクが失敗します。

      重要

      移行元データベースと移行先データベースで他の問題が発生した場合の、再試行までの待機時間です。 の値は、失敗した接続の再試行時間 の値よりも小さくする必要があります。

      完全同期レートを制限するかどうか

      完全同期ステージ中、DTS はソースおよび宛先データベースの読み取りおよび書き込みリソースを消費するため、データベース負荷が増大します。ソースおよび宛先データベースの負荷を軽減するために、1 秒あたりのソースデータベースのクエリ率 QPS、1 秒あたりの完全移行の行数 RPS、および 1 秒あたりの完全移行データ量 (MB) BPS パラメーターを設定して、完全同期タスクのレート制限を設定できます。

      説明
      • この設定項目は、同期タイプ が 完全データ同期 に設定されている場合にのみ利用可能です。

      • 同期インスタンスの実行後にも、完全同期レートを調整 できます。

      増分同期率を制限するかどうか

      増分同期タスクのレート制限を設定することもできます。宛先データベースの負荷を軽減するために、1 秒あたりの増分同期の行数 RPS および 1 秒あたりの増分同期データ量 (MB) BPS を設定してください。

      環境タグ

      任意です。インスタンスを識別しやすくするためのタグを選択します。

      順方向および逆方向タスクのハートビートテーブル SQL を削除

      DTS インスタンス実行中にソースデータベースにハートビート SQL 情報を書き込むかどうかを選択します。

      • ○:ハートビート SQL 情報はソースデータベースに書き込まれません。これにより、DTS インスタンスが遅延を報告する可能性があります。

      • ×:ハートビート SQL 情報をソースデータベースに書き込みます。これにより、ソースデータベースの物理バックアップやクローンなどの機能に干渉する可能性があります。

      ETL 機能の設定

      抽出・変換・書き出し (ETL) 機能を有効にするかどうかを選択します。詳細については、「ETL とは」をご参照ください。有効値:

      監視アラート

      アラートを設定するかどうかを指定します。同期が失敗した場合や遅延が指定されたしきい値を超えた場合、アラート連絡先に通知が送信されます。

    3. 次へ:データ検証 をクリックして、データ検証タスクを設定します。

      データ検証機能を使用する場合は、「データ検証の設定」を参照して設定手順を確認してください。

  6. タスクを保存して事前チェックを実行します。

    • このインスタンスを設定するための API パラメーターを表示するには、次:タスク設定の保存と事前チェック ボタンにカーソルを合わせ、表示されたバルーン内の OpenAPI パラメーターのプレビュー をクリックします。

    • API パラメーターの確認が完了したら、ページ下部の 次:タスク設定の保存と事前チェック をクリックします。

    説明
    • 同期ジョブ開始前に、DTS は事前チェックを実行します。すべての事前チェック項目が合格した後にのみ、ジョブを開始できます。

    • 事前チェックに失敗した場合は、失敗した項目の横にある 詳細を表示 をクリックします。表示された指示に従って問題を修正し、再度事前チェックを実行してください。

    • 事前チェックで警告が返された場合:

      • チェック項目が失敗し、無視できない場合は、項目の横にある 詳細を表示 をクリックします。指示に従って問題を修正し、再度事前チェックを実行してください。

      • 無視可能なチェック項目については、アラートの詳細を確認、無視、OK、および 再度事前チェックを実行 を順にクリックして、警告をスキップし、事前チェックを再実行します。警告項目をマスクする場合、データの不整合などの問題が発生し、ビジネスにリスクをもたらす可能性があります。

  7. インスタンスを購入します。

    1. [成功率] が 100% になったら、次:インスタンスの購入 をクリックします。

    2. 購入 ページで、データ同期インスタンスの課金方法およびリンク仕様を選択します。以下の表に、これらのパラメーターの詳細を示します。

      カテゴリ

      パラメーター

      説明

      新しいインスタンスクラス

      課金方法

      • サブスクリプション:インスタンス作成時に支払いを行います。長期的なニーズに適しており、従量課金よりもコスト効率が高くなります。サブスクリプション期間が長いほど、割引率が高くなります。

      • 従量課金:1 時間単位で課金されます。短期的なニーズに適しています。使用後すぐにインスタンスをリリースすることでコストを節約できます。

      リソースグループ設定

      インスタンスが属するリソースグループです。デフォルトは default resource group です。詳細については、「Resource Management とは」をご参照ください。

      リンク仕様

      DTS は、さまざまなパフォーマンスレベルを持つ同期仕様を提供しています。同期リンク仕様は同期レートに影響します。ビジネスシナリオに基づいて仕様を選択できます。詳細については、「データ同期リンク仕様」をご参照ください。

      サブスクリプション期間

      サブスクリプションモードの場合、サブスクリプションインスタンスの期間および数量を選択します。1~9 ヶ月の月単位サブスクリプション、または 1、2、3、5 年の年単位サブスクリプションを選択できます。

      説明

      このオプションは、課金方法が サブスクリプション の場合にのみ利用可能です。

    3. 設定が完了したら、Data Transmission Service (従量課金) 利用規約 を読み、同意してください。

    4. 購入して起動 をクリックします。OK ダイアログボックスで、OK をクリックします。

      データ同期ページでタスクの進捗状況を確認できます。