DTS は、MySQL から PolarDB for MySQL クラスターへデータを同期します。
サポートされるソースデータベース
以下のソース MySQL データベースを PolarDB for MySQL クラスターに同期できます。本トピックでは RDS MySQL インスタンスを例として説明します。他のソースデータベースの場合も手順は同様です。
-
ApsaraDB RDS for MySQL インスタンス
-
Elastic Compute Service (ECS) 上でホストされている自己管理データベース
-
Express Connect、VPN Gateway、または Smart Access Gateway 経由で接続された自己管理データベース
-
Database Gateway 経由で接続された自己管理データベース
-
Cloud Enterprise Network (CEN) 経由で接続された自己管理データベース
前提条件
-
ソースとなる RDS for MySQL インスタンス。
-
ターゲットとなる PolarDB for MySQL クラスター。詳細については、「従量課金クラスターの作成」および「サブスクリプションクラスターの作成」をご参照ください。
-
PolarDB for MySQL クラスターのストレージ容量は、RDS for MySQL インスタンスの容量を超える必要があります。
注意事項
スキーマ同期中に、DTS は外部キーをソースデータベースから宛先データベースに同期します。
完全データ同期および増分データ同期中、DTS はセッションレベルで制約チェックおよび外部キーのカスケード操作を一時的に無効化します。タスク実行中にソースデータベースでカスケード更新または削除操作が実行されると、データの不整合が発生する可能性があります。
種別 | 説明 |
ソースデータベースの制限 |
|
その他の制限 |
|
特殊なケース |
|
課金
|
同期タイプ |
料金 |
|
スキーマ同期および完全データ同期 |
無料です。 |
|
増分データ同期 |
課金対象です。詳細については、「課金概要」をご参照ください。 |
サポートされる同期トポロジ
-
1 対 1 の一方向同期
-
1 対多の一方向同期
-
カスケード型の一方向同期
-
多対 1 の一方向同期
同期トポロジおよびその使用方法の詳細については、「データ同期トポロジ」をご参照ください。
サポートされる SQL ステートメント
|
操作タイプ |
SQL ステートメント |
|
DML |
INSERT、UPDATE、DELETE |
|
DDL |
|
操作手順
-
宛先リージョンの同期タスク一覧ページに移動します。以下の 2 つの方法のいずれかを使用できます。
DTS コンソールから
-
左側のナビゲーションウィンドウで、データ同期 をクリックします。
-
ページ左上隅で、同期インスタンスが配置されているリージョンを選択します。
DMS コンソールから
説明実際の操作は、DMS コンソールのモードおよびレイアウトによって異なる場合があります。詳細については、「シンプルモード」および「DMS インターフェイスのレイアウトとスタイルのカスタマイズ」をご参照ください。
-
Data Management (DMS) にログインします。
-
上部メニューバーで、 を選択します。
-
データ同期タスク の右側で、同期インスタンスが配置されているリージョンを選択します。
-
タスクの作成 をクリックして、タスク設定ページを開きます。
-
ソースおよび宛先データベースを設定します。
警告ソースおよび宛先インスタンスを選択した後、ページ上部に表示される制限事項を慎重に確認してください。制限事項に従わないと、タスクが失敗したりデータの不整合が発生したりする可能性があります。
カテゴリ
パラメーター
説明
該当なし
タスク名
DTS は自動的にタスク名を生成します。識別しやすいように、わかりやすい名前を指定することを推奨します。名前に一意性は必要ありません。
移行元データベース
既存の接続情報の選択
-
システムに追加済み(新規作成または保存済み)のデータベースインスタンスを使用する場合は、ドロップダウンリストからデータベースインスタンスを選択します。データベース情報は自動的に設定されます。
説明DMS コンソールでは、この設定項目の名前は DMS データベースインスタンスの選択 です。
-
データベースインスタンスをシステムに追加していない場合、またはすでに追加済みのインスタンスを使用しない場合は、以下のデータベース情報を手動で設定します。
データベースタイプ
MySQL を選択します。
アクセス方法
Alibaba Cloud インスタンス を選択します。
インスタンスリージョン
ソース ApsaraDB RDS for MySQL インスタンスが配置されているリージョンを選択します。
Alibaba Cloudアカウント全体でのデータの複製
同一 Alibaba Cloud アカウント内での同期の場合、× を選択します。
RDS インスタンス ID
ソース ApsaraDB RDS for MySQL インスタンスの ID を選択します。
データベースアカウント
ソース ApsaraDB RDS for MySQL インスタンスのデータベースアカウントを入力します。アカウントには REPLICATION CLIENT、REPLICATION SLAVE、SHOW VIEW、および SELECT 権限が必要です。
データベースパスワード
データベースアカウントに対応するパスワードを入力します。
暗号化
必要に応じて、非暗号化 または SSL 暗号化 を選択します。SSL 暗号化 を選択する場合、事前に RDS for MySQL インスタンスで SSL 暗号化を有効にしておく必要があります。詳細については、「クラウド証明書を使用した SSL 暗号化の迅速な有効化」をご参照ください。
移行先データベース
既存の接続情報の選択
-
システムに追加済み(新規作成または保存済み)のデータベースインスタンスを使用する場合は、ドロップダウンリストからデータベースインスタンスを選択します。データベース情報は自動的に設定されます。
説明DMS コンソールでは、この設定項目の名前は DMS データベースインスタンスの選択 です。
-
データベースインスタンスをシステムに追加していない場合、またはすでに追加済みのインスタンスを使用しない場合は、以下のデータベース情報を手動で設定します。
データベースタイプ
PolarDB for MySQL を選択します。
アクセス方法
Alibaba Cloud インスタンス を選択します。
インスタンスリージョン
宛先 PolarDB for MySQL クラスターが配置されているリージョンを選択します。
PolarDB クラスター ID
宛先 PolarDB for MySQL クラスターの ID を選択します。
データベースアカウント
宛先 PolarDB for MySQL クラスターのデータベースアカウントを入力します。アカウントには読み取りおよび書き込み権限が必要です。
データベースパスワード
データベースアカウントに対応するパスワードを入力します。
暗号化
要件に基づいてオプションを選択します。詳細については、「SSL 暗号化の設定」をご参照ください。
-
-
設定が完了したら、ページ下部の 接続をテストして続行 をクリックします。
説明-
DTS サーバーからのアクセスを許可するために、ソースおよび宛先データベースのセキュリティ設定に DTS サーバーの IP アドレス CIDR ブロックを追加していることを確認してください。これは自動または手動で行えます。詳細については、「DTS サーバーの IP アドレス CIDR ブロックをホワイトリストに追加」をご参照ください。
-
ソースまたは宛先データベースが自己管理データベース(アクセス方法 が Alibaba Cloud インスタンス ではない)の場合、DTS サーバーの CIDR ブロック ダイアログボックスで 接続テスト をクリックする必要もあります。
-
-
タスクオブジェクトを設定します。
-
オブジェクト設定 ページで、同期するオブジェクトを設定します。
パラメーター
説明
同期タイプ
増分データ同期 が選択されています。デフォルトでは、スキーマ同期 および 完全データ同期 も選択する必要があります。事前チェックが完了すると、DTS は選択されたオブジェクトの完全データ同期をソースインスタンスから宛先クラスターに実行します。これは、その後の増分データ同期のベースラインデータとなります。
移行元データベースのトリガーを移行する方法
トリガー同期方法を選択します。トリガーが関与しない場合は、このパラメーターをスキップしてください。詳細については、「トリガーの同期または移行方法の設定」をご参照ください。
説明このパラメーターは、同期タイプ が スキーマ同期 に設定されている場合にのみ設定できます。
同期トポロジ
一方向同期 を選択します。
競合するテーブルの処理モード
-
エラーの事前チェックと報告:宛先データベースに同じ名前のテーブルが存在するかどうかをチェックします。同じ名前のテーブルが存在しない場合、事前チェックは合格します。同じ名前のテーブルが存在する場合、事前チェックは失敗し、データ同期タスクは開始されません。
説明宛先データベースで同じ名前のテーブルを削除または名前変更できない場合は、別のテーブル名にマッピングできます。詳細については、「テーブル名およびカラム名のマッピング」をご参照ください。
-
エラーを無視して続行:宛先データベースでの重複テーブル名のチェックをスキップします。
警告エラーを無視して続行 を選択すると、データの不整合が発生し、ビジネスにリスクをもたらす可能性があります。例:
-
テーブルスキーマが同一で、宛先データベースのレコードがソースデータベースのレコードと同じプライマリキーまたは一意キー値を持つ場合:
-
完全同期中は、DTS が宛先クラスターのレコードを保持します。ソースデータベースの対応するレコードは同期されません。
-
増分同期中は、ソースデータベースのレコードが宛先データベースのレコードを上書きします。
-
-
テーブルスキーマが異なる場合、初期データ同期が失敗する可能性があります。これにより、一部のカラムデータのみが同期されるか、完全に同期が失敗する可能性があります。慎重に操作してください。
-
イベントを移行するかどうか
必要に応じて、ソースデータベースからイベントを同期するかどうかを指定します。○ を選択する場合、関連要件を満たし、後続の操作を実行する必要があります。詳細については、「イベントの同期または移行」をご参照ください。
移行先インスタンスでのオブジェクト名の大文字化
宛先インスタンスに同期されるデータベース、テーブル、カラムオブジェクト名の大文字小文字の扱いポリシーを設定できます。デフォルトでは、DTS のデフォルトポリシー が選択されています。ソースおよび宛先データベースのデフォルトポリシーを使用することもできます。詳細については、「宛先オブジェクト名の大文字小文字の扱いポリシー」をご参照ください。
ソースオブジェクト
ソースオブジェクト ボックスで、同期するオブジェクトをクリックし、
をクリックして 選択中のオブジェクト ボックスに移動させます。説明データベースまたはテーブルレベルで同期するオブジェクトを選択できます。
選択中のオブジェクト
-
宛先インスタンスで単一の同期オブジェクトの名前を変更するには、選択中のオブジェクト ボックス内のオブジェクトを右クリックします。オブジェクトの名前変更方法の詳細については、「単一のデータベース、テーブル、またはカラムのマッピング」をご参照ください。
-
宛先インスタンスで複数の同期オブジェクトの名前を一括で変更するには、選択中のオブジェクト ボックスの右上隅にある 一括編集 をクリックします。詳細については、「データベース、テーブル、およびカラムの一括マッピング」をご参照ください。
説明-
データベースまたはテーブルレベルで SQL 操作を選択するには、選択中のオブジェクト セクションで同期オブジェクトを右クリックし、ダイアログボックスで目的の操作を選択します。詳細については、「サポートされる SQL 操作」をご参照ください。
-
データをフィルターするには、選択中のオブジェクト セクションで同期するテーブルを右クリックし、ダイアログボックスでフィルター条件を設定します。詳細については、「フィルター条件の設定」をご参照ください。
-
オブジェクト名マッピング機能を使用する場合、マッピングされたオブジェクトに依存する他のオブジェクトの同期が失敗する可能性があります。
-
-
詳細設定へ をクリックして、高度なパラメーターを設定します。
パラメーター
説明
タスクのスケジュールに使用する専用クラスターの選択
デフォルトでは、DTS は共有クラスター上でタスクをスケジューリングするため、クラスターを選択する必要はありません。より安定したパフォーマンスを求める場合は、DTS 同期タスクを実行するための専用クラスターを購入できます。詳細については、「DTS 専用クラスターとは」をご参照ください。
移行先データベースのエンジンタイプを選択します。
宛先データベースのエンジンタイプを選択します。
-
InnoDB:デフォルトのストレージエンジンです。
-
X-Engine:オンライントランザクション処理 (OLTP) 向けのデータベースストレージエンジンです。
移行元テーブルで生成された Online DDL ツールの一時テーブルを移行先データベースにコピーします。
ソースデータベースで Data Management (DMS) または gh-ost を使用してオンライン DDL 変更を実行する場合、オンライン DDL 変更によって生成された一時テーブルのデータを同期するかどうかを選択できます。
重要-
DTS タスクは、pt-online-schema-change などのツールを使用したオンライン DDL 変更をサポートしていません。これらのツールを使用すると、DTS タスクが失敗します。
-
各ステージの処理方法は次のとおりです。スキーマ同期 および 完全データ同期 ステージでは、データベースまたはテーブルスキーマを変更する DDL 操作が許可されていないため、これらのステージはオンライン DDL ポリシーの制御を受けません。
-
スキーマ同期:このステージはオンライン DDL ポリシーの制御を受けません。関連する一時テーブルが作成されます。
-
完全データ同期:このステージはオンライン DDL ポリシーの制御を受けません。一時テーブルは完全同期オブジェクトに含まれません。正規表現 (
^_(.+)_(?:gho|new)$または^_(.+)_(?:ghc|del|old)$) に一致するすべてのテーブルがフィルターで除外されます。 -
増分データ同期:このステージはオンライン DDL ポリシーの制御を受けます。
-
○:オンライン DDL 操作によって生成された一時テーブル(例:
_table-name_gho)のデータ変更を同期します。 -
いいえ、DMS オンライン DDL に適応 および いいえ、gh-ost に適応:gh-ost などのツールによって生成された一時テーブル(例:
_table-name_gho)のデータ変更を正規表現ルールに基づいてフィルターで除外します。
-
-
-
○:オンライン DDL 変更によって生成された一時テーブルのデータを同期します。
説明オンライン DDL 変更によって生成された一時テーブルのデータが大きすぎる場合、同期遅延が発生する可能性があります。
-
いいえ、DMS オンライン DDL に適応:オンライン DDL 操作によって生成された一時テーブルのデータを同期しません。ソースデータベースで Data Management (DMS) を使用して実行された元の DDL ステートメントのみを同期します。
説明このオプションにより、宛先データベースでテーブルがロックされます。
-
いいえ、gh-ost に適応:オンライン DDL 変更によって生成された一時テーブルのデータを同期しません。カスタムフィルタールールをサポートしています。DTS は、gh-ost などのツールによって生成された一時テーブル(例:
_table-name_gho)のデータ変更を正規表現ルールに基づいてフィルターで除外します。必要に応じて、シャドウテーブルおよび不要なテーブルに一致させるデフォルトの正規表現を変更できます。-
シャドウテーブル:
^_(.+)_(?:gho|new)$ -
不要なテーブル:
^_(.+)_(?:ghc|del|old)$
説明このオプションにより、宛先データベースでテーブルがロックされます。
-
アカウントを移行
ソースデータベースからアカウント情報を同期するかどうかを指定します。○ を選択する場合、同期するアカウントを選択し、アカウント権限を確認してください。権限付与方法については、「データベースアカウントの移行」をご参照ください。
失敗した接続の再試行時間
同期タスク開始後、ソースまたは宛先データベースへの接続が失敗した場合、DTS はエラーを報告し、直ちに接続の再試行を開始します。デフォルトの再試行時間は 720 分です。10 分から 1,440 分の範囲でカスタム再試行時間を指定することもできます。30 分以上に設定することを推奨します。指定された時間内に DTS がデータベースへの再接続に成功した場合、同期タスクは自動的に再開されます。それ以外の場合は、タスクが失敗します。
説明-
同じソースまたは宛先を共有する複数の DTS インスタンス(例:インスタンス A とインスタンス B)があり、インスタンス A のネットワーク再試行時間を 30 分、インスタンス B を 60 分に設定した場合、両方に短い方の 30 分が適用されます。
-
DTS は接続再試行期間中もタスクランタイムに対して課金するため、ビジネス要件に基づいて再試行時間をカスタマイズするか、ソースおよび宛先データベースインスタンスをリリースした後は速やかに DTS インスタンスをリリースすることを推奨します。
移行元データベースと移行先データベースで他の問題が発生した場合の、再試行までの待機時間です。
同期タスク開始後、ソースまたは宛先データベースで接続以外の問題(DDL または DML 実行例外など)が発生した場合、DTS はエラーを報告し、直ちに継続的な再試行操作を開始します。デフォルトの再試行時間は 10 分です。1 分から 1,440 分の範囲でカスタム再試行時間を指定することもできます。10 分以上に設定することを推奨します。設定された再試行時間内に関連操作が成功した場合、同期タスクは自動的に再開されます。それ以外の場合は、タスクが失敗します。
重要移行元データベースと移行先データベースで他の問題が発生した場合の、再試行までの待機時間です。 の値は、失敗した接続の再試行時間 の値よりも小さくする必要があります。
完全同期レートを制限するかどうか
完全同期ステージ中、DTS はソースおよび宛先データベースの読み取りおよび書き込みリソースを消費するため、データベース負荷が増大します。ソースおよび宛先データベースの負荷を軽減するために、1 秒あたりのソースデータベースのクエリ率 QPS、1 秒あたりの完全移行の行数 RPS、および 1 秒あたりの完全移行データ量 (MB) BPS パラメーターを設定して、完全同期タスクのレート制限を設定できます。
説明-
この設定項目は、同期タイプ が 完全データ同期 に設定されている場合にのみ利用可能です。
-
同期インスタンスの実行後にも、完全同期レートを調整 できます。
増分同期率を制限するかどうか
増分同期タスクのレート制限を設定することもできます。宛先データベースの負荷を軽減するために、1 秒あたりの増分同期の行数 RPS および 1 秒あたりの増分同期データ量 (MB) BPS を設定してください。
環境タグ
任意です。インスタンスを識別しやすくするためのタグを選択します。
順方向および逆方向タスクのハートビートテーブル SQL を削除
DTS インスタンス実行中にソースデータベースにハートビート SQL 情報を書き込むかどうかを選択します。
-
○:ハートビート SQL 情報はソースデータベースに書き込まれません。これにより、DTS インスタンスが遅延を報告する可能性があります。
-
×:ハートビート SQL 情報をソースデータベースに書き込みます。これにより、ソースデータベースの物理バックアップやクローンなどの機能に干渉する可能性があります。
ETL 機能の設定
抽出・変換・書き出し (ETL) 機能を有効にするかどうかを選択します。詳細については、「ETL とは」をご参照ください。有効値:
-
○:ETL 機能を有効にします。コードエディタにデータ処理ステートメントを入力します。詳細については、「データ移行またはデータ同期タスクでの ETL の設定」をご参照ください。
-
×:ETL 機能を無効にします。
監視アラート
アラートを設定するかどうかを指定します。同期が失敗した場合や遅延が指定されたしきい値を超えた場合、アラート連絡先に通知が送信されます。
-
×:アラートは設定されません。
-
○:アラートのしきい値を設定し、アラート通知を指定することでアラートを設定します。詳細については、「タスク設定中のモニタリングとアラートの設定」をご参照ください。
-
-
次へ:データ検証 をクリックして、データ検証タスクを設定します。
データ検証機能を使用する場合は、「データ検証の設定」を参照して設定手順を確認してください。
-
-
タスクを保存して事前チェックを実行します。
-
このインスタンスを設定するための API パラメーターを表示するには、次:タスク設定の保存と事前チェック ボタンにカーソルを合わせ、表示されたバルーン内の OpenAPI パラメーターのプレビュー をクリックします。
-
API パラメーターの確認が完了したら、ページ下部の 次:タスク設定の保存と事前チェック をクリックします。
説明-
同期ジョブ開始前に、DTS は事前チェックを実行します。すべての事前チェック項目が合格した後にのみ、ジョブを開始できます。
-
事前チェックに失敗した場合は、失敗した項目の横にある 詳細を表示 をクリックします。表示された指示に従って問題を修正し、再度事前チェックを実行してください。
-
事前チェックで警告が返された場合:
-
チェック項目が失敗し、無視できない場合は、項目の横にある 詳細を表示 をクリックします。指示に従って問題を修正し、再度事前チェックを実行してください。
-
無視可能なチェック項目については、アラートの詳細を確認、無視、OK、および 再度事前チェックを実行 を順にクリックして、警告をスキップし、事前チェックを再実行します。警告項目をマスクする場合、データの不整合などの問題が発生し、ビジネスにリスクをもたらす可能性があります。
-
-
-
インスタンスを購入します。
-
[成功率] が 100% になったら、次:インスタンスの購入 をクリックします。
-
購入 ページで、データ同期インスタンスの課金方法およびリンク仕様を選択します。以下の表に、これらのパラメーターの詳細を示します。
カテゴリ
パラメーター
説明
新しいインスタンスクラス
課金方法
-
サブスクリプション:インスタンス作成時に支払いを行います。長期的なニーズに適しており、従量課金よりもコスト効率が高くなります。サブスクリプション期間が長いほど、割引率が高くなります。
-
従量課金:1 時間単位で課金されます。短期的なニーズに適しています。使用後すぐにインスタンスをリリースすることでコストを節約できます。
リソースグループ設定
インスタンスが属するリソースグループです。デフォルトは default resource group です。詳細については、「Resource Management とは」をご参照ください。
リンク仕様
DTS は、さまざまなパフォーマンスレベルを持つ同期仕様を提供しています。同期リンク仕様は同期レートに影響します。ビジネスシナリオに基づいて仕様を選択できます。詳細については、「データ同期リンク仕様」をご参照ください。
サブスクリプション期間
サブスクリプションモードの場合、サブスクリプションインスタンスの期間および数量を選択します。1~9 ヶ月の月単位サブスクリプション、または 1、2、3、5 年の年単位サブスクリプションを選択できます。
説明このオプションは、課金方法が サブスクリプション の場合にのみ利用可能です。
-
-
設定が完了したら、Data Transmission Service (従量課金) 利用規約 を読み、同意してください。
-
購入して起動 をクリックします。OK ダイアログボックスで、OK をクリックします。
データ同期ページでタスクの進捗状況を確認できます。
-