Topik ini menjelaskan cara mengatasi kegagalan koneksi ke instans ApsaraDB RDS.
Galat koneksi umum
Temukan pesan error yang sesuai dengan situasi Anda dan ikuti solusi yang relevan.
MySQL dan MariaDB
Pesan Kesalahan | Penyebab | Solusi |
| Masalah konektivitas jaringan. |
Untuk informasi lebih lanjut, lihat Solusi. |
| Masalah konfigurasi daftar putih alamat IP. | |
| Username atau password salah. | Periksa username dan password dalam detail koneksi Anda:
|
| Server DNS tidak dapat menyelesaikan titik akhir. |
Catatan Meskipun Anda dapat melakukan ping ke instans untuk mengetahui alamat IP-nya saat ini, jangan gunakan IP tersebut untuk koneksi. Alamat IP dapat berubah selama peristiwa seperti migrasi atau alih bencana primary/secondary. Selalu gunakan endpoint karena bersifat statis. |
ERROR 2059 (HY000): Authentication plugin 'caching_sha2_password' cannot be loaded: /usr/xx/xx/caching_sha2_password.so: cannot open shared object file: No such file or directory | MySQL tidak dapat memuat plug-in autentikasi |
|
| Koneksi timeout karena tidak aktif. | Hal ini terjadi ketika koneksi client idle melebihi periode timeout server (dikendalikan oleh parameter seperti |
Access denied for user 'root'@'XXX' (using password: YES) to database 'XX' | Koneksi dari instance ECS ditolak karena menggunakan akun | Secara default, akun |
From XXX (172.17.XX.XX) icmp_seq=1 Destination Host Unreachable | Instance ECS tidak dapat melakukan ping ke private endpoint instance RDS karena blok CIDR pribadi instance RDS bertentangan dengan layanan lain di instance ECS. |
SQL Server
Pesan error | Penyebab | Solusi |
Cannot connect to XXX. A network-related or instance-specific error occurred while establishing a connection to SQL Server. The server was not found or was not accessible. Verify that the instance name is correct and that SQL Server is configured to allow remote connections. (provider: TCP Provider, error: 0 - A connection attempt failed because the connected party did not properly respond after a period of time, or established connection failed because connected host has failed to respond.) (Microsoft SQL Server, Error: 10060 or 258) | Masalah konektivitas jaringan. |
Untuk informasi lebih lanjut, lihat Solusi. |
Cannot connect to XXX. A connection was successfully established with the server, but then an error occurred during the login process. (provider: TCP Provider, error: 0 - The specified network name is no longer available.) (Microsoft SQL Server, Error: 64) | Masalah konfigurasi daftar putih alamat IP. | |
Logon failed for login 'user' due to trigger execution | Batas koneksi tercapai. | Periksa jumlah koneksi ke instans dan apakah ada koneksi yang diblokir |
cannot open user default database.Login failed | Database default pengguna yang melakukan koneksi tidak memiliki user terkait di instans ApsaraDB RDS for SQL Server. | |
From XXX (172.17.XX.XX) icmp_seq=1 Destination Host Unreachable | Instance ECS tidak dapat melakukan ping ke private endpoint instance RDS karena blok CIDR pribadi instance RDS bertentangan dengan layanan lain di instance ECS. |
PostgreSQL
Pesan kesalahan | Penyebab | Solusi |
Unable to connect to server: could not connect to server: Connection timed out (0x0000274C/10060)Is the server running on host XXX.rds.aliyuncs.com and acceptingTCP/IP connections on port XXX? | Masalah konektivitas jaringan. |
Untuk informasi lebih lanjut, lihat Solusi. |
| Masalah konfigurasi daftar putih alamat IP. | |
FATAL: remaining connection slots are reserved for non-replication superuser connections | Batas koneksi tercapai. | |
FATAL: password authentication failed for user "xxx". | Password salah. | Atur ulang password dan coba lagi. Untuk informasi lebih lanjut tentang cara mengatur ulang password, lihat Atur ulang password. |
From XXX (172.17.XX.XX) icmp_seq=1 Destination Host Unreachable | Instance ECS tidak dapat melakukan ping ke private endpoint instance RDS karena blok CIDR pribadi instance RDS bertentangan dengan layanan lain di instance ECS. |
Galat koneksi DMS
Untuk operasi terkait, lihat Hubungkan ke database RDS MySQL menggunakan DMS, Hubungkan ke database RDS SQL Server menggunakan DMS, Hubungkan ke database RDS PostgreSQL menggunakan DMS, dan Hubungkan ke database RDS MariaDB menggunakan DMS.
Jika Anda mengatur ulang password akun, Anda harus login ke DMS lagi.
Pesan error | Penyebab | Solusi |
The MYSQL server is running with the --rds-deny-access option so it cannot execute this statement |
| Login ke console ApsaraDB RDS untuk memeriksa apakah instance terkunci:
|
Sorry, you cannot access this instance by using DMS at the moment. | Anda bukan pemilik instance dan belum diberikan izin login. | |
Please check the correctness of the endpoint, the network connectivity, and the IP address whitelist settings. | Masalah ini biasanya terjadi pada server MySQL yang dikelola sendiri. Kemungkinan penyebabnya meliputi:
|
Untuk informasi lebih lanjut, lihat Solusi. |
max_user_connections | Jumlah koneksi ke database RDS telah mencapai batas atas. | Atasi masalah yang disebabkan oleh batas koneksi RDS yang habis |
Unable to log on to the database due to an IP address whitelist issue. | Blok CIDR layanan DMS tidak ada dalam daftar putih alamat IP RDS. |
ECS tidak dapat mengakses RDS melalui jaringan internal
Untuk terhubung ke instance RDS menggunakan private endpoint-nya, Anda harus menambahkan alamat IP pribadi instance ECS ke daftar putih alamat IP instance RDS.
CatatanUntuk menambahkan daftar putih alamat IP, lihat Atur daftar putih alamat IP untuk RDS MySQL, Atur daftar putih alamat IP untuk RDS SQL Server, Atur daftar putih alamat IP untuk RDS PostgreSQL, Atur daftar putih alamat IP untuk RDS MariaDB.
Koneksi melalui jaringan internal akan gagal jika Anda hanya menambahkan alamat IP publik instance ECS ke daftar putih alamat IP RDS.
Instance ECS dan instance RDS harus berada di wilayah yang sama agar dapat berkomunikasi melalui jaringan internal. Keduanya dapat berada di zona ketersediaan yang sama atau berbeda dalam wilayah yang sama.
Pastikan instance ECS dan instance RDS berada di wilayah yang sama:
Lihat wilayah instance ECS.

Lihat wilayah instance RDS.

Jika instance ECS dan instance RDS berada di wilayah berbeda, keduanya tidak dapat berkomunikasi langsung melalui jaringan internal. Gunakan salah satu metode berikut:
Metode 1:
Metode 2: Instance ECS terhubung ke instance RDS menggunakan public endpoint instance RDS. Metode ini memberikan performa, keamanan, dan stabilitas yang buruk. Untuk informasi lebih lanjut tentang cara mengajukan public endpoint, lihat Ajukan public endpoint untuk MySQL, Ajukan public endpoint untuk SQL Server, Ajukan public endpoint untuk PostgreSQL, atau Ajukan public endpoint untuk MariaDB.
Periksa jenis jaringan
Pastikan instance ECS dan instance RDS memiliki jenis jaringan yang sama (keduanya berada di VPC atau keduanya berada di classic network).
Lihat jenis jaringan instance ECS.

Lihat jenis jaringan instance RDS.

Jika satu instance berada di classic network dan yang lain di VPC, gunakan salah satu metode berikut:
Skenario: Instance ECS berada di VPC, dan instance RDS berada di classic network.
Metode 1 (disarankan): Migrasikan instance RDS dari classic network ke VPC instance ECS. Untuk informasi lebih lanjut, lihat Ubah jenis jaringan.
Metode 2: Beli instance ECS baru yang berada di classic network. Namun, VPC direkomendasikan karena menyediakan keamanan yang lebih baik.
CatatanAnda tidak dapat memigrasikan instance ECS dari VPC ke classic network.
Metode 3: Instance ECS terhubung ke instance RDS menggunakan public endpoint instance RDS. Metode ini menawarkan performa, keamanan, dan stabilitas yang buruk. Untuk mempelajari cara mengajukan public endpoint, lihat Ajukan public endpoint untuk MySQL, Ajukan public endpoint untuk SQL Server, Ajukan public endpoint untuk PostgreSQL, atau Ajukan public endpoint untuk MariaDB.
Skenario: Instance ECS berada di classic network, dan instance RDS berada di VPC.
Metode 1 (disarankan): Migrasikan instance ECS dari classic network ke VPC tempat instance RDS berada. Untuk menemukan ID VPC instance RDS, buka halaman detail instance dan klik View Connection Details di sebelah Network Type. Untuk informasi lebih lanjut, lihat Contoh migrasi satu instance ECS.
Metode 2: Ubah jenis jaringan instance RDS dari VPC ke classic network. Namun, VPC menyediakan keamanan yang lebih baik daripada classic network. Kami menyarankan Anda menggunakan VPC.
Metode 3: Aktifkan ClassicLink untuk menghubungkan instance ECS classic network ke instance RDS VPC melalui jaringan internal.
CatatanJika jaringan tidak terhubung setelah Anda mengaktifkan ClassicLink, lihat Atasi masalah konektivitas jaringan antara classic network dan VPC setelah koneksi ClassicLink dibuat.
Metode 4: Instance ECS terhubung ke instance RDS menggunakan public endpoint instance RDS. Metode ini memiliki performa, keamanan, dan stabilitas yang buruk. Untuk informasi lebih lanjut tentang cara mengajukan public endpoint, lihat Ajukan public endpoint untuk MySQL, Ajukan public endpoint untuk SQL Server, Ajukan public endpoint untuk PostgreSQL, atau Ajukan public endpoint untuk MariaDB.
Jika instance ECS dan instance RDS keduanya berada di VPC, pastikan keduanya berada di VPC yang sama.
Lihat ID VPC instance ECS.

Lihat jenis jaringan instance RDS.

Jika keduanya berada di VPC berbeda, gunakan salah satu metode berikut:
Metode 1 (disarankan): Migrasikan instance RDS ke VPC tempat instance ECS berada. Untuk informasi lebih lanjut, lihat Ubah VPC dan vSwitch instance ApsaraDB RDS.
Metode 2: Gunakan CEN untuk menghubungkan kedua VPC.
Metode 3: Instance ECS terhubung ke instance RDS menggunakan public endpoint instance RDS. Metode ini memberikan performa, keamanan, dan stabilitas yang buruk. Untuk informasi tentang cara mengajukan public endpoint, lihat Ajukan public endpoint MySQL, Ajukan public endpoint SQL Server, Ajukan public endpoint PostgreSQL, atau Ajukan public endpoint MariaDB.
Jika instance ECS dan RDS berada di VPC dan wilayah yang sama, tetapi Anda hanya dapat terhubung menggunakan public endpoint (bukan private endpoint), dan ping serta telnet gagal, lihat Instance ECS tidak dapat terhubung ke instance RDS karena masalah routing.
Tidak dapat mengakses RDS melalui internet
Konfirmasi public endpoint
Verifikasi bahwa Anda menggunakan public endpoint instance RDS. Endpoint ini tersedia di halaman Database Connection di console ApsaraDB RDS.

Konfirmasi bahwa alamat IP publik perangkat lokal telah ditambahkan ke daftar putih alamat IP
PentingAlamat IP publik perangkat lokal dapat berubah. Misalnya, jika alamat IP publik bersifat dinamis, perubahan alamat IP dapat menyebabkan kegagalan koneksi. Untuk koneksi yang stabil, gunakan koneksi privat atau konfigurasikan blok CIDR publik yang cukup luas dalam daftar putih alamat IP.
Pastikan alamat IP publik perangkat lokal Anda yang benar telah ditambahkan ke daftar putih alamat IP RDS. Untuk troubleshooting, sementara tambahkan
0.0.0.0/0ke daftar putih alamat IP database. Jika Anda dapat mengakses database secara normal setelah perubahan ini, artinya daftar putih alamat IP tidak dikonfigurasi dengan benar.Anda dapat menggunakan metode berikut untuk mendapatkan alamat IP publik perangkat lokal Anda dan menambahkan alamat tersebut ke daftar putih alamat IP. Untuk informasi lebih lanjut, lihat Konfigurasikan daftar putih alamat IP untuk ApsaraDB RDS for MySQL, Konfigurasikan daftar putih alamat IP untuk ApsaraDB RDS for SQL Server, Konfigurasikan daftar putih alamat IP untuk ApsaraDB RDS for PostgreSQL, atau Konfigurasikan daftar putih alamat IP untuk ApsaraDB RDS for MariaDB.
Untuk informasi lebih lanjut, lihat topik berikut:
Akses lintas akun
Jika instance ECS dan instance RDS Anda berada di akun Alibaba Cloud yang berbeda, gunakan salah satu metode berikut untuk terhubung:
Metode 1 (disarankan): Gunakan koneksi peering VPC.
Metode 2: Gunakan peran RAM.
Metode 3: Instance ECS terhubung ke instance RDS menggunakan public endpoint instance RDS. Metode ini memberikan performa, keamanan, dan stabilitas yang buruk. Untuk informasi tentang cara mengajukan public endpoint, lihat Ajukan public endpoint untuk instance MySQL, Ajukan public endpoint untuk instance SQL Server, Ajukan public endpoint untuk instance PostgreSQL, atau Ajukan public endpoint untuk instance MariaDB.
Referensi
Berlaku untuk
ApsaraDB RDS