You can use CloudMonitor to monitor key metrics for Simple Log Service, such as write traffic, overall QPS, and service status, to track service usage. You can also create alert rules to detect exceptions in log collection and shard resource usage.
Prerequisites
An Alibaba Cloud account must grant the required permissions to a RAM user so they can view CloudMonitor metrics. To do this, attach the AliyunCloudMonitorReadOnlyAccess (read-only) or AliyunCloudMonitorFullAccess (read-write) policy to the RAM user. For instructions, see Create a RAM user and grant permissions.
View monitoring metrics
Log on to the Simple Log Service console.
In the Projects section, click the one you want.

-
On the tab, find the target Logstore and click in the column to the right.
-
View the monitoring metrics for Simple Log Service.
Metrics
|
Metric |
Description |
|
write traffic |
The real-time amount of data written to the Logstore per minute. |
|
raw data size |
The size of the original data written to the Logstore per minute, measured before compression. |
|
overall QPS |
The total queries per second (QPS) for all operations. |
|
number of operations |
The number of API requests made per minute. For more information, see API overview. |
|
service status |
The number of HTTP status codes returned in response to user operations. |
|
Successfully Parsed Traffic (Client-side) |
The size of raw log data successfully collected by Logtail. |
|
Successfully Parsed Lines (Client-side) |
The number of log lines successfully collected by Logtail. |
|
Parse Failure Lines (Client-side) |
The number of log lines that Logtail failed to collect. If this chart shows data, collection errors have occurred. |
|
Client-side Error Count |
The number of errors that occurred during log collection by Logtail. |
|
Number of Machines with Client-side Errors |
The number of machine instances where log collection errors occurred during log collection by Logtail. |
|
IPs with Errors |
The number of IP addresses where different types of log collection errors occurred. Based on the specific error, find the corresponding IP address. Then, log on to the machine and check the /usr/local/ilogtail/ilogtail.LOG file to analyze the cause of the error. |
|
write lines |
The number of lines written to the Logstore per minute. |
|
read traffic |
The real-time amount of data read from the Logstore per minute. |
|
consumer lag |
The time difference between the current consumption checkpoint and the time at which the latest data was written to the queue. In a consumer group, this value is the largest time difference among all its shards. |
Configure alert rules
You can use CloudMonitor to configure alert rules for Simple Log Service. When service status triggers an alert rule, CloudMonitor sends a notification by text message or email. You can configure alert rules for log monitoring to detect exceptions in log collection and shard resource usage.
Configure alert rules for cloud service resources. Cloud Monitor sends notifications when the specified conditions are met.
-
Log on to the Cloud Monitor console.
-
In the left-side navigation pane, choose .
-
On the Cloud Service Monitoring page, select a cloud service and configure alert rules for Metric Monitoring or Quota Monitoring.
-
Metric Monitoring: Click a cloud service to open its resource list.
-
Find the target resource and click Alert Rules in the Actions column.
-
On the Alert Rules page, click Create Alert Rule.
-
In the Create Alert Rule panel, configure the alert rule parameters.
-
Click Confirm.
-
-
Quota Monitoring: Click a cloud service to open its resource list. Set alert rules for resources under General Quotas or API Rate Limits.
-
Find the target resource and click Alert Rules in the Actions column, or click Global Alert Rule in the upper-right corner.
NoteGlobal Alert Rules: Alert rules that apply to all resource quotas of the target cloud service.
-
Click Create Alert Rule and configure the alert rule parameters.
-
Click OK.
-
NoteAlert rule parameters: Create an alert rule.
-
View alert rules
View all alert rules configured for a cloud service on its monitoring page.
-
Log on to the Cloud Monitor console.
-
In the left-side navigation pane, choose .
-
On the Cloud Service Monitoring page, click a cloud service to open its resource list. View alert rules for Metric Monitoring or Quota Monitoring.
-
Find the target instance and click Alert Rules in the Actions column.
> Monitor