This topic describes the problem that a Windows server can be pinged but cannot be connected to. This topic also describes the causes of and solutions to the problem.
Problem description
Your on-premises device can ping a Windows server but cannot connect to the Windows server.
Causes
The issue may occur due to one of the following reasons:
The password that you entered for the Windows server is invalid.
Remote Desktop Services is not enabled on the Windows server.
A firewall is blocking the remote connection. This could be either the firewall in the Simple Application Server console or the Windows Defender Firewall on the server itself.
Solutions
Select one of the following solutions based on the cause:
Solution 1: Check whether the password that you entered for the Windows server is valid
If an invalid password causes the connection failure, enter the valid password of the server. For more information, see Set or reset server passwords.
Solution 2: Check whether Remote Desktop Services is enabled on the Windows server
If Remote Desktop Services is not enabled, enable it. For more information, see Step 5: Check whether RDS is enabled for the instance.
Solution 3: Check firewall configurations
Check the Simple Application Server firewall: The default remote connection port of Windows servers is port 3389. Ensure this port is open in your server's firewall rules in the console. For more information, see Manage the firewall of a simple application server.
Check the Windows Defender Firewall:
Connect to the Windows server by using VNC from the Simple Application Server console. For more information, see the "Use VNC to connect to the server in the Simple Application Server console" section of Connect to a Windows server.
In the menu bar, choose Start > Control Panel.
In the All Control Panel Items window, select Small icons for View by, and click Windows Firewall.
On the Windows Firewall page, click Advanced settings.
Enable firewall configurations.
In the Windows Firewall with Advanced Security window, click Windows Firewall Properties.
Select On (recommended) and click Apply (A).
We recommend that you enable all firewalls on the Domain Profile, Private Profile, and Public Profile tabs.
On the Windows Firewall with Advanced Security page. In the left pane, click Inbound Rules. Find the rule named Remote Desktop-User Mode (TCP-In), right-click it, and select and select Enable Rule.
For more information, see FAQ about remote connection.