All Products
Search
Document Center

Data Transmission Service:Migrate PolarDB for MySQL to Kafka

Last Updated:Aug 27, 2026

Use DTS to migrate data from a PolarDB for MySQL cluster to a Kafka cluster to scale your message processing.

Prerequisites

  • A self-managed Kafka cluster or Message Queue for Apache Kafka instance is created as the destination.

    Note
    • If the destination is a Message Queue for Apache Kafka instance, ensure that a topic is created to receive the migrated data. Then, configure the instance as a self-managed Kafka cluster. For information about how to create a topic, see Step 1: Create a topic.

    • For supported source and destination versions, see migration solution overview.

  • The destination Kafka cluster has more storage space than the source PolarDB for MySQL cluster uses.

Limitations

Note

DTS does not migrate foreign keys. As a result, cascade operations such as cascade delete in the source database are not replicated in the destination database.

Type

Description

Source database limitations

  • The source database must have sufficient outbound bandwidth. Insufficient bandwidth slows the migration.

  • Tables to migrate must have a primary key or unique constraint with unique values. Otherwise, duplicate data may occur in the destination.

  • If you migrate objects at the table level and need edits such as column name mapping, a single task supports up to 1,000 tables. Exceeding this limit may cause a request error on submission. To migrate more than 1,000 tables, split them into multiple tasks or migrate the entire database.

  • Data migration from read-only nodes is not supported.

  • If you perform incremental migration:

    • You must enable binary logging and set the loose_polar_log_bin parameter to on. Otherwise, the precheck reports an error and the data migration task cannot start. For more information about how to enable binary logging and modify parameters, see Enable binary logging and Modify parameters.

      Note

      Enabling binary logging for a PolarDB for MySQL cluster consumes storage space and incurs storage fees.

    • The binary logs of the PolarDB for MySQL cluster must be retained for at least 3 days. We recommend a retention period of 7 days. Otherwise, DTS may fail to obtain the binary logs, which can cause the task to fail. In extreme cases, this can lead to data inconsistency or data loss. Issues caused by a binary log retention period shorter than the DTS requirement are not covered by the DTS Service-Level Agreement (SLA).

      Note

      For more information about how to set the retention period for binary logs of a PolarDB for MySQL cluster, see Modify the retention period.

  • During the schema migration and full migration phases, do not perform DDL operations that change the database or table schema. Otherwise, the data migration task will fail.

    Note

    During the full migration phase, DTS queries the source database. This creates a metadata lock, which may block DDL operations on the source database.

  • If you perform only a full data migration, do not write new data to the source database. Otherwise, data inconsistency will occur between the source and destination databases. To maintain real-time data consistency, select schema migration, full data migration, and incremental data migration.

Other limitations

  • DTS does not support the migration of read-only nodes of the source PolarDB for MySQL instance.

  • DTS does not support the migration of OSS external tables from the source PolarDB for MySQL instance.

  • DTS does not migrate the following database objects: indexes, partitions, views, stored procedures, functions, and triggers.

  • DTS does not support primary/standby switchover scenarios for the database instance during full data migration. In such a scenario, reconfigure the migration task promptly.

  • Do not use tools such as pt-online-schema-change to perform online DDL operations on the migration objects in the source database. Otherwise, the data migration task fails.

  • For columns of the FLOAT or DOUBLE data type, DTS reads values using the ROUND(COLUMN,PRECISION) function. If precision is not explicitly defined, DTS uses a default of 38 digits for FLOAT and 308 digits for DOUBLE. Ensure this meets your business requirements.

  • Evaluate the performance of the source and destination databases before starting migration. We recommend migrating during off-peak hours because full data migration increases the load on both databases.

  • DTS attempts to resume failed tasks within seven days. Before switching your workload to the destination instance, end or release the DTS instance. Alternatively, use the REVOKE command to revoke write permissions from the DTS account on the destination instance. This prevents the task from resuming and overwriting destination data.

  • If a task fails, DTS support staff will attempt to restore it within eight hours. During restoration, they may restart the task or adjust its parameters.

    Note

    Only DTS task parameters are modified—not database parameters. Parameters that may be adjusted include those listed in Modify instance parameters.

Other notes

  • DTS periodically runs the CREATE DATABASE IF NOT EXISTS test command on the source database to advance the binary log position.

  • During full data migration, concurrent INSERT operations cause table fragmentation in the destination database. Consequently, tables in the destination database use more storage space than those in the source instance.

Billing

Migration type

Instance configuration fee

Internet traffic fee

Schema migration and full data migration

Free of charge.

When the Access Method parameter of the destination database is set to Public IP Address, you are charged for Internet traffic. For more information, see Billing overview.

Incremental data migration

Charged. For more information, see Billing overview.

Migration types

  • Schema migration

    DTS migrates the schema definitions of the migration objects from the source database to the destination database.

  • Full migration

    DTS migrates all historical data of the specified migration objects from the source database to the destination database.

  • Incremental migration

    After a full migration is complete, DTS migrates incremental data updates from the source database to the destination database. Incremental migration lets you smoothly migrate data without interrupting your self-managed applications.

SQL operations for incremental migration

Type

SQL statement

DML

INSERT, UPDATE, and DELETE

DDL

CREATE TABLE, ALTER TABLE, DROP TABLE, RENAME TABLE, and TRUNCATE TABLE

Required permissions for database accounts

Database

Permission requirements

Actions

PolarDB for MySQL cluster

Read permission on objects to be migrated

Create and Manage a Database Account

Procedure

  1. Navigate to the migration task list page for the destination region using one of the following methods.

    From the DTS console

    1. Log on to the Data Transmission Service (DTS) console.

    2. In the navigation pane on the left, click Data Migration.

    3. In the upper-left corner of the page, select the region where the migration instance is located.

    From the DMS console

    Note

    The actual operations may vary based on the mode and layout of the DMS console. For more information, see Simple mode console and Customize the layout and style of the DMS console.

    1. Log on to the Data Management (DMS) console.

    2. In the top menu bar, choose Data + AI > Data Transmission (DTS) > Data Migration.

    3. To the right of Data Migration Tasks, select the region where the migration instance is located.

  2. Click Create Task to navigate to the task configuration page.

  3. Configure the source and destination databases.

    Section

    Parameter

    Description

    N/A

    Task Name

    DTS automatically generates a task name. We recommend that you specify a descriptive name for easy identification. The name does not need to be unique.

    Source Database

    Select Existing Connection

    • To use a database instance that has been added to the system (created or saved), select the desired database instance from the drop-down list. The database information below will be automatically configured.

      Note

      In the DMS console, this parameter is named Select a DMS database instance..

    • If you have not registered the database instance with the system, or do not need to use a registered instance, manually configure the database information below.

    Database Type

    Select PolarDB for MySQL.

    Access Method

    Select Alibaba Cloud Instance.

    Instance Region

    Select the region where the source PolarDB for MySQL cluster is located.

    Cross-account

    Select No to migrate data within the same Alibaba Cloud account.

    PolarDB Cluster ID

    Select the cluster ID of the source PolarDB for MySQL cluster.

    Database Account

    Enter the database account for the source PolarDB for MySQL cluster. For information about the required permissions, see Permissions required for database accounts.

    Database Password

    Enter the password for the database account.

    Encryption

    Select a connection type as needed. For more information about the SSL encryption feature, see Enable SSL encryption.

    Destination Database

    Select Existing Connection

    • To use a database instance that has been added to the system (created or saved), select the desired database instance from the drop-down list. The database information below will be automatically configured.

      Note

      In the DMS console, this parameter is named Select a DMS database instance..

    • If you have not registered the database instance with the system, or do not need to use a registered instance, manually configure the database information below.

    Database Type

    Select Kafka.

    Access Method

    Select a connection type based on where the destination instance is deployed. This example uses Self-managed Database on ECS.

    Note

    If the destination is a self-managed database, you must also complete additional prerequisites. For more information, see Preparation overview.

    Instance Region

    Select the region where the destination Kafka cluster is located.

    ECS Instance ID

    Select the ID of the ECS instance where the destination Kafka cluster is deployed.

    Port Number

    Enter the service port of the destination Kafka cluster. The default port is 9092.

    Database Account

    Enter the username for the Kafka cluster. Leave this blank if authentication is not enabled.

    Database Password

    Enter the password for the Kafka cluster username. Leave this blank if authentication is not enabled.

    Kafka Version

    Select the version of your Kafka cluster.

    Note

    If your self-managed Kafka cluster is version 1.0 or later, set Kafka Version to Later Than 1.0.

    Connection Method

    Select Non-encrypted or SCRAM-SHA-256 based on your business and security requirements.

    Topic

    Select the topic to receive data from the drop-down list.

    Use Kafka Schema Registry

    Kafka Schema Registry provides a RESTful interface for storing and retrieving Avro schemas.

    • No: Do not use Kafka Schema Registry.

    • Yes: Use Kafka Schema Registry. You must enter the URL or IP address where the Avro schema is registered in Kafka Schema Registry.

  4. After you complete the configuration, click Test Connectivity and Proceed at the bottom of the page.

    Note
    • Ensure that the IP address segment of the DTS service is automatically or manually added to the security settings of the source and destination databases to allow access from DTS servers. For more information, see Add DTS server IP addresses to a whitelist.

    • If the source or destination database is a self-managed database (the Access Method is not Alibaba Cloud Instance), you must also click Test Connectivity in the CIDR Blocks of DTS Servers dialog box that appears.

  5. Configure the task objects.

    1. On the Configure Objects page, configure the objects that you want to migrate.

      Parameter

      Description

      Migration Types

      • For a full data migration only, select both Schema Migration and Full Data Migration.

      • For a migration with minimal downtime, select Schema Migration, Full Data Migration, and Incremental Data Migration.

      Note
      • Schema Migration is not supported when the Access Method for the destination Kafka instance is set to Alibaba Cloud Instance.

      • If you do not select Schema Migration, ensure the destination database contains the necessary databases and tables to receive the data. You may also need to use the object name mapping feature in the Selected Objects box.

      • To ensure data consistency, if you do not select Incremental Data Migration, do not write new data to the source instance while the data migration is in progress.

      Processing Mode for Existing Destination Tables

      • Precheck and Report Errors: Checks whether tables with the same names exist in the destination database. If no tables with the same names exist, the precheck is passed. If tables with the same names exist, an error is reported during the precheck, and the data migration task does not start.

        Note

        If a table in the destination database has the same name but cannot be easily deleted or renamed, you can change the name of the table in the destination database. For more information, see Object name mapping.

      • Ignore Errors and Proceed: Skips the check for tables with the same names.

        Warning

        Selecting Ignore Errors and Proceed may cause data inconsistency and business risks. For example:

        • If the table schemas are consistent and a record in the destination database has the same primary key value as a record in the source database:

          • During full migration, DTS keeps the record in the destination database. The record from the source database is not migrated.

          • During incremental migration, DTS does not keep the record in the destination database. The record from the source database overwrites the record in the destination database.

        • If the table schemas are inconsistent, only some columns of data may be migrated, or the migration may fail. Proceed with caution.

      Data Format in Kafka

      Select the data format for storing data in the Kafka instance.

      Kafka Data Compression Format

      Select a compression format for Kafka messages based on your requirements.

      • LZ4 (default): low compression ratio, high compression speed.

      • GZIP: high compression ratio, low compression speed.

        Note

        High CPU consumption.

      • Snappy: medium compression ratio, medium compression speed.

      Policy for Shipping Data to Kafka Partitions

      Select a policy based on your business requirements.

      Message acknowledgement mechanism

      Select a message acknowledgment mechanism based on your business requirements.

      Topic That Stores DDL Information

      Select the topic for storing DDL information.

      Note

      If no topic is selected, DTS stores DDL information in the data topic by default.

      Case Policy for Destination Object Names

      Configure the case sensitivity for migrated database, table, and column names in the destination instance. By default, DTS default policy is selected. You can also choose a policy consistent with the source or destination database. For more information, see Case sensitivity of object names in the destination instance.

      Source Objects

      Select one or more objects from the Source Objects section. Click the Rightwards arrow icon and add the objects to the Selected Objects section.

      Note

      You can select objects to migrate at the table level.

      Selected Objects

      Use the mapping feature to set the topic name, number of partitions, and partition key for each source table in the destination Kafka instance. For more information, see Map information.

      Note
      • If you use the object name mapping feature, other objects that depend on the mapped object may fail to migrate.

      • To select the SQL operations for incremental migration, right-click a migration object in the Selected Objects box and select the desired SQL operations from the dialog box that appears.

    2. Click Next: Advanced Settings to configure advanced parameters.

      Parameter

      Description

      Dedicated Cluster for Task Scheduling

      By default, DTS schedules tasks on a shared cluster. You do not need to select one. If you want more stable tasks, you can purchase a dedicated cluster to run DTS migration tasks.

      Retry Time for Failed Connections

      After the migration task starts, if the connection to the source or destination database fails, DTS reports an error and immediately begins to retry the connection. The default retry duration is 720 minutes. You can customize the retry time to a value from 10 to 1440 minutes. We recommend that you set the duration to more than 30 minutes. If DTS reconnects to the source and destination databases within the specified duration, the migration task automatically resumes. Otherwise, the task fails.

      Note
      • For multiple DTS instances that share the same source or destination, the network retry time is determined by the setting of the last created task.

      • Because you are charged for the task during the connection retry period, we recommend that you customize the retry time based on your business needs, or release the DTS instance as soon as possible after the source and destination database instances are released.

      Retry Time for Other Issues

      After the migration task starts, if a non-connectivity issue, such as a DDL or DML execution exception, occurs in the source or destination database, DTS reports an error and immediately begins to retry the operation. The default retry duration is 10 minutes. You can customize the retry time to a value from 1 to 1440 minutes. We recommend that you set the duration to more than 10 minutes. If the related operations succeed within the specified retry duration, the migration task automatically resumes. Otherwise, the task fails.

      Important

      The value of Retry Time for Other Issues must be less than the value of Retry Time for Failed Connections.

      Enable Throttling for Full Data Migration

      During full migration, DTS consumes read and write resources on the source and destination databases, which may increase the database load. If required, you can enable throttling for the full migration task. You can set Queries per second (QPS) to the source database, RPS of Full Data Migration, and Data migration speed for full migration (MB/s) to reduce the load on the destination database.

      Note
      • This configuration item is available only if you select Full Data Migration for Migration Types.

      • You can also adjust the full migration speed after the migration instance is running.

      Enable Throttling for Incremental Data Migration

      If required, you can also choose to set speed limits for the incremental migration task. You can set RPS of Incremental Data Migration and Data migration speed for incremental migration (MB/s) to reduce the load on the destination database.

      Note
      • This configuration item is available only if you select Incremental Data Migration for Migration Types.

      • You can also adjust the incremental migration speed after the migration instance is running.

      Whether to delete SQL operations on heartbeat tables of forward and reverse tasks

      Choose whether DTS writes heartbeat SQL information to the source database while the instance is running.

      • Yes: Does not write heartbeat SQL information to the source database. The DTS instance may display latency.

      • No: Writes heartbeat SQL information to the source database. This may interfere with source database operations like physical backups and cloning.

      Environment Tag

      Select an environment tag to identify the instance. This parameter is optional.

      Configure ETL

      Based on your business needs, select whether to configure the ETL feature to process data.

      • Yes: Configures the ETL feature. You must also enter data processing statements in the text box.

      • No: Does not configure the ETL feature.

      Monitoring and Alerting

      Select whether to set alerts and receive alert notifications based on your business needs.

      • No: Does not set an alert.

      • Yes: Configure alerts by setting an alert threshold and an alert notifications. If a migration fails or the latency exceeds the threshold, the system sends an alert notification.

  6. Save the task and run a precheck.

    • To view the parameters for configuring this instance when you call the API operation, move the pointer over the Next: Save Task Settings and Precheck button and click Preview OpenAPI parameters in the bubble that appears.

    • If you do not need to view or have finished viewing the API parameters, click Next: Save Task Settings and Precheck at the bottom of the page.

    Note
    • Before the migration task starts, DTS performs a precheck. The task starts only after it passes the precheck.

    • If the precheck fails, click View Details next to the failed check item, fix the issue based on the prompt, and then run the precheck again.

    • If a warning is reported during the precheck:

      • For check items that cannot be ignored, click View Details next to the failed item, fix the issue based on the prompt, and then run the precheck again.

      • For check items that can be ignored, you can click Confirm Alert Details, Ignore, OK, and Precheck Again to skip the alert item and run the precheck again. If you choose to ignore a warning, it may cause issues such as data inconsistency and pose risks to your business.

  7. Purchase the instance.

    1. When the Success Rate is 100%, click Next: Purchase Instance.

    2. On the Purchase page, select the link specification for the data migration instance. For more information, see the following table.

      Category

      Parameter

      Description

      New Instance Class

      Resource Group Settings

      Select the resource group to which the instance belongs. The default value is default resource group. For more information, see What is Resource Management?

      Instance Class

      DTS provides migration specifications with different performance levels. The link specification affects the migration speed. You can select a specification based on your business scenario. For more information, see Data migration link specifications.

    3. After the configuration is complete, read and select Data Transmission Service (Pay-as-you-go) Service Terms.

    4. Click Buy and Start. In the OK dialog box that appears, click OK.

      You can view the progress of the migration task on the Data Migration Tasks list page.

      Note
      • If the migration task does not include incremental migration, it stops automatically after the full migration is complete. After the task stops, its Status changes to Completed.

      • If the migration task includes incremental migration, it does not stop automatically. The incremental migration task continues to run. While the incremental migration task is running, the Status of the task is Running.

Mapping information

  1. In the Selected Objects area, hover over the destination topic name at the table level.

  2. Click Edit next to the destination topic name.

  3. In the Edit Table dialog box, configure the mapping information.

    Note
    • The dialog box is named Edit Schema at the database level and Edit Table at the table level. The Edit Schema dialog box has fewer parameters.

    • If you do not migrate the entire database, you cannot modify the Name of target Topic and Number of Partitions parameters in the Edit Schema dialog box.

    Parameter

    Description

    Name of target Topic

    The name of the topic that receives data from the source table. This defaults to the Topic you selected in the Destination Database section during the Configurations for Source and Destination Databases step.

    Important
    • If the destination is a Message Queue for Apache Kafka instance, the specified topic must already exist in the destination instance. Otherwise, the data migration task fails. If the destination is a self-hosted Kafka database and the data migration task includes database and table structure migration, DTS attempts to create the specified topic in the destination database.

    • If you change the Name of target Topic, DTS writes data to the specified topic.

    Filter Conditions

    For more information, see Configure filter conditions.

    Number of Partitions

    The number of partitions in the destination topic.

    Partition Key

    Available when Policy for Shipping Data to Kafka Partitions is set to Ship Data to Separate Partitions Based on Hash Values of Primary Keys. Specify one or more columns as the partition key. DTS calculates a hash value for the specified columns and distributes rows across partitions in the destination topic.

    Note

    You can select Partition Key only in the Edit Table dialog box.

  4. Click OK.