Diagnostique e resolva falhas de inicialização, problemas de login, erros de rede e gargalos de desempenho em instâncias do ECS com Linux e Windows.
Problemas no sistema operacional Linux
Falhas de inicialização
-
Verifique se o arquivo fstab lista todos os dispositivos de bloco da instância.
Um dispositivo de bloco não listado em
/etc/fstabpode impedir a reinicialização do sistema. Consulte Como remover um dispositivo de bloco que não existe no arquivo /etc/fstab de uma instância Linux? -
Confira se os dispositivos de bloco no arquivo fstab estão montados corretamente.
Um dispositivo de bloco mal montado pode impedir a reinicialização do sistema. Consulte Uma instância Linux tem um disco que não está montado corretamente.
-
Valide o formato do arquivo fstab.
Um formato inválido em
/etc/fstabpode impedir a reinicialização do sistema. Consulte Como corrigir um erro de formato no arquivo de configuração /etc/fstab de uma instância Linux? -
Execute o comando fsck para verificar os arquivos do sistema.
Um sistema de arquivos danificado pode impedir a inicialização da instância. Consulte Verificar e reparar os sistemas de arquivos em uma instância Linux.
Falhas de login
-
Verifique se o arquivo de configuração de limites está correto.
Se o valor
nofileem/etc/security/limits.confexcedernr_open, as conexões à instância podem falhar. Consulte Resolver falhas de conexão remota ou erros "Too many open files" em uma instância Linux. -
Confira se a senha da conta root existe no arquivo /etc/shadow.
A ausência da senha root em /etc/shadow impede o login. Consulte O usuário principal do sistema não existe na instância Linux.
-
Verifique o formato dos arquivos críticos do sistema.
Um arquivo de sistema fora do formato UNIX pode impedir o login. Consulte Como modificar o formato Unix de uma instância Linux?
-
Confira se as permissões de acesso SSH estão configuradas corretamente.
Permissões SSH incorretas bloqueiam o login. Consulte Permissões SSH incorretas bloqueiam a conexão remota a uma instância Linux.
-
Verifique se os arquivos e diretórios críticos do SSH existem.
Arquivos SSH ausentes (como o arquivo de configuração
sshd_config) podem impedir o login. Consulte Verificar arquivos SSH obrigatórios em uma instância Linux. -
Confira se o tamanho das huge pages configuradas excede o intervalo permitido.
Uma configuração de huge page muito grande pode impedir o login. Ajuste o valor em
/etc/sysctl.conf. Consulte Como ajustar Huge Pages em uma instância Linux. -
Verifique se o sistema operacional está sem memória.
Condições de falta de memória podem impedir o login. Consulte Solucionar problemas de falta de memória (Out of Memory) em uma instância Linux.
-
Confira se o firewall do sistema está ativado.
Regras de firewall que bloqueiam o acesso externo podem impedir conexões. Consulte Gerenciar o firewall do sistema no Linux.
-
Verifique se o TCP SACK está ativado.
O TCP SACK desativado degrada o desempenho da rede. Consulte Ativar TCP SACK em instâncias Linux.
-
Confira se há estouro do buffer UDP.
O estouro do buffer UDP degrada o desempenho da rede e pode impedir o login. Consulte Estouro de cache UDP em instância Linux causa falha de conexão remota.
-
Verifique se o Security-Enhanced Linux (SELinux) está ativado.
O SELinux ativado pode causar erros de conexão SSH. Consulte A conexão SSH falha quando o SELinux está ativado em uma instância Linux.
-
Tanto o login via SSH quanto via VNC falham.
Desanexe o disco do sistema, anexe-o como disco de dados a outra instância e faça login na nova instância. Consulte Desanexar o disco do sistema de uma instância Linux e anexar o disco a outra instância.
-
A conexão SSH retorna um erro.
O SSH como root retorna
Permission denied, please try again. Consulte Resolver o erro "Permission denied, please try again" em conexões SSH a uma instância Linux.
Falhas de acesso
-
Verifique os parâmetros do kernel relacionados ao NAT.
Parâmetros do kernel NAT mal configurados podem bloquear o acesso SSH e HTTP pela rede privada. Consulte Falha ao acessar a instância através de um NAT Linux devido a problemas de configuração do kernel.
-
Confira se os processos de serviço estão em execução e se as portas estão ouvindo.
Um processo de serviço parado causa falhas de acesso. Consulte Como iniciar serviços comuns de uma instância Linux e consultar o status da porta de escuta.
Falhas de conexão de rede
-
Verifique as configurações do Dynamic Host Configuration Protocol (DHCP).
As instâncias do ECS usam DHCP para atribuir endereços IP às ENIs. Um arquivo de configuração de ENI incorreto ou um processo dhclient parado pode interromper o DHCP e desconectar a instância. Consulte Verificar e corrigir configurações DHCP para interfaces de rede locais em instâncias Linux.
-
Confira se existe um processo relacionado à rede.
Sem um processo de rede, as concessões DHCP não podem ser renovadas, desconectando a instância. Consulte O processo de rede Linux não existe.
-
Verifique se o multi-queue da controladora de interface de rede (NIC) está ativado.
O multi-queue da NIC distribui as interrupções da NIC entre as vCPUs, evitando gargalos em uma única vCPU. Consulte Multi-queue da NIC.
Problemas de desempenho (Linux)
-
Verifique se há estouro do buffer de backlog TCP.
O estouro do buffer de backlog TCP degrada o desempenho da rede e pode impedir o login. Consulte Estouro de cache de backlog TCP em instância Linux causado por falha ao conectar remotamente à instância.
-
Confira se a utilização da CPU excede o intervalo normal.
Alta utilização da CPU afeta a estabilidade do sistema. Consulte Solucionar alta utilização ou carga da CPU em uma instância Linux.
-
Falhas de gravação em disco.
Expanda a capacidade do disco online conforme as necessidades de armazenamento aumentam. Consulte Etapa 1: Redimensionar um disco para expandir a capacidade do disco ou Redimensionar discos offline para instâncias Linux.
Problemas no sistema operacional Windows
Falhas de login
-
Verifique as NICs da instância.
NICs indisponíveis impedem o login. Consulte A controladora de interface de rede de uma instância Windows não está disponível.
-
Confira se a porta 3389 está ativada.
Os Serviços de Área de Trabalho Remota devem estar ativados para conexões de área de trabalho remota. Consulte Como ativar os Serviços de Área de Trabalho Remota em uma instância do ECS com Windows?
-
Verifique a versão do driver virtio.
Um driver virtio desatualizado pode impedir o login. Consulte Atualizar o driver virtio para uma instância Windows.
-
Confira se o firewall está configurado corretamente.
Configurações incorretas do firewall podem impedir o login. Consulte Configurar regras de firewall para Windows.
Problemas de desempenho (Windows)
-
Verifique se a utilização da CPU excede o intervalo normal.
Alta utilização da CPU afeta a estabilidade do sistema. Consulte Solucionar alta utilização da CPU em instâncias Windows.
-
Confira a versão do sistema operacional Windows.
A Microsoft encerrou o suporte para o Windows Server 2008 e 2008 R2 em 14 de janeiro de 2020. A Alibaba Cloud não fornece mais suporte técnico para instâncias do ECS que executam esses sistemas operacionais. Atualize para o Windows Server 2012 ou posterior. Para imagens compatíveis, consulte Imagens públicas.
-
Verifique a capacidade do disco.
A redução do espaço livre na unidade C pode causar instabilidade do sistema. Consulte Solucionar diminuição do espaço em disco na Unidade C de uma instância Windows.