既存データを新しいインスタンス (クローンインスタンス) に復元します。
操作説明
サポートされているエンジン
ApsaraDB RDS for MySQL
ApsaraDB RDS for PostgreSQL
ApsaraDB RDS for SQL Server
ApsaraDB RDS for MariaDB
関連サイト
今すぐお試しください
テスト
RAM 認証
|
アクション |
アクセスレベル |
リソースタイプ |
条件キー |
依存アクション |
|
rds:CloneDBInstance |
create |
DBInstance
|
|
なし |
リクエストパラメーター
|
パラメーター |
型 |
必須 / 任意 |
説明 |
例 |
| ClientToken |
string |
任意 |
リクエストのべき等性を確保するために使用されるクライアントトークン。クライアントを使用してトークンを生成できますが、異なるリクエスト間でトークンが一意であることを確認する必要があります。トークンには ASCII 文字のみを使用でき、長さは 64 文字を超えることはできません。 |
0c593ea1-3bea-11e9-b96b-88********** |
| RegionId |
string |
任意 |
リージョン ID。DescribeRegions 操作を呼び出して、最新のリージョンリストを照会できます。 |
cn-hangzhou |
| ZoneId |
string |
任意 |
プライマリゾーンの ID。DescribeRegions 操作を呼び出して、ゾーン ID を照会できます。 説明
デフォルト値: ソースインスタンスのゾーン。 |
cn-hangzhou-b |
| DBInstanceClass |
string |
任意 |
インスタンスタイプ。インスタンスタイプのフォーマットについては、「インスタンスタイプ」を参照してください。 説明
デフォルト値: ソースインスタンスのインスタンスタイプ。 |
mysql.n1.micro.1 |
| DBInstanceStorage |
integer |
任意 |
インスタンスストレージ容量。単位: GB。値は 5 GB 刻みで増加します。インスタンスタイプのフォーマットについては、「インスタンスタイプ」を参照してください。 説明
デフォルト値: ソースインスタンスのインスタンスストレージ容量。 |
1000 |
| DBInstanceDescription |
string |
任意 |
インスタンスの名前。名前の長さは 2~255 文字である必要があります。先頭は英字または漢字とし、数字、漢字、英字、アンダースコア (_)、ハイフン (-) を含めることができます。 説明
名前の先頭を http:// または https:// にすることはできません。 |
testInstance |
| DbNames |
string |
任意 |
次のフォーマットのデータベース名: |
test1,test2 |
| PayType |
string |
必須 |
課金方法。有効な値:
|
Postpaid |
| InstanceNetworkType |
string |
任意 |
インスタンスのネットワークタイプ。有効な値:
説明
デフォルト値: ソースインスタンスのネットワークタイプ。 |
VPC |
| DBInstanceId |
string |
必須 |
インスタンスの ID。 |
rm-uf6wjk5**** |
| BackupId |
string |
任意 |
バックアップセットの ID。 DescribeBackups 操作を呼び出して、バックアップセットリストを照会できます。 説明
BackupId と RestoreTime の少なくとも一方を指定する必要があります。 |
902**** |
| RestoreTime |
string |
任意 |
バックアップ保持期間内の任意の時間ポイント。時間は yyyy-MM-ddTHH:mm:ssZ (協定世界時 (UTC)) フォーマットで指定します。 説明
BackupId と RestoreTime の少なくとも一方を指定する必要があります。 |
2011-06-11T16:00:00Z |
| VPCId |
string |
任意 |
VPC の ID。 説明
VPC が対応するリージョンに属していることを確認してください。 |
vpc-uf6f7l4fg90**** |
| VSwitchId |
string |
任意 |
vSwitch の ID。vSwitch のゾーンは、ZoneId で指定されたプライマリゾーン ID に対応している必要があります。
|
vsw-uf6adz52c2p**** |
| PrivateIpAddress |
string |
任意 |
新しいインスタンスの内部 IP アドレス。IP アドレスは、指定された vSwitch の IP アドレス範囲内である必要があります。システムは、VPCId と VSwitchId の値に基づいて内部 IP アドレスを自動的に割り当てます。 |
172.XX.XX.69 |
| UsedTime |
integer |
任意 |
サブスクリプション期間。有効な値:
説明
PayType が Prepaid に設定されている場合、このパラメーターは必須です。 |
1 |
| Period |
string |
任意 |
サブスクリプション期間の単位。有効な値:
説明
PayType が Prepaid に設定されている場合、このパラメーターは必須です。 |
Year |
| Category |
string |
任意 |
インスタンスエディション。有効な値:
サーバーレスインスタンス
説明
このパラメーターを指定する必要はありません。クローンインスタンスは、ソースインスタンスと同じエディションを使用します。 |
HighAvailability |
| ZoneIdSlave1 |
string |
任意 |
セカンダリノードのゾーン ID。このパラメーターが ZoneId と同じ値に設定されている場合、シングルゾーンデプロイメントが使用されます。このパラメーターが ZoneId と異なる値に設定されている場合、マルチゾーンデプロイメントが使用されます。 |
cn-hangzhou-c |
| ZoneIdSlave2 |
string |
任意 |
ロガーノードのゾーン ID。このパラメーターが ZoneId と同じ値に設定されている場合、シングルゾーンデプロイメントが使用されます。このパラメーターが ZoneId と異なる値に設定されている場合、マルチゾーンデプロイメントが使用されます。 |
cn-hangzhou-d |
| DBInstanceStorageType |
string |
任意 |
インスタンスストレージタイプ。有効な値:
説明
Serverless インスタンスでは、PL1 ESSD と高性能 ESSD のみがサポートされています。 |
general_essd |
| RestoreTable |
string |
任意 |
個別のデータベースとテーブルを復元するかどうかを指定します。個別のデータベースとテーブルを復元するには、このパラメーターを true に設定します。それ以外の場合は、このパラメーターを空のままにします。 |
true |
| TableMeta |
string |
任意 |
復元するデータベースとテーブルの情報。フォーマット:
|
[{"type":"db","name":"testdb1","newname":"testdb1_new","tables":[{"type":"table","name":"testdb1table1","newname":"testdb1table1_new"}]}] |
| DedicatedHostGroupId |
string |
任意 |
専用クラスターの ID。 |
dhg-7a9**** |
| BackupType |
string |
任意 |
バックアップタイプ。有効な値:
|
FullBackup |
| DeletionProtection |
boolean |
任意 |
リリース保護特徴を有効にするかどうかを指定します。有効な値:
|
true |
| IoAccelerationEnabled |
string |
任意 |
サーバーレス構成。データをサーバーレスインスタンスにクローンする場合にのみ、このパラメーターを指定します。 説明
このパラメーターは、中国サイト (aliyun.com) でのみサポートされています。 |
0 |
| BurstingEnabled |
boolean |
任意 |
非推奨のパラメーター。このパラメーターを設定する必要はありません。 |
0 |
| AutoPay |
boolean |
任意 |
高性能 ESSD クラウドディスクのバッファープール拡張 (BPE) 特徴を有効にするかどうかを指定します。有効な値:
説明
BPE 特徴のフォーマットについては、「バッファープール拡張 (BPE)」を参照してください。 |
0 |
| CustomExtraInfo |
string |
任意 |
高性能 ESSD クラウドディスクの I/O バースト特徴を有効にするかどうかを指定します。有効な値:
説明
I/O バースト特徴のフォーマットについては、「高性能 ESSD とは」を参照してください。 |
false |
レスポンスフィールド
|
フィールド |
型 |
説明 |
例 |
|
object |
レスポンス要素。 |
||
| DBInstanceId |
string |
インスタンスの ID。 |
rm-uf6wjk5**** |
| OrderId |
string |
注文の ID。 |
100789370**** |
| RequestId |
string |
リクエストの ID。 |
1E43AAE0-BEE8-43DA-860D-EAF2**** |
例
成功レスポンス
JSONJSON
{
"DBInstanceId": "rm-uf6wjk5****",
"OrderId": "100789370****",
"RequestId": "1E43AAE0-BEE8-43DA-860D-EAF2****"
}
エラーコード
|
HTTP ステータスコード |
エラーコード |
エラーメッセージ |
説明 |
|---|---|---|---|
| 400 | InvalidAvZone.Format | Specified AvZone is not valid. | 指定されたアベイラビリティゾーンが無効です。このパラメーターが有効かどうかを確認してください。 |
| 400 | InvalidAvZone.NotSupport | Specified availableArea multiZone does not support in RDS. | 指定されたマルチゾーンのエリアは、ApsaraDB RDS ではサポートされていません。 |
| 400 | CannotDecreaseEssdPerfLevel | cannot decrease cloud essd performance level. | クラウドディスクの仕様ではスペックダウン操作がサポートされていないため、操作が失敗しました。 |
| 400 | InvalidIPAddress.Conflict | IP address conflict. | IP アドレスの競合が発生しました。 |
| 400 | CDDC.AvailableHostsNotEnoughInZone | Not enough available hosts are in the target zone. | 送信先ゾーンに十分なホストリソースがありません。そのゾーンにホストを作成してください。 |
| 400 | InvalidInstanceLevel.DiskType | Specified instance level not support request disk type | 現在のインスタンスタイプでは、このストレージタイプはサポートされていません。 |
| 400 | InvalidRecoveryDbInstance.StorageType | The disk local_ssd can not clone to cloud disk type | ローカルディスクをクラウドディスクにクローンすることはできません。 |
| 400 | InvalidRecoveryDbInstance.StorageSize | The disk space of the new instance cannot be less than that of the current instance | 操作に失敗しました。新しいインスタンスのディスク領域を現在のインスタンスのディスク領域より小さくすることはできません。 |
| 400 | InvalidDBInstanceClass.Offline | The specified instance type is no longer provided. Please specify another instance type. | 選択されたインスタンスタイプは廃止されました。別のインスタンスタイプを指定してください。 |
| 400 | InvalidTunnelId | Specified conn tunnel is not valid. | 指定された接続チャンネルは無効です。 |
| 400 | ZoneId.NotMatchWithCategory | The number of available zones does not match the database engine or instance edition. Please reset it. | ゾーン数がデータベースタイプまたはインスタンスエディションと一致しません。設定を再構成してください。 |
| 400 | UnsupportExtendDisk.NotSupport | Specified DB instance is unsupport extend disk. | 指定されたインスタンスでは、ディスクの拡張はサポートされていません。 |
| 400 | Order.ComboInstanceNotAllowOperate | A package instance is not allowed to operate independently. | パッケージ内のインスタンスは個別に操作できません。 |
| 400 | Price.PricingPlanResultNotFound | Pricing plan price result not found. | 料金プランの結果が見つかりませんでした。 |
| 400 | Order.NoRealNameAuthentication | You have not passed the real-name authentication and do not meet the purchase conditions. Please log in to the user center for real-name authentication. | 実名認証が完了していないため、購入する資格がありません。実名認証を完了するには、費用とコストにログインしてください。 |
| 400 | InsufficientAvailableQuota | Your account quota limit is less than 0, please recharge before trying to purchase. | アカウント残高が 0 未満です。購入を試みる前にアカウントに入金してください。 |
| 400 | CommodityServiceCalling.Exception | Failed to call commodity service. | 商品サービスの呼び出しに失敗しました。 |
| 400 | RegionDissolvedEOM | Dear customer, Alibaba Cloud plans to optimize and adjust the current region. Cloud services in this region will cease operations. You are currently unable to operate new purchase orders. Thank you for your understanding and support. | Alibaba Cloud は現在のリージョンの最適化と調整を計画しており、このリージョンのクラウドサービスの操作は停止されます。業務継続性とスムーズなデータ移行を確保するため、現時点では新しい購入注文を行うことはできません。ご理解とサポートのほどよろしくお願いいたします。 |
| 400 | Commodity.InvalidComponent | The module you purchased is not legal, please buy it again. | 購入したモジュールは無効です。モジュールを再度購入してください。 |
| 400 | RegionEndTimeDissolvedAustralia | Cloud services in the Australia (Sydney) region will be discontinued. Set the validity date to September 30, 2024 or earlier than September 30, 2024. | 指定されたリージョンは廃止されています。 |
| 400 | Price.CommoditySys | Commodity system call exception. | 商品システムの呼び出し時に例外が発生しました。 |
| 400 | Pay.InsufficientBalance | Insufficient available balance. | |
| 400 | Order.PeriodInvalid | There is a problem with the period you selected, please choose again. | 選択したサブスクリプション期間が無効です。別のサブスクリプション期間を選択してください。 |
| 400 | pay.noCreditCard | Account not bound to credit card. | アカウントにクレジットカードが関連付けられていません。 |
| 400 | Order.InstHasUnpaidOrder | There is an unpaid order for the service you have purchased. Please pay or void it before placing the order. | 選択したサービスに未払いの注文が存在します。新しい注文を行う前に、既存の注文の支払いを行うか、キャンセルしてください。 |
| 400 | noAvailablePaymentMethod | No payment method is specified for your account. We recommend that you add a payment method. | アカウントに支払方法が指定されていません。支払方法を追加してください。 |
| 400 | BasicInfoUncompleted | Your information is incomplete. Complete your information before the operation. | 情報が不完全です。続行する前に情報の入力を完了してください。 |
| 400 | Risk.RiskControlRejection | Your account is abnormal, please contact customer service for details. | アカウントに異常があります。詳細については、カスタマーサービスにお問い合わせください。 |
| 400 | Api.NotSupport | Specified api is not supported. | 現在の操作はサポートされていません。 |
| 400 | ContainForbiddenLabelError | There is a label that prohibits placing orders. Please contact your distributor for assistance. | 注文をブロックするタグが存在します。この問題を解決するには、販売代理店にお問い合わせください。 |
| 400 | InvalidDBInstanceId.NotFound | The DBInstanceId provided does not exist in records. | 指定されたインスタンスは存在しません。インスタンスが存在し、削除されていないことを確認してください。 |
| 400 | InvalidParam | Sepcified wal level Parameter is invalid. There are still logical slots in instance, so it can not be set as replica. | 操作に失敗しました。パラメーターが無効です。 |
| 400 | KmsApiError | User secret key invalid. | ユーザーキーが無効です。 |
| 400 | System.SaleValidateFailed | Sales expression validation system error. | |
| 400 | Abs.InvalidAccount.NotFound | account is not found. | アカウントが存在しません。 |
| 400 | SqlExecuteFailedOrTimeout | sql command execution failed or timed out:%s. | SQL コマンドの実行に失敗したか、タイムアウトしました。 |
| 400 | ColdData.EngineVersionNotSupport | The current instance engine version not support coldDataEnabled. | 現在のインスタンスの DPI エンジンバージョンでは、コールドデータアーカイブはサポートされていません。 |
| 400 | ColdData.MinorVersionNotSupport | The current instance minor version not support coldDataEnabled. | 現在のカーネルバージョンでは、コールドデータアーカイブはサポートされていません。 |
| 400 | IncorrectTargetClasscode | The current instance type does not support this operation. | 現在のインスタンスタイプではこの操作はサポートされていません。 |
| 400 | InvalidConnectionString.Duplicate | Specified connection string already exists in the RDS. | エンドポイント名が重複しています。別の接続文字列を指定してください。 |
| 400 | RequiredParam.NotFound | Required input param is not found. | 必須パラメーターが不足しています。 |
| 400 | Parameters.Invalid | Parameter error, please check the parameters. | パラメーターが有効ではありません。パラメーターを確認してください。 |
| 400 | BackupPolicyNotSupport | Cold Data won't open with CrossBackup or Flash Backup, please check Backup Policy. | コールドデータアーカイブは、クロスリージョンバックアップまたは高頻度スナップショットバックアップをサポートしていません。バックアップポリシーを確認してください。 |
| 400 | InvalideStatus.Format | The instance status does not support this operation. | 現在のインスタンスステータスでは、この操作は実行できません。 |
| 400 | InvalidReleasedKeepPolicy.Format | Specified Released Keep Policy is not valid. | インスタンスリリース後のアーカイブ済みバックアップデータの保持ポリシーが有効ではありません。 |
| 400 | InvalidDBInstanceEngineType.Format | the DB instance engine type does not support this operation. | インスタンスのデータベースエンジンタイプでは、この操作はサポートされていません。 |
| 400 | Pay.NoCreditCard | No credit cards. | |
| 400 | VpcNetworkTypeNotSupport | The vpc network type instance does not support this operation. | VPC ネットワークタイプのインスタンスでは、この操作はサポートされていません。 |
| 400 | MirrorInsExists | Specified DB instance mirror ins already existed. | データベースインスタンスのイメージはすでに存在します。 |
| 400 | UnsupportedClassCode | The specified DB instance class stops selling. | 指定されたインスタンスタイプは購入できなくなりました。 |
| 400 | InvalidBackupSet | The specified database does not exist in the backup set. | 指定されたデータベースがバックアップセットに存在しません。 |
| 400 | OrdTCommodityQueryError | Failed to query for product. | プロダクトのクエリに失敗しました。 |
| 400 | ProductInstanceReleased | The instance has been released. Please check before placing the order. | インスタンスはリリース済みです。注文前にインスタンスを確認してください。 |
| 400 | RegionEndTimeDissolvedIndia | The region is no longer supported. | 指定されたリージョンは廃止されています。 |
| 400 | StopService.Clone | The service has been discontinued and cloning operations on classic network instances are no longer permitted. | クラシックネットワークは廃止され、サービス停止時間を超過しました。クラシックネットワークタイプのインスタンスのクローン作成は許可されていません。 |
| 400 | InvalidParam.UsedTime | The clone expiration date cannot exceed %s. | PayType パラメーターが Prepaid に設定されている場合、usedTime パラメーターは有効である必要があります。 |
| 400 | MinorVersionTag.NotFound | Minor version tags cannot be parsed by the instance. | |
| 400 | InvalidBakset.Invalid | Specified bakset is not valid. | 指定されたバックアップセットでは、この操作はサポートされていません。 |
| 400 | InvalidParamForXfs | Xfs instance must be single tenant standard instance. | Xfs インスタンスは、専用高可用性インスタンスである必要があります。 |
| 400 | AtLeastThreeVSwitchAvailableIp | The primary vswitch requires at least three available IP addresses. | プライマリ vSwitch には、少なくとも 3 つの利用可能な IP アドレスが必要です。 |
| 400 | AtLeastTwoVSwitchAvailableIp | The primary vswitch requires at least two available IP addresses. | プライマリ vSwitch には、少なくとも 2 つの利用可能な IP アドレスが必要です。 |
| 400 | DiskSize.NotEnough | The disk size is not enough to restore tables. | 残りのディスク領域が不足しています。 |
| 500 | ExternalFailure | The request processing has failed due to external service failure. | リクエストが失敗しました。後でもう一度お試しください。 |
| 500 | RequestMetaDataFailed | The service request failed. Please try again later or contact service personnel. | リクエストが失敗しました。後でもう一度試すか、テクニカルサポートにお問い合わせください。 |
| 500 | InvokeProxyFailure | The request processing has failed due to service failure of rds api. | RDS API サービスの障害により、リクエストは失敗しました。 |
| 403 | IncorrectMinorVersion | Current engine minor version does not support operations. | 現在のエンジンのマイナーバージョンでは、この操作はサポートされていません。 |
| 403 | IncorrectCharacterType | Current DB instance character type does not support this operation. | 現在のインスタンスの文字タイプではこの操作はサポートされていません。 |
| 403 | CloudDiskEncryptionNotSupport | The encryption key is not allowed for general-purpose instance. | 汎用インスタンスでは、クラウドディスク暗号化はサポートされていません。 |
| 403 | OrderStatus.UnPaid | The specified db instance has unpaid order. | インスタンスに未払いの注文があります。注文の支払いを完了してから、もう一度お試しください。 |
| 403 | InvalidReduceDiskSize | The storage capacity after the scale-down must be larger than the used amount. | スケールダウンのターゲット容量は、現在のストレージ使用量未満に設定できません。 |
| 403 | CloudSSDNotSupport | Cloud ssd does not support this operation, please upgrade to essd. | SSD クラウドディスクではこの操作はサポートされていません。ESSD にアップグレードしてください。 |
| 403 | InvalidUserOperatorPermission | The user permission does not support this operation. | ユーザー権限が不足しているため、この操作はサポートされていません。 |
| 403 | InvalidVswitchId | Specified conn vswitch id is not valid. | 指定された VSwitchId の形式が無効か、または空です。 |
| 403 | OperationDenied.ZoneResource | There is no available zone for inventory. | 利用可能なゾーンに在庫がありません。 |
| 403 | NotInFlowController | Sorry,no permission. | この操作はエンタープライズユーザー以外では利用できません。必須の権限がありません。 |
| 403 | InvalidKmsKey | Kms key is disabled. | KMS キーが無効化されています。 |
| 403 | InvalidInstanceLevel.Malformed | Current DB instance level does not support this operation. | 操作に失敗しました。指定された仕様コードでは、指定されたエンドポイント数がサポートされていません。シャード数と現在のエンドポイント数を確認してください。 |
| 403 | InvalidMeta.TooLarge | Meta information is too large. | メタデータが大きすぎます。インスタンス内のテーブル数が 50,000 を超えていないか確認してください。 |
| 404 | InvalidDBInstance.NotFound | The specified instance does not exist or is not supported. | 指定されたインスタンスが存在しないか、この操作がサポートされていません。 |
| 404 | InvalidClusterKms | The current instance does not authorized to access the Key Management Service. | 現在のインスタンスには、Key Management サービスへのアクセスが許可されていません。 |
| 404 | Request.NotFound | The requested resource is not available. | リクエストされたリソースは利用できません。 |
| 404 | HostInfo.NotFound | The specified host info is not found. | 指定されたホスト情報が存在しません。 |
完全なリストについては、「エラーコード」をご参照ください。
変更履歴
完全なリストについては、「変更履歴」をご参照ください。