すべてのプロダクト
Search
ドキュメントセンター

PolarDB:PolarDB for MySQL 5.7 release notes

最終更新日:Sep 15, 2026

このトピックでは、PolarDB for MySQL 5.7 のアップデートと機能について説明します。

5.7.1.0.42.1 & 5.7.1.0.42.2 & 5.7.1.0.42.3

カテゴリ

説明

リリース日

新機能

スタンバイのネットワーク遅延に基づいてセミ同期を動的に有効または無効にする適応型セミ同期機能を追加し、innodb_polar_wait_slave_reply_* パラメーターと Innodb_polar_repl_* ステータス変数を提供します。

  • 5.7.1.0.42.1:2026-08-14

  • 5.7.1.0.42.2:2026-08-16

  • 5.7.1.0.42.3:2026-09-12

5.7.1.0.42

カテゴリ

説明

リリース日

バグ修正

MySQL Community Edition の起動時に purge binlog を実行すると Previous_gtid エラーが発生する問題を修正しました。

2026-08-04

InnoDB における buffer pool のオンライン resize 中に、古い page_hash オブジェクトへの同時アクセスが原因で mysqld がクラッシュする可能性がある不具合を修正しました。

LOAD DATA の失敗後にセッション状態が異常になり、後続の有効な INSERT ステートメントが失敗する問題を修正しました。

5.7.1.0.41 & 5.7.1.0.41.1 & 5.7.1.0.41.2 & 5.7.1.0.41.3

カテゴリ

説明

リリース日

新機能

PolarDB で圧縮テーブルを作成するためのポリシーを制御する polar_compressed_table_policy パラメーターを追加しました。

  • 5.7.1.0.41:2026-05-09

  • 5.7.1.0.41.1:2026-06-28

  • 5.7.1.0.41.2:2026-06-29

  • 5.7.1.0.41.3:2026-07-25

バグ修正

高い書き込み負荷の下で B ツリーインデックス構造の調整中に、読み取り専用ノードが特定のレコードのクエリに失敗することがある問題を修正しました。この問題は、新しい innodb_polar_replica_skip_supremum パラメーターを有効にすることで解決されます。

パラメーターを有効にした後に同時バッファープールのサイズ変更操作が実行された場合、innodb_adaptive_hash_index パラメーターが有効にならないことがある問題を修正しました。

5.7.1.0.40 & 5.7.1.0.40.1

カテゴリ

説明

リリース日

バグ修正

1 KB を超える非常に長い SQL ステートメントのアウトラインを追加する際に発生する問題を修正しました。SQL テンプレートが切り捨てられ、後続のマッチングに影響がありました。安定した実行計画を確保するため、システムは現在、このような describe の追加をブロックし、エラーを返します。これにより、潜在的なサイレント障害を防ぎます。このような SQL ステートメントのアウトラインを作成する必要がある場合は、max_digest_length パラメーターを対象の SQL テキストの長さの 1.2 倍以上の値に設定してください。

  • 5.7.1.0.40:2025-11-27

  • 5.7.1.0.40.1:2026-07-02

5.7.1.0.39

カテゴリ

説明

リリース日

新機能とパフォーマンスの最適化

  • DDL プロセス中にバルクロードの redo ログを圧縮する機能を追加しました。

  • BLOB データの redo ログの圧縮をサポートしました。

  • DDL テーブル再構築中の BLOB データの書き込みパフォーマンスを最適化しました。

2025-08-25

バグ修正

  • 高い書き込み負荷の下でゼロフィル拡張によってトリガーされた高可用性 (HA) フェールオーバーがクラスターのクラッシュを引き起こす問題を修正しました。

  • SELECT ... FOR UPDATE ステートメントを実行するために LOCK TABLES 権限が必要だった問題を修正しました。

  • トランザクションのロールバック中にバックグラウンドのパージプロセスがセカンダリインデックスの破損を引き起こす稀な問題を修正しました。

5.7.1.0.38

カテゴリ

説明

リリース日

バグ修正

  • REDUNDANT 行フォーマットを使用し、インスタントカラム追加が有効になっているテーブルで NULL 値を空の文字列に更新すると、クラスターがクラッシュする問題を修正しました。

  • 仮想カラムを持つテーブルでオンライン DDL 操作を実行する際の ROW LOG での稀な範囲外読み取り/書き込みの問題を修正しました。

  • 5.7 の本番クラスターを再起動しても memory profile を有効にできなかった問題を修正しました。

  • グローバル整合性 (高性能モード) に関連する変数の設定を最適化しました。スコープがシステムレベルから接続レベルに変更され、データベースプロキシでこの機能を有効にするかどうかを設定できるようになりました。

  • DDL プロセス中に読み取り専用ノードが指定されたファイルを開くときに見つけられない場合にクラスターがクラッシュする問題を修正しました。

  • 読み取り専用ノードが Show Binlog Events を実行したときに「ファイルが見つかりません」というエラーが発生する問題を修正しました。

  • 仮想カラムに作成されたセカンダリインデックスでインデックスが破損する可能性がある問題を修正しました。

  • loose_innodb_initialize_in_space_extend パラメーターを 0 に設定できなかったために、データベースとテーブルの拡張機能とファイルスペース拡張機能に互換性がなかった問題を修正しました。

  • 値を 0 に設定せずにスペース拡張機能を使用すると、データベースとテーブルの復元プロセスが中断される可能性がある問題を修正しました。

  • 最適化された BLOB 書き込みプロセスが異常終了した後、IMPORT TABLESPACE を使用してデータを回復できない問題を修正しました。

2025-06-20

5.7.1.0.37

カテゴリ

説明

リリース日

新機能とパフォーマンスの最適化

SM4 アルゴリズムを使用してフィールドレベルのアクセス暗号化を実装するために、sm4_encrypt() および sm4_decrypt() 関数を追加しました。

2025-01-13

バグ修正

  • システム変数の互換性の問題を修正しました。optimizer_switch などの flagset 変数を設定する際に重複した項目が存在してもエラーは報告されません。

  • Innodb_flush_log_at_trx_commit=0 の場合に redo ログ同期が遅くなり、SCC 整合性タイムアウトを引き起こす可能性がある問題を修正しました。

  • 同期オフセットが失われたために、セカンダリノードがインデックス構造の逆検索中にクラッシュする稀な問題を修正しました。

  • 非アトミック DDL プロセス中にクラッシュが発生し、クラスターが起動できなくなる問題を修正しました。

  • 以前のコミュニティバージョンで、複数テーブルの UPDATE ステートメントの JOIN ORDER が正しく最適化されていなかった問題を修正しました。

5.7.1.0.36

カテゴリ

説明

リリース日

新機能とパフォーマンスの最適化

  • 読み取り専用ノードでのカスタム一時テーブルの作成をサポートしました。MEMORY および MyISAM エンジンのみがサポートされています。

  • インスタントカラム追加機能を最適化し、パーティションテーブルにカラムを即座に追加できるようになりました。

  • バッファープールのスケールアウトプロセスを最適化し、ユーザースレッドとのロック競合を減らしてスケールアウト体験を向上させました。

2024-11-28

バグ修正

  • プロキシでの高度なトランザクション分割と高速クエリキャッシュとの間の競合が結果セットに影響を与える問題を修正しました。

  • 新しいデータベースとテーブルの復元フローで、同じテーブルで複数回の復元を行った後にプロセスが中断される問題を修正しました。

  • 読み取り専用 (RO) ノードで CHECK TABLE を実行するとクラスターがクラッシュする可能性がある問題を修正しました。

  • 並列 DDL 実行中のタイムウィンドウ内で innodb_bulk_load_page_grained_redo_enable パラメーターを変更すると、一部のページで不正な redo 書き込みが発生する稀な問題を修正しました。

  • 読み取り専用ノードが読み取り/書き込みノードに切り替わった後、INSERT ... ON DUPLICATE KEY UPDATE ステートメントが実行されたときにテーブルの自動増分値がロールバックされる問題を修正しました。

  • パフォーマンスを向上させ、デッドロックを防ぐために、DML ステートメントに対してデフォルトで index merge intersection アクセスパスを無効にすることで問題を修正しました。

5.7.1.0.35

カテゴリ

説明

リリース日

新機能とパフォーマンスの最適化

  • PolarDB 5.6 から PolarDB 5.7 への物理移行をサポートしました。

  • TDE (透過的データ暗号化) が有効になった後、新しいテーブルに TDE 暗号化を適用する機能を追加しました。

  • 詳細なデータ変更追跡を追加して、グローバル整合性 (高性能モード) のパフォーマンスを向上させました。

  • 読み取り専用ノードでのユーザー定義のインメモリ一時テーブルをサポートしました。現在、MEMORY および MyISAM エンジンのみがサポートされています。

  • 読み取り専用変数 max_digest_length を動的に設定可能に最適化しました。

  • シミュレート AIO のパフォーマンスを最適化しました。

  • アウトラインライブラリを最適化し、各実行で空のアウトラインライブラリ名を許可するようにしました。

  • PolarDB IO スレッドを再起動なしで動的に調整できるように最適化しました。

2024-08-30

バグ修正

  • 動的なバッファープールのスケールイン中のロック競合の問題を修正しました。

  • blob データ型のパージの事前読み取りに関連する問題を修正しました。

  • HA フェールオーバー後にパーティションテーブルの自動増分値がロールバックされる問題を修正しました。

  • 大きな JSON シリアル化のパフォーマンス問題を修正しました。

  • JSON の浮動小数点数の精度が不十分である問題を修正しました。

  • 不要な一意キー (UK) 制約に起因するレコードロックによるデッドロックの問題を修正しました。

  • バッファープールがいっぱいの場合に、読み取り専用ノードのユーザースレッドが空きページを待機しすぎる問題を修正しました。

  • テーブル内のすべてのデータが削除された後、自動増分値が 0 にロールバックされる可能性がある問題を修正しました。

5.7.1.0.34

カテゴリ

説明

リリース日

新機能とパフォーマンスの最適化

  • DDL 同期中のメタデータロック (MDL) の取得失敗を解決するために、プリエンプティブル DDL 機能を追加しました。

  • PolarFileSystem のスレッド優先度を最適化し、トランザクションリクエストのタイムリーな処理を保証し、PolarDB for MySQL の DDL パフォーマンスを向上させました。

  • PolarFileSystem の読み取り専用ノードでのページ読み取りパフォーマンスを最適化しました。

2024-07-01

バグ修正

  • 接続数が 65,536 を超えると MDL システムが異常になる問題を修正しました。

5.7.1.0.33

カテゴリ

説明

リリース日

新機能とパフォーマンスの最適化

  • 読み取り専用ノードでのメタデータロック (MDL) 同期失敗のエラーメッセージを改善しました。

  • polar_only_allow_discard_with_admin パラメーターを追加しました。有効にすると、このパラメーターはユーザーが DISCARD 操作を実行するのを禁止します。デフォルト値は ON です。必要に応じて設定できます。

  • 高速クエリキャッシュを強化し、返された行数に関する情報を含めるようにしました。キャッシュヒットしたクエリの場合、返された行数を監査ログに表示できます。

2024-05-27

バグ修正

  • システムの O&M アクセスが `slow_queries` ステータスメトリックに影響を与える問題を修正しました。

  • SET_VAR hint を使用して loose_optimizer_switch を設定する際に末尾のカンマが必要だった問題を修正しました。

5.7.1.0.32

カテゴリ

説明

リリース日

新機能とパフォーマンスの最適化

  • グローバルトランザクション ID (GTID) 機能が有効になった後、トランザクション内で一時テーブルを作成および削除するサポートを追加しました。

  • グローバル整合性 (高性能モード) で変数設定ヒント構文を使用するサポートを追加しました。

  • バイナリロギングのマルチスレッド同時書き込みが有効な場合のスレッドプールのパフォーマンスを最適化しました。

2024-03-27

バグ修正

  • fork を使用して子プロセスが作成されたときの TDE (透過的データ暗号化) と RDMA メモリの間の互換性の問題を修正しました。

  • バッファープールのスケールイン操作中に、大きなユーザー SQL ステートメントが長時間にわたって多くのページを占有したために、後続のスケールアウト要求がブロックされる問題を修正しました。

  • 自動増分値のロールバックから回復するためにノードの再起動が必要だった問題を修正しました。

  • 並列 DDL シナリオでの DDL 先読みのデッドロックの問題を修正しました。

  • パーティションテーブルでパーティションを変更する DDL ステートメントが実行された後、新しい INSERT 要求で「autoinc duplicate key」エラーが発生する問題を修正しました。

5.7.1.0.31

カテゴリ

説明

リリース日

新機能とパフォーマンスの最適化

低同時実行シナリオでスレッドプールが接続要求を処理する速度を改善しました。

2024-01-31

バグ修正

  • 論理的事前読み取り機能を使用するとノードがクラッシュする可能性がある問題を修正しました。

  • 論理的事前読み取り機能を使用する際のメモリリークの問題を修正しました。

  • 新しいデータベースとテーブルの復元フローで、ディスクがいっぱいになったためにスレッドが終了できない問題を修正しました。

  • 新しいデータベースとテーブルの復元フローで、RO ノードの登録オフセットが低すぎたために新しい読み取り専用 (RO) ノードの追加に失敗する問題を修正しました。

5.7.1.0.30.1

カテゴリ

説明

リリース日

バグ修正

  • autoinc_persist が有効な場合に高可用性 (HA) フェールオーバー後に自動増分値がロールバックされる問題を修正しました。

  • 読み取り/書き込みノードとスタンバイ (または読み取り専用) ノード間で HA フェールオーバーが繰り返された後、自動増分値がロールバックされる問題を修正しました。

  • 読み取り/書き込みノードで Degrade 操作が実行された後、スタンバイノードが物理レプリケーション再接続メカニズムを失う問題を修正しました。

2023-12-11

5.7.1.0.30

カテゴリ

説明

リリース日

新機能とパフォーマンスの最適化

  • データベースとテーブルの復元機能を最適化しました。機能強化には、復元速度の向上とタスク失敗のロールバックのサポートが含まれます。

  • fil_space_extend から不要なエラーログを削除することで、ログ出力機能を最適化しました。

2023-11-23

バグ修正

  • 読み取り専用 (RO) ノードの物理サーバに障害が発生した場合に、特殊なケースで読み取り/書き込み (RW) ノードがレプリケーション関係を終了しなかったために、RW ノードでのダーティページフラッシュがブロックされる問題を修正しました。

  • 高可用性 (HA) フェールオーバー後、テーブル数が多すぎることによるテーブルキャッシュのエビクションが原因で、自動増分値がロールバックされる問題を修正しました。

  • RDS for MySQL から PolarDB for MySQL へのワンクリックアップグレード中に PolarDB クラスターが再起動したため、移行リンクが中断される問題を修正しました。

  • undo トランケートプロセス中の異常なチェックポイントの問題を修正しました。

  • 読み取り専用ノードが起動時に読み取り/書き込みノードに接続するために polarfs dir fast scan インターフェイスを使用しなかった問題を修正しました。

5.7.1.0.29

カテゴリ

説明

リリース日

バグ修正

  • 論理的事前読み取りのクロスページ操作と分割マージ操作 (SMO) のマージ操作との間の競合によって引き起こされるデッドロックの問題を修正しました。

  • InnoDB ストレージエンジンの一時テーブルをフラッシュできない問題を修正しました。

  • スキーマとテーブルを指定せずにキーワードのみを指定した同じ SQL ステートメントタイプの最後の CCL ルールを削除すると、ノードがクラッシュする可能性がある問題を修正しました。

2023-09-14

5.7.1.0.28.4

カテゴリ

説明

リリース日

バグ修正

ダーティページレベルが低いときにページクリーナースレッドがダーティページをフラッシュしすぎたために書き込みパフォーマンスが低下する問題を修正しました。

2023-08-28

5.7.1.0.28.2

カテゴリ

説明

リリース日

バグ修正

監査ログを有効にした後、ローカルディスクへの過度の圧力により SQL 遅延が増加する問題を修正しました。

2023-08-02

5.7.1.0.28

カテゴリ

説明

リリース日

新機能とパフォーマンスの最適化

  • innodb_polar_import_tablespace_strict_mode パラメーターを追加しました。デフォルト値は ON で、データベースとテーブルの復元操作を実行する際にテーブルスキーマにフルテキストインデックスが含まれている場合にエラーが報告されることを意味します。

  • 現在の接続要求が強力な整合性を必要とするかどうかを制御するために、セッションレベルの innodb_polar_scc パラメーターを追加しました。グローバル整合性 (高性能モード) が有効で、現在の接続で innodb_polar_scc=true の場合、グローバル整合性が有効になります。

2023-07-23

バグ修正

  • 一般ユーザーが performance_schema データベースを削除できる問題を修正しました。

  • チェックポイント LSN が期待どおりに進まない問題を修正しました。

  • 読み取り/書き込み (RW) ノードで ALTER TABLE ... IMPORT TABLESPACE 操作が実行されている間に、読み取り専用 (RO) ノードでクエリを実行するとエラーが発生する可能性がある問題を修正しました。

  • プライマリノードがシャットダウンして再起動されたときに、セカンダリノードが再接続メカニズムをトリガーしない問題を修正しました。

  • group_concat_max_len パラメーターが大きな値に設定されている場合に、算術オーバーフローにより GROUP_CONCAT 関数が不正な結果を返す問題を修正しました。

  • PolarTrans が動的に有効になった後の高同時実行範囲更新シナリオでの mutex ロック競合の問題を修正しました。

  • 読み取り/書き込み (RW) ノードで undo ログリサイクルメカニズムがトリガーされた後、RO ノードを介してデータベースに接続してデータを読み取ると、読み取り専用 (RO) ノードがクラッシュする問題を修正しました。

5.7.1.0.27.2

カテゴリ

説明

リリース日

バグ修正

スロークエリログの同時記録中に、スレッドプール内の異常な内部カウンターが原因で SQL 要求が積み重なる問題を修正しました。

2023-06-14

5.7.1.0.27

カテゴリ

説明

リリース日

新機能とパフォーマンスの最適化

  • DDL および LOCK TABLE ステートメントをシステムテーブルに記録するサポートを追加しました。

  • スレッドプール機能を CCL と互換性を持たせました。スレッドプール機能が有効になった後、ユーザー接続が CCL によってブロックされた場合、接続はスレッドプール内でマークされます。その後、スレッドプールは他の接続で SQL ステートメントを実行するために追加のスレッドを作成します。

  • ステートメントアウトラインを使用する際、指定されたインデックスヒントが存在しない場合、エラーではなく警告のみが報告されるようになりました。

  • show full tables from db_name like table_name を最適化しました。

  • クエリ中のタイムアウト数を記録するために、グローバル整合性 (高性能モード) の Innodb_scc_timeout_count パラメーターを追加しました。

  • クエリがタイムアウトし、非同期クエリに切り替えられた回数を記録するために、グローバル整合性 (高性能モード) の Innodb_scc_timeout_degrade_count パラメーターを追加しました。

  • アウトラインが存在しない場合にステートメント実行のダイジェストハッシュ計算をスキップすることで、ステートメントアウトラインの使用プロセスを最適化しました。

  • 一時テーブルの切り捨て効率を改善しました。

  • 読み取り専用ノードでの GTID 情報のクエリをサポートしました。

  • PolarFS の内部ロックの粒度を最適化し、一部の高負荷シナリオでのパフォーマンスを大幅に向上させました。

2023-05-08

バグ修正

  • イベントが作成された後に削除できない問題を修正しました。

  • 読み取り専用ノードで物理レプリケーションが確立されたときに、読み取りタイムアウトのためにデータベース接続を確立できない問題を修正しました。

  • undo ログを切り捨てられない問題を修正しました。

  • 読み取り専用ノードがワイドテーブルの redo ログを適用する際に発生するレプリケーションの遅延の問題を修正しました。

5.7.1.0.26.2

カテゴリ

説明

リリース日

バグ修正

  • グローバル整合性 (高性能モード) を有効にすると、ホットレプリカが予期せずクラッシュする可能性がある問題を修正しました。

  • 読み取り/書き込みノードが再起動された後、PolarTrans ログが適切に回収されない問題を修正しました。

2023-03-25

5.7.1.0.26

カテゴリ

説明

リリース日

バグ修正

  • プライマリノードとセカンダリノード間のフェールオーバー後、CREATE TABLE ステートメントの AUTO_INCREMENT 値が失われる問題を修正しました。

  • my.cnf ファイルの innodb_buffer_pool_in_core_file パラメーターがクラスター起動時に有効にならなかった問題を修正しました。

  • 大きなメモリ仕様のインスタンスで TDE (透過的データ暗号化) プラグインの通信が遅くなる問題を修正しました。

2023-02-27

5.7.1.0.25

カテゴリ

説明

リリース日

新機能とパフォーマンスの最適化

  • dbms_ccl.add_ccl_digest_ruledbms_outln.add_index_outline、および dbms_outln.add_optimizer_outline 組み込みストアドプロシージャのクエリパラメーターで、SQL ステートメントの末尾のセミコロンを無視するようになりました。

  • ステートメントアウトラインがすべての UNION 句をサポートするようになりました。

  • 読み取り/書き込みノードの物理サーバに障害が発生した場合の接続問題を防止するために、物理レプリケーション接続に関連するタイムアウトパラメーターを調整しました。

  • スレッドプールの最適化:

    • thread_pool_high_priority_users パラメーターを使用して、優先度の高いユーザーのリストを設定できます。スレッドプールがスレッドを割り当てるとき、優先度の高いユーザーのリクエストを優先します。

    • バイパスメカニズムを追加しました。bypass_thread_pool_ips パラメーターを使用して特権接続を設定できます。bypass_thread_pool_ips の IP アドレスからユーザーがデータベースに接続すると、接続はスレッドプールをバイパスできます。

    • スロークエリタイムアウト処理メカニズムを追加しました。スレッドプールは、スレッドの総数を計算する際に、スロークエリ状態のスレッド数を無視します。これにより、スレッドの総数がスロークエリスレッド数によって制限されなくなります。

2023-01-06

バグ修正

長時間トランザクションのシナリオでデータベースパフォーマンスが低下する可能性がある問題を修正しました。

5.7.1.0.24

カテゴリ

説明

リリース日

新機能とパフォーマンスの最適化

  • クエリ中のタイムアウト数を記録するために、グローバル整合性 (高性能モード) の Innodb_scc_timeout_count パラメーターを追加しました。

  • クエリがタイムアウトし、非同期クエリに切り替えられた回数を記録するために、グローバル整合性 (高性能モード) の Innodb_scc_timeout_degrade_count パラメーターを追加しました。

2022-11-11

バグ修正

  • 読み取り/書き込みノードの物理レプリケーションモジュールが余分なメモリを消費する問題を修正しました。

  • 特殊なシナリオで undo ログをパージできない問題を修正しました。

  • 特殊なシナリオでコントロールのヘルスチェックが失敗する問題を修正し、高同時実行シナリオでのシステムの安定性を向上させました。

5.7.1.0.23.3

カテゴリ

説明

リリース日

バグ修正

ファイル名のハッシュ競合によって引き起こされる読み取り専用ノードのクラッシュの問題を修正しました。

2022-09-17

5.7.1.0.23

カテゴリ

説明

リリース日

新機能とパフォーマンスの最適化

  • グローバル整合性 (高性能モード) 機能を追加しました。この機能を有効にすると、PolarDB の読み取り専用ノードが強力な整合性の読み取りサービスを提供できます。詳細については、「概要」をご参照ください。

  • DDL 先読み機能を最適化し、インデックス作成の効率を向上させました。

  • DDL ソートを最適化しました。双方向マージを多方向マージに置き換え、I/O 操作を削減し、DDL インデックス追加のパフォーマンスを向上させました。

  • 高同時実行性下でのスレッドプールのパフォーマンスを改善しました。

2022-08-30

バグ修正

データベースの削除がスローログに記録されない問題を修正しました。

5.7.1.0.22

カテゴリ

説明

リリース日

新機能とパフォーマンスの最適化

インデックス作成の効率を向上させるために、DDL 先読み機能のサポートを追加しました。

2022-06-17

バグ修正

  • インデックスによるテーブルアクセスへのコストを考慮していなかった、順序付けインデックスパスの選択を最適化しました。

  • バッファープールにダーティページが多すぎてフラッシュが遅い場合に、LRU リストのクリーンアップがブロックされ、ページが解放されない問題を修正しました。

5.7.1.0.21

カテゴリ

説明

リリース日

新機能とパフォーマンスの最適化

プライマリノードとセカンダリノード間の物理レプリケーションでミリ秒レベルの遅延をサポートしました。

2022-05-20

バグ修正

  • クラスターの負荷が低い場合の過剰な物理レプリケーションの遅延の問題を修正しました。

  • 順序付けインデックスの選択を最適化し、インデックス条件を使用でき、かつ順序付けを提供できるインデックスパスを優先するようにしました。

  • 一部の GROUP BY ステートメントでオプティマイザーがより良いインデックス範囲パスを選択しなかった問題を修正しました。

  • 読み取り専用ノードが読み取り/書き込みノードに登録されたときにチェックポイントがトリガーされなかった問題を修正しました。

5.7.1.0.20

カテゴリ

説明

リリース日

新機能とパフォーマンスの最適化

SQL 解析において、OFCOMMIT_ON_SUCCESSROLLBACK_ON_FAIL、および TARGET_AFFECT_ROW を予約キーワードから非予約キーワードに変更しました。

2022-04-07

5.7.1.0.17

カテゴリ

説明

リリース日

新機能とパフォーマンスの最適化

  • ホット行最適化機能のサポートを追加しました。詳細については、「ホット行の最適化」をご参照ください。

  • 高可用性の効率をさらに向上させるために、ホットレプリカ機能のサポートを追加しました。

2022-01-14

5.7.1.0.16

カテゴリ

説明

リリース日

バグ修正

手動でチェックポイントをトリガーするポリシーを最適化しました。

2021-12-14

5.7.1.0.15

カテゴリ

説明

リリース日

新機能とパフォーマンスの最適化

高速クエリキャッシュ機能を追加しました。詳細については、「高速クエリキャッシュ」をご参照ください。

2021-11-17

5.7.1.0.14

カテゴリ

説明

リリース日

バグ修正

  • ユーザーがビューのマージを強制するかどうかを制御できるオプティマイザヒントを提供しました。詳細については、MySQL の公式ドキュメントをご参照ください。

  • SELECT FOR UPDATE WAIT N 構文のサポートを追加しました。N は秒単位のタイムアウト期間を示し、単一の行ロックにのみ適用されます。クエリが複数の行をロックする必要がある場合、システムは複数の行の時間を累積せず、単一の行のタイムアウトのみをチェックします。待機時間が N 秒を超えると、システムはロック待機タイムアウトエラーを返します:Lock wait timeout exceeded; try restarting transaction

2021-10-19

5.7.1.0.13

カテゴリ

説明

リリース日

新機能とパフォーマンスの最適化

GDN のセカンダリクラスターの読み取り専用ノードは、alter polar to slave コマンドを使用してプライマリノードに切り替えることができます。これにより、セカンダリクラスターの高可用性が実現します。

2021-09-10

5.7.1.0.12

カテゴリ

説明

リリース日

新機能とパフォーマンスの最適化

  • GDN 内のプライマリクラスターと同期ノード間の複数の接続をサポートし、物理レプリケーションのスループットを向上させました。

  • 読み取り専用ノードからバイナリログを取得するサポートを追加しました。詳細については、「PolarDB for MySQL のバイナリログをリモートで取得して解析する」をご参照ください。

2021-08-27

バグ修正

  • ステートメント同時実行制御で指定されたデータベースとテーブルのルールが一致しない問題を修正しました。

  • 読み取り専用ノードとセカンダリクラスターでの redo ログの適用を高速化し、プライマリノードの同期効率を向上させました。

5.7.1.0.11

カテゴリ

説明

リリース日

新機能とパフォーマンスの最適化

polar_replica_work_on_nonblock_mdl_mode パラメーターを追加しました。このパラメーターを有効にすると、読み取り専用ノードの RU/RC 分離レベルでの未コミットのトランザクションがプライマリノードの DDL 操作をブロックしなくなります。この場合、読み取り専用ノードではテーブル定義のトランザクションプロパティが保証されなくなります。

2021-07-08

5.7.1.0.10

カテゴリ

説明

リリース日

新機能とパフォーマンスの最適化

MySQL 8.0 との互換性のために SELECT FOR UPDATE/SHARE SKIP LOCKED/NOWAIT 構文のサポートを追加しました。詳細については、MySQL 8.0 をご参照ください。

2021-06-15

バグ修正

読み取り専用ノードで InnoDB 一時テーブルデータをディスクにフラッシュするサポートを追加しました。

5.7.1.0.9

カテゴリ

説明

リリース日

バグ修正

  • 複数テーブルのシナリオでストレージエンジンのクイック起動をサポートしました。

  • 仮想カラムに対する UPDATE 操作をロールバックすることによって引き起こされるデータベースクラッシュの問題を修正しました。

2021-05-13

5.7.1.0.8

カテゴリ

説明

リリース日

新機能とパフォーマンスの最適化

読み取り専用ノードがレプリケーション関係を確立したときに、プライマリノードでチェックポイントポリシーを即座に実行するかどうかを指定します。

2021-04-19

バグ修正

  • KICKOUT を非予約キーワードに変更しました。

  • プライマリ/セカンダリフェールオーバー後、TDE 暗号化テーブルの暗号化情報が失われ、復号に失敗する可能性がある問題を修正しました。

5.7.1.0.7

カテゴリ

説明

リリース日

新機能とパフォーマンスの最適化

  • DDL パフォーマンスを向上させるために並列 DDL 機能を追加しました。詳細については、「並列 DDL」をご参照ください。

  • バッファープールをコアファイルから削除するために innodb_buffer_pool_in_core_file パラメーターを追加しました。

  • オプティマイザーがクエリを処理する際に指定されたインデックスを使用または無視できるようにする、インデックスヒントに次のキーワードのサポートを追加しました:

    • GROUP_INDEX または NO_GROUP_INDEX:GROUP BY 操作を伴うインデックススキャンに指定されたインデックスを使用または無視します。

    • INDEX または NO_INDEX:サーバーに指定されたインデックスの使用または無視を強制します。

    • JOIN_INDEX または NO_JOIN_INDEX:MySQL に任意のアクセス方法で指定されたインデックスの使用または無視を強制します。

  • オプティマイザーが適切なテーブル結合順序を選択できるようにする、結合順序ヒントに次のキーワードのサポートを追加しました:

    • JOIN_FIXED_ORDER:オプティマイザーに FROM 句に表示される順序でテーブルを結合させます。

    • JOIN_ORDER:オプティマイザーに指定された順序でテーブルを結合させます。このヒントは名前付きテーブルに適用されます。オプティマイザーは、指定されたテーブルの間を含め、名前のないテーブルを結合順序のどこにでも配置できます。

    • JOIN_PREFIX:オプティマイザーに結合実行計画の最初のいくつかのテーブルに対して指定された順序でテーブルを結合させます。このヒントは名前付きテーブルに適用されます。オプティマイザーは、他のすべてのテーブルを名前付きテーブルの後に配置します。

    • JOIN_SUFFIX:オプティマイザーに結合実行計画の最後のいくつかのテーブルに対して指定された順序でテーブルを結合させます。このヒントは名前付きテーブルに適用されます。オプティマイザーは、他のすべてのテーブルを名前付きテーブルの前に配置します。

2021-03-10

バグ修正

  • トークン番号比較テーブルをパーティション分割し、いくつかのトークンを予約して、新しいトークンが挿入された後に同じステートメントのダイジェストハッシュ値が不整合になる問題を修正しました。

  • アップグレード/ダウングレードプロセス中に読み取り専用ノードがプライマリノードに登録できなかったことによるアップグレード/ダウングレードの失敗を修正しました。

  • session_track_temporary_tables システム変数が有効な場合に、ストアドプロシージャで一時テーブルを作成または削除するとクラスターが異常終了する問題を修正しました。

5.7.1.0.6.3

カテゴリ

説明

リリース日

バグ修正

一部のシナリオで SHOW PROCESSLIST の結果が正しくない問題を修正しました。

2021-02-22

5.7.1.0.6.2

カテゴリ

説明

リリース日

バグ修正

読み取り専用ノードでインデックスマージ最適化を使用したクエリを実行すると、エラーコード 1032 (Can't find record in TABLE) が稀に発生する問題を修正しました。

2021-02-10

5.7.1.0.6.1

カテゴリ

説明

リリース日

バグ修正

  • 読み取り/書き込みノードでの異常なダーティページフラッシュの問題を修正しました。

  • プライマリ/セカンダリフェールオーバーを経験したクラスターでプライマリゾーンを変更できない問題を修正しました。

  • SHOW PROCESSLIST を実行する際に Thread Descriptor (THD) への不正な呼び出しによって引き起こされるデータベースクラッシュの問題を修正しました。

2021-02-02

5.7.1.0.6

カテゴリ

説明

リリース日

新機能とパフォーマンスの最適化

  • ステートメントキュー機能のサポートを追加しました。詳細については、「ステートメントキュー」をご参照ください。

  • Instant add column 機能のサポートを追加しました。詳細については、「テーブルの末尾にカラムを即座に追加する」をご参照ください。

  • Returning 機能のサポートを追加しました。詳細については、「Returning」をご参照ください。

  • innodb_adaptive_hash_index パラメーターのデフォルト値が ON から OFF に変更されました。

2021-01-29

バグ修正

PolarDB カーネルバージョンをアップグレードする際にシステムテーブルが失われる問題を修正しました。

5.7.1.0.5

カテゴリ

説明

リリース日

バグ修正

  • プライマリノードでキーが変更された後、読み取り専用ノードでクエリを実行するとクラッシュする問題を修正しました。

  • 読み取り専用ノードでパーティションテーブルを分析するとクラッシュする問題を修正しました。

  • プライマリ/セカンダリフェールオーバー後、テーブルスペースの不整合により新しいプライマリノードがクラッシュする問題を修正しました。

2020-12-31

5.7.1.0.4

カテゴリ

説明

リリース日

バグ修正

  • プライマリ/セカンダリフェールオーバー後、一時テーブルにデータを挿入できない問題を修正しました。

  • 読み取り専用ノードで一時表領域が拡張されたときに、そのノードが利用できなくなる問題を修正しました。

  • シミュレート AIO が期待どおりに機能しない問題を修正しました。

2020-11-17

5.7.1.0.3

カテゴリ

説明

リリース日

新機能とパフォーマンスの最適化

TDE (透過的データ暗号化) 機能のサポートを追加しました。

2020-10-21

バグ修正

  • 読み取り専用ノードとプライマリノード間のパフォーマンス統計の不整合の問題を修正しました。

  • SHOW PROCESSLIST の結果にエラーメッセージが表示される問題を修正しました。

5.7.1.0.2

カテゴリ

説明

リリース日

バグ修正

  • RDS for MySQL 5.7 からの移行後、.IDB ファイルを拡張できない問題を修正しました。

  • 正常な動作を保証するために、プライマリ/セカンダリフェールオーバー中に CF_STATUS_COMMAND 関連のコマンドの実行を禁止しました。

  • 統計情報を更新するバックグラウンドスレッドと Truncate ロジック間のページ競合により、プライマリノードが利用できなくなる問題を修正しました。

2020-08-28

5.7.1.0.1

カテゴリ

説明

リリース日

バグ修正

  • 一部の PolarDB 固有のコマンドに対応するコマンド番号がなかったため、MaxScale にアクセスできない問題を修正しました。

  • ゴミ箱から復元して作成されたクラスターが、テーブルスペースが見つからないために利用できなくなる問題を修正しました。

  • promote replica コマンドが実行されたときにファイルが閉じられず、PFS ファイルのマウント解除時にクラッシュする問題を修正しました。

2020-07-30