アカウントと権限
企業IDシステムでのサインイン
Alibaba Cloud RAM を使用して SSO を構成することで、従業員は Okta や Microsoft Entra ID などの企業アカウントでサインインできます。
独自の ID システムを使用した Alibaba Cloud への企業シングルサインオンをご参照ください。
SSO を構成した後、RAM ユーザーに LangStudio の権限を付与してください。「クラウドサービスの依存関係と認可: LangStudio」をご参照ください。
モデルの呼び出し
Alibaba Cloud Model Studio モデルを呼び出す際の APIConnectionError: Connection error
APIConnectionError: Connection error
ランタイム VPC にインターネットアクセスがありません。Alibaba Cloud Model Studio モデルはアウトバウンド接続を必要とします。
SNAT を構成してインターネットアクセスを有効にしてください。「Internet NAT ゲートウェイの SNAT 機能を使用してインターネットにアクセスする」をご参照ください。
ナレッジベース
Faiss と Milvus の選択
| 基準 | Faiss | Milvus |
|---|---|---|
| ユースケース | テストとプロトタイピング | 本番ワークロード |
| インフラストラクチャ | 軽量、別途データベースインスタンスは不要 | 別途データベースインスタンスが必要 |
| スケール | 小規模なデータセット | 大規模なデータ処理 |
| パフォーマンス | 開発には十分 | より優れたパフォーマンスとスケーラビリティ |
テストには Faiss から始めてください。本番環境に移行する際や、より大規模なデータセットを扱う場合は Milvus に切り替えてください。
Faiss ベースのナレッジベースで The run failed due to reaching the timeout: 300 が発生
The run failed due to reaching the timeout: 300
ランタイムのリソースが不足しています。Faiss は OSS からメモリにベクトルデータを読み込むため、リソースを大量に消費します。
ランタイムのリソース仕様を増やしてください。
-
既存のランタイムをアップグレードする: ランタイムリストでランタイム名をクリックし、右上の 設定の変更 をクリックします。8 コアまたは 16 コア CPU など、より大きな リソース仕様 を選択してください。
-
ランタイムを置き換える: 現在のランタイムを削除し、より高い仕様で新しいランタイムを作成し、アプリケーションフローを更新して新しいランタイムを使用するように設定してください。
Faiss ベースのナレッジベースで ToolLoadError... (AccessDenied) が発生
Tool load failed in 'index_lookup': (ToolLoadError) Failed to load package tool 'Index Lookup': (AccessDenied)

アプリケーションフローには、指定された OSS パスにインデックスファイルを保存するための権限がありません。
適切な権限でナレッジベースインデックスを再作成してください。
-
デフォルトの PAI ロールを使用してナレッジベースインデックスを再作成してください。
-
[Output OSS Path] を、ワークスペースのデフォルトのストレージパスとして機能する OSS Bucket 内のディレクトリに設定してください。
-
アプリケーションフロー内のナレッジベースインデックスノードを再構成し、新しいインデックスを使用するように設定してください。
「ナレッジベースインデックス管理 - ナレッジベースインデックスの作成」をご参照ください。

課金
予期しない PAI-DSW の課金
LangStudio ランタイムは PAI-DSW インスタンス上で実行されます。ランタイムを開始すると DSW インスタンスが起動し、直ちに課金が開始されます。
使用していないときは、[DSW instance list] から DSW インスタンスを停止して、課金を回避してください。
