すべてのプロダクト
Search
ドキュメントセンター

Realtime Compute for Apache Flink:課金と権限

最終更新日:Aug 27, 2026

このトピックでは、Realtime Compute for Apache Flink の課金と権限に関するよくある質問に回答します。

ワークスペース作成失敗時の課金

いいえ。作成に失敗したワークスペースに対しては課金されません。課金の詳細を確認して確かめることができます。詳細については、「請求の表示」をご参照ください。

アイドル状態の従量課金ワークスペースへの課金

はい。デプロイメントが実行されていない場合でも、従量課金ワークスペースには課金されます。これには、デプロイメントが停止しているワークスペースや、作成後にアイドル状態になっているワークスペースが含まれます。Realtime Compute for Apache Flink の料金には、コンピューティングリソースと管理リソースが含まれます。コンピューティングリソースの使用量がゼロであっても、管理リソースに対しては、2 CU (コンピューティングユニット) に ご利用のリージョンの単価 を乗じた料金が課金されます。すべての課金を停止するには、ワークスペースをリリースする必要があります。

ワークロードが安定している場合は、サブスクリプションモデルへの切り替えをご検討ください。詳細については、「課金方法の変更」をご参照ください。

消費 CU の計算

  1. 開発コンソールで、[O&M] > [セッションクラスター] ページに移動します。各名前空間のすべてのセッションクラスターについて、合計 CPU コアとメモリを計算します。

  2. ワークスペース内のすべての名前空間にわたる、すべてのセッションクラスターの合計 CPU コア数とメモリを計算します。

  3. 次の式を使用して、消費 CU を計算します:MAX (⌈合計 CPU コア数⌉, ⌈合計メモリ (GB) / 4⌉)。

    この結果は、管理コンソールに表示される消費 CU の値と一致します。[Workspaces] リストページでは、[Consumed/Purchased CUs] 列で各ワークスペースの CU 使用量を確認できます。ワークスペースを展開すると、各名前空間の CU 割り当ての詳細が表示されます。ワークスペースの合計消費 CU は、各名前空間で消費される CU の合計です。例:9.00 + 18.00 = 27.00。

未使用 CU の課金

  • サブスクリプションワークスペースの場合、リソースを前払いします。10 CU を購入して 5 CU しか使用しなかった場合でも、10 CU すべてに対して課金されます。さらに、各ワークスペースには管理リソースの固定料金が適用されます。詳細については、「サブスクリプション」をご参照ください。

    スケールダウンなど、ビジネスニーズに基づいてリソースを調整できます。詳細については、「リソースのスケールイン」をご参照ください。従量課金モデルに切り替えることもできます。詳細については、「サブスクリプションから従量課金への切り替え」をご参照ください。

  • 従量課金ワークスペースの場合、ワークスペースが実際に消費するリソースに基づいて課金されます。購入 CU の概念は適用されません。

課金方法の切り替え

はい、従量課金とサブスクリプションの課金方法を切り替えることができます。Realtime Compute for Apache Flink の管理コンソールでワークスペースを見つけ、[Actions] 列の [More] をクリックし、目的の変換オプションを選択します。たとえば、[More] > [Convert To Subscription] を選択します。

場合によっては、課金方法の切り替えがサポートされていないことがあります。たとえば、ARM アーキテクチャを使用するワークスペースをサブスクリプションから従量課金に切り替えることはできません。具体的な制限については、コンソールのプロンプトをご参照ください。

コンソールが従量課金モデルへの切り替えを妨げる理由はいくつかあります:ワークスペースが実行中の状態ではない、すでに従量課金ワークスペースである、サブスクリプションが期限切れで更新が必要である、ARM アーキテクチャを使用している、またはクロスアベイラビリティゾーンのデプロイメントが有効になっている場合などです。

サブスクリプション更新の範囲

Realtime Compute for Apache Flink の更新はサービスのみを対象とします。Virtual Private Cloud (VPC)、Object Storage Service (OSS)、Application Real-Time Monitoring Service (ARMS) などの他の Alibaba Cloud 製品の料金は含まれません。詳細については、「関連製品の課金」をご参照ください。

課金項目

説明

管理リソース

ワークスペースを作成すると、システムはワークスペース用の開発コンソールをデプロイします。各開発コンソールとその必要なコンポーネントには、約 2 CU の管理リソースが必要です。

コンピューティングリソース

これらは計算に利用できるリソースです。サブスクリプションワークスペースの場合は購入したリソース、従量課金ワークスペースの場合は使用したリソースに基づいて課金されます。測定単位は CU です。

ワークスペースのリリース

ワークスペースが不要になった場合は、データをバックアップまたは移行し、リリースがビジネスに影響を与えないことを確認した上で、リリースすることができます。

  • 従量課金:料金滞納なし、または滞納期間が 15 日以下

    対象のワークスペースの [Actions] 列にある [Release Resources] をクリックし、画面の指示に従います。

  • 従量課金:料金滞納期間が 15 日超

    支払いが 15 日以上滞納された場合、ワークスペースは自動的にリリースされます。ワークスペース内のすべてのデプロイメントデータは消去され、復元できなくなります。

  • サブスクリプション:有効期間中、または期限切れから 15 日以内

    チケットを送信して解約を依頼できます。

  • サブスクリプション:期限切れから 15 日超

    ワークスペースは自動的にリリースされます。デプロイメントデータは削除され、復元できません。詳細については、「有効期限切れ後のリソースの変更」をご参照ください。

ワークスペースリリース後の課金

請求書は遅れて生成される場合があります。従量課金ワークスペースをリリースした後に課金が発生していることに気づいた場合は、まず請求書を表示し、[Billing Time] を確認してください。このフィールドは請求明細にあり、実際の課金期間を確認できます。

RAM ユーザーがデプロイメントを表示できない

  • 問題

    RAM ユーザーがログインすると、「The current account cannot access this namespace. You can refer to the authorization documentation to obtain access permissions.」というメッセージが表示されます。

  • 原因

    AliyunStreamFullAccess ポリシーは、ワークスペースの購入と設定に使用される Realtime Compute for Apache Flink の管理コンソールに対する完全な権限を付与します。デプロイメントの開発と管理に使用される開発コンソールに対する権限は付与しません。コンソールの権限の詳細な比較については、「権限管理」をご参照ください。

  • 解決策

    その名前空間の owner ロールを持つメンバー、またはユーザー管理権限を持つメンバーに、「開発コンソールの権限付与」に記載されている必要な権限を付与するよう依頼してください。アクセス権が付与された後、ページを更新するか、再度ログインして名前空間にアクセスしてください。

バケットポリシーのアクセスエラーの解決

  • 問題

    アーティファクトをアップロードすると、[Server Response Error] ダイアログボックスが表示され、次のエラー詳細が表示されます:Failed to parse the response result. [ErrorCode]: InvalidResponse [RequestId]: 6503FEFEDAC9123933E98AFB [HostId]: null [ResponseError]: AccessDenied Access denied by bucket policy.、ステータスコードは 500 です。主要なエラーは AccessDenied Access denied by bucket policy です。

  • 原因

    • 現在のアカウントに oss:PutBucketCORS 権限がないため、Object Storage Service (OSS) アーティファクトのアップロードに失敗します。

    • RAM のグローバルな deny ポリシーが AliyunStreamAsiDefaultRole ロールの権限を制限しています。これにより、Realtime Compute for Apache Flink は oss:PutBucketCORS アクションを実行できません。その結果、システムはクロスオリジンリソース共有 (CORS) ルールを自動的に設定できず、OSS アーティファクトのアップロードに失敗します。

  • 解決策

    1. 現在のアカウントに oss:PutBucketCORS 権限がない場合は、この権限をアカウントに付与してください。詳細については、「管理コンソールの権限付与」をご参照ください。

    2. アカウントにすでに oss:PutBucketCORS 権限があるにもかかわらず問題が解決しない場合は、対象のバケットに deny ポリシーが設定されているかどうかを確認してください。deny ポリシーが存在する場合は、Realtime Compute for Apache Flink が oss:PutBucketCORS アクションを実行できるようにポリシーを調整してください。

認証のリダイレクトループ

  • 問題

    Realtime Compute コンソールで [Purchase Product] をクリックすると、[Authorize in RAM] をクリックするよう促されます。しかし、[Authorize in RAM] をクリックした後、Realtime Compute コンソールにリダイレクトされ、無限ループが発生し、手動での認証もできなくなります。

  • 原因

    以前に手動で AliyunStreamAsiDefaultRole ロールを追加したため、ロールの自動付与プロセスはスキップされます。

  • 解決策

    RAM コンソールで、手動で追加した AliyunStreamAsiDefaultRole ロールを削除します。次に、Apache Flink 向けリアルタイムコンピューティングの購入ページに戻り、[RAM で承認] ボタンをクリックして承認を完了します。ロールを確認するには、RAM コンソールにログオンし、[ID] > [ロール] に移動して リアルタイムコンピューティング を検索し、次にロール名 [AliyunStreamAsiDefaultRole] をクリックします。ロールが存在し、その説明が「これは、リアルタイムコンピューティング完全マネージド版 (FlinkServerless) が他のクラウド製品のリソースにアクセスするために使用するデフォルトのロールです。」となっていることを確認します。

Flink コンソールの権限

開発および運用のために Realtime Compute for Apache Flink コンソールにアクセスするには、RAM 権限と名前空間権限の両方が必要です。

  • RAM 権限:ワークスペースの購入やリソースの調整などの操作に必要です。

  • 名前空間権限:名前空間内でのデプロイメントの開発および運用に必要です。

これらの権限タイプの使用例と違いについての詳細は、「権限管理」をご参照ください。

ログイン時の権限拒否エラー

  • 問題

    Realtime Compute コンソールにログインすると、「You are not authorized to perform this operation. You need the following permissions: [stream:DescribeVvpInstances] on [acs:stream:cn-beijing:1418886*********:vvpinstance/*]. Contact your administrator.」というエラーメッセージが表示されます。

  • 原因

    使用しているアイデンティティに Flink ワークスペースを表示する権限がないか、特定のリソースグループに対してのみ権限を持っています。

  • 解決策

    • 特定のリソースグループに対してのみ権限がある場合は、上部メニューから正しいリソースグループとリージョンを選択して、対象のワークスペースを表示します。

      リソースグループセレクターは、上部メニューの [All Resources] ドロップダウンメニューです。

    • アイデンティティが承認されていない場合は、Flink ワークスペースを表示する権限を付与する権限ポリシーを RAM ユーザーまたはロールにアタッチします。詳細については、「権限の付与」をご参照ください。

      以下の権限ポリシーは、Flink ワークスペースを表示する権限を付与します。どちらか一方を使用できます。

      • システムポリシー:AliyunStreamReadOnlyAccess (ストリーミングサービスへの読み取り専用アクセス) または AliyunStreamFullAccess (ストリーミングサービスへのフルアクセス)。詳細については、「管理コンソールの権限付与」をご参照ください。

      • カスタムポリシー:stream:DescribeVvpInstances (ワークスペースの表示)。詳細については、「カスタムポリシー」をご参照ください。

ロールまたはポリシーの削除後のサービス復元

以下の手順に従って、自動認証プロセスを再実行します。

  1. AliyunStreamAsiDefaultRole という名前の RAM ロールを削除します。詳細については、「RAM ロールの削除」をご参照ください。

    重要

    ロールを削除する前に、ロールからすべての権限ポリシーを[取り消す]必要があります。

  2. FlinkServerlessStack と FlinkOnAckStack スタックを削除します。詳細については、「スタックの削除」をご参照ください。

    • FlinkServerlessStack:Realtime Compute for Apache Flink の Resource Orchestration Service (ROS) スタックの統一名称です。

    • FlinkOnAckStack:Container Service for Kubernetes (ACK) の ROS スタックの統一名称です。

  3. AliyunStreamAsiDefaultRolePolicy という名前の RAM ポリシーを削除します。詳細については、「カスタムポリシーの削除」をご参照ください。

  4. Realtime Compute コンソールで、自動認証プロセスを再実行します。詳細については、「従量課金ワークスペースの作成」をご参照ください。

"You are not authorized" エラーの解決

このエラーは、デプロイメントのデプロイ、開始、停止などの操作を実行するために必要な権限がないことを示します。

これは、アカウントに操作に必要な権限がないことを意味します。[Security] > [Permissions] に移動し、[Role Management] タブで、どのロールが必要な権限を持ち、どのメンバーがそれらのロールに割り当てられているかを確認できます。その後、owner ロールまたはロール管理権限を持つメンバーに連絡して、アクセス権を付与してもらいます。ロールとその権限の依存関係に関する詳細については、「開発コンソールの権限付与」をご参照ください。