すべてのプロダクト
Search
ドキュメントセンター

Elastic Compute Service:カスタムイメージのスキャンと修復

最終更新日:Aug 21, 2026

イメージ作成およびイメージインポートの際に、イメージチェック機能を使用すると、カスタムイメージから正常に動作する Elastic Compute Service (ECS) インスタンスを作成できるか検証できます。チェックの完了後、ECS コンソールで結果を確認し、修復の提案に従ってイメージの品質を改善できます。これにより、ECS インスタンスの安定稼働と効率的な運用が保証されます。

説明
  • イメージを作成またはインポートすると、イメージチェックがトリガーされます。チェックが失敗しても、ワークフローは中断されません。

  • イメージチェックは無料です。

  • チェックに合格したイメージには、オペレーティングシステムのバージョン (acs:ecs:image:osVersion) とカーネルのバージョン (acs:ecs:image:kernelVersion) のタグが自動的に付与されます。

制限事項

イメージチェックは、暗号化されていないスナップショット、または暗号化されたクラウドディスクを持たないインスタンスから作成されたカスタムイメージのみをサポートします。

イメージチェックは、次の表に示す一部の Linux および Windows オペレーティングシステムをサポートしていません。

サポートされていない Linux オペレーティングシステム

オペレーティングシステム

バージョン

Gentoo

Gentoo 13 64 ビット

Gentoo_32

Gentoo_64

Gentoo_arm64

Aliyun

LifseaOS 10 64 ビット

LifseaOS 3 64 ビット

LifseaOS 3 64 ビット GPU エディション

FreeBSD

FreeBSD 10.1 64 ビット

FreeBSD 8.2 64 ビット

Freebsd_32

Freebsd_64

FreeBSD 11.1 64 ビット

FreeBSD 11.2 64 ビット

FreeBSD 11.3 64 ビット

FreeBSD 12.1 64 ビット

FreeBSD 11.4 64 ビット

Freebsd_arm64

FreeBSD 13.0 64 ビット

FreeBSD 12.3 64 ビット

CoreOS

CoreOS 681.2.0 64 ビット

CoreOS_32

CoreOS_64

CoreOS 1353.8.0 64 ビット

CoreOS 1465.8.0 64 ビット

CoreOS 1576.5.0 64 ビット

CoreOS 1688.5.3 64 ビット

CoreOS 1745.7.0 64 ビット

CoreOS 2023.4.0 64 ビット

CoreOS 2247.6.0 64 ビット

CoreOS 2303.3.0 64 ビット

CoreOS 2303.4.0 64 ビット

CoreOS 2345.3.0 64 ビット

CoreOS_arm64

Fedora CoreOS

FedoraCoreOS_64

Fedora CoreOS 33.20210217.3.0_3

FedoraCoreOS_arm64

Fedora CoreOS 34.20210529.3.0_3

Solaris

Solaris 10u8 64 ビット

mars

Aliyun カスタマイズされた Linux

カスタマイズされた Linux

CustomizedLinux_64

CustomizedLinux_32

CustomizedLinux_arm64

サポートされていない Windows オペレーティングシステム

オペレーティングシステム

バージョン

Windows Server 2008

Windows Server 2008 Standard Edition 64 ビット 中国語版

Windows Server 2008 Standard Edition 64 ビット 英語版

Windows Server 2008 Standard Edition SP2 32 ビット 中国語版

Windows Server 2008 Enterprise Edition 32 ビット 中国語版

Windows Server 2008 Standard Edition SP2 32 ビット 英語版

WindowsServer2008_64

WindowsServer2008_32

Windows Server 2008 Standard Edition SP2 32 ビット 日本語版

Windows Server 2003

Windows Server 2003 R2 Standard Edition SP2 64 ビット 中国語版

Windows Server 2003 R2 Standard Edition SP2 32 ビット 中国語版

Windows Server 2003 R2 Standard Edition SP2 64 ビット 英語版

Windows Server 2003 R2 Enterprise Edition 64 ビット 英語版

Windows Server 2003 R2 Enterprise Edition 64 ビット 中国語版

Windows Server 2003 R2 Enterprise Edition 32 ビット 中国語版

WindowsServer2003_64

WindowsServer2003_32

Windows 7

Windows7_32

Windows 8

Windows8_32

Windows 10

Windows10_32

イメージチェックの設定

イメージ作成時

コンソール

ECS コンソールでカスタムイメージを作成すると、デフォルトでイメージチェックが実行されます。変更は不要です。詳細については、「インスタンスを使用したカスタムイメージの作成」および「スナップショットを使用したカスタムイメージの作成」をご参照ください。

API

CreateImage API で、DetectionStrategy=Standard パラメーターを設定します。OpenAPI Explorer でこの API を実行すると、署名の計算が不要になり、SDK コードサンプルが自動生成されます。

イメージインポート時

コンソール

ECS コンソールでカスタムイメージをインポートすると、デフォルトでイメージチェックが実行されます。変更は不要です。詳細については、「カスタムイメージのインポート」をご参照ください。

API

ImportImage API で、DetectionStrategy=Standard パラメーターを設定します。OpenAPI Explorer でこの API を実行すると、署名の計算が不要になり、SDK コードサンプルが自動生成されます。

イメージチェック結果

コンソール

  1. 「カスタムイメージ」ページで、作成したイメージを見つけます。イメージのステータスが利用可能 に変更されると、イメージチェックタスクが自動的に実行されます。

  2. チェック結果にカーソルを合わせ、詳細を表示 をクリックすると、詳細なイメージチェック結果を表示できます。 イメージチェックが完了すると、[チェック結果] 列にチェックステータスが表示されます。 チェック結果にカーソルを合わせると、[緊急]、[推奨]、および [合格] の項目数が表示され、[詳細を表示] をクリックすると完全なチェックレポートを表示できます。

  3. 修正が必要な項目がある場合は、推奨事項に従って対応してください。

    • (Linux イメージのみ) {value,select, repair {今すぐ修復} other {作成} } をクリックし、CloudOps Orchestration Service (OOS) の ACS-ECS-RepairImage パブリックテンプレートを使用して問題を修正します。

    • または、イメージの詳細にある推奨事項に基づいて、手動で問題を修正します。詳細については、「イメージのチェック項目と修正の推奨事項」をご参照ください。

    イメージチェック結果ページでは、項目を リスクが検出されなかった項目、重大な修正、推奨される最適化 の 3 種類に分類します。各カテゴリには、具体的なチェック項目の一覧と、修正または最適化のためのリンクが表示されます。

API

DescribeImages API を呼び出し、イメージ ID を使用して結果を照会します。OpenAPI Explorer でこの API を実行できます。このツールは、署名計算を処理し、SDK コード例を自動生成することで、プロセスを簡素化します。

説明

レスポンスでは、DetectionOptions には検出結果が、Status にはタスクのステータスが、Item には各チェック項目の結果が含まれます。

イメージのチェックと修正

Linux

チェック項目

説明

推奨される修正

GUESTOS.Platform

システムプラットフォーム。Linux オペレーティングシステムであること。

該当なし

GUESTOS.OSVersion

オペレーティングシステムのバージョン。

該当なし

GUESTOS.Architecture

システムアーキテクチャ。

該当なし

GUESTOS.RtcTimeMode

イメージのハードウェアクロック (RTC) のタイムゾーンを指定します。有効な値は UTC または local です。ハードウェアクロックを UTC に設定することを推奨します。

ハードウェアクロックを UTC に設定するには、「Linux の時刻とタイムゾーン」をご参照ください。

GUESTOS.BootMode

イメージの起動モード。有効な値は LEGACY または UEFI です。

該当なし

GUESTOS.KernelVersion

カーネルバージョン。

該当なし

GUESTOS.Virtio

virtio ドライバーがインストールされているかどうかをチェックします。ECS インスタンスは仮想化にこのドライバーを必要とし、これがないと起動に失敗する可能性があります。

イメージに virtio ドライバーをインストールするには、「virtio ドライバーのインストール」をご参照ください。

GUESTOS.Nvme

NVMe ドライバーがインストールされているかどうかをチェックします。ecs.g7se などの特定の ECS インスタンスファミリーは、NVMe 接続のクラウドディスクを使用するため、イメージにこのドライバーが必要です。

イメージに NVMe ドライバーをインストールするには、「既存のカスタムイメージに NVMe ドライバーをインストールする方法」をご参照ください。

GUESTOS.Fstab

/etc/fstab ファイルをチェックします。存在しないデバイスや不正なデバイス UUID などの誤った設定は、システムの起動失敗の原因となる可能性があります。

/etc/fstab を正しく設定するには、「fstab ファイルで UUID を設定してデータディスクを自動的にマウントする」をご参照ください。

GUESTOS.Grub

GRUB ブートローダーの設定をチェックします。無効なデバイスパスや UUID などの不正な設定は、システムの起動失敗の原因となる可能性があります。

なし

GUESTOS.Dhcp

ネットワークが DHCP を使用するように設定されているかどうかをチェックします。イメージ内で静的 IP アドレスを使用すると、インスタンスの起動時にネットワーク障害が発生する可能性があります。

イメージのネットワーク設定モードを DHCP に設定するには、「Linux インスタンスの DHCP の設定」をご参照ください。

GUESTOS.Selinux

SELinux が無効になっているかどうかをチェックします。クラウドイメージでは、起動失敗を防ぐため SELinux を無効にすることを推奨します。

SELinux を無効にするには、「SELinux の有効化または無効化」をご参照ください。

GUESTOS.OnlineResizeFS

イメージがルートパーティションの自動サイズ変更をサポートしているかどうかをチェックします。イメージに cloud-init、growpart コマンド、およびその他の必要なツールがインストールされている場合、このイメージから作成されたインスタンスのルートパーティションは自動的に拡張されます。たとえば、20 GB のイメージから 100 GB のシステムディスクを持つインスタンスを作成すると、ルートパーティションは 100 GB に拡張されます。

イメージが自動サイズ変更をサポートするように設定するには、「cloud-init のインストール」をご参照ください。

GUESTOS.SystemImage

イメージが有効なシステムディスクイメージであるかどうかをチェックします。ISO イメージや空のイメージなどの無効なイメージをインポートしないでください。

該当なし

GUESTOS.CloudAssistant

Cloud Assistant がインストールされているかどうかをチェックします。Cloud Assistant は ECS 向けのネイティブな自動化および管理ツールであり、パスワード、ログイン、またはバスティオンホストなしで、ECS インスタンス上でバッチ操作の実行、コマンド (Shell、PowerShell、Bat コマンドなど) の実行、およびファイルの転送を可能にします。効率的なインスタンス管理のために Cloud Assistant をインストールすることを推奨します。

Cloud Assistant をインストールするには、「Cloud Assistant エージェントのインストール」をご参照ください。

GUESTOS.CloudInit

イメージに cloud-init がインストールされているかどうかをチェックします。cloud-init は、クラウドインスタンスの初期化における業界標準であり、ホスト名、SSH キーペアの設定、ルートパーティションのサイズ変更などのセットアップタスクを処理します。

イメージに cloud-init をインストールするには、「cloud-init のインストール」をご参照ください。

GUESTOS.SecurityCenterAgent

イメージに Security Center エージェントがインストールされているかどうかをチェックします。Security Center は、リアルタイムの脅威検出と保護を提供する統合セキュリティ管理システムです。その機能には、セキュリティポスチャの概要、ランサムウェア対策、ウイルス対策、改ざん防止、コンプライアンスチェックが含まれ、サーバーと Web アプリケーションを包括的に検出・保護します。

イメージに Security Center エージェントをインストールするには、「クライアントのインストール」をご参照ください。

GUESTOS.SupportMocInstanceTypes

イメージが ECS Bare Metal Instance ファミリーをサポートしているかどうかをチェックします。

ecs.g6 や ecs.g7 などの最新の ECS インスタンスファミリーは、多くの場合 ECS Bare Metal Instance アーキテクチャに基づいています。イメージの OS とカーネルバージョンが古い場合、これらのファミリーでインスタンスが起動に失敗することがあります。インスタンスファミリーの詳細については、「インスタンスファミリー」をご参照ください。

  • CentOS 5 を使用している場合は、最新バージョンの CentOS 5.11 にアップグレードすることを推奨します。詳細については、「移行後のインスタンスのダウンタイムを解決する方法」をご参照ください。

  • ECS Bare Metal Instance ファミリーをサポートしないオペレーティングシステムは、多くの場合、古いサポート終了 (EOL) バージョンです。できるだけ早く、ベンダーが積極的にメンテナンスしているオペレーティングシステムのバージョンにアップグレードすることを推奨します。

Windows

チェック項目

説明

推奨される修正

GUESTOS.Platform

システムプラットフォーム。Windows オペレーティングシステムであること。

該当なし

GUESTOS.OSVersion

オペレーティングシステムのバージョン。

該当なし

GUESTOS.Architecture

システムアーキテクチャ。

該当なし

GUESTOS.KernelVersion

カーネルバージョン。

該当なし

GUESTOS.Virtio

virtio ドライバーがインストールされているかどうかをチェックします。ECS インスタンスが正しく機能するためにこのドライバーは必要で、このドライバーがないと起動に失敗する可能性があります。

イメージに virtio ドライバーをインストールするには、「virtio ドライバーのインストール」をご参照ください。

GUESTOS.BCD

イメージ内のブート構成データ (BCD) ファイルが有効かどうかをチェックします。BCD ファイルがないか破損していると、インスタンスの起動に失敗する可能性があります。

正しい BCD ファイルを使用します。

GUESTOS.Registry

イメージ内のレジストリファイルが有効かどうかをチェックします。レジストリファイルがないか破損していると、インスタンスの起動に失敗する可能性があります。

正しいレジストリファイルを使用します。

GUESTOS.Hotfix

修正プログラムが正しくインストールされているかチェックします。必要な修正プログラムがないか、既知の問題がある修正プログラムをインストールすると、インスタンスの起動に失敗する可能性があります。

  • 不正な修正プログラムをアンインストールします。不正な修正プログラムには、KB5009624、KB5009595、KB5009546、KB5009557、KB5009555、KB5014738、KB5014702、KB5014692、および KB5014678 が含まれます。

  • 64 ビットの Microsoft Windows Server 2008 R2 オペレーティングシステムでは、修正プログラム KB3033929 もインストールする必要があります。

GUESTOS.Disk

ディスク設定が正しいかどうかをチェックします。レジストリ内の残留ドライバーエントリは、インスタンスの起動失敗の原因となる可能性があります。

レジストリから残留ドライバーをクリアします

GUESTOS.Sysprep

イメージ作成中に Sysprep が正常に完了したかどうかをチェックします。強制シャットダウンなどによる Sysprep プロセスの中断により、インスタンスの起動に失敗する可能性があります。

再度イメージを作成します。Sysprep プロセスが中断されないようにしてください。詳細については、「仮想マシンの作成とオペレーティングシステムのインストール」をご参照ください。

GUESTOS.Update

イメージ作成中に更新プロセスが完了したかどうかをチェックします。たとえば、強制シャットダウンによって更新プロセスが中断された場合、インスタンスが起動に失敗することがあります。

再度イメージを作成します。システム更新プロセスが中断されないようにしてください。詳細については、「仮想マシンの作成とオペレーティングシステムのインストール」をご参照ください。

GUESTOS.Xen

残留 Xen ドライバーをチェックします。このドライバーは、システムの起動失敗の原因となる可能性があります。

Xen ドライバーを無効化します

GUESTOS.CloudAssistant

Cloud Assistant がインストールされているかどうかをチェックします。Cloud Assistant は ECS 向けのネイティブな自動化および管理ツールであり、パスワード、ログイン、またはバスティオンホストなしで、ECS インスタンス上でバッチ操作の実行、コマンド (Shell、PowerShell、Bat コマンドなど) の実行、およびファイルの転送を可能にします。効率的なインスタンス管理のために Cloud Assistant をインストールすることを推奨します。

Cloud Assistant をインストールするには、「Cloud Assistant エージェントのインストール」をご参照ください。

GUESTOS.Server

イメージ内のサービス設定が正しいかどうかをチェックします。ドライバーのインストールが無効になっている場合、インスタンスはドライバーの更新に失敗します。

ドライバーのインストールを許可します

GUESTOS.DesktopConfig

デスクトップ設定ファイル (desktop.ini) がないかどうかをチェックします。ない場合、デスクトップ設定は適用されません。

正しい desktop.ini ファイルを設定します。

GUESTOS.BootMgr

システムブートマネージャー (BootMgr) がないかどうかをチェックします。BootMgr がないと、システムは起動できません。

正しい BootMgr を設定します。

残留ドライバーのクリア

HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control レジストリツリーには、システムの起動と特定のデバイスを制御する設定情報が含まれています。その Class サブキーには、デバイスに登録されているフィルタードライバーが含まれています。アンインストールされたソフトウェアの残留ドライバーエントリが原因で、イメージから作成されたインスタンスの起動に失敗する可能性があります。このセクションでは、これらの残留エントリを手動でクリーンアップする方法について説明します。

  1. イメージファイルが作成されたソースサーバーにログオンします。

  2. レジストリ エディターを開きます。

    たとえば、Windows 10 では、タスクバーの検索ボックスに regedit と入力し、Enter キーを押します。

  3. ディスクレジストリキーを開きます。

    パスは HKEY_LOCAL_MACHINE\SYSTEM\ControlSet001\Control\Class\{4d36e967-e325-11ce-bfc1-08002be10318} です。

  4. 残留ドライバーエントリを確認して削除します。

    1. UpperFilters プロパティの値を確認し、残留ドライバーエントリを特定します。

      対応するドライバーファイルが C:\Windows\System32\drivers にないにもかかわらず、そのエントリが UpperFilters に残っている場合、そのエントリは残留と見なされます。

      警告

      ドライバーエントリを削除するときは注意してください。システム例外を避けるため、ドライバーがシステム既定のドライバーではないことを確認してください。

      たとえば、partmgr はシステム既定のドライバーであり、UpperFilters から削除してはなりません。レジストリパス HKEY_LOCAL_MACHINE\OfflineSYSTEM\ControlSet001\Control\Class\{4d36e967-e325-11ce-bfc1-08002be10318} では、UpperFilters の値は partmgr です。これはシステム既定のドライバーであり、削除する必要はありません。

    2. UpperFilters で、残留ドライバーの名前を削除します。

Xen ドライバーの無効化

ECS インスタンスは Xen ドライバーを使用しません。ただし、古いイメージには残留 Xen ドライバーエントリが含まれていることがあり、起動失敗の原因となる可能性があります。レジストリで Xen ドライバーを無効化できます。

  1. イメージファイルが作成されたソースサーバーにログオンします。

  2. レジストリ エディターを開きます。

    たとえば、Windows 10 では、タスクバーの検索ボックスに regedit と入力し、Enter キーを押します。

  3. 対応するレジストリキーを開きます。

    パスは HKEY_LOCAL_MACHINE\SYSTEM\ControlSet001\Services\XenPCI\Parameters です。

  4. hide_devices プロパティの値をクリアします。

    hide_devices プロパティをダブルクリックします。表示されるダイアログボックスで、値をクリアし、[OK] をクリックします。

ドライバーインストールの許可

HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services レジストリツリーには、システム内のすべてのサービスが記録されます。一部のサービスは、ドライバーをインストールできるかどうかを制御します。イメージのレジストリでドライバーのインストールが無効になっている場合、そのイメージから作成されたインスタンスはドライバーを更新できません。この設定を無効にしているプロパティを変更する必要があります。

  1. イメージファイルが作成されたソースサーバーにログオンします。

  2. レジストリ エディターを開きます。

    たとえば、Windows 10 では、タスクバーの検索ボックスに regedit と入力し、Enter キーを押します。

  3. 対応するレジストリキーを開きます。

    • Windows Server 2008 R2 以降: HKEY_LOCAL_MACHINE\SYSTEM\ControlSet001\Services\DeviceInstall\Parameters。

    • Windows Server 2008 R2 以前: HKEY_LOCAL_MACHINE\SYSTEM\ControlSet001\Services\PlugPlay\Parameters。

  4. ドライバーのインストールを無効にしているプロパティを変更します。DeviceInstallDisabled プロパティが存在し、その値が 0 でない場合は、値を 0 に変更するか、プロパティを削除します。

    • たとえば、Windows Server 2008 R2 では、このプロパティは REG_DWORD 型で、レジストリパス HKEY_LOCAL_MACHINE\SYSTEM\ControlSet001\Services\PlugPlay\Parameters にあります。

    • たとえば、Windows Server 2016 では、レジストリパス HKEY_LOCAL_MACHINE\SYSTEM\ControlSet001\Services\DeviceInstall\Parameters の REG_DWORD 型の DeviceInstallDisabled プロパティの値が 1 の場合、値を 0 に変更するか、プロパティを削除する必要があります。

次のステップ

カスタムイメージのチェックと修復が完了したら、そのイメージから ECS インスタンスを作成できます。詳細については、「カスタムイメージまたは共有イメージからインスタンスを作成する」をご参照ください。