すべてのプロダクト
Search
ドキュメントセンター

Data Transmission Service:RDS for MySQL から ApsaraMQ for RocketMQ へのデータ同期

最終更新日:Jul 18, 2026

Data Transmission Service (DTS) を使用して、自己管理 MySQL データベースや ApsaraDB RDS for MySQL インスタンスなどの MySQL データベースから ApsaraMQ for RocketMQ インスタンスへデータを同期できます。本トピックでは、ApsaraDB RDS for MySQL インスタンスからのデータ同期方法について説明します。

前提条件

  • 宛先となる ApsaraMQ for RocketMQ インスタンス(サーバーレス以外)が必要です。詳細については、「インスタンスの管理」または「インスタンスの管理」をご参照ください。

    説明

    ソースおよびターゲットデータベースでサポートされているバージョンについては、「データ同期の概要」をご参照ください。

  • 同期データを受信するためのトピックが、宛先の ApsaraMQ for RocketMQ インスタンス内に必要です。詳細については、「トピックの管理」または「トピックの管理」をご参照ください。

    重要

    4.x シリーズのインスタンスの場合、トピックの メッセージタイプ は パーティション順序付きメッセージ に設定する必要があります。

    5.x シリーズのインスタンスの場合、トピックの メッセージタイプ は 順序付きメッセージ に設定する必要があります。

制限事項

種別

説明

ソースデータベース

  • 同期するテーブルにはプライマリキーまたは一意制約が必要で、フィールドは一意である必要があります。そうしないと、ターゲットデータベースに重複データが現れる可能性があります。

    • 同期対象のテーブルにはプライマリキーまたは一意制約が存在し、フィールド値が一意である必要があります。この条件を満たさない場合、ターゲットデータベースに重複データが発生する可能性があります。

    • テーブル単位で同期し、マッピング(カラム名マッピングなど)を編集する必要がある場合、1 つの同期タスクで最大 1,000 のテーブルをサポートします。この上限を超えると、タスクはエラーで失敗します。これを修正するには、複数のタスクにテーブルを分割するか、完全データベース同期タスクを構成してください。

  • バイナリログ:

    • ApsaraDB RDS for MySQL はデフォルトでバイナリロギングが有効になっています。binlog_row_image パラメーターが full に設定されていることを確認してください。設定されていない場合、事前チェックに失敗し、同期タスクを開始できません。手順については、「インスタンスパラメーターの設定」をご参照ください。

      重要
      • ソースインスタンスが自己管理 MySQL データベースの場合、バイナリロギングを有効にし、binlog_format を row、binlog_row_image を full に設定してください。

      • 自己管理 MySQL データベースがデュアルプライマリクラスター(両ノードがプライマリおよびセカンダリとして動作)の場合、log_slave_updates パラメーターを有効にして、DTS がすべてのバイナリログイベントを取得できるようにしてください。手順については、「自己管理 MySQL データベースのアカウント作成とバイナリロギングの設定」をご参照ください。

    • ApsaraDB RDS for MySQL インスタンスのローカルバイナリログは、少なくとも 3 日間保持する必要があります(7 日間の保持を推奨します)。自己管理 MySQL データベースの場合は、ローカルバイナリログを少なくとも 7 日間保持してください。保持しない場合、DTS がバイナリログを取得できず、タスクが失敗する可能性があります。最悪の場合、データの不整合やデータ損失が発生する可能性があります。DTS が必要とするよりも短いバイナリログ保持期間によって発生した問題は、DTS SLA の適用範囲外です。

      説明

      ApsaraDB RDS for MySQL インスタンスのローカルバイナリログの 保持期間 を設定するには、「ローカルログの自動削除」をご参照ください。

  • スキーマ同期および完全データ同期フェーズ中は、データベースまたはテーブル構造を変更する DDL 操作を実行しないでください。実行すると、データ同期タスクが失敗します。

    説明

    完全データ同期フェーズ中、DTS はソースデータベースに対してクエリを実行します。このクエリによりメタデータロックが生成され、ソースデータベースでの DDL 操作がブロックされる可能性があります。

  • バイナリログに書き込まれない変更(物理バックアップからの復元やカスケード操作によって作成されたデータなど)によって生成されたデータは、ターゲットデータベースに同期されません。

    説明

    このような状況が発生した場合は、影響を受けたデータベースまたはテーブルを同期オブジェクトから削除し、再度追加してください。ただし、これはビジネス要件で許容される場合に限ります。詳細については、「同期オブジェクトの変更」をご参照ください。

  • ソースデータベースが MySQL 8.0.23 以降で、非表示の隠しカラムが含まれている場合、DTS がこれらのカラムを読み取らない可能性があります。これにより、データ損失が発生する可能性があります。

    説明

    ALTER TABLE <table_name> ALTER COLUMN <column_name> SET VISIBLE; コマンドを実行して、隠しカラムを表示可能にしてください。詳細については、「Invisible Columns」をご参照ください。

その他の制限事項

  • サーバーレス ApsaraMQ for RocketMQ インスタンスは、宛先として使用できません。

  • データは、宛先の ApsaraMQ for RocketMQ インスタンス内の特定のトピックにのみ同期できます。

    • ApsaraMQ for RocketMQ 4.x の場合:宛先トピックの メッセージタイプ は パーティション順序付きメッセージ である必要があります。

      ターゲットの Message Queue for RocketMQ インスタンスがソースデータベースとは異なる インスタンスのリージョン にある場合、DTS はパブリックエンドポイントを使用してターゲットの Message Queue for RocketMQ インスタンスにアクセスし、パブリックネットワークトラフィック料金が発生します。ターゲットの Message Queue for RocketMQ インスタンスでパブリックアクセスが有効になっていることを確認してください。

      説明
      • パブリックアクセスのステータスは、ApsaraMQ for RocketMQ コンソールの インスタンス詳細 ページの 基本情報 タブで確認できます。

      • 宛先の ApsaraMQ for RocketMQ インスタンスのインターネットトラフィック料金の詳細については、「インターネットトラフィックの料金詳細」をご参照ください。

    • ApsaraMQ for RocketMQ 5.x の場合:宛先トピックの メッセージタイプ は 順序付きメッセージ である必要があります。

  • 宛先の ApsaraMQ for RocketMQ インスタンスは、最大 4 MB のメッセージ本文サイズをサポートします。

  • 宛先の ApsaraMQ for RocketMQ インスタンスの仕様を変更した場合(例:インスタンスの設定を変更)、DTS インスタンスの配信順序が変更前の順序と異なる可能性があります。その後のメッセージは、新しい順序に基づいて配信されます。

  • 完全データ同期、DTS はソースおよびターゲットデータベースの読み取り・書き込みリソースを消費するため、負荷が増加する可能性があります。両方のデータベースのパフォーマンスを評価し、オフピーク時間帯(例:両方のデータベースの CPU 使用率が 30 % 未満のとき)にデータ同期を実行することを推奨します。

  • 完全データ同期中、同時実行の INSERT 操作により、ターゲットデータベースでテーブルの断片化が発生します。完全データ同期が完了すると、ターゲットテーブルのストレージ使用量がソーステーブルよりも多くなります。

  • データ同期中は、pt-online-schema-change などのツールを使用して、ソースデータベースの同期オブジェクトに対してオンライン DDL 操作を実行しないでください。実行すると、タスクが失敗します。

  • データ同期中に、DTS 以外のソースがターゲットデータベースにデータを書き込むと、ソースおよびターゲットデータベース間にデータの不整合が発生する可能性があります。

  • ApsaraDB RDS for MySQL インスタンスで EncDB 機能が有効になっている場合、完全データ同期はサポートされません。

    説明

    TDE (透過的データ暗号化) が有効になっている ApsaraDB RDS for MySQL インスタンスは、完全データ同期および増分同期をサポートします。

  • タスクが失敗した場合、DTS サポートスタッフは 8 時間以内に復旧を試みます。復旧中、タスクを再起動したり、パラメーターを調整したりする可能性があります。

    説明

    データベースパラメーターではなく、DTS タスクパラメーターのみが変更されます。 調整対象となるパラメーターは、「インスタンスパラメーターの変更」に記載されています。

特殊なケース

  • 自己管理 MySQL ソースデータベースの場合:

    • 同期中にソースデータベースでプライマリ/セカンダリ スイッチオーバーが発生すると、タスクは失敗します。

    • DTS は、最後に同期されたレコードのタイムスタンプと現在時刻を比較して遅延を計算します。ソースデータベースで長時間 DML 操作が実行されない場合、遅延レポートが不正確になる可能性があります。遅延が高すぎると思われる場合は、ソースデータベースで DML 操作を実行して遅延を更新してください。

      説明

      完全データベースを同期対象に選択する場合は、ハートビートテーブルを作成してください。このテーブルを毎秒更新または書き込みます。

    • DTS は、バイナリログオフセットを進めるために、定期的にソースデータベースで CREATE DATABASE IF NOT EXISTS `test` コマンドを実行します。

    • ソースデータベースが Amazon Aurora MySQL またはその他のクラスタ型 MySQL インスタンスの場合、タスク構成で使用するドメイン名または IP アドレスおよびその DNS 解決が常に読み取り/書き込み (RW) ノードを指すようにしてください。そうでない場合、同期が失敗する可能性があります。

  • ApsaraDB RDS for MySQL ソースデータベースの場合:

    • トランザクションログを記録しない読み取り専用インスタンス(例:ApsaraDB RDS for MySQL 5.6 読み取り専用インスタンス)は、ソースデータベースとして使用できません。

    • DTS は、バイナリログオフセットを進めるために、定期的にソースデータベースで CREATE DATABASE IF NOT EXISTS `test` コマンドを実行します。

課金

同期タイプ

構成料金

完全データ同期

無料です。

増分同期

料金が発生します。詳細については、「課金の概要」をご参照ください。

同期可能な SQL 操作

操作タイプ SQL ステートメント
DML INSERT、UPDATE、DELETE
DDL CREATE TABLE、ALTER TABLE、DROP TABLE、RENAME TABLE、TRUNCATE TABLE;CREATE VIEW、ALTER VIEW、DROP VIEW;CREATE PROCEDURE、ALTER PROCEDURE、DROP PROCEDURE;CREATE FUNCTION、DROP FUNCTION、CREATE TRIGGER、DROP TRIGGER;CREATE INDEX、DROP INDEX
DTS は、ソースからターゲットへの外部キーを同期しません。ソースでのカスケードおよび削除操作はレプリケートされません。

データベースアカウントの権限

データベース

権限

操作

ソース ApsaraDB RDS for MySQL

同期対象オブジェクトの読み取り権限。

「アカウントの作成」および「アカウント権限の変更」を行います。

説明

ApsaraDB RDS for MySQL コンソール以外でソースデータベースアカウントを作成および権限付与する場合は、REPLICATION CLIENT、REPLICATION SLAVE、SHOW VIEW、および SELECT 権限がアカウントに付与されていることを確認してください。

操作手順

  1. 宛先リージョンの同期タスクリストページに移動します。以下のいずれかの方法を使用できます。

    DTS コンソールから

    1. Data Transmission Service (DTS) コンソールにログインします。

    2. 左側のナビゲーションウィンドウで、データ同期 をクリックします。

    3. ページ左上隅で、同期インスタンスが配置されているリージョンを選択します。

    DMS コンソールから

    説明

    実際の操作は、DMS コンソールのモードおよびレイアウトによって異なる場合があります。詳細については、「シンプルモード」および「DMS インターフェイスのレイアウトとスタイルのカスタマイズ」をご参照ください。

    1. Data Management (DMS) にログインします。

    2. 上部のメニューバーで、Data + AI > Data Transmission (DTS) > データ同期 を選択します。

    3. データ同期タスク の右側で、同期インスタンスが配置されているリージョンを選択します。

  2. タスクの作成 をクリックして、タスク構成ページに移動します。

  3. ソースおよびターゲットデータベースを構成します。

    カテゴリ

    パラメーター

    説明

    該当なし

    タスク名

    DTS は自動的にタスク名を生成します。識別しやすいように、わかりやすい名前を指定することを推奨します。名前は一意である必要はありません。

    移行元データベース

    既存の接続情報の選択

    • システムに追加済み(新規作成または保存済み)のデータベースインスタンスを使用する場合は、ドロップダウンリストからデータベースインスタンスを選択します。データベース情報は自動的に構成されます。

      説明

      DMS コンソールでは、この設定項目の名前は DMS データベースインスタンスの選択 です。

    • データベースインスタンスをシステムに追加していない場合、またはすでに追加されているインスタンスを使用しない場合は、以下のデータベース情報を手動で構成します。

    データベースタイプ

    MySQL を選択します。

    アクセス方法

    Alibaba Cloud インスタンス を選択します。

    インスタンスのリージョン

    ソースの RDS for MySQL インスタンスが配置されているリージョンを選択します。

    Alibaba Cloud アカウント間でデータを複製

    この例では、現在の Alibaba Cloud アカウントに属するデータベースインスタンスを使用します。× を選択します。

    RDS インスタンス ID

    ソースの RDS for MySQL インスタンスの ID を選択します。

    データベースアカウント

    ソースの RDS for MySQL インスタンスのデータベースアカウントを入力します。権限要件については、「データベースアカウントの権限」をご参照ください。

    データベースのパスワード

    データベースアカウントに対応するパスワードを入力します。

    暗号化

    必要に応じて、非暗号化 または SSL 暗号化 を選択します。SSL 暗号化 を選択する場合は、事前に RDS for MySQL インスタンスで SSL 暗号化を有効にしておく必要があります。詳細については、「クラウド証明書を使用した SSL 暗号化の迅速な有効化」をご参照ください。

    移行先データベース

    既存の接続情報の選択

    • システムに追加済み(新規作成または保存済み)のデータベースインスタンスを使用する場合は、ドロップダウンリストからデータベースインスタンスを選択します。データベース情報は自動的に構成されます。

      説明

      DMS コンソールでは、この設定項目の名前は DMS データベースインスタンスの選択 です。

    • データベースインスタンスをシステムに追加していない場合、またはすでに追加されているインスタンスを使用しない場合は、以下のデータベース情報を手動で構成します。

    データベースタイプ

    RocketMQ を選択します。

    アクセス方法

    Alibaba Cloud インスタンス を選択します。

    インスタンスのリージョン

    宛先の Message Queue for RocketMQ インスタンスが配置されているリージョンを選択します。

    RocketMQ バージョン

    宛先の Message Queue for RocketMQ インスタンスのバージョンを選択します。

    インスタンス ID

    宛先の Message Queue for RocketMQ インスタンスの ID を選択します。

    データベースアカウント

    宛先の Message Queue for RocketMQ インスタンスのデータベースアカウントおよびパスワードを入力します。

    説明
    • これらのパラメーターは、RocketMQ バージョン が 5.x に設定されている場合にのみ必須です。

    • 認証情報は、Message Queue for RocketMQ コンソールの アクセス制御 ページの インテリジェント認証 タブで取得できます。

    データベースのパスワード

    トピック

    ドロップダウンリストから、データを受信するトピックを選択します。

    DDL 情報を格納するトピック

    ドロップダウンリストから、DDL 情報を格納するトピックを選択します。

    説明

    トピックを選択しない場合、DDL 情報は トピック パラメーターで選択したトピックにデフォルトで格納されます。

  4. 構成が完了したら、ページ下部の 接続をテストして続行 をクリックします。

    説明
    • DTS サーバーからのアクセスを許可するために、ソースおよびターゲットデータベースのセキュリティ設定に DTS サーバーの IP アドレス CIDR ブロックを追加していることを確認してください。これは自動または手動で行えます。詳細については、「DTS サーバーの IP アドレス CIDR ブロックをホワイトリストに追加」をご参照ください。

    • ソースまたはターゲットデータベースが自己管理データベース(アクセス方法 が Alibaba Cloud インスタンス ではない)の場合、DTS サーバーの CIDR ブロック ダイアログボックスで 接続テスト をクリックする必要があります。

  5. タスクオブジェクトを構成します。

    1. オブジェクト設定 ページで、同期対象のオブジェクトを構成します。

      パラメーター

      説明

      同期タイプ

      増分データ同期 が選択されています。完全データ同期 のみ選択可能です。スキーマ同期 はサポートされていません。事前チェックが完了すると、DTS は選択したオブジェクトのデータをソースインスタンスから宛先クラスターに同期します。これは、後続の増分同期のベースラインデータとなります。

      説明

      ターゲットデータベースが Message Queue for RocketMQ インスタンスの場合、スキーマ同期 はサポートされていません。

      競合するテーブルの処理モード

      • エラーの事前チェックと報告:ターゲットデータベースに同じ名前のテーブルが存在するかどうかをチェックします。同じ名前のテーブルが存在しない場合、事前チェックは成功します。同じ名前のテーブルが存在する場合、事前チェックは失敗し、データ同期タスクは開始されません。

        説明

        ターゲットデータベースで同じ名前のテーブルを削除または名前変更できない場合は、別のテーブル名にマッピングできます。詳細については、「テーブル名およびカラム名のマッピング」をご参照ください。

      • エラーを無視して続行:ターゲットデータベースでの重複テーブル名のチェックをスキップします。

        警告

        エラーを無視して続行 を選択すると、データの不整合が発生し、ビジネスにリスクをもたらす可能性があります。例:

        • テーブルスキーマが同じで、ターゲットデータベースのレコードがソースデータベースのレコードと同じプライマリキーまたは一意キー値を持つ場合:

          • 完全同期中、DTS はターゲットクラスターのレコードを保持します。ソースデータベースの対応するレコードは同期されません。

          • 増分同期中、ソースデータベースのレコードがターゲットデータベースのレコードを上書きします。

        • テーブルスキーマが異なる場合、初期データ同期が失敗する可能性があります。これにより、一部のカラムデータのみが同期されるか、完全に同期が失敗する可能性があります。慎重に操作してください。

      RocketMQ に配信されるデータ形式

      要件に応じて、宛先トピックへのデータ書き込みのストレージフォーマットを選択します。詳細については、「メッセージキューにおけるデータストレージフォーマット」をご参照ください。

      すべてのフィールドを同期する

      UPDATE 操作について、宛先トピックの old フィールドに更新されたフィールドのみのプレイメージを同期するか、更新されたフィールドを含む行全体のプレイメージを同期するかを指定します。プレイメージとは、UPDATE 操作が実行される前のデータレコードです。

      説明

      このパラメーターは、RocketMQ に配信されるデータ形式 が Canal JSON に設定されている場合にのみ利用可能です。

      • ○:更新されたフィールドを含む行全体のプレイメージを同期します。

      • ×(デフォルト):更新されたフィールドのプレイメージのみを同期します。

      RocketMQ に配信されるメッセージ順序のルール

      宛先トピックへのデータ書き込みのメッセージ順序付けルールを選択します。詳細については、「Message Queue for RocketMQ のメッセージ順序付けルール」をご参照ください。

      DTS プロデューサーグループ名

      宛先トピックにメッセージを送信するプロデューサーグループ (ProducerGroup) のカスタム名を指定できます。

      説明

      デフォルト値は dts-producer-group です。

      RocketMQ メッセージ送受信の TPS 制限

      宛先トピックへのデータ書き込みのメッセージング TPS の制限を設定できます。メッセージング TPS の詳細については、「計算仕様」をご参照ください。

      重要
      • 値は、Message Queue for RocketMQ インスタンスの最大 TPS 以下である必要があります。詳細については、「インスタンス仕様」をご参照ください。

      • 同期タスクの実行中、Message Queue for RocketMQ インスタンスの実際のメッセージング TPS は、指定値の周囲でわずかに変動する可能性があります。

      大規模なレコードのフィルタリングを設定するかどうか

      宛先トピックへの書き込み前に 4 MB を超えるメッセージをフィルターするかどうかを指定します。

      重要

      × を選択すると、4 MB を超えるメッセージを宛先トピックに書き込もうとした場合、同期タスクは失敗します。

      移行先インスタンスでのオブジェクト名の大文字化

      宛先インスタンスに同期されるデータベース、テーブル、カラムオブジェクト名の大文字小文字の扱いポリシーを構成できます。デフォルトでは、DTS のデフォルトポリシー が選択されています。ソースおよびターゲットデータベースのデフォルトポリシーを使用することもできます。詳細については、「宛先オブジェクト名の大文字小文字の扱いポリシー」をご参照ください。

      ソースオブジェクト

      ソースオブジェクト ボックスで、同期するオブジェクトをクリックし、向右 をクリックして 選択中のオブジェクト ボックスに移動させます。

      説明

      同期オブジェクトとしてデータベースまたはテーブルを選択できます。

      選択中のオブジェクト

      この例では、追加の構成は不要です。マッピング機能を使用して、宛先の Message Queue for RocketMQ インスタンスに書き込まれるデータのトピック名、フィルター条件、同期する SQL 操作、およびパーティションキーを設定できます。詳細については、「マッピング情報」をご参照ください。

    2. 詳細設定へ をクリックして、高度なパラメーターを構成します。

      パラメーター

      説明

      タスクのスケジュールに使用する専用クラスターの選択

      デフォルトでは、DTS は共有クラスター上でタスクをスケジューリングするため、クラスターを選択する必要はありません。より安定したパフォーマンスを求める場合は、DTS 同期タスクを実行するための専用クラスターを購入できます。詳細については、「DTS 専用クラスターとは」をご参照ください。

      失敗した接続の再試行時間

      同期タスクの開始後、ソースまたはターゲットデータベースへの接続が失敗した場合、DTS はエラーを報告し、直ちに接続の再試行を開始します。デフォルトの再試行時間は 720 分です。10 ~ 1,440 分の範囲でカスタム再試行時間を指定することもできます。30 分以上に設定することを推奨します。指定された時間内に DTS がデータベースへの再接続に成功した場合、同期タスクは自動的に再開されます。それ以外の場合、タスクは失敗します。

      説明
      • 複数の DTS インスタンス(例:インスタンス A およびインスタンス B)が同じソースまたはターゲットを共有しており、インスタンス A のネットワークリトライ時間を 30 分、インスタンス B を 60 分に設定した場合、両方に短い方の 30 分が適用されます。

      • DTS は接続再試行期間中のタスクランタイムに対して課金するため、ビジネスニーズに基づいて再試行時間をカスタマイズするか、ソースおよびターゲットデータベースインスタンスをリリースした後は速やかに DTS インスタンスをリリースすることを推奨します。

      移行元データベースと移行先データベースで他の問題が発生した場合の、再試行までの待機時間です。

      同期タスクの開始後、ソースまたはターゲットデータベースで接続以外の問題(DDL または DML 実行例外など)が発生した場合、DTS はエラーを報告し、直ちに継続的な再試行操作を開始します。デフォルトの再試行時間は 10 分です。1 ~ 1,440 分の範囲で再試行時間をカスタマイズすることもできます。10 分以上に設定することを推奨します。設定された再試行時間内に関連操作が成功した場合、同期タスクは自動的に再開されます。それ以外の場合、タスクは失敗します。

      重要

      移行元データベースと移行先データベースで他の問題が発生した場合の、再試行までの待機時間です。 の値は、失敗した接続の再試行時間 の値より小さくする必要があります。

      完全同期レートを制限するかどうか

      完全同期フェーズ中、DTS はソースおよびターゲットデータベースの読み取り・書き込みリソースを消費するため、データベースの負荷が増加します。ソースおよびターゲットデータベースの負荷を軽減するために、1 秒あたりのソースデータベースのクエリ率 QPS、1 秒あたりの完全移行の行数 RPS、および 1 秒あたりの完全移行データ量 (MB) BPS パラメーターを構成して、完全同期タスクのレート制限を設定できます。

      説明
      • この設定項目は、同期タイプ が 完全データ同期 に設定されている場合にのみ利用可能です。

      • 同期インスタンスの実行後も、完全同期レートを調整 できます。

      増分同期率を制限するかどうか

      増分同期タスクのレート制限を設定することもできます。ターゲットデータベースの負荷を軽減するために、1 秒あたりの増分同期の行数 RPS および 1 秒あたりの増分同期データ量 (MB) BPS を設定します。

      順方向および逆方向タスクのハートビートテーブル SQL を削除

      DTS インスタンスの実行中に、ハートビート SQL 情報をソースデータベースに書き込むかどうかを選択します。

      • ○:ハートビート SQL 情報はソースデータベースに書き込まれません。これにより、DTS インスタンスが遅延を報告する可能性があります。

      • ×:ハートビート SQL 情報をソースデータベースに書き込みます。これにより、ソースデータベースの物理バックアップやクローンなどの機能に干渉する可能性があります。

      環境タグ

      インスタンスを識別するために環境タグを選択できます。この例では、タグは不要です。

      ETL 機能の設定

      抽出・変換・書き出し (ETL) 機能を有効にするかどうかを選択します。詳細については、「ETL とは」をご参照ください。有効値:

      監視アラート

      アラートを構成するかどうかを指定します。同期が失敗した場合や遅延が指定されたしきい値を超えた場合、アラート連絡先に通知が送信されます。

  6. タスクを保存して事前チェックを実行します。

    • このインスタンスを構成するための API パラメーターを表示するには、次:タスク設定の保存と事前チェック ボタンにカーソルを合わせ、表示されたバルーンで OpenAPI パラメーターのプレビュー をクリックします。

    • API パラメーターの確認が完了したら、ページ下部の 次:タスク設定の保存と事前チェック をクリックします。

    説明
    • 同期ジョブの開始前に、DTS は事前チェックを実行します。すべての事前チェック項目が合格した場合にのみ、ジョブを開始できます。

    • 事前チェックに失敗した場合は、失敗した項目の横にある 詳細を表示 をクリックします。指示に従って問題を修正し、再度事前チェックを実行します。

    • 事前チェックで警告が返された場合:

      • チェック項目が失敗し、無視できない場合は、項目の横にある 詳細を表示 をクリックします。指示に従って問題を修正し、再度事前チェックを実行します。

      • 無視可能なチェック項目については、アラートの詳細を確認、無視、OK、および 再度事前チェックを実行 を順にクリックして、警告をスキップし、事前チェックを再実行します。警告項目をマスクすると、データの不整合などの問題が発生し、ビジネスにリスクをもたらす可能性があります。

  7. インスタンスを購入します。

    1. [成功率] が 100 % になったら、次:インスタンスの購入 をクリックします。

    2. 購入 ページで、データ同期インスタンスの課金方法およびリンク仕様を選択します。以下の表に、これらのパラメーターの詳細を示します。

      カテゴリ

      パラメーター

      説明

      新しいインスタンスクラス

      課金方法

      • サブスクリプション:インスタンス作成時に支払いが発生します。長期的なニーズに適しており、従量課金よりもコスト効率が高くなります。サブスクリプション期間が長いほど、割引率が高くなります。

      • 従量課金:1 時間単位で課金されます。短期的なニーズに適しています。使用後すぐにインスタンスをリリースすることでコストを節約できます。

      リソースグループ構成

      インスタンスが属するリソースグループです。デフォルトはデフォルトリソースグループです。詳細については、「Resource Management とは」をご参照ください。

      リンク仕様

      DTS は、さまざまなパフォーマンスレベルを持つ同期仕様を提供します。同期リンク仕様は、同期レートに影響します。ビジネスシナリオに基づいて仕様を選択できます。詳細については、「データ同期リンク仕様」をご参照ください。

      サブスクリプション期間

      サブスクリプションモードの場合、サブスクリプションインスタンスの期間および数量を選択します。1 ~ 9 ヶ月の月額サブスクリプション、または 1、2、3、5 年の年額サブスクリプションを選択できます。

      説明

      このオプションは、課金方法が サブスクリプション の場合にのみ利用可能です。

    3. Data Transmission Service (従量課金) 利用規約 を読み、同意してください。

    4. 購入して起動 をクリックします。OK ダイアログボックスで、OK をクリックします。

      データ同期ページでタスクの進行状況を確認できます。

マッピング情報

  1. 選択中のオブジェクト リストで、宛先トピック名にポインターを合わせます。

  2. 宛先トピック名の横にある 編集 をクリックします。

  3. ダイアログボックスで、マッピング情報を構成します。

    説明
    • データベースレベルおよびテーブルレベルの両方でマッピングが構成されている場合、テーブルレベルのマッピングが優先されます。

    • データベースレベルのマッピングには スキーマの編集 ダイアログボックスを使用します。テーブルレベルのマッピングには テーブルの編集 ダイアログボックスを使用します。

    データベースレベル

    パラメーター

    説明

    スキーマ名

    同期データが書き込まれる宛先トピックです。デフォルトでは、ソースデータベースとターゲットデータベースの設定 ステップで 移行先データベース に選択した トピック になります。

    重要
    • 指定されたトピック名は、宛先の Message Queue for RocketMQ インスタンス内に存在している必要があります。存在しない場合、データ同期タスクは失敗します。

    • スキーマ名 を変更すると、データは指定されたトピックに書き込まれます。

    同期する DDL および DML 操作を選択

    増分同期の SQL 操作を選択します。

    テーブルレベル

    パラメーター

    説明

    テーブル名

    同期データが書き込まれる宛先トピックです。デフォルトでは、ソースデータベースとターゲットデータベースの設定 ステップで 移行先データベース に選択した トピック になります。

    重要
    • 指定されたトピック名は、宛先の Message Queue for RocketMQ インスタンス内に存在している必要があります。存在しない場合、データ同期タスクは失敗します。

    • テーブル名 を変更すると、データは指定されたトピックに書き込まれます。

    フィルタリング条件

    詳細については、「フィルター条件の設定」をご参照ください。

    同期する DDL および DML 操作を選択

    増分同期の SQL 操作を選択します。

    パーティションキー

    RocketMQ に配信されるメッセージ順序のルール が 指定した列のハッシュ値による配信 に設定されている場合、1 つ以上のカラムをパーティションキーとして指定できます。DTS は、キーから計算されたハッシュ値に基づいて、行を宛先トピックの異なるパーティションに配信します。

  4. 確かですか をクリックします。