すべてのプロダクト
Search
ドキュメントセンター

Data Transmission Service:RDS for MySQL から SelectDB へのデータ同期

最終更新日:Jul 18, 2026

ApsaraDB for SelectDB は、大規模データセットに対するサブ秒単位のクエリ応答、数万件の同時ポイントクエリ、および高スループットの複雑な分析をサポートします。Data Transmission Service (DTS) は、自己管理 MySQL データベースや ApsaraDB RDS for MySQL インスタンスなどの MySQL ソースから ApsaraDB for SelectDB インスタンスへデータを同期し、大規模データ分析を実現します。本トピックでは、ApsaraDB RDS for MySQL インスタンスを例に、その手順を説明します。

前提条件

ソース ApsaraDB RDS for MySQL インスタンスで使用されているストレージ容量を超えるストレージスペースを持つターゲット ApsaraDB for SelectDB インスタンスを作成済みである必要があります。詳細については、「インスタンスの作成」をご参照ください。

考慮事項

種別

説明

ソースデータベースの制限

  • 同期オブジェクトに関する要件:

    • 同期対象のすべてのテーブルにプライマリキーまたは一意制約がある場合:

      キーまたは制約を構成する列に一意の値が含まれていることを確認してください。

    • 同期オブジェクトにプライマリキーも一意制約もないテーブルが含まれる場合:

      データ同期インスタンスを設定する際、同期タイプスキーマ同期 を選択することを推奨します。その後、テーブル・列設定 ステップで、該当テーブルの エンジンの選択duplicate に設定してください。これを設定しないと、インスタンスが失敗したりデータ損失が発生したりする可能性があります。

      説明

      スキーマ同期中、DTS は宛先テーブルに列を追加します。詳細については、「追加列」をご参照ください。

  • テーブルレベルで同期を行い、マッピング(列名マッピングなど)を編集する必要がある場合、各同期タスクでサポートされるテーブル数は最大 1,000 です。この上限を超えると、タスクはエラーで失敗します。これを修正するには、複数のタスクにテーブルを分割するか、データベース全体の同期タスクを設定してください。

  • バイナリログ:

    • ApsaraDB RDS for MySQL では、デフォルトでバイナリロギングが有効になっています。binlog_row_image パラメーターが full に設定されていることを確認してください。設定されていない場合、事前チェックに失敗し、同期タスクを開始できません。手順については、「インスタンスパラメーターの設定」をご参照ください。

      重要
      • ソースインスタンスが自己管理 MySQL データベースの場合、バイナリロギングを有効にし、binlog_format を row、binlog_row_image を full に設定してください。

      • 自己管理 MySQL データベースがデュアルプライマリクラスター(両ノードがプライマリおよびセカンダリとして動作)の場合、log_slave_updates パラメーターを有効にして、DTS がすべてのバイナリログイベントをキャプチャできるようにしてください。手順については、「自己管理 MySQL データベースのアカウント作成とバイナリロギング設定」をご参照ください。

    • ApsaraDB RDS for MySQL インスタンスのローカルバイナリログは、少なくとも 3 日間(推奨は 7 日間)保持する必要があります。自己管理 MySQL データベースの場合は、ローカルバイナリログを少なくとも 7 日間保持してください。これより短い場合、DTS がバイナリログを取得できず、タスクが失敗する可能性があります。最悪の場合、データの不整合やデータ損失が発生します。DTS の要件よりも短いバイナリログ保持期間に起因する問題は、DTS SLA の対象外です。

      説明

      ApsaraDB RDS for MySQL インスタンスのローカルバイナリログの 保持期間 を設定するには、「ローカルログの自動削除」をご参照ください。

  • スキーマ同期または完全同期中に、データベースまたはテーブルスキーマを変更する DDL 操作を実行しないでください。実行すると、同期タスクが失敗します。

    説明

    完全同期中、DTS はソースデータベースに対してクエリを実行します。これによりメタデータロックが発生し、ソースデータベースでの DDL 操作がブロックされる可能性があります。

  • バイナリログに書き込まれない変更(物理バックアップからの復元やカスケード操作によって生成されたデータなど)によって生成されたデータは、ターゲットデータベースに同期されません。

    説明

    このような状況が発生した場合、影響を受けたデータベースまたはテーブルを同期オブジェクトから除外し、再度追加してください。ただし、これはビジネス要件で許容される場合に限ります。詳細については、「同期オブジェクトの変更」をご参照ください。

  • ソースデータベースが MySQL 8.0.23 以降で、非表示の隠し列が含まれている場合、DTS がそれらの列を読み取らない可能性があります。これによりデータ損失が発生する可能性があります。

    説明

    ALTER TABLE <table_name> ALTER COLUMN <column_name> SET VISIBLE; コマンドを実行して、隠し列を表示可能にしてください。詳細については、「Invisible Columns」をご参照ください。

その他の制限

  • Alibaba Cloud SelectDB インスタンスでは、Unique エンジンまたは Duplicate エンジンを使用するテーブルにのみデータを同期できます。

    Unique エンジン

    宛先テーブルが Unique エンジンを使用している場合、宛先テーブルのすべての一意キーがソーステーブルに存在し、同期オブジェクトに含まれていることを確認してください。そうでない場合、データの不整合が発生する可能性があります。

    Duplicate エンジン

    宛先テーブルが Duplicate エンジンを使用している場合、以下のいずれかの状況により、宛先データベースに重複データが発生する可能性があります。追加列 (_is_deleted、_version、_record_id) を基に手動で重複排除できます。

    • データ同期インスタンスが再試行された。

    • データ同期インスタンスが再起動された。

    • データ同期インスタンスの開始後、同じ行に対して 2 回以上の DML 操作が実行された。

      説明

      宛先テーブルが Duplicate エンジンを使用している場合、DTS は UPDATE または DELETE 文を INSERT 文に変換します。

  • DTS は、INDEX、PARTITION、VIEW、PROCEDURE、FUNCTION、TRIGGER、外部キー (FK) オブジェクトを同期しません。

  • 選択中のオブジェクト セクションでパラメーターを設定する際、bucket_count(バケット数)パラメーターのみを設定できます。

    説明

    bucket_count パラメーターの値は正の整数である必要があります。デフォルト値は auto です。

  • データ同期中、宛先 Alibaba Cloud SelectDB インスタンスにクラスターを作成しないでください。実行すると、タスクが失敗します。データ同期インスタンスを再起動してタスクを再開できます。

  • 同期対象のデータベースまたはテーブル名が英字で始まらない場合、オブジェクト名マッピング機能を使用して名前を変更してください。

  • 同期対象のオブジェクト(データベース、テーブル、列など)の名前に中国語文字が含まれる場合、オブジェクト名マッピング機能を使用して(例:英語名に)名前を変更してください。変更しないと、タスクが失敗する可能性があります。

  • DTS は、一度に複数の列を変更する DDL 操作や、同じテーブルに対する連続する DDL 操作をサポートしていません。

  • データ同期中、Alibaba Cloud SelectDB データベースに BE ノードを追加しないでください。実行すると、タスクが失敗します。データ同期インスタンスを再起動してタスクを再開できます。

  • 多対一テーブル同期シナリオ(複数のソーステーブルから単一の宛先テーブルへデータを同期)では、すべてのソーステーブルのスキーマが同一であることを確認してください。そうでない場合、データの不整合やタスクの失敗が発生する可能性があります。

  • MySQL では、VARCHAR(M) の M は文字数を表します。一方、Alibaba Cloud SelectDB では、VARCHAR(N) の N はバイト数を表します。DTS が提供するスキーマ同期機能を使用しない場合、Alibaba Cloud SelectDB の VARCHAR フィールドの長さを、MySQL の対応する VARCHAR フィールドの長さの 4 倍に設定することを推奨します。

  • ソースで DMS または gh-ost ツールを使用してオンライン DDL 操作を実行する場合、DTS は元の DDL 文のみを宛先に同期します。このシナリオでは、大量の一時テーブルデータを同期する必要がないため負荷が軽減されますが、宛先でテーブルがロックされる可能性があります。

    説明

    DTS は、pt-online-schema-change などのツールによるオンライン DDL 変更の同期をサポートしていません。ソースでこのような変更が存在する場合、宛先でデータが失われるか、同期インスタンスが失敗する可能性があります。

  • データ同期を開始する前に、ソースおよびターゲットデータベースのパフォーマンスを評価してください。データ同期はオフピーク時間帯に実行することを推奨します。初期完全データ同期は、ソースおよびターゲットデータベースの読み取り・書き込みリソースを消費するため、データベース負荷が増加する可能性があります。

  • 初期完全データ同期では、同時 INSERT 操作が実行されるため、宛先データベースのテーブルに断片化が発生します。その結果、初期完全データ同期完了後の宛先データベースの表領域が、ソースデータベースの表領域よりも大きくなります。

  • データ同期中、ソースデータベースの同期オブジェクトに対して pt-online-schema-change などのツールを使用してオンライン DDL 変更を実行しないでください。実行すると、タスクが失敗します。

  • データ同期中、DTS 以外のソースが宛先データベースにデータを書き込むと、データの不整合が発生する可能性があります。

  • ApsaraDB RDS for MySQL インスタンスで Always-Encrypted が有効になっている場合、完全データ同期はサポートされません。

    説明

    透過的データ暗号化 (TDE) が有効になっている ApsaraDB RDS for MySQL インスタンスは、スキーマ同期、完全データ同期、および増分データ同期をサポートしています。

  • 増分同期中、DTS は宛先への負荷を軽減するためにバッチ同期戦略を使用します。デフォルトでは、DTS は単一の同期オブジェクトに対して最大 5 秒に 1 回しか書き込みを行いません。そのため、DTS 同期タスクでは定期的な同期遅延(通常は 10 秒以内)が発生する可能性があります。この定期的な同期遅延を軽減するには、コンソールで DTS インスタンスパラメーター selectdb.reservoir.timeout.milliseconds を変更してバッチ間隔を調整してください。許容範囲は [1000, 10000] ミリ秒です。

    説明

    バッチ間隔を調整する際、値を小さくすると DTS の書き込み頻度が増加します。これにより、宛先の負荷および書き込みレスポンスタイム (RT) が増加し、DTS 同期遅延が逆に大きくなる可能性があります。宛先の負荷に基づいて値を調整してください。

  • タスクが失敗した場合、DTS サポートスタッフが 8 時間以内に復旧を試みます。復旧中、タスクを再起動したりパラメーターを調整したりする可能性があります。

    説明

    データベースパラメーターではなく、DTS タスクパラメーターのみが変更されます。 調整対象となるパラメーターは、「インスタンスパラメーターの変更」に記載されています。

特殊なケース

  • 自己管理 MySQL ソースデータベースの場合:

    • 同期中にソースデータベースでプライマリ/セカンダリ スイッチオーバーが発生すると、タスクが失敗します。

    • DTS は、最後に同期されたレコードのタイムスタンプと現在時刻を比較して遅延を計算します。ソースデータベースで長時間 DML 操作が実行されない場合、遅延レポートが不正確になる可能性があります。遅延が過剰に表示される場合は、ソースデータベースで DML 操作を実行して遅延を更新してください。

      説明

      データベース全体を同期対象に選択する場合、ハートビートテーブルを作成してください。このテーブルを毎秒更新または書き込みます。

    • DTS は、バイナリログオフセットを進めるために、ソースデータベースで定期的に CREATE DATABASE IF NOT EXISTS `test` コマンドを実行します。

    • Amazon Aurora MySQL または他のクラスタ型 MySQL インスタンスをソースデータベースとして使用する場合、タスク設定で使用するドメイン名または IP アドレスおよびその DNS 解決が常に読み取り/書き込み (RW) ノードを指すようにしてください。そうでない場合、同期が失敗する可能性があります。

  • ApsaraDB RDS for MySQL ソースデータベースの場合:

    • トランザクションログを記録しない読み取り専用インスタンス(例:ApsaraDB RDS for MySQL 5.6 読み取り専用インスタンス)は、ソースデータベースとして使用できません。

    • DTS は、バイナリログオフセットを進めるために、ソースデータベースで定期的に CREATE DATABASE IF NOT EXISTS `test` コマンドを実行します。

課金

同期タイプ

料金

スキーマ同期および完全データ同期

無料です。

増分データ同期

課金対象です。詳細については、「課金概要」をご参照ください。

増分同期の SQL

操作タイプ

SQL ステートメント

DML

INSERT、UPDATE、DELETE

DDL

  • ADD COLUMN

  • MODIFY COLUMN

  • CHANGE COLUMN

  • DROP COLUMN および DROP TABLE

  • TRUNCATE TABLE

  • RENAME TABLE

    重要

    RENAME TABLE 操作によりデータの不整合が発生する可能性があります。たとえば、同期オブジェクトが単一テーブルで、同期中にソースインスタンスでこのテーブルの名前を変更した場合、このテーブルのデータはターゲットデータベースに同期されません。この問題を回避するには、テーブルが属するデータベース全体を同期オブジェクトとして選択してください。RENAME TABLE 操作の前後でテーブルが属するデータベースが同期オブジェクトに含まれていることを確認してください。

データベースアカウント権限

データベース

必要な権限

操作

ソース ApsaraDB RDS for MySQL

同期対象オブジェクトに対する読み取りおよび書き込み権限

アカウントの作成 および アカウント権限の変更

ターゲット ApsaraDB for SelectDB インスタンス

クラスターへのアクセス権限 (Usage_priv) およびデータベースに対する読み取り・書き込み権限 (Select_priv、Load_priv、Alter_priv、Create_priv、Drop_priv)

クラスター権限の管理 および 基本権限の管理

説明

ApsaraDB RDS for MySQL コンソール以外でソースデータベースアカウントを作成した場合、REPLICATION CLIENT、REPLICATION SLAVE、SHOW VIEW、SELECT 権限が付与されていることを確認してください。

操作手順

  1. 宛先リージョンの同期タスクリストページに移動します。次の 2 つの方法のいずれかを使用できます。

    DTS コンソールから

    1. Data Transmission Service (DTS) コンソール にログインします。

    2. 左側のナビゲーションウィンドウで、データ同期 をクリックします。

    3. ページ左上隅で、同期インスタンスが配置されているリージョンを選択します。

    DMS コンソールから

    説明

    実際の操作は、DMS コンソールのモードおよびレイアウトによって異なる場合があります。詳細については、「シンプルモード」および「DMS インターフェイスのレイアウトとスタイルのカスタマイズ」をご参照ください。

    1. Data Management (DMS) にログインします。

    2. トップメニューバーで、データ + AI > データ伝送 (DTS) > データ同期 を選択します。

    3. データ同期タスク の右側で、同期インスタンスが配置されているリージョンを選択します。

  2. タスクの作成 をクリックして、タスク設定ページに移動します。

  3. ソースおよびターゲットデータベースを設定します。

    セクション

    パラメーター

    説明

    該当なし

    タスク名

    DTS が自動的にタスク名を生成します。識別しやすいように、わかりやすい名前を指定することを推奨します。名前は一意である必要はありません。

    移行元データベース

    既存の接続情報の選択

    • システムに追加済み(新規作成または保存済み)のデータベースインスタンスを使用する場合、ドロップダウンリストからデータベースインスタンスを選択します。データベース情報は自動的に設定されます。

      説明

      DMS コンソールでは、この設定項目の名前は DMS データベースインスタンスの選択 です。

    • データベースインスタンスをシステムに追加していない場合、またはすでに追加済みのインスタンスを使用しない場合は、以下のデータベース情報を手動で設定します。

    データベースタイプ

    MySQL を選択します。

    アクセス方法

    Alibaba Cloud インスタンス を選択します。

    インスタンスのリージョン

    ソース ApsaraDB RDS for MySQL インスタンスのリージョンを選択します。

    Alibaba Cloud アカウント間でデータを複製

    本例では、同じ Alibaba Cloud アカウント内でデータを同期します。× を選択します。

    RDS インスタンス ID

    ソース ApsaraDB RDS for MySQL インスタンスの ID を選択します。

    データベースアカウント

    ソース ApsaraDB RDS for MySQL インスタンスのデータベースアカウントを入力します。必要な権限については、「データベースアカウントに必要な権限」をご参照ください。

    データベースのパスワード

    データベースアカウントに対応するパスワードを入力します。

    暗号化

    必要に応じて、非暗号化 または SSL 暗号化 を選択します。SSL 暗号化 を選択する場合、事前に RDS for MySQL インスタンスで SSL 暗号化を有効にする必要があります。詳細については、「クラウド証明書を使用した SSL 暗号化の迅速な有効化」をご参照ください。

    移行先データベース

    既存の接続情報の選択

    • システムに追加済み(新規作成または保存済み)のデータベースインスタンスを使用する場合、ドロップダウンリストからデータベースインスタンスを選択します。データベース情報は自動的に設定されます。

      説明

      DMS コンソールでは、この設定項目の名前は DMS データベースインスタンスの選択 です。

    • データベースインスタンスをシステムに追加していない場合、またはすでに追加済みのインスタンスを使用しない場合は、以下のデータベース情報を手動で設定します。

    データベースタイプ

    ApsaraDB for SelectDB を選択します。

    アクセス方法

    Alibaba Cloud インスタンス を選択します。

    インスタンスのリージョン

    ターゲット ApsaraDB for SelectDB インスタンスのリージョンを選択します。

    Alibaba Cloud アカウント間でデータを複製

    本例では、同じ Alibaba Cloud アカウント内でデータを同期します。× を選択します。

    インスタンス ID

    ターゲット ApsaraDB for SelectDB インスタンスの ID を選択します。

    データベースアカウント

    ターゲット ApsaraDB for SelectDB インスタンスのデータベースアカウントを入力します。必要な権限については、「データベースアカウントに必要な権限」をご参照ください。

    データベースのパスワード

    データベースアカウントに対応するパスワードを入力します。

  4. 設定が完了したら、ページ下部の 接続をテストして続行 をクリックします。

    説明
    • DTS サーバーからのアクセスを許可するために、ソースおよびターゲットデータベースのセキュリティ設定に DTS サーバーの IP アドレス CIDR ブロックを追加してください。これは自動または手動で行えます。詳細については、「DTS サーバーの IP アドレス CIDR ブロックをホワイトリストに追加」をご参照ください。

    • ソースまたはターゲットデータベースが自己管理データベース(アクセス方法Alibaba Cloud インスタンス ではない)の場合、DTS サーバーの CIDR ブロック ダイアログボックスで 接続テスト をクリックする必要があります。

  5. タスクオブジェクトを設定します。

    1. オブジェクト設定 ページで、同期対象オブジェクトを設定します。

      パラメーター

      説明

      同期タイプ

      増分データ同期 が選択されています。デフォルトでは、スキーマ同期 および 完全データ同期 も選択する必要があります。事前チェック完了後、DTS は選択したオブジェクトをソースインスタンスから宛先クラスターに完全同期し、これを以降の増分データ同期のベースラインデータとします。

      重要

      MySQL から ApsaraDB for SelectDB へのデータ同期時にデータ型が変換されます。スキーマ同期 を選択しない場合、事前に宛先 ApsaraDB for SelectDB インスタンスに、適切なスキーマを持つ Unique または Duplicate モデルのテーブルを作成しておく必要があります。詳細については、「データ型マッピング」、「追加列」、および「データモデル」をご参照ください。

      競合するテーブルの処理モード

      • エラーの事前チェックと報告:DTS は宛先データベースに同名のテーブルがあるかどうかをチェックします。競合が存在する場合、事前チェックでエラーを報告し、タスクを開始しません。

        説明

        競合テーブルを削除または名前変更することが実用的でない場合、テーブルを別の名前にマッピングできます。詳細については、「オブジェクト名のマッピング」をご参照ください。

      • エラーを無視して続行:宛先データベースに同名のテーブルがあるかどうかのチェックをスキップします。

        警告

        エラーを無視して続行 を選択すると、データの不整合が発生する可能性があります。たとえば:

        • テーブルスキーマが一致している場合、ソースレコードと同じプライマリキーまたは一意キーを持つ宛先レコードが上書きされます。

        • テーブルスキーマが一致していない場合、タスクが失敗するか、一部のデータのみが同期される可能性があります。慎重に操作してください。

      移行先インスタンスでのオブジェクト名の大文字化

      宛先インスタンスに同期されるデータベース、テーブル、列オブジェクト名の大文字小文字区別ポリシーを設定できます。デフォルトでは、DTS のデフォルトポリシー が選択されています。ソースおよび宛先データベースのデフォルトポリシーを使用することもできます。詳細については、「宛先オブジェクト名の大文字小文字区別ポリシー」をご参照ください。

      ソースオブジェクト

      ソースオブジェクト ボックスで、同期対象のオブジェクトをクリックし、向右 をクリックして 選択中のオブジェクト ボックスに移動させます。

      説明

      データベースレベルまたはテーブルレベルでオブジェクトを選択できます。

      選択中のオブジェクト

      • 宛先インスタンスにおける同期オブジェクトの名前を変更するには、選択中のオブジェクト ボックスでオブジェクトを右クリックします。詳細については、「オブジェクト名のマッピング」をご参照ください。

      • 同期タイプスキーマ同期 を選択し、テーブルを同期オブジェクトとして選択し、バケット数(bucket_count パラメーター)を設定する必要がある場合、選択中のオブジェクト ボックスでテーブルを右クリックします。パラメーター設定 セクションで、パラメーター設定の有効化 に設定し、要件に基づいて パラメーター値 を指定してから、OK をクリックします。

      説明
      • データベースまたはテーブルレベルで同期する増分 SQL 操作を選択するには、選択中のオブジェクト ボックスでオブジェクトを右クリックし、表示されるダイアログボックスで目的の SQL 操作を選択します。

      • WHERE 句を使用してデータをフィルターするには、選択中のオブジェクト ボックスでテーブルを右クリックし、表示されるダイアログボックスでフィルター条件を設定します。詳細については、「フィルター条件の設定」をご参照ください。

      • オブジェクト名マッピング機能を使用する場合、名前変更されたオブジェクトに依存する他のオブジェクトの同期が失敗する可能性があります。

    2. 詳細設定へ をクリックして、高度なパラメーターを設定します。

      パラメーター

      説明

      タスクのスケジュールに使用する専用クラスターの選択

      デフォルトでは、DTS は共有クラスター上でタスクをスケジューリングするため、クラスターを選択する必要はありません。より安定したパフォーマンスが必要な場合は、DTS 同期タスクを実行するための専用クラスターを購入できます。詳細については、「DTS 専用クラスターとは」をご参照ください。

      失敗した接続の再試行時間

      同期タスク開始後、ソースまたはターゲットデータベースへの接続が失敗した場合、DTS はエラーを報告し、直ちに接続の再試行を開始します。デフォルトの再試行時間は 720 分です。10 ~ 1,440 分の範囲でカスタム再試行時間を指定することもできます。30 分以上に設定することを推奨します。指定された時間内に DTS がデータベースへの再接続に成功した場合、同期タスクは自動的に再開されます。そうでない場合、タスクは失敗します。

      説明
      • 同じソースまたはターゲットを共有する複数の DTS インスタンス(例:インスタンス A とインスタンス B)があり、インスタンス A のネットワーク再試行時間を 30 分、インスタンス B を 60 分に設定した場合、両方に短い方の 30 分が適用されます。

      • DTS は接続再試行期間中のタスク実行時間に対して課金するため、ビジネス要件に基づいて再試行時間をカスタマイズするか、ソースおよびターゲットデータベースインスタンスをリリースした後は速やかに DTS インスタンスをリリースすることを推奨します。

      移行元データベースと移行先データベースで他の問題が発生した場合の、再試行までの待機時間です。

      同期タスク開始後、ソースまたはターゲットデータベースで接続以外の問題(DDL または DML 実行例外など)が発生した場合、DTS はエラーを報告し、直ちに継続的な再試行操作を開始します。デフォルトの再試行時間は 10 分です。1 ~ 1,440 分の範囲でカスタム再試行時間を設定することもできます。10 分以上に設定することを推奨します。設定された再試行時間内に関連操作が成功した場合、同期タスクは自動的に再開されます。そうでない場合、タスクは失敗します。

      重要

      移行元データベースと移行先データベースで他の問題が発生した場合の、再試行までの待機時間です。 の値は、失敗した接続の再試行時間 の値より小さくする必要があります。

      完全同期レートを制限するかどうか

      完全同期ステージ中、DTS はソースおよびターゲットデータベースの読み取り・書き込みリソースを消費するため、データベース負荷が増加します。ソースおよびターゲットデータベースへの負荷を軽減するには、1 秒あたりのソースデータベースのクエリ率 QPS1 秒あたりの完全移行の行数 RPS、および 1 秒あたりの完全移行データ量 (MB) BPS パラメーターを設定して、完全同期タスクのレート制限を設定できます。

      説明
      • この設定項目は、同期タイプ完全データ同期 に設定されている場合にのみ利用可能です。

      • 同期インスタンス実行後も、完全同期レートを調整 できます。

      増分同期率を制限するかどうか

      増分同期タスクのレート制限も設定できます。宛先データベースへの負荷を軽減するには、1 秒あたりの増分同期の行数 RPS および 1 秒あたりの増分同期データ量 (MB) BPS を設定してください。

      環境タグ

      要件に基づいて、インスタンスを識別するための環境タグを選択できます。本例ではタグは不要です。

      順方向および逆方向タスクのハートビートテーブル SQL を削除

      DTS インスタンス実行中に、ハートビート SQL 情報をソースデータベースに書き込むかどうかを選択します。

      • :ハートビート SQL 情報はソースデータベースに書き込まれません。これにより、DTS インスタンスが遅延を報告する可能性があります。

      • ×:ハートビート SQL 情報をソースデータベースに書き込みます。これにより、ソースデータベースの物理バックアップやクローンなどの機能に干渉する可能性があります。

      ETL 機能の設定

      抽出・変換・書き出し (ETL) 機能を有効にするかどうかを選択します。詳細については、「ETL とは」をご参照ください。有効値:

      監視アラート

      アラートを設定するかどうかを指定します。同期が失敗した場合や、遅延が指定されたしきい値を超えた場合、アラート連絡先に通知が送信されます。

    3. オプション: 上記の設定を完了したら、次:データベースおよびテーブルのフィールド設定 をクリックして、宛先テーブルの プライマリキー列の追加配布キー、および エンジンの選択 を設定します。

      説明
      • このステップは、同期オブジェクトを設定する際に 同期タイプスキーマ同期 を選択した場合にのみ利用可能です。定義ステータスすべて に設定して設定を変更できます。

      • 複数の列を選択して複合 プライマリキー列の追加 を構成できます。また、プライマリキー列の追加 から 1 つ以上の列を選択して 配布キー として指定する必要があります。

      • プライマリキーも一意制約もないテーブルの場合、エンジンの選択duplicate を選択する必要があります。これを設定しないと、タスクが失敗したりデータ損失が発生したりする可能性があります。

  6. タスクを保存して事前チェックを実行します。

    • このインスタンスを設定するための API パラメーターを表示するには、次:タスク設定の保存と事前チェック ボタンにカーソルを合わせ、表示されるバルーンで OpenAPI パラメーターのプレビュー をクリックします。

    • API パラメーターの確認が完了したら、ページ下部の 次:タスク設定の保存と事前チェック をクリックします。

    説明
    • 同期ジョブ開始前に、DTS が事前チェックを実行します。すべての事前チェック項目が合格した場合にのみ、ジョブを開始できます。

    • 事前チェックに失敗した場合、失敗した項目の横にある 詳細を表示 をクリックします。表示された指示に従って問題を修正し、再度事前チェックを実行してください。

    • 事前チェックで警告が返された場合:

      • チェック項目が失敗し、無視できない場合は、項目の横にある 詳細を表示 をクリックします。指示に従って問題を修正し、再度事前チェックを実行してください。

      • 無視可能なチェック項目については、アラートの詳細を確認無視OK、および 再度事前チェックを実行 を順にクリックして警告をスキップし、事前チェックを再実行できます。警告項目を無視することを選択した場合、データの不整合などの問題が発生し、ビジネスにリスクをもたらす可能性があります。

  7. インスタンスを購入します。

    1. [成功率] が 100 % になったら、次:インスタンスの購入 をクリックします。

    2. 購入 ページで、データ同期インスタンスの課金方法およびリンク仕様を選択します。以下の表にこれらのパラメーターの詳細を示します。

      カテゴリ

      パラメーター

      説明

      新しいインスタンスクラス

      課金方法

      • サブスクリプション:インスタンス作成時に支払いが発生します。長期的なニーズに適しており、従量課金よりもコスト効率が高くなります。サブスクリプション期間が長いほど割引率が高くなります。

      • 従量課金:1 時間単位で課金されます。短期的なニーズに適しています。使用後すぐにインスタンスをリリースすることでコストを節約できます。

      リソースグループ設定

      インスタンスが属するリソースグループです。デフォルトはデフォルトリソースグループです。詳細については、「Resource Management とは」をご参照ください。

      リンク仕様

      DTS は、さまざまなパフォーマンスレベルを持つ同期仕様を提供しています。同期リンク仕様は同期レートに影響します。ビジネスシナリオに基づいて仕様を選択できます。詳細については、「データ同期リンク仕様」をご参照ください。

      サブスクリプション期間

      サブスクリプションモードでは、サブスクリプションインスタンスの期間および数量を選択します。1 ~ 9 ヶ月の月額サブスクリプション、または 1、2、3、5 年の年額サブスクリプションを選択できます。

      説明

      このオプションは、課金方法が サブスクリプション の場合にのみ利用可能です。

    3. 設定を完了したら、Data Transmission Service (従量課金) 利用規約 を読み、同意してください。

    4. 購入して起動 をクリックします。OK ダイアログボックスで、OK をクリックします。

      データ同期ページでタスクの進行状況を確認できます。

データ型マッピング

カテゴリ

MySQL 型

SelectDB 型

NUMERIC

TINYINT

TINYINT

TINYINT UNSIGNED

SMALLINT

SMALLINT

SMALLINT

SMALLINT UNSIGNED

INT

MEDIUMINT

INT

MEDIUMINT UNSIGNED

BIGINT

INT

INT

INT UNSIGNED

BIGINT

BIGINT

BIGINT

BIGINT UNSIGNED

LARGEINT

BIT(M)

INT

DECIMAL

DECIMAL

説明

ZEROFILL はサポートされていません。

NUMERIC

Decimal

FLOAT

FLOAT

DOUBLE

DOUBLE

  • BOOL

  • BOOLEAN

BOOLEAN

日付および時刻

DATE

DATEV2

DATETIME[(fsp)]

DATETIMEV2

TIMESTAMP[(fsp)]

DATETIMEV2

TIME[(fsp)]

VARCHAR

YEAR[(4)]

INT

文字列

  • CHAR

  • VARCHAR

VARCHAR

重要

データ損失を防ぐため、CHAR および VARCHAR(n) データは、宛先 ApsaraDB for SelectDB インスタンスに同期する際に VARCHAR(4*n) に変換されます。

  • データ長が指定されていない場合、デフォルトは VARCHAR(65533) です。

  • データ長が 65533 を超える場合、データは STRING に変換されます。

  • BINARY

  • VARBINARY

STRING

  • TINYTEXT

  • TEXT

  • MEDIUMTEXT

  • LONGTEXT

STRING

  • TINYBLOB

  • BLOB

  • MEDIUMBLOB

  • LONGBLOB

STRING

ENUM

STRING

SET

STRING

JSON

STRING

追加列

説明

この表は、DTS が自動的に追加する列、または宛先の duplicate モデルテーブルに手動で追加する必要がある列を示しています。

パラメーター

デフォルト

説明

_is_deleted

Int

0

行が削除されたかどうかを示します。

  • Insert:値は 0 です。

  • Update:値は 0 です。

  • Delete:値は 1 です。

_version

Bigint

0

  • 完全同期からのデータの場合、値は 0 です。

  • 増分同期からのデータの場合、値はソースデータベースのバイナリログからの変更のコミットタイムスタンプ(秒単位)です。

_record_id

Bigint

0

  • 完全同期からのデータの場合、値は 0 です。

  • 増分同期からのデータの場合、値は増分ログからのレコード ID です。この ID はログエントリを一意に識別します。

    説明

    ID は一意であり、単調増加します。