ApsaraDB for SelectDB は、大規模データセットに対するサブ秒単位のクエリ応答、数万件の同時ポイントクエリ、および高スループットの複雑な分析をサポートします。Data Transmission Service (DTS) は、自己管理 MySQL データベースや ApsaraDB RDS for MySQL インスタンスなどの MySQL ソースから ApsaraDB for SelectDB インスタンスへデータを同期し、大規模データ分析を実現します。本トピックでは、ApsaraDB RDS for MySQL インスタンスを例に、その手順を説明します。
前提条件
ソース ApsaraDB RDS for MySQL インスタンスで使用されているストレージ容量を超えるストレージスペースを持つターゲット ApsaraDB for SelectDB インスタンスを作成済みである必要があります。詳細については、「インスタンスの作成」をご参照ください。
考慮事項
|
種別 |
説明 |
|
ソースデータベースの制限 |
|
|
その他の制限 |
|
|
特殊なケース |
|
課金
|
同期タイプ |
料金 |
|
スキーマ同期および完全データ同期 |
無料です。 |
|
増分データ同期 |
課金対象です。詳細については、「課金概要」をご参照ください。 |
増分同期の SQL
|
操作タイプ |
SQL ステートメント |
|
DML |
INSERT、UPDATE、DELETE |
|
DDL |
|
データベースアカウント権限
|
データベース |
必要な権限 |
操作 |
|
ソース ApsaraDB RDS for MySQL |
同期対象オブジェクトに対する読み取りおよび書き込み権限 |
アカウントの作成 および アカウント権限の変更 |
|
ターゲット ApsaraDB for SelectDB インスタンス |
クラスターへのアクセス権限 (Usage_priv) およびデータベースに対する読み取り・書き込み権限 (Select_priv、Load_priv、Alter_priv、Create_priv、Drop_priv) |
クラスター権限の管理 および 基本権限の管理 |
ApsaraDB RDS for MySQL コンソール以外でソースデータベースアカウントを作成した場合、REPLICATION CLIENT、REPLICATION SLAVE、SHOW VIEW、SELECT 権限が付与されていることを確認してください。
操作手順
-
宛先リージョンの同期タスクリストページに移動します。次の 2 つの方法のいずれかを使用できます。
DTS コンソールから
-
Data Transmission Service (DTS) コンソール にログインします。
-
左側のナビゲーションウィンドウで、データ同期 をクリックします。
-
ページ左上隅で、同期インスタンスが配置されているリージョンを選択します。
DMS コンソールから
説明実際の操作は、DMS コンソールのモードおよびレイアウトによって異なる場合があります。詳細については、「シンプルモード」および「DMS インターフェイスのレイアウトとスタイルのカスタマイズ」をご参照ください。
-
Data Management (DMS) にログインします。
-
トップメニューバーで、 を選択します。
-
データ同期タスク の右側で、同期インスタンスが配置されているリージョンを選択します。
-
-
タスクの作成 をクリックして、タスク設定ページに移動します。
-
ソースおよびターゲットデータベースを設定します。
セクション
パラメーター
説明
該当なし
タスク名
DTS が自動的にタスク名を生成します。識別しやすいように、わかりやすい名前を指定することを推奨します。名前は一意である必要はありません。
移行元データベース
既存の接続情報の選択
-
システムに追加済み(新規作成または保存済み)のデータベースインスタンスを使用する場合、ドロップダウンリストからデータベースインスタンスを選択します。データベース情報は自動的に設定されます。
説明DMS コンソールでは、この設定項目の名前は DMS データベースインスタンスの選択 です。
-
データベースインスタンスをシステムに追加していない場合、またはすでに追加済みのインスタンスを使用しない場合は、以下のデータベース情報を手動で設定します。
データベースタイプ
MySQL を選択します。
アクセス方法
Alibaba Cloud インスタンス を選択します。
インスタンスのリージョン
ソース ApsaraDB RDS for MySQL インスタンスのリージョンを選択します。
Alibaba Cloud アカウント間でデータを複製
本例では、同じ Alibaba Cloud アカウント内でデータを同期します。× を選択します。
RDS インスタンス ID
ソース ApsaraDB RDS for MySQL インスタンスの ID を選択します。
データベースアカウント
ソース ApsaraDB RDS for MySQL インスタンスのデータベースアカウントを入力します。必要な権限については、「データベースアカウントに必要な権限」をご参照ください。
データベースのパスワード
データベースアカウントに対応するパスワードを入力します。
暗号化
必要に応じて、非暗号化 または SSL 暗号化 を選択します。SSL 暗号化 を選択する場合、事前に RDS for MySQL インスタンスで SSL 暗号化を有効にする必要があります。詳細については、「クラウド証明書を使用した SSL 暗号化の迅速な有効化」をご参照ください。
移行先データベース
既存の接続情報の選択
-
システムに追加済み(新規作成または保存済み)のデータベースインスタンスを使用する場合、ドロップダウンリストからデータベースインスタンスを選択します。データベース情報は自動的に設定されます。
説明DMS コンソールでは、この設定項目の名前は DMS データベースインスタンスの選択 です。
-
データベースインスタンスをシステムに追加していない場合、またはすでに追加済みのインスタンスを使用しない場合は、以下のデータベース情報を手動で設定します。
データベースタイプ
ApsaraDB for SelectDB を選択します。
アクセス方法
Alibaba Cloud インスタンス を選択します。
インスタンスのリージョン
ターゲット ApsaraDB for SelectDB インスタンスのリージョンを選択します。
Alibaba Cloud アカウント間でデータを複製
本例では、同じ Alibaba Cloud アカウント内でデータを同期します。× を選択します。
インスタンス ID
ターゲット ApsaraDB for SelectDB インスタンスの ID を選択します。
データベースアカウント
ターゲット ApsaraDB for SelectDB インスタンスのデータベースアカウントを入力します。必要な権限については、「データベースアカウントに必要な権限」をご参照ください。
データベースのパスワード
データベースアカウントに対応するパスワードを入力します。
-
-
設定が完了したら、ページ下部の 接続をテストして続行 をクリックします。
説明-
DTS サーバーからのアクセスを許可するために、ソースおよびターゲットデータベースのセキュリティ設定に DTS サーバーの IP アドレス CIDR ブロックを追加してください。これは自動または手動で行えます。詳細については、「DTS サーバーの IP アドレス CIDR ブロックをホワイトリストに追加」をご参照ください。
-
ソースまたはターゲットデータベースが自己管理データベース(アクセス方法 が Alibaba Cloud インスタンス ではない)の場合、DTS サーバーの CIDR ブロック ダイアログボックスで 接続テスト をクリックする必要があります。
-
-
タスクオブジェクトを設定します。
-
オブジェクト設定 ページで、同期対象オブジェクトを設定します。
パラメーター
説明
同期タイプ
増分データ同期 が選択されています。デフォルトでは、スキーマ同期 および 完全データ同期 も選択する必要があります。事前チェック完了後、DTS は選択したオブジェクトをソースインスタンスから宛先クラスターに完全同期し、これを以降の増分データ同期のベースラインデータとします。
競合するテーブルの処理モード
-
エラーの事前チェックと報告:DTS は宛先データベースに同名のテーブルがあるかどうかをチェックします。競合が存在する場合、事前チェックでエラーを報告し、タスクを開始しません。
説明競合テーブルを削除または名前変更することが実用的でない場合、テーブルを別の名前にマッピングできます。詳細については、「オブジェクト名のマッピング」をご参照ください。
-
エラーを無視して続行:宛先データベースに同名のテーブルがあるかどうかのチェックをスキップします。
警告エラーを無視して続行 を選択すると、データの不整合が発生する可能性があります。たとえば:
-
テーブルスキーマが一致している場合、ソースレコードと同じプライマリキーまたは一意キーを持つ宛先レコードが上書きされます。
-
テーブルスキーマが一致していない場合、タスクが失敗するか、一部のデータのみが同期される可能性があります。慎重に操作してください。
-
移行先インスタンスでのオブジェクト名の大文字化
宛先インスタンスに同期されるデータベース、テーブル、列オブジェクト名の大文字小文字区別ポリシーを設定できます。デフォルトでは、DTS のデフォルトポリシー が選択されています。ソースおよび宛先データベースのデフォルトポリシーを使用することもできます。詳細については、「宛先オブジェクト名の大文字小文字区別ポリシー」をご参照ください。
ソースオブジェクト
ソースオブジェクト ボックスで、同期対象のオブジェクトをクリックし、
をクリックして 選択中のオブジェクト ボックスに移動させます。説明データベースレベルまたはテーブルレベルでオブジェクトを選択できます。
選択中のオブジェクト
-
宛先インスタンスにおける同期オブジェクトの名前を変更するには、選択中のオブジェクト ボックスでオブジェクトを右クリックします。詳細については、「オブジェクト名のマッピング」をご参照ください。
-
同期タイプ で スキーマ同期 を選択し、テーブルを同期オブジェクトとして選択し、バケット数(
bucket_countパラメーター)を設定する必要がある場合、選択中のオブジェクト ボックスでテーブルを右クリックします。パラメーター設定 セクションで、パラメーター設定の有効化 を ○ に設定し、要件に基づいて パラメーター値 を指定してから、OK をクリックします。
説明-
データベースまたはテーブルレベルで同期する増分 SQL 操作を選択するには、選択中のオブジェクト ボックスでオブジェクトを右クリックし、表示されるダイアログボックスで目的の SQL 操作を選択します。
-
WHERE 句を使用してデータをフィルターするには、選択中のオブジェクト ボックスでテーブルを右クリックし、表示されるダイアログボックスでフィルター条件を設定します。詳細については、「フィルター条件の設定」をご参照ください。
-
オブジェクト名マッピング機能を使用する場合、名前変更されたオブジェクトに依存する他のオブジェクトの同期が失敗する可能性があります。
-
-
詳細設定へ をクリックして、高度なパラメーターを設定します。
パラメーター
説明
タスクのスケジュールに使用する専用クラスターの選択
デフォルトでは、DTS は共有クラスター上でタスクをスケジューリングするため、クラスターを選択する必要はありません。より安定したパフォーマンスが必要な場合は、DTS 同期タスクを実行するための専用クラスターを購入できます。詳細については、「DTS 専用クラスターとは」をご参照ください。
失敗した接続の再試行時間
同期タスク開始後、ソースまたはターゲットデータベースへの接続が失敗した場合、DTS はエラーを報告し、直ちに接続の再試行を開始します。デフォルトの再試行時間は 720 分です。10 ~ 1,440 分の範囲でカスタム再試行時間を指定することもできます。30 分以上に設定することを推奨します。指定された時間内に DTS がデータベースへの再接続に成功した場合、同期タスクは自動的に再開されます。そうでない場合、タスクは失敗します。
説明-
同じソースまたはターゲットを共有する複数の DTS インスタンス(例:インスタンス A とインスタンス B)があり、インスタンス A のネットワーク再試行時間を 30 分、インスタンス B を 60 分に設定した場合、両方に短い方の 30 分が適用されます。
-
DTS は接続再試行期間中のタスク実行時間に対して課金するため、ビジネス要件に基づいて再試行時間をカスタマイズするか、ソースおよびターゲットデータベースインスタンスをリリースした後は速やかに DTS インスタンスをリリースすることを推奨します。
移行元データベースと移行先データベースで他の問題が発生した場合の、再試行までの待機時間です。
同期タスク開始後、ソースまたはターゲットデータベースで接続以外の問題(DDL または DML 実行例外など)が発生した場合、DTS はエラーを報告し、直ちに継続的な再試行操作を開始します。デフォルトの再試行時間は 10 分です。1 ~ 1,440 分の範囲でカスタム再試行時間を設定することもできます。10 分以上に設定することを推奨します。設定された再試行時間内に関連操作が成功した場合、同期タスクは自動的に再開されます。そうでない場合、タスクは失敗します。
重要移行元データベースと移行先データベースで他の問題が発生した場合の、再試行までの待機時間です。 の値は、失敗した接続の再試行時間 の値より小さくする必要があります。
完全同期レートを制限するかどうか
完全同期ステージ中、DTS はソースおよびターゲットデータベースの読み取り・書き込みリソースを消費するため、データベース負荷が増加します。ソースおよびターゲットデータベースへの負荷を軽減するには、1 秒あたりのソースデータベースのクエリ率 QPS、1 秒あたりの完全移行の行数 RPS、および 1 秒あたりの完全移行データ量 (MB) BPS パラメーターを設定して、完全同期タスクのレート制限を設定できます。
説明-
この設定項目は、同期タイプ が 完全データ同期 に設定されている場合にのみ利用可能です。
-
同期インスタンス実行後も、完全同期レートを調整 できます。
増分同期率を制限するかどうか
増分同期タスクのレート制限も設定できます。宛先データベースへの負荷を軽減するには、1 秒あたりの増分同期の行数 RPS および 1 秒あたりの増分同期データ量 (MB) BPS を設定してください。
環境タグ
要件に基づいて、インスタンスを識別するための環境タグを選択できます。本例ではタグは不要です。
順方向および逆方向タスクのハートビートテーブル SQL を削除
DTS インスタンス実行中に、ハートビート SQL 情報をソースデータベースに書き込むかどうかを選択します。
-
○:ハートビート SQL 情報はソースデータベースに書き込まれません。これにより、DTS インスタンスが遅延を報告する可能性があります。
-
×:ハートビート SQL 情報をソースデータベースに書き込みます。これにより、ソースデータベースの物理バックアップやクローンなどの機能に干渉する可能性があります。
ETL 機能の設定
抽出・変換・書き出し (ETL) 機能を有効にするかどうかを選択します。詳細については、「ETL とは」をご参照ください。有効値:
-
○:ETL 機能を有効にします。コードエディタにデータ処理文を入力します。詳細については、「データ移行またはデータ同期タスクでの ETL の設定」をご参照ください。
-
×:ETL 機能を無効にします。
監視アラート
アラートを設定するかどうかを指定します。同期が失敗した場合や、遅延が指定されたしきい値を超えた場合、アラート連絡先に通知が送信されます。
-
×:アラートは設定されません。
-
○:アラートのしきい値を設定し、アラート通知 を指定してアラートを設定します。詳細については、「タスク設定時のモニタリングとアラートの設定」をご参照ください。
-
-
オプション: 上記の設定を完了したら、次:データベースおよびテーブルのフィールド設定 をクリックして、宛先テーブルの プライマリキー列の追加、配布キー、および エンジンの選択 を設定します。
説明-
このステップは、同期オブジェクトを設定する際に 同期タイプ で スキーマ同期 を選択した場合にのみ利用可能です。定義ステータス を すべて に設定して設定を変更できます。
-
複数の列を選択して複合 プライマリキー列の追加 を構成できます。また、プライマリキー列の追加 から 1 つ以上の列を選択して 配布キー として指定する必要があります。
-
プライマリキーも一意制約もないテーブルの場合、エンジンの選択 に duplicate を選択する必要があります。これを設定しないと、タスクが失敗したりデータ損失が発生したりする可能性があります。
-
-
-
タスクを保存して事前チェックを実行します。
-
このインスタンスを設定するための API パラメーターを表示するには、次:タスク設定の保存と事前チェック ボタンにカーソルを合わせ、表示されるバルーンで OpenAPI パラメーターのプレビュー をクリックします。
-
API パラメーターの確認が完了したら、ページ下部の 次:タスク設定の保存と事前チェック をクリックします。
説明-
同期ジョブ開始前に、DTS が事前チェックを実行します。すべての事前チェック項目が合格した場合にのみ、ジョブを開始できます。
-
事前チェックに失敗した場合、失敗した項目の横にある 詳細を表示 をクリックします。表示された指示に従って問題を修正し、再度事前チェックを実行してください。
-
事前チェックで警告が返された場合:
-
チェック項目が失敗し、無視できない場合は、項目の横にある 詳細を表示 をクリックします。指示に従って問題を修正し、再度事前チェックを実行してください。
-
無視可能なチェック項目については、アラートの詳細を確認、無視、OK、および 再度事前チェックを実行 を順にクリックして警告をスキップし、事前チェックを再実行できます。警告項目を無視することを選択した場合、データの不整合などの問題が発生し、ビジネスにリスクをもたらす可能性があります。
-
-
-
インスタンスを購入します。
-
[成功率] が 100 % になったら、次:インスタンスの購入 をクリックします。
-
購入 ページで、データ同期インスタンスの課金方法およびリンク仕様を選択します。以下の表にこれらのパラメーターの詳細を示します。
カテゴリ
パラメーター
説明
新しいインスタンスクラス
課金方法
-
サブスクリプション:インスタンス作成時に支払いが発生します。長期的なニーズに適しており、従量課金よりもコスト効率が高くなります。サブスクリプション期間が長いほど割引率が高くなります。
-
従量課金:1 時間単位で課金されます。短期的なニーズに適しています。使用後すぐにインスタンスをリリースすることでコストを節約できます。
リソースグループ設定
インスタンスが属するリソースグループです。デフォルトはデフォルトリソースグループです。詳細については、「Resource Management とは」をご参照ください。
リンク仕様
DTS は、さまざまなパフォーマンスレベルを持つ同期仕様を提供しています。同期リンク仕様は同期レートに影響します。ビジネスシナリオに基づいて仕様を選択できます。詳細については、「データ同期リンク仕様」をご参照ください。
サブスクリプション期間
サブスクリプションモードでは、サブスクリプションインスタンスの期間および数量を選択します。1 ~ 9 ヶ月の月額サブスクリプション、または 1、2、3、5 年の年額サブスクリプションを選択できます。
説明このオプションは、課金方法が サブスクリプション の場合にのみ利用可能です。
-
-
設定を完了したら、Data Transmission Service (従量課金) 利用規約 を読み、同意してください。
-
購入して起動 をクリックします。OK ダイアログボックスで、OK をクリックします。
データ同期ページでタスクの進行状況を確認できます。
-
データ型マッピング
|
カテゴリ |
MySQL 型 |
SelectDB 型 |
|
NUMERIC |
TINYINT |
TINYINT |
|
TINYINT UNSIGNED |
SMALLINT |
|
|
SMALLINT |
SMALLINT |
|
|
SMALLINT UNSIGNED |
INT |
|
|
MEDIUMINT |
INT |
|
|
MEDIUMINT UNSIGNED |
BIGINT |
|
|
INT |
INT |
|
|
INT UNSIGNED |
BIGINT |
|
|
BIGINT |
BIGINT |
|
|
BIGINT UNSIGNED |
LARGEINT |
|
|
BIT(M) |
INT |
|
|
DECIMAL |
DECIMAL 説明
ZEROFILL はサポートされていません。 |
|
|
NUMERIC |
Decimal |
|
|
FLOAT |
FLOAT |
|
|
DOUBLE |
DOUBLE |
|
|
BOOLEAN |
|
|
日付および時刻 |
DATE |
DATEV2 |
|
DATETIME[(fsp)] |
DATETIMEV2 |
|
|
TIMESTAMP[(fsp)] |
DATETIMEV2 |
|
|
TIME[(fsp)] |
VARCHAR |
|
|
YEAR[(4)] |
INT |
|
|
文字列 |
|
VARCHAR 重要
データ損失を防ぐため、CHAR および VARCHAR(n) データは、宛先 ApsaraDB for SelectDB インスタンスに同期する際に VARCHAR(4*n) に変換されます。
|
|
STRING |
|
|
STRING |
|
|
STRING |
|
|
ENUM |
STRING |
|
|
SET |
STRING |
|
|
JSON |
STRING |
追加列
この表は、DTS が自動的に追加する列、または宛先の duplicate モデルテーブルに手動で追加する必要がある列を示しています。
|
パラメーター |
型 |
デフォルト |
説明 |
|
_is_deleted |
Int |
0 |
行が削除されたかどうかを示します。
|
|
_version |
Bigint |
0 |
|
|
_record_id |
Bigint |
0 |
|