すべてのプロダクト
Search
ドキュメントセンター

Data Transmission Service:RDS for MySQL から Elasticsearch への同期

最終更新日:Jul 18, 2026

このトピックでは、ApsaraDB RDS for MySQL インスタンスから Elasticsearch クラスターへデータを同期するために Data Transmission Service (DTS) を使用する方法について説明します。

前提条件

  • ターゲットの Elasticsearch クラスターが必要です。詳細については、「Alibaba Cloud Elasticsearch クラスターの作成」をご参照ください。

  • ターゲットの Elasticsearch クラスターの利用可能なストレージ容量は、ソースの ApsaraDB RDS for MySQL インスタンスで使用されているストレージ容量を超える必要があります。

注意事項

種別

説明

ソースデータベースの制限

  • 同期対象のテーブルにはプライマリキーまたは一意制約が存在し、フィールド値が一意である必要があります。そうでない場合、宛先データベースに重複データが発生する可能性があります。

  • テーブル単位で同期を行い、マッピング(列名マッピングなど)を編集する必要がある場合、1 つの同期タスクでサポートされるテーブル数は最大 1,000 件です。この上限を超えると、タスクはエラーで失敗します。これを修正するには、複数のタスクに分けてテーブルを割り当てるか、データベース全体の同期タスクを構成してください。

  • バイナリログ:

    • ApsaraDB RDS for MySQL では、デフォルトでバイナリロギングが有効になっています。binlog_row_image パラメーターが full に設定されていることを確認してください。設定されていない場合、事前チェックに失敗し、同期タスクを開始できません。手順については、「インスタンスパラメーターの設定」をご参照ください。

      重要
      • ソースインスタンスが自己管理 MySQL データベースの場合、バイナリロギングを有効にし、binlog_format を row に、binlog_row_image を full に設定してください。

      • 自己管理 MySQL データベースがデュアルプライマリクラスター(両ノードがプライマリおよびセカンダリとして動作)の場合、log_slave_updates パラメーターを有効にして、DTS がすべてのバイナリログイベントをキャプチャできるようにしてください。手順については、「自己管理 MySQL データベースのアカウント作成とバイナリロギング設定」をご参照ください。

    • ApsaraDB RDS for MySQL インスタンスのローカルバイナリログは、少なくとも 3 日間(推奨は 7 日間)保持する必要があります。自己管理 MySQL データベースの場合は、ローカルバイナリログを少なくとも 7 日間保持してください。保持期間が短いと、DTS がバイナリログを取得できず、タスクが失敗する可能性があります。最悪の場合、データの不整合やデータ損失が発生する可能性があります。DTS が要求するよりも短いバイナリログ保持期間に起因する問題は、DTS の SLA の適用外となります。

      説明

      ApsaraDB RDS for MySQL インスタンスのローカルバイナリログの保持期間を設定するには、「ローカルログの自動削除」をご参照ください。

  • スキーマ同期または完全同期中に、データベースまたはテーブルスキーマを変更する DDL 操作を実行しないでください。実行すると、同期タスクが失敗します。

    説明

    完全同期中、DTS はソースデータベースに対してクエリを実行します。これによりメタデータロックが発生し、ソースデータベースでの DDL 操作がブロックされる可能性があります。

  • バイナリログに書き込まれない変更(物理バックアップからの復元やカスケード操作によって生成されたデータなど)によって生成されたデータは、宛先データベースに同期されません。

    説明

    このような状況が発生した場合は、影響を受けたデータベースまたはテーブルを同期オブジェクトから除外し、その後再度追加してください。ただし、これはビジネス要件で許容される場合に限ります。詳細については、「同期オブジェクトの変更」をご参照ください。

  • ソースデータベースが MySQL 8.0.23 以降で、非表示の隠し列が含まれている場合、DTS がこれらの列を読み取らない可能性があります。これによりデータ損失が発生する可能性があります。

    説明

    ALTER TABLE <table_name> ALTER COLUMN <column_name> SET VISIBLE; コマンドを実行して、隠し列を表示可能にしてください。詳細については、「Invisible Columns」をご参照ください。

  • MySQL 互換性:DTS が MySQL ファミリーのソースデータベースからデータを同期する際には、標準的な MySQL プロトコルおよび Binlog フォーマットに依存しており、標準 MySQL と互換性のない動作はサポートされていません。ソースデータベースが MySQL 互換を謳っていても MySQL とは異なる動作をする場合(例:OceanBase を MySQL モードでソースとして接続した際に、Binlog 内の末尾 rotate イベントのタイムスタンプが 0 になるなど)、DTS 同期タスクが失敗する可能性があります。

その他の制限

  • DTS は、インデックス、パーティション、ビュー、ストアドプロシージャ、関数、トリガー、外部キーの同期をサポートしていません。

  • Elasticsearch インデックスに親子関係またはJoin フィールドタイプが含まれる場合、データを同期することはできません。これを行うと、タスクエラーまたは宛先でのクエリ失敗が発生する可能性があります。

  • 同期を開始する前に、ソースおよび宛先データベースのパフォーマンスを評価してください。オフピーク時間帯に同期を実行することを推奨します。そうしないと、完全初期化時に両方のデータベースの読み取りおよび書き込みリソースが消費され、データベース負荷が増大する可能性があります。

  • 完全初期化は INSERT 操作を並行して実行します。これにより宛先テーブルがフラグメント化されます。完全初期化後、宛先インスタンスの表領域はソースインスタンスよりも大きくなります。

  • データベース全体ではなく 1 つ以上のテーブルを同期する場合、pt-online-schema-change などのツールを使用してソーステーブルでオンライン DDL 操作を実行しないでください。実行すると、同期が失敗します。

  • ソーステーブルに列を追加する必要がある場合は、まず Elasticsearch インスタンス内の対応するマッピングを変更します。次に、ソース MySQL データベースで DDL 操作を実行します。最後に、DTS 同期タスクを一時停止して再開します。

  • 同期実行中は、DTS 以外の手段で宛先データベースにデータを書き込まないでください。書き込むと、ソースおよび宛先データベース間にデータの不整合が発生する可能性があります。たとえば、DMS を使用してオンライン DDL 操作を実行している間に他のデータが宛先データベースに書き込まれると、データ損失が発生する可能性があります。

  • MySQL から Elasticsearch に同期されるデータに null 文字が含まれている場合、DTS はそれらを LONG 型の値に変換します。これによりタスクが失敗します。

  • MySQL から Elasticsearch に同期されるデータに緯度と経度の値が逆になった位置情報が含まれている場合、Elasticsearch への書き込みが失敗します。

  • Elasticsearch インスタンスの開発およびテスト仕様はサポートされていません。

  • ApsaraDB RDS for MySQL インスタンスで Always-Encrypted が有効になっている場合、完全データ同期はサポートされていません。

    説明

    透過的データ暗号化 (TDE) が有効になっている ApsaraDB RDS for MySQL インスタンスは、スキーマ同期、完全データ同期、および増分データ同期をサポートしています。

  • タスクが失敗した場合、DTS サポートスタッフは 8 時間以内に復旧を試みます。復旧中、タスクを再起動したり、パラメーターを調整したりする可能性があります。

    説明

    データベースパラメーターではなく、DTS タスクパラメーターのみが変更されます。 調整対象となるパラメーターは、「インスタンスパラメーターの変更」に記載されています。

特殊なケース

  • 自己管理 MySQL ソースデータベースの場合:

    • 同期中にソースデータベースでプライマリ/セカンダリ スイッチオーバーが発生すると、タスクは失敗します。

    • DTS は、最後に同期されたレコードのタイムスタンプと現在時刻を比較して遅延を計算します。ソースデータベースで長時間 DML 操作が実行されない場合、遅延レポートが不正確になる可能性があります。遅延が過剰に表示される場合は、ソースデータベースで DML 操作を実行して遅延を更新してください。

      説明

      データベース全体を同期対象に選択する場合は、ハートビートテーブルを作成してください。このテーブルを毎秒更新または書き込みを行ってください。

    • DTS は、バイナリログオフセットを進めるために、ソースデータベースで定期的に CREATE DATABASE IF NOT EXISTS `test` コマンドを実行します。

    • Amazon Aurora MySQL またはその他のクラスタ化された MySQL インスタンスをソースデータベースとして使用する場合は、タスク構成で使用するドメイン名または IP アドレス、およびその DNS 解決が常に読み取り/書き込み (RW) ノードを指すようにしてください。そうでないと、同期が失敗する可能性があります。

  • ApsaraDB RDS for MySQL ソースデータベースの場合:

    • トランザクションログを記録しない読み取り専用インスタンス(例:ApsaraDB RDS for MySQL 5.6 読み取り専用インスタンス)は、ソースデータベースとして使用できません。

    • DTS は、バイナリログオフセットを進めるために、ソースデータベースで定期的に CREATE DATABASE IF NOT EXISTS `test` コマンドを実行します。

課金

同期タイプ

料金

スキーマ同期および完全データ同期

無料です。

増分データ同期

課金対象です。詳細については、「課金概要」をご参照ください。

同期された SQL 操作

操作タイプ

SQL ステートメント

DML

INSERT、UPDATE、DELETE

説明

UPDATE による列の削除は同期されません。

データベースアカウント権限

データベース

権限

操作

ソース ApsaraDB RDS for MySQL インスタンス

同期対象オブジェクトに対する読み取り権限。

「アカウントの作成」および「アカウント権限の変更」を行います。

宛先 Elasticsearch インスタンス

Elasticsearch インスタンス作成時に設定したユーザー名(デフォルトは elastic)およびパスワード。

説明

ApsaraDB RDS for MySQL コンソール外で作成されたソースデータベースアカウントには、REPLICATION CLIENT、REPLICATION SLAVE、SHOW VIEW、および SELECT 権限が付与されていることを確認してください。

データ型のマッピング

  • ソースデータベースと Elasticsearch インスタンスではサポートされるデータ型が異なり、常に直接マッピングできるとは限りません。構造初期化中、DTS はターゲット Elasticsearch インスタンスでサポートされているデータ型に基づいてマッピングを行います。詳細については、「構造初期化時のデータ型マッピング」をご参照ください。

    説明

    DTS のスキーマ移行プロセス中、DTS は dynamic パラメーターを mapping に設定しません。このパラメーターの動作は、ご利用の Elasticsearch インスタンスの設定に依存します。ソースデータが JSON 型の場合、特定のキーに対応する値がテーブル内のすべての行で同じデータ型を持つことを保証する必要があります。そうでないと、DTS で同期に関する問題が発生する可能性があります。詳細については、「dynamic」をご参照ください。

  • Elasticsearch とリレーショナルデータベースのマッピングは、Elasticsearch のバージョンによって異なります。

    重要

    Elasticsearch 7.0 以降では、インデックスが複数のタイプをサポートしなくなり、Elasticsearch 8.0 ではタイプが完全に廃止されました。デフォルトでは、同期または移行タスクを構成する際に、DTS はリレーショナルデータベースのテーブルを Elasticsearch のインデックスにマッピングします。同期または移行対象オブジェクトを構成する際に、このマッピングを変更できます。

    Elasticsearch 7.0 以降

    Elasticsearch

    リレーショナルデータベース

    インデックス

    テーブル

    ドキュメント

    行

    フィールド

    列

    マッピング

    スキーマ

    Elasticsearch 7.0 より前のバージョン

    Elasticsearch

    リレーショナルデータベース

    index

    database

    type

    table

    document

    row

    field

    column

    mapping

    schema

操作手順

  1. 宛先リージョンの同期タスクリストページに移動します。以下の 2 つの方法のいずれかを使用できます。

    DTS コンソールから

    1. Data Transmission Service (DTS) コンソールにログインします。

    2. 左側のナビゲーションウィンドウで、データ同期 をクリックします。

    3. ページ左上隅で、同期インスタンスが配置されているリージョンを選択します。

    DMS コンソールから

    説明

    実際の操作は、DMS コンソールのモードおよびレイアウトによって異なる場合があります。詳細については、「シンプルモード」および「DMS インターフェイスのレイアウトとスタイルのカスタマイズ」をご参照ください。

    1. Data Management (DMS) にログインします。

    2. 上部メニューバーで、Data + AI > Data Transmission (DTS) > データ同期 を選択します。

    3. データ同期タスク の右側で、同期インスタンスが配置されているリージョンを選択します。

  2. タスクの作成 をクリックして、タスク設定ページを開きます。

  3. ソースおよび宛先データベースを設定します。

    カテゴリ

    パラメーター

    説明

    該当なし

    タスク名

    DTS が自動的にタスク名を生成します。識別しやすいように、わかりやすい名前を指定することを推奨します。名前は一意である必要はありません。

    ソースデータベース

    既存の接続情報の選択

    • システムに追加済み(新規作成または保存済み)のデータベースインスタンスを使用する場合は、ドロップダウンリストからデータベースインスタンスを選択します。データベース情報は自動的に設定されます。

      説明

      DMS コンソールでは、この設定項目の名前は DMS データベースインスタンスの選択 です。

    • データベースインスタンスをシステムに追加していない場合、またはすでに追加済みのインスタンスを使用しない場合は、以下のデータベース情報を手動で設定します。

    データベースタイプ

    MySQL を選択します。

    アクセス方法

    Alibaba Cloud インスタンス を選択します。

    インスタンスリージョン

    ソース ApsaraDB RDS for MySQL インスタンスが配置されているリージョンを選択します。

    Alibaba Cloud アカウント間でデータを複製

    この例では、同じ Alibaba Cloud アカウント内でデータを同期します。× を選択します。

    RDS インスタンス ID

    ソース ApsaraDB RDS for MySQL インスタンスの ID を選択します。

    データベースアカウント

    ソース ApsaraDB RDS for MySQL インスタンスのデータベースアカウントを入力します。必要な権限の詳細については、「データベースアカウントに必要な権限」をご参照ください。

    データベースパスワード

    データベースアカウントに対応するパスワードを入力します。

    暗号化

    必要に応じて、非暗号化 または SSL 暗号化 を選択します。SSL 暗号化 を選択する場合は、事前に RDS for MySQL インスタンスで SSL 暗号化を有効にしておく必要があります。詳細については、「クラウド証明書を使用した SSL 暗号化の迅速な有効化」をご参照ください。

    宛先データベース

    既存の接続情報の選択

    • システムに追加済み(新規作成または保存済み)のデータベースインスタンスを使用する場合は、ドロップダウンリストからデータベースインスタンスを選択します。データベース情報は自動的に設定されます。

      説明

      DMS コンソールでは、この設定項目の名前は DMS データベースインスタンスの選択 です。

    • データベースインスタンスをシステムに追加していない場合、またはすでに追加済みのインスタンスを使用しない場合は、以下のデータベース情報を手動で設定します。

    データベースタイプ

    Elasticsearch を選択します。

    アクセス方法

    Alibaba Cloud インスタンス を選択します。

    インスタンスリージョン

    宛先 Elasticsearch インスタンスが配置されているリージョンを選択します。

    タイプ

    クラスター または Serverless を必要に応じて選択します。

    インスタンス ID

    宛先 Elasticsearch インスタンスの ID を選択します。

    データベースアカウント

    Elasticsearch インスタンスに接続するために使用するアカウントを入力します。これは、Elasticsearch インスタンス作成時に指定した ユーザー名 です。デフォルトアカウントは elastic です。

    データベースパスワード

    データベースアカウントに対応するパスワードを入力します。

    暗号化

    必要に応じて、HTTP または HTTPS を選択します。

  4. 設定が完了したら、ページ下部の 接続をテストして続行 をクリックします。

    説明
    • DTS サーバーからのアクセスを許可するために、ソースおよび宛先データベースのセキュリティ設定に DTS サーバーの IP アドレス CIDR ブロックを追加する必要があります。これは自動または手動で行えます。詳細については、「DTS サーバーの IP アドレス CIDR ブロックをホワイトリストに追加する」をご参照ください。

    • ソースまたは宛先データベースが自己管理データベース(アクセス方法 が Alibaba Cloud インスタンス ではない)の場合、DTS サーバーの CIDR ブロック ダイアログボックスで 接続テスト をクリックする必要もあります。

  5. タスクオブジェクトを設定します。

    1. オブジェクト設定 ページで、同期対象オブジェクトを設定します。

      パラメーター

      説明

      同期タイプ

      同期タイプです。デフォルトでは、増分データ同期 が選択されています。スキーマ同期 および 完全データ同期 も選択する必要があります。事前チェックが完了すると、DTS は選択したオブジェクトの既存データをソースデータベースから宛先クラスターに同期します。既存データは、その後の増分同期の基盤となります。

      競合するテーブルの処理モード

      • エラーの事前チェックと報告:宛先データベースに同名のテーブルが存在するかどうかをチェックします。同名のテーブルが存在しない場合、事前チェックは合格します。同名のテーブルが存在する場合、事前チェックは失敗し、データ同期タスクは開始されません。

        説明

        宛先データベースで同名のテーブルを削除または名前変更できない場合は、別のテーブル名にマッピングできます。詳細については、「テーブル名および列名のマッピング」をご参照ください。

      • エラーを無視して続行:宛先データベースでの重複テーブル名のチェックをスキップします。

        警告

        エラーを無視して続行 を選択すると、データの不整合が発生し、ビジネスにリスクをもたらす可能性があります。例:

        • テーブルスキーマが同じで、宛先データベースのレコードがソースデータベースのレコードと同じプライマリキーまたは一意キー値を持つ場合:

          • 完全同期中、DTS は宛先クラスターのレコードを保持します。ソースデータベースの対応するレコードは同期されません。

          • 増分同期中、ソースデータベースのレコードが宛先データベースのレコードを上書きします。

        • テーブルスキーマが異なる場合、初期データ同期が失敗する可能性があります。これにより、一部の列データのみが同期されるか、同期が完全に失敗する可能性があります。慎重に操作してください。

      インデックス名

      • テーブル名 を選択すると、宛先 Elasticsearch インスタンスに作成されるインデックス名はテーブル名と同じになります。

      • データベース名_テーブル名 を選択すると、宛先 Elasticsearch インスタンスのインデックス名は、データベース名、アンダースコア (_)、テーブル名を連結したものになります。

      説明

      インデックス名マッピング設定は、すべてのテーブルに適用されます。

      移行先インスタンスでのオブジェクト名の大文字化

      宛先インスタンスに同期されるデータベース、テーブル、列オブジェクト名の大文字小文字の扱いポリシーを設定できます。デフォルトでは、DTS のデフォルトポリシー が選択されています。ソースおよび宛先データベースのデフォルトポリシーを使用することもできます。詳細については、「宛先オブジェクト名の大文字小文字の扱いポリシー」をご参照ください。

      ソースオブジェクト

      ソースオブジェクト ボックスで、同期対象のオブジェクトをクリックし、向右 をクリックして 選択中のオブジェクト ボックスに移動させます。

      説明

      同期対象としてテーブルまたはデータベースを選択できます。テーブルを選択した場合、ビュー、トリガー、ストアドプロシージャなどの他のオブジェクトタイプは同期されません。

      選択中のオブジェクト

      同期フィールドの名前を変更する必要がある場合は、選択中のオブジェクト ボックスで対応するテーブル名を右クリックし、宛先 Elasticsearch インスタンスのテーブルに対するインデックス名、タイプ名、その他の情報を指定して、OK をクリックします。詳細については、「個別のデータベース、テーブル、列名のマッピング」をご参照ください。

      説明
      • インデックス名およびタイプ名では、特殊文字としてアンダースコア (_) のみがサポートされています。

      • SQL 条件を設定して同期対象データをフィルターできます。条件を満たすデータのみが宛先インスタンスに同期されます。詳細については、「SQL 条件を使用したデータのフィルター」をご参照ください。

    2. 詳細設定へ をクリックして、高度なパラメーターを設定します。

      パラメーター

      説明

      タスクのスケジュールに使用する専用クラスターの選択

      デフォルトでは、DTS は共有クラスター上でタスクをスケジューリングするため、クラスターを選択する必要はありません。より安定したパフォーマンスを求める場合は、DTS 同期タスクを実行するための専用クラスターを購入できます。詳細については、「DTS 専用クラスターとは」をご参照ください。

      失敗した接続の再試行時間

      同期タスク開始後、ソースまたは宛先データベースへの接続が失敗した場合、DTS はエラーを報告し、直ちに再試行を開始します。デフォルトの再試行時間は 720 分です。10 ~ 1,440 分の範囲でカスタム再試行時間を指定することもできます。30 分以上に設定することを推奨します。指定された時間内に DTS がデータベースへの再接続に成功した場合、同期タスクは自動的に再開されます。そうでない場合、タスクは失敗します。

      説明
      • 同じソースまたは宛先を共有する複数の DTS インスタンス(例:インスタンス A とインスタンス B)があり、インスタンス A のネットワーク再試行時間を 30 分、インスタンス B を 60 分に設定した場合、両方に短い方の 30 分が適用されます。

      • DTS は接続再試行期間中もタスクランタイムに対して課金されるため、ビジネス要件に基づいて再試行時間をカスタマイズするか、ソースおよび宛先データベースインスタンスをリリースした後は速やかに DTS インスタンスをリリースすることを推奨します。

      移行元データベースと移行先データベースで他の問題が発生した場合の、再試行までの待機時間です。

      同期タスク開始後、ソースまたは宛先データベースで接続以外の問題(DDL または DML 実行例外など)が発生した場合、DTS はエラーを報告し、直ちに継続的な再試行操作を開始します。デフォルトの再試行時間は 10 分です。1 ~ 1,440 分の範囲でカスタム再試行時間を設定することもできます。10 分以上に設定することを推奨します。設定された再試行時間内に該当操作が成功した場合、同期タスクは自動的に再開されます。そうでない場合、タスクは失敗します。

      重要

      移行元データベースと移行先データベースで他の問題が発生した場合の、再試行までの待機時間です。 の値は、失敗した接続の再試行時間 の値より小さくする必要があります。

      完全同期レートを制限するかどうか

      完全同期フェーズ中、DTS はソースおよび宛先データベースの読み取りおよび書き込みリソースを消費し、データベース負荷が増大する可能性があります。ソースおよび宛先データベースの負荷を軽減するために、1 秒あたりのソースデータベースのクエリ率 QPS、1 秒あたりの完全移行の行数 RPS、および 1 秒あたりの完全移行データ量 (MB) BPS パラメーターを設定して、完全同期タスクのレート制限を設定できます。

      説明
      • この設定項目は、同期タイプ が 完全データ同期 に設定されている場合にのみ利用可能です。

      • 同期インスタンス実行後も、完全同期レートを調整 できます。

      増分同期率を制限するかどうか

      増分同期タスクのレート制限も設定できます。宛先データベースの負荷を軽減するために、1 秒あたりの増分同期の行数 RPS および 1 秒あたりの増分同期データ量 (MB) BPS を設定します。

      シャード構成

      宛先 Elasticsearch インスタンスのインデックスにおける最大シャード構成に基づいて、インデックスのプライマリシャード数およびレプリカシャード数を設定します。

      文字列インデックス

      宛先 Elasticsearch インスタンスに同期される文字列のインデックス方法を指定します。

      • analyzed:文字列はインデックス前に分析されます。特定のアナライザーも選択する必要があります。アナライザータイプおよびその機能の詳細については、「Analyzers」をご参照ください。

      • not analyzed:文字列は分析せずに元の値でインデックスされます。

      • no:文字列はインデックスされません。

      タイムゾーン

      DATETIME または TIMESTAMP データを宛先 Elasticsearch インスタンスに同期する際に、タイムゾーンを選択できます。

      説明

      宛先インスタンスの日時データ型にタイムゾーンが不要な場合は、事前に宛先インスタンスでこれらのデータ型のドキュメントタイプ (type) を設定する必要があります。

      DOCID

      このパラメーターを設定する必要はありません。DOCID はデフォルトでテーブルのプライマリキーになります。テーブルにプライマリキーがない場合、DOCID は Elasticsearch が自動生成する ID 列になります。

      環境タグ

      必要に応じて、インスタンスを識別するための環境タグを選択できます。この例では、タグを選択する必要はありません。

      ETL 機能の設定

      抽出・変換・書き出し (ETL) 機能を有効にするかどうかを選択します。詳細については、「ETL とは」をご参照ください。有効値:

      順方向および逆方向タスクのハートビートテーブル SQL を削除

      DTS インスタンス実行中に、ソースデータベースにハートビート SQL 情報を書き込むかどうかを選択します。

      • ○:ハートビート SQL 情報はソースデータベースに書き込まれません。これにより、DTS インスタンスが遅延を報告する可能性があります。

      • ×:ハートビート SQL 情報をソースデータベースに書き込みます。これにより、ソースデータベースの物理バックアップやクローンなどの機能に干渉する可能性があります。

      監視アラート

      アラートを設定するかどうかを指定します。同期が失敗した場合や遅延が指定されたしきい値を超えた場合、アラート連絡先に通知が送信されます。

    3. 上記の設定が完了したら、ページ下部の 次:データベースおよびテーブルのフィールド設定 をクリックして、宛先 Elasticsearch インスタンスにおける同期対象テーブルの _routing ポリシーおよび _id 値を設定します。

      タイプ

      説明

      _routing の設定

      _routing 機能は、ドキュメントを宛先 Elasticsearch インスタンスの特定のシャードに格納するためのルーティングを行います。詳細については、「_routing」をご参照ください。

      • ○ を選択すると、ルーティング用のカスタム列を指定できます。

      • × を選択すると、_id 値がルーティングに使用されます。

      説明

      宛先 Elasticsearch インスタンスがバージョン 7.x の場合、× を選択する必要があります。

      _routing 列

      ルーティングに使用する列を選択します。

      説明

      このパラメーターは、_routing の設定 が ○ に設定されている場合にのみ必須です。

      _id の値

      ドキュメント ID として使用する列を選択します。

  6. タスクを保存して事前チェックを実行します。

    • このインスタンスを設定するための API パラメーターを表示するには、次:タスク設定の保存と事前チェック ボタンにカーソルを合わせ、表示されたバルーン内の OpenAPI パラメーターのプレビュー をクリックします。

    • API パラメーターの確認が完了したら、ページ下部の 次:タスク設定の保存と事前チェック をクリックします。

    説明
    • 同期ジョブ開始前に、DTS は事前チェックを実行します。すべての事前チェック項目が合格した後にのみ、ジョブを開始できます。

    • 事前チェックに失敗した場合は、失敗した項目の横にある 詳細を表示 をクリックします。指示に従って問題を修正し、再度事前チェックを実行してください。

    • 事前チェックで警告が返された場合:

      • チェック項目が失敗し、無視できない場合は、項目の横にある 詳細を表示 をクリックします。指示に従って問題を修正し、再度事前チェックを実行してください。

      • 無視可能なチェック項目については、アラートの詳細を確認、無視、OK、再度事前チェックを実行 の順にクリックして、警告をスキップして事前チェックを再実行できます。警告項目を非表示にすると、データの不整合などの問題が発生し、ビジネスにリスクをもたらす可能性があります。

  7. インスタンスを購入します。

    1. 成功率 が 100% になったら、次:インスタンスの購入 をクリックします。

    2. 購入 ページで、データ同期インスタンスの課金方法およびリンク仕様を選択します。以下の表に、これらのパラメーターの詳細を示します。

      カテゴリ

      パラメーター

      説明

      新しいインスタンスクラス

      課金方法

      • サブスクリプション:インスタンス作成時に支払いを行います。長期的なニーズに適しており、従量課金よりもコスト効率が高くなります。サブスクリプション期間が長いほど、割引率が高くなります。

      • 従量課金:1 時間単位で課金されます。短期的なニーズに適しています。使用後すぐにインスタンスをリリースすることでコストを節約できます。

      リソースグループ構成

      インスタンスが属するリソースグループです。デフォルトは default resource group です。詳細については、「Resource Management とは」をご参照ください。

      リンク仕様

      DTS は、さまざまなパフォーマンスレベルを持つ同期仕様を提供しています。同期リンク仕様は同期レートに影響します。ビジネスシナリオに基づいて仕様を選択できます。詳細については、「データ同期リンク仕様」をご参照ください。

      サブスクリプション期間

      サブスクリプションモードでは、サブスクリプションインスタンスの期間および数量を選択します。1 ~ 9 ヶ月の月額サブスクリプション、または 1、2、3、5 年の年額サブスクリプションを選択できます。

      説明

      このオプションは、課金方法が サブスクリプション の場合にのみ利用可能です。

    3. 設定が完了したら、Data Transmission Service (従量課金) 利用規約 を読み、同意してください。

    4. 購入して起動 をクリックします。OK ダイアログボックスで、OK をクリックします。

      データ同期ページでタスクの進行状況を確認できます。