Data Transmission Service (DTS) を使用して、PolarDB-X 2.0 インスタンスのデータを PolarDB for MySQL クラスターに同期できます。
前提条件
-
ソースとなる PolarDB-X 2.0 インスタンスが作成済みです。
-
ターゲットとなる PolarDB for MySQL クラスターが作成済みです。詳細については、「従量課金クラスターの作成」および「サブスクリプションクラスターの作成」をご参照ください。
-
ターゲットとなる PolarDB for MySQL クラスターのストレージ容量が、ソースとなる PolarDB-X 2.0 インスタンスで使用されている容量よりも大きい必要があります。
制限事項
スキーマ同期中に、DTS はソースデータベースの外部キーをターゲットデータベースに同期します。
初期完全同期および増分同期中、DTS はセッションレベルで一時的に制約チェックおよび外部キーのカスケード操作を無効化します。同期タスク実行中にソースデータベースでカスケード更新または削除操作を実行すると、データの不整合が発生する可能性があります。
|
種別 |
説明 |
|
ソースデータベースの制限事項 |
|
|
その他の制限事項 |
|
|
その他の注意事項 |
DTS は、バイナリログファイルの位置を進めるために、定期的にソースデータベース内の |
課金
|
同期タイプ |
料金 |
|
スキーマ同期および完全データ同期 |
無料です。 |
|
増分データ同期 |
課金対象です。詳細については、「課金概要」をご参照ください。 |
サポートされる SQL 操作
|
操作タイプ |
SQL ステートメント |
|
DML |
INSERT、UPDATE、DELETE |
|
DDL |
|
注意事項
操作手順
-
ターゲットリージョンの同期タスクリストページに移動します。次のいずれかの方法を使用できます。
DTS コンソールからのアクセス
-
左側のナビゲーションウィンドウで、データ同期 をクリックします。
-
ページ左上隅で、同期インスタンスが配置されているリージョンを選択します。
DMS コンソールから
説明実際の操作は、DMS コンソールのモードおよびレイアウトによって異なる場合があります。詳細については、「シンプルモード」および「DMS インターフェイスのレイアウトとスタイルのカスタマイズ」をご参照ください。
-
Data Management (DMS) にログインします。
-
上部メニューバーで、 を選択します。
-
データ同期タスク の右側で、同期インスタンスが配置されているリージョンを選択します。
-
タスクの作成 をクリックして、タスク構成ページを開きます。
-
ソースおよびターゲットデータベースを構成します。
警告ソースおよびターゲットインスタンスを選択した後、ページ上部に表示される制限事項をよくお読みください。制限事項に従わないと、タスクが失敗したりデータの不整合が発生したりする可能性があります。
カテゴリ
パラメーター
説明
該当なし
タスク名
DTS は自動的にタスク名を生成します。識別しやすいように、わかりやすい名前を指定することを推奨します。タスク名は一意である必要はありません。
ソースデータベース
既存の接続情報の選択
-
システムに追加済み(新規作成または保存済み)のデータベースインスタンスを使用する場合は、ドロップダウンリストからデータベースインスタンスを選択します。データベース情報は自動的に構成されます。
説明DMS コンソールでは、この設定項目の名前は DMS データベースインスタンスの選択 です。
-
データベースインスタンスをまだシステムに追加していない場合、またはすでに追加済みのインスタンスを使用しない場合は、以下のデータベース情報を手動で構成してください。
データベースタイプ
PolarDB-X 2.0 を選択します。
アクセス方法
Alibaba Cloud インスタンス を選択します。
インスタンスリージョン
ソース PolarDB-X 2.0 インスタンスが配置されているリージョンを選択します。
Alibaba Cloud アカウント間でデータを複製
本チュートリアルでは、同一 Alibaba Cloud アカウントに属するインスタンスを使用します。× を選択します。
インスタンス ID
ソース PolarDB-X 2.0 インスタンスの ID を選択します。
データベースアカウント
ソース PolarDB-X 2.0 インスタンスのデータベースアカウントを入力します。このアカウントには、同期対象オブジェクトに対する REPLICATION SLAVE、REPLICATION CLIENT、および SELECT 権限が必要です。
説明権限付与方法については、「データ同期時のアカウント権限に関する問題」をご参照ください。
データベースパスワード
データベースアカウントに対応するパスワードを入力します。
宛先データベース
既存の接続情報の選択
-
システムに追加済み(新規作成または保存済み)のデータベースインスタンスを使用する場合は、ドロップダウンリストからデータベースインスタンスを選択します。データベース情報は自動的に構成されます。
説明DMS コンソールでは、この設定項目の名前は DMS データベースインスタンスの選択 です。
-
データベースインスタンスをまだシステムに追加していない場合、またはすでに追加済みのインスタンスを使用しない場合は、以下のデータベース情報を手動で構成してください。
データベースタイプ
PolarDB for MySQL を選択します。
アクセス方法
Alibaba Cloud インスタンス を選択します。
インスタンスリージョン
ターゲット PolarDB for MySQL クラスターのリージョンを選択します。
PolarDB クラスター ID
ターゲット PolarDB for MySQL クラスターの ID を選択します。
データベースアカウント
ターゲット PolarDB for MySQL クラスターのデータベースアカウントを入力します。このアカウントには ALL 権限が必要です。
データベースパスワード
データベースアカウントに対応するパスワードを入力します。
暗号化
要件に基づいてオプションを選択します。詳細については、「SSL 暗号化の構成」をご参照ください。
-
-
構成が完了したら、ページ下部の 接続をテストして続行 をクリックします。
説明DTS サーバーからのアクセスを許可するために、ソースおよびターゲットデータベースのセキュリティ設定に DTS サーバーの IP アドレス CIDR ブロックを追加する必要があります。これは自動または手動で行えます。詳細については、「DTS サーバーの IP アドレス CIDR ブロックをホワイトリストに追加」をご参照ください。
-
タスクオブジェクトを構成します。
-
オブジェクト設定 ページで、同期するオブジェクトを構成します。
パラメーター
説明
同期タイプ
増分データ同期 が選択されています。デフォルトでは、スキーマ同期 および 完全データ同期 も選択する必要があります。事前チェック完了後、DTS は選択したオブジェクトの完全データ同期をソースインスタンスからターゲットクラスターに実行します。これは、その後の増分データ同期のベースラインデータとなります。
競合テーブルの処理モード
-
エラーの事前チェックと報告:ターゲットデータベースに同名のテーブルが存在するかどうかをチェックします。同名のテーブルが存在しない場合、事前チェックは合格します。同名のテーブルが存在する場合、事前チェックは失敗し、データ同期タスクは開始されません。
説明ターゲットデータベースで同名のテーブルを削除またはリネームできない場合は、別のテーブル名にマッピングできます。詳細については、「テーブル名および列名のマッピング」をご参照ください。
-
エラーを無視して続行:ターゲットデータベースでの重複テーブル名のチェックをスキップします。
警告エラーを無視して続行 を選択すると、データの不整合が発生し、ビジネスにリスクをもたらす可能性があります。たとえば:
-
テーブルスキーマが同じで、ターゲットデータベースのレコードがソースデータベースのレコードと同じプライマリキーまたは一意キー値を持つ場合:
-
完全同期中、DTS はターゲットクラスターのレコードを保持します。ソースデータベースの対応するレコードは同期されません。
-
増分同期中、ソースデータベースのレコードがターゲットデータベースのレコードを上書きします。
-
-
テーブルスキーマが異なる場合、初期データ同期が失敗する可能性があります。その結果、一部の列データのみが同期されるか、完全に同期が失敗する可能性があります。慎重にご対応ください。
-
ソースオブジェクト
ソースオブジェクト ボックスで、同期するオブジェクトをクリックし、
をクリックして 選択中のオブジェクト ボックスに移動させます。説明同期オブジェクトとして、データベース、テーブル、列を選択できます。テーブルまたは列を選択した場合、ビュー、トリガー、ストアドプロシージャなどの他のオブジェクトはターゲットデータベースに同期されません。
[選択済みオブジェクト]
-
ターゲットインスタンスで単一の同期オブジェクトの名前を変更するには、選択中のオブジェクト ボックス内のオブジェクトを右クリックします。オブジェクトの名前変更方法については、「単一のデータベース、テーブル、または列のマッピング」をご参照ください。
-
ターゲットインスタンスで複数の同期オブジェクトの名前を一括で変更するには、選択中のオブジェクト ボックスの右上隅にある 一括編集 をクリックします。詳細については、「データベース、テーブル、および列の一括マッピング」をご参照ください。
説明-
特定のデータベースまたはテーブルについて同期する SQL 操作を選択するには、選択中のオブジェクト ボックス内のオブジェクトを右クリックし、表示されるダイアログボックスで目的の SQL 操作を選択します。
-
WHERE 句を使用してデータをフィルターするには、選択中のオブジェクト ボックス内のテーブルを右クリックし、表示されるダイアログボックスでフィルター条件を指定します。詳細については、「フィルター条件の構成」をご参照ください。
-
-
詳細設定へ をクリックして、詳細パラメーターを構成します。
パラメーター
説明
タスクのスケジュールに使用する専用クラスターの選択
デフォルトでは、DTS は共有クラスター上でタスクをスケジューリングするため、クラスターを選択する必要はありません。より安定したパフォーマンスを求める場合は、DTS 同期タスクを実行するための専用クラスターを購入できます。詳細については、「DTS 専用クラスターとは」をご参照ください。
失敗した接続の再試行時間
同期タスク開始後、ソースまたはターゲットデータベースへの接続が失敗した場合、DTS はエラーを報告し、直ちに接続の再試行を開始します。デフォルトの再試行時間は 720 分です。10 ~ 1,440 分の範囲でカスタム再試行時間を指定することもできます。30 分以上に設定することを推奨します。指定された時間内に DTS がデータベースへの再接続に成功した場合、同期タスクは自動的に再開されます。それ以外の場合、タスクは失敗します。
説明-
同じソースまたはターゲットを共有する複数の DTS インスタンス(例:インスタンス A とインスタンス B)があり、インスタンス A のネットワーク再試行時間を 30 分、インスタンス B を 60 分に設定した場合、両方に短い方の 30 分が適用されます。
-
DTS は接続再試行期間中のタスクランタイムに対して課金するため、ビジネスニーズに基づいて再試行時間をカスタマイズするか、ソースおよびターゲットデータベースインスタンスをリリースした後はできるだけ早く DTS インスタンスをリリースすることを推奨します。
移行元データベースと移行先データベースで他の問題が発生した場合の、再試行までの待機時間です。
移行タスク開始後、ソースまたはターゲットデータベースで接続性以外の問題(例:DDL または DML 実行例外)が発生した場合、DTS はエラーを報告し、直ちに操作の再試行を開始します。デフォルトの再試行時間は 10 分です。1 ~ 1,440 分の範囲で再試行時間をカスタマイズできます。10 分以上に設定することを推奨します。指定された再試行時間内に関連操作が成功した場合、移行タスクは自動的に再開されます。それ以外の場合、タスクは失敗します。
重要移行元データベースと移行先データベースで他の問題が発生した場合の、再試行までの待機時間です。 の値は、失敗した接続の再試行時間 の値より小さくする必要があります。
完全同期レートを制限するかどうか
完全同期ステージ中、DTS はソースおよびターゲットデータベースの読み取り・書き込みリソースを消費するため、データベース負荷が増加します。ソースおよびターゲットデータベースの負荷を軽減するために、1 秒あたりのソースデータベースのクエリ率 QPS、1 秒あたりの完全移行の行数 RPS、および 1 秒あたりの完全移行データ量 (MB) BPS パラメーターを構成することで、完全同期タスクのレート制限を設定できます。
説明-
この設定項目は、同期タイプ が 完全データ同期 に設定されている場合にのみ利用可能です。
-
同期インスタンス実行後も、完全同期レートを調整 できます。
増分同期率を制限するかどうか
増分同期タスクのレート制限も設定できます。ターゲットデータベースの負荷を軽減するために、1 秒あたりの増分同期の行数 RPS および 1 秒あたりの増分同期データ量 (MB) BPS を設定してください。
環境タグ
インスタンスを識別するために環境タグを選択できます。本チュートリアルでは必須ではありません。
ETL 機能の設定
抽出・変換・書き出し (ETL) 機能を有効にするかどうかを選択します。詳細については、「ETL とは」をご参照ください。有効値:
-
○:ETL 機能を有効化します。コードエディタにデータ処理文を入力します。詳細については、「データ移行またはデータ同期タスクでの ETL の構成」をご参照ください。
-
×:ETL 機能を無効化します。
順方向および逆方向タスクのハートビートテーブル SQL を削除
DTS インスタンス実行中に、ハートビート SQL 情報をソースデータベースに書き込むかどうかを選択します。
-
○:ハートビート SQL 情報はソースデータベースに書き込まれません。これにより、DTS インスタンスが遅延を報告する可能性があります。
-
×:ハートビート SQL 情報をソースデータベースに書き込みます。これにより、ソースデータベースの物理バックアップやクローンなどの機能に干渉する可能性があります。
監視アラート
アラートを構成するかどうかを指定します。同期が失敗した場合や遅延が指定されたしきい値を超えた場合、アラート連絡先に通知が送信されます。
-
×:アラートは構成されません。
-
○:アラートのしきい値を設定し、アラート通知を指定してアラートを構成します。詳細については、「タスク構成時のモニタリングとアラートの構成」をご参照ください。
-
-
次へ:データ検証 をクリックして、データ検証タスクを構成します。
データ検証機能を使用する場合は、「データ検証の構成」を参照して構成手順をご確認ください。
-
-
タスクを保存して事前チェックを実行します。
-
このインスタンスを構成するための API パラメーターを表示するには、次:タスク設定の保存と事前チェック ボタンにカーソルを合わせ、表示されるバルーン内の OpenAPI パラメーターのプレビュー をクリックします。
-
API パラメーターの確認が完了したら、ページ下部の 次:タスク設定の保存と事前チェック をクリックします。
説明-
同期ジョブ開始前に、DTS は事前チェックを実行します。すべての事前チェック項目が合格した場合にのみ、ジョブを開始できます。
-
事前チェックに失敗した場合は、失敗した項目の横にある 詳細を表示 をクリックします。表示された指示に従って問題を修正し、再度事前チェックを実行してください。
-
事前チェックで警告が返された場合:
-
チェック項目が失敗し、無視できない場合は、項目の横にある 詳細を表示 をクリックします。指示に従って問題を修正し、再度事前チェックを実行してください。
-
無視可能なチェック項目については、アラートの詳細を確認、無視、OK、再度事前チェックを実行 の順にクリックして、警告をスキップし、事前チェックを再実行できます。警告項目を無視すると、データの不整合などの問題が発生し、ビジネスにリスクをもたらす可能性があります。
-
-
-
インスタンスを購入します。
-
[成功率] が 100 %になったら、次:インスタンスの購入 をクリックします。
-
購入 ページで、データ移行インスタンスのリンク仕様を選択します。詳細は次の表をご参照ください。
カテゴリ
パラメーター
説明
新しいインスタンスクラス
リソースグループの設定
インスタンスが属するリソースグループを選択します。デフォルト値は default resource group です。詳細については、「Resource Management とは」をご参照ください。
インスタンスクラス
DTS は、さまざまなパフォーマンスレベルを持つ移行仕様を提供しています。リンク仕様は移行速度に影響します。ビジネスシナリオに基づいて仕様を選択できます。詳細については、「データ移行リンク仕様」をご参照ください。
-
構成が完了したら、Data Transmission Service (従量課金) 利用規約 を読み、同意してください。
-
購入して起動 をクリックします。OK ダイアログボックスが表示されたら、OK をクリックします。
データ移行タスク リストページで、移行タスクの進捗状況を確認できます。
説明-
移行タスクに増分移行が含まれていない場合、完全移行完了後に自動的に停止します。タスクが停止すると、ステータス は 完了 に変化します。
-
移行タスクに増分移行が含まれている場合、自動的には停止しません。増分移行タスクは継続して実行されます。増分移行タスク実行中、タスクの ステータス は 実行中 になります。
-
-