Data Transmission Service (DTS) を使用して、ApsaraDB RDS for MySQL インスタンスから Alibaba Cloud Elasticsearch クラスターにデータを移行できます。
前提条件
-
ターゲットの Elasticsearch インスタンスが作成済みです。詳細については、「Alibaba Cloud Elasticsearch インスタンスの作成」をご参照ください。
-
完全なデータ移行を行う場合、ターゲットインスタンスのストレージ容量はソースデータベースの使用量よりも大きくする必要があります。
制限事項
-
DTS はスキーマ移行中に外部キーを移行します。
-
完全および増分データ移行中、DTS はセッションレベルで一時的に制約チェックおよび外部キーのカスケードを無効にします。タスク実行中にソースデータベースでカスケード更新または削除が発生すると、データの不整合が生じる可能性があります。
|
種別 |
説明 |
|
ソースデータベースの制限事項 |
|
|
その他の制限事項 |
|
|
特殊なケース |
|
課金
|
移行タイプ |
インスタンス構成料金 |
インターネットトラフィック料金 |
|
スキーマ移行および完全なデータ移行 |
無料です。 |
ターゲットデータベースの アクセス方法 パラメーターが パブリック IP アドレス に設定されている場合、インターネットトラフィック料金が発生します。詳細については、「課金概要」をご参照ください。 |
|
増分データ移行 |
課金対象です。詳細については、「課金概要」をご参照ください。 |
移行タイプ
-
スキーマ移行
DTS は移行オブジェクトのスキーマ定義をソースデータベースからターゲットデータベースに移行します。
-
完全移行
DTS は指定された移行オブジェクトの既存データをすべてソースデータベースからターゲットデータベースに移行します。
-
増分移行
完全移行完了後、DTS はソースデータベースからターゲットデータベースに増分データの更新を移行します。増分移行により、セルフマネージドアプリケーションを中断せずにスムーズにデータ移行できます。
増分移行でサポートされる SQL 操作
|
種別 |
SQL ステートメント |
|
DML |
INSERT、UPDATE、DELETE 説明
UPDATE ステートメントを使用してカラムを削除する操作はサポートされていません。 |
データベースアカウントの権限
|
データベース |
スキーマ移行 |
完全なデータ移行 |
増分データ移行 |
操作 |
|
ApsaraDB RDS for MySQL インスタンス |
|
|
|
|
|
Elasticsearch クラスター |
データベースアカウント(通常は |
|||
データ型のマッピング
-
ソースデータベースと Elasticsearch インスタンスは、常に直接マッピングできるとは限らない異なるデータの型をサポートしています。構造の初期化中に、DTS はターゲットの Elasticsearch インスタンスがサポートするデータの型に基づいて、データの型をマッピングします。詳細については、「構造の初期化時のデータの型マッピング」をご参照ください。
説明DTS のスキーマ移行プロセス中、DTS は
dynamicパラメーターをmapping内で設定しません。このパラメーターの動作は、ご利用の Elasticsearch インスタンスの設定に依存します。ソースデータが JSON 型の場合、特定のキーに対応する値がテーブル内のすべての行で同じデータ型を持つことを保証する必要があります。そうでない場合、DTS で同期の問題が発生する可能性があります。詳細については、「dynamic」をご参照ください。 -
Elasticsearch とリレーショナルデータベースのマッピングは、Elasticsearch のバージョンによって異なります。
重要Elasticsearch 7.0 以降では、インデックスは複数のタイプをサポートしなくなり、Elasticsearch 8.0 ではタイプが完全に削除されました。同期または移行タスクを設定する際、DTS はデフォルトでリレーショナルデータベースのテーブルを Elasticsearch のインデックスにマッピングします。移行または同期するオブジェクトを設定する際に、このマッピングを変更できます。
Elasticsearch 7.0 以降
Elasticsearch
リレーショナルデータベース
インデックス
テーブル
ドキュメント
行
フィールド
列
マッピング
スキーマ
Elasticsearch 7.0 より前のバージョン
Elasticsearch
リレーショナルデータベース
index
database
type
table
document
row
field
column
mapping
schema
操作手順
-
次のいずれかの方法で、ターゲットリージョンの移行タスクリストページに移動します。
DTS コンソールから
-
左側のナビゲーションウィンドウで、データの移行 をクリックします。
-
ページ左上隅で、移行インスタンスが配置されているリージョンを選択します。
DMS コンソールから
説明実際の操作は DMS コンソールのモードおよびレイアウトによって異なる場合があります。詳細については、「シンプルモードコンソール」および「DMS コンソールのレイアウトとスタイルのカスタマイズ」をご参照ください。
-
Data Management (DMS) コンソールにログインします。
-
上部のメニューバーで、 を選択します。
-
データ移行タスク の右側で、移行インスタンスが配置されているリージョンを選択します。
-
タスクの作成 をクリックして、タスク設定ページに移動します。
-
ソースおよびターゲットデータベースを設定します。
カテゴリ
パラメーター
説明
該当なし
タスク名
DTS は自動的にタスク名を生成します。識別しやすいように、わかりやすい名前を指定することを推奨します。名前は一意である必要はありません。
ソースデータベース
既存の接続情報の選択
-
システムに追加済み(作成または保存済み)のデータベースインスタンスを使用する場合は、ドロップダウンリストから目的のデータベースインスタンスを選択します。以下のデータベース情報が自動的に設定されます。
説明DMS コンソールでは、このパラメーターの名前は DMS データベースインスタンスの選択 です。
-
データベースインスタンスをシステムに登録していない場合、または登録済みのインスタンスを使用しない場合は、以下でデータベース情報を手動で設定してください。
データベースタイプ
MySQL を選択します。
アクセス方法
Alibaba Cloud インスタンス を選択します。
インスタンスリージョン
ソース ApsaraDB RDS for MySQL インスタンスが配置されているリージョンを選択します。
Alibaba Cloud アカウント間でデータを複製
同一 Alibaba Cloud アカウント内でデータを移行する場合は、× を選択します。
RDS インスタンス ID
ソース ApsaraDB RDS for MySQL インスタンスの ID を選択します。
データベースアカウント
ソース ApsaraDB RDS for MySQL インスタンスのデータベースアカウントを入力します。必要な権限については、「データベースアカウントに必要な権限」をご参照ください。
データベースパスワード
データベースアカウントに対応するパスワードを入力します。
暗号化
必要に応じて、非暗号化 または SSL 暗号化 を選択します。SSL 暗号化 を選択する場合は、事前に RDS for MySQL インスタンスで SSL 暗号化を有効にしておく必要があります。詳細については、「クラウド証明書を使用した SSL 暗号化の迅速な有効化」をご参照ください。
宛先データベース
既存の接続情報の選択
-
システムに追加済み(作成または保存済み)のデータベースインスタンスを使用する場合は、ドロップダウンリストから目的のデータベースインスタンスを選択します。以下のデータベース情報が自動的に設定されます。
説明DMS コンソールでは、このパラメーターの名前は DMS データベースインスタンスの選択 です。
-
データベースインスタンスをシステムに登録していない場合、または登録済みのインスタンスを使用しない場合は、以下でデータベース情報を手動で設定してください。
データベースタイプ
Elasticsearch を選択します。
アクセス方法
Alibaba Cloud インスタンス を選択します。
インスタンスリージョン
ターゲット Elasticsearch インスタンスが配置されているリージョンを選択します。
タイプ
Cluster Edition または Serverless を要件に応じて選択します。
インスタンス ID
ターゲット Elasticsearch インスタンスの ID を選択します。
データベースアカウント
Elasticsearch インスタンスに接続するために使用するアカウントを入力します。これは、インスタンス作成時に指定した ユーザー名 です。デフォルトアカウントは elastic です。
データベースパスワード
データベースアカウントに対応するパスワードを入力します。
暗号化
必要に応じて、HTTP または HTTPS を選択します。
-
-
設定が完了したら、ページ下部の 接続をテストして続行 をクリックします。
説明-
DTS サーバーからのアクセスを許可するために、ソースおよびターゲットデータベースのセキュリティ設定に DTS サービスの IP アドレスセグメントが自動または手動で追加されていることを確認してください。詳細については、「DTS サーバーの IP アドレスをホワイトリストに追加」をご参照ください。
-
ソースまたはターゲットデータベースがセルフマネージドデータベース(アクセス方法 が Alibaba Cloud インスタンス ではない)の場合、表示される DTS サーバーの CIDR ブロック ダイアログボックスで 接続テスト をクリックする必要があります。
-
-
タスクオブジェクトを設定します。
-
オブジェクト設定 ページで、移行するオブジェクトを設定します。
パラメーター
説明
移行タイプ
-
完全移行のみを実行する場合は、スキーマ移行 と 完全データ移行 の両方を選択します。
-
ダウンタイムなしで移行を実行する場合は、スキーマ移行、完全データ移行、および 増分データ移行 を選択します。
説明-
スキーマ移行 を選択しない場合、ターゲットデータベースにデータを受信するためのデータベースおよびテーブルが存在することを保証する必要があります。選択中のオブジェクト ボックスで必要に応じてオブジェクト名マッピング機能を使用することもできます。
-
増分データ移行 を選択しない場合、データ整合性を確保するためにデータ移行中にソースインスタンスに新しいデータを書き込まないでください。
競合テーブルの処理モード
-
エラーの事前チェックと報告:ターゲットデータベースに同名のテーブルが存在するかどうかをチェックします。同名のテーブルが存在しない場合、事前チェックは合格します。同名のテーブルが存在する場合、事前チェック中にエラーが報告され、データ移行タスクは開始されません。
説明ターゲットデータベースのテーブルが同名で、簡単に削除または名前変更できない場合は、ターゲットデータベースのテーブル名を変更できます。詳細については、「オブジェクト名マッピング」をご参照ください。
-
エラーを無視して続行:同名のテーブルのチェックをスキップします。
警告エラーを無視して続行 を選択すると、データの不整合やビジネスリスクが発生する可能性があります。例えば:
-
テーブルスキーマが一致しており、ターゲットデータベースのレコードがソースデータベースのレコードと同じプライマリキー値を持つ場合:
-
完全移行中、DTS はターゲットデータベースのレコードを保持します。ソースデータベースのレコードは移行されません。
-
増分移行中、DTS はターゲットデータベースのレコードを保持しません。ソースデータベースのレコードがターゲットデータベースのレコードを上書きします。
-
-
テーブルスキーマが不一致の場合、一部のカラムのデータのみが移行されるか、移行が失敗する可能性があります。慎重に進めてください。
-
インデックス名
-
テーブル名 を選択した場合、ターゲット Elasticsearch インスタンスに作成されるインデックスはテーブルと同じ名前になります。
-
データベース名_テーブル名 を選択した場合、ターゲット Elasticsearch インスタンスのインデックス名は、データベース名、アンダースコア (_)、テーブル名を連結したものになります。
説明インデックス名マッピング設定はすべてのテーブルに適用されます。
宛先インスタンスでのオブジェクト名の大文字化
移行されたオブジェクト(データベース、テーブル、カラムなど)の名前について、ターゲットインスタンスでの大文字小文字の区別ポリシーを設定できます。デフォルトでは、DTS のデフォルトポリシー が選択されています。ソースまたはターゲットデータベースのデフォルトポリシーと一致するように設定することもできます。詳細については、「ターゲットデータベースにおけるオブジェクト名の大文字小文字の区別」をご参照ください。
ソースオブジェクト
ソースオブジェクト ペインで、移行するオブジェクトをクリックし、
アイコンをクリックして 選択中のオブジェクト ペインに移動させます。[選択済みオブジェクト]
移行後のフィールド名を変更するには、選択中のオブジェクト ペインで対応するテーブル名を右クリックし、ターゲット Elasticsearch インスタンスのテーブルに対するインデックス名とタイプ名を設定して、OK をクリックします。詳細については、「単一テーブルとそのカラムのマッピング」をご参照ください。
説明-
インデックス名およびタイプ名でサポートされる特殊文字はアンダースコア (_) のみです。
-
SQL フィルター条件を設定できます。これらの条件を満たすデータのみがターゲットインスタンスに移行されます。詳細については、「SQL 条件を使用したタスクデータのフィルタリング」をご参照ください。
-
-
詳細設定へ をクリックして、高度なパラメーターを設定します。
パラメーター
説明
タスクのスケジュールに使用する専用クラスターの選択
デフォルトでは、DTS は共有クラスター上でタスクをスケジューリングします。選択する必要はありません。より安定したタスクが必要な場合は、DTS 移行タスクを実行するための専用クラスターを購入できます。
失敗した接続の再試行時間
移行タスク開始後、ソースまたはターゲットデータベースへの接続が失敗した場合、DTS はエラーを報告し、直ちに接続の再試行を開始します。デフォルトの再試行時間は 720 分です。10 ~ 1440 分の範囲で再試行時間をカスタマイズできます。30 分以上に設定することを推奨します。指定された時間内に DTS がソースおよびターゲットデータベースに再接続できた場合、移行タスクは自動的に再開されます。そうでない場合、タスクは失敗します。
説明-
同一のソースまたはターゲットを共有する複数の DTS インスタンスの場合、ネットワーク再試行時間は最後に作成されたタスクの設定によって決定されます。
-
接続再試行期間中もタスクに対して課金されるため、ビジネスニーズに基づいて再試行時間をカスタマイズするか、ソースおよびターゲットデータベースインスタンスをリリースした後はできるだけ早く DTS インスタンスをリリースすることを推奨します。
移行元データベースと移行先データベースで他の問題が発生した場合の、再試行までの待機時間です。
移行タスク開始後、ソースまたはターゲットデータベースで DDL または DML 実行例外などの接続以外の問題が発生した場合、DTS はエラーを報告し、直ちに操作の再試行を開始します。デフォルトの再試行時間は 10 分です。1 ~ 1440 分の範囲で再試行時間をカスタマイズできます。10 分以上に設定することを推奨します。指定された再試行時間内に関連操作が成功した場合、移行タスクは自動的に再開されます。そうでない場合、タスクは失敗します。
重要移行元データベースと移行先データベースで他の問題が発生した場合の、再試行までの待機時間です。 の値は、失敗した接続の再試行時間 の値よりも小さくする必要があります。
シャード構成
ターゲット Elasticsearch インスタンスのインデックスの最大シャード構成に基づいて、インデックスのプライマリシャードおよびレプリカシャードの数を設定します。
文字列インデックス
ターゲット Elasticsearch インスタンスで文字列がどのようにインデックスされるかを指定します。
-
analyzed:文字列は最初に分析され、その後インデックスされます。特定のアナライザーも選択する必要があります。アナライザーの種類とその機能については、「Analyzers」をご参照ください。
-
not_analyzed:文字列は分析されず、元の値を使用してインデックスされます。
-
no:文字列はインデックスされません。
タイムゾーン
DTS が DATETIME や TIMESTAMP などの時間ベースのデータ型をターゲット Elasticsearch インスタンスに移行する際に適用されるタイムゾーンを指定します。
説明ターゲットインスタンスの時間ベースのデータにタイムゾーンが不要な場合、これらのデータ型に対して事前にターゲットインスタンスでドキュメントタイプ (type) を設定する必要があります。
DOCID
デフォルトでは、DOCID はテーブルのプライマリキーです。テーブルにプライマリキーがない場合、DOCID は Elasticsearch が自動生成する ID カラムになります。
環境タグ
インスタンスを識別するために環境タグを選択します。このパラメーターはこの例では省略可能です。
ETL 機能の設定
抽出・変換・書き出し (ETL) 機能を有効にするかどうかを選択します。詳細については、「ETL とは」をご参照ください。有効値:
-
○:ETL 機能を有効にします。コードエディタにデータ処理ステートメントを入力します。詳細については、「データ移行またはデータ同期タスクでの ETL の設定」をご参照ください。
-
×:ETL 機能を無効にします。
順方向および逆方向タスクのハートビートテーブル SQL を削除
DTS インスタンス実行中にソースデータベースにハートビート SQL 情報を書き込むかどうかを選択します。
-
○:ハートビート SQL 情報はソースデータベースに書き込まれません。これにより、DTS インスタンスが遅延を報告する可能性があります。
-
×:ハートビート SQL 情報をソースデータベースに書き込みます。これにより、ソースデータベースの物理バックアップやクローンなどの機能に干渉する可能性があります。
監視アラート
ビジネスニーズに基づいて、アラートを設定し、アラート通知を受信するかどうかを選択します。
-
×:アラートを設定しません。
-
○:アラートを設定するには、アラートのしきい値 と アラート通知 を設定します。移行が失敗した場合や遅延がしきい値を超えた場合、システムがアラート通知を送信します。
-
-
上記の設定が完了したら、ページ下部の 次:データベースおよびテーブルのフィールド設定 をクリックして、移行対象のテーブルについてターゲット Elasticsearch の
_routing ポリシーおよび_idの値を設定します。種別
説明
_routing の設定
ターゲット Elasticsearch インスタンスでドキュメントを特定のシャードに格納するための _routing を構成します。詳細については、「_routing」をご参照ください。
-
カスタムカラムをルーティングに使用する場合は、○ を選択します。
-
_id 値をルーティングに使用する場合は、× を選択します。
説明ターゲット Elasticsearch インスタンスがバージョン 7.x の場合、× を選択する必要があります。
_routing 列
ルーティングに使用するカラムを選択します。
説明このパラメーターは、_routing の設定 で ○ を選択した場合にのみ必須です。
_id の値
ドキュメント ID として使用するカラムを選択します。
-
-
-
タスクを保存して事前チェックを実行します。
-
このインスタンスを API オペレーションで呼び出す際のパラメーターを表示するには、次:タスク設定の保存と事前チェック ボタンにポインターを合わせ、表示されるバルーンで OpenAPI パラメーターのプレビュー をクリックします。
-
API パラメーターを表示する必要がない場合、または表示が完了した場合は、ページ下部の 次:タスク設定の保存と事前チェック をクリックします。
説明-
移行タスク開始前に、DTS が事前チェックを実行します。事前チェックに合格した場合にのみ、タスクが開始されます。
-
事前チェックに失敗した場合は、失敗したチェック項目の横にある 詳細を表示 をクリックし、プロンプトに基づいて問題を修正してから、再度事前チェックを実行してください。
-
事前チェック中に警告が報告された場合:
-
無視できないチェック項目の場合は、失敗した項目の横にある 詳細を表示 をクリックし、プロンプトに基づいて問題を修正してから、再度事前チェックを実行してください。
-
無視可能なチェック項目の場合は、アラートの詳細を確認、無視、OK、および 再度事前チェックを実行 をクリックして、アラート項目をスキップし、再度事前チェックを実行できます。警告を無視することを選択した場合、データの不整合などの問題が発生し、ビジネスにリスクをもたらす可能性があります。
-
-
-
インスタンスを購入します。
-
成功率 が 100% になったら、次:インスタンスの購入 をクリックします。
-
購入 ページで、データ移行インスタンスのリンク仕様を選択します。詳細は次の表をご参照ください。
カテゴリ
パラメーター
説明
新しいインスタンスクラス
リソースグループの設定
インスタンスが属するリソースグループを選択します。デフォルト値は default resource group です。詳細については、「Resource Management とは」をご参照ください。
インスタンスクラス
DTS は異なるパフォーマンスレベルを持つ移行仕様を提供しています。リンク仕様は移行速度に影響します。ビジネスシナリオに基づいて仕様を選択できます。詳細については、「データ移行リンク仕様」をご参照ください。
-
設定が完了したら、Data Transmission Service (従量課金) 利用規約 を読み、同意してください。
-
購入して起動 をクリックします。表示される OK ダイアログボックスで、OK をクリックします。
データ移行タスク リストページで、移行タスクの進行状況を確認できます。
説明-
移行タスクに増分移行が含まれていない場合、完全移行完了後に自動的に停止します。タスクが停止すると、ステータス は 完了 に変化します。
-
移行タスクに増分移行が含まれている場合、自動的には停止しません。増分移行タスクは継続して実行されます。増分移行タスク実行中、タスクの ステータス は 実行中 です。
-
-