すべてのプロダクト
Search
ドキュメントセンター

Data Transmission Service:MongoDB レプリカセット間の双方向データ同期

最終更新日:Jul 18, 2026

2 つの ApsaraDB for MongoDB レプリカセットインスタンス間で双方向にデータを同期し、常に整合性を保つことができます。

前提条件

  • ソースおよびターゲットの ApsaraDB for MongoDB レプリカセットインスタンスが作成済みである必要があります。レプリカセットインスタンスの作成をご参照ください。

    重要

    サポートされているデータベースバージョンについては、「同期ソリューションの概要」をご参照ください。

  • ターゲットの ApsaraDB for MongoDB インスタンスのストレージ容量は、ソースの ApsaraDB for MongoDB インスタンスのデータサイズよりも少なくとも 10 % 大きい必要があります。

  • 両方のインスタンスで、replication.oplogGlobalIdEnabled パラメーターが true に設定されている必要があります。データベースパラメーターの設定をご参照ください。

    説明

    このパラメーターが true に設定されていない場合、事前チェックが失敗するか、two-way mongo must have gid エラーが返されます。

注意事項

種別

説明

ソースおよびターゲットデータベースの制限

  • 帯域幅要件:ご利用のソースデータベースが配置されているサーバーには十分なアウトバウンド帯域幅が必要です。そうでない場合、同期速度に影響が出る可能性があります。

  • 同期対象のコレクションにはプライマリキーまたは一意制約が設定されており、フィールド値が一意である必要があります。そうでない場合、ターゲットデータベースに重複データが発生する可能性があります。

  • データ内のフィールド名に「.」(ドット)文字を含めることはできません。含まれていると、データの不整合が発生する可能性があります。

  • コレクション単位で同期を行い、オブジェクト(コレクション名の変更など)を編集する必要がある場合、1 つの同期タスクでサポートされるコレクション数は最大 1,000 件です。この上限を超えると、タスク送信後にエラーが発生して失敗します。これを回避するには、コレクションを複数のバッチに分割して複数のタスクを設定するか、データベース全体の同期タスクを設定してください。

  • ご利用のソースデータベース内の単一ドキュメントのサイズは 16 MB を超えてはなりません。超えるとタスクが失敗します。

  • ご利用のソースデータベースは Azure Cosmos DB for MongoDB または Amazon DocumentDB (elastic cluster) であってはなりません。

  • ご利用のソースデータベースでは Oplog を有効化し、Oplog を少なくとも 7 日間保持する必要があります。そうでない場合、DTS がデータ変更をキャプチャできず、タスクが失敗する可能性があります。最悪の場合、データの不整合や損失が発生する可能性があり、これらの問題は DTS SLA の適用外となります。

    重要
    • データ変更のキャプチャには Oplog の使用を推奨します。

    • Change Streams は双方向同期をサポートしていません。

  • 同期対象のコレクションに TTL インデックスが含まれている場合、データの不整合や遅延が発生する可能性があります。

  • ソースおよびターゲットデータベースは、同じアーキテクチャの ApsaraDB for MongoDB インスタンスである必要があります。自主管理 MongoDB インスタンスまたは異なるアーキテクチャの MongoDB インスタンス間での双方向同期はサポートされていません。

  • ソースデータベースの操作に関する制限:

    • スキーマ同期および完全データ同期中は、データベースまたはコレクションのスキーマ(配列型データの更新を含む)を変更しないでください。変更すると、同期タスクが失敗したり、ソースおよびターゲットデータベース間にデータの不整合が発生したりする可能性があります。

    • 完全データ同期のみを実行する場合は、ソースインスタンスに新しいデータを書き込まないでください。書き込むと、ソースおよびターゲットデータベース間にデータの不整合が発生する可能性があります。

  • DTS は SRV アドレスを使用した MongoDB データベースへの接続をサポートしていません。

  • ソースデータベースが MongoDB 5.0 以降で、ターゲットデータベースのバージョンが 5.0 より前の場合、capped collection を同期することはできません。同期を試みると、タスクが失敗するか、ソースおよびターゲットデータベース間にデータの不整合が発生します。これは、MongoDB 5.0 以降で capped collection の動作が変更され、明示的な削除や更新時のドキュメントサイズの増加などの操作が可能になったため、それ以前のバージョンのデータベースカーネルではこれらの新機能をサポートできないためです。

その他の制限

  • ソースおよびターゲットデータベースに同じ MongoDB バージョンを使用することを推奨します。互換性を確保するため、ターゲットにより高いバージョンを使用することも可能です。高バージョンから低バージョンへの同期は、互換性の問題を引き起こす可能性があります。

  • ソースおよびターゲットの ApsaraDB for MongoDB のアーキテクチャは一致している必要があります。

  • DTS は admin、config、local データベースからのデータ同期をサポートしていません。

  • トランザクション情報は保持されません。ソースデータベースのトランザクションは、ターゲットデータベースでは個別のレコードになります。

  • DTS がターゲットコレクションにデータを書き込む際、プライマリキーまたは一意キーの競合が発生した場合、DTS はその書き込み文をスキップし、ターゲットコレクション内の既存データを保持します。

  • ご利用のソース MongoDB バージョンが 3.6 より前で、ターゲット MongoDB バージョンが 3.6 以降の場合、実行計画の違いにより、同期されたデータのフィールド順序が不整合になる可能性があります。フィールドと値の関係は変更されません。ビジネスでネスト構造に対するテキストマッチングクエリを使用している場合は、フィールド順序の不整合が与える影響を評価してください。

  • 同期前に、ソースおよびターゲットデータベースのパフォーマンスを評価してください。オフピーク時間帯に同期を実行することを推奨します。そうでない場合、完全データ初期化によって読み取りおよび書き込みリソースが消費され、データベース負荷が増加します。

  • 完全初期化では INSERT 操作が同時に行われるため、ターゲットデータベースのコレクションに断片化が発生します。完全初期化後、ターゲットインスタンスのコレクションスペースはソースインスタンスよりも大きくなります。

  • 同期中は、DTS 以外からターゲットデータベースにデータを書き込まないでください。書き込むと、ソースおよびターゲットデータベース間にデータの不整合が発生する可能性があります。たとえば、DMS を使用してオンライン DDL 操作を実行中に他のデータがターゲットデータベースに書き込まれると、データ損失が発生する可能性があります。

  • ターゲットコレクションに一意なインデックスが存在するか、capped プロパティが true に設定されている場合、増分同期中の同時リプレイはサポートされません。シングルスレッドでの書き込みのみが許可されます。これにより、タスクの遅延が増加する可能性があります。

  • 双方向同期タスクには、転送同期タスクと逆同期タスクが含まれます。タスクを設定またはリセットする際、一方のタスクの宛先オブジェクトが他方のタスクの同期オブジェクトと一致する場合:

    • 完全および増分データの同期を許可するのは 1 つのタスクのみです。もう一方のタスクは増分同期のみをサポートします。

    • 現在のタスクのソースからのデータは、現在のタスクの宛先にのみ同期されます。他方のタスクのソースデータとしては使用されません。

  • DTS がデータを同時に書き込むため、ターゲットで使用されるストレージスペースはソースよりも 5 % ~ 10 % 大きくなります。

  • ターゲット MongoDB のドキュメント数を取得するには、構文 db.$table_name.aggregate([{ $count:"myCount"}]) を使用してください。

  • ターゲット MongoDB にソースと同じプライマリキー(デフォルトは _id)が存在しないことを確認してください。存在する場合、データ損失が発生する可能性があります。ターゲットに同じプライマリキーが存在する場合は、ビジネスに影響を与えない範囲でターゲットの関連データをクリアしてください(ターゲットで同じ _id 値を持つドキュメントを削除)。

  • DTS は MongoDB 5.0 以降で導入された時系列コレクションの同期をサポートしていません。

  • タスクが失敗した場合、DTS サポートスタッフが 8 時間以内に復旧を試みます。復旧中は、タスクを再起動したり、パラメーターを調整したりする可能性があります。

    説明

    DTS タスクパラメーターのみが変更され、データベースパラメーターは変更されません。 調整対象となるパラメーターは、「インスタンスパラメーターの変更」に記載されています。

課金

同期タイプ

料金

スキーマ同期および完全データ同期

無料です。

増分データ同期

課金対象です。詳細については、「課金概要」をご参照ください。

サポートされる双方向同期トポロジ

DTS は、2 つの ApsaraDB for MongoDB レプリカセットインスタンス間でのみ双方向同期をサポートします。3 つ以上の ApsaraDB for MongoDB インスタンス間の同期はサポートされていません。

サポートされる競合検出

データ整合性を維持するため、同じプライマリキー、ビジネスプライマリキー、または一意キーを共有するレコードは、一度に 1 つのノードでのみ更新してください。

DTS は以下の競合タイプを検出して解決し、同期の安定性を確保します。

  • INSERT 操作による一意性競合

    INSERT によって、すでにターゲットに存在するレコードが追加された場合、DTS はその操作を無視します。

  • UPDATE 操作中のレコード不一致

    UPDATE がターゲットに存在しないレコードを対象とするか、競合を引き起こす場合、DTS はその操作を無視します。

  • 存在しないレコードに対する DELETE 操作

    DELETE がターゲットに存在しないレコードを対象とする場合、DTS はその操作を無視します。

重要
  • DTS の競合検出では、システム時刻の差異や同期遅延によって発生するデータ競合を完全に防止することはできません。アプリケーション側で、同じプライマリキー、ビジネスプライマリキー、または一意キーを共有するレコードを一度に 1 つのノードでのみ更新するようにしてください。

  • デフォルトの競合解決ポリシーは Ignore であり、変更できません。

同期タイプ

種別

説明

スキーマ同期

選択したオブジェクトのスキーマを、ソースの ApsaraDB for MongoDB インスタンスからターゲットの ApsaraDB for MongoDB インスタンスに同期します。

完全データ同期

選択したオブジェクトのすべての既存データを、ソースの ApsaraDB for MongoDB インスタンスからターゲットの ApsaraDB for MongoDB インスタンスに同期します。

説明

完全データ同期は、データベースおよびコレクションをサポートしています。

増分データ同期

完全データ同期が完了した後、DTS はソースの ApsaraDB for MongoDB インスタンスからターゲットの ApsaraDB for MongoDB インスタンスに増分データを継続的に同期します。

増分データ同期では、タスク開始後に作成されたデータベースはレプリケートされません。以下の変更がレプリケートされます。

  • CREATE COLLECTION および CREATE INDEX

  • DROP DATABASE、DROP COLLECTION、および DROP INDEX

  • RENAME COLLECTION

    説明

    dropTarget オプションが true に設定されている場合、RENAME COLLECTION 操作はレプリケートされません。

  • コレクション内のドキュメントの挿入、更新、および削除。

    説明

    ドキュメントの更新については、$set コマンドを使用する操作のみがレプリケートされます。

操作手順

  1. ターゲットリージョンの同期タスクリストページに移動します。次の 2 つの方法のいずれかを使用できます。

    DTS コンソールから

    1. Data Transmission Service (DTS) コンソールにログインします。

    2. 左側のナビゲーションウィンドウで、データ同期 をクリックします。

    3. ページ左上隅で、同期インスタンスが配置されているリージョンを選択します。

    DMS コンソールから

    説明

    実際の操作は、DMS コンソールのモードおよびレイアウトによって異なる場合があります。詳細については、「シンプルモード」および「DMS インターフェイスのレイアウトとスタイルのカスタマイズ」をご参照ください。

    1. Data Management (DMS) にログインします。

    2. 上部のメニューバーで、Data + AI > Data Transmission (DTS) > データ同期 を選択します。

    3. データ同期タスク の右側で、同期インスタンスが配置されているリージョンを選択します。

  2. タスクの作成 をクリックして、タスク設定ページを開きます。

  3. ソースおよびターゲットデータベースを設定します。

    カテゴリ

    パラメーター

    説明

    該当なし

    タスク名

    DTS が自動的にタスク名を生成します。識別しやすいように、わかりやすい名前を指定することを推奨します。名前は一意である必要はありません。

    移行元データベース

    既存の接続情報の選択

    • システムに追加済み(新規作成または保存済み)のデータベースインスタンスを使用する場合は、ドロップダウンリストからデータベースインスタンスを選択します。データベース情報は自動的に設定されます。

      説明

      DMS コンソールでは、この設定項目の名前は DMS データベースインスタンスの選択 です。

    • データベースインスタンスをシステムに追加していない場合、またはすでに追加済みのインスタンスを使用しない場合は、以下のデータベース情報を手動で設定します。

    データベースタイプ

    データベースタイプセレクターをクリックします。デフォルトでは「リレーショナルデータベース」タブが表示されます。「NoSQLデータベース」タブに切り替えて、MongoDB を選択します。

    アクセス方法

    Alibaba Cloud インスタンス を選択します。

    インスタンスリージョン

    ソースの ApsaraDB for MongoDB インスタンスのリージョンを選択します。

    Alibaba Cloud アカウント間でデータを複製

    この例では、現在の Alibaba Cloud アカウントに属するデータベースインスタンスを使用します。× を選択します。

    アーキテクチャ

    レプリカセット を選択します。

    移行方法

    Oplog を選択します。

    インスタンス ID

    ソースの ApsaraDB for MongoDB インスタンスの ID を選択します。

    認証データベース

    ソースの ApsaraDB for MongoDB インスタンスアカウントの認証データベース名を入力します。デフォルトは admin です。

    データベースアカウント

    ソースの ApsaraDB for MongoDB インスタンスのデータベースアカウントを入力します。このアカウントには、同期対象のデータベースおよび config、admin、local データベースに対する読み取り権限が必要です。

    説明

    アカウントの作成および設定方法については、「MongoDB データベースアカウント権限管理」をご参照ください。

    データベースパスワード

    データベースアカウントに対応するパスワードを入力します。

    暗号化

    DTS は、非暗号化、SSL 暗号化、Mongo Atlas SSL の 3 種類の接続方法をサポートしています。暗号化 のオプションは、選択した アクセス方法 および アーキテクチャ によって異なります。コンソールに表示されるオプションが優先されます。

    説明
    • アーキテクチャ が シャードクラスター で、移行方法 が Oplog の MongoDB データベースは、SSL 暗号化 をサポートしていません。

    • ソースが自主管理 MongoDB データベース(アクセス方法 が Alibaba Cloud インスタンス ではない)で、レプリカセット アーキテクチャの場合、SSL 暗号化 を選択すると、DTS では CA 証明書をアップロードして接続を検証することもできます。

    移行先データベース

    既存の接続情報の選択

    • システムに追加済み(新規作成または保存済み)のデータベースインスタンスを使用する場合は、ドロップダウンリストからデータベースインスタンスを選択します。データベース情報は自動的に設定されます。

      説明

      DMS コンソールでは、この設定項目の名前は DMS データベースインスタンスの選択 です。

    • データベースインスタンスをシステムに追加していない場合、またはすでに追加済みのインスタンスを使用しない場合は、以下のデータベース情報を手動で設定します。

    データベースタイプ

    データベースタイプセレクターをクリックします。デフォルトでは「リレーショナルデータベース」タブが表示されます。「NoSQLデータベース」タブに切り替えて、MongoDB を選択します。

    アクセス方法

    Alibaba Cloud インスタンス を選択します。

    インスタンスリージョン

    ターゲットの ApsaraDB for MongoDB インスタンスのリージョンを選択します。

    Alibaba Cloud アカウント間でデータを複製

    この例では、現在の Alibaba Cloud アカウントに属するデータベースインスタンスを使用します。× を選択します。

    アーキテクチャ

    レプリカセット を選択します。

    インスタンス ID

    ターゲットの ApsaraDB for MongoDB インスタンスの ID を選択します。

    認証データベース

    ターゲットの ApsaraDB for MongoDB インスタンスアカウントの認証データベース名を入力します。デフォルトは admin です。

    データベースアカウント

    ターゲットの ApsaraDB for MongoDB インスタンスのデータベースアカウントを入力します。このアカウントには、ターゲットデータベースに対する dbAdminAnyDatabase および readWrite ロール、および local データベースに対する read ロールが必要です。

    説明

    アカウントの作成および設定方法については、「MongoDB データベースアカウント権限管理」をご参照ください。

    データベースパスワード

    データベースアカウントに対応するパスワードを入力します。

    暗号化

    DTS は、非暗号化、SSL 暗号化、Mongo Atlas SSL の 3 種類の接続方法をサポートしています。暗号化 のオプションは、選択した アクセス方法 および アーキテクチャ によって異なります。コンソールに表示されるオプションが優先されます。

    説明
    • アーキテクチャ が シャードクラスター の MongoDB データベースは、SSL 暗号化 をサポートしていません。

    • ターゲットが自主管理 MongoDB データベース(アクセス方法 が Alibaba Cloud インスタンス ではない)で、レプリカセット の場合、SSL 暗号化 を選択すると、DTS では CA 証明書をアップロードして接続を検証することもできます。

  4. 設定が完了したら、ページ下部の 接続をテストして続行 をクリックします。

    説明

    DTS サーバーからのアクセスを許可するために、ソースおよびターゲットデータベースのセキュリティ設定に DTS サーバーの IP アドレス CIDR ブロックを追加していることを確認してください。これは自動または手動で行うことができます。詳細については、「DTS サーバーの IP アドレス CIDR ブロックをホワイトリストに追加する」をご参照ください。

  5. タスクオブジェクトを設定します。

    1. オブジェクト設定 ページで、同期するオブジェクトを設定します。

      パラメーター

      説明

      同期タイプ

      増分データ同期 が選択されています。デフォルトでは、スキーマ同期 および 完全データ同期 も選択する必要があります。事前チェックが完了すると、DTS は選択したオブジェクトの完全データをソースインスタンスから宛先クラスターに同期します。これは、その後の増分データ同期のベースラインデータとして使用されます。

      競合するテーブルの処理モード

      • エラーの事前チェックと報告:ターゲットデータベースに同じ名前のコレクションが存在するかどうかをチェックします。同じ名前のコレクションが見つかった場合、エラーが報告され、データ同期タスクは開始されません。それ以外の場合は、事前チェックが成功します。

        説明

        ターゲットデータベースで同じ名前のコレクションを削除または名前変更できない場合は、宛先データベースのコレクション名を変更できます。詳細については、「宛先インスタンスでの同期オブジェクト名の設定」をご参照ください。

      • エラーを無視して続行:ターゲットデータベースに同じ名前のコレクションがあるかどうかのチェックをスキップします。

        警告

        エラーを無視して続行 を選択すると、データの不整合が発生し、ビジネスにリスクをもたらす可能性があります。たとえば:

        • ターゲットデータベースのレコードが、ソースデータベースのレコードと同じプライマリキーまたは一意キー値を持っている場合、ターゲットデータベースのレコードが保持されます。ソースデータベースのレコードはターゲットデータベースに同期されません。

        • これにより、データ初期化が失敗したり、一部のデータのみが同期されたり、同期全体が失敗したりする可能性があります。

      同期トポロジ

      双方向同期 を選択します。

      DDL 操作を除外

      • ○:DDL 操作は同期されません。

      • いいえ:DDL 操作は同期されます。

        重要

        DDL 同期は転送方向でのみサポートされます。逆方向の DDL 同期はサポートされていません。

      競合修復ポリシー

      競合解決ポリシーを選択します。Ignore のみがサポートされています。DTS は宛先レコードを保持し、競合するソースの変更を破棄します。

      「サポートされる競合検出」に記載されている競合が発生した場合、DTS は競合する文をスキップし、宛先レコードを保持します。

      移行先インスタンスでのオブジェクト名の大文字化

      宛先インスタンスに同期されるデータベースおよびコレクションオブジェクトの英語名の大文字・小文字の扱いポリシーを設定できます。デフォルトオプションである DTS のデフォルトポリシー を選択するか、ソースまたはターゲットデータベースのデフォルトポリシーを使用できます。詳細については、「宛先オブジェクト名の大文字・小文字の扱いポリシー」をご参照ください。

      ソースオブジェクト

      ソースオブジェクト ボックスで、同期するオブジェクトをクリックし、向右 をクリックして 選択中のオブジェクト ボックスに移動させます。

      説明

      オブジェクトは、DATABASE または COLLECTION レベルで選択できます。

      選択中のオブジェクト

      • 宛先インスタンスでの同期オブジェクト名を設定するか、どのオブジェクトがデータを受信するかを指定するには、選択中のオブジェクト ボックスで同期オブジェクトを右クリックして変更します。詳細については、「テーブル名およびカラム名のマッピング」をご参照ください。

      • 同期オブジェクトを削除するには、選択中のオブジェクト ボックスでそのオブジェクトをクリックし、image をクリックして ソースオブジェクト ボックスに移動させます。

      説明
      • データベースまたはコレクションレベルで増分操作を選択するには、選択中のオブジェクト ボックスで目的のオブジェクトを右クリックし、表示されるダイアログボックスで選択を行います。

      • データをフィルターする場合(完全同期中はサポートされますが、増分同期中はサポートされません)、選択中のオブジェクト ボックスで目的のコレクションを右クリックし、表示されるダイアログボックスで設定を行います。手順については、「フィルター条件の設定」をご参照ください。

      • オブジェクト名マッピング機能を使用してデータを受信するデータベースまたはコレクションを指定すると、マッピングされたオブジェクトに依存する他のオブジェクトの同期が失敗する可能性があります。

    2. 詳細設定へ をクリックして、高度なパラメーターを設定します。

      パラメーター

      説明

      タスクのスケジュールに使用する専用クラスターの選択

      デフォルトでは、DTS は共有クラスター上でタスクをスケジューリングするため、クラスターを選択する必要はありません。より安定したパフォーマンスを求める場合は、DTS 同期タスクを実行するための専用クラスターを購入できます。詳細については、「DTS 専用クラスターとは」をご参照ください。

      失敗した接続の再試行時間

      同期タスク開始後、ソースまたはターゲットデータベースへの接続が失敗した場合、DTS はエラーを報告し、直ちに接続の再試行を開始します。デフォルトの再試行時間は 720 分です。10 ~ 1,440 分の範囲でカスタム再試行時間を指定することもできます。30 分以上に設定することを推奨します。指定された時間内に DTS がデータベースへの再接続に成功した場合、同期タスクは自動的に再開されます。そうでない場合、タスクは失敗します。

      説明
      • 同じソースまたはターゲットを共有する複数の DTS インスタンス(例:インスタンス A とインスタンス B)があり、インスタンス A のネットワーク再試行時間を 30 分、インスタンス B を 60 分に設定した場合、両方に短い方の 30 分が適用されます。

      • DTS は接続再試行期間中もタスクランタイムに対して課金するため、ビジネスニーズに基づいて再試行時間をカスタマイズするか、ソースおよびターゲットデータベースインスタンスをリリースした後はできるだけ早く DTS インスタンスをリリースすることを推奨します。

      移行元データベースと移行先データベースで他の問題が発生した場合の、再試行までの待機時間です。

      同期タスク開始後、ソースまたはターゲットデータベースで接続性以外の問題(DDL または DML 実行例外など)が発生した場合、DTS はエラーを報告し、直ちに継続的な再試行操作を開始します。デフォルトの再試行時間は 10 分です。1 ~ 1,440 分の範囲で再試行時間をカスタマイズすることもできます。10 分以上に設定することを推奨します。設定された再試行時間内に関連操作が成功した場合、同期タスクは自動的に再開されます。そうでない場合、タスクは失敗します。

      重要

      移行元データベースと移行先データベースで他の問題が発生した場合の、再試行までの待機時間です。 の値は、失敗した接続の再試行時間 の値より小さくする必要があります。

      完全同期レートを制限するかどうか

      完全同期フェーズ中、DTS はソースおよびターゲットデータベースの読み取りおよび書き込みリソースを消費するため、データベース負荷が増加します。ソースおよびターゲットデータベースの負荷を軽減するために、1 秒あたりのソースデータベースのクエリ率 QPS、1 秒あたりの完全移行の行数 RPS、および 1 秒あたりの完全移行データ量 (MB) BPS パラメーターを設定して、完全同期タスクのレート制限を設定できます。

      説明
      • この設定項目は、同期タイプ が 完全データ同期 に設定されている場合にのみ利用可能です。

      • 同期インスタンスの実行後も、完全同期レートを調整 できます。

      同期するデータのうち、同一テーブル内のプライマリキー_id のデータ型が一意かどうか

      同期対象の各コレクション内で、_id プライマリキーのデータ型が一意かどうかを指定します。

      重要
      • 実際のデータに基づいてオプションを選択してください。誤った選択により、データ損失が発生する可能性があります。

      • このパラメーターは、同期タイプ に 完全データ同期 が含まれている場合にのみ利用可能です。

      • ○:データ型は一意です。完全同期フェーズ中、DTS はソースデータのプライマリキーのデータ型をスキャンしません。各コレクションについて、DTS は 1 つのプライマリキーのデータ型に対応するデータのみを同期します。

      • ×:データ型は一意ではありません。完全同期フェーズ中、DTS はソースデータのプライマリキーのデータ型をスキャンし、すべてのデータを同期します。

      増分同期率を制限するかどうか

      増分同期タスクのレート制限を設定することもできます。ターゲットデータベースの負荷を軽減するために、1 秒あたりの増分同期の行数 RPS および 1 秒あたりの増分同期データ量 (MB) BPS を設定してください。

      環境タグ

      任意です。インスタンスを識別するために環境タグを選択します。

      ETL 機能の設定

      抽出・変換・書き出し (ETL) 機能を有効にするかどうかを選択します。詳細については、「ETL とは」をご参照ください。有効値:

      監視アラート

      アラートを設定するかどうかを指定します。同期が失敗した場合や、遅延が指定されたしきい値を超えた場合、アラート連絡先に通知が送信されます。

    3. 次へ:データ検証 をクリックして、データ検証タスクを設定します。

      データ検証機能を使用する場合は、「データ検証の設定」をご参照のうえ、設定手順に従ってください。

  6. タスクを保存して事前チェックを実行します。

    • このインスタンスを設定するための API パラメーターを表示するには、次:タスク設定の保存と事前チェック ボタンにカーソルを合わせ、表示されるバルーンで OpenAPI パラメーターのプレビュー をクリックします。

    • API パラメーターの確認が完了したら、ページ下部の 次:タスク設定の保存と事前チェック をクリックします。

    説明
    • 同期ジョブ開始前に、DTS が事前チェックを実行します。すべての事前チェック項目が合格した場合にのみ、ジョブを開始できます。

    • 事前チェックが失敗した場合は、失敗した項目の横にある 詳細を表示 をクリックします。表示された指示に従って問題を修正し、再度事前チェックを実行してください。

    • 事前チェックで警告が返された場合:

      • チェック項目が失敗し、無視できない場合は、項目の横にある 詳細を表示 をクリックします。指示に従って問題を修正し、再度事前チェックを実行してください。

      • 無視可能なチェック項目については、アラートの詳細を確認、無視、OK、再度事前チェックを実行 の順にクリックして、警告をスキップして事前チェックを再実行できます。警告項目を非表示にすると、データの不整合などの問題が発生し、ビジネスにリスクをもたらす可能性があります。

  7. インスタンスを購入します。

    1. 成功率 が 100 % になったら、次:インスタンスの購入 をクリックします。

    2. 購入 ページで、データ同期インスタンスの課金方法およびリンク仕様を選択します。以下の表でこれらのパラメーターについて詳しく説明します。

      カテゴリ

      パラメーター

      説明

      新しいインスタンスクラス

      課金方法

      • サブスクリプション:インスタンス作成時に支払いを行います。長期的なニーズに適しており、従量課金よりもコスト効率が高くなります。サブスクリプション期間が長いほど、割引率が高くなります。

      • 従量課金:1 時間ごとに課金されます。短期的なニーズに適しています。使用後すぐにインスタンスをリリースすることでコストを節約できます。

      リソースグループ構成

      インスタンスが属するリソースグループです。デフォルトは default resource group です。詳細については、「Resource Management とは」をご参照ください。

      リンク仕様

      DTS は、さまざまなパフォーマンスレベルを持つ同期仕様を提供しています。同期リンク仕様は同期レートに影響します。ビジネスシナリオに基づいて仕様を選択できます。詳細については、「データ同期リンク仕様」をご参照ください。

      サブスクリプション期間

      サブスクリプションモードでは、サブスクリプションインスタンスの期間および数量を選択します。1 ~ 9 ヶ月の月額サブスクリプション、または 1、2、3、5 年の年額サブスクリプションを選択できます。

      説明

      このオプションは、課金方法が サブスクリプション の場合にのみ利用可能です。

    3. Data Transmission Service (従量課金) 利用規約 を読み、同意してください。

    4. 購入して起動 をクリックします。OK ダイアログボックスで、OK をクリックします。

      データ同期ページでタスクの進捗状況を確認できます。

  8. 逆同期タスクを設定します。

    1. 転送同期タスクの初期化が完了し、ステータス が 実行中 になるまで待ちます。

    2. 逆同期タスクを見つけ、タスクの設定 をクリックします。

    3. ステップ 3 から ステップ 6 を繰り返して、逆同期タスクを設定します。

      重要
      • 逆タスクでは、ソースとターゲットが入れ替わります。つまり、ソースは転送タスクのターゲットとなり、その逆も同様です。データベース名、アカウント、パスワードが正しいことを確認してください。

      • 逆タスクでマッピング名を変更しないことを推奨します。変更すると、データの不整合が発生する可能性があります。

      • 逆タスクでは インスタンスのリージョン を変更できません。逆タスクのパラメーターは少なく、コンソールに表示される値を使用してください。

      • 逆タスクの 競合するテーブルの処理モード 設定では、転送タスクですでに同期されたコレクションはチェックされません。

      • 逆同期タスクは、転送タスクの 選択中のオブジェクト リストにすでに含まれているオブジェクトを同期できません。

      • 逆同期タスクは DDL 操作を自動的に除外します。

    4. 成功率 が 100% になったら、戻る をクリックします。

  9. 逆タスクの設定後、両方のタスクの ステータス が 実行中 になるまで待ちます。これで双方向同期がアクティブになります。