オンプレミス VMware 環境にディザスタリカバリゲートウェイをインストールし、アクティベーションを実行します。アクティベーション完了後、Cloud Backup コンソールからバックアップジョブと復元ジョブを作成します。Cloud Backup は、オンプレミス VMware 仮想マシンのバックアップと復元を行います。
(推奨) ディザスタリカバリ向け RAM ユーザー AccessKey の使用
Resource Access Management (RAM) は、Alibaba Cloud のサービスです。1 つのアカウント配下で、アクセス許可が異なる複数の ID を作成して管理できます。
ディザスタリカバリゲートウェイをアクティベーションするには、AccessKey が必要です。Alibaba Cloud アカウントの AccessKey には、すべてのリソースへのフルアクセス権限があります。漏えいすると、すべてのリソースがリスクにさらされます。代わりに RAM ユーザー AccessKey を使用してください。開始する前に、RAM ユーザーと AccessKey ペアを作成してください: RAM ユーザーの作成、 AccessKey ペアの作成。
前提条件
-
Alibaba Cloud の Cloud Backup サービスが有効化されていること。 Cloud Backup の有効化は無料ですが、Cloud Backup の VMware バックアップとディザスタリカバリ機能を使用する場合、Cloud Backup のストレージ容量と VMware バックアップソフトウェアの料金が発生します。 詳細については、VMware バックアップとディザスタリカバリの料金をご参照ください。
-
vCenter Server とそのリソースにアクセスする権限を持つ VMware アカウントの認証情報があること。
注意事項
-
オペレーティングシステムと VMware プラットフォームのサポートには制限があり、権限の場所とカテゴリは vCenter のバージョンによって異なります。詳細については、VMware ディザスタリカバリの制限をご参照ください。
-
ゲートウェイの AccessKey は、期限切れになるか、ローテーションされる可能性があります。ローテーションされた場合は、ゲートウェイを再アクティブ化しないと、バックアップは失敗します。詳細については、VMware ディザスタリカバリゲートウェイの AccessKey を変更して再アクティブ化するにはどうすればよいですか?をご参照ください。
ステップ 1:バックアップ アカウントの作成
vCenter Server で VMware ロールとユーザーを作成し、そのロールをユーザーに割り当てます。このアカウントを使用することで、Cloud Backup は vCenter Server のリソースにアクセスできるようになります。
-
vSphere Web Client にログインします。
-
VMware ロールを作成します。
-
[メニュー] > [管理] の順にクリックします。
-
[ロール] タブのプラスアイコンをクリックします。
-
[新しいロール] ダイアログボックスで、以下の表から必要な許可を選択し、[次へ] をクリックします。
説明権限の場所とカテゴリは、vCenter のバージョンによって異なる場合があります。必ず注意深く確認してください。
-
-
[ロール名]と[説明]を入力し、 [完了] をクリックします。
HBRBackupAdminRole など、識別しやすい名前を使用してください。たとえば、[ロール名]を
HBRBackupAdminRoleに設定し、[説明]をHBR のバックアップロールに設定します。
-
-
VMware ユーザーを作成します。
-
[メニュー] をクリックし、[管理者] を選択します。
-
[ユーザーとグループ] タブで、[ドメイン] ドロップダウンリストからローカルドメインを選択し、[ユーザーの追加] をクリックします。
-
[ユーザーの追加] ダイアログボックスで、[ユーザー名] と [パスワード] を入力し、[追加] をクリックします。
識別しやすい名前を使用してください。例: BackupAdmin。
重要ユーザー名とパスワードは安全な場所に保存してください。この認証情報は、Cloud Backup コンソールで vCenter Server を追加する際に必要です。
-
-
VMware ユーザーに VMware ロールを割り当てます。
-
[メニュー] をクリックし、[管理] を選択します。
-
[グローバル権限] タブで、プラスアイコンをクリックします。
-
[権限の追加] ダイアログボックスで、次のパラメーターを設定し、[OK] をクリックします。
-
ステップ 2: ディザスタリカバリゲートウェイの追加
ディザスタリカバリゲートウェイは、バックアップジョブと復元ジョブを実行します。vSphere Client がデプロイされているサーバーでゲートウェイを設定し、ダウンロードします。
-
vSphere Client がデプロイされているサーバーで、Cloud Backup コンソールにサインインします。
-
左側のナビゲーションペインで、 を選択します。
-
上部メニューの左上で、リージョンを選択します。
-
[VMware バックアップ・ディザスタリカバリ] ページの右上隅で、バックアップリカバリゲートウェイの追加 をクリックします。
-
バックアップリカバリゲートウェイの追加 パネルで、パラメーターを設定し、作成 をクリックします。
パラメーター
説明
[バックアップボールト設定]
バックアップを保存するためのバックアップボールトを設定します。
-
[バックアップボールトの作成]: 新しいバックアップボールトの名前を入力するか、空白のままにして名前が自動的に割り当てられるようにします。
-
[バックアップボールトの選択]: 既存のバックアップボールトを選択します。
重要バックアップボールトを作成してデータを保存すると、Cloud Backup はストレージ容量などのリソースに対して課金します。詳細については、「課金方法と課金項目」をご参照ください。
データの冗長性を最大化するため、Cloud Backup は、利用可能な場合はデフォルトでゾーン冗長ストレージ (ZRS) ボールトを使用します。ローカル冗長ストレージ (LRS) のみのリージョンでは、Cloud Backup は LRS ボールトを使用します。ボールトタイプを手動で選択する必要はありません。
[バックアップボールト名]
バックアップボールトの名前。
[バックアップボールトリソースグループ]
このパラメーターは、バックアップボールト設定 を [バックアップボールトの作成] に設定した場合にのみ必要です。バックアップボールトが属するリソースグループを指定します。
リソースグループを使用すると、リソースを論理グループ単位で管理し、権限を付与できます。詳細については、「リソースグループの作成」をご参照ください。
ゲートウェイ名
ゲートウェイの名前。64 文字以内で指定します。
VMware 環境
VM がデプロイされている VMware プラットフォームです。このチュートリアルでは、オンプレミス vSphere を選択します。
-
[オンプレミス vSphere]: VM はローカルデータセンター内のサーバーにデプロイされます。
-
[Alibaba Cloud VMware Service (ACVS)]: VM は Alibaba Cloud VMware Service 内にデプロイされます。
ネットワークタイプ
ネットワークタイプ。このチュートリアルでは、パブリックネットワーク を選択します。
-
[VPC]: バックアップボールトと同じリージョンにある VPC を使用する VM の場合は、このオプションを選択します。
説明VMware バックアップクライアントには、Alibaba Cloud VPC へのネットワークルートが必要です。オンプレミスネットワークからクラウドへのルートは、サービス CIDR ブロック (100.64.0.0/10 または 100.96.0.0/11) へのトラフィックを許可する必要があります。
-
[パブリックネットワーク]: VPC 接続が利用できない場合は、このオプションを選択します。
データ転送に HTTPS を使用
このオプションを有効にすると、データは HTTPS 経由で転送されます。パフォーマンスが低下する場合があります。この設定に関わらず、データは保存前に常に暗号化されます。この設定は、次回のバックアップジョブまたは復元ジョブから有効になります。
-
-
バックアップリカバリゲートウェイの追加 パネルで、ダウンロードゲートウェイ と 証明書のダウンロード をクリックします。
ダウンロードされたディザスタリカバリゲートウェイパッケージは、ステップ 3:ディザスタリカバリゲートウェイのインストール に必要な OVF テンプレートです。
説明インストールパッケージはゲートウェイを Cloud Backup に接続し、証明書はゲートウェイをアクティブ化するために使用されます。クライアントのリストからいつでもゲートウェイをダウンロードしてデプロイできます。
ステップ 3: ディザスタリカバリゲートウェイのインストール
ゲートウェイと証明書をダウンロードした後、VMware 環境にゲートウェイをインストールします。
-
vSphere Web Client にログオンします。
-
Cloud Backup は vCenter Server 6.7 以降のみをサポートします。
-
ブラウザを使用して vSphere Web Client (Flash または HTML5) にアクセスします。
-
-
左側のナビゲーションペインで、ゲートウェイをデプロイする仮想マシンを右クリックし、[OVF テンプレートのデプロイ] を選択します。
OVF デプロイの詳細な手順については、OVF テンプレートのデプロイをご参照ください。
-
[OVF テンプレートのデプロイ] ページで、[ローカル ファイル] を選択します。[ファイルをアップロード] をクリックし、ダウンロードした災害復旧ゲートウェイのインストールパッケージを選択して、[次へ] をクリックします。
説明Cloud Backup は、ダウンロードを簡素化するために OVA 形式のクライアントパッケージを提供しています。このパッケージは、Web Client で OVF テンプレートとして直接デプロイされます。
-
仮想マシンの名前を入力し、デプロイ場所を選択し、[次へ] をクリックします。
デプロイ先として、ロケーションツリー内の[データセンター] ノードを選択します。
-
デプロイされたテンプレート用のコンピューティングリソースを選択し、[次へ] をクリックします。
下部の [互換性] エリアに [互換性チェックに成功しました] と表示されていることを確認します。
-
テンプレートの詳細を確認し、[次へ] をクリックします。
テンプレートの詳細には、次の情報が含まれます:
製品: Hybrid Backup Recovery Appliance
バージョン: 1.0.18
ダウンロードサイズ: 1.9 GB
ディスクサイズ: 3.7 GB (シンプロビジョニング) / 100.0 GB (シックプロビジョニング)
-
仮想ディスクフォーマットを選択し、デプロイされたテンプレートファイルの保存場所を選択し、[次へ] をクリックします。
[VM ストレージポリシー] ドロップダウンリストはデフォルト値のままにし、下部に [互換性チェックに成功しました] が表示されることを確認します。
-
各送信元ネットワークに対して宛先ネットワークを選択し、[次へ] をクリックします。
[IP 割り当て設定] セクションで、[IP 割り当て] を [静的 - 手動] に、[IP プロトコル] を [IPv4] に設定します。
-
デプロイプロパティをカスタマイズして、[次へ] をクリックします。
-
DHCP を使用する場合、ゲートウェイ、IP、ネットマスクを指定する必要はありません。静的 IP の場合は、これらの値を指定します。
-
プライマリ DNS とセカンダリ DNS サーバーが、Cloud Backup、vCenter Server、および ESXi のドメイン名を解決できることを確認してください。
-
管理者ユーザー名と管理者ユーザーパスワードで、ゲートウェイ VM の認証情報を設定します。このユーザーは、VM ログインの root 権限を持ちます。
-
-
設定内容を確認し、[完了] をクリックします。
-
-
[最近のタスク] ペインで、タスクが完了するまで監視します。
タスクリストには、[OVF パッケージのインポート] と [OVF テンプレートのデプロイ] のタスクが表示されます。ステータス列には現在の進捗率が表示されます。ステータスが完了に変わるまで待機します。
ステップ 4:ディザスタリカバリゲートウェイのアクティベーション
VMware ディザスタリカバリゲートウェイは、作成から 48 時間以内にアクティベーションされない場合、システムによって自動的に削除されます。
-
デプロイ後、OVF テンプレートからデプロイされた VM を起動します。
-
ブラウザを開き、アドレスバーに
http://hostname:8011と入力します。hostnameは、OVF テンプレートからデプロイされたゲートウェイ VM の IP アドレスです。 -
[登録] ページでパラメーターを設定し、[登録] をクリックしてディザスタリカバリゲートウェイにログインします。次の表で各パラメーターを説明します。
パラメーター
説明
AccessKey ID
Cloud Backup がアクティベートされている Alibaba Cloud アカウントから RAM ユーザーの AccessKey ID と AccessKey Secret を取得します。RAM ユーザーの AccessKey ペアの作成。
説明ゲートウェイの AccessKey は、有効期限が切れるか、ローテーションされる可能性があります。ローテーションされた場合は、ゲートウェイを再アクティベーションしないとバックアップジョブは失敗します。VMware バックアップゲートウェイをリセット (AccessKey ペアを変更) するにはどうすればよいですか?。
AccessKey Secret
パスワード
ゲートウェイのログインパスワード。6 文字以上の長さが必要です。
証明書ファイル
コンソールからダウンロードした証明書を選択します。アクティベーション後にゲートウェイの電源が 5 日以上オフになっている場合、証明書の有効期限が切れるため、新しい証明書をダウンロードして再アクティベーションする必要があります。
ゲートウェイをアクティベーションすると、VMware バックアップ・ディザスタリカバリ ページの バックアップリカバリゲートウェイ タブで、そのステータスが [有効化済み] に変わります。また、[操作] 列で次の操作を実行できます:
-
フロー制御:時間帯ごとにトラフィック制限を設定し、バックアップジョブが VMware のリソースを過剰に消費するのを防ぎます。
-
<hd>その他</hd>:
-
ダウンロードゲートウェイ:ディザスタリカバリゲートウェイのインストールパッケージをダウンロードします。
-
証明書のダウンロード:ディザスタリカバリゲートウェイのアクティベーション証明書をダウンロードします。
-
削除:クライアントとそのすべてのバックアップデータを削除します。実行中のバックアップジョブまたは復元ジョブは失敗します。データが不要になったこと、および進行中のジョブがないことを確認してください。
-
网关设置:データ転送用の HTTPS、最大ワーカースレッド数、および CPU コア数を設定します。
-
-
よくある質問
OVA テンプレートのデプロイメントでエラーが発生した場合
OVA テンプレートをデプロイするには、vCenter Server 6.7 以降で管理されている vSphere Web Client を使用します。エラーが発生した場合は、次の点を確認してください。
-
Cloud Backup がお使いの vCenter Server のバージョンをサポートしていることを確認してください。
-
デプロイメント中に「一般的なエラー」メッセージが表示される場合は、ブラウザの言語を英語に変更してから、テンプレートを再度デプロイしてください。
vCenter Server の追加に失敗した場合
パスワードに次の特殊文字のいずれかが含まれている場合、この操作は失敗する可能性があります。
` ^ ~ = ; ! / ( [ ] { } @ $ \ & # % +
ベストプラクティスとして、管理者ロールを持つ専用の vCenter Server バックアップアカウントを作成してください。認証失敗を防ぐため、パスワードには、特殊文字としてピリオド (.) のみを使用してください。詳細については、バックアップアカウントの作成をご参照ください。