This topic describes the cause of the "S3_* An error occurred in the data synchronization of the disk partition." error message that is reported when you use Server Migration Center (SMC) to run a migration job. This topic also describes how to resolve the error.
Problem description
During an SMC migration job, the "S3_* An error occurred in the data synchronization of the disk partition." error message is reported. The following S3_* error codes may be reported:
S3_F30
S3_F32
S3_F6
S3_F4
S3_F40
S3_F70
Cause
An error occurred when the SMC client synchronized the data from the disk partitions of the source server at block level. The following list describes the possible causes of different error codes:
S3_F30, S3_F32, and S3_F6: An error occurred when data was read from the disk partitions of the source server.
S3_F4: The network over which the data in the disk partitions of the source server is synchronized at block level is disconnected.
S3_F40: The source server cannot access the IP address of the destination instance by using port 8703.
S3_F70: The migration job timed out because the block-level data synchronization from the disk partitions of the source server stopped.
Solution
Resolve the error based on the error code.
S3_F30, S3_F32, and S3_F6
If block replication is enabled, the SMC client automatically creates a snapshot device for a disk partition on the source server for data synchronization. These error codes may be reported if the device is disabled or an error occurs in the device. For more information about how to check and resolve this error, see What do I do if I receive an S6 error code indicating an error during the snapshot creation of a disk partition?
S3_F4
Check whether the network over which the source server accesses the IP address of the destination instance by using port 8703 is stable. Do not interrupt the network connection during a migration job. Retry the migration job when the network is stable.
S3_F40
Check whether the source server can access the IP address of the destination instance by using port 8703.
Check whether the security group of the destination instance allows inbound traffic from port 8703. If yes, check whether a security group rule forbids inbound traffic from port 8703.
NoteBy default, an SMC migration job automatically associates a temporary security group with the destination instance to allow inbound traffic from port 8703.
Check the local network configurations or intermediate network devices. For example, check whether the required IP address and port are blocked by the firewall or whether the proxy server forbids outbound traffic to the required IP address and port.
Check whether Alibaba Cloud Cloud Firewall is enabled and whether access control policies are configured to block network access, such as Internet firewall and VPC firewall. For more information, see Firewall Settings.
S3_F70
Check whether the network over which the source server accesses the IP address of the destination instance by using port 8703 is stable and whether the bandwidth of the source server is sufficient. If the bandwidth is low, the transfer speed is low and the migration job may time out.
After the error is resolved, run the SMC client and retry the migration job. For more information, see Run the SMC client.