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Server Migration Center:What do I do if I receive an S6 error code indicating an error during the snapshot creation of a disk partition?

Last Updated:Sep 12, 2024

This topic describes the cause of the "S6_* An error occurred in the snapshot creation of the disk partition." error message that is reported when you use Server Migration Center (SMC) to run a migration job. This topic also describes how to resolve the error.

Problem description

During an SMC migration job, the "S6_* An error occurred in the snapshot creation of the disk partition." error message is reported. The following S6_* error codes may be reported:

  • S6_8

  • S6_1

Cause

If block replication is enabled, the SMC client automatically creates a snapshot device for a disk partition on the source server for data synchronization. The SMC client of the source server may fail to create a snapshot for a disk partition due to the following causes based on the operating system that the source server runs:

  • Windows server:

    • The storage space of the disk partition is insufficient.

    • Third-party antivirus software is installed.

    • The maximum storage space specified by Volume Shadow Copy Service (VSS) for the disk partition is insufficient.

    • VSS cannot be used as expected.

  • Linux server:

    • The storage space of the disk partition is insufficient.

    • The available memory of the server is less than 300 MB.

    • The snapshot device of the disk partition cannot be used as expected.

Solution

Resolve errors based on the operating system that the source server runs.

  • Windows server:

    Open Event Viewer to check whether exceptions related to VSS, volsnap, and the disk occur. If these exceptions occur, resolve errors based on the error messages.

    • If an error indicating that the storage space of the disk is insufficient or VSS cannot create more snapshots is reported,

      • check whether the remaining space of the disk partition is insufficient. We recommend that you reserve 10% to 15% of the disk space.

      • check whether the maximum storage space specified by VSS for the disk partition is insufficient. We recommend that you increase the upper limit or remove the limit and create a snapshot again.

    • If the access to VSS is denied and the error code 0x80070005 is returned, check whether third-party antivirus software is installed. We recommend that you enable disk backup or disable the antivirus software and create a snapshot again.

    • Check whether VSS can be used as expected.

  • Linux server:

    1. Check whether the smcss9 driver exists in the /dev directory. Run the dmesg | grep smcss command to check whether errors related to smcss9 are reported.

      1. Check whether the available memory of the server reaches 300 MB.

      2. Check whether the remaining space of the disk partition is insufficient. We recommend that you reserve 10% to 15% of the disk space.

      3. Run the ./Check/client_check --ssclear smcss command in the installation directory of the SMC client, remove the remaining snapshot devices, and then create a snapshot again. For more information about how to find the installation directory of the SMC client, see the "View the SMC client" section of the View and run the SMC client topic.

    2. Optional. If the error information contains "io scheduler not support", perform the following steps to change the I/O scheduler of the disk:

      1. Determine the serial number of the disk on which the error occurred.

        View the value of msg in the error information and determine the serial number based on the following pattern: 0-x indicates the first disk, 1-x indicates the second disk, and 2-x indicates the third disk. Example: msg=CreateSnapshot 0-x Failed.

      2. Determine the disk name based on the serial number obtained in Step i.

        Run the lsblk command to determine the disk name corresponding to the obtained serial number. Serial numbers start from 0.

        image

      3. View the I/O scheduler used by the disk based on the disk name obtained in Step ii.

        For example, run the cat /sys/block/vdb/queue/scheduler command to view the I/O scheduler used by the disk named vdb.

        The following figure shows the returned information. The I/O scheduler named bfq that is given in brackets ([]) is used by the disk vdb.

        image

        Note

        The returned information lists all I/O schedulers: mq-deadline, kyber, bfq, and none.

      4. Replace the current I/O scheduler bfq with another I/O scheduler.

        Replace the current I/O scheduler bfq with another I/O scheduler. For example, you can replace bfq with mq-deadline.

        Run the sudo echo mq-deadline > /sys/block/vdb/queue/scheduler command to replace the I/O scheduler.

        Run the cat /sys/block/vdb/queue/scheduler command to view the current I/O scheduler used by this disk. You can see that the I/O scheduler in use is changed from bfq to mq-deadline.

        image

After the error is resolved, run the SMC client and retry the migration job. For more information, see Run the SMC client.