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Server Migration Center:Error message S0 client calls SMC service error

Last Updated:Jul 17, 2025

This topic describes the error message "S0_* client calls SMC service error" that may occur during SMC migration, including the problem description, causes, and solutions.

Problem description

During SMC migration, the error message "S0_* client calls SMC service error" is displayed. The possible error codes for S0_* are as follows:

  • S0_U28

  • S0_U7

  • S0_U56

  • S0_U6

  • S0_U35

  • S0_U52

Cause

The network connection from the source system to the SMC service domain is unavailable.

Solution

  1. Confirm the SMC service domain.

    The service domains of SMC include the client download address, default activation code domain, and Alibaba Cloud AccessKey pair domain, as described below:

    • SMC client storage address

      Default public domain: https://p2v-tools.oss-cn-hangzhou.aliyuncs.com

    • Default activation code domain (for importing through command line or manually generating activation codes):

      • Default public domain: https://smc-service.aliyuncs.com.

      • ECS internal domain: https://<region-id>.axt.aliyun.com (accessible only from Alibaba Cloud ECS).

    • Alibaba Cloud AccessKey pair domain (for manually downloading the client and entering the AccessKey pair):

      • Default public domain: https://smc.aliyuncs.com (server IP: 101.37.132.1, 47.111.202.72).

      • ECS internal domain: https://smc.vpc-proxy.aliyuncs.com (accessible only from Alibaba Cloud ECS).

    Note
    • By default, SMC domains use HTTPS protocol on port 443. HTTP protocol on port 80 may not be supported.

    • If you can directly access a virtual private cloud (VPC) in an Alibaba Cloud region from your on-premises IDC, virtual machine environment, or cloud host, we recommend that you use the private network transmission migration solution of SMC. Private network transmission migration is faster and more stable than Internet transmission migration and can improve migration efficiency.

  2. Check whether the network service of the source system is normal.

    1. Check whether the local network service of the source system is normal, and whether the hosts, DNS, and other configurations are normal.

    2. Migration tasks use the public mode for transmission by default. You need to ensure that the source system can access the Internet.

    3. If the private mode is selected for the migration task, you need to ensure that the private network from the source system to the target VPC/vSwitch is connected. For more information, see Private network migration.

      Note

      If you are not sure whether the private network is connected, we generally recommend that you select the public mode for transmission. If you have incorrectly selected the private mode, you can reselect the public mode and try again.

  3. Check whether the network access from the source system to the SMC service domain is normal.

    1. Use the ping command on the source system to test whether the network from the source system to the SMC service domain is normal.

      If the test fails, you need to check the local network configuration or intermediate network devices, such as whether the firewall or proxy has outbound restrictions on the SMC service domain IP.

    2. On Linux systems, use the curl command to access the SMC service domain. On Windows, use a browser to access the SMC service domain to test whether the source system can access the SMC service domain.

      If the access fails, you need to check the local network configuration or intermediate network devices, such as whether the firewall or proxy has outbound restrictions on the SMC service domain IP port access.

  4. After the problem is resolved, run the SMC client again. For more information, see Run the SMC client.