This topic describes the causes and solutions for "S0_*" errors, which occur when the Server Migration Center (SMC) client fails to connect to the SMC service.
Description
During an SMC migration job, the "S0_* An error occurred in the invocation of SMC by the SMC client." error message is reported. The following S0_* error codes may be reported:
S0_U28
S0_U7
S0_U56
S0_U6
S0_U35
S0_U52
Cause
The source server cannot establish a network connection to the required SMC service endpoints.
Solution
Check the endpoint of SMC.
The endpoint of SMC varies based on whether the migration source is activated by using an activation code or an AccessKey pair.101.37.XXX.X
SMC client storage address
Default public domain: https://p2v-tools.oss-cn-hangzhou.aliyuncs.com
Default activation code domain (for importing through command line or manually generating activation codes):
Default public domain: https://smc-service.aliyuncs.com.
ECS internal domain: https://<region-id>.axt.aliyun.com (accessible only from Alibaba Cloud ECS).
Alibaba Cloud AccessKey pair domain (for manually downloading the client and entering the AccessKey pair):
Default public domain: https://smc.aliyuncs.com (Server IP: 101.37.132.1, 47.111.202.72).
ECS internal domain: https://smc.vpc-proxy.aliyuncs.com (accessible only from Alibaba Cloud ECS).
NoteBy default, SMC domains use HTTPS protocol on port 443. HTTP protocol on port 80 may not be supported.
If you can directly access a virtual private cloud (VPC) in an Alibaba Cloud region from your on-premises data center, virtual machine environment, or cloud host, we recommend that you use the private network transmission migration solution of SMC. Private network transmission migration is faster and more stable than public network transmission migration and can improve migration efficiency.
Check the source server's network configuration.
Check whether the local network service of the source server is normal and whether the configurations such as the hosts file and Domain Name System (DNS) settings are valid.
By default, SMC migrates data over the Internet. Make sure that the source server can access the Internet.
If you migrate data over a VPC, make sure that the source server is connected to the specified VPC and vSwitch. For more information, see Migrate servers over a VPC.
NoteIf you are not sure whether the source server is connected to the specified VPC and vSwitch, we recommend that you set the Network Type parameter to Public Network when you create a migration job. If you set the Network Type parameter to VPC and the migration job fails, change the value of the Network Type parameter to Public Network and try again.
Check whether the network connection from the source server to the SMC endpoint is normal.
On the source server, use the
pingcommand to test basic network connectivity to the SMC endpoints.If the network is disconnected, check the local network configurations or intermediate network devices. For example, check whether the IP address of the SMC endpoint is blocked by the firewall or whether the proxy server forbids outbound traffic to the IP address of the SMC endpoint.
Run the
curlcommand on a Linux operating system or visit the SMC endpoint by using a browser on a Windows operating system to test whether the source server can access the SMC endpoint.If the test fails, check the local network configurations or intermediate network devices. For example, check whether the IP address and port of the SMC endpoint are blocked by the firewall or whether the proxy server forbids outbound traffic to the IP address and port of the SMC endpoint.
After you resolve the network issue, run the SMC client to retry the operation. For more information, see Run the SMC client.