No worker available
Symptom:
The system reports a "no worker available" error.
Cause:
The configuration is incorrect.
Solution:
You can log on to the worker and view the SchedulerX logs. The log path is /${user.home}/logs/schedulerx/worker.log.
If the process is started by the admin account, the log path is /home/admin/logs/schedulerx/worker.log.
If the process is started by the root account, the log path is /root/logs/schedulerx/worker.log.
You can search for the WorkerConfig keyword and check whether the Endpoint, Namespace, and GroupId are configured correctly.
DomainNotFoundException error during application publishing
Symptom:
Caused by: com.alibaba.schedulerx.worker.exception.DomainNotFoundException: Not found domainName
Cause:
The endpoint does not match the environment.
Solution:
You can check whether the online machine matches the endpoint. Local machines can connect only to public endpoints. For more information about the endpoints that SchedulerX supports, see Endpoints.
"can not find namespaceId" error during application publishing
Symptom:
The application fails to start and reports the following error.
can not find namespaceId, key: d783212a9c-5a00-4d00-b8ca-b7a68824c97f
source:schedulerx domain=schedulerx-test.console.aliyun.comCause:
The Namespace parameter is configured incorrectly.
The region of the deployment machine differs from the region of the namespace created in the Distributed Task Scheduling Platform console.
For example, the namespace is created in the China (Hangzhou) region, but the application is configured to connect to the public network region.
Solution:
You can log on to the the SchedulerX console. On the Application Management page, click Access Configuration and check the information.
How to test a local connection
In the SchedulerX console, you can switch the region to Public Network, and then create and connect an application in the public network environment. For more information, see Connect to the public network environment from an on-premises machine.

What to do if a local SchedulerX proxy cannot connect to the public network
If you can connect directly to the public network but cannot connect in proxy mode, you can specify the corresponding endpoint. For more information about the regions where you can deploy applications and their corresponding endpoints, see Endpoints.
Domain names cannot be resolved in a self-managed IDC or on an office network over a leased line
After you connect over a leased line, you can complete the Forwarding Management configuration and forward the DNS requests for internal domain names in an Alibaba Cloud VPC to an external DNS system. Then, your self-managed IDC or office network can correctly resolve the domain names.