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Serverless App Engine:What can I do if an application fails to be scaled in?

Last Updated:Nov 15, 2024

This topic describes how to resolve the scale-in failure for an application in SAE console.

Description

An application fails to be scaled in.

Possible cause

The monitoring metrics that are used to trigger the auto scaling policy are invalid.

Solution

  1. Log on to the SAE console, find the target instance, and click the Instance Information tab on the Basic Information page to check the threshold based on which an automatic scale-up is triggered and confirm whether the metrics are qualified.

    • If they are qualified, proceed to the next step.

    • If they are disqualified, modify the metrics.

  2. In the Advanced Settings pane of the auto scaling policy, check the Scale-in Stabilization Window to determine whether the threshold is met within the window time and whether Disable Scale-in is configured.