All Products
Search
Document Center

ApsaraDB RDS:ListUserBackupFiles

Last Updated:Aug 27, 2026

Queries the details about the full backup files that are imported into an instance.

Operation description

Supported database engines

  • MySQL

Feature description

  • A full backup file contains the data of a self-managed MySQL database. You can restore the data of a self-managed MySQL database from a full backup file to an ApsaraDB RDS for MySQL instance. For more information, see Migrate the data of a self-managed MySQL 5.7 instance to the cloud.
  • Before you call the CreateDBInstance operation to create an ApsaraDB RDS for MySQL instance into which you want to import full backup files, you can call this operation to query the IDs of full backup files.
  • You can call the ImportUserBackupFile operation to import a full backup file into an ApsaraDB RDS for MySQL instance.

Debugging

You can run this interface directly in OpenAPI Explorer, saving you the trouble of calculating signatures. After running successfully, OpenAPI Explorer can automatically generate SDK code samples.

Authorization information

The following table shows the authorization information corresponding to the API. The authorization information can be used in the Action policy element to grant a RAM user or RAM role the permissions to call this API operation. Description:

  • Operation: the value that you can use in the Action element to specify the operation on a resource.
  • Access level: the access level of each operation. The levels are read, write, and list.
  • Resource type: the type of the resource on which you can authorize the RAM user or the RAM role to perform the operation. Take note of the following items:
    • For mandatory resource types, indicate with a prefix of * .
    • If the permissions cannot be granted at the resource level, All Resources is used in the Resource type column of the operation.
  • Condition Key: the condition key that is defined by the cloud service.
  • Associated operation: other operations that the RAM user or the RAM role must have permissions to perform to complete the operation. To complete the operation, the RAM user or the RAM role must have the permissions to perform the associated operations.
Operation Access level Resource type Condition key Associated operation
rds:ListUserBackupFiles get
*All Resources
*
    none
none

Request parameters

Parameter Type Required Description Example
Status string No

The status of the full backup file. Valid values:

  • Importing: The full backup file is being imported.
  • Failed: The full backup file fails to be imported.
  • CheckSucccess: The full backup file passes the check.
  • BackupSuccess: The full backup file is imported.
  • Deleted: The full backup file is deleted.
CheckSuccess
RegionId string Yes

The region ID. You can call the DescribeRegions operation to query the most recent region list.

cn-hangzhou
Comment string No

The description of the full backup file.

Note The system implements a fuzzy match based on the value of this parameter.
BackupTest
BackupId string No

The ID of the full backup file.

b-kwwvr7v8t7of********
OssUrl string No

The URL from which you can download the full backup file that is stored as an object in an Object Storage Service (OSS) bucket. For more information about how to obtain the URL, see Obtain the access URL after you upload objects.

https://******.oss-ap-********.aliyuncs.com/backup_qp.xb
Tags string No

The tag that is added to the full backup file.

key1:value1
ResourceGroupId string No

The resource group ID. You can call the DescribeDBInstanceAttribute operation to obtain the ID of the resource group.

rg-acfmy*****

Response parameters

Parameter Type Description Example
object

The response parameters.

RequestId string

The ID of the request.

AD67C22F-64F3-4448-A9A8-D1606D242879
Records array<object>

The information about the full backup files.

Records object
Status string

The status of the full backup file. Valid values:

  • Importing: The full backup file is being imported.
  • Failed: The full backup file fails to be imported.
  • CheckSucccess: The full backup file passes the check.
  • BackupSuccess: The full backup file is imported.
  • Deleted: The full backup file is deleted.
BackupSuccess
CreationTime string

The time when the system started to import the full backup file. The value is a UNIX timestamp. Unit: milliseconds.

1623231084000
FinishTime string

The time when the full backup file is successfully imported. The value is a UNIX timestamp. Unit: milliseconds.

1623231750000
Comment string

The description of the full backup file.

BackupTest
OssFilePath string

The path of the full backup file that is stored as an object in an OSS bucket.

test/backup_qp.xb
OssBucket string

The name of the OSS bucket in which the full backup file is stored as an object.

BackupTest
ModificationTime string

The time when the full backup file is successfully imported. The value is a UNIX timestamp. Unit: milliseconds.

1623231750000
OssFileSize long

The size of the full backup file that is stored as an object in an OSS bucket. Unit: KB.

79115
OssFileName string

The name of the full backup file that is stored as an object in an OSS bucket.

backup_qp.xb
EngineVersion string

The database engine version.

5.7
BackupId string

The ID of the full backup file.

b-kwwvr7v8t7of********
RestoreSize string

The amount of storage that is required to restore the data of the full backup file. Unit: GB.

20
ZoneId string

The zone ID of the full backup file.

cn-hangzhou-b
Retention integer

The retention period of the full backup file. Unit: days.

3
Engine string

The database engine of the instance.

mysql
OssUrl string

The URL to download the full backup file from the OSS bucket.

https://******.oss-ap-********.aliyuncs.com/backup_qp.xb
OssFileMetaData string

The metadata of the full backup file. For more information, see Manage object metadata.

{\"Accept-Ranges\":\"bytes\",\"Connection\":\"keep-alive\",\"Content-Length\":81014337,\"Content-Type\":\"application/octet-stream\",\"Date\":1623309548000,\"ETag\":\"889FE9E5FCEBFE4781829488A352863B-1\",\"Last-Modified\":1622186844000,\"Server\":\"AliyunOSS\",\"x-oss-hash-crc64ecma\":\"5793608435727323129\",\"x-oss-object-type\":\"Multipart\",\"x-oss-request-id\":\"60C1BCEC92572F37318BD499\",\"x-oss-server-time\":\"166\",\"x-oss-storage-class\":\"Standard\"}
BinlogInfo string

The information about the binary log file that contains incremental data. If incremental data is generated during the full backup, this parameter is returned.

{\"binlogPosition\":\"154\",\"binlogFile\":\"0.000002\"}
Reason string

The reason why the full backup file failed to be imported.

success

Examples

Sample success responses

JSONformat

{
  "RequestId": "AD67C22F-64F3-4448-A9A8-D1606D242879",
  "Records": [
    {
      "Status": "BackupSuccess",
      "CreationTime": 1623231084000,
      "FinishTime": 1623231750000,
      "Comment": "BackupTest",
      "OssFilePath": "test/backup_qp.xb",
      "OssBucket": "BackupTest",
      "ModificationTime": 1623231750000,
      "OssFileSize": 79115,
      "OssFileName": "backup_qp.xb",
      "EngineVersion": 5.7,
      "BackupId": "b-kwwvr7v8t7of********",
      "RestoreSize": 20,
      "ZoneId": "cn-hangzhou-b",
      "Retention": 3,
      "Engine": "mysql",
      "OssUrl": "https://******.oss-ap-********.aliyuncs.com/backup_qp.xb",
      "OssFileMetaData": "{\\\"Accept-Ranges\\\":\\\"bytes\\\",\\\"Connection\\\":\\\"keep-alive\\\",\\\"Content-Length\\\":81014337,\\\"Content-Type\\\":\\\"application/octet-stream\\\",\\\"Date\\\":1623309548000,\\\"ETag\\\":\\\"889FE9E5FCEBFE4781829488A352863B-1\\\",\\\"Last-Modified\\\":1622186844000,\\\"Server\\\":\\\"AliyunOSS\\\",\\\"x-oss-hash-crc64ecma\\\":\\\"5793608435727323129\\\",\\\"x-oss-object-type\\\":\\\"Multipart\\\",\\\"x-oss-request-id\\\":\\\"60C1BCEC92572F37318BD499\\\",\\\"x-oss-server-time\\\":\\\"166\\\",\\\"x-oss-storage-class\\\":\\\"Standard\\\"}",
      "BinlogInfo": "{\\\"binlogPosition\\\":\\\"154\\\",\\\"binlogFile\\\":\\\"0.000002\\\"}",
      "Reason": "success"
    }
  ]
}

Error codes

HTTP status code Error code Error message Description
400 Order.ComboInstanceNotAllowOperate A package instance is not allowed to operate independently. A package instance is not allowed to operate independently.
400 Price.PricingPlanResultNotFound Pricing plan price result not found. Pricing plan price result not found.
400 Order.NoRealNameAuthentication You have not passed the real-name authentication and do not meet the purchase conditions. Please log in to the user center for real-name authentication. You have not passed the real-name authentication and do not meet the purchase conditions. Please log in to the cost and cost for real-name authentication.
400 InsufficientAvailableQuota Your account quota limit is less than 0, please recharge before trying to purchase. Your account available limit is less than 0, please recharge before trying to purchase.
400 CommodityServiceCalling.Exception Failed to call commodity service. Failed to call commodity service return.
400 RegionDissolvedEOM Dear customer, Alibaba Cloud plans to optimize and adjust the current region. Cloud services in this region will cease operations. You are currently unable to operate new purchase orders. Thank you for your understanding and support. Hello, Alibaba Cloud plans to optimize and adjust the current region. Cloud services in this region will stop operating. In order to ensure your business continuity and smooth transition of data migration, you are currently unable to operate new purchase orders. Thank you for your understanding and support.
400 Commodity.InvalidComponent The module you purchased is not legal, please buy it again. The module you purchased is not legal, please buy it again.
400 RegionEndTimeDissolvedIndia Cloud services in the India (Mumbai) region will be discontinued. Set the validity date to July 15, 2024 or earlier than July 15, 2024. Hello customer, this area has been abolished.
400 RegionEndTimeDissolvedAustralia Cloud services in the Australia (Sydney) region will be discontinued. Set the validity date to September 30, 2024 or earlier than September 30, 2024. Hello customer, this area has been abolished.
400 Price.CommoditySys Commodity system call exception. Commodity system call exception.
400 Pay.InsufficientBalance Insufficient available balance. Insufficient available balance.
400 Order.PeriodInvalid There is a problem with the period you selected, please choose again. There is a problem with the period you selected, please choose again.
400 pay.noCreditCard Account not bound to credit card. -
400 Order.InstHasUnpaidOrder There is an unpaid order for the service you have purchased. Please pay or void it before placing the order. There is an unpaid order for the service you have purchased. Please pay or void it before placing the order.
400 noAvailablePaymentMethod No payment method is specified for your account. We recommend that you add a payment method. No payment method has been specified for your account. We recommend that you add a payment method.
400 BasicInfoUncompleted Your information is incomplete. Complete your information before the operation. Your basic information is not complete, please complete your basic information before operation.
400 Risk.RiskControlRejection Your account is abnormal, please contact customer service for details. Your account is abnormal, please contact customer service for details.
400 BasicInfoUncompleted Your information is incomplete, Complete your information before the operation. -
400 System.SaleValidateFailed Sales expression validation system error. A system error occurs when the sales expression is verified.
400 ContainForbiddenLabelError There is a label that prohibits placing orders. Please contact your distributor for assistance. You cannot place the order because a tag indicates that order placement is prohibited. Contact your distributor.
403 OrderStatus.UnPaid The specified db instance has unpaid order. The instance has an unpaid order. Please pay first and try again.

For a list of error codes, visit the Service error codes.

Change history

Change time Summary of changes Operation
2023-07-25 The request parameters of the API has changed View Change Details
2022-06-23 API Description Update View Change Details