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Object Storage Service:A "The OSS Access Key Id you provided does not exist in our records" error is prompted when you use the STS temporary access credential to access OSS

Last Updated:Aug 15, 2022

Issue

A temporary access credential is issued to other users through the STS service. When you use the temporary access credential to access OSS resources within a specified period of time, a "The OSS Access Key Id you provided does not exist in our records" error is displayed.

Cause

The reasons for this error when using the STS temporary access credential to access OSS are as follows:

  • The error message returned because the AccessKeyID is disabled or does not exist.
  • Use the temporary AccessKey pair to apply for a new temporary access credential from the app server

Fixes

  1. Log on to Security Management in the Alibaba Cloud Management Console.
  2. Check whether the AccessKeyID used to access OSS exists and check its status.
    • If your AccessKey ID is disabled, enable it.
    • If you do not have an AccessKey ID, create an AccessKey ID and use it to access OSS.
  3. If your AccessKeyID is enabled, check the validity period of the temporary access credential set in the code. If it has expired, use the AccessKeyId and AccessKeySecret to apply for a new temporary access credential from the App server. For more information, see Use STS temporary access credential to access OSS in Step 5: Obtain temporary access credential.
    Description:
    • The minimum validity period of a temporary access credential is 900 seconds. The maximum validity period of a temporary access credential is the maximum session duration specified for the current role. For more information, see Set the maximum session time.
    • For more information about naming conventions for role session name roleSessionName, see AssumeRole.

References

Applicable scope

  • OSS