All Products
Search
Document Center

Lindorm:CreateLindormV2Instance

Last Updated:Sep 18, 2026

Creates a Lindorm V2 instance.

Operation description

At least one data engine must be selected when you create an instance. For more information about data engines and storage specifications, see How to select a data engine and How to select storage specifications.

Important If you do not specify data engine parameters when creating an instance, the API call fails.

Try it now

Try this API in OpenAPI Explorer, no manual signing needed. Successful calls auto-generate SDK code matching your parameters. Download it with built-in credential security for local usage.

Test

RAM authorization

The table below describes the authorization required to call this API. You can define it in a Resource Access Management (RAM) policy. The table's columns are detailed below:

  • Action: The actions can be used in the Action element of RAM permission policy statements to grant permissions to perform the operation.

  • API: The API that you can call to perform the action.

  • Access level: The predefined level of access granted for each API. Valid values: create, list, get, update, and delete.

  • Resource type: The type of the resource that supports authorization to perform the action. It indicates if the action supports resource-level permission. The specified resource must be compatible with the action. Otherwise, the policy will be ineffective.

    • For APIs with resource-level permissions, required resource types are marked with an asterisk (*). Specify the corresponding Alibaba Cloud Resource Name (ARN) in the Resource element of the policy.

    • For APIs without resource-level permissions, it is shown as All Resources. Use an asterisk (*) in the Resource element of the policy.

  • Condition key: The condition keys defined by the service. The key allows for granular control, applying to either actions alone or actions associated with specific resources. In addition to service-specific condition keys, Alibaba Cloud provides a set of common condition keys applicable across all RAM-supported services.

  • Dependent action: The dependent actions required to run the action. To complete the action, the RAM user or the RAM role must have the permissions to perform all dependent actions.

Action

Access level

Resource type

Condition key

Dependent action

lindorm:CreateLindormV2Instance

create

*All Resource

*

None None

Request parameters

Parameter

Type

Required

Description

Example

RegionId

string

Yes

The region ID of the instance. You can call DescribeRegions to query available regions. Use this parameter to specify the region in which to create the instance.

cn-shanghai

ZoneId

string

Yes

The zone ID of the instance.

cn-shanghai-f

InstanceAlias

string

No

The name of the instance.

lindorm-test

CloudStorageType

string

No

The storage type. This parameter is not required when you select Big Data or Local SSD.

  • PerformanceStorage: performance cloud storage.

  • StandardStorage: standard cloud storage.

Valid values:

  • StandardStorage :

    standard cloud storage.

  • CapacityStorage :

    storage-optimized cloud storage.

  • PerformanceStorage :

    performance cloud storage.

PerformanceStorage

PayType

string

Yes

The billing method of the instance. Valid values:

  • PREPAY: subscription.

  • POSTPAY: pay-as-you-go.

PREPAY

VPCId

string

Yes

The VPC ID of the instance.

vpc-wz9ydz3vg93s1ozsd****

VSwitchId

string

No

The vSwitch ID.

vsw-bp1e7clcw529l773d****

PricingCycle

string

No

The billing cycle of the instance. Valid values:

  • Month: billed on a monthly basis.

  • Year: billed on a yearly basis.

Note

This parameter is available and required only when PayType is set to PREPAY.

Valid values:

  • Month :

    month.

  • Year :

    year.

Month

Duration

integer

No

The subscription duration of the instance. Valid values:

  • If PricingCycle is set to Month, the valid values are 1 to 9.

  • If PricingCycle is set to Year, the valid values are 1 to 3.

Note

This parameter is available and required only when PayType is set to PREPAY.

1

CloudStorageSize

integer

Yes

The cloud storage size. Unit: GB.

320

ArchVersion

string

No

The deployment architecture. Valid values:

  • 1.0: single-zone.

  • 2.0: multi-zone Basic Edition.

  • 3.0: multi-zone High-availability Edition.

2.0

PrimaryZoneId

string

No

The zone ID of the primary zone for a multi-zone instance. This parameter is required if you want to create a multi-zone instance.

cn-shanghai-e

StandbyZoneId

string

No

The zone ID of the secondary zone for a multi-zone instance. This parameter is required if you want to create a multi-zone instance.

cn-shanghai-f

ArbiterZoneId

string

No

The zone ID of the arbiter zone for a multi-zone instance. This parameter is required if you want to create a multi-zone instance.

cn-shanghai-g

PrimaryVSwitchId

string

No

The vSwitch ID in the primary zone for a multi-zone instance. The vSwitch must be in the zone specified by PrimaryZoneId. This parameter is required if you want to create a multi-zone instance.

vsw-uf6fdqa7c0pipnqzq****

StandbyVSwitchId

string

No

The vSwitch ID in the secondary zone for a multi-zone instance. The vSwitch must be in the zone specified by StandbyZoneId. This parameter is required if you want to create a multi-zone instance.

vsw-2zec0kcn08cgdtr6****

ArbiterVSwitchId

string

No

The vSwitch ID in the arbiter zone for a multi-zone instance. The vSwitch must be in the zone specified by ArbiterZoneId. This parameter is required if you want to create a multi-zone instance.

vsw-uf6664pqjawb87k36****

ResourceGroupId

string

No

The resource group ID.

rg-aek2i6weeb4nfii

AutoRenewal

boolean

No

Specifies whether to enable auto-renewal for the instance. Valid values:

  • true: Auto-renewal is enabled.

  • false: Auto-renewal is disabled.

Default value: false.

Note

This parameter takes effect only when PayType is set to PREPAY (subscription).

false

AutoRenewDuration

string

No

The auto-renewal duration. Unit: months.

Valid values: 1 to 12.

Note

This parameter takes effect only when AutoRenewal is set to true.

1

ClusterPattern

string

No

The cluster type. Valid values:

  • basic: production

basic

ClusterMode

string

No

The instance mode. This parameter is optional.

  • BASIC: general-purpose mode

Valid values:

  • BASIC :

    general-purpose mode.

BASIC

EnableCapacityStorage

boolean

No

Specifies whether to enable storage-optimized cloud storage.

false

CapacityStorageSize

integer

No

The storage-optimized storage size. Unit: GB.

10000

EngineList

array<object>

Yes

The list of engine information.

array<object>

No

The list of engine information.

EngineType

string

Yes

The engine type. Valid values:

  • TABLE: LindormTable.

  • TSDB: LindormTSDB.

  • LSEARCH: search engine.

  • LTS: LTS engine.

  • LVECTOR: vector engine.

  • LCOLUMN: column store engine.

  • LAI: AI engine.

Valid values:

  • TABLE :

    LindormTable.

  • LSEARCH :

    search engine.

  • LMESSAGE :

    message engine.

  • LAI :

    AI engine.

  • LCOLUMN :

    column store engine.

  • LVECTOR :

    vector engine.

  • LTS :

    LTS engine.

  • TSDB :

    LindormTSDB.

  • LGRAPH :

    graph engine.

  • LSTREAM :

    stream engine.

TABLE

NodeGroupList

array<object>

No

The list of engine nodes.

object

No

The list of engine nodes.

NodeSpec

string

Yes

The node specifications.

If you select compute-optimized instance cloud storage or standard cloud storage, valid values for this parameter include:

  • lindorm.c.2xlarge: 8 cores, 16 GB memory.

  • lindorm.g.2xlarge: 8 cores, 32 GB memory.

  • lindorm.c.4xlarge: 16 cores, 32 GB memory.

  • lindorm.g.4xlarge: 16 cores, 64 GB memory.

  • lindorm.c.8xlarge: 32 cores, 64 GB memory.

  • lindorm.g.8xlarge: 32 cores, 128 GB memory.

  • lindorm.r.2xlarge: 8 cores, 64 GB memory.

  • lindorm.r.4xlarge: 16 cores, 128 GB memory.

  • lindorm.r.8xlarge: 32 cores, 256 GB memory.

If you select the local SSD type, valid values for this parameter include:

  • lindorm.i4.xlarge: 4 cores, 32 GB memory (I4).

  • lindorm.i4.2xlarge: 8 cores, 64 GB memory (I4).

  • lindorm.i4.4xlarge: 16 cores, 128 GB memory (I4).

  • lindorm.i4.8xlarge: 32 cores, 256 GB memory (I4).

  • lindorm.i3.xlarge: 4 cores, 32 GB memory (I3).

  • lindorm.i3.2xlarge: 8 cores, 64 GB memory (I3).

  • lindorm.i3.4xlarge: 16 cores, 128 GB memory (I3).

  • lindorm.i3.8xlarge: 32 cores, 256 GB memory (I3).

  • lindorm.i2.xlarge: 4 cores, 32 GB memory (I2).

  • lindorm.i2.2xlarge: 8 cores, 64 GB memory (I2).

  • lindorm.i2.4xlarge: 16 cores, 128 GB memory (I2).

  • lindorm.i2.8xlarge: 32 cores, 256 GB memory (I2).

If you select the big data type, valid values for this parameter include:

  • lindorm.sd3c.3xlarge: 14 cores, 56 GB memory (D3C PRO).

  • lindorm.sd3c.7xlarge: 28 cores, 112 GB memory (D3C PRO).

  • lindorm.sd3c.14xlarge: 56 cores, 224 GB memory (D3C PRO).

  • lindorm.d2c.6xlarge: 24 cores, 88 GB memory (D2C).

  • lindorm.d2c.12xlarge: 48 cores, 176 GB memory (D2C).

  • lindorm.d2c.24xlarge: 96 cores, 352 GB memory (D2C).

  • lindorm.d2s.5xlarge: 20 cores, 88 GB memory (D2S).

  • lindorm.d2s.10xlarge: 40 cores, 176 GB memory (D2S).

  • lindorm.d1.2xlarge: 8 cores, 32 GB memory (D1NE).

  • lindorm.d1.4xlarge: 16 cores, 64 GB memory (D1NE).

  • lindorm.d1.6xlarge: 24 cores, 96 GB memory (D1NE).

lindorm.g.2xlarge

NodeCount

integer

Yes

The number of nodes in the cluster.

7

NodeDiskType

string

No

The cloud disk type of the node. This parameter is optional. This parameter is used in special scenarios and requires whitelist activation.

Valid values:

  • cloud_efficiency :

    standard cloud disk.

  • cloud_essd :

    ESSD cloud disk.

cloud_essd

NodeDiskSize

integer

No

The disk size per node. Default unit: GB.

100

ResourceGroupName

string

No

The name of the node group. This parameter is optional.

group_name_01

Response elements

Element

Type

Description

Example

object

RequestId

string

The request ID.

1556DCB0-043A-4444-8BD9-CF4A68E7EE64

InstanceId

string

The instance ID.

ld-bp1mq0tdzbx1m****

OrderId

integer

The order ID.

211110656240000

AccessDeniedDetail

string

The details of the access denial.

{"AuthAction":"xxx","AuthPrincipalDisplayName":"222","AuthPrincipalOwnerId":"111","AuthPrincipalType":"SubUser",,"NoPermissionType":"ImplicitDeny","PolicyType":"AccountLevelIdentityBasedPolicy","EncodedDiagnosticMessage":"xxxxxx"}

Examples

Success response

JSON format

{
  "RequestId": "1556DCB0-043A-4444-8BD9-CF4A68E7EE64",
  "InstanceId": "ld-bp1mq0tdzbx1m****",
  "OrderId": 211110656240000,
  "AccessDeniedDetail": "{\"AuthAction\":\"xxx\",\"AuthPrincipalDisplayName\":\"222\",\"AuthPrincipalOwnerId\":\"111\",\"AuthPrincipalType\":\"SubUser\",,\"NoPermissionType\":\"ImplicitDeny\",\"PolicyType\":\"AccountLevelIdentityBasedPolicy\",\"EncodedDiagnosticMessage\":\"xxxxxx\"}"
}

Error codes

HTTP status code

Error code

Error message

Description

400 Lindorm.Errorcode.ParameterInvaild The parameter is invalid.
400 LindormErrorCode.%s %s. %s.
403 Lindorm.Errorcode.OperationDenied You are not authorized to operate on the specified resource.
403 API.Forbidden The API operation is forbidden in this environment. This operation is not supported in the current environment.
403 Lindorm.Errorcode.ServiceLinkedRoleNoPermission No permission to create service linked role. You are not authorized to create the service-linked role.

See Error Codes for a complete list.

Release notes

See Release Notes for a complete list.