This topic describes the possible reasons why NS setup cannot be converted to CNAME and provides solutions.
Issue
The website was added to ESA using NS setup, and the Convert option is unavailable.

Cause
The service location for your website is either Global or the Chinese Mainland, and the Proxy Status of the DNS record is DNS Only.
Solutions
Use one of the following three methods to delete records or modify parameters, and then convert DNS setup from NS to CNAME.
Procedure
Method 1: Delete records
After you delete the records with Proxy Status set to DNS Only, convert DNS setup from NS to CNAME. To facilitate addition of records to the new DNS provider, you can back up the records with Proxy Status set to DNS Only before you delete them.
In the ESA console, choose Websites and click the website name you want to manage.
In the left-side navigation pane, choose .
Optional. Find and back up the record with Proxy Status set to DNS Only.
Find the record with Proxy Status set to DNS Only and click Delete in the Actions column.

Method 2: Modify proxy status
Modify the proxy status of the records to support conversion.
In the ESA console, choose Websites and click the website name you want to manage.
In the left-side navigation pane, choose .
Select the record with Proxy Status set to DNS Only, and click Edit in the Actions column.

Enable Proxy Status and click Next.
Select your business type and click OK.

Method 3: Modify the location
After setting the website's location to Global (Excluding the Chinese Mainland), you can convert DNS setup. Once you have converted the setup to CNAME, you can also set the location to Global or Chinese Mainland.
In the ESA console, choose Websites and click the website name you want to manage.
In the Basic Information area, click Change on the right of Location.

In the pop-up dialog box, select Global (Excluding the Chinese Mainland), and then click Change.