Symptoms
After an ARMS agent is installed, no monitoring data is displayed in the ARMS console.
Causes
This problem may occur because the application does not have continuous external access
requests, the region of the application is different from that of the ARMS agent,
or the permissions on the ARMS agent installation directory are invalid.
Solutions
- If the log file of the ARMS agent contains "send agent metrics. no metrics.", verify
whether the development framework is supported by the ARMS agent and whether your
application has continuous external access requests, including HTTP requests, HSF
requests, and Dubbo requests. For more information about third-party components and
frameworks supported by the ARMS agent, see Java components and frameworks supported by ARMS.
- Check whether the selected time range to query is correct. Select the last 15 minutes
as the query time range and check whether monitoring data is displayed.
- If you start the ARMS agent by running the
-jar
command, check the configuration of the command line and make sure that the -javaagent parameter is before -jar
.java -javaagent:/{user.workspace}/ArmsAgent/arms-bootstrap-1.7.0-SNAPSHOT.jar -Darms.licenseKey=xxx -Darms.appName=xxx -jar demoApp.jar
- If the log in ArmsAgent/log/ contains the LicenseKey is invalid. error, check whether the region of your application is the same as that of the ARMS
agent.
- If the log subdirectory does not exist in the ArmsAgent directory after your application
is started, this is because arms-bootstrap-1.7.0-SNAPSHOT.jar failed to be loaded.
Check whether the permissions on the ARMS agent installation directory are valid.
- If the following error is reported when your application is started, check whether
the arms-bootstrap-1.7.0-SNAPSHOT.jar package and the permissions are correct.
- If no monitoring data is displayed, pack the log file of the ARMS agent for Java applications
in the ArmsAgent/log directory, and contact customer services of ARMS at DingTalk
service account
arms160804
for assistance.
- Check the JDK version.
If the JDK version is 1.8.0_25 or 1.8.0_31, you may fail to install the agent. We
recommend that you upgrade the JDK or contact customer services of ARMS at DingTalk
service account arms160804
.