Problem Description
Login to the Webmail of the Alibaba Mail and prompt that The current mailbox domain name is configured with CNAME resolution that conflicts with MX resolution, which may cause some emails to be unable to be received. Please contact the administrator in time to check and modify as required (the prompt will disappear automatically within 1~2 hours after the resolution takes effect).
Cause
1. CNAME records are added to other services, such as ECS and CDN.
2. A conflict with the MX resolution may occur, resulting in the failure to receive the email.
Solutions
Do not use both CNAME resolution and MX resolution with the host as @.
Select one of the three solutions:
1. At present, only the localDNS cache can be resolved to CNAME, resulting in MX not being found. Please observe whether there is any leakage.
2. Use another domain name or subdomain to purchase an email service.
3. Removed the CNAME resolution from the domain name resolution. You may use www to replace @ or use the A record to access ECS, CDN and other products.
Before you perform this operation, please evaluate whether to use the CNAME record to avoid business impacts after it is removed.