Description
Failed to send emails through the Webmail and the system prompts the following error:
The specific sender address is invalid
Cause
If the DNS resolution of the mailbox domain name is abnormal, the Alibaba Mail cannot be used normally, and the above error may occur when sending letters. The DNS resolution of an email domain name may be abnormal, as follows:
MX resolution setting error, not correctly pointing to Alibaba Mail server.
The domain name expires.
If you change the DNS service provider of a domain name, it may take a while for the resolution to take effect after the change, or you have not set the correct MX parsing records at the new DNS service provider.
Solution
Because this issue is related to the DNS resolution status of the mailbox domain name, please refer to the following steps to check:
1. Log on to the Alimail Console.
2. Find your email service under the list and click Manage.
3. Check the Resolution Status and perform the corresponding operations.
a. If the resolution status is Resolved, please log on to Webmail again to test the email sending function and make sure that the problem is fixed.

b. If the resolution status is Resolution Invalid, please perform the following steps to check the resolution status of your domain name.

c. Check the expiration time of your domain name to ensure that it has not expired. If the domain name expires, please renew it at the domain name service provider in a timely manner. Try again after the domain name resolution recovers. If the domain name has not expired, proceed to the next step.
After the domain name is successfully renewed, the resolution usually returns to normal within about 24 hours.
d. Confirm that if you have changed the DNS service provider for your domain name. If the email address is changed, make sure that you have set the correct resolution records at the new DNS service provider. After confirming that the resolution takes effect, click Resolution Result or Refresh on the console. If you have not changed your DNS service provider, please proceed to the next step.

e. Check the DNS records of the domain name and confirm that the records in the following table exist and the records values are exactly the same. If there are inconsistencies, please refer to the following table to modify. After confirming that the resolution takes effect, click Resolution Result or Refresh on the console.
Hostname | Record Type | Priority | Record Value |
@ | MX | 5 | mx1.sg.aliyun.com |
@ | MX | 10 | mx2.sg.aliyun.com |
imap | CNAME | imap.sg.aliyun.com | |
pop3 | CNAME | pop.sg.aliyun.com | |
smtp | CNAME | smtp.sg.aliyun.com | |
CNAME | mail.sg.aliyun.com | ||
@ | TXT | v=spf1 include:spf.sg.aliyun.com -all |
Some service providers will add a "." decimal point symbol at the end of the records value, please do not remove it.