防勒索服務備份大量資料時需要消耗伺服器記憶體和磁碟空間進行緩衝,當備份檔案過多、過大或程式異常時,可能導致資源佔用過高引發備份失敗。本文提供磁碟空間不足和記憶體佔用過高兩種情境的排查方法,並介紹通過修改備份緩衝配置來最佳化資源使用的解決方案。
防勒索功能和雲備份產品共用同一用戶端,因此對防勒索用戶端的配置修改,將同樣作用於雲備份,請在調整前充分評估對雲備份服務的影響。
磁碟空間不足
問題現象
防勒索備份任務佔用伺服器的磁碟空間過大,備份緩衝目錄佔用大量磁碟空間,導致伺服器磁碟警示或備份失敗。
問題原因
正常情況下,防勒索備份佔用伺服器的磁碟空間為臨時佔用,待備份資料上傳到雲端後,伺服器上的備份資料會自動刪除。在備份檔案過多、過大或程式運行異常時,會出現備份佔用伺服器的磁碟空間過大的情況。
解決方案:修改備份緩衝配置
您可以參考以下步驟修改備份緩衝的位置、狀態及佔用系統記憶體空間的上限。
如果伺服器已開啟用戶端自保護,需先關閉該功能。
在左側導覽列,選擇。在控制台左上方,選擇需防護資產所在的地區:中國內地或非中國內地。
在主機資產頁面,單擊目標伺服器操作列的查看。
在防禦狀態地區,關閉用戶端自保護防護開關。

使用具有管理員權限的使用者登入需要操作的伺服器。
找到並進入防勒索用戶端的安裝路徑。各版本預設安裝目錄請參見本文附錄:查看用戶端版本和安裝目錄。
進入防勒索用戶端的安裝目錄(預設為
../client目錄),建立hbr.config檔案。在
hbr.config檔案中按照以下參數添加資料ID及中繼資料快取資訊,並儲存該檔案。重要無需重啟,配置參數即可生效。
修改後的配置參數,只對後續建立的備份任務有效,對已經建立的備份任務無法進行緩衝加速備份。
通過配置
hbr.config檔案中的參數,可以設定快取資料存放的位置、快取資料佔用系統記憶體空間的上限等緩衝配置。hbr.config檔案的配置樣本如下:
disable_blob_cache = false max_blob_cache_weight = 0.15 cache_prefix = D:\CacheFolder max_retain_count = 16 disable_file_cache = false file_cache_max_size_hint = 32GB file_cache_disk_free_space_hint = 1GB file_cache_max_retain_count = 2參數
說明
disable_blob_cache
是否啟用資料ID緩衝。啟用資料ID緩衝可以添加備份原始伺服器的資料ID及中繼資料快取來減少備份過程中的網路請求,從而利用資料緩衝加速備份。取值:
true:不啟用資料ID緩衝。
false:啟用資料ID緩衝。
max_blob_cache_weight
控制資料ID緩衝最多使用系統記憶體的百分比。預設值0.15,即15%的系統總記憶體。取值範圍為(0,1)。
cache_prefix
控制緩衝存放位置的路徑字串,取值為絕對路徑。
max_retain_count
控制最大保留資料ID緩衝個數。
disable_file_cache
是否啟用中繼資料快取。取值包括:
true:不啟用中繼資料快取。
false:啟用中繼資料快取。
file_cache_max_size_hint
表示檔案cache最多佔用的空間。預設值32GB。如果檔案cache佔用的磁碟空間超過該值,檔案備份失敗並提示檔案cache空間不足,請根據實際情況調高file_cache_max_size_hint。比如1000萬檔案每次的備份緩衝大概佔用1.5GB磁碟空間,具體磁碟佔用空間與備份源的檔案個數、檔案總資料量、檔案全路徑長度有關。在備份期間新產生1份緩衝空間,那麼預估需要為磁碟預留的空間是:1.5GB *(file_cache_max_retain_count + 1)+ file_cache_disk_free_space_hint
說明僅對防勒索用戶端V2.13.1版本及以上生效。
file_cache_disk_free_space_hint
表示檔案cache所在磁碟的剩餘空間,預設值為1GB。如果磁碟剩餘空間小於該值,檔案備份失敗並提示檔案cache空間不足,請根據實際情況調整緩衝空間。
說明僅對防勒索用戶端V2.13.1版本及以上生效。
file_cache_max_retain_count
表示為每個備份路徑保留的檔案cache個數,預設值為2。例如,當設定為2時本地將保留最近兩次備份的緩衝,如果刪除最新的備份之後,仍然可以找到最新的上次備份。
說明僅對防勒索用戶端V2.13.1版本及以上生效。
記憶體佔用過高(OOM)
問題現象
備份任務狀態為備份失敗,且錯誤提示資訊為OOM(Out of Memory)。備份任務執行期間,hbrclient進程持續存在並佔用大量記憶體,備份任務結束後hbrclient進程通常會被終止。
問題原因
在備份檔案過多、過大或程式運行異常時,可能會導致備份任務佔用伺服器的記憶體資源過高。常見原因包括:
防護目錄包含網路掛載路徑(如OSS、NAS),導致頻繁資料訪問。
備份網路頻寬未限制,備份輸送量過大。
伺服器記憶體配置偏低,無法滿足備份需求。
解決方案
可以根據具體業務需求選取以下一種或多種方案。
排除網路掛載路徑
請勿在防勒索的防護目錄中直接添加網路掛載路徑(如掛載到ECS伺服器上的OSS、NAS地址),此操作可能因頻繁的資料訪問而導致記憶體佔用過高,併產生額外的API調用費用。您可以通過以下方式處理:
使用雲備份服務:對於OSS和NAS資料,建議使用專用的雲備份服務。具體操作,請參見快速入門-OSS備份、快速入門-本地NAS備份。
升級用戶端:升級至最新版防勒索用戶端,系統將自動把掛載目錄納入排除清單。
拆分防護目錄
將防護策略中的防護目錄位址拆分為多個子目錄。在同一個防護策略中,多個防護目錄會串列執行備份。由於每個拆分目錄的資料量有所減少,單個備份任務消耗的資源也會降低。
例如,將防護目錄/user/bin拆分為多個子目錄。具體操作,請參見管理防護策略。。

拆分防護目錄位址後,Security Center會按照拆分後的目錄執行備份計劃,不會影響已備份的資料恢複。
限制備份網路頻寬
適當限制備份的輸送量,可以降低備份對磁碟、記憶體和CPU的使用。在编辑防护策略面板,修改备份网络带宽限制。具體操作,請參見管理防護策略。

備份網路頻寬節流設定設定為0時,表示不限制頻寬。
調整CPU佔用限制
如果伺服器資源配置與備份資料量相匹配,可以嘗試調高備份的CPU使用佔比。調高CPU佔用後可以提高備份的並發處理能力,縮短備份時間,減少記憶體的累計佔用。
調整CPU佔用限制前,請您務必全面評估系統效能及當前負載狀況,確保系統具備承受增加負荷的能力。
例如,伺服器共有8個核,可將預設佔用的1核修改為2核。進入防勒索用戶端的安裝目錄(預設為../client目錄),在hbr.config設定檔中添加配置cpu_max_procs = 2。
若hbr.config設定檔不存在,可以建立一個hbr.config檔案,只需添加上述的cpu_max_procs = 2配置即可,下次備份任務啟動時生效。各版本用戶端的預設安裝目錄,請參見附錄:查看用戶端版本和安裝目錄。
升級資源配置
備份資料量較大時,需要使用的記憶體資源較多。如果伺服器的記憶體較小無法滿足備份需求,您需要升級伺服器的記憶體配置。具體資源對照,請參見備份所需要的資源說明。
如果您使用的是Elastic Compute Service,升級配置步驟,請參見修改執行個體規格。
附錄:查看用戶端版本和安裝目錄
查看用戶端版本
可以在頁面,查看防勒索用戶端的版本。
查看用戶端安裝目錄
不同版本的防勒索用戶端的預設安裝目錄如下:
用戶端版本 | 伺服器的作業系統 | 防勒索用戶端的安裝目錄 |
1.X.X | Windows | C:\Program Files (x86)\Alibaba\Aegis\hbr\client |
Linux | /usr/local/aegis/hbr/client | |
2.X.X | Windows | C:\Program Files (x86)\Alibaba\Aegis\hbrclient\client |
Linux | /usr/local/aegis/hbrclient/client |
其他常見問題
防勒索備份快取資料佔用了伺服器過多的C盤空間,能修改快取資料的位置嗎?
可以。您可以通過修改防勒索備份用戶端的設定檔修改防勒索備份快取資料的位置。具體操作,請參見防勒索備份佔用過多磁碟空間解決方案。
已購買的防勒索資料保護容量不夠用怎麼辦?
當已購買的防勒索資料保護容量不足時,可能導致伺服器資料備份失敗。可通過擴容或釋放防勒索容量空間來解決此問題。
擴容防勒索容量空間
防勒索容量不足會導致伺服器資料備份失敗,無法恢複伺服器資料。建議及時升級防勒索容量以避免此類風險。
操作步驟:
在左側導覽列,選擇。在控制台左上方,選擇需防護資產所在的地區:中國內地或非中國內地。
在防勒索頁面,單擊已使用容量/总容量下的升級,完成容量擴容。
建議配置: 每台伺服器配置50 GB的資料防護容量。
釋放防勒索容量空間
減少伺服器數量
通過刪除防護策略下的非生產狀態伺服器(測試伺服器、閑置伺服器等)來節約防勒索容量空間。具體操作,請參見管理防護策略中的伺服器。
減少防護目錄
可以在建立防護策略時,選擇自訂策略,通過備份指定目錄,節約防勒索容量空間。具體操作,請參見建立防護策略及用戶端。
刪除歷史備份資料
確認某伺服器的歷史備份資料無需保留後,可刪除該伺服器已備份的歷史資料來釋放防勒索容量空間。具體操作,請參見刪除已備份資料。
聯絡我們
如果以上方法都無法解決,可擷取線上人工協助,並提供以下資訊:
裝置總記憶體和可用記憶體;
備份期間備份進程佔用的記憶體;
備份檔案總數和備份資料量;
備份用戶端的版本;
磁碟IO和網路輸送量;
CloudMonitor資料:備份前和備份期間的CPU和記憶體資訊截圖。具體查看步驟,請參見請參見雲產品監控。