Restaura dados históricos para uma nova instância clonada.
Descrição da operação
Mecanismos aplicáveis
-
RDS MySQL
-
RDS PostgreSQL
-
RDS SQL Server
-
RDS MariaDB
Documentos de recursos relacionados
Antes de usar esta API, leia os documentos de recursos relacionados para entender seus pré-requisitos e impactos.
Experimente agora
Testar
Autorização RAM
|
Ação |
Nível de acesso |
Tipo de recurso |
Chave de condição |
Ação dependente |
|
rds:CloneDBInstance |
create |
DBInstance
|
|
Nenhuma |
Parâmetros da solicitação
|
Parâmetro |
Tipo |
Obrigatório |
Descrição |
Exemplo |
| ClientToken |
string |
Não |
O token de cliente que garante a idempotência da solicitação. Você deve gerar um token exclusivo para cada solicitação. O token pode conter apenas caracteres ASCII e não deve exceder 64 caracteres de comprimento. |
0c593ea1-3bea-11e9-b96b-88********** |
| RegionId |
string |
Não |
O ID da região. Você pode chamar a operação DescribeRegions para consultar os IDs das regiões. |
cn-hangzhou |
| ZoneId |
string |
Não |
O ID da zona de disponibilidade primária. Você pode chamar a operação DescribeRegions para consultar os IDs das zonas de disponibilidade. Nota
Por padrão, a zona de disponibilidade da instância de origem é usada. |
cn-hangzhou-b |
| DBInstanceClass |
string |
Não |
O tipo de instância. Para mais informações, consulte Tipos de instância. Nota
Por padrão, a nova instância usa o mesmo tipo de instância da instância de origem. |
mysql.n1.micro.1 |
| DBInstanceStorage |
integer |
Não |
A capacidade de armazenamento da instância em GB. O valor deve ser um múltiplo de 5. Para mais informações, consulte Tipos de instância. Nota
Por padrão, a nova instância usa a mesma capacidade de armazenamento da instância de origem. |
1000 |
| DBInstanceDescription |
string |
Não |
O nome da instância. O nome deve ter de 2 a 255 caracteres. Deve começar com uma letra ou um caractere chinês e pode conter letras, dígitos, caracteres chineses, sublinhados (_) e hifens (-). Nota
O nome não pode começar com http:// ou https://. |
testInstance |
| DbNames |
string |
Não |
Os nomes dos bancos de dados a serem clonados. Separe vários nomes de bancos de dados com vírgulas. Formato: |
test1,test2 |
| PayType |
string |
Sim |
O método de cobrança. Valores válidos:
|
Postpaid |
| InstanceNetworkType |
string |
Não |
O tipo de rede da instância. Valores válidos:
Nota
Por padrão, a nova instância usa o mesmo tipo de rede da instância de origem. |
VPC |
| DBInstanceId |
string |
Sim |
O ID da instância de origem. |
rm-uf6wjk5**** |
| BackupId |
string |
Não |
O ID do conjunto de backups. Você pode chamar a operação DescribeBackups para consultar os IDs dos conjuntos de backups. Nota
Você deve especificar BackupId ou RestoreTime. |
902**** |
| RestoreTime |
string |
Não |
O ponto no tempo para o qual você deseja restaurar os dados, que deve estar dentro do período de retenção de backup. Especifique a hora em UTC, usando o formato aaaa-MM-ddTHH:mm:ssZ. Nota
Você deve especificar BackupId ou RestoreTime. |
2011-06-11T16:00:00Z |
| VPCId |
string |
Não |
O ID da VPC. Nota
A VPC deve estar na região especificada. |
vpc-uf6f7l4fg90**** |
| VSwitchId |
string |
Não |
O ID do vSwitch. O vSwitch deve estar na zona de disponibilidade especificada pelo parâmetro ZoneId.
|
vsw-uf6adz52c2p**** |
| PrivateIpAddress |
string |
Não |
O endereço IP privado da nova instância. O endereço IP deve estar dentro do bloco CIDR do vSwitch especificado. Se este parâmetro não for especificado, o sistema atribuirá automaticamente um endereço IP com base nos parâmetros VPCId e VSwitchId. |
172.XX.XX.69 |
| UsedTime |
integer |
Não |
A duração da assinatura. Valores válidos:
Nota
Este parâmetro é obrigatório quando PayType está definido como Prepaid. |
1 |
| Period |
string |
Não |
A unidade para a duração da assinatura especificada pelo parâmetro UsedTime. Valores válidos:
Nota
Este parâmetro é obrigatório quando PayType está definido como Prepaid. |
Year |
| Category |
string |
Não |
A edição da instância. Valores válidos:
Instâncias Serverless
Nota
Se você não especificar este parâmetro, a nova instância usará a mesma edição da instância de origem. |
HighAvailability |
| ZoneIdSlave1 |
string |
Não |
O ID da zona de disponibilidade secundária. Uma implantação multi-AZ é usada se este valor for diferente do valor de ZoneId. Caso contrário, uma implantação de zona única é usada. |
cn-hangzhou-c |
| ZoneIdSlave2 |
string |
Não |
O ID da zona de disponibilidade do nó logger. Uma implantação multi-AZ é usada se este valor for diferente do valor de ZoneId. Caso contrário, uma implantação de zona única é usada. |
cn-hangzhou-d |
| DBInstanceStorageType |
string |
Não |
O tipo de armazenamento da instância. Valores válidos:
Nota
As instâncias Serverless suportam apenas discos em nuvem ESSD PL1 e ESSDs de uso geral. |
general_essd |
| RestoreTable |
string |
Não |
Defina como 1 para clonar apenas bancos de dados ou tabelas específicas. Você também deve especificar o parâmetro TableMeta. |
1 |
| TableMeta |
string |
Não |
Os bancos de dados e tabelas a serem clonados. Este parâmetro é obrigatório se RestoreTable estiver definido como 1. Formato:
|
[{"type":"db","name":"testdb1","newname":"testdb1_new","tables":[{"type":"table","name":"testdb1table1","newname":"testdb1table1_new"}]}] |
| DedicatedHostGroupId |
string |
Não |
O ID do grupo de hosts dedicados. |
dhg-7a9**** |
| BackupType |
string |
Não |
O tipo de backup. Valores válidos:
|
FullBackup |
| DeletionProtection |
boolean |
Não |
Especifica se a proteção contra exclusão deve ser ativada. Valores válidos:
|
true |
| IoAccelerationEnabled |
string |
Não |
Este parâmetro é uma opção Serverless que se aplica apenas quando você clona dados para uma instância Serverless. Nota
Este parâmetro é suportado apenas no site da China. |
0 |
| BurstingEnabled |
boolean |
Não |
Este parâmetro foi descontinuado e não precisa ser configurado. |
false |
| AutoPay |
boolean |
Não |
Especifica se o pagamento automático para a assinatura deve ser ativado. Este parâmetro é válido apenas quando PayType está definido como Prepaid. Valores válidos:
Nota
Para mais informações sobre o BPE, consulte Buffer Pool Extension (BPE). |
true |
| CustomExtraInfo |
string |
Não |
Informações estendidas sobre a instância, no formato JSON. Nota
|
Elementos de resposta
|
Elemento |
Tipo |
Descrição |
Exemplo |
|
object |
O corpo da resposta. |
||
| DBInstanceId |
string |
O ID da nova instância. |
rm-uf6wjk5**** |
| OrderId |
string |
O ID do pedido. |
100789370**** |
| RequestId |
string |
O ID da solicitação. |
1E43AAE0-BEE8-43DA-860D-EAF2**** |
Exemplos
Resposta de sucesso
JSON formato
{
"DBInstanceId": "rm-uf6wjk5****",
"OrderId": "100789370****",
"RequestId": "1E43AAE0-BEE8-43DA-860D-EAF2****"
}
Códigos de erro
|
Código de status HTTP |
Código de erro |
Mensagem de erro |
Descrição |
|---|---|---|---|
| 400 | InvalidAvZone.Format | Specified AvZone is not valid. | A operação falhou. A zona está incorreta. Verifique e tente novamente. |
| 400 | InvalidAvZone.NotSupport | Specified availableArea multiZone does not support in RDS. | A multiZone availableArea especificada não é suportada no ApsaraDB RDS. |
| 400 | CannotDecreaseEssdPerfLevel | cannot decrease cloud essd performance level. | O tamanho de armazenamento do ESSD em nuvem é inválido. |
| 400 | InvalidIPAddress.Conflict | IP address conflict. | O endereço IP entra em conflito com um endereço IP existente. |
| 400 | CDDC.AvailableHostsNotEnoughInZone | Not enough available hosts are in the target zone. | A zona de destino não possui recursos de host suficientes. Crie um host na zona. |
| 400 | InvalidInstanceLevel.DiskType | Specified instance level not support request disk type | O tipo de instância atual não oferece suporte ao tipo de armazenamento especificado. |
| 400 | InvalidRecoveryDbInstance.StorageType | The disk local_ssd can not clone to cloud disk type | Um disco local não pode ser clonado para um disco em nuvem. |
| 400 | InvalidRecoveryDbInstance.StorageSize | The disk space of the new instance cannot be less than that of the current instance | A operação falhou. O espaço em disco da nova instância não pode ser menor que o da instância atual. |
| 400 | InvalidDBInstanceClass.Offline | The specified instance type is no longer provided. Please specify another instance type. | O tipo de instância selecionado foi descontinuado. Selecione um tipo de instância diferente. |
| 400 | InvalidTunnelId | Specified conn tunnel is not valid. | O túnel de conexão especificado é inválido. |
| 400 | ZoneId.NotMatchWithCategory | The number of available zones does not match the database engine or instance edition. Please reset it. | O número de zonas não corresponde ao tipo de banco de dados ou à edição da instância. Reconfigure as definições. |
| 400 | UnsupportExtendDisk.NotSupport | Specified DB instance is unsupport extend disk. | A instância especificada não oferece suporte à expansão de disco em nuvem. |
| 400 | Order.ComboInstanceNotAllowOperate | A package instance is not allowed to operate independently. | Operações individuais não são permitidas para instâncias de pacote. |
| 400 | Price.PricingPlanResultNotFound | Pricing plan price result not found. | O resultado do preço do plano de preços não foi encontrado. |
| 400 | Order.NoRealNameAuthentication | You have not passed the real-name authentication and do not meet the purchase conditions. Please log in to the user center for real-name authentication. | Você não concluiu a verificação de nome real e não está elegível para fazer uma compra. Faça login em Despesas e Custos para concluir a verificação de nome real. |
| 400 | InsufficientAvailableQuota | Your account quota limit is less than 0, please recharge before trying to purchase. | O crédito disponível da sua conta é menor que 0. Recarregue sua conta antes de tentar fazer uma compra. |
| 400 | CommodityServiceCalling.Exception | Failed to call commodity service. | A chamada para o serviço de commodity retornou uma falha. |
| 400 | RegionDissolvedEOM | Dear customer, Alibaba Cloud plans to optimize and adjust the current region. Cloud services in this region will cease operations. You are currently unable to operate new purchase orders. Thank you for your understanding and support. | O Alibaba Cloud planeja otimizar e ajustar a região atual. Os serviços em nuvem nesta região serão descontinuados. Para garantir a continuidade dos seus negócios e uma migração de dados tranquila, você não pode fazer novos pedidos de compra no momento. Agradecemos sua compreensão e apoio. |
| 400 | Commodity.InvalidComponent | The module you purchased is not legal, please buy it again. | O módulo adquirido é inválido. Adquira um módulo válido. |
| 400 | RegionEndTimeDissolvedAustralia | Cloud services in the Australia (Sydney) region will be discontinued. Set the validity date to September 30, 2024 or earlier than September 30, 2024. | A região foi desativada. |
| 400 | Price.CommoditySys | Commodity system call exception. | Ocorreu uma exceção ao chamar o sistema de commodities. |
| 400 | Pay.InsufficientBalance | Insufficient available balance. | |
| 400 | Order.PeriodInvalid | There is a problem with the period you selected, please choose again. | O período de assinatura selecionado é inválido. Selecione um período de assinatura válido. |
| 400 | pay.noCreditCard | Account not bound to credit card. | A conta não está associada a um cartão de crédito. |
| 400 | Order.InstHasUnpaidOrder | There is an unpaid order for the service you have purchased. Please pay or void it before placing the order. | Existe um pedido não pago para o serviço selecionado. Pague ou cancele o pedido antes de fazer um novo. |
| 400 | noAvailablePaymentMethod | No payment method is specified for your account. We recommend that you add a payment method. | Nenhum método de pagamento está especificado para a conta. Adicione um método de pagamento. |
| 400 | BasicInfoUncompleted | Your information is incomplete. Complete your information before the operation. | Suas informações básicas estão incompletas. Complete suas informações básicas antes de realizar esta operação. |
| 400 | Risk.RiskControlRejection | Your account is abnormal, please contact customer service for details. | Ocorreu uma exceção com a sua conta. Entre em contato com o atendimento ao cliente para obter detalhes. |
| 400 | Api.NotSupport | Specified api is not supported. | A operação de API atual não é suportada. |
| 400 | ContainForbiddenLabelError | There is a label that prohibits placing orders. Please contact your distributor for assistance. | Existe uma tag de bloqueio de pedido. Entre em contato com seu distribuidor para obter assistência. |
| 400 | InvalidDBInstanceId.NotFound | The DBInstanceId provided does not exist in records. | O DBInstanceId especificado não existe. |
| 400 | InvalidParam | Sepcified wal level Parameter is invalid. There are still logical slots in instance, so it can not be set as replica. | O parâmetro de entrada é inválido. |
| 400 | KmsApiError | User secret key invalid. | A chave do usuário é inválida. |
| 400 | System.SaleValidateFailed | Sales expression validation system error. | |
| 400 | Abs.InvalidAccount.NotFound | account is not found. | Sua conta da Alibaba Cloud não existe ou sua AccessKey expirou. |
| 400 | SqlExecuteFailedOrTimeout | sql command execution failed or timed out:%s. | A execução do comando SQL falhou ou expirou. |
| 400 | ColdData.EngineVersionNotSupport | The current instance engine version not support coldDataEnabled. | A versão atual do mecanismo DPI da instância não suporta o arquivamento de dados frios. |
| 400 | ColdData.MinorVersionNotSupport | The current instance minor version not support coldDataEnabled. | A versão atual do kernel não suporta o arquivamento de dados frios. |
| 400 | IncorrectTargetClasscode | The current instance type does not support this operation. | O tipo de instância atual não oferece suporte a esta operação. |
| 400 | InvalidConnectionString.Duplicate | Specified connection string already exists in the RDS. | O nome do endereço de conexão está duplicado. Reconfigure a string de conexão. |
| 400 | RequiredParam.NotFound | Required input param is not found. | Parâmetros obrigatórios estão ausentes. |
| 400 | Parameters.Invalid | Parameter error, please check the parameters. | O parâmetro está incorreto. Verifique o parâmetro. |
| 400 | BackupPolicyNotSupport | Cold Data won't open with CrossBackup or Flash Backup, please check Backup Policy. | O arquivamento de dados frios não oferece suporte a backup entre regiões ou backup de snapshot de alta frequência. Verifique a política de backup. |
| 400 | InvalideStatus.Format | The instance status does not support this operation. | O status da instância não suporta esta operação. |
| 400 | InvalidReleasedKeepPolicy.Format | Specified Released Keep Policy is not valid. | A política de retenção de dados de backup arquivados após a liberação da instância é inválida. |
| 400 | InvalidDBInstanceEngineType.Format | the DB instance engine type does not support this operation. | O tipo de mecanismo de banco de dados da instância não oferece suporte a esta operação. |
| 400 | Pay.NoCreditCard | No credit cards. | |
| 400 | VpcNetworkTypeNotSupport | The vpc network type instance does not support this operation. | Esta operação não é suportada para instâncias do tipo de rede VPC. |
| 400 | MirrorInsExists | Specified DB instance mirror ins already existed. | A imagem da instância de banco de dados atual já existe. |
| 400 | UnsupportedClassCode | The specified DB instance class stops selling. | O tipo de instância não está mais disponível para compra. |
| 400 | InvalidBackupSet | The specified database does not exist in the backup set. | O banco de dados especificado não existe no conjunto de backup. |
| 400 | OrdTCommodityQueryError | Failed to query for product. | Falha ao consultar o produto. |
| 400 | ProductInstanceReleased | The instance has been released. Please check before placing the order. | A instância foi liberada. Verifique a instância antes de fazer o pedido. |
| 400 | RegionEndTimeDissolvedIndia | The region is no longer supported. | A região foi desativada. |
| 400 | StopService.Clone | The service has been discontinued and cloning operations on classic network instances are no longer permitted. | A clonagem de instâncias do tipo rede clássica não é permitida porque a rede clássica foi descontinuada e o prazo de interrupção do serviço expirou. |
| 400 | InvalidParam.UsedTime | The clone expiration date cannot exceed %s. | Como a rede clássica foi descontinuada, o período de uso da instância de rede clássica clonada não pode exceder o limite de tempo. |
| 400 | MinorVersionTag.NotFound | Minor version tags cannot be parsed by the instance. | |
| 400 | InvalidBakset.Invalid | Specified bakset is not valid. | O conjunto de backups especificado não oferece suporte a esta operação. |
| 400 | InvalidParamForXfs | Xfs instance must be single tenant standard instance. | A instância Xfs deve ser uma instância dedicada de alta disponibilidade. |
| 400 | AtLeastThreeVSwitchAvailableIp | The primary vswitch requires at least three available IP addresses. | O vSwitch principal deve ter pelo menos 3 endereços IP disponíveis. |
| 400 | AtLeastTwoVSwitchAvailableIp | The primary vswitch requires at least two available IP addresses. | O vSwitch principal deve ter pelo menos 2 endereços IP disponíveis. |
| 400 | DiskSize.NotEnough | The disk size is not enough to restore tables. | O disco em nuvem não tem espaço suficiente. |
| 500 | ExternalFailure | The request processing has failed due to external service failure. | A solicitação para o serviço falhou. Tente novamente mais tarde. |
| 500 | RequestMetaDataFailed | The service request failed. Please try again later or contact service personnel. | A solicitação de serviço falhou. Tente novamente mais tarde ou entre em contato com o suporte. |
| 500 | InvokeProxyFailure | The request processing has failed due to service failure of rds api. | A solicitação falhou porque o serviço da API do RDS apresentou falha. |
| 403 | IncorrectMinorVersion | Current engine minor version does not support operations. | A versão secundária atual do mecanismo não suporta esta operação. |
| 403 | IncorrectCharacterType | Current DB instance character type does not support this operation. | O tipo de caractere da instância atual não suporta esta operação. |
| 403 | CloudDiskEncryptionNotSupport | The encryption key is not allowed for general-purpose instance. | As instâncias de uso geral não suportam a criptografia de disco em nuvem. |
| 403 | OrderStatus.UnPaid | The specified db instance has unpaid order. | Existe um pedido não pago para a instância atual. Pague o pedido e tente novamente. |
| 403 | InvalidReduceDiskSize | The storage capacity after the scale-down must be larger than the used amount. | A capacidade de destino para redução de escala não pode ser menor que o uso de armazenamento atual. |
| 403 | CloudSSDNotSupport | Cloud ssd does not support this operation, please upgrade to essd. | Os discos em nuvem SSD não suportam esta operação. Faça upgrade para ESSD. |
| 403 | InvalidUserOperatorPermission | The user permission does not support this operation. | As permissões do usuário não suportam esta operação. |
| 403 | InvalidVswitchId | Specified conn vswitch id is not valid. | O VSwitchId especificado está em um formato incorreto ou está vazio. |
| 403 | OperationDenied.ZoneResource | There is no available zone for inventory. | Não há regiões de inventário disponíveis. |
| 403 | NotInFlowController | Sorry,no permission. | Este recurso está disponível apenas para usuários de nuvem corporativa. Você não tem as permissões necessárias. |
| 403 | InvalidKmsKey | Kms key is disabled. | A chave KMS está desativada. |
| 403 | InvalidInstanceLevel.Malformed | Current DB instance level does not support this operation. | O nível atual da instância de banco de dados não oferece suporte a esta operação. |
| 403 | InvalidMeta.TooLarge | Meta information is too large. | Os metadados são muito grandes. Verifique se o número de tabelas na instância excede 50.000. |
| 404 | InvalidDBInstance.NotFound | The specified instance does not exist or is not supported. | A instância especificada não foi encontrada. Verifique se a instância é válida. |
| 404 | InvalidClusterKms | The current instance does not authorized to access the Key Management Service. | A instância atual não está autorizada a acessar o Key Management Service (KMS). |
| 404 | Request.NotFound | The requested resource is not available. | O recurso solicitado não está disponível. |
| 404 | HostInfo.NotFound | The specified host info is not found. | As informações do host especificado não existem. |
Consulte Códigos de Erro para uma lista completa.
Notas de versão
Consulte Notas de Versão para uma lista completa.