Todos os produtos
Search
Central de documentação

ApsaraDB RDS:ModifySecurityIps

Última atualização: Jul 07, 2026

Modifica a lista de permissões de endereços IP de uma instância do ApsaraDB RDS.

Descrição da operação

Experimente agora

Experimente esta API no OpenAPI Explorer, sem necessidade de assinatura manual. Chamadas bem-sucedidas geram automaticamente código SDK correspondente aos seus parâmetros. Faça o download com segurança de credenciais integrada para uso local.

Testar

Autorização RAM

A tabela abaixo descreve a autorização necessária para chamar esta API. Você pode defini-la em uma política do Resource Access Management (RAM). As colunas da tabela estão detalhadas abaixo:

  • Ação: As ações que podem ser usadas no elemento Action das instruções de política de permissão do RAM para conceder permissões para executar a operação.

  • API: A API que você pode chamar para executar a ação.

  • Nível de acesso: O nível de acesso predefinido concedido para cada API. Valores válidos: create, list, get, update e delete.

  • Tipo de recurso: O tipo de recurso que suporta autorização para executar a ação. Indica se a ação suporta permissão em nível de recurso. O recurso especificado deve ser compatível com a ação. Caso contrário, a política será ineficaz.

    • Para APIs com permissões em nível de recurso, os tipos de recursos obrigatórios são marcados com um asterisco (*). Especifique o Nome de Recurso Alibaba Cloud (ARN) correspondente no elemento Resource da política.

    • Para APIs sem permissões em nível de recurso, é exibido como Todos os Recursos. Use um asterisco (*) no elemento Resource da política.

  • Chave de condição: As chaves de condição definidas pelo serviço. A chave permite controle granular, aplicando-se somente a ações ou a ações associadas a recursos específicos. Além das chaves de condição específicas do serviço, o Alibaba Cloud fornece um conjunto de chaves de condição comuns aplicáveis a todos os serviços compatíveis com RAM.

  • Ação dependente: As ações dependentes necessárias para executar a ação. Para concluir a ação, o usuário RAM ou a função RAM deve ter permissões para executar todas as ações dependentes.

Ação

Nível de acesso

Tipo de recurso

Chave de condição

Ação dependente

rds:ModifySecurityIps

update

*DBInstance

acs:rds:{#regionId}:{#accountId}:dbinstance/{#dbinstanceId}

  • rds:ResourceTag
  • rds:ResourceTag
  • rds:ResourceTag
  • rds:ResourceTag
Nenhuma

Parâmetros da solicitação

Parâmetro

Tipo

Obrigatório

Descrição

Exemplo

DBInstanceId

string

Sim

O ID da instância. Você pode chamar a operação DescribeDBInstances para consultar o ID da instância.

pgm-bp18n0c8zt45****

SecurityIps

string

Sim

Os endereços IP em uma lista de permissões de endereços IP. Separe vários endereços IP com vírgulas (,). Cada endereço IP na lista de permissões de endereços IP deve ser exclusivo. As entradas na lista de permissões de endereços IP devem estar em um dos seguintes formatos:

  • Endereços IP, como 10.23.XX.XX.

  • Blocos CIDR, como 10.23.XX.XX/24. Neste exemplo, 24 indica que o prefixo de cada endereço IP na lista de permissões de endereços IP tem 24 bits de comprimento. Você pode substituir 24 por um valor dentro do intervalo de 1 a 32.

Nota

Um máximo de 1.000 endereços IP ou blocos CIDR podem ser adicionados para cada instância. Se você quiser adicionar um grande número de endereços IP, recomendamos que os agrupe em blocos CIDR, como 10.23.XX.XX/24.

10.23.XX.XX

DBInstanceIPArrayName

string

Não

O nome da lista de permissões de endereços IP que você deseja modificar. Valor padrão: Default.

Nota

Um máximo de 200 listas de permissões de endereços IP podem ser configuradas para cada instância.

test

DBInstanceIPArrayAttribute

string

Não

O atributo da lista de permissões de endereços IP. Por padrão, este parâmetro está vazio.

Nota

As listas de permissões de endereços IP que possuem o atributo oculto não são exibidas no console do ApsaraDB RDS. Essas listas de permissões de endereços IP são usadas para acessar serviços da Alibaba Cloud, como o Data Transmission Service (DTS).

hidden

SecurityIPType

string

Não

O tipo de endereço IP. O valor é fixo como IPv4.

IPv4

WhitelistNetworkType

string

Não

O tipo de rede da lista de permissões de endereços IP. Valores válidos:

  • Classic: rede clássica no modo de lista de permissões aprimorado

  • VPC: tipo de rede de nuvem privada virtual (VPC) no modo de lista de permissões aprimorado.

  • MIX: modo de lista de permissões padrão

Valor padrão: MIX.

Nota
  • No modo de lista de permissões padrão, endereços IP e blocos CIDR são adicionados apenas à lista de permissões de endereços IP padrão. No modo de lista de permissões aprimorado, endereços IP e blocos CIDR são adicionados às listas de permissões de endereços IP do tipo de rede clássica e do tipo de rede VPC.

  • Se a sua instância RDS executa PostgreSQL e usa discos em nuvem, defina este parâmetro como MIX. Se você defini-lo com outro valor, o sistema altera automaticamente o valor para MIX.

MIX

ModifyMode

string

Não

O método usado para modificar a lista de permissões. Valores válidos:

  • Cover: Use os endereços IP e blocos CIDR especificados no parâmetro SecurityIps para substituir os endereços IP e blocos CIDR existentes na lista de permissões de endereços IP.

  • Append: Adicione os endereços IP e blocos CIDR especificados no parâmetro SecurityIps à lista de permissões de endereços IP.

  • Delete: Exclua os endereços IP e blocos CIDR especificados no parâmetro SecurityIps da lista de permissões de endereços IP. Você deve reter pelo menos um endereço IP ou bloco CIDR.

Valor padrão: Cover.

Cover

FreshWhiteListReadins

string

Não

As instâncias somente leitura para as quais você deseja sincronizar a lista de permissões de endereços IP.

  • Este parâmetro se aplica apenas a instâncias do ApsaraDB RDS for PostgreSQL.

  • Se a instância estiver anexada a uma instância somente leitura, você pode usar este parâmetro para sincronizar a lista de permissões de endereços IP com a instância somente leitura. Se a instância estiver anexada a várias instâncias somente leitura, separe as instâncias somente leitura com vírgulas (,).

  • Se a instância não estiver anexada a uma instância somente leitura, deixe este parâmetro vazio.

pgr-bp17yuz4dn3d****,pgr-bp1vn2ph54u1****

Elementos de resposta

Elemento

Tipo

Descrição

Exemplo

object

Os parâmetros de resposta.

RequestId

string

O ID da solicitação.

1AD222E9-E606-4A42-BF6D-8A4442913CEF

TaskId

string

O ID da tarefa.

11585****

Exemplos

Resposta de sucesso

JSON formato

{
  "RequestId": " 1AD222E9-E606-4A42-BF6D-8A4442913CEF",
  "TaskId": "11585****"
}

Resposta de erro

JSON formato

{
    "RequestId": "7463B73D-35CC-4D19-A010-6B8D65D242EF",
    "HostId": "rds.aliyuncs.com",
    "Code": "UnsupportedOperation",
    "Message": "The specified action is not supported."
}

Códigos de erro

Código de status HTTP

Código de erro

Mensagem de erro

Descrição

400 IncorrectMasterDBInstanceState Master instance state does not support this operation.
400 InvalidWhitelistNetType.Malformed Specified WhitelistNetType is not valid. The specified WhitelistNetworkType is invalid. Please check again.
400 InvalidIPArrayAttribute.Format The format of the IP attribute is invalid. The specified DBInstanceIPArrayAttribute parameter is invalid. Specify a valid value and try again. If the value that you specify contains multiple entries, separate the entries with commas (,). Each entry must be unique. Valid entries are in one of the following formats: IP address, such as 10.23.12.24. CIDR, such as 10.23.12.0/24. In this example, 24 indicates that the prefix in each IP address is 24 bits in length. You can replace 24 with an integer within the range of 1 to 32.
400 InvalidSecurityIPList.Duplicate Specified security IP list is not valid: Duplicate IP address in the list. The IP address whitelist is invalid. It contains duplicate entries.
400 SecurityIPList.Format Specified SecurityIPList is not valid. The specified IP address whitelist is invalid.
400 InvalidGroupName.DuplicatedWithTemplate Sepecified group name is used by whitelist template. The whitelist group name conflicts with the whitelist template associated with the instance.
400 InvalidSecurityIPListGroup.QuotaExceeded Specified security IP list group is not valid: Exceeding the allowed amount of group. The specified whitelist security group is invalid and exceeds the number of allowed groups.
400 InvalidDBInstanceType.Format Specified instance type is not valid. The operation failed. The database engine is invalid. Specify a valid database engine.
400 Order.ComboInstanceNotAllowOperate A package instance is not allowed to operate independently. A package instance is not allowed to operate independently.
400 Price.PricingPlanResultNotFound Pricing plan price result not found. Pricing plan price result not found.
400 Order.NoRealNameAuthentication You have not passed the real-name authentication and do not meet the purchase conditions. Please log in to the user center for real-name authentication. You have not passed the real-name authentication and do not meet the purchase conditions. Please log in to the cost and cost for real-name authentication.
400 InsufficientAvailableQuota Your account quota limit is less than 0, please recharge before trying to purchase. Your account available limit is less than 0, please recharge before trying to purchase.
400 CommodityServiceCalling.Exception Failed to call commodity service. Failed to call commodity service return.
400 RegionDissolvedEOM Dear customer, Alibaba Cloud plans to optimize and adjust the current region. Cloud services in this region will cease operations. You are currently unable to operate new purchase orders. Thank you for your understanding and support. Hello, Alibaba Cloud plans to optimize and adjust the current region. Cloud services in this region will stop operating. In order to ensure your business continuity and smooth transition of data migration, you are currently unable to operate new purchase orders. Thank you for your understanding and support.
400 Commodity.InvalidComponent The module you purchased is not legal, please buy it again. The module you purchased is not legal, please buy it again.
400 RegionEndTimeDissolvedAustralia Cloud services in the Australia (Sydney) region will be discontinued. Set the validity date to September 30, 2024 or earlier than September 30, 2024. Hello customer, this area has been abolished.
400 Price.CommoditySys Commodity system call exception. Commodity system call exception.
400 Pay.InsufficientBalance Insufficient available balance. Insufficient available balance.
400 Order.PeriodInvalid There is a problem with the period you selected, please choose again. There is a problem with the period you selected, please choose again.
400 pay.noCreditCard Account not bound to credit card.
400 Order.InstHasUnpaidOrder There is an unpaid order for the service you have purchased. Please pay or void it before placing the order. There is an unpaid order for the service you have purchased. Please pay or void it before placing the order.
400 noAvailablePaymentMethod No payment method is specified for your account. We recommend that you add a payment method. No payment method has been specified for your account. We recommend that you add a payment method.
400 BasicInfoUncompleted Your information is incomplete. Complete your information before the operation. Your basic information is not complete, please complete your basic information before operation.
400 Risk.RiskControlRejection Your account is abnormal, please contact customer service for details. Your account is abnormal, please contact customer service for details.
400 Api.NotSupport Specified api is not supported. The current interface does not support.
400 ContainForbiddenLabelError There is a label that prohibits placing orders. Please contact your distributor for assistance. You cannot place the order because a tag indicates that order placement is prohibited. Contact your distributor.
400 InvalidDBInstanceId.NotFound The DBInstanceId provided does not exist in records. The DBInstanceId provided does not exist.
400 InvalidInstanceLevel.DiskType Specified instance level not support request disk type The current instance type does not support the specified storage type.
400 InvalidParam Sepcified wal level Parameter is invalid. There are still logical slots in instance, so it can not be set as replica. The specified wal_level parameter is invalid. There is still a copy slot in the instance, so it cannot be set to replica.
400 KmsApiError User secret key invalid. The user key is invalid.
400 System.SaleValidateFailed Sales expression validation system error. A system error occurs when the sales expression is verified.
400 Abs.InvalidAccount.NotFound account is not found. The account does not exist.
400 SqlExecuteFailedOrTimeout sql command execution failed or timed out:%s. SQL command execution failed or timed out
400 ColdData.EngineVersionNotSupport The current instance engine version not support coldDataEnabled. The current instance engine version not support coldDataEnabled.
400 ColdData.MinorVersionNotSupport The current instance minor version not support coldDataEnabled. The current instance minor version not support coldDataEnabled.
400 IncorrectTargetClasscode The current instance type does not support this operation. This operation is not supported by the instance type.
400 InvalidConnectionString.Duplicate Specified connection string already exists in the RDS. The link address name is duplicate. Please reset the connection string.
400 RequiredParam.NotFound Required input param is not found.
400 Parameters.Invalid Parameter error, please check the parameters. Parameter error, please check the parameters.
400 BackupPolicyNotSupport Cold Data won't open with CrossBackup or Flash Backup, please check Backup Policy. Cold Data won't open with CrossBackup or Flash Backup, please check Backup Policy.
400 InvalideStatus.Format The instance status does not support this operation.
400 InvalidReleasedKeepPolicy.Format Specified Released Keep Policy is not valid. Specified Released Keep Policy is not valid.
400 InvalidDBInstanceEngineType.Format the DB instance engine type does not support this operation. This operation is not supported for the database engine of the instance.
400 Pay.NoCreditCard No credit cards. No credit cards.
400 VpcNetworkTypeNotSupport The vpc network type instance does not support this operation. The vpc network type instance does not support this operation.
400 MirrorInsExists Specified DB instance mirror ins already existed. Specified DB instance mirror ins already existed.
400 UnsupportedClassCode The specified DB instance class stops selling. The specified DB instance class stops selling.
400 InvalidBackupSet The specified database does not exist in the backup set. The specified database does not exist in the backup set.
400 OrdTCommodityQueryError Failed to query for product. Failed to query product.
400 ProductInstanceReleased The instance has been released. Please check before placing the order. The instance has been released, please verify and place an order.
400 RegionEndTimeDissolvedIndia The region is no longer supported. The region is no longer supported.
500 ExternalFailure The request processing has failed due to external service failure. The request processing has failed due to external service failure.
500 RequestMetaDataFailed The service request failed. Please try again later or contact service personnel. The service request failed. Please try again later or contact service personnel.
500 InvokeProxyFailure The request processing has failed due to service failure of rds api. The request failed to be processed due to an RDS API failure.
403 IncorrectDBType The current DB type does not support this operation. The operation failed. The operation is not supported by the database engine of the RDS instance. Specify a different database engine.
403 IncorrectDBInstanceType Current DB instance type does not support this operation. The operation failed. The RDS instance is not in a ready state.
403 IncorrectDBInstanceCharacterType Current DB Instance character_type does not support this operation. This operation is not supported for the character type of the current instance.
403 IncorrectDBInstanceState Current DB instance state does not support this operation.
403 IncorrectEngineVersion The engine version does not support the operation. The operation failed. The operation is not supported for the database engine version of the RDS instance.
403 OrderStatus.UnPaid The specified db instance has unpaid order. The instance has an unpaid order. Please pay first and try again.
403 InvalidReduceDiskSize The storage capacity after the scale-down must be larger than the used amount. The scale-in target capacity cannot be less than the current storage space usage
403 CloudSSDNotSupport Cloud ssd does not support this operation, please upgrade to essd.
403 InvalidUserOperatorPermission The user permission does not support this operation. The user is not authorized to perform this operation.
403 InvalidVswitchId Specified conn vswitch id is not valid.
403 IncorrectMinorVersion Current engine minor version does not support operations. This operation is not supported for the current minor engine version.
403 OperationDenied.ZoneResource There is no available zone for inventory. There is no available zone for inventory.
403 NotInFlowController Sorry,no permission. Sorry,no permission.
403 InvalidKmsKey Kms key is disabled.
403 InvalidInstanceLevel.Malformed Current DB instance level does not support this operation. The specified database instance type does not support this operation.
404 Readins.NotFound The current instance does not contain any read only instance. The operation is not supported. The operation failed. The RDS instance is not attached with read-only RDS instances.
404 InvalidDBInstanceName.NotFound The database instance does not exist. The name of the RDS instance cannot be found. Check the name of the RDS instance.
404 InvalidDBInstance.NotFound The specified instance does not exist or is not supported. The RDS instance cannot be found. Check the ID or name of the RDS instance.
404 IncorrectDBInstanceLockMode Current DB instance lock mode does not support this operation. The operation failed. The RDS instance is locked.
404 InvalidClusterKms The current instance does not authorized to access the Key Management Service. The instance does not have permissions to access Key Management Service (KMS).
404 Request.NotFound The requested resource is not available. The requested resources are unavailable.
404 HostInfo.NotFound The specified host info is not found.

Consulte Códigos de Erro para uma lista completa.

Notas de versão

Consulte Notas de Versão para uma lista completa.