Todos os produtos
Search
Central de documentação

:Outros problemas de uso do ECS

Última atualização: Jul 04, 2026

Este tópico descreve problemas comuns que podem ocorrer durante a configuração e o uso de software de terceiros em instâncias do Elastic Compute Service (ECS) e apresenta as soluções correspondentes.

Problemas com MySQL

O que fazer se a mensagem de erro "1045 - Access denied for user 'root'@''(using password:YES)" aparecer ao conectar-se ao MySQL implantado em uma instância após instalar e fazer login no MySQL na instância?

Descrição do problema

Após instalar e fazer login no MySQL em uma instância ECS, a seguinte mensagem de erro aparece ao tentar conectar-se ao MySQL a partir de um endereço IP remoto usando o nome de usuário e a senha corretos: 1045 - Access denied for user 'root'@'****'(using password:YES)'(using password:YES).

Causa

Após a instalação do MySQL na instância ECS, o sistema permite logins apenas de endereços IP locais e bloqueia logins de endereços IP remotos.

Solução

Execute as etapas a seguir para permitir logins no MySQL a partir de endereços IP remotos:

  1. Conecte-se à instância ECS.

    Para mais informações, consulte Métodos de conexão remota para instâncias ECS.

  2. Faça login no MySQL e execute a seguinte instrução SQL para conceder permissões de login remoto ao usuário root:

    GRANT ALL PRIVILEGES ON *.* TO 'root'@'%' WITH GRANT OPTION;
    Nota

    Após executar a instrução SQL anterior, o usuário root poderá fazer login no MySQL a partir de qualquer endereço IP e realizar operações em objetos nos bancos de dados MySQL.

    A tabela a seguir descreve os parâmetros da instrução SQL.

    Parâmetro

    Descrição

    .

    O primeiro asterisco (*) é um espaço reservado para banco de dados. Se você especificar *, este parâmetro indicará todos os bancos de dados. O segundo asterisco (*) é um espaço reservado para tabelas de banco de dados. Se você especificar *, este parâmetro indicará todas as tabelas no banco de dados.

    'root'@'%'

    root é a conta de banco de dados à qual as permissões de login são concedidas. O sinal de porcentagem (%) é um espaço reservado para endereço IP. Por exemplo, se quiser que apenas o endereço IP 1.1.1.1 faça login nos bancos de dados, altere % para 1.1.1.1. Se você especificar %, este parâmetro indicará que todos os endereços IP têm permissão para fazer login.

  3. Para atualizar as permissões, execute a seguinte instrução SQL:

    flush privileges;
  4. Reconecte-se ao MySQL. Se o problema for resolvido, a mensagem de erro anterior não aparecerá mais.

O que fazer se não for possível conectar-se ao MySQL em uma instância Linux ECS e a mensagem de erro "ERROR 2003 (HY000): Can't connect to MySQL server on '39.106..' (110)" aparecer?

Descrição do problema

Não é possível conectar-se ao MySQL em uma instância Linux ECS e a seguinte mensagem de erro é exibida: ERROR 2003 (HY000): Can't connect to MySQL server on '39.106.**.**' (110).' (110).

Causa

Esse problema pode ocorrer porque a porta 3306 na instância Linux ECS não está no estado Listening. Consequentemente, o endereço IP 39.106.**.** da instância não tem acesso ao MySQL.

Solução

  1. Conecte-se à instância Linux ECS onde o MySQL está instalado.

    Para mais informações, consulte Fazer login em uma instância Linux usando o Workbench.

  2. Execute o comando a seguir para fazer backup do arquivo de configuração my.cnf:

    cp my.cnf my.cnf.bak
  3. Modifique o arquivo de configuração my.cnf.

    1. Execute o comando a seguir para abrir o arquivo de configuração my.cnf:

      vim /etc/my.cnf
    2. Pressione a tecla i para entrar no modo Insert e adicione o seguinte conteúdo ao arquivo my.cnf:

      bind-address = 0.0.0.0

      A figura a seguir mostra onde adicionar o conteúdo.

    3. Pressione a tecla Esc para sair do modo Insert, insira :wq e pressione a tecla Enter para salvar e fechar o arquivo.

  4. Execute o comando a seguir para reiniciar o MySQL e garantir que a porta 3306 esteja no estado Listening:

    /etc/init.d/mysqld restart

Problemas de upload de arquivos

O que fazer se a mensagem de erro "553 Could not create file" aparecer ao tentar fazer upload de arquivos para uma instância Linux usando Very Secure FTP (VSFTP)?

Descrição do problema

Não é possível usar o VSFTP para fazer upload de arquivos para uma instância Linux ECS e a mensagem de erro "553 Could not create file" é exibida.

Causas

Esse problema pode ocorrer pelos seguintes motivos:

  • O espaço em disco da instância Linux está cheio.

  • As permissões write no diretório home do FTP não foram concedidas.

Solução

Execute as etapas a seguir para verificar o uso do espaço em disco da instância Linux e as permissões no diretório home do FTP:

  1. Conecte-se à instância Linux ECS.

    Para mais informações, consulte Fazer login em uma instância Linux usando o Workbench.

  2. Execute o comando a seguir para verificar se o espaço em disco da instância está cheio:

    df -h
    Nota

    Se o uso da partição em um disco atingir 100%, o espaço em disco estará cheio.

    A figura a seguir mostra um exemplo de saída de comando. Na saída de exemplo, o uso da partição /dev/xvda1 é de 59%.

  3. Execute o comando a seguir para verificar se as permissões write no diretório home do FTP foram concedidas.

    Nota

    Especifique o diretório home real do FTP. Neste exemplo, o diretório /home/user é usado como o diretório home do FTP.

    ls -l /home/user

    Se as permissões write no diretório home do FTP não tiverem sido concedidas, w não estará incluído nas configurações de permissão, conforme mostrado no quadro vermelho na figura a seguir.

    1111

  4. Execute o comando a seguir para conceder as permissões write no diretório home do FTP:

    chmod +w /home/user
  5. Execute o comando a seguir para verificar se as permissões de escrita no diretório home do FTP foram concedidas. Se w for exibido na saída do comando, as permissões write no diretório home do FTP foram concedidas.

    ls -l /home/user

O que fazer se a mensagem de erro "550 Permission denied" aparecer ao fazer upload de um arquivo para o FileZilla Server usando FTP em uma instância Windows ECS?

Descrição do problema

A mensagem de erro 550 Permission denied aparece ao fazer upload de um arquivo para o FileZilla Server usando FTP em uma instância Windows ECS.

Causa

A conta FTP não tem as permissões write no FileZilla Server.

Solução

  1. Conecte-se à instância Windows ECS.

    Para mais informações, consulte Conectar-se a uma instância Windows usando o Workbench.

  2. Execute o FileZilla Server. Na janela Users, selecione Shared folders.

  3. Selecione o usuário e o diretório correspondentes à conta FTP, marque Write e clique em OK para conceder as permissões de escrita ao usuário.

Falhas na instalação do controlador de domínio Active Directory (AD)

O que fazer se não for possível instalar um controlador de domínio AD e a mensagem de erro "Failed to install active directory domain services binaries" aparecer?

Descrição do problema

Não é possível instalar um controlador de domínio AD em uma instância Windows ECS e a mensagem de erro "Failed to install active directory domain services binaries" é exibida.

Causa

O erro exibido no Visualizador de Eventos do Windows indica que o serviço Remote Registry está desabilitado e não pode ser iniciado conforme esperado.

Solução

Execute as etapas a seguir para iniciar o serviço Remote Registry:

  1. Conecte-se à instância Windows ECS.

    Para mais informações, consulte Conectar-se a uma instância Windows usando o Workbench.

  2. Na barra de tarefas da área de trabalho, clique em Start e selecione Run. Na caixa de diálogo Run, insira services.msc e clique em OK.

  3. Na janela Services, clique duas vezes em Remote Registry para abrir a janela Propriedades de Remote Registry. Na janela Remote Registry Properties, defina as seguintes configurações:

    • Defina Startup type como Automatic.

    • Na seção Service status, clique em Start e verifique se o serviço Remote Registry inicia conforme esperado.

  4. Clique em OK.

O que fazer se a mensagem de erro "This computer has dynamically assigned IP addresses" aparecer ao instalar um controlador de domínio AD?

Descrição do problema

Ao instalar um controlador de domínio AD em uma instância Windows ECS, a mensagem de erro "This computer has dynamically assigned IP addresses" é exibida.

Causa

Pelo menos um adaptador de rede física na instância não possui um endereço IP estático.

Solução

  1. Conecte-se à instância Windows ECS.

    Para mais informações, consulte Conectar-se a uma instância Windows usando o Workbench.

  2. Instale um controlador de domínio AD.

  3. Na janela Static IP assignment, clique em Yes.

Nota

O Loopback usa o protocolo DHCP (Dynamic Host Configuration Protocol) e funciona conforme esperado sem um endereço IP estático.

O que fazer se o código de erro 0x0000232B RCODE_NAME_ERROR for retornado ao instalar um controlador de domínio AD?

Descrição do problema

Ao instalar um controlador de domínio AD em uma instância Windows ECS, o código de erro 0x0000232B RCODE_NAME_ERROR é retornado.

Causa

Os endereços IP estão configurados incorretamente no servidor DNS.

Solução

Execute as etapas a seguir para alterar os endereços do servidor DNS para o endereço IP privado da instância Windows ECS:

  1. Conecte-se à instância Windows ECS.

    Para mais informações, consulte Conectar-se a uma instância Windows usando o Workbench.

  2. Abra a janela Internet Protocol Version 4 (TCP/IP) Properties, altere os endereços do servidor DNS e clique em OK.

    Nota

    Altere os endereços do servidor DNS para o endereço IP privado da instância Windows ECS.

    p13294

  3. Verifique se é possível fazer ping no endereço IP do servidor DNS.

O que fazer se a mensagem de erro "The network path was not found" aparecer ao instalar um controlador de domínio AD em uma instância Windows ECS?

Descrição do problema

Ao instalar um controlador de domínio AD em uma instância Windows ECS, a mensagem de erro "The network path was not found" é exibida.

Causas

Esse problema pode ocorrer pelos seguintes motivos:

  • Os serviços TCP/IP NetBIOS Helper e Remote Registry não estão iniciados no controlador de domínio AD e no cliente.

  • As configurações de DNS do controlador de domínio AD e do cliente estão incorretas.

  • O identificador de segurança (SID) do cliente é igual ao SID do controlador de domínio AD.

  • O firewall ou software de segurança bloqueia o cliente.

Solução

Execute as seguintes operações:

  • Inicie os serviços TCP/IP NetBIOS Helper e Remote Registry

    Inicie os serviços TCP/IP NetBIOS Helper e Remote Registry na instância ECS onde deseja instalar o controlador de domínio AD e na instância ECS que atua como cliente. Para mais informações, consulte as subseções de Solução na seção "Falhas na instalação do controlador de domínio Active Directory (AD)" deste tópico.

  • Modifique as configurações de DNS do cliente

    Para mais informações, consulte as subseções de Solução na seção "Falhas na instalação do controlador de domínio Active Directory (AD)" deste tópico.

  • Altere o SID do cliente

    Execute as etapas a seguir:

    1. Conecte-se à instância Windows ECS que atua como cliente.

      Para mais informações, consulte Conectar-se a uma instância Windows usando o Workbench.

    2. Baixe o script PowerShell usado para alterar o SID do cliente.

    3. Abra o Prompt de Comando e entre no PowerShell. A janela Windows PowerShell será exibida.

      Nota

      Se sua instância ECS executar um sistema operacional de 64 bits, não use um script do PowerShell de 32 bits (Windows PowerShell (x86)). Caso contrário, ocorrerá um erro.

    4. Acesse o caminho onde o script está armazenado e execute o comando a seguir para visualizar a descrição da ferramenta de script:

      .\AutoSysprep.ps1 -help
    5. Execute o comando a seguir para reinicializar o SID do cliente:

      .\AutoSysprep.ps1 -ReserveHostname -ReserveNetwork -SkipRearm -PostAction "reboot"

      Após a inicialização do SID, a instância ECS que atua como cliente é reiniciada. Observe os seguintes itens:

      • O endereço IP do cliente é alterado de um endereço IP dinâmico atribuído via DHCP para um endereço IP estático. Certifique-se de que o endereço IP estático seja o mesmo que o endereço IP da instância ECS. Você pode configurar o endereço IP que deseja atribuir via DHCP para obter o endereço IP privado principal da instância ECS.

        Nota

        Não altere o endereço IP privado principal da instância ECS no console ECS. Caso contrário, ocorrerão exceções de acesso.

      • Após reinicializar o SID, as configurações do firewall na instância ECS retornam aos padrões da Microsoft. Como resultado, não é possível fazer ping na instância. Desabilite o firewall do Windows para o perfil Guest or public networks ou abra as portas necessárias.

    6. Abra o Painel de Controle para desabilitar o firewall do perfil de rede Convidado ou Pública.

      Após desabilitar o firewall do Windows para o perfil de rede Convidado ou Pública, será possível fazer ping na instância.

  • Configure o firewall ou software de segurança para permitir o acesso do cliente

    Para mais informações, consulte Configurar regras de firewall para Windows.

Erros ao executar comandos wget

O que fazer se a mensagem de erro "command not found" aparecer ao executar um comando wget em uma instância Linux?

Descrição do problema

Ao executar um comando wget em uma instância Linux ECS, a mensagem de erro "command not found" é exibida. Ao executar o comando yum install wget, a mensagem de erro "already installed and latest version" é exibida.

Causa

O arquivo wge existe no diretório /usr/bin em vez do arquivo wget. Esse problema pode ocorrer porque o arquivo foi renomeado para wge.

Solução

Execute as etapas a seguir:

  1. Conecte-se à instância Linux ECS.

    Para mais informações, consulte Fazer login em uma instância Linux usando o Workbench.

  2. Execute o comando a seguir para consultar o caminho do arquivo wge:

    whereis wge

    A seguinte saída de comando é retornada, indicando que o arquivo wge está armazenado no caminho /usr/bin/wge:

    wge: /usr/bin/wge
  3. Execute o comando a seguir para copiar o arquivo wge no diretório /usr/bin/wge:

    cp /usr/bin/wge /usr/bin/wget
  4. Execute novamente o comando wget. Se o problema for resolvido, a mensagem de erro não aparecerá mais.

O que fazer se a mensagem de erro "Permission denied" aparecer ao executar um comando wget para baixar dados em uma instância Linux ECS?

Descrição do problema

Ao executar um comando wget para baixar dados em uma instância Linux ECS, a seguinte mensagem de erro é exibida:

wget bash: /usr/bin/wget: Permission denied

Causa

As permissões do utilitário wget na instância Linux ECS estão definidas como 000, o que significa que nenhum usuário tem permissão para ler, gravar ou executar o utilitário.

Solução

Execute as etapas a seguir:

  1. Conecte-se à instância Linux ECS.

    Para mais informações, consulte Fazer login em uma instância Linux usando o Workbench.

  2. Execute o comando a seguir para consultar as permissões do utilitário wget:

    ls -l /usr/bin/wget

    A seguinte saída de comando é retornada, indicando que as permissões do utilitário wget estão definidas como 000:

    -------- 1 root root 366800 Oct 31 2014 /usr/bin/wget
  3. Execute o comando a seguir para consultar os atributos do arquivo /usr/bin/wget:

    lsattr /usr/bin/wget

    A seguinte saída de comando é retornada, indicando que o arquivo /usr/bin/wget possui o atributo i e é imutável. Nesse caso, não é possível criar ou excluir arquivos no diretório.

    ----i--------e- /usr/bin/wget
  4. Execute o comando a seguir para remover o atributo i do arquivo /usr/bin/wget:

    chattr -i /usr/bin/wget
  5. Execute o comando a seguir para conceder permissões ao arquivo /usr/bin/wget:

    chmod 755 /usr/bin/wget 
  6. Execute novamente o comando wget. Se o problema for resolvido, a mensagem de erro não aparecerá mais.

Falhas de acesso FTP

  • Instâncias Windows

    O que fazer se não for possível acessar um servidor FTP em uma instância Windows ECS a partir de redes externas?

    Descrição do problema

    Não é possível acessar um servidor FTP implantado em uma instância Windows ECS a partir de redes externas.

    Causas

    Esse problema pode ocorrer pelos seguintes motivos:

    Soluções

    Use uma das soluções a seguir para resolver o problema com base no cenário real:

    Solução 1: Adicionar regras de grupo de segurança para abrir as portas FTP necessárias

    Após criar um site FTP na instância Windows ECS, adicione regras de entrada aos grupos de segurança da instância para abrir a porta 21 e as portas no intervalo de 1024 a 65535 para conexões passivas ao serviço FTP. Para obter informações sobre como adicionar uma regra de grupo de segurança de entrada, consulte Adicionar uma regra de grupo de segurança.

    Nota

    Para obter informações sobre grupos de segurança, consulte Diretrizes e casos de uso e Portas comuns.

    Solução 2: Configurar o recurso FTP Firewall Support

    Se o firewall estiver habilitado, configure o Gerenciador do Internet Information Services (IIS) para abrir a porta TCP 21 e as portas no intervalo de 1024 to 65535 para o serviço FTP. Execute as etapas a seguir:

    Nota
    • Por padrão, o firewall da instância Windows ECS está desabilitado.

    • Esta seção descreve como usar o Gerenciador do IIS para configurar o FTP.

    1. Conecte-se à instância Windows ECS.

      Para mais informações, consulte Conectar-se a uma instância Windows usando o Workbench.

    2. Abra o IIS Manager e clique duas vezes em FTP Firewall Support na lista de recursos no painel central.

    3. Na página FTP Firewall Support no painel central, configure os parâmetros e clique em Apply no painel Actions.

      Nota

      Observe os seguintes parâmetros:

      • External IP Address of Firewall: Insira o endereço IP público da instância Windows ECS.

      • Data Channel Port Range: Insira um intervalo de portas para conexões passivas ao serviço FTP. Intervalo válido para números de porta: 1024 a 65535. Insira um intervalo de portas com base nos seus requisitos de negócios. Neste exemplo, 1024-65535 é inserido.

    4. Abra o Prompt de Comando e execute o comando a seguir para reiniciar o serviço FTP, garantindo que as configurações de todos os sites FTP entrem em vigor:

      net stop ftpsvc&net start ftpsvc
    5. (Opcional) Após configurar um servidor FTP na instância Windows ECS, você pode acessar o serviço FTP localmente, mas não a partir de outra instância ECS. Esse problema é causado por configurações incorretas de firewall. Para resolver o problema, execute as etapas a seguir:

      1. Verifique as regras de entrada no Server Manager para garantir que o servidor FTP esteja habilitado.

      2. Adicione o processo host (svchost.exe) para serviços do Windows.

        1. Abra o Control Panel e clique em Windows Defender Firewall. No painel de navegação à esquerda da janela do Windows Defender Firewall, clique em Allow an app or feature through Windows Defender Firewall.

        2. Na janela exibida, clique em Allow another app. Navegue até C:\Windows\System32\svchost.exe e adicione svchost.exe.

        3. A opção Host Process for Windows Services é exibida na seção Allowed apps and features. Selecione Private e Public para a opção e clique em OK.

    O que fazer se a mensagem de erro "530 Login incorrect" aparecer ao conectar-se a um servidor FTP implantado em uma instância Windows ECS?

    Descrição do problema

    Ao conectar-se a um servidor FTP implantado em uma instância Windows ECS, a seguinte mensagem de erro é exibida:

    Response: 331 Please specify the password.
    Command: PASS ************
    Response: 530 Login incorrect.
    Error: Critical error: Could not connect to server

    Causas

    Esse problema pode ocorrer pelos seguintes motivos:

    Soluções

    Use uma das soluções a seguir para resolver o problema com base no cenário real:

    Solução 1: Alterar a senha FTP

    1. Conecte-se à instância Windows ECS.

      Para mais informações, consulte Conectar-se a uma instância Windows usando o Workbench.

    2. Na área de trabalho do Windows, clique com o botão direito em This PC e selecione Manage para abrir a janela Computer Management.

    3. No painel de navegação à esquerda, escolha Local Users and Groups > Users. Clique com o botão direito na conta FTP que você usa e selecione Set Password.

    Solução 2: Conceder permissões à sua conta FTP

    1. Conecte-se à instância Windows ECS.

      Para mais informações, consulte Conectar-se a uma instância Windows usando o Workbench.

    2. Verifique se existe uma pasta para compartilhar arquivos com o site FTP.

      1. Se a pasta não existir, crie-a e conceda as permissões necessárias na pasta à sua conta FTP. Para mais informações, consulte a seção Etapa 3: Definir permissões para a pasta compartilhada do tópico "Criar um site FTP em uma instância Windows".

      2. Se a pasta existir, clique com o botão direito nela, selecione Properties, clique na guia Security, selecione sua conta FTP e conceda as permissões necessárias à conta.

    O que fazer se a mensagem de erro "530 valid hostname is expected" aparecer ao conectar-se a um servidor FTP implantado em uma instância Windows ECS?

    Descrição do problema

    Após configurar um site FTP no IIS 7.5 em uma instância Windows ECS e vincular um nome de domínio ao site FTP, a mensagem de erro 530 valid hostname is expected ou 503 Login with USER first aparece ao conectar-se ao servidor FTP na instância usando um endereço IP ou outros métodos.

    Causa

    O formato do nome de domínio inserido ao conectar-se ao servidor FTP é inválido.

    Solução

    Se o nome de domínio www.example.com estiver vinculado ao site FTP e você usar o nome de usuário user para conexão, use o nome de domínio www.example.com|user para conectar-se ao servidor FTP.

    Nota
    • Separe o nome de domínio vinculado ao site FTP e o nome de usuário com uma barra vertical (|).

    • Você também pode remover as vinculações do site e usar diretamente o nome de usuário para conectar-se ao servidor FTP, conforme mostrado na figura a seguir.

    O que fazer se a mensagem de erro "550 Permission denied" aparecer ao fazer upload de um arquivo para o FileZilla Server usando FTP em uma instância Windows ECS?

    Descrição do problema

    A mensagem de erro 550 Permission denied aparece ao fazer upload de um arquivo para o FileZilla Server usando FTP em uma instância Windows ECS.

    Causa

    A conta FTP não tem as permissões write no FileZilla Server.

    Solução

    1. Conecte-se à instância Windows ECS.

      Para mais informações, consulte Conectar-se a uma instância Windows usando o Workbench.

    2. Execute o FileZilla Server. Na janela Users, selecione Shared folders.

    3. Selecione o usuário e o diretório correspondentes à conta FTP, marque Write e clique em OK para conceder as permissões de escrita ao usuário.

    O que fazer se a mensagem de erro "534 Policy requires SSL" aparecer ao conectar-se a um site FTP implantado em uma instância Windows ECS usando FTP over TLS?

    Descrição do problema

    Não é possível usar FTP over TLS para acessar um site FTP criado pelo IIS em uma instância Windows ECS e a mensagem de erro "534 Policy requires SSL" é exibida.

    Causa

    A mensagem de erro "534 Local policy on server does not allow TLS secure connections" indica que o problema é causado por configurações incorretas de parâmetros em FTP SSL Settings.

    Solução

    1. Conecte-se à instância Windows ECS.

      Para mais informações, consulte Métodos de conexão remota para instâncias ECS.

    2. No canto inferior esquerdo da área de trabalho, escolha 开始图标 > Windows Administrative Tools > Internet Information Services (IIS) Manager.

    3. Na seção FTP da página inicial do FTP, clique em FTP SSL Settings.

    4. Na página FTP SSL Settings, defina SSL Policy como Allow SSL connections. Em seguida, clique em Apply no painel Actions.

    5. Acesse o site FTP.

  • Instâncias Linux

    O que fazer se a mensagem de erro "425 Security:Bad IP connection" aparecer ao fazer upload de um arquivo para um site FTP implantado em uma instância Linux ECS?

    Descrição do problema

    Ao fazer upload de um arquivo para um site FTP implantado em uma instância Linux ECS, a mensagem de erro "425 Security:Bad IP connection" é exibida.

    Causa

    Na maioria dos casos, esse problema ocorre quando o cliente reside em uma rede NAT e está associado a vários endereços IP públicos. Isso causa inconsistências entre os endereços IP de origem das duas conexões mantidas pelo serviço FTP e resulta em erro.

    Nota

    O serviço FTP mantém simultaneamente duas conexões: uma conexão de controle e uma conexão de dados. Por padrão, durante a transmissão de dados, o servidor FTP verifica se os endereços IP de origem das duas conexões são consistentes. Se os endereços IP de origem forem inconsistentes, o servidor FTP relata um erro "425 Security: Bad IP connection".

    Solução

    Execute as etapas a seguir para desabilitar a verificação de segurança de IP para o modo passivo do FTP:

    1. Conecte-se à instância Linux ECS.

      Para mais informações, consulte Fazer login em uma instância Linux usando o Workbench.

    2. Execute o comando a seguir para abrir o arquivo de configuração do FTP:

      vi /etc/vsftpd/vsftpd.conf
    3. Pressione a tecla i para entrar no modo Insert e adicione o seguinte conteúdo ao arquivo:

      pasv_promiscuous=yes
    4. Pressione a tecla Esc para sair do modo Insert. Em seguida, insira :wq e pressione a tecla Enter para salvar e fechar o arquivo.

    5. Execute o comando a seguir para reiniciar o serviço FTP:

      systemctl restart vsftpd

    O que fazer se a mensagem de erro "553 Could not create file" aparecer ao tentar fazer upload de arquivos para uma instância Linux ECS usando VSFTP?

    Descrição do problema

    Não é possível usar o VSFTP para fazer upload de arquivos para uma instância Linux ECS e a mensagem de erro "553 Could not create file" é exibida.

    Causas

    Esse problema pode ocorrer pelos seguintes motivos:

    • O espaço em disco da instância Linux está cheio.

    • As permissões write no diretório home do FTP não foram concedidas.

    Solução

    Execute as etapas a seguir para verificar o uso do espaço em disco da instância Linux e as permissões no diretório home do FTP:

    1. Conecte-se à instância Linux ECS.

      Para mais informações, consulte Fazer login em uma instância Linux usando o Workbench.

    2. Execute o comando a seguir para verificar se o espaço em disco da instância está cheio:

      df -h
      Nota

      Se o uso da partição em um disco atingir 100%, o espaço em disco estará cheio.

      A figura a seguir mostra um exemplo de saída de comando. Na saída de exemplo, o uso da partição /dev/xvda1 é de 59%.

    3. Execute o comando a seguir para verificar se as permissões write no diretório home do FTP foram concedidas.

      Nota

      Especifique o diretório home real do FTP. Neste exemplo, o diretório /home/user é usado como o diretório home do FTP.

      ls -l /home/user

      Se as permissões write no diretório home do FTP não tiverem sido concedidas, w não estará incluído nas configurações de permissão, conforme mostrado no quadro vermelho na figura a seguir.

      1111

    4. Execute o comando a seguir para conceder as permissões write no diretório home do FTP:

      chmod +w /home/user
    5. Execute o comando a seguir para verificar se as permissões de escrita no diretório home do FTP foram concedidas. Se w for exibido na saída do comando, as permissões write no diretório home do FTP foram concedidas.

      ls -l /home/user

Outros

O que fazer se o token da Plataforma de Contas Oficiais do WeChat implantado em uma instância ECS falhar na verificação?

Descrição do problema

O token da Plataforma de Contas Oficiais do WeChat implantado em uma instância ECS falha na verificação.

Causas

Esse problema pode ocorrer pelos seguintes motivos:

  • O arquivo de token foi editado incorretamente, por exemplo, usando o Bloco de Notas ou um editor online. Como resultado, uma assinatura UTF-8 Byte Order Mark (BOM) foi adicionada ao arquivo.

  • O Safe Dog ou Security Center está instalado na instância ECS e bloqueia solicitações do servidor Tencent.

  • A instância ECS usa um nome de domínio temporário para a verificação do token e a solicitação é interceptada pelo sistema Tencent.

  • O arquivo PHP contém uma quebra de linha ou outros caracteres após a tag de fechamento.

  • Outros métodos de verificação de depuração são usados.

  • Ocorre uma exceção durante a criptografia Gzip no seu programa.

Soluções

Execute as operações a seguir para resolver o problema com base na causa:

  • O arquivo de token foi editado incorretamente, por exemplo, usando o Bloco de Notas ou um editor online

    Para remover a assinatura UTF-8 BOM do arquivo de token, recomendamos o uso de um editor multifuncional.

  • O Safe Dog ou Security Center está instalado na instância ECS

    Recomendamos desinstalar o Safe Dog ou adicionar o servidor Tencent à lista de permissões do Security Center.

  • A instância ECS usa um nome de domínio temporário para a verificação do token

    Ao realizar a verificação, recomendamos o uso de um nome de domínio registrado no Alibaba Cloud.

  • O arquivo PHP contém uma quebra de linha ou outros caracteres após a tag de fechamento

    Exclua caracteres extras após a tag de fechamento.

  • Outros métodos de depuração e verificação são usados

    Execute o comando curl http://xxx/index.php/api/xx para realizar depuração e verificação. Simule uma solicitação de API do WeChat e realize a análise.

  • Ocorre uma exceção durante a criptografia Gzip no seu programa

    Recomendamos desabilitar temporariamente o recurso de criptografia Gzip do seu programa e solucionar o problema.

O que fazer se os caracteres chineses em uma instância Linux ECS estiverem ilegíveis?

Descrição do problema

Ao conectar-se a uma instância Linux ECS usando um cliente SSH de terceiros, os caracteres chineses na instância aparecem ilegíveis.

Causas

Esse problema pode ocorrer pelos seguintes motivos:

Soluções

Use uma das soluções a seguir para resolver o problema com base no cenário real:

Solução 1: Instalar um pacote de idiomas chinês na instância Linux ECS

Neste exemplo, é usada uma instância que executa CentOS 7.8. As configurações e comandos podem variar com base no sistema operacional, como versões específicas do CentOS e distribuições como Red Hat, Debian e Ubuntu. Para mais informações, consulte a documentação oficial dos sistemas operacionais.

  1. Conecte-se à instância Linux ECS.

    Para mais informações, consulte Fazer login em uma instância Linux usando o Workbench.

  2. Execute o comando a seguir para consultar o idioma usado pelo sistema operacional:

    echo $LANG
    Nota
  3. Execute o comando a seguir para verificar se um pacote de idiomas chinês está instalado no sistema operacional:

    locale -a | grep "zh_CN"

    A seguinte saída de comando é exibida. zh indica chinês, CN indica China, e gb18030, gb2312, gbk e utf8 são conjuntos de caracteres.

    zh_CN
    zh_CN.gb18030
    zh_CN.gb2312
    zh_CN.gbk
    zh_CN.utf8

    Se um pacote de idiomas chinês não estiver instalado, execute o comando a seguir para instalar o pacote de idiomas:

    sudo yum groupinstall "fonts"
  4. Execute o comando a seguir para abrir o arquivo de configuração /etc/locale.conf:

    vim /etc/locale.conf
    1. Pressione a tecla i para entrar no modo Insert. Em seguida, altere LANG=en_US.UTF-8 para LANG=zh_CN.UTF-8 para mudar o idioma do sistema para chinês.

    2. Pressione a tecla Esc, insira :wq e pressione a tecla Enter para salvar e fechar o arquivo de configuração.

  5. Execute o comando a seguir para aplicar a configuração:

    source /etc/locale.conf
  6. Execute o comando a seguir para reiniciar a instância:

    reboot
  7. (Opcional) Se o idioma do sistema ainda estiver em inglês após a reinicialização da instância, execute o comando a seguir para abrir o arquivo de configuração /etc/profile.d/lang.sh:

    vim /etc/profile.d/lang.sh
    1. Pressione a tecla i para entrar no modo Insert. Altere zh*) LANG=en_US.UTF-8 para zh*) LANG=zh_CN.UTF-8. A figura a seguir mostra o conteúdo modificado.Dingtalk_20210709104253.jpg

    2. Pressione a tecla Esc, insira :wq e pressione a tecla Enter para salvar e fechar o arquivo de configuração.

    3. Execute o comando a seguir para reiniciar a instância:

      reboot

Solução 2: Modificar o conjunto de caracteres da ferramenta cliente SSH de terceiros

A seção a seguir descreve como alterar o conjunto de caracteres do cliente Xshell.

  1. Abra o cliente Xshell.

  2. Na janela do cliente Xshell, defina Default Language como Unicode (UTF-8).

  3. Faça login na instância. Se o problema for resolvido, a mensagem de erro não aparecerá mais.