Todos os produtos
Search
Central de documentação

Data Transmission Service:Criar uma tarefa de change tracking do PolarDB-X 1.0

Última atualização: Aug 26, 2026

Crie uma tarefa de change tracking para capturar alterações de dados em tempo real de uma instância PolarDB-X 1.0 e disponibilizá-las para consumo downstream.

Pré-requisitos

  • Você já criou uma instância PolarDB-X 1.0. Caso contrário, consulte Create a PolarDB-X 1.0 instance e Create a database.

    Nota

    O tipo de armazenamento da instância PolarDB-X 1.0 deve ser ApsaraDB RDS for MySQL (incluindo instâncias personalizadas do ApsaraDB RDS for MySQL e instâncias adquiridas separadamente). O PolarDB for MySQL não é compatível.

  • Você criou uma Virtual Private Cloud (VPC) and a vSwitch para a instância de assinatura de dados.

Limitações

Tipo

Descrição

Limites do banco de dados source

  • As tabelas a serem rastreadas devem ter uma chave primária ou uma restrição única com campos exclusivos. Caso contrário, o DTS poderá rastrear dados duplicados. Tabelas com apenas uma restrição única não oferecem suporte ao rastreamento de atualização de schema. Recomendamos o uso de uma chave primária.

  • Ao assinar dados no nível de tabela, uma única tarefa de assinatura aceita até 500 tabelas. Se esse limite for excedido, a tarefa falhará com um erro após o envio. Nesse caso, recomendamos dividir as tabelas em várias tarefas de assinatura ou configurar uma tarefa de assinatura para todo o banco de dados.

  • Configurações de binary log para as instâncias ApsaraDB RDS for MySQL anexadas a uma instância PolarDB-X 1.0:

    • O binary logging deve estar ativado e o parâmetro binlog_row_image deve estar definido como full. Caso contrário, a pré-verificação reportará um erro e não será possível iniciar a tarefa de change tracking.

    • O DTS exige que o banco de dados source retenha binary logs locais por mais de 24 horas. Caso contrário, o DTS poderá falhar ao obter os binary logs, causando a falha da tarefa. Em casos extremos, pode ocorrer inconsistência ou perda de dados. Problemas causados por retenção insuficiente de logs não são cobertos pelo Service Level Agreement (SLA) do DTS.

  • Se a instância source for somente leitura ou temporária, garanta que ela possua logs de transações.

  • A instância source PolarDB-X 1.0 deve ser da versão 5,2 ou posterior.

Outros limites

  • O DTS depende da continuidade das transações XA na instância source PolarDB-X 1.0 para rastrear alterações de dados. Se a continuidade da transação XA for interrompida (por exemplo, ao modificar objetos rastreados ou durante o failover do módulo de captura de dados incrementais), transações XA não confirmadas poderão ser perdidas.

  • Uma tarefa de change tracking para uma instância PolarDB-X 1.0 é uma tarefa distribuída. Cada instância ApsaraDB RDS for MySQL anexada corresponde a uma subtarefa. É possível visualizar o status de cada subtarefa na página Task Topology.

  • O PolarDB-X 1.0 oferece suporte a sharding de banco de dados e tabelas. Uma operação DDL na instância source PolarDB-X 1.0 é executada em todos os shards de tabela. Como o progresso das subtarefas pode não estar sincronizado, os dados rastreados podem conter operações DDL duplicadas. Se seu cliente consumidor processar essas operações DDL várias vezes, poderão ocorrer exceções de dados. Trate essa situação conforme seus requisitos de negócio.

  • Limites sobre os objetos para change tracking:

    • Não há suporte ao rastreamento de alterações no nível de banco de dados. Apenas alterações no nível de tabela podem ser rastreadas.

    • Após configurar uma tarefa de change tracking, não é possível modificar os objetos rastreados. Para adicionar mais tabelas, crie uma nova tarefa.

  • Se ocorrer um switchover primário/secundário no banco de dados source, a tarefa de change tracking falhará.

  • Durante o change tracking, não realize scale out, scale in, migração de tabelas hotspot, alteração de chaves de sharding ou execução de operações DDL na instância source. Caso contrário, a tarefa poderá falhar ou ocorrerão inconsistências de dados.

  • Se outra tarefa (como uma tarefa de migração de dados) também utilizar o banco de dados source, dados de objetos não selecionados poderão ser rastreados. Nesse caso, filtre manualmente os dados indesejados no seu cliente consumidor.

  • Se uma única linha rastreada exceder 16 MB, seu cliente consumidor não conseguirá consumi-la e poderá ocorrer um erro de falta de memória (OOM).

  • Verifique se a precisão da assinatura para colunas FLOAT ou DOUBLE atende aos seus requisitos de negócio. O DTS lê valores dessas colunas usando a função ROUND(COLUMN,PRECISION). Se você não definir explicitamente uma precisão, o DTS definirá a precisão para colunas FLOAT como 38 dígitos e para colunas DOUBLE como 308 dígitos.

  • O DTS não assina alterações DDL feitas por ferramentas como pt-online-schema-change. Como resultado, o cliente consumidor pode falhar ao gravar dados na tabela de destino devido a inconsistências de schema.

  • Se uma tarefa falhar, a equipe de suporte do DTS tentará restaurá-la dentro de oito horas. Durante a restauração, eles podem reiniciar a tarefa ou ajustar seus parâmetros.

    Nota

    Os ajustes de parâmetros modificam apenas os parâmetros da instância DTS, não os parâmetros do banco de dados.

Procedimento

  1. Utilize um dos métodos a seguir para acessar a página Change Tracking Tasks e selecione a região onde reside a instância de change tracking.

    DTS console

    1. Faça login no DTS console.

    2. No painel de navegação à esquerda, clique em Change Tracking.

    3. No canto superior esquerdo da página, selecione a região onde reside a instância de change tracking.

    DMS console

    Nota

    As operações reais podem variar dependendo do modo e do layout do DMS console. Para mais informações, consulte Simple mode console e Customize DMS console layout and style.

    1. Faça login no DMS console.

    2. Na barra de navegação superior, passe o ponteiro sobre Data + AI > DTS (DTS) > Change Tracking.

    3. Na lista suspensa à direita de Change Tracking Tasks, selecione a região onde reside a instância de change tracking.

  2. Clique em Create Task para acessar a página de configuração da tarefa.

  3. Configure os parâmetros nas seções Source Database e Consumer Network Type.

    Aviso

    Após especificar a instância do banco de dados source, recomendamos ler os Limits exibidos na parte superior da página. Caso contrário, a tarefa poderá falhar ou os dados rastreados não poderão ser consumidos.

    Seção

    Parâmetro

    Descrição

    N/A

    Task Name

    Nome da tarefa de change tracking. O DTS atribui automaticamente um nome à tarefa. Recomendamos especificar um nome descritivo que facilite a identificação da tarefa. Não é necessário usar um nome exclusivo.

    Source Database

    Select Existing Connection

    • Para usar uma instância de banco de dados que já está Manage database connections(recém-criada ou salva), selecione-a na lista suspensa. O sistema configura automaticamente as informações do banco de dados abaixo.

      Nota

      No DMS console, este parâmetro é denominado Select a DMS database instance.

    • Se sua instância não estiver listada ou se você não quiser usar uma conexão salva, insira manualmente as seguintes informações do banco de dados.

    Database Type

    Selecione PolarDB-X 1.0.

    Access Method

    Este parâmetro é fixo como Alibaba Cloud Instance.

    Instance Region

    Selecione a região onde a instância PolarDB-X 1.0 está localizada.

    Replicate Data Across Alibaba Cloud Accounts

    Para este tutorial, selecione No.

    Importante

    Se precisar acessar recursos do banco de dados source entre contas (selecionando Yes), configure a autorização RAM para a conta Alibaba Cloud usada para criar a tarefa DTS. Também será necessário inserir a Alibaba Cloud Account e o RAM Role Name. Para instruções, consulte Configure RAM authorization for cross-account tasks.

    Instance ID

    Selecione o ID da instância PolarDB-X 1.0.

    Database Account

    Insira a conta do banco de dados para a instância PolarDB-X 1.0. A conta deve ter permissões de leitura nos objetos que você deseja rastrear.

    Database Password

    Senha usada para acessar a instância do banco de dados.

    Consumer Network Type

    Network Type

    O valor do parâmetro Network Type é fixo como VPC. Selecione uma VPC e um vSwitch. Para mais informações, consulte VPCs.

    Nota
    • Após configurar uma tarefa de change tracking, não é possível alterar as configurações na seção Consumer Network Type.

    • Se seu cliente de change tracking estiver implantado em uma VPC, recomendamos selecionar a mesma VPC e o mesmo vSwitch conectados ao cliente.

    • Ao rastrear alterações de dados em redes internas, a latência de rede é mínima.

  4. Na parte inferior da página, clique em Test Connectivity and Proceed.

    Nota

    Certifique-se de que os blocos CIDR dos servidores DTS possam ser adicionados automática ou manualmente às configurações de segurança dos bancos de dados source e de destino para permitir o acesso dos servidores DTS. Para mais informações, consulte Whitelist DTS server IP addresses.

  5. Configure os objetos para change tracking.

    1. Na página Configure Objects, configure os objetos para change tracking.

      Parâmetro

      Descrição

      Data Change Types

      Os Data Change Types são selecionados por padrão e não podem ser modificados.

      • Data Update

        O DTS rastreia atualizações de dados dos objetos selecionados, incluindo as operações INSERT, DELETE e UPDATE.

      • Schema Update

        O DTS rastreia as operações de criação, exclusão e modificação realizadas em todos os schemas de objetos da instância source. Use o cliente de change tracking para filtrar os dados a serem rastreados.

      Source Objects

      Na lista Source Objects, selecione os objetos que deseja rastrear e clique no ícone 向右小箭头 para movê-los para a lista Selected Objects.

      Nota
      • Não há suporte ao rastreamento de alterações no nível de banco de dados. Apenas alterações no nível de tabela podem ser rastreadas.

      • Após configurar uma tarefa de change tracking, não é possível modificar os objetos rastreados. Para adicionar mais tabelas, crie uma nova tarefa.

    2. Clique em Next: Advanced Settings para configurar as definições avançadas.

      Parâmetro

      Descrição

      Dedicated Cluster for Task Scheduling

      Por padrão, o DTS agenda a tarefa para um cluster compartilhado. Não é necessário configurar este parâmetro. É possível adquirir clusters dedicados com especificações definidas para executar tarefas de change tracking do DTS. Para mais informações, consulte What is a DTS dedicated cluster?.

      Retry Time for Failed Connections

      Intervalo de tempo para nova tentativa de conexões com falha. Se a tarefa de change tracking falhar, o DTS tentará reconectar imediatamente dentro desse intervalo. Valores válidos: 10 a 1440. Unidade: minutos. Valor padrão: 720. Recomendamos definir o parâmetro com um valor superior a 30. Se o DTS for reconectado à instância do banco de dados source dentro do intervalo especificado, a tarefa de change tracking será retomada. Caso contrário, a tarefa falhará.

      Nota
      • Se várias tarefas de change tracking estiverem configuradas para uma instância de banco de dados, o menor intervalo de tempo de nova tentativa terá precedência. Por exemplo, se a Tarefa A e a Tarefa B estiverem configuradas para a mesma instância, com intervalos de 30 e 60 minutos respectivamente, o intervalo de 30 minutos prevalecerá.

      • Quando o DTS tenta uma nova conexão, taxas são cobradas. Recomendamos especificar o intervalo de nova tentativa conforme seus requisitos de negócio ou liberar a instância DTS o mais rápido possível após a liberação da instância do banco de dados source.

      Retry Time for Other Issues

      Intervalo de tempo para nova tentativa devido a outros problemas. Por exemplo, se operações DDL ou DML falharem após o início da tarefa de change tracking, o DTS tentará repetir as operações imediatamente dentro deste intervalo. Valores válidos: 1 a 1440. Unidade: minutos. Valor padrão: 10. Recomendamos definir o parâmetro com um valor superior a 10. Se as operações com falha forem executadas com sucesso dentro do intervalo especificado, o DTS retomará a tarefa de change tracking. Caso contrário, a tarefa falhará.

      Importante

      O valor do parâmetro Retry Time for Other Issues deve ser menor que o valor do parâmetro Retry Time for Failed Connections.

      Environment Tag

      Selecione uma tag de ambiente para identificar a instância conforme suas necessidades de negócio. Isso não é obrigatório neste exemplo.

      Monitoring and Alerting

      Define se o alerta para a tarefa de change tracking será ativado. Se o alerta estiver configurado e a tarefa falhar ou a latência exceder o limiar, notificações de alerta serão enviadas. Valores válidos:

      • No: não ativa alertas.

      • Yes: ativa alertas. Neste caso, também é necessário configurar o limiar de alerta e as configurações de notificação de alerta. Para mais informações, consulte Configure alerts during instance configuration.

  6. Na parte inferior da página, clique em Next: Save Task Settings and Precheck.

    • Para visualizar os parâmetros a serem especificados ao chamar a operação de API relevante para configurar a tarefa DTS, passe o ponteiro sobre Next: Save Task Settings and Precheck e clique em Preview OpenAPI parameters.

    • Se não precisar visualizar os parâmetros ou já os tiver visualizado, clique em Next: Save Task Settings and Precheck na parte inferior da página.

    Nota
    • Antes de iniciar a tarefa de change tracking, o DTS realiza uma pré-verificação. Só é possível iniciar a tarefa após ela passar nessa pré-verificação.

    • Se a tarefa não passar na pré-verificação, clique em View Details ao lado de cada item com falha. Após solucionar os problemas com base na mensagem de erro, execute a pré-verificação novamente.

    • Se um alerta for gerado para um item durante a pré-verificação, realize as seguintes operações conforme o cenário:

      • Se um item de alerta não puder ser ignorado, clique em View Details ao lado do item com falha e solucione os problemas. Em seguida, execute a pré-verificação novamente.

      • Se o item de alerta puder ser ignorado, clique em Confirm Alert Details. Na caixa de diálogo View Details, clique em Ignore. Na mensagem exibida, clique em OK. Depois, clique em Precheck Again para executar a pré-verificação novamente. Ignorar o item de alerta pode causar inconsistência de dados e expor seu negócio a riscos potenciais.

  7. Adquira a instância.

    1. Aguarde até que Success Rate se torne 100%. Em seguida, clique em Next: Purchase Instance.

    2. Na página Purchase, especifique o método de faturamento da instância de change tracking. A tabela a seguir descreve os parâmetros.

      Parâmetro

      Descrição

      Método de faturamento

      • Assinatura: O pagamento é feito no momento da criação da instância. O método de faturamento por assinatura é mais econômico que o pagamento conforme o uso para utilização de longo prazo. Descontos maiores são oferecidos para durações de assinatura mais longas.

      • Pagamento conforme o uso: Uma instância com pagamento conforme o uso é faturada por hora. Recomendamos selecionar este método para uso de curto prazo. Se não precisar mais da instância, libere-a para reduzir custos.

      Resource Group Settings

      Grupo de recursos ao qual a instância pertence. Valor padrão: default resource group. Para mais informações, consulte What is resource management?

      Subscription Duration

      Se selecionar o método de faturamento por assinatura, defina a duração da assinatura e o número de instâncias a serem criadas. A duração pode ser de um a nove meses, um ano, dois anos, três anos ou cinco anos.

      Nota

      Este parâmetro está disponível apenas se você selecionar o método de faturamento por Subscription.

    3. Leia e selecione os Data Transmission Service (Pay-as-you-go) Service Terms.

    4. Clique em Buy and Start para iniciar a tarefa de change tracking. É possível acompanhar o progresso da tarefa na lista de tarefas.

Próximos passos

Após o início da execução da tarefa de change tracking, crie grupos de consumidores e escolha um método de consumo adequado ao seu cliente downstream.

  1. Para informações sobre como criar e gerenciar grupos de consumidores, consulte Create consumer groups.

  2. Escolha um método para consumir os dados rastreados com base no tipo do seu cliente: