Todos os produtos
Search
Central de documentação

Data Transmission Service:Criar uma assinatura de banco de dados lógico do DMS

Última atualização: Aug 26, 2026

Este tópico descreve como criar uma tarefa de assinatura de dados para um banco de dados lógico no Data Management (DMS).

Pré-requisitos

Um banco de dados lógico deve estar configurado no DMS. Para mais informações, consulte Logical databases.

Nota

Um banco de dados lógico do DMS deve ser composto por shards de banco de dados de vários clusters do PolarDB for MySQL.

Limitações

Tipo

Descrição

Limites do banco de dados de origem

  • As tabelas assinadas devem ter uma chave primária ou uma restrição única, e os campos da restrição devem ser exclusivos. Caso contrário, você poderá receber dados duplicados.

  • Ao assinar dados no nível de tabela, uma única tarefa de assinatura suporta até 500 tabelas. Se esse limite for excedido, a tarefa falhará com um erro após o envio. Nesse caso, recomendamos dividir as tabelas em várias tarefas de assinatura ou configurar uma tarefa de assinatura para todo o banco de dados.

  • Log binário

    • Ative o log binário e defina o parâmetro binlog_row_image como full para todas as instâncias filho do banco de dados lógico do DMS.

    • O Data Transmission Service (DTS) exige que o banco de dados de origem retenha seu log binário local por mais de 24 horas. Um período de retenção menor pode causar falha na tarefa e, em casos extremos, levar à inconsistência ou perda de dados. O Acordo de Nível de Serviço (SLA) do DTS não cobre problemas causados pelo não cumprimento desse requisito.

Outros limites

  • Verifique se a precisão da assinatura para colunas FLOAT e DOUBLE atende aos seus requisitos. O DTS lê valores dessas colunas usando ROUND(COLUMN,PRECISION). Se você não definir explicitamente uma precisão, o DTS usará uma precisão de 38 dígitos para colunas FLOAT e 308 dígitos para colunas DOUBLE.

  • Alterações de DDL online feitas com ferramentas como pt-online-schema-change não são capturadas pela assinatura. Isso pode causar falhas de gravação no lado do cliente se o esquema da tabela ficar inconsistente com os dados consumidos.

  • Linhas de dados maiores que 16 MB não podem ser consumidas e podem causar um erro de falta de memória (OOM) no cliente consumidor.

  • Você criou uma Virtual Private Cloud (VPC) and a vSwitch para a instância de assinatura de dados.

  • Se uma tarefa falhar, a equipe de suporte do DTS tentará restaurá-la dentro de oito horas. Durante a restauração, eles podem reiniciar a tarefa ou ajustar seus parâmetros.

    Nota

    Os ajustes de parâmetros modificam apenas os parâmetros da instância do DTS, não os parâmetros do banco de dados.

Procedimento

  1. Use um dos métodos a seguir para acessar a página Change Tracking Tasks e selecione a região onde a instância de rastreamento de alterações está localizada.

    Console do DTS

    1. Faça login no console do DTS.

    2. No painel de navegação à esquerda, clique em Change Tracking.

    3. No canto superior esquerdo da página, selecione a região onde a instância de rastreamento de alterações está localizada.

    Console do DMS

    Nota

    As operações reais podem variar dependendo do modo e do layout do console do DMS. Para mais informações, consulte Simple mode console e Customize DMS console layout and style.

    1. Faça login no console do DMS.

    2. Na barra de navegação superior, passe o ponteiro sobre Data + AI > DTS (DTS) > Change Tracking.

    3. Na lista suspensa à direita de Change Tracking Tasks, selecione a região onde a instância de rastreamento de alterações está localizada.

  2. Clique em Create Task para acessar a página de configuração da tarefa.

  3. Configure os parâmetros nas seções Source Database e Consumer Network Type.

    Aviso

    Após especificar a instância do banco de dados de origem, recomendamos ler as Limits exibidas na parte superior da página. Caso contrário, a tarefa poderá falhar ou os dados rastreados não poderão ser consumidos.

    Tipo

    Parâmetro

    Descrição

    N/A

    Task Name

    Nome da tarefa de rastreamento de alterações. O DTS atribui automaticamente um nome à tarefa. Recomendamos especificar um nome descritivo que facilite a identificação da tarefa. Não é necessário usar um nome exclusivo.

    Source Database

    Select Existing Connection

    Selecione um modelo de conexão existente, se disponível. O DTS preenche os parâmetros restantes automaticamente. Para usar uma nova conexão, deixe este campo em branco e preencha os parâmetros abaixo.

    Database Type

    Selecione DMS LogicDB.

    Access Method

    Selecione Alibaba Cloud Instance.

    Instance Region

    Selecione a região onde o banco de dados lógico do DMS está localizado.

    DMS LogicDB

    Selecione o nome do banco de dados lógico do DMS.

    Database Account

    Todos os shards de banco de dados físico no banco de dados lógico do DMS devem residir em clusters do PolarDB for MySQL e compartilhar a mesma conta e senha de banco de dados. Essa conta requer permissões de leitura para cada shard de banco de dados físico. Para obter informações sobre como criar e autorizar uma conta, consulte Create and manage database accounts.

    Database Password

    Senha usada para acessar a instância do banco de dados.

    Consumer Network Type

    Network Type

    O valor do parâmetro Network Type é fixo como VPC. Selecione uma VPC e um vSwitch. Para mais informações, consulte VPCs.

    Nota
    • Após configurar uma tarefa de rastreamento de alterações, não é possível alterar as configurações na seção Consumer Network Type.

    • Se o seu cliente de rastreamento de alterações estiver implantado em uma VPC, recomendamos selecionar a mesma VPC e o mesmo vSwitch conectados ao cliente.

    • Ao rastrear alterações de dados em redes internas, a latência de rede é mínima.

  4. Na parte inferior da página, clique em Test Connectivity and Proceed.

    Nota

    Certifique-se de que os blocos CIDR dos servidores do DTS possam ser adicionados automática ou manualmente às configurações de segurança dos bancos de dados de origem e destino para permitir o acesso dos servidores do DTS. Para mais informações, consulte Whitelist DTS server IP addresses.

  5. Configure os objetos para rastreamento de alterações.

    1. Na página Configure Objects, configure os objetos para rastreamento de alterações.

      Parâmetro

      Descrição

      Data Change Types

      Data Change Types vem selecionado por padrão e não pode ser modificado.

      • Data Update

        O DTS rastreia atualizações de dados dos objetos selecionados, incluindo as operações INSERT, DELETE e UPDATE.

      • Schema Update

        O DTS rastreia as operações de criação, exclusão e modificação realizadas em todos os esquemas de objeto da instância de origem. Use o cliente de rastreamento de alterações para filtrar os dados a serem rastreados.

      Source Objects

      Selecione um ou mais objetos na seção Source Objects e clique no ícone Right arrow para adicionar os objetos à seção Selected Objects.

      Nota

      É possível selecionar tabelas ou bancos de dados como objetos para rastreamento de alterações.

      • Ao selecionar um banco de dados como objeto, o DTS rastreia dados incrementais de todos os objetos, incluindo novos objetos no banco de dados.

      • Ao selecionar uma tabela como objeto, o DTS rastreia apenas dados incrementais dessa tabela. Nesse caso, para rastrear alterações de dados de outra tabela, adicione-a à lista de objetos. Para mais informações, consulte Modify the objects for change tracking.

    2. Clique em Next: Advanced Settings para definir as configurações avançadas.

      Parâmetro

      Descrição

      Dedicated Cluster for Task Scheduling

      Por padrão, o DTS agenda a tarefa em um cluster compartilhado. Não é necessário configurar este parâmetro. É possível adquirir clusters dedicados com especificações definidas para executar tarefas de rastreamento de alterações do DTS. Para mais informações, consulte What is a DTS dedicated cluster?.

      Retry Time for Failed Connections

      Intervalo de tempo para novas tentativas de conexões com falha. Se a tarefa de rastreamento de alterações falhar, o DTS tenta reconectar imediatamente dentro desse intervalo. Valores válidos: 10 a 1440. Unidade: minutos. Valor padrão: 720. Recomendamos definir o parâmetro com um valor maior que 30. Se o DTS for reconectado à instância do banco de dados de origem dentro do intervalo especificado, a tarefa de rastreamento de alterações será retomada. Caso contrário, a tarefa falhará.

      Nota
      • Se várias tarefas de rastreamento de alterações estiverem configuradas para uma instância de banco de dados, o menor intervalo de nova tentativa terá precedência. Por exemplo, se a Tarefa A e a Tarefa B estiverem configuradas para a mesma instância, com intervalos de 30 e 60 minutos respectivamente, o intervalo de 30 minutos prevalecerá.

      • Durante as novas tentativas de conexão do DTS, taxas são cobradas. Recomendamos especificar o intervalo de nova tentativa com base nos requisitos do seu negócio ou liberar a instância do DTS assim que possível após a liberação da instância do banco de dados de origem.

      Retry Time for Other Issues

      Intervalo de tempo para novas tentativas devido a outros problemas. Por exemplo, se operações DDL ou DML falharem após o início da tarefa de rastreamento de alterações, o DTS tentará executá-las novamente imediatamente dentro desse intervalo. Valores válidos: 1 a 1440. Unidade: minutos. Valor padrão: 10. Recomendamos definir o parâmetro com um valor maior que 10. Se as operações com falha forem executadas com êxito dentro do intervalo especificado, o DTS retomará a tarefa de rastreamento de alterações. Caso contrário, a tarefa falhará.

      Importante

      O valor do parâmetro Retry Time for Other Issues deve ser menor que o valor do parâmetro Retry Time for Failed Connections.

      Environment Tag

      Selecione uma tag de ambiente para identificar a instância. Este parâmetro é opcional.

      Monitoring and Alerting

      Define se o alerta deve ser ativado para a tarefa de rastreamento de alterações. Se o alerta estiver configurado e a tarefa falhar ou a latência exceder o limiar, notificações de alerta serão enviadas. Valores válidos:

      • No: não ativa alertas.

      • Yes: ativa alertas. Nesse caso, também é necessário configurar o limiar de alerta e configurações de notificação de alerta. Para mais informações, consulte Configure alerts during instance configuration.

  6. Na parte inferior da página, clique em Next: Save Task Settings and Precheck.

    • Para visualizar os parâmetros necessários ao chamar a operação de API relevante para configurar a tarefa do DTS, passe o ponteiro sobre Next: Save Task Settings and Precheck e clique em Preview OpenAPI parameters.

    • Se não precisar visualizar os parâmetros ou já os tiver visualizado, clique em Next: Save Task Settings and Precheck na parte inferior da página.

    Nota
    • Antes de iniciar a tarefa de rastreamento de alterações, o DTS executa uma pré-verificação. Só é possível iniciar a tarefa após ela ser aprovada na pré-verificação.

    • Se a tarefa não passar na pré-verificação, clique em View Details ao lado de cada item com falha. Após solucionar os problemas com base na mensagem de erro, execute a pré-verificação novamente.

    • Se um alerta for gerado para um item durante a pré-verificação, proceda conforme o cenário:

      • Se um item de alerta não puder ser ignorado, clique em View Details ao lado do item com falha e solucione os problemas. Em seguida, execute a pré-verificação novamente.

      • Se o item de alerta puder ser ignorado, clique em Confirm Alert Details. Na caixa de diálogo View Details, clique em Ignore. Na mensagem exibida, clique em OK. Depois, clique em Precheck Again para executar a pré-verificação novamente. Ignorar o item de alerta pode causar inconsistência de dados e expor seu negócio a riscos potenciais.

  7. Adquira a instância.

    1. Aguarde até que Success Rate se torne 100%. Em seguida, clique em Next: Purchase Instance.

    2. Na página Purchase, especifique o método de faturamento da instância de rastreamento de alterações. A tabela a seguir descreve os parâmetros.

      Parâmetro

      Descrição

      Método de faturamento

      • Assinatura: O pagamento é feito no momento da criação da instância. O método de faturamento por assinatura é mais econômico que o pagamento conforme o uso para utilização de longo prazo. Descontos maiores são oferecidos para durações de assinatura mais longas.

      • Pagamento conforme o uso: A instância é faturada por hora. Recomendamos o método de pagamento conforme o uso para utilização de curto prazo. Se a instância não for mais necessária, libere-a para reduzir custos.

      Resource Group Settings

      Grupo de recursos ao qual a instância pertence. Valor padrão: default resource group. Para mais informações, consulte What is resource management?

      Subscription Duration

      Se selecionar o método de faturamento por assinatura, defina a duração da assinatura e o número de instâncias a serem criadas. A duração pode ser de um a nove meses, um ano, dois anos, três anos ou cinco anos.

      Nota

      Este parâmetro está disponível apenas se você selecionar o método de faturamento por Subscription.

    3. Leia e selecione os Data Transmission Service (Pay-as-you-go) Service Terms.

    4. Clique em Buy and Start para iniciar a tarefa de rastreamento de alterações. Acompanhe o progresso da tarefa na lista de tarefas.

Próximas etapas

Após o início da execução da tarefa de rastreamento de alterações, crie grupos de consumidores e escolha um método de consumo adequado ao seu cliente downstream.

  1. Para obter informações sobre como criar e gerenciar grupos de consumidores, consulte Create consumer groups.

  2. Escolha um método para consumir dados rastreados com base no tipo de cliente: