Todos os produtos
Search
Central de documentação

Data Transmission Service:Migrar do RDS SQL Server para o AnalyticDB for MySQL 3.0

Última atualização: Jul 20, 2026

Migre dados do SQL Server (incluindo ApsaraDB RDS for SQL Server e SQL Server autogerenciado) para o AnalyticDB for MySQL 3.0 para análise de dados em tempo real.

3.0

Bancos de dados de origem suportados

É possível migrar os seguintes bancos de dados de origem SQL Server para o AnalyticDB for MySQL. Este tópico usa uma instância RDS for SQL Server como exemplo. O processo para outras origens é semelhante.

  • Instâncias RDS for SQL Server.

  • Bancos de dados autogerenciados:

    • Banco de dados autogerenciado com endereço IP público

    • Banco de dados autogerenciado hospedado no Elastic Compute Service (ECS)

    • Banco de dados autogerenciado conectado via Express Connect, VPN Gateway ou Smart Access Gateway

    • Banco de dados autogerenciado conectado via Database Gateway

Pré-requisitos

  • Configure esta tarefa de migração apenas no novo console.

  • Crie uma instância de origem RDS SQL Server. Para obter a lista de versões suportadas, consulte Overview of migration solutions. Para criar uma instância, consulte Create an ApsaraDB RDS for SQL Server instance.

    Importante

    Se a instância RDS SQL Server executar o SQL Server 2008 ou SQL Server 2008 R2, a migração incremental de dados não é suportada.

  • Crie um cluster de destino AnalyticDB for MySQL. Para obter instruções, consulte Create a cluster.

  • A capacidade de armazenamento do cluster de destino AnalyticDB for MySQL deve ser maior que a da instância de origem RDS SQL Server.

  • Caso a instância de origem atenda a qualquer uma das condições a seguir, divida-a em várias tarefas de migração.

    • A instância de origem possui mais de 10 bancos de dados.

    • Backups de log são executados mais de uma vez por hora para um único banco de dados.

    • Mais de 100 operações de Data Definition Language (DDL) são executadas por hora em um único banco de dados.

    • A taxa de geração de log para um único banco de dados excede 20 MB/s.

    • É necessário ativar o change data capture (CDC) em mais de 1.000 tabelas.

Observações

Nota
  • Durante a migração de esquema, o DTS não migra chaves estrangeiras do banco de dados de origem para o banco de dados de destino.

  • Nas fases de migração total e incremental de dados, o DTS desativa temporariamente as verificações de restrições e as operações em cascata de chaves estrangeiras no nível da sessão. Se ocorrerem operações de atualização ou exclusão em cascata no banco de dados de origem enquanto a tarefa estiver em execução, poderá haver inconsistência de dados.

  • O DTS não suporta a migração de views materializadas para a instância de destino AnalyticDB for MySQL durante a migração de esquema. Para utilizar views materializadas, crie-as manualmente na instância de destino após a conclusão da migração.

Tipo

Descrição

Limites do banco de dados de origem

  • O servidor do banco de dados de origem deve ter largura de banda de saída suficiente. Largura de banda insuficiente reduz a velocidade da migração de dados.

  • As tabelas a serem migradas devem ter uma chave primária ou restrição única, e as colunas nessa chave ou restrição devem ser únicas. Caso contrário, pode ocorrer duplicação de dados no banco de dados de destino.

  • Ao selecionar tabelas específicas para migração e precisar editá-las (por exemplo, mapear nomes de tabelas ou colunas), uma única tarefa de migração pode migrar no máximo 1.000 tabelas. Se você ultrapassar esse limite, a tarefa falhará ao ser enviada. Divida as tabelas em várias tarefas ou configure uma tarefa para migrar o banco de dados inteiro.

  • Uma única tarefa de migração suporta no máximo 10 bancos de dados. Exceder esse limite pode causar problemas de estabilidade e desempenho. Divida a migração em várias tarefas, se necessário.

  • Se você configurar uma tarefa para migrar objetos específicos em vez de um banco de dados inteiro, não será possível migrar objetos que tenham o mesmo nome de tabela, mas nomes de esquema diferentes, para o mesmo banco de dados de destino dentro de uma única tarefa.

  • Para realizar migração incremental de dados, os logs de transação devem atender aos seguintes requisitos:

    • O registro de transações deve estar ativado, o modo de backup deve estar definido como Full e um backup físico completo deve ter sido executado com êxito.

    • Para migração apenas incremental, o Data Transmission Service (DTS) exige a retenção dos logs de transação do banco de dados de origem por mais de 24 horas. Se a tarefa incluir migração total e incremental, mantenha os logs por pelo menos sete dias. Após a conclusão da migração total, reduza o período de retenção para mais de 24 horas. Caso contrário, a tarefa do DTS poderá falhar devido à indisponibilidade dos logs de transação. Em casos extremos, pode ocorrer inconsistência ou perda de dados. Problemas causados por retenção insuficiente de logs não são cobertos pelo Service Level Agreement (SLA) do DTS.

  • Se você ativar o CDC (change data capture) para as tabelas de origem a serem migradas, elas devem atender às seguintes condições. Caso contrário, a pré-verificação falhará.

    • O valor do campo srvname na view sys.sysservers deve ser igual ao valor retornado pela função SERVERPROPERTY.

    • Se o banco de dados de origem for um SQL Server autogerenciado, o proprietário do banco de dados deve ser sa. Se for uma instância ApsaraDB RDS for SQL Server, o proprietário deve ser sqlsa.

    • Para bancos de dados Enterprise Edition, a versão deve ser SQL Server 2008 ou posterior.

    • Para bancos de dados Standard Edition, a versão deve ser SQL Server 2016 SP1 ou posterior.

    • Se o banco de dados de origem for SQL Server 2017 (Standard ou Enterprise Edition), atualize-o para uma versão mais recente.

  • O DTS utiliza a função fn_log para obter logs do banco de dados de origem. Essa função apresenta gargalos de desempenho, portanto não limpe os logs do banco de dados de origem prematuramente. Caso contrário, a tarefa do DTS poderá falhar.

  • Limites sobre operações no banco de dados de origem:

    • Durante as fases de migração de esquema e migração total de dados, não execute operações DDL que alterem a estrutura do banco de dados ou da tabela. Caso contrário, a tarefa de migração de dados falhará.

    • Se você executar apenas a migração total de dados, não grave novos dados na instância de origem. Caso contrário, os dados nos bancos de origem e destino ficarão inconsistentes. Para garantir consistência de dados em tempo real, selecione Migração de Esquema, Migração Total de Dados e Migração Incremental de Dados.

  • Se o banco de dados de origem for uma instância somente leitura, o DTS não migrará operações DDL.

  • Se o banco de dados de origem for um Azure SQL Database, uma instância de migração poderá migrar apenas um banco de dados.

  • Se o banco de dados de origem for uma instância ApsaraDB RDS for SQL Server e a tarefa de migração incluir migração incremental de dados, garanta que a Transparent Data Encryption (TDE) esteja desativada para garantir a estabilidade da tarefa. Para mais informações, consulte Disable TDE.

  • Se você usar o comando sp_rename para renomear objetos, como procedimentos armazenados, antes da execução da tarefa de migração de esquema, a tarefa poderá não funcionar conforme esperado ou falhar.

    Nota

    Utilize o comando ALTER para renomear objetos de banco de dados.

  • No modo de análise híbrida baseada em logs, o banco de dados de origem não suporta operações consecutivas de adição ou remoção de colunas com intervalo inferior a 10 minutos. Por exemplo, se você executar as instruções SQL a seguir consecutivamente, a tarefa falhará.

    ALTER TABLE test_table DROP COLUMN Flag;
    ALTER TABLE test_table ADD Remark nvarchar(50) not null default('');
  • Se o banco de dados de origem for uma instância ApsaraDB RDS for SQL Server executando a edição Web, defina o SQL Server Incremental Synchronization Mode como Incremental Synchronization Based on Logs of Source Database (Heap tables are not supported) ao configurar a tarefa.

  • Durante a migração total de dados, ative o parâmetro READ_COMMITTED_SNAPSHOT no banco de dados de origem para evitar que a contenção de bloqueios compartilhados afete a gravação de dados. Caso contrário, pode ocorrer inconsistência de dados ou falha na tarefa. Problemas causados pela não ativação desse parâmetro não são cobertos pelo SLA do DTS.

Outros limites

  • A migração é suportada apenas para tipos de dados básicos, mas não para dados dos tipos CURSOR, ROWVERSION, SQL_VARIANT, HIERARCHYID, POLYGON, GEOMETRY ou GEOGRAPHY, nem para tipos definidos pelo usuário criados com o comando CREATE TYPE.

  • Se uma instrução DDL falhar ao ser gravada no banco de dados de destino, a tarefa do DTS continuará em execução. Verifique os logs da tarefa para encontrar a instrução DDL com falha. Para saber como visualizar os logs da tarefa, consulte View task logs.

  • O banco de dados de destino deve ter uma chave primária personalizada. Ou, na etapa Configurations for Databases, Tables, and Columns, defina a Primary Key Column. Caso contrário, a migração poderá falhar.

  • Se você definir Configure Objects como SQL Server Incremental Synchronization Mode na etapa Incremental Synchronization Based on Logs of Source Database (Heap tables are not supported), as tabelas a serem migradas devem ter um índice clusterizado que inclua a coluna de chave primária. O DTS não suporta a migração de tabelas heap, tabelas sem chaves primárias, tabelas compactadas, tabelas com colunas computadas ou tabelas com colunas esparsas neste modo. Essas limitações não se aplicam no modo de análise híbrida baseada em logs.

  • Se você definir Configure Objects como SQL Server Incremental Synchronization Mode na etapa Log-based Parsing for Non-heap Tables and CDC-based Incremental Synchronization for Heap Tables (Hybrid Log-based Parsing), os seguintes limites também se aplicam:

    • O DTS depende do componente CDC para migração incremental. Garanta que o job de CDC no banco de dados de origem esteja funcionando conforme esperado. Caso contrário, a tarefa do DTS falhará.

    • Por padrão, o componente CDC armazena dados incrementais por três dias. Ajuste o período de retenção executando o comando exec console.sys.sp_cdc_change_job @job_type = 'cleanup', @retention= <time>;.

      Nota
      • <time> especifica o período de retenção em minutos.

      • Se a média diária de alterações SQL incrementais para uma única tabela exceder 10 milhões, defina <time> como 1440.

    • Em uma única tarefa de migração, ative o CDC para no máximo 1.000 tabelas. Caso contrário, a tarefa poderá apresentar alta latência ou tornar-se instável.

    • O módulo de pré-verificação de uma tarefa de migração incremental de dados do DTS ativa o CDC no banco de dados de origem. Durante esse processo, as limitações internas do mecanismo do SQL Server podem causar bloqueio temporário de tabelas no banco de dados de origem.

  • Se você definir Configure Objects como SQL Server Incremental Synchronization Mode na etapa Polling and querying CDC instances for incremental synchronization, os seguintes limites também se aplicam:

    • A conta do banco de dados de origem usada pela instância do DTS deve ter permissões para ativar o CDC. Uma conta com a função sysadmin é necessária para ativar o CDC no nível do banco de dados. Uma conta privilegiada é necessária para ativar o CDC no nível da tabela.

      Nota
      • A conta com mais privilégios (administrador do servidor) fornecida pelo console do Azure SQL Database atende aos requisitos. Para bancos de dados adquiridos com base no modelo vCore, o CDC pode ser ativado para todas as especificações. Para bancos de dados adquiridos com base no modelo DTU, o CDC só pode ser ativado para camadas de service S3 ou superior.

      • A conta privilegiada de uma instância Amazon RDS for SQL Server atende aos requisitos e suporta a ativação de CDC no nível do banco de dados via procedimentos armazenados.

      • Não é possível ativar o CDC para tabelas que possuem um índice columnstore clusterizado.

      • O módulo de pré-verificação de uma tarefa de migração incremental de dados do DTS ativa o CDC no banco de dados de origem. Durante esse processo, as limitações internas do mecanismo do SQL Server podem causar bloqueio temporário de tabelas no banco de dados de origem.

    • O DTS obtém dados incrementais consultando periodicamente a instância de CDC de cada tabela no banco de dados de origem. Migre no máximo 1.000 tabelas do banco de dados de origem. Caso contrário, a tarefa poderá apresentar alta latência ou tornar-se instável.

    • Por padrão, o componente CDC armazena dados incrementais por três dias. Ajuste o período de retenção executando o comando exec console.sys.sp_cdc_change_job @job_type = 'cleanup', @retention= <time>;.

      Nota
      • <time> especifica o período de retenção em minutos.

      • Se a média diária de alterações SQL incrementais para uma única tabela exceder 10 milhões, defina <time> como 1440.

    • Operações consecutivas de adição ou remoção de colunas não são suportadas (mais de duas operações DDL ADD COLUMN ou DROP COLUMN em um minuto). Caso contrário, a tarefa poderá falhar.

    • Não modifique as instâncias de CDC do banco de dados de origem. Caso contrário, a tarefa de migração de dados poderá falhar ou ocorrer perda de dados.

  • Para garantir relatórios precisos de latência na migração incremental de dados, o DTS cria objetos no banco de dados de origem. No modo de análise baseada em logs, o DTS cria um gatilho dts_cdc_sync_ddl, uma tabela de heartbeat dts_sync_progress e uma tabela de armazenamento DDL dts_cdc_ddl_history. No modo de análise híbrida baseada em logs, o DTS cria os mesmos objetos e também ativa o CDC nos níveis de banco de dados e tabela. Para tabelas com CDC ativado, a taxa de alteração de dados não deve exceder 1.000 linhas por segundo (RPS).

  • Devido a limites inerentes do AnalyticDB for MySQL, o desempenho de gravação no banco de dados de destino diminui quando o uso de disco dos nós do AnalyticDB for MySQL excede 80%, causando atrasos na tarefa do DTS. Se o uso do disco exceder 90%, as gravações falharão completamente e a tarefa do DTS falhará. Estime o espaço em disco necessário com base nos objetos de migração e garanta armazenamento suficiente no cluster de destino.

  • Se o cluster de destino AnalyticDB for MySQL 3.0 estiver realizando backup enquanto a tarefa do DTS estiver em execução, a tarefa falhará.

  • Antes de migrar dados, avalie o desempenho dos bancos de dados de origem e destino e realize a migração fora dos horários de pico. Durante a migração total de dados, o DTS consome recursos de leitura e gravação em ambos os bancos de dados, o que pode aumentar a carga deles.

  • Durante a migração total de dados, operações INSERT simultâneas podem causar fragmentação nas tabelas de destino, de modo que o espaço de armazenamento das tabelas no banco de dados de destino pode ser maior do que no banco de dados de origem após a migração.

  • Verifique se a precisão que o DTS usa para migrar colunas dos tipos de dados FLOAT ou DOUBLE atende aos seus requisitos de negócios. O DTS usa a função ROUND(COLUMN,PRECISION) para ler valores dessas colunas. Se uma precisão não for definida explicitamente, o DTS migrará valores FLOAT com precisão de 38 dígitos e valores DOUBLE com precisão de 308 dígitos.

  • O DTS tenta retomar uma tarefa com falha por até sete dias. Antes de alternar suas cargas de trabalho de negócios para a instância de destino, encerre ou libere a tarefa de migração. Alternativamente, revogue as permissões de gravação da conta do DTS na instância de destino usando o comando revoke para evitar que uma tarefa retomada sobrescreva os dados de destino.

  • Se uma tarefa de migração incluir migração incremental de dados, não será possível executar operações de reindexação. Isso pode causar falha na tarefa ou resultar em perda de dados.

    Nota

    Não é possível modificar a chave primária de uma tabela para a qual o CDC está ativado.

  • Se o número de tabelas com CDC ativado em uma única tarefa de migração exceder o valor definido no parâmetro The maximum number of tables for which CDC is enabled that DTS supports., a pré-verificação falhará.

  • Se uma tarefa incluir migração incremental e um único campo em uma tabela com CDC ativado a ser gravada contiver mais de 64 KB de dados, execute o comando exec sp_configure 'max text repl size', -1; para ajustar a configuração do banco de dados de origem antecipadamente.

    Nota

    Por padrão, um job de CDC pode processar um tamanho máximo de dados de 64 KB para um único campo.

  • Quando várias instâncias de migração usam o mesmo banco de dados SQL Server de origem, seus módulos de coleta de dados incrementais operam independentemente.

  • Se uma tarefa falhar, a equipe de suporte do DTS tentará restaurá-la dentro de oito horas. Durante a restauração, eles podem reiniciar a tarefa ou ajustar seus parâmetros.

    Nota

    Apenas os parâmetros da tarefa do DTS são modificados — não os parâmetros do banco de dados. Os parâmetros que podem ser ajustados incluem aqueles listados em Modify instance parameters.

  • O SQL Server é um banco de dados comercial e de código fechado cujo formato de log pode causar problemas inevitáveis durante o CDC incremental e a análise no DTS. Antes de ativar o DTS para sincronização incremental a partir de uma origem SQL Server em um ambiente de produção, realize testes abrangentes de prova de conceito (POC) que cubram todos os cenários de alteração de negócios, ajustes de esquema e testes de estresse de carga máxima. A consistência entre a lógica do seu ambiente de produção e a fase de POC é essencial para operações estáveis do DTS.

  • Quando o banco de dados de destino é o AnalyticDB for MySQL, o DTS suporta a gravação apenas dos tipos de dados nativamente suportados pelo AnalyticDB for MySQL, incluindo basic data types e complex data types, como ARRAY, MAP e JSON. Outros tipos, como MULTIVALUE, não são suportados.

  • Rollbacks parciais de transações no banco de dados de origem não são suportados durante a migração incremental e podem ser perdidos.

Casos especiais

Se a origem for uma instância ApsaraDB RDS for SQL Server, o DTS cria uma conta de sistema chamada rdsdt_dtsacct na instância para migração de dados. Não exclua essa conta nem altere sua senha enquanto a tarefa estiver em execução. Caso contrário, a tarefa poderá falhar. Para mais informações, consulte System accounts.

Faturamento

Tipo de migração

Taxa de configuração da instância

Taxa de tráfego de Internet

Migração de esquema e migração total de dados

Gratuito.

Quando o parâmetro Access Method do banco de dados de destino está definido como Public IP Address, você é cobrado pelo tráfego de Internet. Para mais informações, consulte Billing overview.

Migração incremental de dados

Pago. Para mais informações, consulte Billing overview.

Tipos de migração

  • Migração de esquema

    O DTS migra as definições de esquema dos objetos de migração do banco de dados de origem para o banco de dados de destino.

    • O DTS pode migrar os seguintes objetos de esquema: esquemas, tabelas, views, funções e procedimentos.

    • O DTS não pode migrar os seguintes objetos: assemblies, service brokers, índices de texto completo, catálogos de texto completo, esquemas distribuídos, funções distribuídas, procedimentos armazenados Common Language Runtime (CLR), funções escalares CLR, funções com valor de tabela CLR, tabelas internas, sistemas ou funções agregadas.

    Aviso

    Em migrações entre bancos de dados heterogêneos, os tipos de dados podem não ter correspondência um para um, podendo causar falhas na tarefa ou perda de dados. Avalie o impacto nos negócios dos mapeamentos de tipos de dados antes de prosseguir. Para mais informações, consulte Data type mapping for heterogeneous databases.

  • Migração total

    O DTS migra todos os dados históricos dos objetos de migração especificados do banco de dados de origem para o banco de dados de destino.

  • Migração incremental

    Após a conclusão da migração total, o DTS migra as atualizações incrementais de dados do banco de dados de origem para o banco de dados de destino. A migração incremental permite migrar dados suavemente sem interromper suas aplicações autogerenciadas.

Operações SQL suportadas para migração incremental

Tipo de operação

Instrução SQL

DML

INSERT, UPDATE e DELETE

Nota
  • A migração incremental não suporta instruções UPDATE que modificam apenas campos grandes.

  • Ao gravar dados no AnalyticDB for MySQL, ele converte automaticamente instruções UPDATE em REPLACE INTO. Se você atualizar uma chave primária, ele converte a instrução UPDATE em um DELETE seguido por um INSERT.

DDL

  • CREATE TABLE

  • ALTER TABLE

    Apenas ADD COLUMN e DROP COLUMN são suportados.

  • DROP TABLE

  • CREATE INDEX e DROP INDEX

Nota
  • Operações DDL que contêm um tipo definido pelo usuário não são suportadas.

  • Operações DDL transacionais não são suportadas. Por exemplo, uma única instrução SQL que adiciona várias colunas ou contém operações DDL e DML simultaneamente pode causar perda de dados.

  • Operações DDL online não são suportadas.

  • Operações DDL que usam uma palavra-chave reservada como nome de atributo não são suportadas.

  • Operações DDL executadas por um procedimento armazenado do sistema não são suportadas.

  • O DTS não suporta operações TRUNCATE TABLE.

  • Tabelas com partições ou definições contendo uma função não são suportadas.

Permissões de conta de banco de dados

Banco de dados

Migração de esquema

Migração total de dados

Migração incremental de dados

Instância RDS SQL Server

Permissões de leitura nos objetos a serem migrados

Permissões de leitura nos objetos a serem migrados

Permissões de proprietário nos objetos a serem migrados

Cluster AnalyticDB for MySQL

Permissões de leitura e gravação

Para criar e conceder permissões a uma conta de banco de dados, consulte os seguintes tópicos:

Procedimento

  1. Acesse a página da lista de tarefas de migração da região de destino usando um dos métodos a seguir.

    Pelo console do DTS

    1. Faça login no console do Data Transmission Service (DTS).

    2. No painel de navegação à esquerda, clique em Data Migration.

    3. No canto superior esquerdo da página, selecione a região onde a instância de migração está localizada.

    Pelo console do DMS

    Nota

    As operações reais podem variar com base no modo e layout do console do DMS. Para mais informações, consulte Simple mode console e Customize the layout and style of the DMS console.

    1. Faça login no console do Data Management (DMS).

    2. Na barra de menu superior, escolha Data + AI > Data Transmission (DTS) > Data Migration.

    3. À direita de Data Migration Tasks, selecione a região onde a instância de migração está localizada.

  2. Clique em Create Task para acessar a página de configuração da tarefa.

  3. Configure os bancos de dados de origem e de destino.

    Aviso

    Após selecionar as instâncias de origem e destino, recomendamos ler atentamente os limites exibidos na parte superior da página. Caso contrário, a tarefa poderá falhar ou ocorrer inconsistência de dados.

    Categoria

    Parâmetro

    Descrição

    N/A

    Task Name

    O DTS gera automaticamente um nome para a tarefa. Recomendamos especificar um nome descritivo para facilitar a identificação. O nome não precisa ser único.

    Source Database

    Select Existing Connection

    • Para usar uma instância de banco de dados que já foi added to the system (criada ou salva), selecione a instância desejada na lista suspensa. As informações do banco de dados abaixo serão configuradas automaticamente.

      Nota

      No console do DMS, este parâmetro é denominado Select a DMS database instance..

    • Se você não registrou a instância de banco de dados no sistema ou não precisa usar uma instância registrada, configure manualmente as informações do banco de dados abaixo.

    Database Type

    Selecione SQL Server.

    Access Method

    Selecione Alibaba Cloud Instance.

    Instance Region

    Selecione a região onde reside a instância de origem RDS SQL Server.

    Replicate Data Across Alibaba Cloud Accounts

    Este exemplo mostra como migrar dados dentro da mesma conta Alibaba Cloud. Selecione No.

    RDS Instance ID

    Selecione o ID da instância de origem RDS SQL Server.

    Database Account

    Insira a conta do banco de dados para a instância de origem RDS SQL Server. Para detalhes sobre as permissões necessárias, consulte Permission requirements for database accounts.

    Database Password

    Insira a senha da conta do banco de dados.

    Encryption

    Selecione Non-encrypted ou SSL-encrypted com base nos seus requisitos de negócios.

    • Se a criptografia SSL estiver desativada para o banco de dados de origem, selecione Non-encrypted.

    • Se a criptografia SSL estiver ativada para o banco de dados de origem, selecione SSL-encrypted. Por padrão, o DTS confia no certificado do servidor.

    Destination Database

    Select Existing Connection

    • Para usar uma instância de banco de dados que já foi added to the system (criada ou salva), selecione a instância desejada na lista suspensa. As informações do banco de dados abaixo serão configuradas automaticamente.

      Nota

      No console do DMS, este parâmetro é denominado Select a DMS database instance..

    • Se você não registrou a instância de banco de dados no sistema ou não precisa usar uma instância registrada, configure manualmente as informações do banco de dados abaixo.

    Database Type

    Selecione AnalyticDB for MySQL 3.0.

    Access Method

    Selecione Alibaba Cloud Instance.

    Instance Region

    Selecione a região onde reside o cluster de destino AnalyticDB for MySQL 3.0.

    Instance ID

    Selecione o ID do cluster de destino AnalyticDB for MySQL 3.0.

    Database Account

    Insira a conta do banco de dados para o cluster de destino AnalyticDB for MySQL 3.0. Para detalhes sobre as permissões necessárias, consulte Permission requirements for database accounts.

    Database Password

    Insira a senha da conta do banco de dados.

  4. Após concluir a configuração, clique em Test Connectivity and Proceed na parte inferior da página.

    Nota
    • Garanta que o segmento de endereço IP do service DTS seja adicionado automática ou manualmente às configurações de segurança dos bancos de dados de origem e destino para permitir o acesso dos servidores DTS. Para mais informações, consulte Add DTS server IP addresses to a whitelist.

    • Se o banco de dados de origem ou de destino for um banco de dados autogerenciado (o Access Method não é Alibaba Cloud Instance), você também deve clicar em Test Connectivity na caixa de diálogo CIDR Blocks of DTS Servers que aparece.

  5. Configure os objetos da tarefa.

    1. Na página Configure Objects, configure os objetos que deseja migrar.

      Parâmetro

      Descrição

      Migration Types

      • Para migração total de dados apenas, selecione Schema Migration e Full Data Migration.

      • Para uma migração sem tempo de inatividade, selecione Schema Migration, Full Data Migration e Incremental Data Migration.

      Nota
      • Se você selecionar Full Data Migration, o esquema e os dados das tabelas criadas com a instrução CREATE TABLE poderão ser migrados para o banco de dados de destino.

      • Se você não selecionar Incremental Data Migration, não grave novos dados na instância de origem durante a migração de dados para garantir a consistência dos dados.

      Processing Mode of Conflicting Tables

      • Precheck and Report Errors: Verifica se existem tabelas com os mesmos nomes no banco de dados de destino. Se não existirem tabelas com os mesmos nomes, a pré-verificação é aprovada. Se existirem tabelas com os mesmos nomes, um erro será relatado durante a pré-verificação e a tarefa de migração de dados não iniciará.

        Nota

        Se uma tabela no banco de dados de destino tiver o mesmo nome, mas não puder ser facilmente excluída ou renomeada, você poderá alterar o nome da tabela no banco de dados de destino. Para mais informações, consulte Object name mapping.

      • Ignore Errors and Proceed: Ignora a verificação de tabelas com os mesmos nomes.

        Aviso

        Selecionar Ignore Errors and Proceed pode causar inconsistência de dados e riscos aos negócios. Por exemplo:

        • Se os esquemas das tabelas forem consistentes e um registro no banco de dados de destino tiver o mesmo valor de chave primária que um registro no banco de dados de origem:

          • Durante a migração total, o DTS mantém o registro no banco de dados de destino. O registro do banco de dados de origem não é migrado.

          • Durante a migração incremental, o DTS não mantém o registro no banco de dados de destino. O registro do banco de dados de origem sobrescreve o registro no banco de dados de destino.

        • Se os esquemas das tabelas forem inconsistentes, apenas algumas colunas de dados poderão ser migradas ou a migração poderá falhar. Prossiga com cautela.

      Schema Mapping Mode of Source and Destination Databases

      Selecione um modo de mapeamento de esquema com base nas suas necessidades de negócios para mapear esquemas entre os bancos de dados de origem e destino.

      Aviso

      Vários esquemas no banco de dados de origem não podem ter tabelas com o mesmo nome. Caso contrário, pode ocorrer inconsistência de dados ou falha na tarefa.

      SQL Server Incremental Synchronization Mode

      • Log-based Parsing for Non-heap Tables and CDC-based Incremental Synchronization for Heap Tables (Hybrid Log-based Parsing):

        • Vantagens:

          • Suporta cenários que envolvem tabelas heap de origem, tabelas sem chaves primárias, tabelas compactadas ou tabelas com colunas computadas.

          • Oferece alta estabilidade de link. Este modo pode obter instruções DDL completas e suporta uma ampla gama de cenários DDL.

        • Desvantagens:

          • O DTS cria o gatilho dts_cdc_sync_ddl, a tabela de heartbeat dts_sync_progress e a tabela de armazenamento DDL dts_cdc_ddl_history no banco de dados de origem. Ele também ativa o CDC no nível do banco de dados e o CDC para algumas tabelas.

          • Você não pode executar instruções SELECT INTO, TRUNCATE ou RENAME COLUMN em tabelas com CDC ativado no banco de dados de origem. Você não pode excluir manualmente gatilhos criados pelo DTS no banco de dados de origem.

      • Incremental Synchronization Based on Logs of Source Database (Heap tables are not supported):

        • Vantagem:

          Este modo não é intrusivo para o banco de dados de origem.

        • Desvantagem:

          Este modo não suporta cenários que envolvem tabelas heap de origem, tabelas sem chaves primárias, tabelas compactadas ou tabelas com colunas computadas.

      • Polling and querying CDC instances for incremental synchronization:

        • Vantagens:

          • Suporta migração total e incremental quando o banco de dados de origem é Amazon RDS for SQL Server, Azure SQL Database, Azure SQL Managed Instance, Azure SQL Server on Virtual Machine ou Google Cloud SQL for SQL Server.

          • Este modo usa o componente CDC nativo do SQL Server para obter dados incrementais, o que melhora a estabilidade da migração incremental e reduz o uso de largura de banda de rede.

        • Desvantagens:

          • A conta do banco de dados de origem usada pela instância do DTS deve ter permissões para ativar o CDC. A migração incremental de dados tem uma latência de cerca de 10 segundos.

          • Ao migrar várias tabelas em vários bancos de dados, você pode encontrar problemas de estabilidade e desempenho.

      Nota

      Este parâmetro está disponível apenas se você selecionar Incremental Data Migration para o parâmetro Migration Types.

      The maximum number of tables for which CDC is enabled that DTS supports.

      Você pode definir um limite para o número de tabelas com CDC ativado para a instância de migração atual com base nos seus requisitos de negócios. O valor padrão é 1.000.

      Nota

      Este parâmetro não está disponível se você definir SQL Server Incremental Synchronization Mode como Incremental Synchronization Based on Logs of Source Database (Heap tables are not supported).

      Select DDL and DML to Sync at the Instance Level

      Selecione as operações SQL para migração incremental no nível da instância. Para obter informações sobre as operações suportadas, consulte SQL operations supported for incremental migration.

      Nota

      Para selecionar operações SQL para migração incremental no nível do banco de dados ou da tabela, clique com o botão direito em um objeto de migração na caixa Selected Objects e selecione as operações SQL desejadas.

      Source Objects

      Na caixa Source Objects, clique nos objetos a serem migrados e, em seguida, clique em Right arrow para movê-los para a caixa Selected Objects.

      Nota

      Este cenário é uma migração entre bancos de dados heterogêneos. Portanto, a granularidade para seleção de objetos de migração é a tabela. Outros objetos, como views, gatilhos e procedimentos armazenados, não são migrados para o banco de dados de destino.

      Selected Objects

      • Para alterar o nome de um único objeto de migração na instância de destino, clique com o botão direito no objeto na caixa Selected Objects. Para mais informações, consulte Map individual schema, table, and column names.

      • Para alterar os nomes de vários objetos de migração na instância de destino, clique em Selected Objects no canto superior direito da caixa Batch Edit. Para mais informações, consulte Map multiple schema, table, and column names.

      Nota
      • Se você usar o recurso de mapeamento de nomes de objetos, a migração de outros objetos que dependem do objeto renomeado poderá falhar.

      • Para definir uma condição WHERE para filtrar dados, clique com o botão direito na tabela a ser migrada na seção Selected Objects e especifique a condição de filtro na caixa de diálogo que aparece. Para obter instruções, consulte Set filter conditions.

      • Para selecionar operações SQL a serem migradas no nível do banco de dados ou da tabela, clique com o botão direito no objeto de migração na seção Selected Objects e selecione as operações SQL desejadas na caixa de diálogo que aparece.

    2. Clique em Next: Advanced Settings para configurar parâmetros avançados.

      Parâmetro

      Descrição

      Dedicated Cluster for Task Scheduling

      Por padrão, o DTS agenda tarefas em um cluster compartilhado. Você não precisa selecionar um. Se desejar tarefas mais estáveis, adquira um dedicated cluster para executar tarefas de migração do DTS.

      Retry Time for Failed Connections

      Após o início da tarefa de migração, se a conexão com o banco de dados de origem ou de destino falhar, o DTS relatará um erro e começará imediatamente a tentar reconectar. A duração padrão de nova tentativa é de 720 minutos. Você pode personalizar o tempo de nova tentativa para um valor entre 10 e 1440 minutos. Recomendamos definir a duração para mais de 30 minutos. Se o DTS se reconectar aos bancos de dados de origem e destino dentro da duração especificada, a tarefa de migração será retomada automaticamente. Caso contrário, a tarefa falhará.

      Nota
      • Para várias instâncias do DTS que compartilham a mesma origem ou destino, o tempo de nova tentativa de rede é determinado pela configuração da última tarefa criada.

      • Como você é cobrado pela tarefa durante o período de nova tentativa de conexão, recomendamos personalizar o tempo de nova tentativa com base nas suas necessidades de negócios ou liberar a instância do DTS o mais rápido possível após a liberação das instâncias de banco de dados de origem e destino.

      Retry Time for Other Issues

      Após o início da tarefa de migração, se ocorrer um problema que não seja de conectividade, como uma exceção de execução DDL ou DML, no banco de dados de origem ou de destino, o DTS relatará um erro e começará imediatamente a tentar novamente a operação. A duração padrão de nova tentativa é de 10 minutos. Você pode personalizar o tempo de nova tentativa para um valor entre 1 e 1440 minutos. Recomendamos definir a duração para mais de 10 minutos. Se as operações relacionadas forem bem-sucedidas dentro da duração de nova tentativa especificada, a tarefa de migração será retomada automaticamente. Caso contrário, a tarefa falhará.

      Importante

      O valor de Retry Time for Other Issues deve ser menor que o valor de Retry Time for Failed Connections.

      Enable Throttling for Full Data Migration

      Durante a migração total, o DTS consome recursos de leitura e gravação nos bancos de dados de origem e destino, o que pode aumentar a carga do banco de dados. Se necessário, você pode ativar o limitador de velocidade para a tarefa de migração total. Defina Queries per second (QPS) to the source database, RPS of Full Data Migration e Data migration speed for full migration (MB/s) para reduzir a carga no banco de dados de destino.

      Nota
      • Este item de configuração está disponível apenas se você selecionar Full Data Migration para Migration Types.

      • Você também pode adjust the full migration speed após a instância de migração estar em execução.

      Enable Throttling for Incremental Data Migration

      Se necessário, você também pode optar por definir limites de velocidade para a tarefa de migração incremental. Defina RPS of Incremental Data Migration e Data migration speed for incremental migration (MB/s) para reduzir a carga no banco de dados de destino.

      Nota
      • Este item de configuração está disponível apenas se você selecionar Incremental Data Migration para Migration Types.

      • Você também pode adjust the incremental migration speed após a instância de migração estar em execução.

      Environment Tag

      Você pode selecionar uma tag de ambiente para identificar a instância com base nos seus requisitos. Este exemplo não exige que você selecione uma tag.

      Configure ETL

      Escolha se deseja ativar o recurso de extração, transformação e carregamento (ETL). Para mais informações, consulte What is ETL? Valores válidos:

      Monitoring and Alerting

      Selecione se deseja definir alertas e receber notificações de alerta com base nas suas necessidades de negócios.

      • No: Não define um alerta.

      • Yes: Configure alertas definindo um alert threshold e um alert notifications. Se uma migração falhar ou a latência exceder o limiar, o sistema enviará uma notificação de alerta.

    3. Clique em Next: Data Validation para configurar uma tarefa de validação de dados.

      Para mais informações sobre o recurso de validação de dados, consulte Configure data validation.

    4. Opcional: Após concluir as configurações anteriores, clique em Next: Configure Database and Table Fields para definir o Type, Primary Key Column, Distribution Key e as informações de chave de partição (Partition Key, Partitioning Rules e Partition Lifecycle) para as tabelas a serem migradas no banco de dados de destino.

      Nota
      • Esta etapa está disponível apenas se você selecionar a opção Schema Migration para Migration Types ao configurar os objetos da tarefa. Selecione All para Definition Status para fazer modificações.

      • Selecione várias colunas para Primary Key Column para formar uma chave primária composta. Você também deve selecionar uma ou mais colunas da Primary Key Column para usar como Distribution Key e Partition Key. Para mais informações, consulte CREATE TABLE.

  6. Salve a tarefa e execute uma pré-verificação.

    • Para visualizar os parâmetros de configuração desta instância ao chamar a operação de API, passe o ponteiro sobre o botão Next: Save Task Settings and Precheck e clique em Preview OpenAPI parameters no balão que aparece.

    • Se você não precisar visualizar ou já tiver terminado de visualizar os parâmetros da API, clique em Next: Save Task Settings and Precheck na parte inferior da página.

    Nota
    • Antes do início da tarefa de migração, o DTS realiza uma pré-verificação. A tarefa só inicia após ser aprovada na pré-verificação.

    • Se a pré-verificação falhar, clique em View Details ao lado do item de verificação com falha, corrija o problema com base no aviso e execute a pré-verificação novamente.

    • Se um aviso for relatado durante a pré-verificação:

      • Para itens de verificação que não podem ser ignorados, clique em View Details ao lado do item com falha, corrija o problema com base no aviso e execute a pré-verificação novamente.

      • Para itens de verificação que podem ser ignorados, clique em Confirm Alert Details, Ignore, OK e Precheck Again para pular o item de alerta e executar a pré-verificação novamente. Se você optar por ignorar um aviso, isso poderá causar problemas como inconsistência de dados e representar riscos aos seus negócios.

  7. Adquira uma instância.

    1. Quando a Success Rate for 100%, clique em Next: Purchase Instance.

    2. Na página Purchase, selecione a especificação de link para a instância de migração de dados. Para mais informações, consulte a tabela a seguir.

      Categoria

      Parâmetro

      Descrição

      New Instance Class

      Resource Group Settings

      Selecione o grupo de recursos ao qual a instância pertence. O valor padrão é default resource group. Para mais informações, consulte What is Resource Management?

      Instance Class

      O DTS fornece especificações de migração com diferentes níveis de desempenho. A especificação do link afeta a velocidade da migração. Selecione uma especificação com base no seu cenário de negócios. Para mais informações, consulte Data migration link specifications.

    3. Após concluir a configuração, leia e selecione Data Transmission Service (Pay-as-you-go) Service Terms.

    4. Clique em Buy and Start. Na caixa de diálogo OK que aparece, clique em OK.

      Visualize o progresso da tarefa de migração na página de lista Data Migration Tasks.

      Nota
      • Se a tarefa de migração não incluir migração incremental, ela será interrompida automaticamente após a conclusão da migração total. Após a interrupção da tarefa, seu Status muda para Completed.

      • Se a tarefa de migração incluir migração incremental, ela não será interrompida automaticamente. A tarefa de migração incremental continua em execução. Enquanto a tarefa de migração incremental estiver em execução, o Status da tarefa será Running.