Use o console do Container Service for Kubernetes (ACK) para excluir clusters desnecessários. Na página de exclusão, revise os recursos a serem removidos e selecione quais deseja manter. Leia atentamente os avisos na tela para compreender os riscos antes de prosseguir.
Regras de exclusão de cluster e liberação de nós
Ao excluir um cluster, o ACK libera os nós excluindo sequencialmente seus pools de nós. As seguintes regras se aplicam aos pools de nós no cluster:
Se um pool de nós estiver configurado com um número desejado de nós: Todos os nós de pagamento conforme o uso no pool são liberados. Nós por assinatura não são liberados. Para liberar nós por assinatura, faça login no console do ECS, converta os nós por assinatura para pagamento conforme o uso e libere-os no console do ECS. Após a liberação de um nó, seu disco de sistema também é liberado.
Caso o pool de nós não tenha um número desejado configurado: Nós por assinatura e quaisquer nós adicionados manual ou automaticamente ao pool não são liberados. Todos os demais nós são liberados.
Para mais informações, consulte Como verificar se um pool de nós tem um número desejado de nós configurado?
Procedimento
Faça login no console do ACK. No painel de navegação à esquerda, clique em Clusters.
Na página Clusters, localize o cluster a ser excluído e escolha na coluna Actions.
No painel exibido, revise cuidadosamente os recursos que serão excluídos automaticamente, como recursos do ECS, Elastic Container Instance (ECI) e Container Compute Service (ACS). Selecione os recursos que deseja manter, leia as observações sobre exclusão de recursos e faturamento e siga as instruções na tela para excluir o cluster.
Limpar recursos
Após a exclusão de um cluster, o ACK limpa automaticamente alguns dos recursos associados. No entanto, certos recursos de service cloud associados, como nós por assinatura e volumes de armazenamento, podem não ser liberados automaticamente junto com o cluster. Depois de confirmar que os recursos restantes não são mais necessários, exclua-os manualmente o quanto antes para evitar cobranças contínuas. Acesse o console do Resource Management para visualizar todos os recursos da sua conta.
A tabela a seguir lista alguns desses recursos:
Recurso cloud | Guia de exclusão |
Nós do ECS (assinatura) | Primeiro, converta as instâncias por assinatura para pagamento conforme o uso (Console/OpenAPI) e libere as instâncias (Console/OpenAPI). |
VPC | |
vSwitch | |
Grupo de segurança | |
Gateway NAT | |
EIP | |
CLB (assinatura) | |
NLB | |
ALB | |
API gateway nativo da cloud (APIG) | |
MSE Cloud Native Gateway | |
Disco cloud (usado como PV) | |
NAS (usado como PV) | |
Bucket do OSS (usado como PV) | |
CPFS for AI (usado como PV) | |
CPFS General-purpose (usado como PV) | |
Projeto do SLS | |
Prometheus |
Perguntas frequentes
O que fazer se a exclusão do cluster falhar?
Se a exclusão falhar, o status do cluster muda para delete_failed.
A exclusão pode falhar pelos seguintes motivos:
-
Dependências de recursos inesperadas
Ao excluir um cluster ACK, o service libera os recursos selecionados para remoção e verifica suas dependências durante o processo. Por exemplo, se um recurso a ser excluído possuir dependências não criadas pelo cluster, a exclusão poderá falhar. Clique em View na coluna Cluster Status para ver a causa da falha. Após resolver o problema, tente excluir o cluster novamente.
Por exemplo, se um gateway NAT criado automaticamente pelo cluster ACK contiver entradas SNAT ou DNAT não criadas pelo cluster, a exclusão poderá falhar.
Durante a exclusão, opte por manter o gateway NAT cuja liberação falhou. Após a exclusão do cluster, libere manualmente os recursos NAT. Alternativamente, siga as instruções na tela para remover manualmente as entradas SNAT ou DNAT bloqueantes e tente excluir o cluster novamente.
Se a exclusão do cluster falhar por outros motivos, abra um ticket.
Como desativar a proteção contra exclusão do cluster?
Se um cluster tiver a proteção contra exclusão ativada, o console solicitará que você a desative antes de permitir a exclusão. Para desativar a proteção contra exclusão do cluster:
Faça login no console do ACK. No painel de navegação à esquerda, clique em Clusters.
Na página Actions, localize o cluster e escolha na coluna Actions e siga as instruções na tela.
Como verificar se um pool de nós tem um número desejado de nós configurado?
Faça login no console do ACK. No painel de navegação à esquerda, clique em Clusters.
Na página Clusters, clique no nome do seu cluster. No painel de navegação à esquerda, clique em .
-
Clique no nome do pool de nós desejado e, em seguida, clique na aba Basic Information. Na seção Scaling Configurations, verifique se há um número desejado de nós configurado.
Em caso afirmativo, o número correspondente será exibido.
Essa seção também mostra os valores de Expected Nodes e Actual Nodes.
Como ocorre o faturamento dos recursos de product cloud associados quando meu cluster ACK está em estado de exclusão ou anormal?
Todos os tipos de cluster — Basic Edition, Pro Edition e clusters dedicados ACK — continuam a gerar cobranças por recursos associados, como ECS e SLB, até que esses recursos sejam liberados. Isso se aplica a clusters nos seguintes estados: Deleting, Delete failed, Inactive e Unavailable.
Para mais informações, consulte Ciclo de vida do cluster e Visão geral do faturamento.
Como é faturado um cluster ACK no estado Inactive ou Unavailable?
Você paga apenas uma taxa de recurso cloud por um cluster ACK gerenciado Basic ou cluster dedicado ACK. Se um cluster ACK Basic ou cluster dedicado ACK estiver em estado anormal, o faturamento dos recursos cloud utilizados pelo cluster continua normalmente.
Você paga uma taxa de gerenciamento de cluster e uma taxa de recurso cloud por um cluster ACK gerenciado Pro. Quando um cluster ACK Pro entra em estado anormal, o ACK reduz o plano de controle do cluster. Após essa redução, o faturamento do gerenciamento do cluster é interrompido, mas a cobrança dos recursos cloud utilizados pelo cluster continua.
Para mais informações, consulte Ciclo de vida do cluster e Regras de faturamento.
Estados sem taxas de gerenciamento
A taxa de gerenciamento de cluster é cobrada apenas para clusters ACK gerenciados Pro. Não há cobrança de taxa de gerenciamento para clusters ACK gerenciados ou clusters dedicados ACK.
Quando um cluster ACK gerenciado Pro se encontra em um dos estados a seguir, as taxas de gerenciamento deixam de ser cobradas:
Initializing
Failed
Inactive
Unavailable
Deleting
Delete_failed
Deleted (O cluster não fica mais visível neste estado.)
Para mais informações, consulte Ciclo de vida do cluster e Visão geral do faturamento.
Por que uma instância CLB associada não é liberada automaticamente após a exclusão de um cluster ACK?
Uma instância CLB associada não é liberada automaticamente quando você exclui um cluster ACK. Isso ocorre porque uma instância CLB por assinatura precisa ser convertida para pagamento conforme o uso antes de poder ser liberada.
Converta a instância CLB por assinatura para pagamento conforme o uso (para mais informações, consulte Perguntas frequentes sobre faturamento do CLB) e, em seguida, Criar e gerenciar instâncias CLB.
Para mais informações sobre como excluir clusters, consulte Excluir um cluster .