ApsaraDB RDS インスタンスの特定のデータベースまたはテーブルを元のインスタンスに復元します。
操作説明
サポート対象エンジン。
今すぐお試しください
テスト
RAM 認証
|
アクション |
アクセスレベル |
リソースタイプ |
条件キー |
依存アクション |
|
rds:RestoreTable |
create |
*DBInstance
|
|
なし |
リクエストパラメーター
|
パラメーター |
型 |
必須 / 任意 |
説明 |
例 |
| ClientToken |
string |
任意 |
リクエストのべき等性を確保するために使用されるクライアントトークン。クライアントを使用してトークンを生成できますが、異なるリクエスト間でトークンが一意であることを確認する必要があります。トークンには ASCII 文字のみを使用でき、長さは 64 文字以下である必要があります。 |
ETnLKlblzczshOTUbOCz**** |
| DBInstanceId |
string |
必須 |
インスタンスの ID。 |
rm-uf6wjk5**** |
| BackupId |
string |
任意 |
バックアップセットの ID。 DescribeBackups オペレーションを呼び出して、バックアップセットのリストを照会できます。 説明
BackupId と RestoreTime のいずれか一方以上を指定する必要があります。 |
902**** |
| RestoreTime |
string |
任意 |
バックアップ保持期間内の任意の時点。フォーマット: yyyy-MM-ddTHH:mm:ssZ (UTC)。 説明
|
2011-06-11T16:00:00Z |
| TableMeta |
string |
必須 |
復元するデータベースおよびテーブル。 説明
RDS PostgreSQL では、指定したデータベースのみの復元がサポートされており、指定したテーブルの復元はサポートされていません。
|
[{"type":"db","name":"testdb1","newname":"testdb1_new","tables":[{"type":"table","name":"testdb1table1","newname":"testdb1table1_new"}]}] |
| InstantRecovery |
boolean |
任意 |
単一データベースおよびテーブルの高速復元を有効にするかどうかを指定します。有効な値:
説明
単一データベースおよびテーブルの高速復元の詳細については、「単一データベースおよびテーブルの復元」を参照してください。 |
true |
レスポンスフィールド
|
フィールド |
型 |
説明 |
例 |
|
object |
応答パラメーター。 |
||
| RequestId |
string |
リクエストの ID。 |
EA2D4F34-01A7-46EB-A339-D80882135206 |
例
成功レスポンス
JSONJSON
{
"RequestId": "EA2D4F34-01A7-46EB-A339-D80882135206"
}
エラーコード
|
HTTP ステータスコード |
エラーコード |
エラーメッセージ |
説明 |
|---|---|---|---|
| 400 | InvalidRestoreType.Format | Specified restore type is not valid. | 指定された解凍タイプが無効です。有効な解凍タイプを設定してください。 |
| 400 | InvalidRestoreTime.Format | Specified restore time is not valid. | 指定された解凍時間が無効なため、操作が失敗しました。有効な解凍時間を設定してください。 |
| 400 | InvalidBakset.Invalid | Specified bakset is not valid. | 指定されたバックアップセットはこの操作をサポートしていません。 |
| 400 | InvalidParamTableMeta | Invalid parameter TableMeta is null or not json format | TableMeta パラメーターが無効です。このパラメーターの有効性を確認してください。 |
| 400 | InvalidBakHistoryDO | BakHistory is inbalid when check restore TableMeta | |
| 400 | InvalidBakTableMetaDO | BakTableMeta in BakHistory.Info is invalid | |
| 400 | InvalidParamTableMeta.Content | TableMeta has duplicate db.table in newname or with common. | テーブルメタデータに重複するテーブル名が含まれています。 |
| 400 | InvalidParamTableMeta.Duplicate | TableMeta has duplicate db or table with other newname, commons or system | 読み取り用に指定されたデータベースまたはテーブルがデータベース内に既に存在するため、操作は失敗しました。 |
| 400 | InvalidSourceRestoreDBName.NotFound | specific source restore dbname is not found in db list | 操作が失敗しました。解凍対象として指定されたデータベースがバックアップセット内に存在しません。 |
| 400 | InvalidParamTableMetaForRestore.Content | new dbname or table in TableMeta cannot be same with old when restore to source instance | |
| 400 | InvalidDBName.Duplicate | Specified DB name already exists in the This instance. | 現在のデータベース名が無効です。データベース名を再設定してください。 |
| 400 | InvalidParameters.Format | Specified parameters is not valid. | 操作が失敗しました。指定されたパラメーターのフォーマットが無効です。 |
| 400 | InvalidAvZone.Format | Specified AvZone is not valid. | 操作が失敗しました。ゾーンが正しくありません。確認してから再試行してください。 |
| 400 | InvalidRegion.Format | Specified Region is not valid. | 指定されたリージョンが無効です。このパラメーターの有効性を確認してください。 |
| 400 | InvalidIP.Format | Specified ip is not valid. | |
| 400 | InvalidVpcParameter | Specified VPCId VSwitchId or IPAddress or TunnelId is not valid. | 操作が失敗しました。VPC パラメーターが正しいかどうかを確認してください。 |
| 400 | MissingUserID | The request is missing a user_id parameter. | ユーザー ID が存在しません。 |
| 400 | MissingUID | The request is missing a uid parameter. | 現在のリクエストに UID がないため、操作は失敗しました。 |
| 400 | MissBackupSetAndRestoreTime.NotFound | Both BackupSet and RestoreTime are null. | BackupSet と RestoreTime の両方が空であるため、操作は失敗しました。 |
| 400 | InvalidBakHistory.DbVersionMismatch | db version of bakhistory is mismatch with custins | データベースとテーブルの復元では、バックアップデータのバージョンを元のインスタンスのバージョンと異なるものにすることはできません。 |
| 400 | DiskSize.NotEnough | The disk size is not enough to restore tables. | ディスクに十分な空き容量がありません。 |
| 400 | InvalidSourceCategory | specified source category is not supported for this function. | |
| 400 | RestoreTableException | RestoreTable Exception, result is null. | RestoreTable 例外が発生しました。結果が null です。 |
| 400 | InvalidParamTableMeta.TooManyTables | At most 100 tables are supported. Restoring the database is recommended. | テーブルメタデータでは最大値 100 個のテーブルがサポートされています。代わりにデータベースを解凍することを推奨します。 |
| 400 | InvalideStatus.Format | The instance status does not support this operation. | インスタンスステータスはこの操作をサポートしていません。 |
| 400 | Order.ComboInstanceNotAllowOperate | A package instance is not allowed to operate independently. | パッケージインスタンスに対して個別の操作を行うことはできません。 |
| 400 | Price.PricingPlanResultNotFound | Pricing plan price result not found. | 料金プランの価格結果が見つかりませんでした。 |
| 400 | Order.NoRealNameAuthentication | You have not passed the real-name authentication and do not meet the purchase conditions. Please log in to the user center for real-name authentication. | 実名認証が完了していないため、購入資格がありません。料金・コスト管理にログインして実名認証を完了してください。 |
| 400 | InsufficientAvailableQuota | Your account quota limit is less than 0, please recharge before trying to purchase. | アカウントの利用可能額が 0 未満です。購入を試みる前にアカウントをチャージしてください。 |
| 400 | CommodityServiceCalling.Exception | Failed to call commodity service. | 商品サービスへの呼び出しに失敗しました。 |
| 400 | RegionDissolvedEOM | Dear customer, Alibaba Cloud plans to optimize and adjust the current region. Cloud services in this region will cease operations. You are currently unable to operate new purchase orders. Thank you for your understanding and support. | Alibaba Cloud は現在のリージョンの最適化および調整を予定しています。このリージョンのクラウドサービスは終了されます。業務継続性とスムーズなデータ移行を確保するため、現時点では新規購入注文を行うことができません。ご理解とご支援のほどよろしくお願いいたします。 |
| 400 | Commodity.InvalidComponent | The module you purchased is not legal, please buy it again. | 購入したモジュールが無効です。有効なモジュールを購入してください。 |
| 400 | RegionEndTimeDissolvedAustralia | Cloud services in the Australia (Sydney) region will be discontinued. Set the validity date to September 30, 2024 or earlier than September 30, 2024. | リージョンが廃止されました。 |
| 400 | Price.CommoditySys | Commodity system call exception. | 商品システムの呼び出し時に例外が発生しました。 |
| 400 | Pay.InsufficientBalance | Insufficient available balance. | |
| 400 | Order.PeriodInvalid | There is a problem with the period you selected, please choose again. | 選択したサブスクリプション期間が無効です。有効な期間を選択してください。 |
| 400 | pay.noCreditCard | Account not bound to credit card. | 利用可能なクレジットカードがありません。 |
| 400 | Order.InstHasUnpaidOrder | There is an unpaid order for the service you have purchased. Please pay or void it before placing the order. | 選択したサービスに未払いの注文があります。新しい注文を行う前に、既存の注文の支払いを完了するかキャンセルしてください。 |
| 400 | noAvailablePaymentMethod | No payment method is specified for your account. We recommend that you add a payment method. | アカウントに支払方法が設定されていません。支払方法を追加してください。 |
| 400 | BasicInfoUncompleted | Your information is incomplete. Complete your information before the operation. | 基本情報が不完全です。この操作を実行する前に、基本情報のフォームを完了させてください。フォーマットを確認してください。 |
| 400 | Risk.RiskControlRejection | Your account is abnormal, please contact customer service for details. | アカウントで例外が発生しました。詳細についてはカスタマーサービスにお問い合わせください。 |
| 400 | Api.NotSupport | Specified api is not supported. | 現在の API オペレーションはサポートされていません。 |
| 400 | ContainForbiddenLabelError | There is a label that prohibits placing orders. Please contact your distributor for assistance. | 注文ブロックタグが存在します。この問題を解決するには、販売代理店にお問い合わせください。 |
| 400 | InvalidDBInstanceId.NotFound | The DBInstanceId provided does not exist in records. | 指定された DBInstanceId が存在しません。 |
| 400 | InvalidInstanceLevel.DiskType | Specified instance level not support request disk type | 現在のインスタンスタイプは、指定されたストレージタイプをサポートしていません。 |
| 400 | InvalidParam | Sepcified wal level Parameter is invalid. There are still logical slots in instance, so it can not be set as replica. | 入力パラメーターが無効です。 |
| 400 | KmsApiError | User secret key invalid. | ユーザーキーが無効です。 |
| 400 | System.SaleValidateFailed | Sales expression validation system error. | |
| 400 | Abs.InvalidAccount.NotFound | account is not found. | Alibaba Cloud アカウントが存在しないか、AccessKey が期限切れです。 |
| 400 | SqlExecuteFailedOrTimeout | sql command execution failed or timed out:%s. | SQL コマンドの実行に失敗したか、または時間切れになりました。 |
| 400 | ColdData.EngineVersionNotSupport | The current instance engine version not support coldDataEnabled. | 現在のインスタンスの DPI エンジンバージョンは、コールドデータアーカイブをサポートしていません。 |
| 400 | ColdData.MinorVersionNotSupport | The current instance minor version not support coldDataEnabled. | 現在のカーネルバージョンは、コールドデータアーカイブをサポートしていません。 |
| 400 | IncorrectTargetClasscode | The current instance type does not support this operation. | 現在のインスタンスの仕様では、この操作はサポートされていません。 |
| 400 | InvalidConnectionString.Duplicate | Specified connection string already exists in the RDS. | エンドポイント名が重複しています。接続文字列を再設定してください。 |
| 400 | RequiredParam.NotFound | Required input param is not found. | 必須パラメーターが不足しています。 |
| 400 | Parameters.Invalid | Parameter error, please check the parameters. | パラメーターが正しくありません。パラメーターを確認してください。 |
| 400 | BackupPolicyNotSupport | Cold Data won't open with CrossBackup or Flash Backup, please check Backup Policy. | 現在のバックアップポリシーではこの操作はサポートされていません。 |
| 400 | InvalidReleasedKeepPolicy.Format | Specified Released Keep Policy is not valid. | インスタンスリリース後のアーカイブバックアップデータの保持ポリシーが無効です。 |
| 400 | InvalidDBInstanceEngineType.Format | the DB instance engine type does not support this operation. | インスタンスのデータベースエンジンタイプはこの操作をサポートしていません。 |
| 400 | Pay.NoCreditCard | No credit cards. | |
| 400 | VpcNetworkTypeNotSupport | The vpc network type instance does not support this operation. | この操作は、VPC ネットワークタイプのインスタンスではサポートされていません。 |
| 400 | MirrorInsExists | Specified DB instance mirror ins already existed. | 現在のデータベースインスタンスのイメージが既に存在します。読み取りを確認してください。 |
| 400 | UnsupportedClassCode | The specified DB instance class stops selling. | このインスタンスタイプは購入できなくなりました。 |
| 400 | InvalidBackupSet | The specified database does not exist in the backup set. | 指定されたデータベースがバックアップセットに存在しません。 |
| 400 | OrdTCommodityQueryError | Failed to query for product. | プロダクトのクエリに失敗しました。 |
| 400 | ProductInstanceReleased | The instance has been released. Please check before placing the order. | インスタンスはリリースされています。注文を行う前にインスタンスを確認してください。 |
| 400 | RegionEndTimeDissolvedIndia | The region is no longer supported. | 指定されたリージョンが無効です。 |
| 500 | ResourceConfigError | The request processing has failed due to resource config error. | |
| 500 | ExternalFailure | The request processing has failed due to external service failure. | サービスへのリクエストが失敗しました。後でもう一度お試しください。 |
| 500 | RequestMetaDataFailed | The service request failed. Please try again later or contact service personnel. | サービスリクエストに失敗しました。後でもう一度お試しいただくか、サポートにお問い合わせください。 |
| 500 | InvokeProxyFailure | The request processing has failed due to service failure of rds api. | RDS API サービスの障害により、リクエストの処理が失敗しました。 |
| 403 | InvalidBackupLogStatus | Current backup log enable status does not support this operation. | 操作が失敗しました。ログバックアップが有効になっていません。ポイントインタイム復元は利用できません。 |
| 403 | IncorrectDBInstanceType | Current DB instance type does not support this operation. | 操作が失敗しました。現在のインスタンスステータスでは、この操作はサポートされていません。 |
| 403 | IncorrectDBInstanceState | Current DB instance state does not support this operation. | 現在のインスタンスステータスではこの操作はサポートされていません。 |
| 403 | IncorrectBackupSetMethod | Current backup set method does not support operations. | 操作が失敗しました。指定されたバックアップセットではデータベースとテーブルの復元はサポートされていません。 |
| 403 | IncorrectBackupSetState | Current backup set state does not support operations. | 操作が失敗しました。現在のバックアップセットステータスではこの操作はサポートされていません。 |
| 403 | ChildDBInstanceExists | Current DB instance had child instance. | 操作に失敗しました。読み取り専用インスタンスが既に存在します。 |
| 403 | OrderStatus.UnPaid | The specified db instance has unpaid order. | 現在のインスタンスに未払いの注文があります。注文の支払いを完了してから再試行してください。 |
| 403 | InvalidReduceDiskSize | The storage capacity after the scale-down must be larger than the used amount. | スケールダウンのターゲット容量を現在のストレージ使用量より小さくすることはできません。 |
| 403 | CloudSSDNotSupport | Cloud ssd does not support this operation, please upgrade to essd. | SSD ディスクはこの操作をサポートしていません。ESSD にアップグレードしてください。 |
| 403 | InvalidUserOperatorPermission | The user permission does not support this operation. | ユーザー権限ではこの操作はサポートされていません。 |
| 403 | InvalidVswitchId | Specified conn vswitch id is not valid. | 指定された VSwitchId のフォーマットが正しくないか、または空です。 |
| 403 | IncorrectMinorVersion | Current engine minor version does not support operations. | 現在のマイナーバージョンでは、この操作はサポートされていません。 |
| 403 | OperationDenied.ZoneResource | There is no available zone for inventory. | 利用可能な在庫リージョンがありません。 |
| 403 | NotInFlowController | Sorry,no permission. | この特徴は利用できません。法人クラウドユーザーではないため、権限がありません。 |
| 403 | InvalidKmsKey | Kms key is disabled. | KMS キーが無効化されています。 |
| 403 | InvalidInstanceLevel.Malformed | Current DB instance level does not support this operation. | 現在のデータベースインスタンスレベルは、この操作をサポートしていません。 |
| 403 | InvalidMeta.TooLarge | Meta information is too large. | メタデータが large です。インスタンス内のテーブル数が 50,000 を超えていないか確認してください。 |
| 403 | GuardDBInstanceNotSupport | Guard instance does not support this operation. | ディザスタリカバリインスタンスではこの操作はサポートされていません。 |
| 404 | InvalidBackup.NotFound | The available backup does not exist in recovery time. | |
| 404 | InvalidBinlog.NotFound | The available binlog does not exist in recovery time. | 指定された復元ポイントでバイナリログが有効ではありません。 |
| 404 | InvalidBackupSetID.NotFound | Specified backup set ID does not exist. | バックアップセットが存在しません。既存のバックアップセットを表示してください。 |
| 404 | InvalidDB.NotFound | Specified db does not exist or DB status does not support. | 指定されたデータベースが存在しないか、データベースのステータスがこの操作をサポートしていません。 |
| 404 | InvalidRegion.NotFound | Specified Region does not exist in RDS. | |
| 404 | InsufficientResourceCapacity | There is insufficient capacity available for the requested instance. | |
| 404 | InvalidDBInstance.NotFound | Specified instance does not exist or not support. | 指定されたインスタンスが見つかりませんでした。インスタンスが有効かどうかを確認してください。 |
| 404 | InvalidClusterKms | The current instance does not authorized to access the Key Management Service. | 現在のインスタンスは Key Management Service へのアクセスを許可されていません。 |
| 404 | Request.NotFound | The requested resource is not available. | リクエストされたリソースは利用できません。 |
| 404 | HostInfo.NotFound | The specified host info is not found. | 指定されたホスト情報が存在しません。 |
完全なリストについては、「エラーコード」をご参照ください。
変更履歴
完全なリストについては、「変更履歴」をご参照ください。