すべてのプロダクト
Search
ドキュメントセンター

ApsaraDB RDS:データベースとテーブルの復元

最終更新日:Jun 10, 2026

ApsaraDB RDS for MySQL は、標準および高速なデータベースとテーブルの復元に対応しています。データセット全体を復元することなく、バックアップセットから、またはポイントインタイムに、特定のデータベースとテーブルを元のインスタンスまたは新しいインスタンスに復元できます。この機能は、誤操作からの回復や履歴データの分析に役立ちます。

復元モードの違い

個別のデータベースとテーブルは、標準復元と高速復元で復元できます。高速復元ではパフォーマンスタイプのサンドボックスインスタンス を使用し、同じデータ量の場合、標準復元より 50%~95% 高速です。個別のデータベースとテーブルの高速復元を使用するには、まず機能を有効にし、次に機能が有効になった後に生成されたバックアップセット を使用してデータを元のインスタンスまたは新しいインスタンスに復元する必要があります。

詳細については、「データ復元ソリューションの概要 (復元速度の比較)」をご参照ください。

image

項目

標準復元

高速復元

復元範囲

インスタンス内の指定したデータベースとテーブルを復元できます。

インスタンス内の指定したデータベースとテーブルを復元できます。

復元先

  • 高性能ローカルディスク を使用するインスタンスの場合、データを元のインスタンスまたは新しいインスタンスに復元できます。

  • クラウドディスク を使用するインスタンスの場合、データは元のインスタンスにのみ復元できます。

  • 高性能ローカルディスク を使用するインスタンスの場合、データは元のインスタンスにのみ復元できます。

  • この機能は、クラウドディスク を使用するインスタンスではサポートされていません。

復元速度

復元速度は比較的遅く、データ量に依存します。

復元速度はデータ量に依存します。このモードは、標準復元より 50%~95% 高速です。

復元方法

バックアップセット からデータを復元するか、ポイントインタイムリカバリ を実行できます。

  • 無料版:最新の完全データバックアップの時点にデータを復元できます。

  • 有料版:バックアップセット からデータを復元するか、任意の時点にポイントインタイムリカバリ を実行できます。

説明
  • ログバックアップ を有効にすると、ログバックアップの保持期間内の任意の時点にデータを復元できます。ログバックアップが有効になっていない場合、既存のデータバックアップ の時点にのみデータを復元できます。

  • 復元可能な時間範囲は、ログバックアップとデータバックアップの 保持期間 や復元機能を有効にしたタイミングなどの要因によって異なります。ログバックアップとデータバックアップの最大保持期間は 730 日です。DescribeLocalAvailableRecoveryTime API を呼び出して、復元に利用可能な時間範囲を照会できます。

前提条件

標準リカバリ

ローカル SSD

  • ApsaraDB for RDS for MySQL インスタンスは、次の要件を満たす必要があります:

    • メジャーバージョン:8.4、8.0、5.7、または 5.6

    • エディション:High-availability Edition または MySQL 5.7 の three-node Enterprise Edition

    • ストレージタイプ:ローカル SSD

    • ストレージエンジン:InnoDB

    • 課金方法:従量課金またはサブスクリプション (サーバーレス インスタンスには適用されません)

    説明

    この情報は、インスタンスの 基本情報 ページで確認できます。

  • インスタンスのテーブル数が 50,000 未満である必要があります。

  • ApsaraDB for RDS バックアップサービスを初めて使用する場合は、Alibaba Cloud アカウントで DBS のサービスリンクロール (AliyunServiceRoleForDBS) を承認する必要があります。

  • インスタンスでデータベース・テーブルの復元機能が有効になっていることを確認してください。

    インスタンスの バックアップリカバリ ページに移動します。バックアップポリシー タブで、データベース/テーブルの復元機能のステータスを確認します。無効の場合は、データベースとテーブルの復元 を有効にしてください。

    重要
    • データベース・テーブルの復元を有効にすると、この機能をサポートするために、バックアップ形式が tar アーカイブから xbstream パッケージに変更されます。

    • 新しいインスタンスでは、データベース・テーブルの復元機能がデフォルトで有効になっており、無効にできません。

    • この機能を有効にする前に作成されたバックアップセットは、データベース・テーブルの復元に使用できません。機能を有効にした後、手動で 完全バックアップ を実行する必要があります。その後、機能を有効にした後に作成されたバックアップセットを使用して、データベースとテーブルを復元できます。

      または、「完全バックアップデータの復元」をご参照ください。

クラウドディスク

  • ApsaraDB for RDS for MySQL インスタンスは、次の要件を満たす必要があります:

    • メジャーバージョン:8.4、8.0、または 5.7

    • エディション:High-availability Edition、Basic Edition、または Cluster Edition

    • ストレージタイプ:SSD クラウドディスク、ESSD クラウドディスク、または ultra disk

    • ストレージエンジン:InnoDB

    • 課金方法:従量課金またはサブスクリプション (サーバーレス インスタンスには適用されません)

    説明

    この情報は、インスタンスの 基本情報 ページで確認できます。

  • ApsaraDB for RDS バックアップサービスを初めて使用する場合は、Alibaba Cloud アカウントで DBS のサービスリンクロール (AliyunServiceRoleForDBS) を承認する必要があります。

  • インスタンスでデータベース・テーブルの復元機能が有効になっていることを確認してください。

    • 個々のデータベースとテーブルの復元機能は、2023年12月1日以降に作成されたRDSインスタンスで自動的に有効になり、無効にすることはできません。

    • 2023年12月1日より前に作成されたRDSインスタンスでは、個々のデータベースとテーブルの復元機能が強制的に無効になります。 この場合、RDSインスタンスの [バックアップと復元] ページの [バックアップ戦略] タブに移動して、この機能を再度有効にできます。 この機能を有効にすると、すべての有効なバックアップセットを使用して、個々のデータベースとテーブルを即座に復元できます。 機能を有効にすると、機能を無効にすることはできません。

      重要

      既存のバックアップセットが無効で復元に使用できない場合は、機能を有効にした後、手動で 完全バックアップ を実行できます。その後、新しいバックアップセットを使用して復元できます。

高速リカバリ

  • ApsaraDB for RDS for MySQL インスタンスは、次の要件を満たす必要があります:

    • メジャーバージョン:8.4、8.0、5.7、または 5.6

    • エディション:High-availability Edition

    • ストレージタイプ:ローカル SSD (クラウドディスクでは高速データベース/テーブル復元はサポートされていません)

    • ストレージエンジン:InnoDB

    • 課金方法:従量課金またはサブスクリプション (サーバーレス インスタンスには適用されません)

    • リージョン:中国 (杭州)、中国 (上海)、中国 (北京)、中国 (張家口)、中国 (フフホト)、または中国 (深圳)

    説明

    この情報は、インスタンスの 基本情報 ページで確認できます。

  • ApsaraDB for RDS バックアップサービスを初めて使用する場合は、Alibaba Cloud アカウントで DBS のサービスリンクロール (AliyunServiceRoleForDBS) を承認する必要があります。

  • 容量ベースのサンドボックスインスタンス機能が無効になっている必要があります。有効になっている場合は、無効にしてください。

    説明

    すでに容量ベースのサンドボックスインスタンスが有効になっている場合に、高速データベース/テーブル復元を有効にすると、サンドボックスインスタンスはパフォーマンスベースのサンドボックスインスタンスにアップグレードされます。これにより、緊急リカバリのコストが増加します。

  • インスタンスで高速データベース/テーブル復元機能が有効になっていることを確認してください。

    インスタンスの バックアップリカバリ ページに移動します。バックアップポリシー タブで、データベースとテーブルの高速復元 機能のステータスを確認します。無効の場合は有効にしてください。詳細については、「1. 高速データベース/テーブル復元を有効にする」をご参照ください。

    重要

    この機能を有効にする前に作成されたバックアップセットは、高速復元に使用できません。機能を有効にした後、手動で 完全バックアップ を実行する必要があります。その後、機能を有効にした後に作成されたバックアップセットを使用して、データベースとテーブルを復元できます。

    または、「完全バックアップデータの復元」をご参照ください。

注意事項

  • デフォルトで有効:

    • 新しいインスタンスでは、高速のデータベースおよびテーブルの復元がデフォルトで有効になっており、無効にできません。

    • 復元タスクは、開始後に 一時停止またはキャンセル できません。

  • ログバックアップの要件:

    特定の時点にデータを復元するには、インスタンスで ログバックアップが有効 になっていることを確認する必要があります。有効でない場合、高速データベースおよびテーブルの復元は失敗します。

  • プライマリ/セカンダリ スイッチオーバーとサービス中断:

    • 高性能ローカルディスクを使用するインスタンスの場合:

      • 元のインスタンスにデータを復元すると、プライマリ/セカンダリ スイッチオーバーがトリガーされ、30 ~ 120 秒のサービス中断が発生する場合があります。アプリケーションに自動再接続メカニズムがあることを確認してください。

      • 新しいインスタンスにデータを復元しても、プライマリ/セカンダリ スイッチオーバーはトリガーされません。

    • クラウドディスクを使用するインスタンスの場合:

      • 元のインスタンスにデータを復元しても、プライマリ/セカンダリ スイッチオーバーはトリガーされません。ただし、この操作は元のインスタンスのパフォーマンスに影響する場合があり、 インスタンススイッチオーバー がトリガーされることもあります。

      • 復元が完了すると、完全バックアップが作成されます。

制限

  • データベースとテーブルの復元 (標準および高速) の制限:

    • InnoDB ストレージエンジンを使用するデータベースとテーブルからのみデータを復元できます。X-Engine ストレージエンジンを使用するテーブルはサポートされていません。

    • この機能では、パーティションテーブル、ビュー、ストアドプロシージャ、またはその他のデータベースオブジェクトを復元できません。これらのオブジェクトを復元するには、代わりに 完全なデータ復元 機能を使用してください。

    • バイナリログにテーブルの名前変更操作が含まれている場合、またはテーブルに生成列が含まれている場合、そのテーブルを復元できません。

    • バイナリログに XA トランザクションが含まれている場合、データベースとテーブルの復元タスクは失敗します。

    • 制約の復元:データベースとテーブルの復元では、プライマリキー、一意キー、およびインデックスは復元されますが、外部キー制約、トリガー、または全文検索インデックスは復元されません。

      重要

      復元プロセスは、成功率を高めるために外部キー制約を自動的に削除します。これらの制約が必要な場合は、復元が完了した後に手動で再作成する必要があります。

  • テーブル数の制限:

    • インスタンスに 50,000 を超えるテーブルが含まれている場合、復元タスクは失敗します。

    • 指定した時間範囲内に大量のデータ、多数のデータベースとテーブル、または多数のバイナリログが含まれる場合、復元プロセスが大幅に長くなることがあります。

  • データベースとテーブルの高速復元の制限:

    • 高性能ローカルディスクを使用するインスタンスでは、データは元のインスタンスにのみ復元でき、新しいインスタンスには復元できません。

    • 読み取り専用ノードがある、TDE (透過的データ暗号化) を使用している、またはログバックアップが有効になっていないインスタンスでは、データベースとテーブルの高速復元を使用できません。

課金

標準テーブルリカバリ

高性能ローカルディスク

標準テーブルリカバリは、高性能ローカルディスクインスタンスでデフォルトで有効になっており、追加料金は発生しません。新しいインスタンスにデータを復元する場合、その新しいインスタンスに対して課金されます。料金詳細は、インスタンス作成時に確認できます。

説明

クラウドディスク

2023 年 12 月 1 日以降、クラウドディスクインスタンスでテーブルレベルリカバリを有効にすると、バックアップアーキテクチャがアップグレードされ、バックアップボリュームが 30% から 80% 増加します。合計バックアップサイズ が無料クォータ内であれば、課金されません。無料クォータを超える使用量については、実際の使用量に基づいて課金されます。

エクスプレステーブルリカバリ

高性能ローカルディスクインスタンスの場合、エクスプレステーブルリカバリは無料版と有料版で利用できます。クラウドディスクインスタンスはサポートされていません。

  • 無料版:このエディションは無料で、バックアップセットから、または最新の完全バックアップの時点へデータを復元できます。

  • 有料版:このエディションは従量課金制で、1 日 1 GB あたり USD 0.008 で課金されます。バックアップセットからデータを復元するか、ポイントインタイムリカバリを実行できます。

1. 高速データベース/テーブル復元の有効化

高速データベース/テーブル復元機能を使用するには、まず有効化する必要があります。 その後、機能が有効になった後に作成されたバックアップセット を使用してデータベース/テーブル復元 を実行できます。 この機能は、前提条件を満たす高性能ローカルディスクを持つインスタンスでのみ利用可能です。 この機能を有効にしても、サービスには影響しません。

説明

標準のデータベースとテーブルの復元のみが必要な場合は、このセクションをスキップして、「2. データベースとテーブルを元のインスタンスまたは新しいインスタンスに復元する」に進んでください。

  1. RDSインスタンスにアクセスし、上部のリージョンを選択し、対象のRDSインスタンスのIDをクリックします。
  2. ナビゲーションペインで、バックアップと復元 をクリックします。

    説明

    「高速データベース/テーブル復元」が有料機能であることを示すダイアログボックスが表示された場合は、次から表示しない を選択し、必要に応じて Free Edition または Paid Edition を有効化できます。 ダイアログボックスが表示されない場合は、次の手順に進んでください。

  3. バックアップと復元 ページで、バックアップポリシー タブをクリックします。

  4. [基本バックアップ] セクションで 編集 をクリックし、データベースとテーブルの高速復元 を [オン] に設定します。

  5. CDM支払いタイプ と CDM保持時間 を設定します。 高速データベース/テーブル復元は、Free Edition と Paid Edition で利用できます:

    • Free Edition:バックアップセットからの復元のみに対応しています。 [CDM 課金方法] を [Last 1 full time point (无料版)] に設定します。 復元されたデータは 1 日間保持されます。

    • Paid Edition:バックアップセットからの復元、または特定の時点への復元 (ログバックアップが有効な場合) に対応しています。 [CDM 課金方法] を [任意のポイント (有料版)] に設定します。 復元されたデータの保持期間は 1 日から 730 日まで設定できます。

  6. OK をクリックします。

手順2:元のインスタンスまたは新しいインスタンスへの復元

重要

データベース/テーブルの復元機能は、元のデータベースのデータを上書きしたり、影響を与えたりしません。元のインスタンスに復元する場合、データは新しいデータベースに保存されます。デフォルトでは、元のデータベース名に _backup サフィックスが追加されます。新しいインスタンスにデータを復元する場合、システムは復元されたデータを保存するために別の RDS インスタンスを作成します。

  1. RDSインスタンスにアクセスし、上部のリージョンを選択し、対象のRDSインスタンスのIDをクリックします。
  2. 左側メニューで バックアップと復元 をクリックし、次に データベースとテーブルの復元 をクリックします。

    説明
    • コンソールに データベースとテーブルの復元 ボタンが表示されない場合は、「前提条件」に記載の要件を満たしていることを確認してください。

    • データベースとテーブルの復元 ボタンをクリックした後にコンソールが応答しない場合は、ブラウザのキャッシュをクリアして再試行してください。

    • ストレージ容量が不足していることを示すメッセージが表示された場合は、復元を開始する前にストレージ容量を拡張してください。

  3. 復元先と復元方法を設定します。

    パラメーター

    説明

    [復元先]

    • [現在のインスタンス]

    • [新しいインスタンス] (ローカル SSD を使用するインスタンスでのみ利用可能):システムは元のインスタンスに影響を与えることなく新しい RDS インスタンスを作成します。

      新しいインスタンスでデータを確認した後、データを元のインスタンスに移行することもできます。

    [復元の速度]

    • [標準]

    • [高速] (元のインスタンスへの復元のみ):高速データベース/テーブル復元機能により、復元速度が 50% から 95% 向上します。詳細については、「ApsaraDB RDS for MySQL の緊急リカバリ」をご参照ください。

    [復元方法]

    • [バックアップセットで]

    • [時刻で] (ログバックアップが有効になっている必要があります):システムは完全バックアップに続いて増分ログバックアップを復元します。ログバックアップの保持期間内であれば、任意の時点を選択できます。ログバックアップの保持期間を表示または変更するには、「自動バックアップ」をご参照ください。

      たとえば、RDS インスタンスのデータバックアップとログバックアップの保持期間が両方とも 7 日間の場合、過去 7 日間のデータを復元できます。7 日間より古いバックアップセットは破棄され、復元には使用できません。

    説明

    高速データベース/テーブル復元の無料版は、ポイントインタイムリカバリをサポートしていません。バックアップセット単位の復元のみをサポートします。

  4. 復元するデータベースとテーブルを選択します。復元後のデータベースまたはテーブルの名前を指定することもできます。次に、OK をクリックします。

    説明
    • 一度に最大 50 のデータベースまたはテーブルを選択できます。

    • 元のインスタンスにデータを復元する場合、元のインスタンスのデータは影響を受けません。復元後のデータベースは既存のデータベースと同じ名前にできませんが、復元後のテーブルは同じ名前にできます。デフォルトでは、システムは復元後のデータベース名に _backup サフィックスを追加します。名前を変更することもできます。

    • 元のインスタンスにデータを復元する場合は、ページの下部で選択したデータベースとテーブルの合計サイズを確認し、インスタンスのストレージ容量に十分な空きがあることを確認してください。

  5. ローカル SSD で実行されているインスタンスから 新しいインスタンス にデータを復元する場合は、課金方法を選択し、新しいインスタンスのパラメーターを設定する必要があります。

    • [サブスクリプション]:新しいインスタンスを作成するときに前払いします。このオプションは、長期的な使用に最適です。

    • [従量課金]:時間単位で課金されます。このオプションは短期的な使用に最適で、不要になったらインスタンスをリリースできます。

    パラメーター

    説明

    [ゾーン]

    アベイラビリティーゾーンは、リージョン内の独立した物理的な場所です。

    ECS インスタンスと同じアベイラビリティーゾーンに RDS インスタンスを作成することも、別のアベイラビリティーゾーンに作成することもできます。

    説明

    新しいインスタンスは、元のインスタンスと同じリージョンにあります。リージョンは変更できません。

    [仕様]

    各インスタンスタイプは、特定の CPU コア数、メモリサイズ、最大接続数、最大 IOPS を提供します。

    [保管スペース]

    ストレージ容量には、データファイル、システムファイル、ログファイル、およびトランザクションファイルの領域が含まれます。

    [ネットワークタイプ]

    VPC (デフォルト)。VPC は、クラシックネットワークよりも高いセキュリティとパフォーマンスを提供する、分離されたネットワーク環境です。

  6. データベース/テーブルの復元または新しいインスタンスの作成の進行状況は、[タスク] ページで確認できます。

    ApsaraDB RDS コンソールで 個々のデータベースとテーブルの復元機能を使用して元の RDS インスタンスにデータを復元すると、RDS インスタンスは [一時インスタンスの作成中] 状態になります。この状態は、復元タスクが進行中であることを示します。この状態でも、RDS インスタンスは正常に実行できます。たとえば、バックアップタスクは正常に実行できます。この状態の期間は、復元するデータ量によって異なります。大量のデータを復元する場合、RDS インスタンスはこの状態が長時間続きます。

    创建临时实例中

    重要
    • 復元タスクが開始されると、タスクを一時停止または中断することはできません。

    • 復元タスクが進行中の場合は、別の復元タスクを開始しないことをお勧めします。別の復元タスクを開始すると、「操作に失敗しました。RDS インスタンスの準備ができていません。」というエラーメッセージが表示されます。復元タスクは、進行中の復元タスクがない場合にのみ実行できます。

    • プライマリ RDS インスタンスに 読み取り専用 RDS インスタンス が接続されていて、プライマリ RDS インスタンスで復元タスクが進行中の場合、復元タスクの完了後に、システムはプライマリ RDS インスタンスからすべての読み取り専用 RDS インスタンスにデータを自動的に同期します。これにより、プライマリ RDS インスタンスとセカンダリ RDS インスタンス間のデータ整合性が確保されます。

  7. RDS for MySQL インスタンスに接続した後、元のインスタンスまたは新しいインスタンスで復元されたデータを表示できます。

    説明
    • インスタンスへの接続に使用するアカウントに、データベースを表示または管理するために必要な権限があることを確認してください。特権アカウントを使用して接続し、データを表示することを推奨します。

    • DMS を使用して RDS for MySQL インスタンスに接続する場合、復元後にインスタンスを右クリックして [更新 / 辞書の同期] を選択し、新しいデータベースがリストに表示されるようにしてください。

    新しいインスタンスに復元した後、必要に応じて DTS を使用してデータを移行して元のインスタンスに戻すことができます。

関連オペレーション

オンラインデータの訂正

ターゲット

訂正方法

元のインスタンス

RENAME TABLE ステートメントを使用して、復元されたテーブルの名前を変更します。

新しいインスタンス

元の RDS インスタンスのデータを新しい RDS インスタンスに復元した後、Data Transmission Service (DTS) を使用して、必要なデータベースとテーブルの一部またはすべてのデータを元の RDS インスタンスに移行し、元の RDS インスタンスのオンラインデータを修正できます。詳細については、「ApsaraDB RDS for MySQL インスタンス間のデータ移行」をご参照ください。

説明

タスクを作成するときは、新しい RDS インスタンスをソースデータベースとして、元の RDS インスタンスをターゲットデータベースとして使用し、ソースデータベースとターゲットデータベースの両方で [アクセス方法] パラメーターを [Alibaba Cloud インスタンス] に設定します。

データベース/テーブルの高速復元の無効化

データベース/テーブルの高速復元を無効化しても、標準のデータベース/テーブル復元には影響しません。

インスタンス詳細ページの バックアップリカバリ に移動し、バックアップポリシー タブで 基本バックアップ の横にある 編集 をクリックして、データベースとテーブルの高速復元 をオフに設定します。

image.png

高速復元エディションの変更

コストを削減するために、データベース/テーブルの高速復元のエディションを無料版に変更できます。無料版に切り替えた後は、バックアップセットからの復元、または最新の完全バックアップの時点への復元のみが可能です。任意の時点へのデータ復元はできなくなります。

インスタンス詳細ページで バックアップリカバリ に移動します。バックアップポリシー タブで、[基本バックアップ] の横にある 編集 をクリックし、CDM支払いタイプ を Last 1 full time point (无料版) に設定します。

image.png

関連 API

API

説明

RestoreTable

指定したデータベースまたはテーブルを元の RDS インスタンスに復元します。

CloneDBInstance

指定したデータベースまたはテーブルを新しい RDS インスタンスに復元します。

DescribeLocalAvailableRecoveryTime

RDS インスタンスの復元可能な時間範囲を照会します。

よくある質問

データベースまたはテーブルを復元する際に、エラーメッセージ Operation failed. This operation is not supported for the current instance state. が表示された場合、どうすればよいですか?

ApsaraDB RDS コンソールのタスクは順次実行されます。前の復元タスクまたは他のタスクが完了するまで待ってから、新しいタスクを開始してください。

復元するデータベースとテーブルを選択できず、エラーメッセージ Meta information is too large. (Error code: InvalidMeta.TooLarge) が表示されるのはなぜですか?

このエラーは、この機能が 50,000 を超えるテーブルの復元をサポートしていないためです。インスタンス全体の復元機能を使用して、データを新しいインスタンスに復元することを推奨します。

説明

データベースまたはテーブルのポイントインタイムリカバリを実行しようとすると、復元時点の読み込みに失敗し、エラーメッセージ Operation failed. The specified restore time is invalid. Please reset the restore time. (Error code: InvalidRestoreTime.Format) が表示されます。どうすればよいですか?

ポイントインタイムリカバリを実行するには、インスタンスのログバックアップが有効になっていることを確認してください。インスタンスの バックアップリカバリ ページに移動します。バックアップポリシー タブで、ログバックアップ のステータスを表示または変更します。詳細については、「自動バックアップ」をご参照ください。

バックアップセットから、または特定の時点にデータベースまたはテーブルを復元する際に、エラーメッセージ Meta information is empty (Error code: InvalidMeta.Empty) が表示されるのはなぜですか?

高性能ローカルディスクを使用するインスタンスの場合、データベースとテーブルの個別復元機能を有効にした後、手動バックアップ を実行する必要があります。その後、復元用に新しいバックアップセットを選択してください。必要に応じて、インスタンス全体の復元 を実行することもできます。

復元されたテーブルが空の場合、どうすればよいですか?

選択した時点でテーブルにデータが含まれていたかどうかを確認してください。その時点にデータが存在しない場合は、別の時点を選択して再度復元してください。

誤って削除したデータを復元するにはどうすればよいですか?

Data Management (DMS) のデータ追跡機能を使用 して、特定の期間内の更新を追跡し、ロールバックスクリプトを生成してから、データ変更 チケットを通じて実行し、データを復元できます。

RAM ユーザーとして ApsaraDB RDS コンソールにログインしたときに、データベースとテーブルの個別復元ボタンが見つからないのはなぜですか?

RAM ユーザーに AliyunDBSFullAccess ポリシーがアタッチされているかどうかを確認してください。権限の付与方法の詳細については、「RAM ユーザー権限の管理」をご参照ください。

データベースとテーブルの個別復元と緊急リカバリのどちらを選択すればよいですか?

  • 特定のデータベースまたはテーブルの誤った削除または更新を復元する場合は、データベースとテーブルの個別復元を使用してください。緊急リカバリ機能は、インスタンス全体のデータを復元する必要がある緊急の状況に最適です。

  • 緊急リカバリ機能は、誤った操作やその他のイベントによって引き起こされたデータ損失またはデータ破損の場合に、サンドボックスインスタンス (RDS インスタンスではありません) に、指定した時点のデータを復元します。これを使用して、履歴データを比較したり、ダーティデータを修正したりできます。また、Data Transmission Service (DTS) を使用して元のインスタンスにデータを移行し、データ損失またはデータ破損から復元することもできます。

説明

データベースとテーブルの個別復元と緊急リカバリの両方を有効にすると、CDM はバックグラウンドでストレージを統合してストレージコストを削減します。データ復元ソリューションの詳細については、「データ復元ソリューションの概要」をご参照ください。

クラウドディスクベースの RDS インスタンスのデータベースとテーブルを復元する他の方法はありますか?

データディザスタリカバリ を使用して、クラウドデータベースまたは ECS インスタンス上のセルフマネージドデータベースをバックアップおよび復元できます。データディザスタリカバリでは、クラウドバックアップセットをローカルマシンに ダウンロード することもできます。

説明

データベースとテーブルを復元する他の方法については、「データベースまたはテーブル単位でのデータ復元」または「mysqldump を使用したデータのバックアップと復元」をご参照ください。

バイナリログ内の特定の時点からの DML 操作を迅速にロールバックするにはどうすればよいですか?

復元されたテーブルはどこで確認できますか?

復元されたテーブルは rx_backup_task_no データベースで見つけることができます。